summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorOliver Poignant <oliver@poignant.se>2016-03-06 23:12:09 +0100
committerOliver Poignant <oliver@poignant.se>2016-03-06 23:12:09 +0100
commit1fcaefe47659877814b2b327f3bd21051e91ef3f (patch)
treeb5ed517016e2fde023414f28adcb5627dbb82441 /setup.py
parent1f3b6f128fecda2aecad8d0fe6d0c0b706d1877e (diff)
downloadGit-Auto-Deploy-1fcaefe47659877814b2b327f3bd21051e91ef3f.zip
Git-Auto-Deploy-1fcaefe47659877814b2b327f3bd21051e91ef3f.tar.gz
Git-Auto-Deploy-1fcaefe47659877814b2b327f3bd21051e91ef3f.tar.bz2
Created setup.py script
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 16 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..ab0e054
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,16 @@
+from setuptools import setup, find_packages
+
+setup(name='git-auto-deploy',
+ version='0.2.0',
+ url='https://github.com/olipo186/Git-Auto-Deploy',
+ author='Oliver Poignant',
+ author_email='oliver@poignant.se',
+ packages = find_packages(),
+ entry_points={
+ 'console_scripts': [
+ 'gad-server = gitautodeploy.__main__:main'
+ ]
+ },
+ description = "Deploy your GitHub, GitLab or Bitbucket projects automatically on Git push events or webhooks.",
+ long_description = "GitAutoDeploy consists of a HTTP server that listens for Web hook requests sent from GitHub, GitLab or Bitbucket servers. This application allows you to continuously and automatically deploy you projects each time you push new commits to your repository."
+)