MSBuild.Community.Tasks Namespace

[image]

.NET Framework Class Library
MSBuild.Community.Tasks Namespace
Send Feedback

Classes

Class | Description
AssemblyInfo | Generates an AssemblyInfo files
Attrib | Changes the attributes of files and/or directories
Beep | A task to play the sound of a beep through the console speaker.
Computer | Provides information about the build computer.
DeleteTree | Delete a directory tree. This task supports wild card directory selection.
FileUpdate | Replace text in file(s) using a Regular Expression.
FtpUpload | Uploads a group of files using File Transfer Protocol (FTP).
FxCop | Uses FxCop to analyse managed code assemblies and reports on their design best-practice compliance.
GacUtil | MSBuild task to install and uninstall assemblies into the GAC
GetSolutionProjects | Retrieves the list of Projects contained within a Visual Studio Solution (.sln) file
ILMerge | A wrapper for the ILMerge tool.
InnoSetup | MSBuild task to create installer with InnoSetup
Mail | Sends an email message
Merge | Merge files into the destination file.
Move | Moves files on the filesystem to a new location.
NDoc | Runs the NDoc application.
NUnit | Run NUnit 2.4 on a group of assemblies.
Prompt | Displays a message on the console and waits for user input.
RegexBase | Base class for Regex tasks Handles public properties for Input, Expression, Options and Output
RegexCompiler | Compiles regular expressions and saves them to disk in an assembly.
RegexMatch | Task to filter an Input list with a Regex expression. Output list contains items from Input list that matched given expression
RegexReplace | Task to replace portions of strings within the Input list Output list contains all the elements of the Input list after performing the Regex Replace.
RegistryRead | Reads a value from the Registry
RegistryWrite | Writes a value to the Registry
RoboCopy | Task wrapping the Window Resource Kit Robocopy.exe command.
Script | Executes code contained within the task.
ServiceController | Task that can control a Windows service.
ServiceQuery | Task that can determine the status of a specified service on a target server.
Sleep | A task for sleeping for a specified period of time.
Sound | A task to play a sound from a .wav file path or URL.
SqlExecute | Executes a SQL command.
TemplateFile | MSBuild task that replaces tokens in a template file and writes out a new file.
Time | Gets the current date and time.
Unzip | Unzip a file to a target directory.
User | Provides information about the build user.
Version | Generates version information based on various algorithms
WebDownload | Downloads a resource with the specified URI to a local file.
XmlRead | Reads a value from a XML document using a XPath.
XmlUpdate | Updates a XML document using a XPath.
Xslt | A task to merge and transform a set of xml files.
Zip | Create a zip file with the files specified.

Interfaces

Interface | Description
IFtpWebRequest | This class references an interface that looks like FtpWebRequest in order to support unit testing without an actual FTP Server.
IFtpWebRequestCreator | Describes a factory for IFtpWebRequest.

Enumerations

Enumeration | Description
GacUtilCommands | The list of the commands available to the GacUtil Task
MergeModes | Defines the modes for merging files.
ServiceActions | Defines the actions that can be performed on a service.
Send feedback on this topic to Microsoft.


AssemblyInfo Class

[image]

.NET Framework Class Library
AssemblyInfo Class
Members Example See Also Send Feedback

Generates an AssemblyInfo files

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class AssemblyInfo _
    Inherits Task
C#
public class AssemblyInfo : Task
Visual C++
public ref class AssemblyInfo : public Task

Examples

Generates a common version file.

Copy Code
            <AssemblyInfo CodeLanguage="CS"
                OutputFile="VersionInfo.cs"
                AssemblyVersion="1.0.0.0"
                AssemblyFileVersion="1.0.0.0" />

Generates a complete version file.

Copy Code
            <AssemblyInfo CodeLanguage="CS"
                OutputFile="$(MSBuildProjectDirectory)\Test\GlobalInfo.cs"
                AssemblyTitle="AssemblyInfoTask"
                AssemblyDescription="AssemblyInfo Description"
                AssemblyConfiguration=""
                AssemblyCompany="Company Name, LLC"
                AssemblyProduct="AssemblyInfoTask"
                AssemblyCopyright="Copyright (c) Company Name, LLC 2006"
                AssemblyTrademark=""
                ComVisible="false"
                CLSCompliant="true"
                Guid="d038566a-1937-478a-b5c5-b79c4afb253d"
                AssemblyVersion="1.0.0.0"
                AssemblyFileVersion="1.0.0.0" />

Generates a complete version file for C++/CLI.

Copy Code
            <AssemblyInfo CodeLanguage="CPP"
                OutputFile="$(MSBuildProjectDirectory)\Properties\AssemblyInfo.cpp"
                AssemblyTitle="MyAssembly"
                AssemblyDescription="MyAssembly Description"
                AssemblyConfiguration="$(Configuration)"
                AssemblyCompany="Company Name, LLC"
                AssemblyProduct="MyAssembly"
                AssemblyCopyright="Copyright (c) Company Name, LLC 2008"
                AssemblyTrademark=""
                ComVisible="false"
                CLSCompliant="true"
                Guid="d038566a-1937-478a-b5c5-b79c4afb253d"
                AssemblyVersion="1.0.0.0"
                AssemblyFileVersion="1.0.0.0"
                UnmanagedCode="true" />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks..::.AssemblyInfo

See Also

AssemblyInfo Members
MSBuild.Community.Tasks Namespace


AssemblyInfo Members

[image] [image]

.NET Framework Class Library
AssemblyInfo Members
AssemblyInfo Class Constructors Methods Fields Properties See Also Send Feedback

The AssemblyInfo type exposes the following members.

Constructors

Name | Description
AssemblyInfo | Initializes a new instance of the AssemblyInfo class.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Fields

Name | Description
DEFAULT_OUTPUT_FILE | The default value of OutputFile. The value is "AssemblyInfo.cs".

Properties

Name | Description
AssemblyCompany | Gets or sets the assembly company.
AssemblyConfiguration | Gets or sets the assembly configuration.
AssemblyCopyright | Gets or sets the assembly copyright.
AssemblyCulture | Gets or sets the assembly culture.
AssemblyDelaySign | Gets or sets the assembly delay sign value.
AssemblyDescription | Gets or sets the assembly description.
AssemblyFileVersion | Gets or sets the assembly file version.
AssemblyInformationalVersion | Gets or sets the assembly informational version.
AssemblyKeyFile | Gets or sets the assembly key file.
AssemblyKeyName | Gets or sets the assembly key name.
AssemblyProduct | Gets or sets the assembly product.
AssemblyTitle | Gets or sets the assembly title.
AssemblyTrademark | Gets or sets the assembly trademark.
AssemblyVersion | Gets or sets the assembly version.
BuildEngine | (Inherited from Task.)
CLSCompliant | Gets or sets a value indicating whether [CLSCompliant].
CodeLanguage | Gets or sets the code language.
ComVisible | Gets or sets a value indicating whether [COMVisible].
GenerateClass | Gets or sets a value indicating whether to generate the ThisAssmebly class.
Guid | Gets or sets the GUID.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
InternalsVisibleTo | Makes it possible to make certain assemblies able to use constructs marked as internal. Example might be setting this value to "UnitTests" assembly. The typical use case might be constructors in classes which shouldn't be available to other assemblies, but the unit tests should be able to use them.
Log | (Inherited from Task.)
NeutralResourcesLanguage | Gets or sets the neutral language which is used as a fallback language configuration if the locale on the computer isn't supported. Example is setting this to "en-US".
OutputFile | Gets or sets the output file.
SkipVerification | Gets or sets the assembly delay sign value.
TaskResources | (Inherited from Task.)
UnmanagedCode | Gets or sets the assembly delay sign value.

See Also

AssemblyInfo Class
MSBuild.Community.Tasks Namespace


AssemblyInfo Constructor

[image]

.NET Framework Class Library
AssemblyInfo Constructor
AssemblyInfo Class See Also Send Feedback

Initializes a new instance of the AssemblyInfo class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public AssemblyInfo()
Visual C++
public:
AssemblyInfo()

See Also

AssemblyInfo Class
MSBuild.Community.Tasks Namespace


AssemblyInfo Fields

[image] [image]

.NET Framework Class Library
AssemblyInfo Fields
AssemblyInfo Class See Also Send Feedback

The AssemblyInfo type exposes the following members.

Fields

Name | Description
DEFAULT_OUTPUT_FILE | The default value of OutputFile. The value is "AssemblyInfo.cs".

See Also

AssemblyInfo Class
MSBuild.Community.Tasks Namespace


DEFAULT_OUTPUT_FILE Field

[image]

.NET Framework Class Library
AssemblyInfo..::.DEFAULT_OUTPUT_FILE Field
AssemblyInfo Class See Also Send Feedback

The default value of OutputFile. The value is "AssemblyInfo.cs".

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Const DEFAULT_OUTPUT_FILE As String
C#
public const string DEFAULT_OUTPUT_FILE
Visual C++
public:
literal String^ DEFAULT_OUTPUT_FILE

See Also

AssemblyInfo Class
MSBuild.Community.Tasks Namespace


AssemblyInfo Methods

[image] [image]

.NET Framework Class Library
AssemblyInfo Methods
AssemblyInfo Class See Also Send Feedback

The AssemblyInfo type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

AssemblyInfo Class
MSBuild.Community.Tasks Namespace


Execute Method

[image]

.NET Framework Class Library
AssemblyInfo..::.Execute Method
AssemblyInfo Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

AssemblyInfo Class
MSBuild.Community.Tasks Namespace


AssemblyInfo Properties

[image] [image]

.NET Framework Class Library
AssemblyInfo Properties
AssemblyInfo Class See Also Send Feedback

The AssemblyInfo type exposes the following members.

Properties

Name | Description
AssemblyCompany | Gets or sets the assembly company.
AssemblyConfiguration | Gets or sets the assembly configuration.
AssemblyCopyright | Gets or sets the assembly copyright.
AssemblyCulture | Gets or sets the assembly culture.
AssemblyDelaySign | Gets or sets the assembly delay sign value.
AssemblyDescription | Gets or sets the assembly description.
AssemblyFileVersion | Gets or sets the assembly file version.
AssemblyInformationalVersion | Gets or sets the assembly informational version.
AssemblyKeyFile | Gets or sets the assembly key file.
AssemblyKeyName | Gets or sets the assembly key name.
AssemblyProduct | Gets or sets the assembly product.
AssemblyTitle | Gets or sets the assembly title.
AssemblyTrademark | Gets or sets the assembly trademark.
AssemblyVersion | Gets or sets the assembly version.
BuildEngine | (Inherited from Task.)
CLSCompliant | Gets or sets a value indicating whether [CLSCompliant].
CodeLanguage | Gets or sets the code language.
ComVisible | Gets or sets a value indicating whether [COMVisible].
GenerateClass | Gets or sets a value indicating whether to generate the ThisAssmebly class.
Guid | Gets or sets the GUID.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
InternalsVisibleTo | Makes it possible to make certain assemblies able to use constructs marked as internal. Example might be setting this value to "UnitTests" assembly. The typical use case might be constructors in classes which shouldn't be available to other assemblies, but the unit tests should be able to use them.
Log | (Inherited from Task.)
NeutralResourcesLanguage | Gets or sets the neutral language which is used as a fallback language configuration if the locale on the computer isn't supported. Example is setting this to "en-US".
OutputFile | Gets or sets the output file.
SkipVerification | Gets or sets the assembly delay sign value.
TaskResources | (Inherited from Task.)
UnmanagedCode | Gets or sets the assembly delay sign value.

See Also

AssemblyInfo Class
MSBuild.Community.Tasks Namespace


AssemblyCompany Property

[image]

.NET Framework Class Library
AssemblyInfo..::.AssemblyCompany Property
AssemblyInfo Class See Also Send Feedback

Gets or sets the assembly company.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyCompany As String
C#
public string AssemblyCompany { get; set; }
Visual C++
public:
property String^ AssemblyCompany {
    String^ get ();
    void set (String^ value);
}

Field Value

The assembly company.

See Also

AssemblyInfo Class
MSBuild.Community.Tasks Namespace


AssemblyConfiguration Property

[image]

.NET Framework Class Library
AssemblyInfo..::.AssemblyConfiguration Property
AssemblyInfo Class See Also Send Feedback

Gets or sets the assembly configuration.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyConfiguration As String
C#
public string AssemblyConfiguration { get; set; }
Visual C++
public:
property String^ AssemblyConfiguration {
    String^ get ();
    void set (String^ value);
}

Field Value

The assembly configuration.

See Also

AssemblyInfo Class
MSBuild.Community.Tasks Namespace


AssemblyCopyright Property

[image]

.NET Framework Class Library
AssemblyInfo..::.AssemblyCopyright Property
AssemblyInfo Class See Also Send Feedback

Gets or sets the assembly copyright.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyCopyright As String
C#
public string AssemblyCopyright { get; set; }
Visual C++
public:
property String^ AssemblyCopyright {
    String^ get ();
    void set (String^ value);
}

Field Value

The assembly copyright.

See Also

AssemblyInfo Class
MSBuild.Community.Tasks Namespace


AssemblyCulture Property

[image]

.NET Framework Class Library
AssemblyInfo..::.AssemblyCulture Property
AssemblyInfo Class See Also Send Feedback

Gets or sets the assembly culture.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyCulture As String
C#
public string AssemblyCulture { get; set; }
Visual C++
public:
property String^ AssemblyCulture {
    String^ get ();
    void set (String^ value);
}

Field Value

The assembly culture.

See Also

AssemblyInfo Class
MSBuild.Community.Tasks Namespace


AssemblyDelaySign Property

[image]

.NET Framework Class Library
AssemblyInfo..::.AssemblyDelaySign Property
AssemblyInfo Class See Also Send Feedback

Gets or sets the assembly delay sign value.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyDelaySign As Boolean
C#
public bool AssemblyDelaySign { get; set; }
Visual C++
public:
property bool AssemblyDelaySign {
    bool get ();
    void set (bool value);
}

See Also

AssemblyInfo Class
MSBuild.Community.Tasks Namespace


AssemblyDescription Property

[image]

.NET Framework Class Library
AssemblyInfo..::.AssemblyDescription Property
AssemblyInfo Class See Also Send Feedback

Gets or sets the assembly description.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyDescription As String
C#
public string AssemblyDescription { get; set; }
Visual C++
public:
property String^ AssemblyDescription {
    String^ get ();
    void set (String^ value);
}

Field Value

The assembly description.

See Also

AssemblyInfo Class
MSBuild.Community.Tasks Namespace


AssemblyFileVersion Property

[image]

.NET Framework Class Library
AssemblyInfo..::.AssemblyFileVersion Property
AssemblyInfo Class See Also Send Feedback

Gets or sets the assembly file version.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyFileVersion As String
C#
public string AssemblyFileVersion { get; set; }
Visual C++
public:
property String^ AssemblyFileVersion {
    String^ get ();
    void set (String^ value);
}

Field Value

The assembly file version.

See Also

AssemblyInfo Class
MSBuild.Community.Tasks Namespace


AssemblyInformationalVersion Property

[image]

.NET Framework Class Library
AssemblyInfo..::.AssemblyInformationalVersion Property
AssemblyInfo Class See Also Send Feedback

Gets or sets the assembly informational version.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyInformationalVersion As String
C#
public string AssemblyInformationalVersion { get; set; }
Visual C++
public:
property String^ AssemblyInformationalVersion {
    String^ get ();
    void set (String^ value);
}

Field Value

The assembly informational version.

See Also

AssemblyInfo Class
MSBuild.Community.Tasks Namespace


AssemblyKeyFile Property

[image]

.NET Framework Class Library
AssemblyInfo..::.AssemblyKeyFile Property
AssemblyInfo Class See Also Send Feedback

Gets or sets the assembly key file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyKeyFile As String
C#
public string AssemblyKeyFile { get; set; }
Visual C++
public:
property String^ AssemblyKeyFile {
    String^ get ();
    void set (String^ value);
}

See Also

AssemblyInfo Class
MSBuild.Community.Tasks Namespace


AssemblyKeyName Property

[image]

.NET Framework Class Library
AssemblyInfo..::.AssemblyKeyName Property
AssemblyInfo Class See Also Send Feedback

Gets or sets the assembly key name.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyKeyName As String
C#
public string AssemblyKeyName { get; set; }
Visual C++
public:
property String^ AssemblyKeyName {
    String^ get ();
    void set (String^ value);
}

See Also

AssemblyInfo Class
MSBuild.Community.Tasks Namespace


AssemblyProduct Property

[image]

.NET Framework Class Library
AssemblyInfo..::.AssemblyProduct Property
AssemblyInfo Class See Also Send Feedback

Gets or sets the assembly product.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyProduct As String
C#
public string AssemblyProduct { get; set; }
Visual C++
public:
property String^ AssemblyProduct {
    String^ get ();
    void set (String^ value);
}

Field Value

The assembly product.

See Also

AssemblyInfo Class
MSBuild.Community.Tasks Namespace


AssemblyTitle Property

[image]

.NET Framework Class Library
AssemblyInfo..::.AssemblyTitle Property
AssemblyInfo Class See Also Send Feedback

Gets or sets the assembly title.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyTitle As String
C#
public string AssemblyTitle { get; set; }
Visual C++
public:
property String^ AssemblyTitle {
    String^ get ();
    void set (String^ value);
}

Field Value

The assembly title.

See Also

AssemblyInfo Class
MSBuild.Community.Tasks Namespace


AssemblyTrademark Property

[image]

.NET Framework Class Library
AssemblyInfo..::.AssemblyTrademark Property
AssemblyInfo Class See Also Send Feedback

Gets or sets the assembly trademark.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyTrademark As String
C#
public string AssemblyTrademark { get; set; }
Visual C++
public:
property String^ AssemblyTrademark {
    String^ get ();
    void set (String^ value);
}

Field Value

The assembly trademark.

See Also

AssemblyInfo Class
MSBuild.Community.Tasks Namespace


AssemblyVersion Property

[image]

.NET Framework Class Library
AssemblyInfo..::.AssemblyVersion Property
AssemblyInfo Class See Also Send Feedback

Gets or sets the assembly version.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyVersion As String
C#
public string AssemblyVersion { get; set; }
Visual C++
public:
property String^ AssemblyVersion {
    String^ get ();
    void set (String^ value);
}

Field Value

The assembly version.

See Also

AssemblyInfo Class
MSBuild.Community.Tasks Namespace


CLSCompliant Property

[image]

.NET Framework Class Library
AssemblyInfo..::.CLSCompliant Property
AssemblyInfo Class See Also Send Feedback

Gets or sets a value indicating whether [CLSCompliant].

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property CLSCompliant As Boolean
C#
public bool CLSCompliant { get; set; }
Visual C++
public:
property bool CLSCompliant {
    bool get ();
    void set (bool value);
}

Field Value

true if [CLSCompliant]; otherwise, false.

See Also

AssemblyInfo Class
MSBuild.Community.Tasks Namespace


CodeLanguage Property

[image]

.NET Framework Class Library
AssemblyInfo..::.CodeLanguage Property
AssemblyInfo Class See Also Send Feedback

Gets or sets the code language.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property CodeLanguage As String
C#
[RequiredAttribute]
public string CodeLanguage { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ CodeLanguage {
    String^ get ();
    void set (String^ value);
}

Field Value

The code language.

See Also

AssemblyInfo Class
MSBuild.Community.Tasks Namespace


ComVisible Property

[image]

.NET Framework Class Library
AssemblyInfo..::.ComVisible Property
AssemblyInfo Class See Also Send Feedback

Gets or sets a value indicating whether [COMVisible].

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ComVisible As Boolean
C#
public bool ComVisible { get; set; }
Visual C++
public:
property bool ComVisible {
    bool get ();
    void set (bool value);
}

Field Value

true if [COMVisible]; otherwise, false.

See Also

AssemblyInfo Class
MSBuild.Community.Tasks Namespace


GenerateClass Property

[image]

.NET Framework Class Library
AssemblyInfo..::.GenerateClass Property
AssemblyInfo Class See Also Send Feedback

Gets or sets a value indicating whether to generate the ThisAssmebly class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property GenerateClass As Boolean
C#
public bool GenerateClass { get; set; }
Visual C++
public:
property bool GenerateClass {
    bool get ();
    void set (bool value);
}

See Also

AssemblyInfo Class
MSBuild.Community.Tasks Namespace


Guid Property

[image]

.NET Framework Class Library
AssemblyInfo..::.Guid Property
AssemblyInfo Class See Also Send Feedback

Gets or sets the GUID.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Guid As String
C#
public string Guid { get; set; }
Visual C++
public:
property String^ Guid {
    String^ get ();
    void set (String^ value);
}

Field Value

The GUID.

See Also

AssemblyInfo Class
MSBuild.Community.Tasks Namespace


InternalsVisibleTo Property

[image]

.NET Framework Class Library
AssemblyInfo..::.InternalsVisibleTo Property
AssemblyInfo Class See Also Send Feedback

Makes it possible to make certain assemblies able to use constructs marked as internal. Example might be setting this value to "UnitTests" assembly. The typical use case might be constructors in classes which shouldn't be available to other assemblies, but the unit tests should be able to use them.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property InternalsVisibleTo As String
C#
public string InternalsVisibleTo { get; set; }
Visual C++
public:
property String^ InternalsVisibleTo {
    String^ get ();
    void set (String^ value);
}

See Also

AssemblyInfo Class
MSBuild.Community.Tasks Namespace


NeutralResourcesLanguage Property

[image]

.NET Framework Class Library
AssemblyInfo..::.NeutralResourcesLanguage Property
AssemblyInfo Class See Also Send Feedback

Gets or sets the neutral language which is used as a fallback language configuration if the locale on the computer isn't supported. Example is setting this to "en-US".

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property NeutralResourcesLanguage As String
C#
public string NeutralResourcesLanguage { get; set; }
Visual C++
public:
property String^ NeutralResourcesLanguage {
    String^ get ();
    void set (String^ value);
}

See Also

AssemblyInfo Class
MSBuild.Community.Tasks Namespace


OutputFile Property

[image]

.NET Framework Class Library
AssemblyInfo..::.OutputFile Property
AssemblyInfo Class See Also Send Feedback

Gets or sets the output file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public Property OutputFile As String
C#
[OutputAttribute]
public string OutputFile { get; set; }
Visual C++
[OutputAttribute]
public:
property String^ OutputFile {
    String^ get ();
    void set (String^ value);
}

Field Value

The output file.

See Also

AssemblyInfo Class
MSBuild.Community.Tasks Namespace


SkipVerification Property

[image]

.NET Framework Class Library
AssemblyInfo..::.SkipVerification Property
AssemblyInfo Class See Also Send Feedback

Gets or sets the assembly delay sign value.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property SkipVerification As Boolean
C#
public bool SkipVerification { get; set; }
Visual C++
public:
property bool SkipVerification {
    bool get ();
    void set (bool value);
}

See Also

AssemblyInfo Class
MSBuild.Community.Tasks Namespace


UnmanagedCode Property

[image]

.NET Framework Class Library
AssemblyInfo..::.UnmanagedCode Property
AssemblyInfo Class See Also Send Feedback

Gets or sets the assembly delay sign value.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property UnmanagedCode As Boolean
C#
public bool UnmanagedCode { get; set; }
Visual C++
public:
property bool UnmanagedCode {
    bool get ();
    void set (bool value);
}

See Also

AssemblyInfo Class
MSBuild.Community.Tasks Namespace


Attrib Class

[image]

.NET Framework Class Library
Attrib Class
Members Example See Also Send Feedback

Changes the attributes of files and/or directories

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Attrib _
    Inherits Task
C#
public class Attrib : Task
Visual C++
public ref class Attrib : public Task

Examples

Make file Readonly, Hidden and System.

Copy Code
            <Attrib Files="Test\version.txt"
                ReadOnly="true" Hidden="true" System="true"/>

Clear Hidden and System attributes.

Copy Code
            <Attrib Files="Test\version.txt"
                Hidden="false" System="false"/>

Make file Normal.

Copy Code
            <Attrib Files="Test\version.txt"
                Normal="true"/>

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks..::.Attrib

See Also

Attrib Members
MSBuild.Community.Tasks Namespace


Attrib Members

[image] [image]

.NET Framework Class Library
Attrib Members
Attrib Class Constructors Methods Properties See Also Send Feedback

The Attrib type exposes the following members.

Constructors

Name | Description
Attrib |

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | Executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
Archive | Gets or sets file's archive status.
BuildEngine | (Inherited from Task.)
Compressed | Gets or sets a value indicating file is compressed.
Directories | Gets or sets the list of directories to change attributes on.
Encrypted | Gets or sets a value indicating file is encrypted.
Files | Gets or sets the list of files to change attributes on.
HelpKeywordPrefix | (Inherited from Task.)
Hidden | Gets or sets a value indicating file is hidden, and thus is not included in an ordinary directory listing.
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
Normal | Gets or sets a value indicating file is normal and has no other attributes set.
ReadOnly | Gets or sets a value indicating file is read-only.
System | Gets or sets a value indicating file is a system file.
TaskResources | (Inherited from Task.)

See Also

Attrib Class
MSBuild.Community.Tasks Namespace


Attrib Constructor

[image]

.NET Framework Class Library
Attrib Constructor
Attrib Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Attrib()
Visual C++
public:
Attrib()

See Also

Attrib Class
MSBuild.Community.Tasks Namespace


Attrib Methods

[image] [image]

.NET Framework Class Library
Attrib Methods
Attrib Class See Also Send Feedback

The Attrib type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | Executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

Attrib Class
MSBuild.Community.Tasks Namespace


Execute Method

[image]

.NET Framework Class Library
Attrib..::.Execute Method
Attrib Class See Also Send Feedback

Executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

trueTruetruetrue (True in Visual Basic) if the task ran successfully; otherwise falseFalsefalsefalse (False in Visual Basic).

Implements

ITask..::.Execute()()()

See Also

Attrib Class
MSBuild.Community.Tasks Namespace


Attrib Properties

[image] [image]

.NET Framework Class Library
Attrib Properties
Attrib Class See Also Send Feedback

The Attrib type exposes the following members.

Properties

Name | Description
Archive | Gets or sets file's archive status.
BuildEngine | (Inherited from Task.)
Compressed | Gets or sets a value indicating file is compressed.
Directories | Gets or sets the list of directories to change attributes on.
Encrypted | Gets or sets a value indicating file is encrypted.
Files | Gets or sets the list of files to change attributes on.
HelpKeywordPrefix | (Inherited from Task.)
Hidden | Gets or sets a value indicating file is hidden, and thus is not included in an ordinary directory listing.
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
Normal | Gets or sets a value indicating file is normal and has no other attributes set.
ReadOnly | Gets or sets a value indicating file is read-only.
System | Gets or sets a value indicating file is a system file.
TaskResources | (Inherited from Task.)

See Also

Attrib Class
MSBuild.Community.Tasks Namespace


Archive Property

[image]

.NET Framework Class Library
Attrib..::.Archive Property
Attrib Class See Also Send Feedback

Gets or sets file's archive status.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Archive As Boolean
C#
public bool Archive { get; set; }
Visual C++
public:
property bool Archive {
    bool get ();
    void set (bool value);
}

Field Value

true if archive; otherwise, false.

See Also

Attrib Class
MSBuild.Community.Tasks Namespace


Compressed Property

[image]

.NET Framework Class Library
Attrib..::.Compressed Property
Attrib Class See Also Send Feedback

Gets or sets a value indicating file is compressed.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Compressed As Boolean
C#
public bool Compressed { get; set; }
Visual C++
public:
property bool Compressed {
    bool get ();
    void set (bool value);
}

Field Value

true if compressed; otherwise, false.

See Also

Attrib Class
MSBuild.Community.Tasks Namespace


Directories Property

[image]

.NET Framework Class Library
Attrib..::.Directories Property
Attrib Class See Also Send Feedback

Gets or sets the list of directories to change attributes on.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Directories As ITaskItem()
C#
public ITaskItem[] Directories { get; set; }
Visual C++
public:
property array<ITaskItem^>^ Directories {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

Field Value

The directories to change attributes on.

See Also

Attrib Class
MSBuild.Community.Tasks Namespace


Encrypted Property

[image]

.NET Framework Class Library
Attrib..::.Encrypted Property
Attrib Class See Also Send Feedback

Gets or sets a value indicating file is encrypted.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Encrypted As Boolean
C#
public bool Encrypted { get; set; }
Visual C++
public:
property bool Encrypted {
    bool get ();
    void set (bool value);
}

Field Value

true if encrypted; otherwise, false.

See Also

Attrib Class
MSBuild.Community.Tasks Namespace


Files Property

[image]

.NET Framework Class Library
Attrib..::.Files Property
Attrib Class See Also Send Feedback

Gets or sets the list of files to change attributes on.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Files As ITaskItem()
C#
public ITaskItem[] Files { get; set; }
Visual C++
public:
property array<ITaskItem^>^ Files {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

Field Value

The files to change attributes on.

See Also

Attrib Class
MSBuild.Community.Tasks Namespace


Hidden Property

[image]

.NET Framework Class Library
Attrib..::.Hidden Property
Attrib Class See Also Send Feedback

Gets or sets a value indicating file is hidden, and thus is not included in an ordinary directory listing.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Hidden As Boolean
C#
public bool Hidden { get; set; }
Visual C++
public:
property bool Hidden {
    bool get ();
    void set (bool value);
}

Field Value

true if hidden; otherwise, false.

See Also

Attrib Class
MSBuild.Community.Tasks Namespace


Normal Property

[image]

.NET Framework Class Library
Attrib..::.Normal Property
Attrib Class See Also Send Feedback

Gets or sets a value indicating file is normal and has no other attributes set.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Normal As Boolean
C#
public bool Normal { get; set; }
Visual C++
public:
property bool Normal {
    bool get ();
    void set (bool value);
}

Field Value

true if normal; otherwise, false.

See Also

Attrib Class
MSBuild.Community.Tasks Namespace


ReadOnly Property

[image]

.NET Framework Class Library
Attrib..::.ReadOnly Property
Attrib Class See Also Send Feedback

Gets or sets a value indicating file is read-only.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ReadOnly As Boolean
C#
public bool ReadOnly { get; set; }
Visual C++
public:
property bool ReadOnly {
    bool get ();
    void set (bool value);
}

Field Value

true if read-only; otherwise, false.

See Also

Attrib Class
MSBuild.Community.Tasks Namespace


System Property

[image]

.NET Framework Class Library
Attrib..::.System Property
Attrib Class See Also Send Feedback

Gets or sets a value indicating file is a system file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property System As Boolean
C#
public bool System { get; set; }
Visual C++
public:
property bool System {
    bool get ();
    void set (bool value);
}

Field Value

true if system; otherwise, false.

See Also

Attrib Class
MSBuild.Community.Tasks Namespace


Beep Class

[image]

.NET Framework Class Library
Beep Class
Members Example See Also Send Feedback

A task to play the sound of a beep through the console speaker.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Beep _
    Inherits Task
C#
public class Beep : Task
Visual C++
public ref class Beep : public Task

Remarks

By default, the beep plays at a frequency of 800 hertz for a duration of 200 milliseconds.

Examples

To play the sound of a beep at a frequency of 800 hertz and for a duration of 200 milliseconds, use
Copy Code
        <Beep />

Examples

To play the sound of a beep at a frequency of 440 hertz and for a duration of 300 milliseconds, use
Copy Code
        <Beep Frequency="440" Duration="300" />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks..::.Beep

See Also

Beep Members
MSBuild.Community.Tasks Namespace


Beep Members

[image] [image]

.NET Framework Class Library
Beep Members
Beep Class Constructors Methods Properties See Also Send Feedback

The Beep type exposes the following members.

Constructors

Name | Description
Beep |

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | Plays the sound of a beep at the given Frequency and for the given Duration through the console speaker. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Duration | Gets or sets the of the beep measured in milliseconds. Defaults to 200 milliseconds.
Frequency | Gets or sets the frequency of the beep, ranging from 37 to 32767 hertz. Defaults to 800 hertz.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
TaskResources | (Inherited from Task.)

See Also

Beep Class
MSBuild.Community.Tasks Namespace


Beep Constructor

[image]

.NET Framework Class Library
Beep Constructor
Beep Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Beep()
Visual C++
public:
Beep()

See Also

Beep Class
MSBuild.Community.Tasks Namespace


Beep Methods

[image] [image]

.NET Framework Class Library
Beep Methods
Beep Class See Also Send Feedback

The Beep type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | Plays the sound of a beep at the given Frequency and for the given Duration through the console speaker. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

Beep Class
MSBuild.Community.Tasks Namespace


Execute Method

[image]

.NET Framework Class Library
Beep..::.Execute Method
Beep Class See Also Send Feedback

Plays the sound of a beep at the given Frequency and for the given Duration through the console speaker.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

Always returns trueTruetruetrue (True in Visual Basic), even when the sound could not be played.

Implements

ITask..::.Execute()()()

See Also

Beep Class
MSBuild.Community.Tasks Namespace


Beep Properties

[image] [image]

.NET Framework Class Library
Beep Properties
Beep Class See Also Send Feedback

The Beep type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Duration | Gets or sets the of the beep measured in milliseconds. Defaults to 200 milliseconds.
Frequency | Gets or sets the frequency of the beep, ranging from 37 to 32767 hertz. Defaults to 800 hertz.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
TaskResources | (Inherited from Task.)

See Also

Beep Class
MSBuild.Community.Tasks Namespace


Duration Property

[image]

.NET Framework Class Library
Beep..::.Duration Property
Beep Class See Also Send Feedback

Gets or sets the of the beep measured in milliseconds. Defaults to 200 milliseconds.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Duration As Integer
C#
public int Duration { get; set; }
Visual C++
public:
property int Duration {
    int get ();
    void set (int value);
}

See Also

Beep Class
MSBuild.Community.Tasks Namespace


Frequency Property

[image]

.NET Framework Class Library
Beep..::.Frequency Property
Beep Class See Also Send Feedback

Gets or sets the frequency of the beep, ranging from 37 to 32767 hertz. Defaults to 800 hertz.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Frequency As Integer
C#
public int Frequency { get; set; }
Visual C++
public:
property int Frequency {
    int get ();
    void set (int value);
}

See Also

Beep Class
MSBuild.Community.Tasks Namespace


Computer Class

[image]

.NET Framework Class Library
Computer Class
Members Example See Also Send Feedback

Provides information about the build computer.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Computer _
    Inherits Task
C#
public class Computer : Task
Visual C++
public ref class Computer : public Task

Examples

Get build computer information.
Copy Code
            <Computer>
              <Output TaskParameter="Name" PropertyName="BuildMachineName" />
              <Output TaskParameter="IPAddress" PropertyName="BuildMachineIPAddress" />
              <Output TaskParameter="OSPlatform" PropertyName="BuildMachineOSPlatform" />
              <Output TaskParameter="OSVersion" PropertyName="BuildMachineOSVersion" />
            </Computer>

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks..::.Computer

See Also

Computer Members
MSBuild.Community.Tasks Namespace


Computer Members

[image] [image]

.NET Framework Class Library
Computer Members
Computer Class Constructors Methods Properties See Also Send Feedback

The Computer type exposes the following members.

Constructors

Name | Description
Computer | Initializes a new instance of the Computer class.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | Executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
IPAddress | Gets the IP address of the build computer.
Log | (Inherited from Task.)
Name | Gets the host name of the build computer.
OSPlatform | Gets the platform identifier of the build computer's operating system .
OSVersion | Gets the version number of the build computer's operating system.
TaskResources | (Inherited from Task.)

See Also

Computer Class
MSBuild.Community.Tasks Namespace


Computer Constructor

[image]

.NET Framework Class Library
Computer Constructor
Computer Class See Also Send Feedback

Initializes a new instance of the Computer class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Computer()
Visual C++
public:
Computer()

See Also

Computer Class
MSBuild.Community.Tasks Namespace


Computer Methods

[image] [image]

.NET Framework Class Library
Computer Methods
Computer Class See Also Send Feedback

The Computer type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | Executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

Computer Class
MSBuild.Community.Tasks Namespace


Execute Method

[image]

.NET Framework Class Library
Computer..::.Execute Method
Computer Class See Also Send Feedback

Executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

trueTruetruetrue (True in Visual Basic) if the task ran successfully; otherwise falseFalsefalsefalse (False in Visual Basic).

Implements

ITask..::.Execute()()()

See Also

Computer Class
MSBuild.Community.Tasks Namespace


Computer Properties

[image] [image]

.NET Framework Class Library
Computer Properties
Computer Class See Also Send Feedback

The Computer type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
IPAddress | Gets the IP address of the build computer.
Log | (Inherited from Task.)
Name | Gets the host name of the build computer.
OSPlatform | Gets the platform identifier of the build computer's operating system .
OSVersion | Gets the version number of the build computer's operating system.
TaskResources | (Inherited from Task.)

See Also

Computer Class
MSBuild.Community.Tasks Namespace


IPAddress Property

[image]

.NET Framework Class Library
Computer..::.IPAddress Property
Computer Class See Also Send Feedback

Gets the IP address of the build computer.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property IPAddress As String
C#
[OutputAttribute]
public string IPAddress { get; }
Visual C++
[OutputAttribute]
public:
property String^ IPAddress {
    String^ get ();
}

See Also

Computer Class
MSBuild.Community.Tasks Namespace


Name Property

[image]

.NET Framework Class Library
Computer..::.Name Property
Computer Class See Also Send Feedback

Gets the host name of the build computer.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property Name As String
C#
[OutputAttribute]
public string Name { get; }
Visual C++
[OutputAttribute]
public:
property String^ Name {
    String^ get ();
}

See Also

Computer Class
MSBuild.Community.Tasks Namespace


OSPlatform Property

[image]

.NET Framework Class Library
Computer..::.OSPlatform Property
Computer Class See Also Send Feedback

Gets the platform identifier of the build computer's operating system .

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property OSPlatform As String
C#
[OutputAttribute]
public string OSPlatform { get; }
Visual C++
[OutputAttribute]
public:
property String^ OSPlatform {
    String^ get ();
}

See Also

Computer Class
MSBuild.Community.Tasks Namespace


OSVersion Property

[image]

.NET Framework Class Library
Computer..::.OSVersion Property
Computer Class See Also Send Feedback

Gets the version number of the build computer's operating system.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property OSVersion As String
C#
[OutputAttribute]
public string OSVersion { get; }
Visual C++
[OutputAttribute]
public:
property String^ OSVersion {
    String^ get ();
}

See Also

Computer Class
MSBuild.Community.Tasks Namespace


DeleteTree Class

[image]

.NET Framework Class Library
DeleteTree Class
Members Example See Also Send Feedback

Delete a directory tree. This task supports wild card directory selection.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class DeleteTree _
    Inherits Task
C#
public class DeleteTree : Task
Visual C++
public ref class DeleteTree : public Task

Examples

Delete all bin and obj directories.

Copy Code
            <DeleteTree Directories="**\bin;**\obj" />

Delete all bin and obj directories that start with MSBuild.Community.

Copy Code
            <DeleteTree Directories="MSBuild.Community.*\**\bin;MSBuild.Community.*\**\obj" />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks..::.DeleteTree

See Also

DeleteTree Members
MSBuild.Community.Tasks Namespace


DeleteTree Members

[image] [image]

.NET Framework Class Library
DeleteTree Members
DeleteTree Class Constructors Methods Properties See Also Send Feedback

The DeleteTree type exposes the following members.

Constructors

Name | Description
DeleteTree | Initializes a new instance of the DeleteTree class.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
DeletedDirectories | Gets the deleted directories.
Directories | Gets or sets the directories to be deleted.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
Recursive | Gets or sets a value indicating whether this DeleteTree is recursive.
TaskResources | (Inherited from Task.)

See Also

DeleteTree Class
MSBuild.Community.Tasks Namespace


DeleteTree Constructor

[image]

.NET Framework Class Library
DeleteTree Constructor
DeleteTree Class See Also Send Feedback

Initializes a new instance of the DeleteTree class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DeleteTree()
Visual C++
public:
DeleteTree()

See Also

DeleteTree Class
MSBuild.Community.Tasks Namespace


DeleteTree Methods

[image] [image]

.NET Framework Class Library
DeleteTree Methods
DeleteTree Class See Also Send Feedback

The DeleteTree type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

DeleteTree Class
MSBuild.Community.Tasks Namespace


Execute Method

[image]

.NET Framework Class Library
DeleteTree..::.Execute Method
DeleteTree Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

DeleteTree Class
MSBuild.Community.Tasks Namespace


DeleteTree Properties

[image] [image]

.NET Framework Class Library
DeleteTree Properties
DeleteTree Class See Also Send Feedback

The DeleteTree type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
DeletedDirectories | Gets the deleted directories.
Directories | Gets or sets the directories to be deleted.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
Recursive | Gets or sets a value indicating whether this DeleteTree is recursive.
TaskResources | (Inherited from Task.)

See Also

DeleteTree Class
MSBuild.Community.Tasks Namespace


DeletedDirectories Property

[image]

.NET Framework Class Library
DeleteTree..::.DeletedDirectories Property
DeleteTree Class See Also Send Feedback

Gets the deleted directories.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property DeletedDirectories As ITaskItem()
C#
[OutputAttribute]
public ITaskItem[] DeletedDirectories { get; }
Visual C++
[OutputAttribute]
public:
property array<ITaskItem^>^ DeletedDirectories {
    array<ITaskItem^>^ get ();
}

Field Value

The deleted directories.

See Also

DeleteTree Class
MSBuild.Community.Tasks Namespace


Directories Property

[image]

.NET Framework Class Library
DeleteTree..::.Directories Property
DeleteTree Class See Also Send Feedback

Gets or sets the directories to be deleted.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property Directories As ITaskItem()
C#
[RequiredAttribute]
public ITaskItem[] Directories { get; set; }
Visual C++
[RequiredAttribute]
public:
property array<ITaskItem^>^ Directories {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

Field Value

The directories to be deleted.

Remarks

Directories can contain wild cards.

See Also

DeleteTree Class
MSBuild.Community.Tasks Namespace


Recursive Property

[image]

.NET Framework Class Library
DeleteTree..::.Recursive Property
DeleteTree Class See Also Send Feedback

Gets or sets a value indicating whether this DeleteTree is recursive.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Recursive As Boolean
C#
public bool Recursive { get; set; }
Visual C++
public:
property bool Recursive {
    bool get ();
    void set (bool value);
}

Field Value

true if recursive; otherwise, false.

See Also

DeleteTree Class
MSBuild.Community.Tasks Namespace


FileUpdate Class

[image]

.NET Framework Class Library
FileUpdate Class
Members Example See Also Send Feedback

Replace text in file(s) using a Regular Expression.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class FileUpdate _
    Inherits Task
C#
public class FileUpdate : Task
Visual C++
public ref class FileUpdate : public Task

Examples

Search for a version number and update the revision.
Copy Code
            <FileUpdate Files="version.txt"
                Regex="(\d+)\.(\d+)\.(\d+)\.(\d+)"
                ReplacementText="$1.$2.$3.123" />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks..::.FileUpdate

See Also

FileUpdate Members
MSBuild.Community.Tasks Namespace


FileUpdate Members

[image] [image]

.NET Framework Class Library
FileUpdate Members
FileUpdate Class Constructors Methods Properties See Also Send Feedback

The FileUpdate type exposes the following members.

Constructors

Name | Description
FileUpdate | Initializes a new instance of the FileUpdate class.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Encoding | The character encoding used to read and write the file.
Files | Gets or sets the files to update.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
IgnoreCase | Gets or sets a value specifies case-insensitive matching. .
Log | (Inherited from Task.)
Multiline | Gets or sets a value changing the meaning of ^ and $ so they match at the beginning and end, respectively, of any line, and not just the beginning and end of the entire string.
Regex | Gets or sets the regex.
ReplacementCount | Gets or sets the maximum number of times the replacement can occur.
ReplacementText | Gets or sets the replacement text.
Singleline | Gets or sets a value changing the meaning of the dot (.) so it matches every character (instead of every character except \n).
TaskResources | (Inherited from Task.)
WarnOnNoUpdate | When TRUE, a warning will be generated to show which file was not updated.

See Also

FileUpdate Class
MSBuild.Community.Tasks Namespace


FileUpdate Constructor

[image]

.NET Framework Class Library
FileUpdate Constructor
FileUpdate Class See Also Send Feedback

Initializes a new instance of the FileUpdate class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FileUpdate()
Visual C++
public:
FileUpdate()

See Also

FileUpdate Class
MSBuild.Community.Tasks Namespace


FileUpdate Methods

[image] [image]

.NET Framework Class Library
FileUpdate Methods
FileUpdate Class See Also Send Feedback

The FileUpdate type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

FileUpdate Class
MSBuild.Community.Tasks Namespace


Execute Method

[image]

.NET Framework Class Library
FileUpdate..::.Execute Method
FileUpdate Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

FileUpdate Class
MSBuild.Community.Tasks Namespace


FileUpdate Properties

[image] [image]

.NET Framework Class Library
FileUpdate Properties
FileUpdate Class See Also Send Feedback

The FileUpdate type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Encoding | The character encoding used to read and write the file.
Files | Gets or sets the files to update.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
IgnoreCase | Gets or sets a value specifies case-insensitive matching. .
Log | (Inherited from Task.)
Multiline | Gets or sets a value changing the meaning of ^ and $ so they match at the beginning and end, respectively, of any line, and not just the beginning and end of the entire string.
Regex | Gets or sets the regex.
ReplacementCount | Gets or sets the maximum number of times the replacement can occur.
ReplacementText | Gets or sets the replacement text.
Singleline | Gets or sets a value changing the meaning of the dot (.) so it matches every character (instead of every character except \n).
TaskResources | (Inherited from Task.)
WarnOnNoUpdate | When TRUE, a warning will be generated to show which file was not updated.

See Also

FileUpdate Class
MSBuild.Community.Tasks Namespace


Encoding Property

[image]

.NET Framework Class Library
FileUpdate..::.Encoding Property
FileUpdate Class See Also Send Feedback

The character encoding used to read and write the file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Encoding As String
C#
public string Encoding { get; set; }
Visual C++
public:
property String^ Encoding {
    String^ get ();
    void set (String^ value);
}

Remarks

Any value returned by WebName is valid input.

The default is utf-8

See Also

FileUpdate Class
MSBuild.Community.Tasks Namespace


Files Property

[image]

.NET Framework Class Library
FileUpdate..::.Files Property
FileUpdate Class See Also Send Feedback

Gets or sets the files to update.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Files As ITaskItem()
C#
public ITaskItem[] Files { get; set; }
Visual C++
public:
property array<ITaskItem^>^ Files {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

Field Value

The files.

See Also

FileUpdate Class
MSBuild.Community.Tasks Namespace


IgnoreCase Property

[image]

.NET Framework Class Library
FileUpdate..::.IgnoreCase Property
FileUpdate Class See Also Send Feedback

Gets or sets a value specifies case-insensitive matching. .

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property IgnoreCase As Boolean
C#
public bool IgnoreCase { get; set; }
Visual C++
public:
property bool IgnoreCase {
    bool get ();
    void set (bool value);
}

Field Value

true if [ignore case]; otherwise, false.

See Also

FileUpdate Class
MSBuild.Community.Tasks Namespace


Multiline Property

[image]

.NET Framework Class Library
FileUpdate..::.Multiline Property
FileUpdate Class See Also Send Feedback

Gets or sets a value changing the meaning of ^ and $ so they match at the beginning and end, respectively, of any line, and not just the beginning and end of the entire string.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Multiline As Boolean
C#
public bool Multiline { get; set; }
Visual C++
public:
property bool Multiline {
    bool get ();
    void set (bool value);
}

Field Value

true if multiline; otherwise, false.

See Also

FileUpdate Class
MSBuild.Community.Tasks Namespace


Regex Property

[image]

.NET Framework Class Library
FileUpdate..::.Regex Property
FileUpdate Class See Also Send Feedback

Gets or sets the regex.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Regex As String
C#
public string Regex { get; set; }
Visual C++
public:
property String^ Regex {
    String^ get ();
    void set (String^ value);
}

Field Value

The regex.

See Also

FileUpdate Class
MSBuild.Community.Tasks Namespace


ReplacementCount Property

[image]

.NET Framework Class Library
FileUpdate..::.ReplacementCount Property
FileUpdate Class See Also Send Feedback

Gets or sets the maximum number of times the replacement can occur.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ReplacementCount As Integer
C#
public int ReplacementCount { get; set; }
Visual C++
public:
property int ReplacementCount {
    int get ();
    void set (int value);
}

Field Value

The replacement count.

See Also

FileUpdate Class
MSBuild.Community.Tasks Namespace


ReplacementText Property

[image]

.NET Framework Class Library
FileUpdate..::.ReplacementText Property
FileUpdate Class See Also Send Feedback

Gets or sets the replacement text.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ReplacementText As String
C#
public string ReplacementText { get; set; }
Visual C++
public:
property String^ ReplacementText {
    String^ get ();
    void set (String^ value);
}

Field Value

The replacement text.

See Also

FileUpdate Class
MSBuild.Community.Tasks Namespace


Singleline Property

[image]

.NET Framework Class Library
FileUpdate..::.Singleline Property
FileUpdate Class See Also Send Feedback

Gets or sets a value changing the meaning of the dot (.) so it matches every character (instead of every character except \n).

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Singleline As Boolean
C#
public bool Singleline { get; set; }
Visual C++
public:
property bool Singleline {
    bool get ();
    void set (bool value);
}

Field Value

true if singleline; otherwise, false.

See Also

FileUpdate Class
MSBuild.Community.Tasks Namespace


WarnOnNoUpdate Property

[image]

.NET Framework Class Library
FileUpdate..::.WarnOnNoUpdate Property
FileUpdate Class See Also Send Feedback

When TRUE, a warning will be generated to show which file was not updated.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property WarnOnNoUpdate As Boolean
C#
public bool WarnOnNoUpdate { get; set; }
Visual C++
public:
property bool WarnOnNoUpdate {
    bool get ();
    void set (bool value);
}

Remarks

N/A

See Also

FileUpdate Class
MSBuild.Community.Tasks Namespace


FtpUpload Class

[image]

.NET Framework Class Library
FtpUpload Class
Members Example See Also Send Feedback

Uploads a group of files using File Transfer Protocol (FTP).

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class FtpUpload _
    Inherits Task _
    Implements IFtpWebRequestCreator
C#
public class FtpUpload : Task, IFtpWebRequestCreator
Visual C++
public ref class FtpUpload : public Task,
    IFtpWebRequestCreator

Remarks

Set either LocalFiles or LocalFile but not both.

Examples

Upload a file.
Copy Code
            <FtpUpload
                LocalFile="MSBuild.Community.Tasks.zip"
                RemoteUri="ftp://localhost/" />
Upload all the files in an ItemGroup:
Copy Code
            <FtpUpload
                Username="username"
                Password="password"
                UsePassive="true"
                RemoteUri="ftp://webserver.com/httpdocs/"
                LocalFiles="@(FilesToUpload)"
                RemoteFiles="@(FilesToUpload->'%(RecursiveDir)%(Filename)%(Extension)')" />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks..::.FtpUpload

See Also

FtpUpload Members
MSBuild.Community.Tasks Namespace


FtpUpload Members

[image] [image]

.NET Framework Class Library
FtpUpload Members
FtpUpload Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The FtpUpload type exposes the following members.

Constructors

Name | Description
FtpUpload | Overloaded.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
LocalFile | Gets or sets the single file to upload. Use this or LocalFiles, but not both.
LocalFiles | Gets or sets the local files to upload. Use this or LocalFile, but not both.
Log | (Inherited from Task.)
Password | Gets or sets the password.
RemoteFiles | Gets or sets the remote files to upload. Each item in this list should have a corresponding item in LocalFiles.
RemoteUri | Gets or sets the remote URI to upload.
TaskResources | (Inherited from Task.)
UsePassive | Gets or sets the behavior of a client application's data transfer process.
Username | Gets or sets the username.

Explicit Interface Implementations

Name | Description
IFtpWebRequestCreator..::.Create |

See Also

FtpUpload Class
MSBuild.Community.Tasks Namespace


FtpUpload Constructor

[image] [image]

.NET Framework Class Library
FtpUpload Constructor
FtpUpload Class See Also Send Feedback

Overload List

Name | Description
FtpUpload()()() | Initializes a new instance of the FtpUpload class.
FtpUpload(IFtpWebRequestCreator) | Initializes a new instance that will inject the specified dependency.

See Also

FtpUpload Class
FtpUpload Members
MSBuild.Community.Tasks Namespace


FtpUpload Constructor

[image]

.NET Framework Class Library
FtpUpload Constructor
FtpUpload Class See Also Send Feedback

Initializes a new instance of the FtpUpload class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FtpUpload()
Visual C++
public:
FtpUpload()

See Also

FtpUpload Class
FtpUpload Overload
MSBuild.Community.Tasks Namespace


FtpUpload Constructor (IFtpWebRequestCreator)

[image]

.NET Framework Class Library
FtpUpload Constructor (IFtpWebRequestCreator)
FtpUpload Class See Also Send Feedback

Initializes a new instance that will inject the specified dependency.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    requestCreator As IFtpWebRequestCreator _
)
C#
public FtpUpload(
    IFtpWebRequestCreator requestCreator
)
Visual C++
public:
FtpUpload(
    IFtpWebRequestCreator^ requestCreator
)

Parameters

requestCreator
Type: MSBuild.Community.Tasks..::.IFtpWebRequestCreator

See Also

FtpUpload Class
FtpUpload Overload
MSBuild.Community.Tasks Namespace


FtpUpload Methods

[image] [image]

.NET Framework Class Library
FtpUpload Methods
FtpUpload Class See Also Send Feedback

The FtpUpload type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IFtpWebRequestCreator..::.Create |

See Also

FtpUpload Class
MSBuild.Community.Tasks Namespace


Execute Method

[image]

.NET Framework Class Library
FtpUpload..::.Execute Method
FtpUpload Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

FtpUpload Class
MSBuild.Community.Tasks Namespace


IFtpWebRequestCreator.Create Method

[image]

.NET Framework Class Library
FtpUpload..::.IFtpWebRequestCreator..::.Create Method
FtpUpload Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Private Function Create ( _
    uri As Uri, _
    method As String _
) As IFtpWebRequest Implements IFtpWebRequestCreator.Create
C#
IFtpWebRequest IFtpWebRequestCreator.Create(
    Uri uri,
    string method
)
Visual C++
private:
virtual IFtpWebRequest^ Create(
    Uri^ uri,
    String^ method
) sealed = IFtpWebRequestCreator::Create

Parameters

uri
Type: System..::.Uri
method
Type: System..::.String

Implements

IFtpWebRequestCreator..::.Create(Uri, String)

See Also

FtpUpload Class
MSBuild.Community.Tasks Namespace


FtpUpload Properties

[image] [image]

.NET Framework Class Library
FtpUpload Properties
FtpUpload Class See Also Send Feedback

The FtpUpload type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
LocalFile | Gets or sets the single file to upload. Use this or LocalFiles, but not both.
LocalFiles | Gets or sets the local files to upload. Use this or LocalFile, but not both.
Log | (Inherited from Task.)
Password | Gets or sets the password.
RemoteFiles | Gets or sets the remote files to upload. Each item in this list should have a corresponding item in LocalFiles.
RemoteUri | Gets or sets the remote URI to upload.
TaskResources | (Inherited from Task.)
UsePassive | Gets or sets the behavior of a client application's data transfer process.
Username | Gets or sets the username.

See Also

FtpUpload Class
MSBuild.Community.Tasks Namespace


LocalFile Property

[image]

.NET Framework Class Library
FtpUpload..::.LocalFile Property
FtpUpload Class See Also Send Feedback

Gets or sets the single file to upload. Use this or LocalFiles, but not both.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property LocalFile As String
C#
public string LocalFile { get; set; }
Visual C++
public:
property String^ LocalFile {
    String^ get ();
    void set (String^ value);
}

See Also

FtpUpload Class
MSBuild.Community.Tasks Namespace


LocalFiles Property

[image]

.NET Framework Class Library
FtpUpload..::.LocalFiles Property
FtpUpload Class See Also Send Feedback

Gets or sets the local files to upload. Use this or LocalFile, but not both.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property LocalFiles As ITaskItem()
C#
public ITaskItem[] LocalFiles { get; set; }
Visual C++
public:
property array<ITaskItem^>^ LocalFiles {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

Field Value

The local file.

See Also

FtpUpload Class
MSBuild.Community.Tasks Namespace


Password Property

[image]

.NET Framework Class Library
FtpUpload..::.Password Property
FtpUpload Class See Also Send Feedback

Gets or sets the password.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password { get; set; }
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

Field Value

The password.

See Also

FtpUpload Class
MSBuild.Community.Tasks Namespace


RemoteFiles Property

[image]

.NET Framework Class Library
FtpUpload..::.RemoteFiles Property
FtpUpload Class See Also Send Feedback

Gets or sets the remote files to upload. Each item in this list should have a corresponding item in LocalFiles.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property RemoteFiles As ITaskItem()
C#
[RequiredAttribute]
public ITaskItem[] RemoteFiles { get; set; }
Visual C++
[RequiredAttribute]
public:
property array<ITaskItem^>^ RemoteFiles {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

See Also

FtpUpload Class
MSBuild.Community.Tasks Namespace


RemoteUri Property

[image]

.NET Framework Class Library
FtpUpload..::.RemoteUri Property
FtpUpload Class See Also Send Feedback

Gets or sets the remote URI to upload.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property RemoteUri As String
C#
[RequiredAttribute]
public string RemoteUri { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ RemoteUri {
    String^ get ();
    void set (String^ value);
}

Field Value

The remote URI.

See Also

FtpUpload Class
MSBuild.Community.Tasks Namespace


UsePassive Property

[image]

.NET Framework Class Library
FtpUpload..::.UsePassive Property
FtpUpload Class See Also Send Feedback

Gets or sets the behavior of a client application's data transfer process.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property UsePassive As Boolean
C#
public bool UsePassive { get; set; }
Visual C++
public:
property bool UsePassive {
    bool get ();
    void set (bool value);
}

Field Value

true if [use passive]; otherwise, false.

See Also

FtpUpload Class
MSBuild.Community.Tasks Namespace


Username Property

[image]

.NET Framework Class Library
FtpUpload..::.Username Property
FtpUpload Class See Also Send Feedback

Gets or sets the username.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Username As String
C#
public string Username { get; set; }
Visual C++
public:
property String^ Username {
    String^ get ();
    void set (String^ value);
}

Field Value

The username.

See Also

FtpUpload Class
MSBuild.Community.Tasks Namespace


FxCop Class

[image]

.NET Framework Class Library
FxCop Class
Members Example See Also Send Feedback

Uses FxCop to analyse managed code assemblies and reports on their design best-practice compliance.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class FxCop _
    Inherits ToolTask
C#
public class FxCop : ToolTask
Visual C++
public ref class FxCop : public ToolTask

Remarks

If you include the MSBuild.Community.Tasks.Targets file in you build project, the ItemGroup @(FxCopRuleAssemblies) is defined with the standard FxCop Rules Assemblies.

Examples

Shows how to analyse an assembly and use an XSLT stylesheet to present the report as an HTML file. If the static anlysis fails, the build does not stop - this is controlled with the FailOnError parameter.

Copy Code
            <FxCop
              TargetAssemblies="$(MSBuildCommunityTasksPath)\MSBuild.Community.Tasks.dll"
              RuleLibraries="@(FxCopRuleAssemblies)"
              Rules="Microsoft.Design#CA1012;-Microsoft.Performance#CA1805"
              AnalysisReportFileName="Test.html"
              DependencyDirectories="$(MSBuildCommunityTasksPath)"
              FailOnError="False"
              ApplyOutXsl="True"
              OutputXslFileName="C:\Program Files\Microsoft FxCop 1.32\Xml\FxCopReport.xsl"
            />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
Microsoft.Build.Utilities..::.ToolTask
MSBuild.Community.Tasks..::.FxCop

See Also

FxCop Members
MSBuild.Community.Tasks Namespace


FxCop Members

[image] [image]

.NET Framework Class Library
FxCop Members
FxCop Class Constructors Methods Properties See Also Send Feedback

The FxCop type exposes the following members.

Constructors

Name | Description
FxCop |

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | Executes the task. (Overrides ToolTask..::.Execute()()().)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | Returns the directory in which to run the executable file. (Overrides ToolTask..::.GetWorkingDirectory()()().)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | (Inherited from ToolTask.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | (Inherited from ToolTask.)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | Indicates whether all task paratmeters are valid. (Overrides ToolTask..::.ValidateParameters()()().)

Properties

Name | Description
AnalysisReportFileName | Specifies the file name for the analysis report.
ApplyOutXsl | Applies the XSL transformation specified in /outXsl to the analysis report before saving the file.
BuildEngine | (Inherited from Task.)
ConsoleXslFileName | Specifies the XSL or XSLT file that contains a transformation to be applied to the analysis output before it is displayed in the console.
DependencyDirectories | Specifies additional directories to search for assembly dependencies. FxCopCmd always searches the target assembly directory and the current working directory.
DirectOutputToConsole | Directs analysis output to the console or to the Output window in Visual Studio .NET. By default, the XSL file FxCopConsoleOutput.xsl is applied to the output before it is displayed.
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
FailOnError | Gets or sets a value indicating whether the build should fail if static code analysis reports errors. Defaults to true.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
ImportFiles | Specifies the name of an analysis report or project file to import. Any messages in the imported file that are marked as excluded are not included in the analysis results.
IncludeSummaryReport | Includes a summary report with the informational messages returned by FxCopCmd.
Log | (Inherited from Task.)
OutputXslFileName | Specifies the XSL or XSLT file that is referenced by the xml-stylesheet processing instruction in the analysis report.
PlatformDirectory | Specifies the location of the version of Mscorlib.dll that was used when building the target assemblies if this version is not installed on the computer running FxCopCmd.
ProjectFile | Specifies the filename of FxCop project file.
ResponseFileEncoding | (Inherited from ToolTask.)
RuleLibraries | Specifies the filename(s) of FxCop rule assemblies
Rules | The list of rules to run
SaveResults | Saves the results of the analysis in the project file.
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | (Inherited from ToolTask.)
TargetAssemblies | Specifies the target assembly to analyze.
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)
TypeList | Comma-separated list of type names to analyze. This option disables analysis of assemblies, namespaces, and resources; only the specified types and their members are included in the analysis. Use the wildcard character '*' at the end of the name to select multiple types.
Verbose | Gets or sets a value indicating whether the output is verbose.
WorkingDirectory | Gets or sets the working directory.

See Also

FxCop Class
MSBuild.Community.Tasks Namespace


FxCop Constructor

[image]

.NET Framework Class Library
FxCop Constructor
FxCop Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FxCop()
Visual C++
public:
FxCop()

See Also

FxCop Class
MSBuild.Community.Tasks Namespace


FxCop Methods

[image] [image]

.NET Framework Class Library
FxCop Methods
FxCop Class See Also Send Feedback

The FxCop type exposes the following members.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | Executes the task. (Overrides ToolTask..::.Execute()()().)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | Returns the directory in which to run the executable file. (Overrides ToolTask..::.GetWorkingDirectory()()().)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | (Inherited from ToolTask.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | (Inherited from ToolTask.)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | Indicates whether all task paratmeters are valid. (Overrides ToolTask..::.ValidateParameters()()().)

See Also

FxCop Class
MSBuild.Community.Tasks Namespace


Execute Method

[image]

.NET Framework Class Library
FxCop..::.Execute Method
FxCop Class See Also Send Feedback

Executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

trueTruetruetrue (True in Visual Basic) if the task ran successfully; otherwise falseFalsefalsefalse (False in Visual Basic).

Implements

ITask..::.Execute()()()

See Also

FxCop Class
MSBuild.Community.Tasks Namespace


GenerateCommandLineCommands Method

[image]

.NET Framework Class Library
FxCop..::.GenerateCommandLineCommands Method
FxCop Class See Also Send Feedback

Returns a string value containing the command line arguments to pass directly to the executable file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateCommandLineCommands As String
C#
protected override string GenerateCommandLineCommands()
Visual C++
protected:
virtual String^ GenerateCommandLineCommands() override

Return Value

A string value containing the command line arguments to pass directly to the executable file.

See Also

FxCop Class
MSBuild.Community.Tasks Namespace


GenerateFullPathToTool Method

[image]

.NET Framework Class Library
FxCop..::.GenerateFullPathToTool Method
FxCop Class See Also Send Feedback

Returns the fully qualified path to the executable file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateFullPathToTool As String
C#
protected override string GenerateFullPathToTool()
Visual C++
protected:
virtual String^ GenerateFullPathToTool() override

Return Value

The fully qualified path to the executable file.

See Also

FxCop Class
MSBuild.Community.Tasks Namespace


GetWorkingDirectory Method

[image]

.NET Framework Class Library
FxCop..::.GetWorkingDirectory Method
FxCop Class See Also Send Feedback

Returns the directory in which to run the executable file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetWorkingDirectory As String
C#
protected override string GetWorkingDirectory()
Visual C++
protected:
virtual String^ GetWorkingDirectory() override

Return Value

The directory in which to run the executable file, or a null reference (Nothing in Visual Basic) if the executable file should be run in the current directory.

See Also

FxCop Class
MSBuild.Community.Tasks Namespace


ValidateParameters Method

[image]

.NET Framework Class Library
FxCop..::.ValidateParameters Method
FxCop Class See Also Send Feedback

Indicates whether all task paratmeters are valid.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function ValidateParameters As Boolean
C#
protected override bool ValidateParameters()
Visual C++
protected:
virtual bool ValidateParameters() override

Return Value

true if all task parameters are valid; otherwise, false

See Also

FxCop Class
MSBuild.Community.Tasks Namespace


FxCop Properties

[image] [image]

.NET Framework Class Library
FxCop Properties
FxCop Class See Also Send Feedback

The FxCop type exposes the following members.

Properties

Name | Description
AnalysisReportFileName | Specifies the file name for the analysis report.
ApplyOutXsl | Applies the XSL transformation specified in /outXsl to the analysis report before saving the file.
BuildEngine | (Inherited from Task.)
ConsoleXslFileName | Specifies the XSL or XSLT file that contains a transformation to be applied to the analysis output before it is displayed in the console.
DependencyDirectories | Specifies additional directories to search for assembly dependencies. FxCopCmd always searches the target assembly directory and the current working directory.
DirectOutputToConsole | Directs analysis output to the console or to the Output window in Visual Studio .NET. By default, the XSL file FxCopConsoleOutput.xsl is applied to the output before it is displayed.
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
FailOnError | Gets or sets a value indicating whether the build should fail if static code analysis reports errors. Defaults to true.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
ImportFiles | Specifies the name of an analysis report or project file to import. Any messages in the imported file that are marked as excluded are not included in the analysis results.
IncludeSummaryReport | Includes a summary report with the informational messages returned by FxCopCmd.
Log | (Inherited from Task.)
OutputXslFileName | Specifies the XSL or XSLT file that is referenced by the xml-stylesheet processing instruction in the analysis report.
PlatformDirectory | Specifies the location of the version of Mscorlib.dll that was used when building the target assemblies if this version is not installed on the computer running FxCopCmd.
ProjectFile | Specifies the filename of FxCop project file.
ResponseFileEncoding | (Inherited from ToolTask.)
RuleLibraries | Specifies the filename(s) of FxCop rule assemblies
Rules | The list of rules to run
SaveResults | Saves the results of the analysis in the project file.
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | (Inherited from ToolTask.)
TargetAssemblies | Specifies the target assembly to analyze.
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)
TypeList | Comma-separated list of type names to analyze. This option disables analysis of assemblies, namespaces, and resources; only the specified types and their members are included in the analysis. Use the wildcard character '*' at the end of the name to select multiple types.
Verbose | Gets or sets a value indicating whether the output is verbose.
WorkingDirectory | Gets or sets the working directory.

See Also

FxCop Class
MSBuild.Community.Tasks Namespace


AnalysisReportFileName Property

[image]

.NET Framework Class Library
FxCop..::.AnalysisReportFileName Property
FxCop Class See Also Send Feedback

Specifies the file name for the analysis report.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AnalysisReportFileName As String
C#
public string AnalysisReportFileName { get; set; }
Visual C++
public:
property String^ AnalysisReportFileName {
    String^ get ();
    void set (String^ value);
}

See Also

FxCop Class
MSBuild.Community.Tasks Namespace


ApplyOutXsl Property

[image]

.NET Framework Class Library
FxCop..::.ApplyOutXsl Property
FxCop Class See Also Send Feedback

Applies the XSL transformation specified in /outXsl to the analysis report before saving the file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ApplyOutXsl As Boolean
C#
public bool ApplyOutXsl { get; set; }
Visual C++
public:
property bool ApplyOutXsl {
    bool get ();
    void set (bool value);
}

See Also

FxCop Class
MSBuild.Community.Tasks Namespace


ConsoleXslFileName Property

[image]

.NET Framework Class Library
FxCop..::.ConsoleXslFileName Property
FxCop Class See Also Send Feedback

Specifies the XSL or XSLT file that contains a transformation to be applied to the analysis output before it is displayed in the console.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ConsoleXslFileName As String
C#
public string ConsoleXslFileName { get; set; }
Visual C++
public:
property String^ ConsoleXslFileName {
    String^ get ();
    void set (String^ value);
}

See Also

FxCop Class
MSBuild.Community.Tasks Namespace


DependencyDirectories Property

[image]

.NET Framework Class Library
FxCop..::.DependencyDirectories Property
FxCop Class See Also Send Feedback

Specifies additional directories to search for assembly dependencies. FxCopCmd always searches the target assembly directory and the current working directory.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property DependencyDirectories As ITaskItem()
C#
public ITaskItem[] DependencyDirectories { get; set; }
Visual C++
public:
property array<ITaskItem^>^ DependencyDirectories {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

See Also

FxCop Class
MSBuild.Community.Tasks Namespace


DirectOutputToConsole Property

[image]

.NET Framework Class Library
FxCop..::.DirectOutputToConsole Property
FxCop Class See Also Send Feedback

Directs analysis output to the console or to the Output window in Visual Studio .NET. By default, the XSL file FxCopConsoleOutput.xsl is applied to the output before it is displayed.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property DirectOutputToConsole As Boolean
C#
public bool DirectOutputToConsole { get; set; }
Visual C++
public:
property bool DirectOutputToConsole {
    bool get ();
    void set (bool value);
}

See Also

FxCop Class
MSBuild.Community.Tasks Namespace


FailOnError Property

[image]

.NET Framework Class Library
FxCop..::.FailOnError Property
FxCop Class See Also Send Feedback

Gets or sets a value indicating whether the build should fail if static code analysis reports errors. Defaults to true.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property FailOnError As Boolean
C#
public bool FailOnError { get; set; }
Visual C++
public:
property bool FailOnError {
    bool get ();
    void set (bool value);
}

Field Value

true if verbose; otherwise, false.

See Also

FxCop Class
MSBuild.Community.Tasks Namespace


ImportFiles Property

[image]

.NET Framework Class Library
FxCop..::.ImportFiles Property
FxCop Class See Also Send Feedback

Specifies the name of an analysis report or project file to import. Any messages in the imported file that are marked as excluded are not included in the analysis results.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ImportFiles As ITaskItem()
C#
public ITaskItem[] ImportFiles { get; set; }
Visual C++
public:
property array<ITaskItem^>^ ImportFiles {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

See Also

FxCop Class
MSBuild.Community.Tasks Namespace


IncludeSummaryReport Property

[image]

.NET Framework Class Library
FxCop..::.IncludeSummaryReport Property
FxCop Class See Also Send Feedback

Includes a summary report with the informational messages returned by FxCopCmd.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property IncludeSummaryReport As Boolean
C#
public bool IncludeSummaryReport { get; set; }
Visual C++
public:
property bool IncludeSummaryReport {
    bool get ();
    void set (bool value);
}

See Also

FxCop Class
MSBuild.Community.Tasks Namespace


OutputXslFileName Property

[image]

.NET Framework Class Library
FxCop..::.OutputXslFileName Property
FxCop Class See Also Send Feedback

Specifies the XSL or XSLT file that is referenced by the xml-stylesheet processing instruction in the analysis report.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property OutputXslFileName As String
C#
public string OutputXslFileName { get; set; }
Visual C++
public:
property String^ OutputXslFileName {
    String^ get ();
    void set (String^ value);
}

See Also

FxCop Class
MSBuild.Community.Tasks Namespace


PlatformDirectory Property

[image]

.NET Framework Class Library
FxCop..::.PlatformDirectory Property
FxCop Class See Also Send Feedback

Specifies the location of the version of Mscorlib.dll that was used when building the target assemblies if this version is not installed on the computer running FxCopCmd.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property PlatformDirectory As String
C#
public string PlatformDirectory { get; set; }
Visual C++
public:
property String^ PlatformDirectory {
    String^ get ();
    void set (String^ value);
}

See Also

FxCop Class
MSBuild.Community.Tasks Namespace


ProjectFile Property

[image]

.NET Framework Class Library
FxCop..::.ProjectFile Property
FxCop Class See Also Send Feedback

Specifies the filename of FxCop project file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ProjectFile As String
C#
public string ProjectFile { get; set; }
Visual C++
public:
property String^ ProjectFile {
    String^ get ();
    void set (String^ value);
}

See Also

FxCop Class
MSBuild.Community.Tasks Namespace


RuleLibraries Property

[image]

.NET Framework Class Library
FxCop..::.RuleLibraries Property
FxCop Class See Also Send Feedback

Specifies the filename(s) of FxCop rule assemblies

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property RuleLibraries As ITaskItem()
C#
public ITaskItem[] RuleLibraries { get; set; }
Visual C++
public:
property array<ITaskItem^>^ RuleLibraries {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

See Also

FxCop Class
MSBuild.Community.Tasks Namespace


Rules Property

[image]

.NET Framework Class Library
FxCop..::.Rules Property
FxCop Class See Also Send Feedback

The list of rules to run

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Rules As ITaskItem()
C#
public ITaskItem[] Rules { get; set; }
Visual C++
public:
property array<ITaskItem^>^ Rules {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

Remarks

Rule names should be provided using the format Library#RuleNumber. For example Microsoft.Design#CA1012

Place a single hyphen (-) in front of the rule name to exclude it. For example -Microsoft.Performance#CA1805

See Also

FxCop Class
MSBuild.Community.Tasks Namespace


SaveResults Property

[image]

.NET Framework Class Library
FxCop..::.SaveResults Property
FxCop Class See Also Send Feedback

Saves the results of the analysis in the project file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property SaveResults As Boolean
C#
public bool SaveResults { get; set; }
Visual C++
public:
property bool SaveResults {
    bool get ();
    void set (bool value);
}

See Also

FxCop Class
MSBuild.Community.Tasks Namespace


TargetAssemblies Property

[image]

.NET Framework Class Library
FxCop..::.TargetAssemblies Property
FxCop Class See Also Send Feedback

Specifies the target assembly to analyze.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property TargetAssemblies As ITaskItem()
C#
public ITaskItem[] TargetAssemblies { get; set; }
Visual C++
public:
property array<ITaskItem^>^ TargetAssemblies {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

See Also

FxCop Class
MSBuild.Community.Tasks Namespace


ToolName Property

[image]

.NET Framework Class Library
FxCop..::.ToolName Property
FxCop Class See Also Send Feedback

Gets the name of the executable file to run.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ToolName As String
C#
protected override string ToolName { get; }
Visual C++
protected:
virtual property String^ ToolName {
    String^ get () override;
}

Field Value

Return Value

The name of the executable file to run.

See Also

FxCop Class
MSBuild.Community.Tasks Namespace


TypeList Property

[image]

.NET Framework Class Library
FxCop..::.TypeList Property
FxCop Class See Also Send Feedback

Comma-separated list of type names to analyze. This option disables analysis of assemblies, namespaces, and resources; only the specified types and their members are included in the analysis. Use the wildcard character '*' at the end of the name to select multiple types.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property TypeList As String
C#
public string TypeList { get; set; }
Visual C++
public:
property String^ TypeList {
    String^ get ();
    void set (String^ value);
}

See Also

FxCop Class
MSBuild.Community.Tasks Namespace


Verbose Property

[image]

.NET Framework Class Library
FxCop..::.Verbose Property
FxCop Class See Also Send Feedback

Gets or sets a value indicating whether the output is verbose.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Verbose As Boolean
C#
public bool Verbose { get; set; }
Visual C++
public:
property bool Verbose {
    bool get ();
    void set (bool value);
}

Field Value

true if verbose; otherwise, false.

See Also

FxCop Class
MSBuild.Community.Tasks Namespace


WorkingDirectory Property

[image]

.NET Framework Class Library
FxCop..::.WorkingDirectory Property
FxCop Class See Also Send Feedback

Gets or sets the working directory.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property WorkingDirectory As String
C#
public string WorkingDirectory { get; set; }
Visual C++
public:
property String^ WorkingDirectory {
    String^ get ();
    void set (String^ value);
}

Field Value

The working directory.

Return Value

The directory in which to run the executable file, or a null reference (Nothing in Visual Basic) if the executable file should be run in the current directory.

See Also

FxCop Class
MSBuild.Community.Tasks Namespace


GacUtil Class

[image]

.NET Framework Class Library
GacUtil Class
Members Example See Also Send Feedback

MSBuild task to install and uninstall assemblies into the GAC

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class GacUtil _
    Inherits Task
C#
public class GacUtil : Task
Visual C++
public ref class GacUtil : public Task

Examples

Install a dll into the GAC.
Copy Code
                <GacUtil
                    Command="Install"
                    Assemblies="MSBuild.Community.Tasks.dll"
                    Force="true" />

Examples

Uninstall a dll from the GAC.
Copy Code
                <GacUtil
                    Command="Uninstall"
                    Assemblies="MSBuild.Community.Tasks"
                    Force="true" />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks..::.GacUtil

See Also

GacUtil Members
MSBuild.Community.Tasks Namespace


GacUtil Members

[image] [image]

.NET Framework Class Library
GacUtil Members
GacUtil Class Constructors Methods Properties See Also Send Feedback

The GacUtil type exposes the following members.

Constructors

Name | Description
GacUtil |

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | Runs the executable file with the specified task parameters. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
Assemblies | Gets or sets the assembly name or file.
BuildEngine | (Inherited from Task.)
Command | Gets or sets the command.
Failed | Gets the number of assemblies that failed to installed/uninstalled.
Force | Gets or sets a value indicating whether to force reinstall of an assembly.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
IncludeRelatedFiles | Gets or sets a value indicating whether related files are included when installing in GAC.
InstalledNames | Gets the installed assembly names.
InstalledPaths | Gets the installed assembly paths.
Log | (Inherited from Task.)
Quiet | Gets or sets a value indicating whether warning messages are output.
RelatedFileExtensions | Gets or sets the related file extensions to copy when IncludeRelatedFiles is true.
Skipped | Gets the number of assemblies that were skipped during installed/uninstalled.
Successful | Gets the number of assemblies successfully installed/uninstalled.
TaskResources | (Inherited from Task.)

See Also

GacUtil Class
MSBuild.Community.Tasks Namespace


GacUtil Constructor

[image]

.NET Framework Class Library
GacUtil Constructor
GacUtil Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public GacUtil()
Visual C++
public:
GacUtil()

See Also

GacUtil Class
MSBuild.Community.Tasks Namespace


GacUtil Methods

[image] [image]

.NET Framework Class Library
GacUtil Methods
GacUtil Class See Also Send Feedback

The GacUtil type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | Runs the executable file with the specified task parameters. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

GacUtil Class
MSBuild.Community.Tasks Namespace


Execute Method

[image]

.NET Framework Class Library
GacUtil..::.Execute Method
GacUtil Class See Also Send Feedback

Runs the executable file with the specified task parameters.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

true if the task runs successfully; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

GacUtil Class
MSBuild.Community.Tasks Namespace


GacUtil Properties

[image] [image]

.NET Framework Class Library
GacUtil Properties
GacUtil Class See Also Send Feedback

The GacUtil type exposes the following members.

Properties

Name | Description
Assemblies | Gets or sets the assembly name or file.
BuildEngine | (Inherited from Task.)
Command | Gets or sets the command.
Failed | Gets the number of assemblies that failed to installed/uninstalled.
Force | Gets or sets a value indicating whether to force reinstall of an assembly.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
IncludeRelatedFiles | Gets or sets a value indicating whether related files are included when installing in GAC.
InstalledNames | Gets the installed assembly names.
InstalledPaths | Gets the installed assembly paths.
Log | (Inherited from Task.)
Quiet | Gets or sets a value indicating whether warning messages are output.
RelatedFileExtensions | Gets or sets the related file extensions to copy when IncludeRelatedFiles is true.
Skipped | Gets the number of assemblies that were skipped during installed/uninstalled.
Successful | Gets the number of assemblies successfully installed/uninstalled.
TaskResources | (Inherited from Task.)

See Also

GacUtil Class
MSBuild.Community.Tasks Namespace


Assemblies Property

[image]

.NET Framework Class Library
GacUtil..::.Assemblies Property
GacUtil Class See Also Send Feedback

Gets or sets the assembly name or file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property Assemblies As String()
C#
[RequiredAttribute]
public string[] Assemblies { get; set; }
Visual C++
[RequiredAttribute]
public:
property array<String^>^ Assemblies {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Field Value

The assembly name or file.

Remarks

When the command is install, Assemblies should be a file path to the assembly to install in the GAC. When command is uninstall, Assemblies should be a the full name of the assembly to uninstall.

See Also

GacUtil Class
MSBuild.Community.Tasks Namespace


Command Property

[image]

.NET Framework Class Library
GacUtil..::.Command Property
GacUtil Class See Also Send Feedback

Gets or sets the command.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Command As String
C#
public string Command { get; set; }
Visual C++
public:
property String^ Command {
    String^ get ();
    void set (String^ value);
}

Field Value

The command.

See Also

GacUtil Class
MSBuild.Community.Tasks Namespace


Failed Property

[image]

.NET Framework Class Library
GacUtil..::.Failed Property
GacUtil Class See Also Send Feedback

Gets the number of assemblies that failed to installed/uninstalled.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property Failed As Integer
C#
[OutputAttribute]
public int Failed { get; }
Visual C++
[OutputAttribute]
public:
property int Failed {
    int get ();
}

Field Value

The number failed assemblies.

See Also

GacUtil Class
MSBuild.Community.Tasks Namespace


Force Property

[image]

.NET Framework Class Library
GacUtil..::.Force Property
GacUtil Class See Also Send Feedback

Gets or sets a value indicating whether to force reinstall of an assembly.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Force As Boolean
C#
public bool Force { get; set; }
Visual C++
public:
property bool Force {
    bool get ();
    void set (bool value);
}

Field Value

true if force; otherwise, false.

See Also

GacUtil Class
MSBuild.Community.Tasks Namespace


IncludeRelatedFiles Property

[image]

.NET Framework Class Library
GacUtil..::.IncludeRelatedFiles Property
GacUtil Class See Also Send Feedback

Gets or sets a value indicating whether related files are included when installing in GAC.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property IncludeRelatedFiles As Boolean
C#
public bool IncludeRelatedFiles { get; set; }
Visual C++
public:
property bool IncludeRelatedFiles {
    bool get ();
    void set (bool value);
}

Field Value

true if related files are included when installing in GAC; otherwise, false.

Remarks

Setting IncludeRelatedFiles to true will copy the pdb and xml files from the same folder as the assembly to the location in the GAC that the assembly was installed to. This is useful in some debugging scenarios were you need to debug assemblies that are GAC'd.

See Also

GacUtil Class
MSBuild.Community.Tasks Namespace


InstalledNames Property

[image]

.NET Framework Class Library
GacUtil..::.InstalledNames Property
GacUtil Class See Also Send Feedback

Gets the installed assembly names.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property InstalledNames As String()
C#
[OutputAttribute]
public string[] InstalledNames { get; }
Visual C++
[OutputAttribute]
public:
property array<String^>^ InstalledNames {
    array<String^>^ get ();
}

Field Value

The installed names.

See Also

GacUtil Class
MSBuild.Community.Tasks Namespace


InstalledPaths Property

[image]

.NET Framework Class Library
GacUtil..::.InstalledPaths Property
GacUtil Class See Also Send Feedback

Gets the installed assembly paths.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property InstalledPaths As ITaskItem()
C#
[OutputAttribute]
public ITaskItem[] InstalledPaths { get; }
Visual C++
[OutputAttribute]
public:
property array<ITaskItem^>^ InstalledPaths {
    array<ITaskItem^>^ get ();
}

Field Value

The installed paths.

See Also

GacUtil Class
MSBuild.Community.Tasks Namespace


Quiet Property

[image]

.NET Framework Class Library
GacUtil..::.Quiet Property
GacUtil Class See Also Send Feedback

Gets or sets a value indicating whether warning messages are output.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Quiet As Boolean
C#
public bool Quiet { get; set; }
Visual C++
public:
property bool Quiet {
    bool get ();
    void set (bool value);
}

Field Value

true to not log warning messages; otherwise, false.

See Also

GacUtil Class
MSBuild.Community.Tasks Namespace


RelatedFileExtensions Property

[image]

.NET Framework Class Library
GacUtil..::.RelatedFileExtensions Property
GacUtil Class See Also Send Feedback

Gets or sets the related file extensions to copy when IncludeRelatedFiles is true.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property RelatedFileExtensions As String()
C#
public string[] RelatedFileExtensions { get; set; }
Visual C++
public:
property array<String^>^ RelatedFileExtensions {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Field Value

The related file extensions.

Remarks

The default extensions are .pdb and .xml.

See Also

GacUtil Class
MSBuild.Community.Tasks Namespace


Skipped Property

[image]

.NET Framework Class Library
GacUtil..::.Skipped Property
GacUtil Class See Also Send Feedback

Gets the number of assemblies that were skipped during installed/uninstalled.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property Skipped As Integer
C#
[OutputAttribute]
public int Skipped { get; }
Visual C++
[OutputAttribute]
public:
property int Skipped {
    int get ();
}

Field Value

The number of skipped assemblies.

See Also

GacUtil Class
MSBuild.Community.Tasks Namespace


Successful Property

[image]

.NET Framework Class Library
GacUtil..::.Successful Property
GacUtil Class See Also Send Feedback

Gets the number of assemblies successfully installed/uninstalled.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property Successful As Integer
C#
[OutputAttribute]
public int Successful { get; }
Visual C++
[OutputAttribute]
public:
property int Successful {
    int get ();
}

Field Value

The number successful assemblies.

See Also

GacUtil Class
MSBuild.Community.Tasks Namespace


GacUtilCommands Enumeration

[image]

.NET Framework Class Library
GacUtilCommands Enumeration
See Also Send Feedback

The list of the commands available to the GacUtil Task

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration GacUtilCommands
C#
public enum GacUtilCommands
Visual C++
public enum class GacUtilCommands

Members

Member name | Description
Install | Install the list of assemblies into the GAC.
Uninstall | Uninstall the list of assembly names from the GAC.

See Also

MSBuild.Community.Tasks Namespace


GetSolutionProjects Class

[image]

.NET Framework Class Library
GetSolutionProjects Class
Members Example See Also Send Feedback

Retrieves the list of Projects contained within a Visual Studio Solution (.sln) file

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class GetSolutionProjects _
    Inherits Task
C#
public class GetSolutionProjects : Task
Visual C++
public ref class GetSolutionProjects : public Task

Examples

Returns project name, GUID, and path information from test solution
Copy Code
              <Target Name="Test">
                  <GetSolutionProjects Solution="TestSolution.sln">
                      <Output ItemName="ProjectFiles" TaskParameter="Output"/>
                  </GetSolutionProjects>

                <Message Text="Project names:" />
                <Message Text="%(ProjectFiles.ProjectName)" />
                <Message Text="Relative project paths:" />
                <Message Text="%(ProjectFiles.ProjectPath)" />
                <Message Text="Project GUIDs:" />
                <Message Text="%(ProjectFiles.ProjectGUID)" />
                <Message Text="Full paths to project files:" />
                <Message Text="%(ProjectFiles.FullPath)" />
              </Target>

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks..::.GetSolutionProjects

See Also

GetSolutionProjects Members
MSBuild.Community.Tasks Namespace


GetSolutionProjects Members

[image] [image]

.NET Framework Class Library
GetSolutionProjects Members
GetSolutionProjects Class Constructors Methods Properties See Also Send Feedback

The GetSolutionProjects type exposes the following members.

Constructors

Name | Description
GetSolutionProjects |

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | Perform task (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
Output | A list of the project files found in Solution
Solution | Name of Solution to get Projects from
TaskResources | (Inherited from Task.)

See Also

GetSolutionProjects Class
MSBuild.Community.Tasks Namespace


GetSolutionProjects Constructor

[image]

.NET Framework Class Library
GetSolutionProjects Constructor
GetSolutionProjects Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public GetSolutionProjects()
Visual C++
public:
GetSolutionProjects()

See Also

GetSolutionProjects Class
MSBuild.Community.Tasks Namespace


GetSolutionProjects Methods

[image] [image]

.NET Framework Class Library
GetSolutionProjects Methods
GetSolutionProjects Class See Also Send Feedback

The GetSolutionProjects type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | Perform task (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

GetSolutionProjects Class
MSBuild.Community.Tasks Namespace


Execute Method

[image]

.NET Framework Class Library
GetSolutionProjects..::.Execute Method
GetSolutionProjects Class See Also Send Feedback

Perform task

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

true on success

Implements

ITask..::.Execute()()()

See Also

GetSolutionProjects Class
MSBuild.Community.Tasks Namespace


GetSolutionProjects Properties

[image] [image]

.NET Framework Class Library
GetSolutionProjects Properties
GetSolutionProjects Class See Also Send Feedback

The GetSolutionProjects type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
Output | A list of the project files found in Solution
Solution | Name of Solution to get Projects from
TaskResources | (Inherited from Task.)

See Also

GetSolutionProjects Class
MSBuild.Community.Tasks Namespace


Output Property

[image]

.NET Framework Class Library
GetSolutionProjects..::.Output Property
GetSolutionProjects Class See Also Send Feedback

A list of the project files found in Solution

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public Property Output As ITaskItem()
C#
[OutputAttribute]
public ITaskItem[] Output { get; set; }
Visual C++
[OutputAttribute]
public:
property array<ITaskItem^>^ Output {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

Remarks

The name of the project can be retrieved by reading metadata tag ProjectName.

The path to the project as it is is stored in the solution file retrieved by reading metadata tag ProjectPath.

The project's GUID can be retrieved by reading metadata tag ProjectGUID.

See Also

GetSolutionProjects Class
MSBuild.Community.Tasks Namespace


Solution Property

[image]

.NET Framework Class Library
GetSolutionProjects..::.Solution Property
GetSolutionProjects Class See Also Send Feedback

Name of Solution to get Projects from

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property Solution As String
C#
[RequiredAttribute]
public string Solution { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ Solution {
    String^ get ();
    void set (String^ value);
}

See Also

GetSolutionProjects Class
MSBuild.Community.Tasks Namespace


IFtpWebRequest Interface

[image]

.NET Framework Class Library
IFtpWebRequest Interface
Members See Also Send Feedback

This class references an interface that looks like FtpWebRequest in order to support unit testing without an actual FTP Server.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Interface IFtpWebRequest
C#
public interface IFtpWebRequest
Visual C++
public interface class IFtpWebRequest

See Also

IFtpWebRequest Members
MSBuild.Community.Tasks Namespace


IFtpWebRequest Members

[image] [image]

.NET Framework Class Library
IFtpWebRequest Members
IFtpWebRequest Interface Methods See Also Send Feedback

The IFtpWebRequest type exposes the following members.

Methods

Name | Description
GetAndCloseResponse | Gets the response from the FTP server and closes it.
GetRequestStream | Calls GetRequestStream on the FtpWebRequest.
GetResponseStream | Gets the response stream from the FtpWebRequest.
GetStatusDescriptionAndCloseResponse | Gets the StatusDescription property of the response, then closes the response on the FtpWebRequest.
SetContentLength | Sets the ContentLength property of the FtpWebRequest.

See Also

IFtpWebRequest Interface
MSBuild.Community.Tasks Namespace


IFtpWebRequest Methods

[image] [image]

.NET Framework Class Library
IFtpWebRequest Methods
IFtpWebRequest Interface See Also Send Feedback

The IFtpWebRequest type exposes the following members.

Methods

Name | Description
GetAndCloseResponse | Gets the response from the FTP server and closes it.
GetRequestStream | Calls GetRequestStream on the FtpWebRequest.
GetResponseStream | Gets the response stream from the FtpWebRequest.
GetStatusDescriptionAndCloseResponse | Gets the StatusDescription property of the response, then closes the response on the FtpWebRequest.
SetContentLength | Sets the ContentLength property of the FtpWebRequest.

See Also

IFtpWebRequest Interface
MSBuild.Community.Tasks Namespace


GetAndCloseResponse Method

[image]

.NET Framework Class Library
IFtpWebRequest..::.GetAndCloseResponse Method
IFtpWebRequest Interface See Also Send Feedback

Gets the response from the FTP server and closes it.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Sub GetAndCloseResponse
C#
void GetAndCloseResponse()
Visual C++
void GetAndCloseResponse()

See Also

IFtpWebRequest Interface
MSBuild.Community.Tasks Namespace


GetRequestStream Method

[image]

.NET Framework Class Library
IFtpWebRequest..::.GetRequestStream Method
IFtpWebRequest Interface See Also Send Feedback

Calls GetRequestStream on the FtpWebRequest.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Function GetRequestStream As Stream
C#
Stream GetRequestStream()
Visual C++
Stream^ GetRequestStream()

Return Value

See Also

IFtpWebRequest Interface
MSBuild.Community.Tasks Namespace


GetResponseStream Method

[image]

.NET Framework Class Library
IFtpWebRequest..::.GetResponseStream Method
IFtpWebRequest Interface See Also Send Feedback

Gets the response stream from the FtpWebRequest.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Function GetResponseStream As Stream
C#
Stream GetResponseStream()
Visual C++
Stream^ GetResponseStream()

Return Value

See Also

IFtpWebRequest Interface
MSBuild.Community.Tasks Namespace


GetStatusDescriptionAndCloseResponse Method

[image]

.NET Framework Class Library
IFtpWebRequest..::.GetStatusDescriptionAndCloseResponse Method
IFtpWebRequest Interface See Also Send Feedback

Gets the StatusDescription property of the response, then closes the response on the FtpWebRequest.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Function GetStatusDescriptionAndCloseResponse As String
C#
string GetStatusDescriptionAndCloseResponse()
Visual C++
String^ GetStatusDescriptionAndCloseResponse()

Return Value

See Also

IFtpWebRequest Interface
MSBuild.Community.Tasks Namespace


SetContentLength Method

[image]

.NET Framework Class Library
IFtpWebRequest..::.SetContentLength Method
IFtpWebRequest Interface See Also Send Feedback

Sets the ContentLength property of the FtpWebRequest.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Sub SetContentLength ( _
    length As Long _
)
C#
void SetContentLength(
    long length
)
Visual C++
void SetContentLength(
    long long length
)

Parameters

length
Type: System..::.Int64

See Also

IFtpWebRequest Interface
MSBuild.Community.Tasks Namespace


IFtpWebRequestCreator Interface

[image]

.NET Framework Class Library
IFtpWebRequestCreator Interface
Members See Also Send Feedback

Describes a factory for IFtpWebRequest.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Interface IFtpWebRequestCreator
C#
public interface IFtpWebRequestCreator
Visual C++
public interface class IFtpWebRequestCreator

See Also

IFtpWebRequestCreator Members
MSBuild.Community.Tasks Namespace


IFtpWebRequestCreator Members

[image] [image]

.NET Framework Class Library
IFtpWebRequestCreator Members
IFtpWebRequestCreator Interface Methods See Also Send Feedback

The IFtpWebRequestCreator type exposes the following members.

Methods

Name | Description
Create | Instantiates an FtpWebRequest.

See Also

IFtpWebRequestCreator Interface
MSBuild.Community.Tasks Namespace


IFtpWebRequestCreator Methods

[image] [image]

.NET Framework Class Library
IFtpWebRequestCreator Methods
IFtpWebRequestCreator Interface See Also Send Feedback

The IFtpWebRequestCreator type exposes the following members.

Methods

Name | Description
Create | Instantiates an FtpWebRequest.

See Also

IFtpWebRequestCreator Interface
MSBuild.Community.Tasks Namespace


Create Method

[image]

.NET Framework Class Library
IFtpWebRequestCreator..::.Create Method
IFtpWebRequestCreator Interface See Also Send Feedback

Instantiates an FtpWebRequest.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Function Create ( _
    uri As Uri, _
    method As String _
) As IFtpWebRequest
C#
IFtpWebRequest Create(
    Uri uri,
    string method
)
Visual C++
IFtpWebRequest^ Create(
    Uri^ uri,
    String^ method
)

Parameters

uri
Type: System..::.Uri
method
Type: System..::.String

See Also

IFtpWebRequestCreator Interface
MSBuild.Community.Tasks Namespace


ILMerge Class

[image]

.NET Framework Class Library
ILMerge Class
Members Example See Also Send Feedback

A wrapper for the ILMerge tool.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class ILMerge _
    Inherits ToolTask
C#
public class ILMerge : ToolTask
Visual C++
public ref class ILMerge : public ToolTask

Remarks

The ILMerge tool itself must be installed separately. It is available here.

The command line options "/wildcards" and "/lib" of ILMerge are not supported, because MSBuild is in charge of expanding wildcards for item groups.

Examples

This example merges two assemblies A.dll and B.dll into one:
Copy Code
             <PropertyGroup>
                 <outputFile>$(testDir)\ilmergetest.dll</outputFile>
                 <keyFile>$(testDir)\keypair.snk</keyFile>
                 <excludeFile>$(testDir)\ExcludeTypes.txt</excludeFile>
                 <logFile>$(testDir)\ilmergetest.log</logFile>
             </PropertyGroup>

             <ItemGroup>
                 <inputAssemblies Include="$(testDir)\A.dll" />
                 <inputAssemblies Include="$(testDir)\B.dll" />

                 <allowDuplicates Include="ClassAB" />
             </ItemGroup>

             <Target Name="merge" >
                <ILMerge InputAssemblies="@(inputAssemblies)"
                    AllowDuplicateTypes="@(allowDuplicates)"
                    ExcludeFile="$(excludeFile)"
                    OutputFile="$(outputFile)" LogFile="$(logFile)"
                    DebugInfo="true" XmlDocumentation="true"
                    KeyFile="$(keyFile)" DelaySign="true" />
             </Target>

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
Microsoft.Build.Utilities..::.ToolTask
MSBuild.Community.Tasks..::.ILMerge

See Also

ILMerge Members
MSBuild.Community.Tasks Namespace


ILMerge Members

[image] [image]

.NET Framework Class Library
ILMerge Members
ILMerge Class Constructors Methods Properties See Also Send Feedback

The ILMerge type exposes the following members.

Constructors

Name | Description
ILMerge | Initializes a new instance of the ILMerge class.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from ToolTask.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Gets the standard installation path of ILMerge.exe. (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | (Inherited from ToolTask.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | (Inherited from ToolTask.)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

Properties

Name | Description
AllowDuplicateTypes | Gets or sets the names of public types to be renamed when they are duplicates.
AllowZeroPeKind | Gets or sets the flag to treat an assembly with a zero PeKind flag (this is the value of the field listed as .corflags in the Manifest) as if it was ILonly.
AttributeFile | Gets or sets the attribute assembly from whre to get all of the assembly-level attributes such as Culture, Version, etc. It will also be used to get the Win32 Resources from.
BuildEngine | (Inherited from Task.)
Closed | Gets or sets the flag to indicate whether to augment the list of input assemblies to its "transitive closure".
CopyAttributes | Gets or sets the flag to indicate whether to copy the assembly level attributes of each input assembly over into the target assembly.
DebugInfo | Gets or sets the flag to indicate whether to preserve any .pdb files that are found for the input assemblies into a .pdb file for the target assembly.
DelaySign | Gets or sets the flag to indicate whether the target assembly will be delay signed.
EnvironmentOverride | (Inherited from ToolTask.)
ExcludeFile | Gets or sets the file that will be used to identify types that are not to have their visibility modified.
ExitCode | (Inherited from ToolTask.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
InputAssemblies | Gets or sets the input assemblies to merge.
Internalize | Gets or sets a value indicating whether whether types in assemblies other than the primary assembly have their visibility modified.
KeyFile | Gets or sets the .snk file to sign the target assembly.
Log | (Inherited from Task.)
LogFile | Gets or sets a log file to write log messages to.
OutputFile | Gets or sets the target assembly.
PublicKeyTokens | Gets or sets the flag to indicate whether external assembly references in the manifest of the target assembly will use public keys (false) or public key tokens (true).
ResponseFileEncoding | (Inherited from ToolTask.)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | (Inherited from ToolTask.)
TargetKind | Gets or sets the indicator whether the target assembly is created as a library (Dll), a console application (Exe) or as a Windows application (WinExe).
TargetPlatformDirectory | Gets or sets the directory in which mscorlib.dll is to be found.
TargetPlatformVersion | Gets or sets the .NET framework version for the target assembly.
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)
Version | Gets or sets the version number of the target assembly.
XmlDocumentation | Gets or sets the flag to indicate whether to merge XML documentation files into one for the target assembly.

See Also

ILMerge Class
MSBuild.Community.Tasks Namespace


ILMerge Constructor

[image]

.NET Framework Class Library
ILMerge Constructor
ILMerge Class See Also Send Feedback

Initializes a new instance of the ILMerge class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ILMerge()
Visual C++
public:
ILMerge()

See Also

ILMerge Class
MSBuild.Community.Tasks Namespace


ILMerge Methods

[image] [image]

.NET Framework Class Library
ILMerge Methods
ILMerge Class See Also Send Feedback

The ILMerge type exposes the following members.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from ToolTask.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Gets the standard installation path of ILMerge.exe. (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | (Inherited from ToolTask.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | (Inherited from ToolTask.)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

See Also

ILMerge Class
MSBuild.Community.Tasks Namespace


GenerateCommandLineCommands Method

[image]

.NET Framework Class Library
ILMerge..::.GenerateCommandLineCommands Method
ILMerge Class See Also Send Feedback

Returns a string value containing the command line arguments to pass directly to the executable file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateCommandLineCommands As String
C#
protected override string GenerateCommandLineCommands()
Visual C++
protected:
virtual String^ GenerateCommandLineCommands() override

Return Value

Returns a string value containing the command line arguments to pass directly to the executable file.

See Also

ILMerge Class
MSBuild.Community.Tasks Namespace


GenerateFullPathToTool Method

[image]

.NET Framework Class Library
ILMerge..::.GenerateFullPathToTool Method
ILMerge Class See Also Send Feedback

Gets the standard installation path of ILMerge.exe.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateFullPathToTool As String
C#
protected override string GenerateFullPathToTool()
Visual C++
protected:
virtual String^ GenerateFullPathToTool() override

Return Value

Returns [ProgramFiles]\Microsoft\ILMerge.exe.

Remarks

If ILMerge is not installed at its standard installation path, provide its location to ToolPath.

See Also

ILMerge Class
MSBuild.Community.Tasks Namespace


ILMerge Properties

[image] [image]

.NET Framework Class Library
ILMerge Properties
ILMerge Class See Also Send Feedback

The ILMerge type exposes the following members.

Properties

Name | Description
AllowDuplicateTypes | Gets or sets the names of public types to be renamed when they are duplicates.
AllowZeroPeKind | Gets or sets the flag to treat an assembly with a zero PeKind flag (this is the value of the field listed as .corflags in the Manifest) as if it was ILonly.
AttributeFile | Gets or sets the attribute assembly from whre to get all of the assembly-level attributes such as Culture, Version, etc. It will also be used to get the Win32 Resources from.
BuildEngine | (Inherited from Task.)
Closed | Gets or sets the flag to indicate whether to augment the list of input assemblies to its "transitive closure".
CopyAttributes | Gets or sets the flag to indicate whether to copy the assembly level attributes of each input assembly over into the target assembly.
DebugInfo | Gets or sets the flag to indicate whether to preserve any .pdb files that are found for the input assemblies into a .pdb file for the target assembly.
DelaySign | Gets or sets the flag to indicate whether the target assembly will be delay signed.
EnvironmentOverride | (Inherited from ToolTask.)
ExcludeFile | Gets or sets the file that will be used to identify types that are not to have their visibility modified.
ExitCode | (Inherited from ToolTask.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
InputAssemblies | Gets or sets the input assemblies to merge.
Internalize | Gets or sets a value indicating whether whether types in assemblies other than the primary assembly have their visibility modified.
KeyFile | Gets or sets the .snk file to sign the target assembly.
Log | (Inherited from Task.)
LogFile | Gets or sets a log file to write log messages to.
OutputFile | Gets or sets the target assembly.
PublicKeyTokens | Gets or sets the flag to indicate whether external assembly references in the manifest of the target assembly will use public keys (false) or public key tokens (true).
ResponseFileEncoding | (Inherited from ToolTask.)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | (Inherited from ToolTask.)
TargetKind | Gets or sets the indicator whether the target assembly is created as a library (Dll), a console application (Exe) or as a Windows application (WinExe).
TargetPlatformDirectory | Gets or sets the directory in which mscorlib.dll is to be found.
TargetPlatformVersion | Gets or sets the .NET framework version for the target assembly.
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)
Version | Gets or sets the version number of the target assembly.
XmlDocumentation | Gets or sets the flag to indicate whether to merge XML documentation files into one for the target assembly.

See Also

ILMerge Class
MSBuild.Community.Tasks Namespace


AllowDuplicateTypes Property

[image]

.NET Framework Class Library
ILMerge..::.AllowDuplicateTypes Property
ILMerge Class See Also Send Feedback

Gets or sets the names of public types to be renamed when they are duplicates.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AllowDuplicateTypes As ITaskItem()
C#
public ITaskItem[] AllowDuplicateTypes { get; set; }
Visual C++
public:
property array<ITaskItem^>^ AllowDuplicateTypes {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

Remarks

Set to an empty item group to allow all public types to be renamed.

Don't provide this parameter if no duplicates of public types are allowed.

Corresponds to command line option "/allowDup".

The default value is null.

See Also

ILMerge Class
MSBuild.Community.Tasks Namespace


AllowZeroPeKind Property

[image]

.NET Framework Class Library
ILMerge..::.AllowZeroPeKind Property
ILMerge Class See Also Send Feedback

Gets or sets the flag to treat an assembly with a zero PeKind flag (this is the value of the field listed as .corflags in the Manifest) as if it was ILonly.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AllowZeroPeKind As Boolean
C#
public bool AllowZeroPeKind { get; set; }
Visual C++
public:
property bool AllowZeroPeKind {
    bool get ();
    void set (bool value);
}

Remarks

Corresponds to command line option "/zeroPeKind".

The default value is false.

See Also

ILMerge Class
MSBuild.Community.Tasks Namespace


AttributeFile Property

[image]

.NET Framework Class Library
ILMerge..::.AttributeFile Property
ILMerge Class See Also Send Feedback

Gets or sets the attribute assembly from whre to get all of the assembly-level attributes such as Culture, Version, etc. It will also be used to get the Win32 Resources from.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AttributeFile As ITaskItem
C#
public ITaskItem AttributeFile { get; set; }
Visual C++
public:
property ITaskItem^ AttributeFile {
    ITaskItem^ get ();
    void set (ITaskItem^ value);
}

Remarks

This property is mutually exclusive with CopyAttributes.

When not specified, then the Win32 Resources from the primary assembly are copied over into the target assembly.

Corresponds to command line option "/attr".

The default value is null.

See Also

ILMerge Class
MSBuild.Community.Tasks Namespace


Closed Property

[image]

.NET Framework Class Library
ILMerge..::.Closed Property
ILMerge Class See Also Send Feedback

Gets or sets the flag to indicate whether to augment the list of input assemblies to its "transitive closure".

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Closed As Boolean
C#
public bool Closed { get; set; }
Visual C++
public:
property bool Closed {
    bool get ();
    void set (bool value);
}

Remarks

An assembly is considered part of the transitive closure if it is referenced, either directly or indirectly, from one of the originally specified input assemblies and it has an external reference to one of the input assemblies, or one of the assemblies that has such a reference.

Corresponds to command line option "/closed".

The default value is false.

See Also

ILMerge Class
MSBuild.Community.Tasks Namespace


CopyAttributes Property

[image]

.NET Framework Class Library
ILMerge..::.CopyAttributes Property
ILMerge Class See Also Send Feedback

Gets or sets the flag to indicate whether to copy the assembly level attributes of each input assembly over into the target assembly.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property CopyAttributes As Boolean
C#
public bool CopyAttributes { get; set; }
Visual C++
public:
property bool CopyAttributes {
    bool get ();
    void set (bool value);
}

Remarks

Any duplicate attribute overwrites a previously copied attribute. The input assemblies are processed in the order they are specified.

This parameter is mutually exclusive with AttributeFile.

Corresponds to command line option "/copyattrs".

The default value is false.

See Also

ILMerge Class
MSBuild.Community.Tasks Namespace


DebugInfo Property

[image]

.NET Framework Class Library
ILMerge..::.DebugInfo Property
ILMerge Class See Also Send Feedback

Gets or sets the flag to indicate whether to preserve any .pdb files that are found for the input assemblies into a .pdb file for the target assembly.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property DebugInfo As Boolean
C#
public bool DebugInfo { get; set; }
Visual C++
public:
property bool DebugInfo {
    bool get ();
    void set (bool value);
}

Remarks

Corresponds to command line option "/ndebug".

The default value is true.

See Also

ILMerge Class
MSBuild.Community.Tasks Namespace


DelaySign Property

[image]

.NET Framework Class Library
ILMerge..::.DelaySign Property
ILMerge Class See Also Send Feedback

Gets or sets the flag to indicate whether the target assembly will be delay signed.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property DelaySign As Boolean
C#
public bool DelaySign { get; set; }
Visual C++
public:
property bool DelaySign {
    bool get ();
    void set (bool value);
}

Remarks

This property can be set only in conjunction with KeyFile.

Corresponds to command line option "/delaysign".

The default value is false.

See Also

ILMerge Class
MSBuild.Community.Tasks Namespace


ExcludeFile Property

[image]

.NET Framework Class Library
ILMerge..::.ExcludeFile Property
ILMerge Class See Also Send Feedback

Gets or sets the file that will be used to identify types that are not to have their visibility modified.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ExcludeFile As ITaskItem
C#
public ITaskItem ExcludeFile { get; set; }
Visual C++
public:
property ITaskItem^ ExcludeFile {
    ITaskItem^ get ();
    void set (ITaskItem^ value);
}

Remarks

If an empty item group is provided, then all types in any assembly other than the primary assembly are made non-public.

Omit this parameter to prevent ILMerge from modifying the visibility of any types.

The contents of the file should be one Regex per line. The regular expressions are matched against each type's full name, e.g., System.Collections.IList. If the match fails, it is tried again with the assembly name (surrounded by square brackets) prepended to the type name. Thus, the pattern \[A\].* excludes all types in assembly A from being made non-public. The pattern N.T will match all types named T in the namespace named N no matter what assembly they are defined in.

Corresponds to command line option "/internalize".

The default value is null.

See Also

ILMerge Class
MSBuild.Community.Tasks Namespace


InputAssemblies Property

[image]

.NET Framework Class Library
ILMerge..::.InputAssemblies Property
ILMerge Class See Also Send Feedback

Gets or sets the input assemblies to merge.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property InputAssemblies As ITaskItem()
C#
[RequiredAttribute]
public ITaskItem[] InputAssemblies { get; set; }
Visual C++
[RequiredAttribute]
public:
property array<ITaskItem^>^ InputAssemblies {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

See Also

ILMerge Class
MSBuild.Community.Tasks Namespace


Internalize Property

[image]

.NET Framework Class Library
ILMerge..::.Internalize Property
ILMerge Class See Also Send Feedback

Gets or sets a value indicating whether whether types in assemblies other than the primary assembly have their visibility modified.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Internalize As Boolean
C#
public bool Internalize { get; set; }
Visual C++
public:
property bool Internalize {
    bool get ();
    void set (bool value);
}

Field Value

true if internalize; otherwise, false.

Remarks

This controls whether types in assemblies other than the primary assembly have their visibility modified. When it is true, then all non-exempt types that are visible outside of their assembly have their visibility modified so that they are not visible from outside of the merged assembly. A type is exempt if its full name matches a line from the ExcludeFile (Section 2.9) using the .NET regular expression engine.

Corresponds to command line option "/internalize".

The default value is false.

See Also

ILMerge Class
MSBuild.Community.Tasks Namespace


KeyFile Property

[image]

.NET Framework Class Library
ILMerge..::.KeyFile Property
ILMerge Class See Also Send Feedback

Gets or sets the .snk file to sign the target assembly.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property KeyFile As ITaskItem
C#
public ITaskItem KeyFile { get; set; }
Visual C++
public:
property ITaskItem^ KeyFile {
    ITaskItem^ get ();
    void set (ITaskItem^ value);
}

Remarks

Can be used with DelaySign.

Corresponds to command line option "/keyfile".

The default value is null.

See Also

ILMerge Class
MSBuild.Community.Tasks Namespace


LogFile Property

[image]

.NET Framework Class Library
ILMerge..::.LogFile Property
ILMerge Class See Also Send Feedback

Gets or sets a log file to write log messages to.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property LogFile As ITaskItem
C#
public ITaskItem LogFile { get; set; }
Visual C++
public:
property ITaskItem^ LogFile {
    ITaskItem^ get ();
    void set (ITaskItem^ value);
}

Remarks

If an empty item group is provided, then log messages are writte to Out.

Corresponds to command line option "/log".

The default value is null.

See Also

ILMerge Class
MSBuild.Community.Tasks Namespace


OutputFile Property

[image]

.NET Framework Class Library
ILMerge..::.OutputFile Property
ILMerge Class See Also Send Feedback

Gets or sets the target assembly.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property OutputFile As ITaskItem
C#
[RequiredAttribute]
public ITaskItem OutputFile { get; set; }
Visual C++
[RequiredAttribute]
public:
property ITaskItem^ OutputFile {
    ITaskItem^ get ();
    void set (ITaskItem^ value);
}

Remarks

Corresponds to command line option "/out".

See Also

ILMerge Class
MSBuild.Community.Tasks Namespace


PublicKeyTokens Property

[image]

.NET Framework Class Library
ILMerge..::.PublicKeyTokens Property
ILMerge Class See Also Send Feedback

Gets or sets the flag to indicate whether external assembly references in the manifest of the target assembly will use public keys (false) or public key tokens (true).

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property PublicKeyTokens As Boolean
C#
public bool PublicKeyTokens { get; set; }
Visual C++
public:
property bool PublicKeyTokens {
    bool get ();
    void set (bool value);
}

Remarks

Corresponds to command line option "/publickeytokens".

The default value is false.

See Also

ILMerge Class
MSBuild.Community.Tasks Namespace


TargetKind Property

[image]

.NET Framework Class Library
ILMerge..::.TargetKind Property
ILMerge Class See Also Send Feedback

Gets or sets the indicator whether the target assembly is created as a library (Dll), a console application (Exe) or as a Windows application (WinExe).

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property TargetKind As String
C#
public string TargetKind { get; set; }
Visual C++
public:
property String^ TargetKind {
    String^ get ();
    void set (String^ value);
}

Remarks

Corresponds to command line option "/target".

The default value is the same kind as that of the primary assembly.

See Also

ILMerge Class
MSBuild.Community.Tasks Namespace


TargetPlatformDirectory Property

[image]

.NET Framework Class Library
ILMerge..::.TargetPlatformDirectory Property
ILMerge Class See Also Send Feedback

Gets or sets the directory in which mscorlib.dll is to be found.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property TargetPlatformDirectory As ITaskItem
C#
public ITaskItem TargetPlatformDirectory { get; set; }
Visual C++
public:
property ITaskItem^ TargetPlatformDirectory {
    ITaskItem^ get ();
    void set (ITaskItem^ value);
}

Remarks

Can only be used in conjunction with TargetPlatformVersion.

Corresponds to the second part of command line option "/targetplatform".

The default value is null.

See Also

ILMerge Class
MSBuild.Community.Tasks Namespace


TargetPlatformVersion Property

[image]

.NET Framework Class Library
ILMerge..::.TargetPlatformVersion Property
ILMerge Class See Also Send Feedback

Gets or sets the .NET framework version for the target assembly.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property TargetPlatformVersion As String
C#
public string TargetPlatformVersion { get; set; }
Visual C++
public:
property String^ TargetPlatformVersion {
    String^ get ();
    void set (String^ value);
}

Remarks

Valid values are "v1", "v1.1", "v2".

Corresponds to the first part of command line option "/targetplatform".

The default value is null.

See Also

ILMerge Class
MSBuild.Community.Tasks Namespace


ToolName Property

[image]

.NET Framework Class Library
ILMerge..::.ToolName Property
ILMerge Class See Also Send Feedback

Gets the name of the executable file to run.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ToolName As String
C#
protected override string ToolName { get; }
Visual C++
protected:
virtual property String^ ToolName {
    String^ get () override;
}

See Also

ILMerge Class
MSBuild.Community.Tasks Namespace


Version Property

[image]

.NET Framework Class Library
ILMerge..::.Version Property
ILMerge Class See Also Send Feedback

Gets or sets the version number of the target assembly.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Version As String
C#
public string Version { get; set; }
Visual C++
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}

Remarks

The parameter should look like 6.2.1.3.

Corresponds to command line option "/ver".

The default value is null.

See Also

ILMerge Class
MSBuild.Community.Tasks Namespace


XmlDocumentation Property

[image]

.NET Framework Class Library
ILMerge..::.XmlDocumentation Property
ILMerge Class See Also Send Feedback

Gets or sets the flag to indicate whether to merge XML documentation files into one for the target assembly.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property XmlDocumentation As Boolean
C#
public bool XmlDocumentation { get; set; }
Visual C++
public:
property bool XmlDocumentation {
    bool get ();
    void set (bool value);
}

Remarks

Corresponds to command line option "/xmldocs".

The default value is false.

See Also

ILMerge Class
MSBuild.Community.Tasks Namespace


InnoSetup Class

[image]

.NET Framework Class Library
InnoSetup Class
Members Example See Also Send Feedback

MSBuild task to create installer with InnoSetup

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class InnoSetup _
    Inherits ToolTask
C#
public class InnoSetup : ToolTask
Visual C++
public ref class InnoSetup : public ToolTask

Examples

Create installer
Copy Code
                <InnoSetup
                    ScriptFile="setup.iss"
                    OutputFileName="MySetup.exe"
                    OutputPath="C:\SetupDir"
                    Quiet="True" />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
Microsoft.Build.Utilities..::.ToolTask
MSBuild.Community.Tasks..::.InnoSetup

See Also

InnoSetup Members
MSBuild.Community.Tasks Namespace


InnoSetup Members

[image] [image]

.NET Framework Class Library
InnoSetup Members
InnoSetup Class Constructors Methods Properties See Also Send Feedback

The InnoSetup type exposes the following members.

Constructors

Name | Description
InnoSetup |

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Overrides ToolTask..::.Execute()()().)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | (Inherited from ToolTask.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Overrides ToolTask..::.LogToolCommand(String).)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
OutputFileName | Specify output filename
OutputPath | Specify output path
Quiet | Quiet compile
ResponseFileEncoding | (Inherited from ToolTask.)
ScriptFile | Filename of Inno Setup script (.iss)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Overrides ToolTask..::.StandardOutputLoggingImportance.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)

See Also

InnoSetup Class
MSBuild.Community.Tasks Namespace


InnoSetup Constructor

[image]

.NET Framework Class Library
InnoSetup Constructor
InnoSetup Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public InnoSetup()
Visual C++
public:
InnoSetup()

See Also

InnoSetup Class
MSBuild.Community.Tasks Namespace


InnoSetup Methods

[image] [image]

.NET Framework Class Library
InnoSetup Methods
InnoSetup Class See Also Send Feedback

The InnoSetup type exposes the following members.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Overrides ToolTask..::.Execute()()().)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | (Inherited from ToolTask.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Overrides ToolTask..::.LogToolCommand(String).)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

See Also

InnoSetup Class
MSBuild.Community.Tasks Namespace


Execute Method

[image]

.NET Framework Class Library
InnoSetup..::.Execute Method
InnoSetup Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

Implements

ITask..::.Execute()()()

See Also

InnoSetup Class
MSBuild.Community.Tasks Namespace


GenerateCommandLineCommands Method

[image]

.NET Framework Class Library
InnoSetup..::.GenerateCommandLineCommands Method
InnoSetup Class See Also Send Feedback

Returns a string value containing the command line arguments to pass directly to the executable file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateCommandLineCommands As String
C#
protected override string GenerateCommandLineCommands()
Visual C++
protected:
virtual String^ GenerateCommandLineCommands() override

Return Value

A string value containing the command line arguments to pass directly to the executable file.

See Also

InnoSetup Class
MSBuild.Community.Tasks Namespace


GenerateFullPathToTool Method

[image]

.NET Framework Class Library
InnoSetup..::.GenerateFullPathToTool Method
InnoSetup Class See Also Send Feedback

Returns the fully qualified path to the executable file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateFullPathToTool As String
C#
protected override string GenerateFullPathToTool()
Visual C++
protected:
virtual String^ GenerateFullPathToTool() override

Return Value

The fully qualified path to the executable file.

See Also

InnoSetup Class
MSBuild.Community.Tasks Namespace


LogToolCommand Method

[image]

.NET Framework Class Library
InnoSetup..::.LogToolCommand Method
InnoSetup Class See Also Send Feedback

Logs the starting point of the run to all registered loggers.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub LogToolCommand ( _
    message As String _
)
C#
protected override void LogToolCommand(
    string message
)
Visual C++
protected:
virtual void LogToolCommand(
    String^ message
) override

Parameters

message
Type: System..::.String
A descriptive message to provide loggers, usually the command line and switches.

See Also

InnoSetup Class
MSBuild.Community.Tasks Namespace


InnoSetup Properties

[image] [image]

.NET Framework Class Library
InnoSetup Properties
InnoSetup Class See Also Send Feedback

The InnoSetup type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
OutputFileName | Specify output filename
OutputPath | Specify output path
Quiet | Quiet compile
ResponseFileEncoding | (Inherited from ToolTask.)
ScriptFile | Filename of Inno Setup script (.iss)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Overrides ToolTask..::.StandardOutputLoggingImportance.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)

See Also

InnoSetup Class
MSBuild.Community.Tasks Namespace


OutputFileName Property

[image]

.NET Framework Class Library
InnoSetup..::.OutputFileName Property
InnoSetup Class See Also Send Feedback

Specify output filename

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property OutputFileName As String
C#
public string OutputFileName { get; set; }
Visual C++
public:
property String^ OutputFileName {
    String^ get ();
    void set (String^ value);
}

Field Value

Name for setup, examples: MySetup.exe

See Also

InnoSetup Class
MSBuild.Community.Tasks Namespace


OutputPath Property

[image]

.NET Framework Class Library
InnoSetup..::.OutputPath Property
InnoSetup Class See Also Send Feedback

Specify output path

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property OutputPath As String
C#
public string OutputPath { get; set; }
Visual C++
public:
property String^ OutputPath {
    String^ get ();
    void set (String^ value);
}

Field Value

Path for output setup, example: C:\Setups

See Also

InnoSetup Class
MSBuild.Community.Tasks Namespace


Quiet Property

[image]

.NET Framework Class Library
InnoSetup..::.Quiet Property
InnoSetup Class See Also Send Feedback

Quiet compile

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Quiet As String
C#
public string Quiet { get; set; }
Visual C++
public:
property String^ Quiet {
    String^ get ();
    void set (String^ value);
}

Field Value

True o False

See Also

InnoSetup Class
MSBuild.Community.Tasks Namespace


ScriptFile Property

[image]

.NET Framework Class Library
InnoSetup..::.ScriptFile Property
InnoSetup Class See Also Send Feedback

Filename of Inno Setup script (.iss)

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property ScriptFile As String
C#
[RequiredAttribute]
public string ScriptFile { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ ScriptFile {
    String^ get ();
    void set (String^ value);
}

Field Value

InnoSetup file, example: C:\Setup.iss

See Also

InnoSetup Class
MSBuild.Community.Tasks Namespace


StandardOutputLoggingImportance Property

[image]

.NET Framework Class Library
InnoSetup..::.StandardOutputLoggingImportance Property
InnoSetup Class See Also Send Feedback

Gets the MessageImportance with which to log errors.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property StandardOutputLoggingImportance As MessageImportance
C#
protected override MessageImportance StandardOutputLoggingImportance { get; }
Visual C++
protected:
virtual property MessageImportance StandardOutputLoggingImportance {
    MessageImportance get () override;
}

Field Value

Return Value

The MessageImportance with which to log errors.

See Also

InnoSetup Class
MSBuild.Community.Tasks Namespace


ToolName Property

[image]

.NET Framework Class Library
InnoSetup..::.ToolName Property
InnoSetup Class See Also Send Feedback

Gets the name of the executable file to run.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ToolName As String
C#
protected override string ToolName { get; }
Visual C++
protected:
virtual property String^ ToolName {
    String^ get () override;
}

Field Value

Return Value

The name of the executable file to run.

See Also

InnoSetup Class
MSBuild.Community.Tasks Namespace


Mail Class

[image]

.NET Framework Class Library
Mail Class
Members Example See Also Send Feedback

Sends an email message

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Mail _
    Inherits Task
C#
public class Mail : Task
Visual C++
public ref class Mail : public Task

Examples

Example of sending an email.
Copy Code
            <Target Name="Mail">
                <Mail SmtpServer="localhost"
                    To="user@email.com"
                    From="from@email.com"
                    Subject="Test Mail Task"
                    Body="This is a test of the mail task." />
            </Target>

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks..::.Mail

See Also

Mail Members
MSBuild.Community.Tasks Namespace


Mail Members

[image] [image]

.NET Framework Class Library
Mail Members
Mail Class Constructors Methods Properties See Also Send Feedback

The Mail type exposes the following members.

Constructors

Name | Description
Mail | Initializes a new instance of the Mail class.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | Sends an email message (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
Attachments | List of files to attach to message
Bcc | List of addresss that contains the blind carbon copy (BCC) recipients for this e-mail message
Body | The email message body
BuildEngine | (Inherited from Task.)
CC | List of addresss that contains the carbon copy (CC) recipients for this e-mail message
EnableSsl | Specify whether the Mail task uses SSL to encrypt the connection.
From | The from address for this e-mail message
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
IsBodyHtml | A value indicating whether the mail message body is in Html
Log | (Inherited from Task.)
Password | Gets or sets the password.
Priority | The priority of this e-mail message
SmtpServer | The name or IP address of the host used for SMTP transactions
Subject | The subject line for this e-mail message
TaskResources | (Inherited from Task.)
To | List of addresss that contains the recipients of this e-mail message
Username | Gets or sets the username.

See Also

Mail Class
MSBuild.Community.Tasks Namespace


Mail Constructor

[image]

.NET Framework Class Library
Mail Constructor
Mail Class See Also Send Feedback

Initializes a new instance of the Mail class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Mail()
Visual C++
public:
Mail()

See Also

Mail Class
MSBuild.Community.Tasks Namespace


Mail Methods

[image] [image]

.NET Framework Class Library
Mail Methods
Mail Class See Also Send Feedback

The Mail type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | Sends an email message (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

Mail Class
MSBuild.Community.Tasks Namespace


Execute Method

[image]

.NET Framework Class Library
Mail..::.Execute Method
Mail Class See Also Send Feedback

Sends an email message

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

Returns true if successful

Implements

ITask..::.Execute()()()

See Also

Mail Class
MSBuild.Community.Tasks Namespace


Mail Properties

[image] [image]

.NET Framework Class Library
Mail Properties
Mail Class See Also Send Feedback

The Mail type exposes the following members.

Properties

Name | Description
Attachments | List of files to attach to message
Bcc | List of addresss that contains the blind carbon copy (BCC) recipients for this e-mail message
Body | The email message body
BuildEngine | (Inherited from Task.)
CC | List of addresss that contains the carbon copy (CC) recipients for this e-mail message
EnableSsl | Specify whether the Mail task uses SSL to encrypt the connection.
From | The from address for this e-mail message
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
IsBodyHtml | A value indicating whether the mail message body is in Html
Log | (Inherited from Task.)
Password | Gets or sets the password.
Priority | The priority of this e-mail message
SmtpServer | The name or IP address of the host used for SMTP transactions
Subject | The subject line for this e-mail message
TaskResources | (Inherited from Task.)
To | List of addresss that contains the recipients of this e-mail message
Username | Gets or sets the username.

See Also

Mail Class
MSBuild.Community.Tasks Namespace


Attachments Property

[image]

.NET Framework Class Library
Mail..::.Attachments Property
Mail Class See Also Send Feedback

List of files to attach to message

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Attachments As String()
C#
public string[] Attachments { get; set; }
Visual C++
public:
property array<String^>^ Attachments {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

See Also

Mail Class
MSBuild.Community.Tasks Namespace


Bcc Property

[image]

.NET Framework Class Library
Mail..::.Bcc Property
Mail Class See Also Send Feedback

List of addresss that contains the blind carbon copy (BCC) recipients for this e-mail message

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Bcc As String()
C#
public string[] Bcc { get; set; }
Visual C++
public:
property array<String^>^ Bcc {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

See Also

Mail Class
MSBuild.Community.Tasks Namespace


Body Property

[image]

.NET Framework Class Library
Mail..::.Body Property
Mail Class See Also Send Feedback

The email message body

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Body As String
C#
public string Body { get; set; }
Visual C++
public:
property String^ Body {
    String^ get ();
    void set (String^ value);
}

See Also

Mail Class
MSBuild.Community.Tasks Namespace


CC Property

[image]

.NET Framework Class Library
Mail..::.CC Property
Mail Class See Also Send Feedback

List of addresss that contains the carbon copy (CC) recipients for this e-mail message

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property CC As String()
C#
public string[] CC { get; set; }
Visual C++
public:
property array<String^>^ CC {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

See Also

Mail Class
MSBuild.Community.Tasks Namespace


EnableSsl Property

[image]

.NET Framework Class Library
Mail..::.EnableSsl Property
Mail Class See Also Send Feedback

Specify whether the Mail task uses SSL to encrypt the connection.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property EnableSsl As Boolean
C#
public bool EnableSsl { get; set; }
Visual C++
public:
property bool EnableSsl {
    bool get ();
    void set (bool value);
}

Field Value

true if the Mail task uses SSL; otherwise false. The default value is false.

See Also

Mail Class
MSBuild.Community.Tasks Namespace


From Property

[image]

.NET Framework Class Library
Mail..::.From Property
Mail Class See Also Send Feedback

The from address for this e-mail message

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property From As String
C#
[RequiredAttribute]
public string From { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ From {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is required.

See Also

Mail Class
MSBuild.Community.Tasks Namespace


IsBodyHtml Property

[image]

.NET Framework Class Library
Mail..::.IsBodyHtml Property
Mail Class See Also Send Feedback

A value indicating whether the mail message body is in Html

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property IsBodyHtml As Boolean
C#
public bool IsBodyHtml { get; set; }
Visual C++
public:
property bool IsBodyHtml {
    bool get ();
    void set (bool value);
}

See Also

Mail Class
MSBuild.Community.Tasks Namespace


Password Property

[image]

.NET Framework Class Library
Mail..::.Password Property
Mail Class See Also Send Feedback

Gets or sets the password.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password { get; set; }
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

Field Value

The password.

See Also

Mail Class
MSBuild.Community.Tasks Namespace


Priority Property

[image]

.NET Framework Class Library
Mail..::.Priority Property
Mail Class See Also Send Feedback

The priority of this e-mail message

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Priority As String
C#
public string Priority { get; set; }
Visual C++
public:
property String^ Priority {
    String^ get ();
    void set (String^ value);
}

Remarks

Possible values are High, Normal, and Low

See Also

Mail Class
MSBuild.Community.Tasks Namespace


SmtpServer Property

[image]

.NET Framework Class Library
Mail..::.SmtpServer Property
Mail Class See Also Send Feedback

The name or IP address of the host used for SMTP transactions

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property SmtpServer As String
C#
[RequiredAttribute]
public string SmtpServer { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ SmtpServer {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is required.

See Also

Mail Class
MSBuild.Community.Tasks Namespace


Subject Property

[image]

.NET Framework Class Library
Mail..::.Subject Property
Mail Class See Also Send Feedback

The subject line for this e-mail message

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property Subject As String
C#
[RequiredAttribute]
public string Subject { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is required.

See Also

Mail Class
MSBuild.Community.Tasks Namespace


To Property

[image]

.NET Framework Class Library
Mail..::.To Property
Mail Class See Also Send Feedback

List of addresss that contains the recipients of this e-mail message

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property To As String()
C#
[RequiredAttribute]
public string[] To { get; set; }
Visual C++
[RequiredAttribute]
public:
property array<String^>^ To {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Remarks

This property is required.

See Also

Mail Class
MSBuild.Community.Tasks Namespace


Username Property

[image]

.NET Framework Class Library
Mail..::.Username Property
Mail Class See Also Send Feedback

Gets or sets the username.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Username As String
C#
public string Username { get; set; }
Visual C++
public:
property String^ Username {
    String^ get ();
    void set (String^ value);
}

Field Value

The username.

See Also

Mail Class
MSBuild.Community.Tasks Namespace


Merge Class

[image]

.NET Framework Class Library
Merge Class
Members Example See Also Send Feedback

Merge files into the destination file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Merge _
    Inherits Task
C#
public class Merge : Task
Visual C++
public ref class Merge : public Task

Examples

Merge CSS files together for better browser performance.
Copy Code
            <Merge Mode="TextLine"
                SourceFiles="Main.css;Login.css"
                DestinationFile="All.css" />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks..::.Merge

See Also

Merge Members
MSBuild.Community.Tasks Namespace


Merge Members

[image] [image]

.NET Framework Class Library
Merge Members
Merge Class Constructors Methods Properties See Also Send Feedback

The Merge type exposes the following members.

Constructors

Name | Description
Merge |

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
DestinationFile | Gets or sets the destination file where the SourceFiles are merged to.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
Mode | Gets or sets the mode to use when merging.
SourceFiles | Gets or sets the source files to merge.
TaskResources | (Inherited from Task.)

See Also

Merge Class
MSBuild.Community.Tasks Namespace


Merge Constructor

[image]

.NET Framework Class Library
Merge Constructor
Merge Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Merge()
Visual C++
public:
Merge()

See Also

Merge Class
MSBuild.Community.Tasks Namespace


Merge Methods

[image] [image]

.NET Framework Class Library
Merge Methods
Merge Class See Also Send Feedback

The Merge type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

Merge Class
MSBuild.Community.Tasks Namespace


Execute Method

[image]

.NET Framework Class Library
Merge..::.Execute Method
Merge Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

Merge Class
MSBuild.Community.Tasks Namespace


Merge Properties

[image] [image]

.NET Framework Class Library
Merge Properties
Merge Class See Also Send Feedback

The Merge type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
DestinationFile | Gets or sets the destination file where the SourceFiles are merged to.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
Mode | Gets or sets the mode to use when merging.
SourceFiles | Gets or sets the source files to merge.
TaskResources | (Inherited from Task.)

See Also

Merge Class
MSBuild.Community.Tasks Namespace


DestinationFile Property

[image]

.NET Framework Class Library
Merge..::.DestinationFile Property
Merge Class See Also Send Feedback

Gets or sets the destination file where the SourceFiles are merged to.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property DestinationFile As ITaskItem
C#
[RequiredAttribute]
public ITaskItem DestinationFile { get; set; }
Visual C++
[RequiredAttribute]
public:
property ITaskItem^ DestinationFile {
    ITaskItem^ get ();
    void set (ITaskItem^ value);
}

Field Value

The destination file.

See Also

Merge Class
MSBuild.Community.Tasks Namespace


Mode Property

[image]

.NET Framework Class Library
Merge..::.Mode Property
Merge Class See Also Send Feedback

Gets or sets the mode to use when merging.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Mode As String
C#
public string Mode { get; set; }
Visual C++
public:
property String^ Mode {
    String^ get ();
    void set (String^ value);
}

Field Value

The merge mode.

See Also

Merge Class
MSBuild.Community.Tasks Namespace


SourceFiles Property

[image]

.NET Framework Class Library
Merge..::.SourceFiles Property
Merge Class See Also Send Feedback

Gets or sets the source files to merge.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property SourceFiles As ITaskItem()
C#
[RequiredAttribute]
public ITaskItem[] SourceFiles { get; set; }
Visual C++
[RequiredAttribute]
public:
property array<ITaskItem^>^ SourceFiles {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

Field Value

The source files to merge.

See Also

Merge Class
MSBuild.Community.Tasks Namespace


MergeModes Enumeration

[image]

.NET Framework Class Library
MergeModes Enumeration
See Also Send Feedback

Defines the modes for merging files.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration MergeModes
C#
public enum MergeModes
Visual C++
public enum class MergeModes

Members

Member name | Description
Binary | Merges files as binary data.
Text | Merges files as text.
TextLine | Merges files as text line by line.

See Also

MSBuild.Community.Tasks Namespace


Move Class

[image]

.NET Framework Class Library
Move Class
Members Example See Also Send Feedback

Moves files on the filesystem to a new location.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Move _
    Inherits Task
C#
public class Move : Task
Visual C++
public ref class Move : public Task

Examples

Move a file to another folder

Copy Code
            <Move SourceFiles="Test\MoveMe.txt"
                DestinationFolder="Test\Move" />

Rename a file

Copy Code
            <Move SourceFiles="Test\Move\MoveMe.txt"
                DestinationFiles="Test\Move\Renamed.txt" />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks..::.Move

See Also

Move Members
MSBuild.Community.Tasks Namespace


Move Members

[image] [image]

.NET Framework Class Library
Move Members
Move Class Constructors Methods Properties See Also Send Feedback

The Move type exposes the following members.

Constructors

Name | Description
Move |

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
DestinationFiles | Gets or sets the list of files to moved the source files to.
DestinationFolder | Gets or sets the directory to which you want to move the files.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
MovedFiles | Gets the items that were successfully moved.
SourceFiles | Gets or sets the source files to move.
TaskResources | (Inherited from Task.)

See Also

Move Class
MSBuild.Community.Tasks Namespace


Move Constructor

[image]

.NET Framework Class Library
Move Constructor
Move Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Move()
Visual C++
public:
Move()

See Also

Move Class
MSBuild.Community.Tasks Namespace


Move Methods

[image] [image]

.NET Framework Class Library
Move Methods
Move Class See Also Send Feedback

The Move type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

Move Class
MSBuild.Community.Tasks Namespace


Execute Method

[image]

.NET Framework Class Library
Move..::.Execute Method
Move Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

Move Class
MSBuild.Community.Tasks Namespace


Move Properties

[image] [image]

.NET Framework Class Library
Move Properties
Move Class See Also Send Feedback

The Move type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
DestinationFiles | Gets or sets the list of files to moved the source files to.
DestinationFolder | Gets or sets the directory to which you want to move the files.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
MovedFiles | Gets the items that were successfully moved.
SourceFiles | Gets or sets the source files to move.
TaskResources | (Inherited from Task.)

See Also

Move Class
MSBuild.Community.Tasks Namespace


DestinationFiles Property

[image]

.NET Framework Class Library
Move..::.DestinationFiles Property
Move Class See Also Send Feedback

Gets or sets the list of files to moved the source files to.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public Property DestinationFiles As ITaskItem()
C#
[OutputAttribute]
public ITaskItem[] DestinationFiles { get; set; }
Visual C++
[OutputAttribute]
public:
property array<ITaskItem^>^ DestinationFiles {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

Field Value

The destination files.

Remarks

This list is expected to be a one-to-one mapping with the list specified in the SourceFiles parameter. That is, the first file specified in SourceFiles will be moved to the first location specified in DestinationFiles, and so forth.

See Also

Move Class
MSBuild.Community.Tasks Namespace


DestinationFolder Property

[image]

.NET Framework Class Library
Move..::.DestinationFolder Property
Move Class See Also Send Feedback

Gets or sets the directory to which you want to move the files.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property DestinationFolder As ITaskItem
C#
public ITaskItem DestinationFolder { get; set; }
Visual C++
public:
property ITaskItem^ DestinationFolder {
    ITaskItem^ get ();
    void set (ITaskItem^ value);
}

Field Value

The destination folder.

See Also

Move Class
MSBuild.Community.Tasks Namespace


MovedFiles Property

[image]

.NET Framework Class Library
Move..::.MovedFiles Property
Move Class See Also Send Feedback

Gets the items that were successfully moved.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property MovedFiles As ITaskItem()
C#
[OutputAttribute]
public ITaskItem[] MovedFiles { get; }
Visual C++
[OutputAttribute]
public:
property array<ITaskItem^>^ MovedFiles {
    array<ITaskItem^>^ get ();
}

Field Value

The moved files.

See Also

Move Class
MSBuild.Community.Tasks Namespace


SourceFiles Property

[image]

.NET Framework Class Library
Move..::.SourceFiles Property
Move Class See Also Send Feedback

Gets or sets the source files to move.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property SourceFiles As ITaskItem()
C#
[RequiredAttribute]
public ITaskItem[] SourceFiles { get; set; }
Visual C++
[RequiredAttribute]
public:
property array<ITaskItem^>^ SourceFiles {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

Field Value

The source files to move.

See Also

Move Class
MSBuild.Community.Tasks Namespace


NDoc Class

[image]

.NET Framework Class Library
NDoc Class
Members Example See Also Send Feedback

Runs the NDoc application.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class NDoc _
    Inherits ToolTask
C#
public class NDoc : ToolTask
Visual C++
public ref class NDoc : public ToolTask

Examples

Generated html help file.
Copy Code
            <NDoc Documenter="MSDN"
                ProjectFilePath="MSBuild.Community.Tasks.ndoc" />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
Microsoft.Build.Utilities..::.ToolTask
MSBuild.Community.Tasks..::.NDoc

See Also

NDoc Members
MSBuild.Community.Tasks Namespace


NDoc Members

[image] [image]

.NET Framework Class Library
NDoc Members
NDoc Class Constructors Methods Properties See Also Send Feedback

The NDoc type exposes the following members.

Constructors

Name | Description
NDoc | Initializes a new instance of the NDoc class.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from ToolTask.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | Returns the directory in which to run the executable file. (Overrides ToolTask..::.GetWorkingDirectory()()().)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | (Inherited from ToolTask.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Overrides ToolTask..::.LogToolCommand(String).)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Documenter | Gets or sets the documenter.
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
ProjectFilePath | Gets or sets the project file path.
ResponseFileEncoding | (Inherited from ToolTask.)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Overrides ToolTask..::.StandardOutputLoggingImportance.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)
Verbose | Gets or sets a value indicating whether the output is verbose.
WorkingDirectory | Gets or sets the working directory.

See Also

NDoc Class
MSBuild.Community.Tasks Namespace


NDoc Constructor

[image]

.NET Framework Class Library
NDoc Constructor
NDoc Class See Also Send Feedback

Initializes a new instance of the NDoc class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public NDoc()
Visual C++
public:
NDoc()

See Also

NDoc Class
MSBuild.Community.Tasks Namespace


NDoc Methods

[image] [image]

.NET Framework Class Library
NDoc Methods
NDoc Class See Also Send Feedback

The NDoc type exposes the following members.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from ToolTask.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | Returns the directory in which to run the executable file. (Overrides ToolTask..::.GetWorkingDirectory()()().)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | (Inherited from ToolTask.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Overrides ToolTask..::.LogToolCommand(String).)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

See Also

NDoc Class
MSBuild.Community.Tasks Namespace


GenerateCommandLineCommands Method

[image]

.NET Framework Class Library
NDoc..::.GenerateCommandLineCommands Method
NDoc Class See Also Send Feedback

Returns a string value containing the command line arguments to pass directly to the executable file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateCommandLineCommands As String
C#
protected override string GenerateCommandLineCommands()
Visual C++
protected:
virtual String^ GenerateCommandLineCommands() override

Return Value

A string value containing the command line arguments to pass directly to the executable file.

See Also

NDoc Class
MSBuild.Community.Tasks Namespace


GenerateFullPathToTool Method

[image]

.NET Framework Class Library
NDoc..::.GenerateFullPathToTool Method
NDoc Class See Also Send Feedback

Returns the fully qualified path to the executable file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateFullPathToTool As String
C#
protected override string GenerateFullPathToTool()
Visual C++
protected:
virtual String^ GenerateFullPathToTool() override

Return Value

The fully qualified path to the executable file.

See Also

NDoc Class
MSBuild.Community.Tasks Namespace


GetWorkingDirectory Method

[image]

.NET Framework Class Library
NDoc..::.GetWorkingDirectory Method
NDoc Class See Also Send Feedback

Returns the directory in which to run the executable file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetWorkingDirectory As String
C#
protected override string GetWorkingDirectory()
Visual C++
protected:
virtual String^ GetWorkingDirectory() override

Return Value

The directory in which to run the executable file, or a null reference (Nothing in Visual Basic) if the executable file should be run in the current directory.

See Also

NDoc Class
MSBuild.Community.Tasks Namespace


LogToolCommand Method

[image]

.NET Framework Class Library
NDoc..::.LogToolCommand Method
NDoc Class See Also Send Feedback

Logs the starting point of the run to all registered loggers.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub LogToolCommand ( _
    message As String _
)
C#
protected override void LogToolCommand(
    string message
)
Visual C++
protected:
virtual void LogToolCommand(
    String^ message
) override

Parameters

message
Type: System..::.String
A descriptive message to provide loggers, usually the command line and switches.

See Also

NDoc Class
MSBuild.Community.Tasks Namespace


NDoc Properties

[image] [image]

.NET Framework Class Library
NDoc Properties
NDoc Class See Also Send Feedback

The NDoc type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Documenter | Gets or sets the documenter.
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
ProjectFilePath | Gets or sets the project file path.
ResponseFileEncoding | (Inherited from ToolTask.)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Overrides ToolTask..::.StandardOutputLoggingImportance.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)
Verbose | Gets or sets a value indicating whether the output is verbose.
WorkingDirectory | Gets or sets the working directory.

See Also

NDoc Class
MSBuild.Community.Tasks Namespace


Documenter Property

[image]

.NET Framework Class Library
NDoc..::.Documenter Property
NDoc Class See Also Send Feedback

Gets or sets the documenter.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property Documenter As String
C#
[RequiredAttribute]
public string Documenter { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ Documenter {
    String^ get ();
    void set (String^ value);
}

Field Value

The documenter.

Remarks

Available documenters are VS.NET_2003, JavaDoc, LaTeX, LinearHtml, MSDN, XML.

See Also

NDoc Class
MSBuild.Community.Tasks Namespace


ProjectFilePath Property

[image]

.NET Framework Class Library
NDoc..::.ProjectFilePath Property
NDoc Class See Also Send Feedback

Gets or sets the project file path.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property ProjectFilePath As String
C#
[RequiredAttribute]
public string ProjectFilePath { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ ProjectFilePath {
    String^ get ();
    void set (String^ value);
}

Field Value

The project file path.

See Also

NDoc Class
MSBuild.Community.Tasks Namespace


StandardOutputLoggingImportance Property

[image]

.NET Framework Class Library
NDoc..::.StandardOutputLoggingImportance Property
NDoc Class See Also Send Feedback

Gets the MessageImportance with which to log errors.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property StandardOutputLoggingImportance As MessageImportance
C#
protected override MessageImportance StandardOutputLoggingImportance { get; }
Visual C++
protected:
virtual property MessageImportance StandardOutputLoggingImportance {
    MessageImportance get () override;
}

Field Value

Return Value

The MessageImportance with which to log errors.

See Also

NDoc Class
MSBuild.Community.Tasks Namespace


ToolName Property

[image]

.NET Framework Class Library
NDoc..::.ToolName Property
NDoc Class See Also Send Feedback

Gets the name of the executable file to run.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ToolName As String
C#
protected override string ToolName { get; }
Visual C++
protected:
virtual property String^ ToolName {
    String^ get () override;
}

Field Value

Return Value

The name of the executable file to run.

See Also

NDoc Class
MSBuild.Community.Tasks Namespace


Verbose Property

[image]

.NET Framework Class Library
NDoc..::.Verbose Property
NDoc Class See Also Send Feedback

Gets or sets a value indicating whether the output is verbose.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Verbose As Boolean
C#
public bool Verbose { get; set; }
Visual C++
public:
property bool Verbose {
    bool get ();
    void set (bool value);
}

Field Value

true if verbose; otherwise, false.

See Also

NDoc Class
MSBuild.Community.Tasks Namespace


WorkingDirectory Property

[image]

.NET Framework Class Library
NDoc..::.WorkingDirectory Property
NDoc Class See Also Send Feedback

Gets or sets the working directory.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property WorkingDirectory As String
C#
public string WorkingDirectory { get; set; }
Visual C++
public:
property String^ WorkingDirectory {
    String^ get ();
    void set (String^ value);
}

Field Value

The working directory.

Return Value

The directory in which to run the executable file, or a null reference (Nothing in Visual Basic) if the executable file should be run in the current directory.

See Also

NDoc Class
MSBuild.Community.Tasks Namespace


NUnit Class

[image]

.NET Framework Class Library
NUnit Class
Members Example See Also Send Feedback

Run NUnit 2.4 on a group of assemblies.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class NUnit _
    Inherits ToolTask
C#
public class NUnit : ToolTask
Visual C++
public ref class NUnit : public ToolTask

Examples

Run NUnit tests.
Copy Code
            <ItemGroup>
                <TestAssembly Include="C:\Program Files\NUnit 2.4\bin\*.tests.dll" />
            </ItemGroup>
            <Target Name="NUnit">
                <NUnit Assemblies="@(TestAssembly)" />
            </Target>

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
Microsoft.Build.Utilities..::.ToolTask
MSBuild.Community.Tasks..::.NUnit

See Also

NUnit Members
MSBuild.Community.Tasks Namespace


NUnit Members

[image] [image]

.NET Framework Class Library
NUnit Members
NUnit Class Constructors Methods Fields Properties See Also Send Feedback

The NUnit type exposes the following members.

Constructors

Name | Description
NUnit | Initializes a new instance of the NUnit class.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from ToolTask.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | Returns the directory in which to run the executable file. (Overrides ToolTask..::.GetWorkingDirectory()()().)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | (Inherited from ToolTask.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Overrides ToolTask..::.LogToolCommand(String).)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

Fields

Name | Description
DEFAULT_NUNIT_DIRECTORY | The default relative path of the NUnit installation. The value is @"NUnit 2.4\bin".

Properties

Name | Description
Assemblies | Gets or sets the assemblies.
BuildEngine | (Inherited from Task.)
DisableShadowCopy | Determines whether assemblies are copied to a shadow folder during testing.
EnvironmentOverride | (Inherited from ToolTask.)
ErrorOutputFile | The file to receive test error details.
ExcludeCategory | Gets or sets the categories to exclude.
ExitCode | (Inherited from ToolTask.)
Fixture | Gets or sets the fixture.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
IncludeCategory | Gets or sets the categories to include.
Log | (Inherited from Task.)
OutputXmlFile | Gets or sets the output XML file.
ProjectConfiguration | The project configuration to run.
ResponseFileEncoding | (Inherited from ToolTask.)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Overrides ToolTask..::.StandardOutputLoggingImportance.)
TaskResources | (Inherited from Task.)
TestInNewThread | Allows tests to be run in a new thread, allowing you to take advantage of ApartmentState and ThreadPriority settings in the config file.
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)
WorkingDirectory | Gets or sets the working directory.
XsltTransformFile | Gets or sets the XSLT transform file.

See Also

NUnit Class
MSBuild.Community.Tasks Namespace


NUnit Constructor

[image]

.NET Framework Class Library
NUnit Constructor
NUnit Class See Also Send Feedback

Initializes a new instance of the NUnit class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public NUnit()
Visual C++
public:
NUnit()

See Also

NUnit Class
MSBuild.Community.Tasks Namespace


NUnit Fields

[image] [image]

.NET Framework Class Library
NUnit Fields
NUnit Class See Also Send Feedback

The NUnit type exposes the following members.

Fields

Name | Description
DEFAULT_NUNIT_DIRECTORY | The default relative path of the NUnit installation. The value is @"NUnit 2.4\bin".

See Also

NUnit Class
MSBuild.Community.Tasks Namespace


DEFAULT_NUNIT_DIRECTORY Field

[image]

.NET Framework Class Library
NUnit..::.DEFAULT_NUNIT_DIRECTORY Field
NUnit Class See Also Send Feedback

The default relative path of the NUnit installation. The value is @"NUnit 2.4\bin".

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Const DEFAULT_NUNIT_DIRECTORY As String
C#
public const string DEFAULT_NUNIT_DIRECTORY
Visual C++
public:
literal String^ DEFAULT_NUNIT_DIRECTORY

See Also

NUnit Class
MSBuild.Community.Tasks Namespace


NUnit Methods

[image] [image]

.NET Framework Class Library
NUnit Methods
NUnit Class See Also Send Feedback

The NUnit type exposes the following members.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from ToolTask.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | Returns the directory in which to run the executable file. (Overrides ToolTask..::.GetWorkingDirectory()()().)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | (Inherited from ToolTask.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Overrides ToolTask..::.LogToolCommand(String).)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

See Also

NUnit Class
MSBuild.Community.Tasks Namespace


GenerateCommandLineCommands Method

[image]

.NET Framework Class Library
NUnit..::.GenerateCommandLineCommands Method
NUnit Class See Also Send Feedback

Returns a string value containing the command line arguments to pass directly to the executable file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateCommandLineCommands As String
C#
protected override string GenerateCommandLineCommands()
Visual C++
protected:
virtual String^ GenerateCommandLineCommands() override

Return Value

A string value containing the command line arguments to pass directly to the executable file.

See Also

NUnit Class
MSBuild.Community.Tasks Namespace


GenerateFullPathToTool Method

[image]

.NET Framework Class Library
NUnit..::.GenerateFullPathToTool Method
NUnit Class See Also Send Feedback

Returns the fully qualified path to the executable file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateFullPathToTool As String
C#
protected override string GenerateFullPathToTool()
Visual C++
protected:
virtual String^ GenerateFullPathToTool() override

Return Value

The fully qualified path to the executable file.

See Also

NUnit Class
MSBuild.Community.Tasks Namespace


GetWorkingDirectory Method

[image]

.NET Framework Class Library
NUnit..::.GetWorkingDirectory Method
NUnit Class See Also Send Feedback

Returns the directory in which to run the executable file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetWorkingDirectory As String
C#
protected override string GetWorkingDirectory()
Visual C++
protected:
virtual String^ GetWorkingDirectory() override

Return Value

The directory in which to run the executable file, or a null reference (Nothing in Visual Basic) if the executable file should be run in the current directory.

See Also

NUnit Class
MSBuild.Community.Tasks Namespace


LogToolCommand Method

[image]

.NET Framework Class Library
NUnit..::.LogToolCommand Method
NUnit Class See Also Send Feedback

Logs the starting point of the run to all registered loggers.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub LogToolCommand ( _
    message As String _
)
C#
protected override void LogToolCommand(
    string message
)
Visual C++
protected:
virtual void LogToolCommand(
    String^ message
) override

Parameters

message
Type: System..::.String
A descriptive message to provide loggers, usually the command line and switches.

See Also

NUnit Class
MSBuild.Community.Tasks Namespace


NUnit Properties

[image] [image]

.NET Framework Class Library
NUnit Properties
NUnit Class See Also Send Feedback

The NUnit type exposes the following members.

Properties

Name | Description
Assemblies | Gets or sets the assemblies.
BuildEngine | (Inherited from Task.)
DisableShadowCopy | Determines whether assemblies are copied to a shadow folder during testing.
EnvironmentOverride | (Inherited from ToolTask.)
ErrorOutputFile | The file to receive test error details.
ExcludeCategory | Gets or sets the categories to exclude.
ExitCode | (Inherited from ToolTask.)
Fixture | Gets or sets the fixture.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
IncludeCategory | Gets or sets the categories to include.
Log | (Inherited from Task.)
OutputXmlFile | Gets or sets the output XML file.
ProjectConfiguration | The project configuration to run.
ResponseFileEncoding | (Inherited from ToolTask.)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Overrides ToolTask..::.StandardOutputLoggingImportance.)
TaskResources | (Inherited from Task.)
TestInNewThread | Allows tests to be run in a new thread, allowing you to take advantage of ApartmentState and ThreadPriority settings in the config file.
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)
WorkingDirectory | Gets or sets the working directory.
XsltTransformFile | Gets or sets the XSLT transform file.

See Also

NUnit Class
MSBuild.Community.Tasks Namespace


Assemblies Property

[image]

.NET Framework Class Library
NUnit..::.Assemblies Property
NUnit Class See Also Send Feedback

Gets or sets the assemblies.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property Assemblies As ITaskItem()
C#
[RequiredAttribute]
public ITaskItem[] Assemblies { get; set; }
Visual C++
[RequiredAttribute]
public:
property array<ITaskItem^>^ Assemblies {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

Field Value

The assemblies.

See Also

NUnit Class
MSBuild.Community.Tasks Namespace


DisableShadowCopy Property

[image]

.NET Framework Class Library
NUnit..::.DisableShadowCopy Property
NUnit Class See Also Send Feedback

Determines whether assemblies are copied to a shadow folder during testing.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property DisableShadowCopy As Boolean
C#
public bool DisableShadowCopy { get; set; }
Visual C++
public:
property bool DisableShadowCopy {
    bool get ();
    void set (bool value);
}

Remarks

Shadow copying is enabled by default. If you want to test the assemblies "in place", you must set this property to True.

See Also

NUnit Class
MSBuild.Community.Tasks Namespace


ErrorOutputFile Property

[image]

.NET Framework Class Library
NUnit..::.ErrorOutputFile Property
NUnit Class See Also Send Feedback

The file to receive test error details.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ErrorOutputFile As String
C#
public string ErrorOutputFile { get; set; }
Visual C++
public:
property String^ ErrorOutputFile {
    String^ get ();
    void set (String^ value);
}

See Also

NUnit Class
MSBuild.Community.Tasks Namespace


ExcludeCategory Property

[image]

.NET Framework Class Library
NUnit..::.ExcludeCategory Property
NUnit Class See Also Send Feedback

Gets or sets the categories to exclude.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ExcludeCategory As String
C#
public string ExcludeCategory { get; set; }
Visual C++
public:
property String^ ExcludeCategory {
    String^ get ();
    void set (String^ value);
}

Remarks

Multiple values must be separated by a comma ","

See Also

NUnit Class
MSBuild.Community.Tasks Namespace


Fixture Property

[image]

.NET Framework Class Library
NUnit..::.Fixture Property
NUnit Class See Also Send Feedback

Gets or sets the fixture.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Fixture As String
C#
public string Fixture { get; set; }
Visual C++
public:
property String^ Fixture {
    String^ get ();
    void set (String^ value);
}

Field Value

The fixture.

See Also

NUnit Class
MSBuild.Community.Tasks Namespace


IncludeCategory Property

[image]

.NET Framework Class Library
NUnit..::.IncludeCategory Property
NUnit Class See Also Send Feedback

Gets or sets the categories to include.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property IncludeCategory As String
C#
public string IncludeCategory { get; set; }
Visual C++
public:
property String^ IncludeCategory {
    String^ get ();
    void set (String^ value);
}

Remarks

Multiple values must be separated by a comma ","

See Also

NUnit Class
MSBuild.Community.Tasks Namespace


OutputXmlFile Property

[image]

.NET Framework Class Library
NUnit..::.OutputXmlFile Property
NUnit Class See Also Send Feedback

Gets or sets the output XML file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property OutputXmlFile As String
C#
public string OutputXmlFile { get; set; }
Visual C++
public:
property String^ OutputXmlFile {
    String^ get ();
    void set (String^ value);
}

Field Value

The output XML file.

See Also

NUnit Class
MSBuild.Community.Tasks Namespace


ProjectConfiguration Property

[image]

.NET Framework Class Library
NUnit..::.ProjectConfiguration Property
NUnit Class See Also Send Feedback

The project configuration to run.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ProjectConfiguration As String
C#
public string ProjectConfiguration { get; set; }
Visual C++
public:
property String^ ProjectConfiguration {
    String^ get ();
    void set (String^ value);
}

Remarks

Only applies when a project file is used. The default is the first configuration, usually Debug.

See Also

NUnit Class
MSBuild.Community.Tasks Namespace


StandardOutputLoggingImportance Property

[image]

.NET Framework Class Library
NUnit..::.StandardOutputLoggingImportance Property
NUnit Class See Also Send Feedback

Gets the MessageImportance with which to log errors.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property StandardOutputLoggingImportance As MessageImportance
C#
protected override MessageImportance StandardOutputLoggingImportance { get; }
Visual C++
protected:
virtual property MessageImportance StandardOutputLoggingImportance {
    MessageImportance get () override;
}

Field Value

Return Value

The MessageImportance with which to log errors.

See Also

NUnit Class
MSBuild.Community.Tasks Namespace


TestInNewThread Property

[image]

.NET Framework Class Library
NUnit..::.TestInNewThread Property
NUnit Class See Also Send Feedback

Allows tests to be run in a new thread, allowing you to take advantage of ApartmentState and ThreadPriority settings in the config file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property TestInNewThread As Boolean
C#
public bool TestInNewThread { get; set; }
Visual C++
public:
property bool TestInNewThread {
    bool get ();
    void set (bool value);
}

See Also

NUnit Class
MSBuild.Community.Tasks Namespace


ToolName Property

[image]

.NET Framework Class Library
NUnit..::.ToolName Property
NUnit Class See Also Send Feedback

Gets the name of the executable file to run.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ToolName As String
C#
protected override string ToolName { get; }
Visual C++
protected:
virtual property String^ ToolName {
    String^ get () override;
}

Field Value

Return Value

The name of the executable file to run.

See Also

NUnit Class
MSBuild.Community.Tasks Namespace


WorkingDirectory Property

[image]

.NET Framework Class Library
NUnit..::.WorkingDirectory Property
NUnit Class See Also Send Feedback

Gets or sets the working directory.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property WorkingDirectory As String
C#
public string WorkingDirectory { get; set; }
Visual C++
public:
property String^ WorkingDirectory {
    String^ get ();
    void set (String^ value);
}

Field Value

The working directory.

Return Value

The directory in which to run the executable file, or a null reference (Nothing in Visual Basic) if the executable file should be run in the current directory.

See Also

NUnit Class
MSBuild.Community.Tasks Namespace


XsltTransformFile Property

[image]

.NET Framework Class Library
NUnit..::.XsltTransformFile Property
NUnit Class See Also Send Feedback

Gets or sets the XSLT transform file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property XsltTransformFile As String
C#
public string XsltTransformFile { get; set; }
Visual C++
public:
property String^ XsltTransformFile {
    String^ get ();
    void set (String^ value);
}

Field Value

The XSLT transform file.

See Also

NUnit Class
MSBuild.Community.Tasks Namespace


Prompt Class

[image]

.NET Framework Class Library
Prompt Class
Members Example See Also Send Feedback

Displays a message on the console and waits for user input.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Prompt _
    Inherits Task
C#
public class Prompt : Task
Visual C++
public ref class Prompt : public Task

Remarks

It is important to note that the message is not written to the MSBuild logger, it is always written to the console, no matter which logger is configured.

This task requires user input from the console. Do not use this task for projects that will be executed unattended. It is recommended that you always add a Condtion so that this task is only enabled when a custom property is set through the command line. This will ensure that the other users do not attempt to execute the task in unattended mode.

Examples

Pause the build if the interactive property is set:
Copy Code
            <!-- Pause when invoked with the interactive property: msbuild myproject.proj /property:interactive=true -->

            <Prompt Text="You can now attach the debugger to the msbuild.exe process..." Condition="'$(Interactive)' == 'True'" />

Examples

Obtain user input during the build: (Note: in most cases, it is recommended that users instead provide custom values to your build through the /property argument of msbuild.exe)
Copy Code
            <Prompt Text="Tell me your name:" Condition="'$(Interactive)' == 'True'" >
              <Output TaskParameter="UserInput" PropertyName="PersonName" />
            </Prompt>
            <Message Text="Hello $(PersonName)" />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks..::.Prompt

See Also

Prompt Members
MSBuild.Community.Tasks Namespace


Prompt Members

[image] [image]

.NET Framework Class Library
Prompt Members
Prompt Class Constructors Methods Properties See Also Send Feedback

The Prompt type exposes the following members.

Constructors

Name | Description
Prompt |

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
TaskResources | (Inherited from Task.)
Text | The message to display in the console.
UserInput | The text entered at the console.

See Also

Prompt Class
MSBuild.Community.Tasks Namespace


Prompt Constructor

[image]

.NET Framework Class Library
Prompt Constructor
Prompt Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Prompt()
Visual C++
public:
Prompt()

See Also

Prompt Class
MSBuild.Community.Tasks Namespace


Prompt Methods

[image] [image]

.NET Framework Class Library
Prompt Methods
Prompt Class See Also Send Feedback

The Prompt type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

Prompt Class
MSBuild.Community.Tasks Namespace


Execute Method

[image]

.NET Framework Class Library
Prompt..::.Execute Method
Prompt Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

Prompt Class
MSBuild.Community.Tasks Namespace


Prompt Properties

[image] [image]

.NET Framework Class Library
Prompt Properties
Prompt Class See Also Send Feedback

The Prompt type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
TaskResources | (Inherited from Task.)
Text | The message to display in the console.
UserInput | The text entered at the console.

See Also

Prompt Class
MSBuild.Community.Tasks Namespace


Text Property

[image]

.NET Framework Class Library
Prompt..::.Text Property
Prompt Class See Also Send Feedback

The message to display in the console.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Text As String
C#
public string Text { get; set; }
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

Prompt Class
MSBuild.Community.Tasks Namespace


UserInput Property

[image]

.NET Framework Class Library
Prompt..::.UserInput Property
Prompt Class See Also Send Feedback

The text entered at the console.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property UserInput As String
C#
[OutputAttribute]
public string UserInput { get; }
Visual C++
[OutputAttribute]
public:
property String^ UserInput {
    String^ get ();
}

See Also

Prompt Class
MSBuild.Community.Tasks Namespace


RegexBase Class

[image]

.NET Framework Class Library
RegexBase Class
Members See Also Send Feedback

Base class for Regex tasks Handles public properties for Input, Expression, Options and Output

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class RegexBase _
    Inherits Task
C#
public abstract class RegexBase : Task
Visual C++
public ref class RegexBase abstract : public Task

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks..::.RegexBase
MSBuild.Community.Tasks..::.RegexMatch
MSBuild.Community.Tasks..::.RegexReplace

See Also

RegexBase Members
MSBuild.Community.Tasks Namespace


RegexBase Members

[image] [image]

.NET Framework Class Library
RegexBase Members
RegexBase Class Constructors Methods Properties See Also Send Feedback

The RegexBase type exposes the following members.

Constructors

Name | Description
RegexBase |

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | (Inherited from Task.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Expression | Regex expression
ExpressionOptions | Options converted to RegexOptions enum
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Input | Input, list of items to perform the regex on
Log | (Inherited from Task.)
Options | Regex options as strings corresponding to the RegexOptions enum: Compiled CultureInvariant ECMAScript ExplicitCapture IgnoreCase IgnorePatternWhitespace Multiline None RightToLeft Singleline
Output | Results of the Regex transformation.
TaskResources | (Inherited from Task.)

See Also

RegexBase Class
MSBuild.Community.Tasks Namespace


RegexBase Constructor

[image]

.NET Framework Class Library
RegexBase Constructor
RegexBase Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New
C#
protected RegexBase()
Visual C++
protected:
RegexBase()

See Also

RegexBase Class
MSBuild.Community.Tasks Namespace


RegexBase Methods

[image] [image]

.NET Framework Class Library
RegexBase Methods
RegexBase Class See Also Send Feedback

The RegexBase type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | (Inherited from Task.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

RegexBase Class
MSBuild.Community.Tasks Namespace


RegexBase Properties

[image] [image]

.NET Framework Class Library
RegexBase Properties
RegexBase Class See Also Send Feedback

The RegexBase type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Expression | Regex expression
ExpressionOptions | Options converted to RegexOptions enum
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Input | Input, list of items to perform the regex on
Log | (Inherited from Task.)
Options | Regex options as strings corresponding to the RegexOptions enum: Compiled CultureInvariant ECMAScript ExplicitCapture IgnoreCase IgnorePatternWhitespace Multiline None RightToLeft Singleline
Output | Results of the Regex transformation.
TaskResources | (Inherited from Task.)

See Also

RegexBase Class
MSBuild.Community.Tasks Namespace


Expression Property

[image]

.NET Framework Class Library
RegexBase..::.Expression Property
RegexBase Class See Also Send Feedback

Regex expression

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property Expression As ITaskItem
C#
[RequiredAttribute]
public ITaskItem Expression { get; set; }
Visual C++
[RequiredAttribute]
public:
property ITaskItem^ Expression {
    ITaskItem^ get ();
    void set (ITaskItem^ value);
}

See Also

RegexBase Class
MSBuild.Community.Tasks Namespace


ExpressionOptions Property

[image]

.NET Framework Class Library
RegexBase..::.ExpressionOptions Property
RegexBase Class See Also Send Feedback

Options converted to RegexOptions enum

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property ExpressionOptions As RegexOptions
C#
protected RegexOptions ExpressionOptions { get; }
Visual C++
protected:
property RegexOptions ExpressionOptions {
    RegexOptions get ();
}

See Also

RegexBase Class
MSBuild.Community.Tasks Namespace


Input Property

[image]

.NET Framework Class Library
RegexBase..::.Input Property
RegexBase Class See Also Send Feedback

Input, list of items to perform the regex on

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property Input As ITaskItem()
C#
[RequiredAttribute]
public ITaskItem[] Input { get; set; }
Visual C++
[RequiredAttribute]
public:
property array<ITaskItem^>^ Input {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

See Also

RegexBase Class
MSBuild.Community.Tasks Namespace


Options Property

[image]

.NET Framework Class Library
RegexBase..::.Options Property
RegexBase Class See Also Send Feedback

Regex options as strings corresponding to the RegexOptions enum: Compiled CultureInvariant ECMAScript ExplicitCapture IgnoreCase IgnorePatternWhitespace Multiline None RightToLeft Singleline

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Options As ITaskItem()
C#
public ITaskItem[] Options { get; set; }
Visual C++
public:
property array<ITaskItem^>^ Options {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

See Also

RegexBase Class
MSBuild.Community.Tasks Namespace


Output Property

[image]

.NET Framework Class Library
RegexBase..::.Output Property
RegexBase Class See Also Send Feedback

Results of the Regex transformation.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public Property Output As ITaskItem()
C#
[OutputAttribute]
public ITaskItem[] Output { get; set; }
Visual C++
[OutputAttribute]
public:
property array<ITaskItem^>^ Output {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

See Also

RegexBase Class
MSBuild.Community.Tasks Namespace


RegexCompiler Class

[image]

.NET Framework Class Library
RegexCompiler Class
Members Example See Also Send Feedback

Compiles regular expressions and saves them to disk in an assembly.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class RegexCompiler _
    Inherits Task
C#
public class RegexCompiler : Task
Visual C++
public ref class RegexCompiler : public Task

Remarks

When defining the regular expressions in an MSBuild project file, the ItemGroup item must have a metadata tag called 'Pattern' that is the actually regular expression. Other optional metadata tags are the following.

Metadata Tags | Description
Pattern | The actually regular expression pattern to be compiled. (Required)
Options | The RegexOptions for the expression.
Namespace | The class namespace for the compile class.
IsPublic | A flag if the generated expression should be public.

Examples

Creates an assembly with the compiled regular expressions.
Copy Code

  <ItemGroup>
    <RegexPatterns Include="TextRegex">
      <Pattern>\G[^&lt;]+</Pattern>
      <Options>RegexOptions.Singleline | RegexOptions.Multiline</Options>
    </RegexPatterns>
    <RegexPatterns Include="CommentRegex">
      <Pattern>\G&lt;%--(([^-]*)-)*?-%&gt;</Pattern>
      <Options>RegexOptions.Singleline | RegexOptions.Multiline</Options>
    </RegexPatterns>
    <RegexPatterns Include="CodeRegex">
      <Pattern>\G&lt;%(?![@%])(?&lt;code&gt;.*?)%&gt;</Pattern>
      <Options>RegexOptions.Singleline | RegexOptions.Multiline</Options>
      <Namespace>MSBuild.Community.RegularExpressions</Namespace>
    </RegexPatterns>
  </ItemGroup>

  <Target Name="RegexCompiler">
    <RegexCompiler
      OutputDirectory="Test"
      RegularExpressions="@(RegexPatterns)"
      Namespace="MSBuild.RegularExpressions"
      AssemblyName="MSBuild.RegularExpressions.dll"
      AssemblyTitle="MSBuild.RegularExpressions"
      AssemblyDescription="MSBuild Community Tasks Regular Expressions"
      AssemblyCompany="Company Name, LLC"
      AssemblyProduct="MSBuildTasks"
      AssemblyCopyright="Copyright (c) MSBuildTasks 2008"
      AssemblyVersion="1.0.0.0"
      AssemblyFileVersion="1.0.0.0" />
  </Target>

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks..::.RegexCompiler

See Also

RegexCompiler Members
MSBuild.Community.Tasks Namespace


RegexCompiler Members

[image] [image]

.NET Framework Class Library
RegexCompiler Members
RegexCompiler Class Constructors Methods Properties See Also Send Feedback

The RegexCompiler type exposes the following members.

Constructors

Name | Description
RegexCompiler | Initializes a new instance of the RegexCompiler class.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
AssemblyCompany | Gets or sets the assembly company.
AssemblyCopyright | Gets or sets the assembly copyright.
AssemblyCulture | Gets or sets the assembly culture.
AssemblyDescription | Gets or sets the assembly description.
AssemblyFileVersion | Gets or sets the assembly file version.
AssemblyInformationalVersion | Gets or sets the assembly informational version.
AssemblyKeyFile | Gets or sets the assembly key file.
AssemblyName | Gets or sets the name of the assembly to be created by the regex compiler.
AssemblyProduct | Gets or sets the assembly product.
AssemblyTitle | Gets or sets the assembly title.
AssemblyVersion | Gets or sets the assembly version.
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
IsPublic | Gets or sets a value indicating whether the default value is public for regular expression instances.
Log | (Inherited from Task.)
Namespace | Gets or sets the default namespace for regular expression instances.
Options | Gets or sets the default regular expression options.
OutputDirectory | Gets or sets the directory where the assembly will be saved.
OutputFile | Gets or sets the output file.
RegularExpressions | Gets or sets the regular expressions.
TaskResources | (Inherited from Task.)

See Also

RegexCompiler Class
MSBuild.Community.Tasks Namespace


RegexCompiler Constructor

[image]

.NET Framework Class Library
RegexCompiler Constructor
RegexCompiler Class See Also Send Feedback

Initializes a new instance of the RegexCompiler class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RegexCompiler()
Visual C++
public:
RegexCompiler()

See Also

RegexCompiler Class
MSBuild.Community.Tasks Namespace


RegexCompiler Methods

[image] [image]

.NET Framework Class Library
RegexCompiler Methods
RegexCompiler Class See Also Send Feedback

The RegexCompiler type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

RegexCompiler Class
MSBuild.Community.Tasks Namespace


Execute Method

[image]

.NET Framework Class Library
RegexCompiler..::.Execute Method
RegexCompiler Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

RegexCompiler Class
MSBuild.Community.Tasks Namespace


RegexCompiler Properties

[image] [image]

.NET Framework Class Library
RegexCompiler Properties
RegexCompiler Class See Also Send Feedback

The RegexCompiler type exposes the following members.

Properties

Name | Description
AssemblyCompany | Gets or sets the assembly company.
AssemblyCopyright | Gets or sets the assembly copyright.
AssemblyCulture | Gets or sets the assembly culture.
AssemblyDescription | Gets or sets the assembly description.
AssemblyFileVersion | Gets or sets the assembly file version.
AssemblyInformationalVersion | Gets or sets the assembly informational version.
AssemblyKeyFile | Gets or sets the assembly key file.
AssemblyName | Gets or sets the name of the assembly to be created by the regex compiler.
AssemblyProduct | Gets or sets the assembly product.
AssemblyTitle | Gets or sets the assembly title.
AssemblyVersion | Gets or sets the assembly version.
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
IsPublic | Gets or sets a value indicating whether the default value is public for regular expression instances.
Log | (Inherited from Task.)
Namespace | Gets or sets the default namespace for regular expression instances.
Options | Gets or sets the default regular expression options.
OutputDirectory | Gets or sets the directory where the assembly will be saved.
OutputFile | Gets or sets the output file.
RegularExpressions | Gets or sets the regular expressions.
TaskResources | (Inherited from Task.)

See Also

RegexCompiler Class
MSBuild.Community.Tasks Namespace


AssemblyCompany Property

[image]

.NET Framework Class Library
RegexCompiler..::.AssemblyCompany Property
RegexCompiler Class See Also Send Feedback

Gets or sets the assembly company.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyCompany As String
C#
public string AssemblyCompany { get; set; }
Visual C++
public:
property String^ AssemblyCompany {
    String^ get ();
    void set (String^ value);
}

Field Value

The assembly company.

See Also

RegexCompiler Class
MSBuild.Community.Tasks Namespace


AssemblyCopyright Property

[image]

.NET Framework Class Library
RegexCompiler..::.AssemblyCopyright Property
RegexCompiler Class See Also Send Feedback

Gets or sets the assembly copyright.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyCopyright As String
C#
public string AssemblyCopyright { get; set; }
Visual C++
public:
property String^ AssemblyCopyright {
    String^ get ();
    void set (String^ value);
}

Field Value

The assembly copyright.

See Also

RegexCompiler Class
MSBuild.Community.Tasks Namespace


AssemblyCulture Property

[image]

.NET Framework Class Library
RegexCompiler..::.AssemblyCulture Property
RegexCompiler Class See Also Send Feedback

Gets or sets the assembly culture.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyCulture As String
C#
public string AssemblyCulture { get; set; }
Visual C++
public:
property String^ AssemblyCulture {
    String^ get ();
    void set (String^ value);
}

Field Value

The assembly culture.

See Also

RegexCompiler Class
MSBuild.Community.Tasks Namespace


AssemblyDescription Property

[image]

.NET Framework Class Library
RegexCompiler..::.AssemblyDescription Property
RegexCompiler Class See Also Send Feedback

Gets or sets the assembly description.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyDescription As String
C#
public string AssemblyDescription { get; set; }
Visual C++
public:
property String^ AssemblyDescription {
    String^ get ();
    void set (String^ value);
}

Field Value

The assembly description.

See Also

RegexCompiler Class
MSBuild.Community.Tasks Namespace


AssemblyFileVersion Property

[image]

.NET Framework Class Library
RegexCompiler..::.AssemblyFileVersion Property
RegexCompiler Class See Also Send Feedback

Gets or sets the assembly file version.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyFileVersion As String
C#
public string AssemblyFileVersion { get; set; }
Visual C++
public:
property String^ AssemblyFileVersion {
    String^ get ();
    void set (String^ value);
}

Field Value

The assembly file version.

See Also

RegexCompiler Class
MSBuild.Community.Tasks Namespace


AssemblyInformationalVersion Property

[image]

.NET Framework Class Library
RegexCompiler..::.AssemblyInformationalVersion Property
RegexCompiler Class See Also Send Feedback

Gets or sets the assembly informational version.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyInformationalVersion As String
C#
public string AssemblyInformationalVersion { get; set; }
Visual C++
public:
property String^ AssemblyInformationalVersion {
    String^ get ();
    void set (String^ value);
}

Field Value

The assembly informational version.

See Also

RegexCompiler Class
MSBuild.Community.Tasks Namespace


AssemblyKeyFile Property

[image]

.NET Framework Class Library
RegexCompiler..::.AssemblyKeyFile Property
RegexCompiler Class See Also Send Feedback

Gets or sets the assembly key file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyKeyFile As String
C#
public string AssemblyKeyFile { get; set; }
Visual C++
public:
property String^ AssemblyKeyFile {
    String^ get ();
    void set (String^ value);
}

Field Value

The assembly key file.

See Also

RegexCompiler Class
MSBuild.Community.Tasks Namespace


AssemblyName Property

[image]

.NET Framework Class Library
RegexCompiler..::.AssemblyName Property
RegexCompiler Class See Also Send Feedback

Gets or sets the name of the assembly to be created by the regex compiler.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property AssemblyName As String
C#
[RequiredAttribute]
public string AssemblyName { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ AssemblyName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the assembly.

See Also

RegexCompiler Class
MSBuild.Community.Tasks Namespace


AssemblyProduct Property

[image]

.NET Framework Class Library
RegexCompiler..::.AssemblyProduct Property
RegexCompiler Class See Also Send Feedback

Gets or sets the assembly product.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyProduct As String
C#
public string AssemblyProduct { get; set; }
Visual C++
public:
property String^ AssemblyProduct {
    String^ get ();
    void set (String^ value);
}

Field Value

The assembly product.

See Also

RegexCompiler Class
MSBuild.Community.Tasks Namespace


AssemblyTitle Property

[image]

.NET Framework Class Library
RegexCompiler..::.AssemblyTitle Property
RegexCompiler Class See Also Send Feedback

Gets or sets the assembly title.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyTitle As String
C#
public string AssemblyTitle { get; set; }
Visual C++
public:
property String^ AssemblyTitle {
    String^ get ();
    void set (String^ value);
}

Field Value

The assembly title.

See Also

RegexCompiler Class
MSBuild.Community.Tasks Namespace


AssemblyVersion Property

[image]

.NET Framework Class Library
RegexCompiler..::.AssemblyVersion Property
RegexCompiler Class See Also Send Feedback

Gets or sets the assembly version.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyVersion As String
C#
public string AssemblyVersion { get; set; }
Visual C++
public:
property String^ AssemblyVersion {
    String^ get ();
    void set (String^ value);
}

Field Value

The assembly version.

See Also

RegexCompiler Class
MSBuild.Community.Tasks Namespace


IsPublic Property

[image]

.NET Framework Class Library
RegexCompiler..::.IsPublic Property
RegexCompiler Class See Also Send Feedback

Gets or sets a value indicating whether the default value is public for regular expression instances.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property IsPublic As Boolean
C#
public bool IsPublic { get; set; }
Visual C++
public:
property bool IsPublic {
    bool get ();
    void set (bool value);
}

Field Value

true if regular expression instance is public; otherwise, false.

See Also

RegexCompiler Class
MSBuild.Community.Tasks Namespace


Namespace Property

[image]

.NET Framework Class Library
RegexCompiler..::.Namespace Property
RegexCompiler Class See Also Send Feedback

Gets or sets the default namespace for regular expression instances.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Namespace As String
C#
public string Namespace { get; set; }
Visual C++
public:
property String^ Namespace {
    String^ get ();
    void set (String^ value);
}

Field Value

The namespace for regular expression instances.

See Also

RegexCompiler Class
MSBuild.Community.Tasks Namespace


Options Property

[image]

.NET Framework Class Library
RegexCompiler..::.Options Property
RegexCompiler Class See Also Send Feedback

Gets or sets the default regular expression options.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Options As String
C#
public string Options { get; set; }
Visual C++
public:
property String^ Options {
    String^ get ();
    void set (String^ value);
}

Field Value

The default regular expression options.

See Also

RegexCompiler Class
MSBuild.Community.Tasks Namespace


OutputDirectory Property

[image]

.NET Framework Class Library
RegexCompiler..::.OutputDirectory Property
RegexCompiler Class See Also Send Feedback

Gets or sets the directory where the assembly will be saved.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property OutputDirectory As String
C#
[RequiredAttribute]
public string OutputDirectory { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ OutputDirectory {
    String^ get ();
    void set (String^ value);
}

Field Value

The output directory.

See Also

RegexCompiler Class
MSBuild.Community.Tasks Namespace


OutputFile Property

[image]

.NET Framework Class Library
RegexCompiler..::.OutputFile Property
RegexCompiler Class See Also Send Feedback

Gets or sets the output file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public Property OutputFile As ITaskItem
C#
[OutputAttribute]
public ITaskItem OutputFile { get; set; }
Visual C++
[OutputAttribute]
public:
property ITaskItem^ OutputFile {
    ITaskItem^ get ();
    void set (ITaskItem^ value);
}

Field Value

The output file.

See Also

RegexCompiler Class
MSBuild.Community.Tasks Namespace


RegularExpressions Property

[image]

.NET Framework Class Library
RegexCompiler..::.RegularExpressions Property
RegexCompiler Class See Also Send Feedback

Gets or sets the regular expressions.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property RegularExpressions As ITaskItem()
C#
[RequiredAttribute]
public ITaskItem[] RegularExpressions { get; set; }
Visual C++
[RequiredAttribute]
public:
property array<ITaskItem^>^ RegularExpressions {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

Field Value

The regular expressions.

See Also

RegexCompiler Class
MSBuild.Community.Tasks Namespace


RegexMatch Class

[image]

.NET Framework Class Library
RegexMatch Class
Members Example See Also Send Feedback

Task to filter an Input list with a Regex expression. Output list contains items from Input list that matched given expression

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class RegexMatch _
    Inherits RegexBase
C#
public class RegexMatch : RegexBase
Visual C++
public ref class RegexMatch : public RegexBase

Examples

Matches from TestGroup those names ending in a, b or c
Copy Code
            <ItemGroup>
               <TestGroup Include="foo.my.foo.foo.test.o" />
               <TestGroup Include="foo.my.faa.foo.test.a" />
               <TestGroup Include="foo.my.fbb.foo.test.b" />
               <TestGroup Include="foo.my.fcc.foo.test.c" />
               <TestGroup Include="foo.my.fdd.foo.test.d" />
               <TestGroup Include="foo.my.fee.foo.test.e" />
               <TestGroup Include="foo.my.fff.foo.test.f" />
            </ItemGroup>
            <Target Name="Test">
               <!-- Outputs only items that end with a, b or c -->
               <RegexMatch Input="@(TestGroup)" Expression="[a-c]$">
                  <Output ItemName ="MatchReturn" TaskParameter="Output" />
               </RegexMatch>
               <Message Text="&#xA;Output Match:&#xA;@(MatchReturn, '&#xA;')" />
            </Target>

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks..::.RegexBase
MSBuild.Community.Tasks..::.RegexMatch

See Also

RegexMatch Members
MSBuild.Community.Tasks Namespace


RegexMatch Members

[image] [image]

.NET Framework Class Library
RegexMatch Members
RegexMatch Class Constructors Methods Properties See Also Send Feedback

The RegexMatch type exposes the following members.

Constructors

Name | Description
RegexMatch |

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | Performs the Match task (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Expression | Regex expression (Inherited from RegexBase.)
ExpressionOptions | Options converted to RegexOptions enum (Inherited from RegexBase.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Input | Input, list of items to perform the regex on (Inherited from RegexBase.)
Log | (Inherited from Task.)
Options | Regex options as strings corresponding to the RegexOptions enum: Compiled CultureInvariant ECMAScript ExplicitCapture IgnoreCase IgnorePatternWhitespace Multiline None RightToLeft Singleline (Inherited from RegexBase.)
Output | Results of the Regex transformation. (Inherited from RegexBase.)
TaskResources | (Inherited from Task.)

See Also

RegexMatch Class
MSBuild.Community.Tasks Namespace


RegexMatch Constructor

[image]

.NET Framework Class Library
RegexMatch Constructor
RegexMatch Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RegexMatch()
Visual C++
public:
RegexMatch()

See Also

RegexMatch Class
MSBuild.Community.Tasks Namespace


RegexMatch Methods

[image] [image]

.NET Framework Class Library
RegexMatch Methods
RegexMatch Class See Also Send Feedback

The RegexMatch type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | Performs the Match task (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

RegexMatch Class
MSBuild.Community.Tasks Namespace


Execute Method

[image]

.NET Framework Class Library
RegexMatch..::.Execute Method
RegexMatch Class See Also Send Feedback

Performs the Match task

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

trueTruetruetrue (True in Visual Basic) if the task ran successfully; otherwise falseFalsefalsefalse (False in Visual Basic).

Implements

ITask..::.Execute()()()

See Also

RegexMatch Class
MSBuild.Community.Tasks Namespace


RegexMatch Properties

[image] [image]

.NET Framework Class Library
RegexMatch Properties
RegexMatch Class See Also Send Feedback

The RegexMatch type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Expression | Regex expression (Inherited from RegexBase.)
ExpressionOptions | Options converted to RegexOptions enum (Inherited from RegexBase.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Input | Input, list of items to perform the regex on (Inherited from RegexBase.)
Log | (Inherited from Task.)
Options | Regex options as strings corresponding to the RegexOptions enum: Compiled CultureInvariant ECMAScript ExplicitCapture IgnoreCase IgnorePatternWhitespace Multiline None RightToLeft Singleline (Inherited from RegexBase.)
Output | Results of the Regex transformation. (Inherited from RegexBase.)
TaskResources | (Inherited from Task.)

See Also

RegexMatch Class
MSBuild.Community.Tasks Namespace


RegexReplace Class

[image]

.NET Framework Class Library
RegexReplace Class
Members Example See Also Send Feedback

Task to replace portions of strings within the Input list Output list contains all the elements of the Input list after performing the Regex Replace.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class RegexReplace _
    Inherits RegexBase
C#
public class RegexReplace : RegexBase
Visual C++
public ref class RegexReplace : public RegexBase

Examples

1st example replaces first occurance of "foo." with empty string 2nd example replaces occurance of "foo." after character 6 with "oop." string
Copy Code
            <ItemGroup>
               <TestGroup Include="foo.my.foo.foo.test.o" />
               <TestGroup Include="foo.my.faa.foo.test.a" />
               <TestGroup Include="foo.my.fbb.foo.test.b" />
               <TestGroup Include="foo.my.fcc.foo.test.c" />
               <TestGroup Include="foo.my.fdd.foo.test.d" />
               <TestGroup Include="foo.my.fee.foo.test.e" />
               <TestGroup Include="foo.my.fff.foo.test.f" />
            </ItemGroup>
            <Target Name="Test">
               <Message Text="Input:&#xA;@(TestGroup, '&#xA;')"/>
               <!-- Replaces first occurance of "foo." with empty string-->
               <RegexReplace Input="@(TestGroup)" Expression="foo\." Replacement="" Count="1">
                  <Output ItemName ="ReplaceReturn1" TaskParameter="Output" />
               </RegexReplace>
               <Message Text="&#xA;Output Replace 1:&#xA;@(ReplaceReturn1, '&#xA;')" />
               <!-- Replaces occurance of "foo." after character 6 with "oop." string-->
               <RegexReplace Input="@(TestGroup)" Expression="foo\." Replacement="oop" Startat="6">
                  <Output ItemName ="ReplaceReturn2" TaskParameter="Output" />
               </RegexReplace>
               <Message Text="&#xA;Output Replace 2:&#xA;@(ReplaceReturn2, '&#xA;')" />
            </Target>

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks..::.RegexBase
MSBuild.Community.Tasks..::.RegexReplace

See Also

RegexReplace Members
MSBuild.Community.Tasks Namespace


RegexReplace Members

[image] [image]

.NET Framework Class Library
RegexReplace Members
RegexReplace Class Constructors Methods Properties See Also Send Feedback

The RegexReplace type exposes the following members.

Constructors

Name | Description
RegexReplace |

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | Performs the Replace task (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Count | Number of matches to allow on each input item. -1 indicates to perform matches on all matches within input item
Expression | Regex expression (Inherited from RegexBase.)
ExpressionOptions | Options converted to RegexOptions enum (Inherited from RegexBase.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Input | Input, list of items to perform the regex on (Inherited from RegexBase.)
Log | (Inherited from Task.)
Options | Regex options as strings corresponding to the RegexOptions enum: Compiled CultureInvariant ECMAScript ExplicitCapture IgnoreCase IgnorePatternWhitespace Multiline None RightToLeft Singleline (Inherited from RegexBase.)
Output | Results of the Regex transformation. (Inherited from RegexBase.)
Replacement | String replacing matching expression strings in input list. If left empty matches in the input list are removed (replaced with empty string)
StartAt | Position within the input item to start matching
TaskResources | (Inherited from Task.)

See Also

RegexReplace Class
MSBuild.Community.Tasks Namespace


RegexReplace Constructor

[image]

.NET Framework Class Library
RegexReplace Constructor
RegexReplace Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RegexReplace()
Visual C++
public:
RegexReplace()

See Also

RegexReplace Class
MSBuild.Community.Tasks Namespace


RegexReplace Methods

[image] [image]

.NET Framework Class Library
RegexReplace Methods
RegexReplace Class See Also Send Feedback

The RegexReplace type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | Performs the Replace task (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

RegexReplace Class
MSBuild.Community.Tasks Namespace


Execute Method

[image]

.NET Framework Class Library
RegexReplace..::.Execute Method
RegexReplace Class See Also Send Feedback

Performs the Replace task

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

trueTruetruetrue (True in Visual Basic) if the task ran successfully; otherwise falseFalsefalsefalse (False in Visual Basic).

Implements

ITask..::.Execute()()()

See Also

RegexReplace Class
MSBuild.Community.Tasks Namespace


RegexReplace Properties

[image] [image]

.NET Framework Class Library
RegexReplace Properties
RegexReplace Class See Also Send Feedback

The RegexReplace type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Count | Number of matches to allow on each input item. -1 indicates to perform matches on all matches within input item
Expression | Regex expression (Inherited from RegexBase.)
ExpressionOptions | Options converted to RegexOptions enum (Inherited from RegexBase.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Input | Input, list of items to perform the regex on (Inherited from RegexBase.)
Log | (Inherited from Task.)
Options | Regex options as strings corresponding to the RegexOptions enum: Compiled CultureInvariant ECMAScript ExplicitCapture IgnoreCase IgnorePatternWhitespace Multiline None RightToLeft Singleline (Inherited from RegexBase.)
Output | Results of the Regex transformation. (Inherited from RegexBase.)
Replacement | String replacing matching expression strings in input list. If left empty matches in the input list are removed (replaced with empty string)
StartAt | Position within the input item to start matching
TaskResources | (Inherited from Task.)

See Also

RegexReplace Class
MSBuild.Community.Tasks Namespace


Count Property

[image]

.NET Framework Class Library
RegexReplace..::.Count Property
RegexReplace Class See Also Send Feedback

Number of matches to allow on each input item. -1 indicates to perform matches on all matches within input item

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Count As ITaskItem
C#
public ITaskItem Count { get; set; }
Visual C++
public:
property ITaskItem^ Count {
    ITaskItem^ get ();
    void set (ITaskItem^ value);
}

See Also

RegexReplace Class
MSBuild.Community.Tasks Namespace


Replacement Property

[image]

.NET Framework Class Library
RegexReplace..::.Replacement Property
RegexReplace Class See Also Send Feedback

String replacing matching expression strings in input list. If left empty matches in the input list are removed (replaced with empty string)

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Replacement As ITaskItem
C#
public ITaskItem Replacement { get; set; }
Visual C++
public:
property ITaskItem^ Replacement {
    ITaskItem^ get ();
    void set (ITaskItem^ value);
}

See Also

RegexReplace Class
MSBuild.Community.Tasks Namespace


StartAt Property

[image]

.NET Framework Class Library
RegexReplace..::.StartAt Property
RegexReplace Class See Also Send Feedback

Position within the input item to start matching

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property StartAt As ITaskItem
C#
public ITaskItem StartAt { get; set; }
Visual C++
public:
property ITaskItem^ StartAt {
    ITaskItem^ get ();
    void set (ITaskItem^ value);
}

See Also

RegexReplace Class
MSBuild.Community.Tasks Namespace


RegistryRead Class

[image]

.NET Framework Class Library
RegistryRead Class
Members Example See Also Send Feedback

Reads a value from the Registry

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class RegistryRead _
    Inherits Task
C#
public class RegistryRead : Task
Visual C++
public ref class RegistryRead : public Task

Remarks

The Value parameter is set according to the following rules:
If a DefaultValue is provided, it will be used if the KeyName or ValueName does not exist.
If a DefaultValue is not provided, the KeyName exists, but the ValueName does not exist, Value will be set to an empty string.
If a DefaultValue is not provided, and the KeyName does not exist, the task will fail.

Examples

Read .NET Framework install root from Registry.
Copy Code
            <RegistryRead
                KeyName="HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework"
                ValueName="InstallRoot">
                <Output TaskParameter="Value" PropertyName="InstallRoot" />
            </RegistryRead>
            <Message Text="InstallRoot: $(InstallRoot)"/>

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks..::.RegistryRead

See Also

RegistryRead Members
MSBuild.Community.Tasks Namespace


RegistryRead Members

[image] [image]

.NET Framework Class Library
RegistryRead Members
RegistryRead Class Constructors Methods Properties See Also Send Feedback

The RegistryRead type exposes the following members.

Constructors

Name | Description
RegistryRead | Initializes a new instance of the RegistryRead class.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
DefaultValue | Gets or sets the default value.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
KeyName | Gets or sets the full registry path of the key, beginning with a valid registry root, such as "HKEY_CURRENT_USER".
Log | (Inherited from Task.)
TaskResources | (Inherited from Task.)
Value | Gets the stored value.
ValueName | Gets or sets the name of the name/value pair.

See Also

RegistryRead Class
MSBuild.Community.Tasks Namespace


RegistryRead Constructor

[image]

.NET Framework Class Library
RegistryRead Constructor
RegistryRead Class See Also Send Feedback

Initializes a new instance of the RegistryRead class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RegistryRead()
Visual C++
public:
RegistryRead()

See Also

RegistryRead Class
MSBuild.Community.Tasks Namespace


RegistryRead Methods

[image] [image]

.NET Framework Class Library
RegistryRead Methods
RegistryRead Class See Also Send Feedback

The RegistryRead type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

RegistryRead Class
MSBuild.Community.Tasks Namespace


Execute Method

[image]

.NET Framework Class Library
RegistryRead..::.Execute Method
RegistryRead Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

RegistryRead Class
MSBuild.Community.Tasks Namespace


RegistryRead Properties

[image] [image]

.NET Framework Class Library
RegistryRead Properties
RegistryRead Class See Also Send Feedback

The RegistryRead type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
DefaultValue | Gets or sets the default value.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
KeyName | Gets or sets the full registry path of the key, beginning with a valid registry root, such as "HKEY_CURRENT_USER".
Log | (Inherited from Task.)
TaskResources | (Inherited from Task.)
Value | Gets the stored value.
ValueName | Gets or sets the name of the name/value pair.

See Also

RegistryRead Class
MSBuild.Community.Tasks Namespace


DefaultValue Property

[image]

.NET Framework Class Library
RegistryRead..::.DefaultValue Property
RegistryRead Class See Also Send Feedback

Gets or sets the default value.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultValue As String
C#
public string DefaultValue { get; set; }
Visual C++
public:
property String^ DefaultValue {
    String^ get ();
    void set (String^ value);
}

Field Value

The default value.

See Also

RegistryRead Class
MSBuild.Community.Tasks Namespace


KeyName Property

[image]

.NET Framework Class Library
RegistryRead..::.KeyName Property
RegistryRead Class See Also Send Feedback

Gets or sets the full registry path of the key, beginning with a valid registry root, such as "HKEY_CURRENT_USER".

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property KeyName As String
C#
[RequiredAttribute]
public string KeyName { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ KeyName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the key.

See Also

RegistryRead Class
MSBuild.Community.Tasks Namespace


Value Property

[image]

.NET Framework Class Library
RegistryRead..::.Value Property
RegistryRead Class See Also Send Feedback

Gets the stored value.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property Value As String
C#
[OutputAttribute]
public string Value { get; }
Visual C++
[OutputAttribute]
public:
property String^ Value {
    String^ get ();
}

Field Value

The value.

See Also

RegistryRead Class
MSBuild.Community.Tasks Namespace


ValueName Property

[image]

.NET Framework Class Library
RegistryRead..::.ValueName Property
RegistryRead Class See Also Send Feedback

Gets or sets the name of the name/value pair.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ValueName As String
C#
public string ValueName { get; set; }
Visual C++
public:
property String^ ValueName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the value.

See Also

RegistryRead Class
MSBuild.Community.Tasks Namespace


RegistryWrite Class

[image]

.NET Framework Class Library
RegistryWrite Class
Members Example See Also Send Feedback

Writes a value to the Registry

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class RegistryWrite _
    Inherits Task
C#
public class RegistryWrite : Task
Visual C++
public ref class RegistryWrite : public Task

Examples

Write a value to Registry
Copy Code
            <RegistryWrite
                KeyName="HKEY_CURRENT_USER\SOFTWARE\MSBuildTasks"
                ValueName="RegistryWrite"
                Value="Test Write" />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks..::.RegistryWrite

See Also

RegistryWrite Members
MSBuild.Community.Tasks Namespace


RegistryWrite Members

[image] [image]

.NET Framework Class Library
RegistryWrite Members
RegistryWrite Class Constructors Methods Properties See Also Send Feedback

The RegistryWrite type exposes the following members.

Constructors

Name | Description
RegistryWrite | Initializes a new instance of the RegistryWrite class.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
KeyName | Gets or sets the full registry path of the key, beginning with a valid registry root, such as "HKEY_CURRENT_USER".
Log | (Inherited from Task.)
TaskResources | (Inherited from Task.)
Value | Gets or sets the value to be stored.
ValueName | Gets or sets the name of the name/value pair.

See Also

RegistryWrite Class
MSBuild.Community.Tasks Namespace


RegistryWrite Constructor

[image]

.NET Framework Class Library
RegistryWrite Constructor
RegistryWrite Class See Also Send Feedback

Initializes a new instance of the RegistryWrite class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RegistryWrite()
Visual C++
public:
RegistryWrite()

See Also

RegistryWrite Class
MSBuild.Community.Tasks Namespace


RegistryWrite Methods

[image] [image]

.NET Framework Class Library
RegistryWrite Methods
RegistryWrite Class See Also Send Feedback

The RegistryWrite type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

RegistryWrite Class
MSBuild.Community.Tasks Namespace


Execute Method

[image]

.NET Framework Class Library
RegistryWrite..::.Execute Method
RegistryWrite Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

RegistryWrite Class
MSBuild.Community.Tasks Namespace


RegistryWrite Properties

[image] [image]

.NET Framework Class Library
RegistryWrite Properties
RegistryWrite Class See Also Send Feedback

The RegistryWrite type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
KeyName | Gets or sets the full registry path of the key, beginning with a valid registry root, such as "HKEY_CURRENT_USER".
Log | (Inherited from Task.)
TaskResources | (Inherited from Task.)
Value | Gets or sets the value to be stored.
ValueName | Gets or sets the name of the name/value pair.

See Also

RegistryWrite Class
MSBuild.Community.Tasks Namespace


KeyName Property

[image]

.NET Framework Class Library
RegistryWrite..::.KeyName Property
RegistryWrite Class See Also Send Feedback

Gets or sets the full registry path of the key, beginning with a valid registry root, such as "HKEY_CURRENT_USER".

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property KeyName As String
C#
[RequiredAttribute]
public string KeyName { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ KeyName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the key.

See Also

RegistryWrite Class
MSBuild.Community.Tasks Namespace


Value Property

[image]

.NET Framework Class Library
RegistryWrite..::.Value Property
RegistryWrite Class See Also Send Feedback

Gets or sets the value to be stored.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property Value As String
C#
[RequiredAttribute]
public string Value { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Field Value

The value.

See Also

RegistryWrite Class
MSBuild.Community.Tasks Namespace


ValueName Property

[image]

.NET Framework Class Library
RegistryWrite..::.ValueName Property
RegistryWrite Class See Also Send Feedback

Gets or sets the name of the name/value pair.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ValueName As String
C#
public string ValueName { get; set; }
Visual C++
public:
property String^ ValueName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the value.

See Also

RegistryWrite Class
MSBuild.Community.Tasks Namespace


RoboCopy Class

[image]

.NET Framework Class Library
RoboCopy Class
Members Example See Also Send Feedback

Task wrapping the Window Resource Kit Robocopy.exe command.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class RoboCopy _
    Inherits ToolTask
C#
public class RoboCopy : ToolTask
Visual C++
public ref class RoboCopy : public ToolTask

Examples

Deploy website to web server.
Copy Code
            <RoboCopy
                SourceFolder="$(MSBuildProjectDirectory)"
                DestinationFolder="\\server\webroot\"
                Mirror="true"
                ExcludeFolders=".svn;obj;Test"
                ExcludeFiles="*.cs;*.resx;*.csproj;*.webinfo;*.log"
                NoJobHeader="true"
            />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
Microsoft.Build.Utilities..::.ToolTask
MSBuild.Community.Tasks..::.RoboCopy

See Also

RoboCopy Members
MSBuild.Community.Tasks Namespace


RoboCopy Members

[image] [image]

.NET Framework Class Library
RoboCopy Members
RoboCopy Class Constructors Methods Properties See Also Send Feedback

The RoboCopy type exposes the following members.

Constructors

Name | Description
RoboCopy |

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from ToolTask.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (Overrides ToolTask..::.HandleTaskExecutionErrors()()().)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | (Inherited from ToolTask.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Overrides ToolTask..::.LogToolCommand(String).)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

Properties

Name | Description
AllSubdirectories | /E Copies all subdirectories (including empty ones).
AppendLogFile | /LOG+:file Redirects output to the specified file, appending it to the file if it already exists.
BackupMode | /B Copies files in Backup mode (Backup copies are not restartable, but can copy some files that restartable mode cannot).
BuildEngine | (Inherited from Task.)
CopyAll | /COPYALL Copies Everything. Equivalent to /COPY:DATSOU.
CopyFlags | /COPY:copyflags Copies the file information specified by copyflags.
Create | /CREATE Creates a directory tree structure containing zero-length files only (that is, no file data is copied).
DestinationFolder | Destination directory.
EnvironmentOverride | (Inherited from ToolTask.)
ExcludeFiles | /XF file [file] Excludes files with the specified names, paths, or wildcard characters.
ExcludeFolders | /XD dir [dir] Excludes directories with the specified names, paths, or wildcard characters.
ExcludeJunctions | /XJ Excludes Junction points.
ExcluedAttributes | /XA:{R|A|S|H|C|N|E|T|O} Excludes files with the specified attributes.
ExitCode | (Inherited from ToolTask.)
FatFileNames | /FAT Creates destination files using only 8.3 FAT file names.
FatFileTimes | /FFT Assume FAT File Times (2-second granularity).
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
IncludeArchive | /A Copies only files with the archive attribute set.
IncludeArchiveClear | /M Copies only files with the archive attribute set and then resets (turns off) the archive attribute in the source files.
IncludeAttributes | /IA:{R|A|S|H|C|N|E|T|O} Includes files with the specified attributes.
Log | (Inherited from Task.)
LogFile | /LOG:file Redirects output to the specified file, overwriting the file if it already exists.
Mirror | /MIR Mirrors a directory tree (equivalent to running both /E and /PURGE).
Move | /MOVE Moves files and directories (that is, deletes source files and directories after copying).
MoveFiles | /MOV Moves files (that is, deletes source files after copying).
NoCopy | /NOCOPY Copies Nothing. Can be useful with /PURGE.
NoFileLogging | /NFL Turns off logging of file names. File names are still shown, however, if file copy errors occur.
NoFolderLogging | /NDL Turns off logging of directory names. Full file pathnames (as opposed to simple file names) will be shown if /NDL is used.
NoJobHeader | /NJH Turns of logging of the job header.
NoJobSummary | /NJS Turns off logging of the job summary.
NoProgress | /NP Turns off copy progress indicator (% copied).
Options | Manually entered options.
Purge | /PURGE Deletes destination files and directories that no longer exist in the source.
ResponseFileEncoding | (Inherited from ToolTask.)
RestartableMode | /Z Copies files in restartable mode (that is, restarts the copy process from the point of failure).
Security | /SEC Copies NTFS security information. (Source and destination volumes must both be NTFS). Equivalent to /COPY:DATS.
SourceFiles | Names of files to act upon.
SourceFolder | Source directory
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Overrides ToolTask..::.StandardOutputLoggingImportance.)
Subdirectories | /S Copies subdirectories (excluding empty ones).
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)
Verbose | /V Produces verbose output (including skipped files).

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


RoboCopy Constructor

[image]

.NET Framework Class Library
RoboCopy Constructor
RoboCopy Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RoboCopy()
Visual C++
public:
RoboCopy()

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


RoboCopy Methods

[image] [image]

.NET Framework Class Library
RoboCopy Methods
RoboCopy Class See Also Send Feedback

The RoboCopy type exposes the following members.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from ToolTask.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (Overrides ToolTask..::.HandleTaskExecutionErrors()()().)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | (Inherited from ToolTask.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Overrides ToolTask..::.LogToolCommand(String).)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


GenerateCommandLineCommands Method

[image]

.NET Framework Class Library
RoboCopy..::.GenerateCommandLineCommands Method
RoboCopy Class See Also Send Feedback

Returns a string value containing the command line arguments to pass directly to the executable file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateCommandLineCommands As String
C#
protected override string GenerateCommandLineCommands()
Visual C++
protected:
virtual String^ GenerateCommandLineCommands() override

Return Value

A string value containing the command line arguments to pass directly to the executable file.

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


GenerateFullPathToTool Method

[image]

.NET Framework Class Library
RoboCopy..::.GenerateFullPathToTool Method
RoboCopy Class See Also Send Feedback

Returns the fully qualified path to the executable file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateFullPathToTool As String
C#
protected override string GenerateFullPathToTool()
Visual C++
protected:
virtual String^ GenerateFullPathToTool() override

Return Value

The fully qualified path to the executable file.

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


HandleTaskExecutionErrors Method

[image]

.NET Framework Class Library
RoboCopy..::.HandleTaskExecutionErrors Method
RoboCopy Class See Also Send Feedback

Handles execution errors raised by the executable file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function HandleTaskExecutionErrors As Boolean
C#
protected override bool HandleTaskExecutionErrors()
Visual C++
protected:
virtual bool HandleTaskExecutionErrors() override

Return Value

true if the method runs successfully; otherwise, false.

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


LogToolCommand Method

[image]

.NET Framework Class Library
RoboCopy..::.LogToolCommand Method
RoboCopy Class See Also Send Feedback

Logs the starting point of the run to all registered loggers.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub LogToolCommand ( _
    message As String _
)
C#
protected override void LogToolCommand(
    string message
)
Visual C++
protected:
virtual void LogToolCommand(
    String^ message
) override

Parameters

message
Type: System..::.String
A descriptive message to provide loggers, usually the command line and switches.

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


RoboCopy Properties

[image] [image]

.NET Framework Class Library
RoboCopy Properties
RoboCopy Class See Also Send Feedback

The RoboCopy type exposes the following members.

Properties

Name | Description
AllSubdirectories | /E Copies all subdirectories (including empty ones).
AppendLogFile | /LOG+:file Redirects output to the specified file, appending it to the file if it already exists.
BackupMode | /B Copies files in Backup mode (Backup copies are not restartable, but can copy some files that restartable mode cannot).
BuildEngine | (Inherited from Task.)
CopyAll | /COPYALL Copies Everything. Equivalent to /COPY:DATSOU.
CopyFlags | /COPY:copyflags Copies the file information specified by copyflags.
Create | /CREATE Creates a directory tree structure containing zero-length files only (that is, no file data is copied).
DestinationFolder | Destination directory.
EnvironmentOverride | (Inherited from ToolTask.)
ExcludeFiles | /XF file [file] Excludes files with the specified names, paths, or wildcard characters.
ExcludeFolders | /XD dir [dir] Excludes directories with the specified names, paths, or wildcard characters.
ExcludeJunctions | /XJ Excludes Junction points.
ExcluedAttributes | /XA:{R|A|S|H|C|N|E|T|O} Excludes files with the specified attributes.
ExitCode | (Inherited from ToolTask.)
FatFileNames | /FAT Creates destination files using only 8.3 FAT file names.
FatFileTimes | /FFT Assume FAT File Times (2-second granularity).
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
IncludeArchive | /A Copies only files with the archive attribute set.
IncludeArchiveClear | /M Copies only files with the archive attribute set and then resets (turns off) the archive attribute in the source files.
IncludeAttributes | /IA:{R|A|S|H|C|N|E|T|O} Includes files with the specified attributes.
Log | (Inherited from Task.)
LogFile | /LOG:file Redirects output to the specified file, overwriting the file if it already exists.
Mirror | /MIR Mirrors a directory tree (equivalent to running both /E and /PURGE).
Move | /MOVE Moves files and directories (that is, deletes source files and directories after copying).
MoveFiles | /MOV Moves files (that is, deletes source files after copying).
NoCopy | /NOCOPY Copies Nothing. Can be useful with /PURGE.
NoFileLogging | /NFL Turns off logging of file names. File names are still shown, however, if file copy errors occur.
NoFolderLogging | /NDL Turns off logging of directory names. Full file pathnames (as opposed to simple file names) will be shown if /NDL is used.
NoJobHeader | /NJH Turns of logging of the job header.
NoJobSummary | /NJS Turns off logging of the job summary.
NoProgress | /NP Turns off copy progress indicator (% copied).
Options | Manually entered options.
Purge | /PURGE Deletes destination files and directories that no longer exist in the source.
ResponseFileEncoding | (Inherited from ToolTask.)
RestartableMode | /Z Copies files in restartable mode (that is, restarts the copy process from the point of failure).
Security | /SEC Copies NTFS security information. (Source and destination volumes must both be NTFS). Equivalent to /COPY:DATS.
SourceFiles | Names of files to act upon.
SourceFolder | Source directory
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Overrides ToolTask..::.StandardOutputLoggingImportance.)
Subdirectories | /S Copies subdirectories (excluding empty ones).
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)
Verbose | /V Produces verbose output (including skipped files).

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


AllSubdirectories Property

[image]

.NET Framework Class Library
RoboCopy..::.AllSubdirectories Property
RoboCopy Class See Also Send Feedback

/E Copies all subdirectories (including empty ones).

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AllSubdirectories As Boolean
C#
public bool AllSubdirectories { get; set; }
Visual C++
public:
property bool AllSubdirectories {
    bool get ();
    void set (bool value);
}

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


AppendLogFile Property

[image]

.NET Framework Class Library
RoboCopy..::.AppendLogFile Property
RoboCopy Class See Also Send Feedback

/LOG+:file Redirects output to the specified file, appending it to the file if it already exists.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AppendLogFile As String
C#
public string AppendLogFile { get; set; }
Visual C++
public:
property String^ AppendLogFile {
    String^ get ();
    void set (String^ value);
}

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


BackupMode Property

[image]

.NET Framework Class Library
RoboCopy..::.BackupMode Property
RoboCopy Class See Also Send Feedback

/B Copies files in Backup mode (Backup copies are not restartable, but can copy some files that restartable mode cannot).

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property BackupMode As Boolean
C#
public bool BackupMode { get; set; }
Visual C++
public:
property bool BackupMode {
    bool get ();
    void set (bool value);
}

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


CopyAll Property

[image]

.NET Framework Class Library
RoboCopy..::.CopyAll Property
RoboCopy Class See Also Send Feedback

/COPYALL Copies Everything. Equivalent to /COPY:DATSOU.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property CopyAll As Boolean
C#
public bool CopyAll { get; set; }
Visual C++
public:
property bool CopyAll {
    bool get ();
    void set (bool value);
}

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


CopyFlags Property

[image]

.NET Framework Class Library
RoboCopy..::.CopyFlags Property
RoboCopy Class See Also Send Feedback

/COPY:copyflags Copies the file information specified by copyflags.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property CopyFlags As String
C#
public string CopyFlags { get; set; }
Visual C++
public:
property String^ CopyFlags {
    String^ get ();
    void set (String^ value);
}

Remarks

D – file Data, S – file Security (NTFS ACLs), A – file Attributes, O – file Ownership information, T – file Timestamps, U – file Auditing infomation.

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


Create Property

[image]

.NET Framework Class Library
RoboCopy..::.Create Property
RoboCopy Class See Also Send Feedback

/CREATE Creates a directory tree structure containing zero-length files only (that is, no file data is copied).

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Create As Boolean
C#
public bool Create { get; set; }
Visual C++
public:
property bool Create {
    bool get ();
    void set (bool value);
}

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


DestinationFolder Property

[image]

.NET Framework Class Library
RoboCopy..::.DestinationFolder Property
RoboCopy Class See Also Send Feedback

Destination directory.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property DestinationFolder As String
C#
[RequiredAttribute]
public string DestinationFolder { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ DestinationFolder {
    String^ get ();
    void set (String^ value);
}

Remarks

You can use drive:\path or \\server\share\path

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


ExcludeFiles Property

[image]

.NET Framework Class Library
RoboCopy..::.ExcludeFiles Property
RoboCopy Class See Also Send Feedback

/XF file [file] Excludes files with the specified names, paths, or wildcard characters.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ExcludeFiles As String()
C#
public string[] ExcludeFiles { get; set; }
Visual C++
public:
property array<String^>^ ExcludeFiles {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


ExcludeFolders Property

[image]

.NET Framework Class Library
RoboCopy..::.ExcludeFolders Property
RoboCopy Class See Also Send Feedback

/XD dir [dir] Excludes directories with the specified names, paths, or wildcard characters.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ExcludeFolders As String()
C#
public string[] ExcludeFolders { get; set; }
Visual C++
public:
property array<String^>^ ExcludeFolders {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


ExcludeJunctions Property

[image]

.NET Framework Class Library
RoboCopy..::.ExcludeJunctions Property
RoboCopy Class See Also Send Feedback

/XJ Excludes Junction points.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ExcludeJunctions As Boolean
C#
public bool ExcludeJunctions { get; set; }
Visual C++
public:
property bool ExcludeJunctions {
    bool get ();
    void set (bool value);
}

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


ExcluedAttributes Property

[image]

.NET Framework Class Library
RoboCopy..::.ExcluedAttributes Property
RoboCopy Class See Also Send Feedback

/XA:{R|A|S|H|C|N|E|T|O} Excludes files with the specified attributes.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ExcluedAttributes As String
C#
public string ExcluedAttributes { get; set; }
Visual C++
public:
property String^ ExcluedAttributes {
    String^ get ();
    void set (String^ value);
}

Remarks

The following file attributes can be acted upon: R – Read only, A – Archive, S – System, H – Hidden, C – Compressed, N – Not content indexed, E – Encrypted, T – Temporary, O - Offline

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


FatFileNames Property

[image]

.NET Framework Class Library
RoboCopy..::.FatFileNames Property
RoboCopy Class See Also Send Feedback

/FAT Creates destination files using only 8.3 FAT file names.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property FatFileNames As Boolean
C#
public bool FatFileNames { get; set; }
Visual C++
public:
property bool FatFileNames {
    bool get ();
    void set (bool value);
}

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


FatFileTimes Property

[image]

.NET Framework Class Library
RoboCopy..::.FatFileTimes Property
RoboCopy Class See Also Send Feedback

/FFT Assume FAT File Times (2-second granularity).

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property FatFileTimes As Boolean
C#
public bool FatFileTimes { get; set; }
Visual C++
public:
property bool FatFileTimes {
    bool get ();
    void set (bool value);
}

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


IncludeArchive Property

[image]

.NET Framework Class Library
RoboCopy..::.IncludeArchive Property
RoboCopy Class See Also Send Feedback

/A Copies only files with the archive attribute set.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property IncludeArchive As Boolean
C#
public bool IncludeArchive { get; set; }
Visual C++
public:
property bool IncludeArchive {
    bool get ();
    void set (bool value);
}

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


IncludeArchiveClear Property

[image]

.NET Framework Class Library
RoboCopy..::.IncludeArchiveClear Property
RoboCopy Class See Also Send Feedback

/M Copies only files with the archive attribute set and then resets (turns off) the archive attribute in the source files.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property IncludeArchiveClear As Boolean
C#
public bool IncludeArchiveClear { get; set; }
Visual C++
public:
property bool IncludeArchiveClear {
    bool get ();
    void set (bool value);
}

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


IncludeAttributes Property

[image]

.NET Framework Class Library
RoboCopy..::.IncludeAttributes Property
RoboCopy Class See Also Send Feedback

/IA:{R|A|S|H|C|N|E|T|O} Includes files with the specified attributes.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property IncludeAttributes As String
C#
public string IncludeAttributes { get; set; }
Visual C++
public:
property String^ IncludeAttributes {
    String^ get ();
    void set (String^ value);
}

Remarks

The following file attributes can be acted upon: R – Read only, A – Archive, S – System, H – Hidden, C – Compressed, N – Not content indexed, E – Encrypted, T – Temporary, O - Offline

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


LogFile Property

[image]

.NET Framework Class Library
RoboCopy..::.LogFile Property
RoboCopy Class See Also Send Feedback

/LOG:file Redirects output to the specified file, overwriting the file if it already exists.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property LogFile As String
C#
public string LogFile { get; set; }
Visual C++
public:
property String^ LogFile {
    String^ get ();
    void set (String^ value);
}

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


Mirror Property

[image]

.NET Framework Class Library
RoboCopy..::.Mirror Property
RoboCopy Class See Also Send Feedback

/MIR Mirrors a directory tree (equivalent to running both /E and /PURGE).

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Mirror As Boolean
C#
public bool Mirror { get; set; }
Visual C++
public:
property bool Mirror {
    bool get ();
    void set (bool value);
}

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


Move Property

[image]

.NET Framework Class Library
RoboCopy..::.Move Property
RoboCopy Class See Also Send Feedback

/MOVE Moves files and directories (that is, deletes source files and directories after copying).

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Move As Boolean
C#
public bool Move { get; set; }
Visual C++
public:
property bool Move {
    bool get ();
    void set (bool value);
}

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


MoveFiles Property

[image]

.NET Framework Class Library
RoboCopy..::.MoveFiles Property
RoboCopy Class See Also Send Feedback

/MOV Moves files (that is, deletes source files after copying).

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property MoveFiles As Boolean
C#
public bool MoveFiles { get; set; }
Visual C++
public:
property bool MoveFiles {
    bool get ();
    void set (bool value);
}

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


NoCopy Property

[image]

.NET Framework Class Library
RoboCopy..::.NoCopy Property
RoboCopy Class See Also Send Feedback

/NOCOPY Copies Nothing. Can be useful with /PURGE.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property NoCopy As Boolean
C#
public bool NoCopy { get; set; }
Visual C++
public:
property bool NoCopy {
    bool get ();
    void set (bool value);
}

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


NoFileLogging Property

[image]

.NET Framework Class Library
RoboCopy..::.NoFileLogging Property
RoboCopy Class See Also Send Feedback

/NFL Turns off logging of file names. File names are still shown, however, if file copy errors occur.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property NoFileLogging As Boolean
C#
public bool NoFileLogging { get; set; }
Visual C++
public:
property bool NoFileLogging {
    bool get ();
    void set (bool value);
}

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


NoFolderLogging Property

[image]

.NET Framework Class Library
RoboCopy..::.NoFolderLogging Property
RoboCopy Class See Also Send Feedback

/NDL Turns off logging of directory names. Full file pathnames (as opposed to simple file names) will be shown if /NDL is used.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property NoFolderLogging As Boolean
C#
public bool NoFolderLogging { get; set; }
Visual C++
public:
property bool NoFolderLogging {
    bool get ();
    void set (bool value);
}

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


NoJobHeader Property

[image]

.NET Framework Class Library
RoboCopy..::.NoJobHeader Property
RoboCopy Class See Also Send Feedback

/NJH Turns of logging of the job header.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property NoJobHeader As Boolean
C#
public bool NoJobHeader { get; set; }
Visual C++
public:
property bool NoJobHeader {
    bool get ();
    void set (bool value);
}

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


NoJobSummary Property

[image]

.NET Framework Class Library
RoboCopy..::.NoJobSummary Property
RoboCopy Class See Also Send Feedback

/NJS Turns off logging of the job summary.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property NoJobSummary As Boolean
C#
public bool NoJobSummary { get; set; }
Visual C++
public:
property bool NoJobSummary {
    bool get ();
    void set (bool value);
}

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


NoProgress Property

[image]

.NET Framework Class Library
RoboCopy..::.NoProgress Property
RoboCopy Class See Also Send Feedback

/NP Turns off copy progress indicator (% copied).

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property NoProgress As Boolean
C#
public bool NoProgress { get; set; }
Visual C++
public:
property bool NoProgress {
    bool get ();
    void set (bool value);
}

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


Options Property

[image]

.NET Framework Class Library
RoboCopy..::.Options Property
RoboCopy Class See Also Send Feedback

Manually entered options.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Options As String()
C#
public string[] Options { get; set; }
Visual C++
public:
property array<String^>^ Options {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


Purge Property

[image]

.NET Framework Class Library
RoboCopy..::.Purge Property
RoboCopy Class See Also Send Feedback

/PURGE Deletes destination files and directories that no longer exist in the source.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Purge As Boolean
C#
public bool Purge { get; set; }
Visual C++
public:
property bool Purge {
    bool get ();
    void set (bool value);
}

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


RestartableMode Property

[image]

.NET Framework Class Library
RoboCopy..::.RestartableMode Property
RoboCopy Class See Also Send Feedback

/Z Copies files in restartable mode (that is, restarts the copy process from the point of failure).

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property RestartableMode As Boolean
C#
public bool RestartableMode { get; set; }
Visual C++
public:
property bool RestartableMode {
    bool get ();
    void set (bool value);
}

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


Security Property

[image]

.NET Framework Class Library
RoboCopy..::.Security Property
RoboCopy Class See Also Send Feedback

/SEC Copies NTFS security information. (Source and destination volumes must both be NTFS). Equivalent to /COPY:DATS.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Security As Boolean
C#
public bool Security { get; set; }
Visual C++
public:
property bool Security {
    bool get ();
    void set (bool value);
}

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


SourceFiles Property

[image]

.NET Framework Class Library
RoboCopy..::.SourceFiles Property
RoboCopy Class See Also Send Feedback

Names of files to act upon.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property SourceFiles As String()
C#
public string[] SourceFiles { get; set; }
Visual C++
public:
property array<String^>^ SourceFiles {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Remarks

You can use wildcard characters (? and *). If no files are listed, Robocopy defaults to all files (*.*).

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


SourceFolder Property

[image]

.NET Framework Class Library
RoboCopy..::.SourceFolder Property
RoboCopy Class See Also Send Feedback

Source directory

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property SourceFolder As String
C#
[RequiredAttribute]
public string SourceFolder { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ SourceFolder {
    String^ get ();
    void set (String^ value);
}

Remarks

You can use drive:\path or \\server\share\path

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


StandardOutputLoggingImportance Property

[image]

.NET Framework Class Library
RoboCopy..::.StandardOutputLoggingImportance Property
RoboCopy Class See Also Send Feedback

Gets the MessageImportance with which to log errors.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property StandardOutputLoggingImportance As MessageImportance
C#
protected override MessageImportance StandardOutputLoggingImportance { get; }
Visual C++
protected:
virtual property MessageImportance StandardOutputLoggingImportance {
    MessageImportance get () override;
}

Field Value

Return Value

The MessageImportance with which to log errors.

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


Subdirectories Property

[image]

.NET Framework Class Library
RoboCopy..::.Subdirectories Property
RoboCopy Class See Also Send Feedback

/S Copies subdirectories (excluding empty ones).

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Subdirectories As Boolean
C#
public bool Subdirectories { get; set; }
Visual C++
public:
property bool Subdirectories {
    bool get ();
    void set (bool value);
}

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


ToolName Property

[image]

.NET Framework Class Library
RoboCopy..::.ToolName Property
RoboCopy Class See Also Send Feedback

Gets the name of the executable file to run.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ToolName As String
C#
protected override string ToolName { get; }
Visual C++
protected:
virtual property String^ ToolName {
    String^ get () override;
}

Field Value

Return Value

The name of the executable file to run.

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


Verbose Property

[image]

.NET Framework Class Library
RoboCopy..::.Verbose Property
RoboCopy Class See Also Send Feedback

/V Produces verbose output (including skipped files).

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Verbose As Boolean
C#
public bool Verbose { get; set; }
Visual C++
public:
property bool Verbose {
    bool get ();
    void set (bool value);
}

See Also

RoboCopy Class
MSBuild.Community.Tasks Namespace


Script Class

[image]

.NET Framework Class Library
Script Class
Members Example See Also Send Feedback

Executes code contained within the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Script _
    Inherits Task
C#
public class Script : Task
Visual C++
public ref class Script : public Task

Examples

Simple script that writes to the console

Copy Code

<PropertyGroup>
    <HelloCode>
        <![CDATA[
        public static void ScriptMain() {
            Console.WriteLine("Hello MSBuild Community Scripting World.");
        }
        ]] >
    </HelloCode>
</PropertyGroup>
<Target Name="Hello">
    <Script Language="C#" Code="$(HelloCode)" Imports="System" />
</Target>

Examples

Script that returns a value.

Copy Code

<PropertyGroup>
    <GetProgramFilesCode>
        <![CDATA[
        public static string ScriptMain() {
            return Environment.GetFolderPath(Environment.SpecialFolder.ProgramFiles);
        }
        ]] >
    </GetProgramFilesCode>
</PropertyGroup>
<Target Name="GetProgramFilesFolder">
    <Script Language="C#" Code="$(GetProgramFilesCode)">
        <Output TaskParameter="ReturnValue" PropertyName="ProgramFilesFolder" />
    </Script>
    <Message Text="Program files are in: $(ProgramFilesFolder)" />
</Target>

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks..::.Script

See Also

Script Members
MSBuild.Community.Tasks Namespace


Script Members

[image] [image]

.NET Framework Class Library
Script Members
Script Class Constructors Methods Properties See Also Send Feedback

The Script type exposes the following members.

Constructors

Name | Description
Script |

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | Executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Code | The code to compile and execute
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Imports | The namespaces to import.
Language | The language of the script block (defaults to C#).
Log | (Inherited from Task.)
MainClass | The name of the main class containing the static ScriptMain entry point.
References | The required references
ReturnValue | The string returned from the custom ScriptMain method.
TaskResources | (Inherited from Task.)

See Also

Script Class
MSBuild.Community.Tasks Namespace


Script Constructor

[image]

.NET Framework Class Library
Script Constructor
Script Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Script()
Visual C++
public:
Script()

See Also

Script Class
MSBuild.Community.Tasks Namespace


Script Methods

[image] [image]

.NET Framework Class Library
Script Methods
Script Class See Also Send Feedback

The Script type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | Executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

Script Class
MSBuild.Community.Tasks Namespace


Execute Method

[image]

.NET Framework Class Library
Script..::.Execute Method
Script Class See Also Send Feedback

Executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

trueTruetruetrue (True in Visual Basic) if the task ran successfully; otherwise falseFalsefalsefalse (False in Visual Basic).

Implements

ITask..::.Execute()()()

See Also

Script Class
MSBuild.Community.Tasks Namespace


Script Properties

[image] [image]

.NET Framework Class Library
Script Properties
Script Class See Also Send Feedback

The Script type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Code | The code to compile and execute
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Imports | The namespaces to import.
Language | The language of the script block (defaults to C#).
Log | (Inherited from Task.)
MainClass | The name of the main class containing the static ScriptMain entry point.
References | The required references
ReturnValue | The string returned from the custom ScriptMain method.
TaskResources | (Inherited from Task.)

See Also

Script Class
MSBuild.Community.Tasks Namespace


Code Property

[image]

.NET Framework Class Library
Script..::.Code Property
Script Class See Also Send Feedback

The code to compile and execute

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Code As String
C#
public string Code { get; set; }
Visual C++
public:
property String^ Code {
    String^ get ();
    void set (String^ value);
}

Remarks

The code must include a static (Shared in VB) method named ScriptMain. It cannot accept any parameters. If you define the method return a String, the returned value will be available in the ReturnValue output property.

See Also

Script Class
MSBuild.Community.Tasks Namespace


Imports Property

[image]

.NET Framework Class Library
Script..::.Imports Property
Script Class See Also Send Feedback

The namespaces to import.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Imports As ITaskItem()
C#
public ITaskItem[] Imports { get; set; }
Visual C++
public:
property array<ITaskItem^>^ Imports {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

See Also

Script Class
MSBuild.Community.Tasks Namespace


Language Property

[image]

.NET Framework Class Library
Script..::.Language Property
Script Class See Also Send Feedback

The language of the script block (defaults to C#).

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property Language As String
C#
[RequiredAttribute]
public string Language { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ Language {
    String^ get ();
    void set (String^ value);
}

Remarks

The supported languages are:

  • Visual Basic.NET (VB, vb, VISUALBASIC)
  • C# (C#, c#, CSHARP)
  • JavaScript (JS, js, JSCRIPT)
  • J# (VJS, vjs, JSHARP)
or, proviude the fully-qualified name for a class implementing CodeDomProvider.

See Also

Script Class
MSBuild.Community.Tasks Namespace


MainClass Property

[image]

.NET Framework Class Library
Script..::.MainClass Property
Script Class See Also Send Feedback

The name of the main class containing the static ScriptMain entry point.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property MainClass As String
C#
public string MainClass { get; set; }
Visual C++
public:
property String^ MainClass {
    String^ get ();
    void set (String^ value);
}

See Also

Script Class
MSBuild.Community.Tasks Namespace


References Property

[image]

.NET Framework Class Library
Script..::.References Property
Script Class See Also Send Feedback

The required references

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property References As ITaskItem()
C#
public ITaskItem[] References { get; set; }
Visual C++
public:
property array<ITaskItem^>^ References {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

See Also

Script Class
MSBuild.Community.Tasks Namespace


ReturnValue Property

[image]

.NET Framework Class Library
Script..::.ReturnValue Property
Script Class See Also Send Feedback

The string returned from the custom ScriptMain method.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property ReturnValue As String
C#
[OutputAttribute]
public string ReturnValue { get; }
Visual C++
[OutputAttribute]
public:
property String^ ReturnValue {
    String^ get ();
}

See Also

Script Class
MSBuild.Community.Tasks Namespace


ServiceActions Enumeration

[image]

.NET Framework Class Library
ServiceActions Enumeration
See Also Send Feedback

Defines the actions that can be performed on a service.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration ServiceActions
C#
public enum ServiceActions
Visual C++
public enum class ServiceActions

Members

Member name | Description
Start | Starts a service.
Stop | Stops a service.
Restart | Restarts a service.
Pause | Pauses a running service.
Continue | Continues a paused service.

See Also

MSBuild.Community.Tasks Namespace


ServiceController Class

[image]

.NET Framework Class Library
ServiceController Class
Members Example See Also Send Feedback

Task that can control a Windows service.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class ServiceController _
    Inherits ServiceQuery
C#
public class ServiceController : ServiceQuery
Visual C++
public ref class ServiceController : public ServiceQuery

Examples

Restart Web Server

Copy Code
            <ServiceController ServiceName="w3svc" Action="Restart" />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks..::.ServiceQuery
MSBuild.Community.Tasks..::.ServiceController

See Also

ServiceController Members
MSBuild.Community.Tasks Namespace


ServiceController Members

[image] [image]

.NET Framework Class Library
ServiceController Members
ServiceController Class Constructors Methods Properties See Also Send Feedback

The ServiceController type exposes the following members.

Constructors

Name | Description
ServiceController | Initializes a new instance of the ServiceController class.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | Executes the task. (Overrides ServiceQuery..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetServiceController | Gets the service controller. (Inherited from ServiceQuery.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
Action | Gets or sets the ServiceActions to perform on the service.
BuildEngine | (Inherited from Task.)
CanPauseAndContinue | Gets a value indicating whether the service can be paused and resumed. (Inherited from ServiceQuery.)
CanShutdown | Gets a value indicating whether the service should be notified when the system is shutting down. (Inherited from ServiceQuery.)
CanStop | Gets a value indicating whether the service can be stopped after it has started. (Inherited from ServiceQuery.)
DisplayName | Gets a friendly name for the service. (Inherited from ServiceQuery.)
Exists | Gets a value indicating whether the service exists. (Inherited from ServiceQuery.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
MachineName | Gets or sets the name of the machine. (Inherited from ServiceQuery.)
ServiceName | Gets or sets the name of the service. (Inherited from ServiceQuery.)
Status | Gets or sets the status. (Inherited from ServiceQuery.)
TaskResources | (Inherited from Task.)
Timeout | Gets or sets the timeout for the command. The default is one minute.

See Also

ServiceController Class
MSBuild.Community.Tasks Namespace


ServiceController Constructor

[image]

.NET Framework Class Library
ServiceController Constructor
ServiceController Class See Also Send Feedback

Initializes a new instance of the ServiceController class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ServiceController()
Visual C++
public:
ServiceController()

See Also

ServiceController Class
MSBuild.Community.Tasks Namespace


ServiceController Methods

[image] [image]

.NET Framework Class Library
ServiceController Methods
ServiceController Class See Also Send Feedback

The ServiceController type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | Executes the task. (Overrides ServiceQuery..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetServiceController | Gets the service controller. (Inherited from ServiceQuery.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

ServiceController Class
MSBuild.Community.Tasks Namespace


Execute Method

[image]

.NET Framework Class Library
ServiceController..::.Execute Method
ServiceController Class See Also Send Feedback

Executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

trueTruetruetrue (True in Visual Basic) if the task ran successfully; otherwise falseFalsefalsefalse (False in Visual Basic).

Implements

ITask..::.Execute()()()

See Also

ServiceController Class
MSBuild.Community.Tasks Namespace


ServiceController Properties

[image] [image]

.NET Framework Class Library
ServiceController Properties
ServiceController Class See Also Send Feedback

The ServiceController type exposes the following members.

Properties

Name | Description
Action | Gets or sets the ServiceActions to perform on the service.
BuildEngine | (Inherited from Task.)
CanPauseAndContinue | Gets a value indicating whether the service can be paused and resumed. (Inherited from ServiceQuery.)
CanShutdown | Gets a value indicating whether the service should be notified when the system is shutting down. (Inherited from ServiceQuery.)
CanStop | Gets a value indicating whether the service can be stopped after it has started. (Inherited from ServiceQuery.)
DisplayName | Gets a friendly name for the service. (Inherited from ServiceQuery.)
Exists | Gets a value indicating whether the service exists. (Inherited from ServiceQuery.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
MachineName | Gets or sets the name of the machine. (Inherited from ServiceQuery.)
ServiceName | Gets or sets the name of the service. (Inherited from ServiceQuery.)
Status | Gets or sets the status. (Inherited from ServiceQuery.)
TaskResources | (Inherited from Task.)
Timeout | Gets or sets the timeout for the command. The default is one minute.

See Also

ServiceController Class
MSBuild.Community.Tasks Namespace


Action Property

[image]

.NET Framework Class Library
ServiceController..::.Action Property
ServiceController Class See Also Send Feedback

Gets or sets the ServiceActions to perform on the service.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property Action As String
C#
[RequiredAttribute]
public string Action { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ Action {
    String^ get ();
    void set (String^ value);
}

Field Value

The action to perform on the service.

See Also

ServiceController Class
MSBuild.Community.Tasks Namespace


Timeout Property

[image]

.NET Framework Class Library
ServiceController..::.Timeout Property
ServiceController Class See Also Send Feedback

Gets or sets the timeout for the command. The default is one minute.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Timeout As Double
C#
public double Timeout { get; set; }
Visual C++
public:
property double Timeout {
    double get ();
    void set (double value);
}

Field Value

The timeout for the command.

See Also

ServiceController Class
MSBuild.Community.Tasks Namespace


ServiceQuery Class

[image]

.NET Framework Class Library
ServiceQuery Class
Members Example See Also Send Feedback

Task that can determine the status of a specified service on a target server.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class ServiceQuery _
    Inherits Task
C#
public class ServiceQuery : Task
Visual C++
public ref class ServiceQuery : public Task

Examples

Check status of SQL Server

Copy Code
            <ServiceQuery ServiceName="MSSQLServer">
                <Output TaskParameter="Status" PropertyName="ResultStatus" />
            </ServiceQuery>
            <Message Text="MSSQLServer Service Status: $(ResultStatus)"/>

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks..::.ServiceQuery
MSBuild.Community.Tasks..::.ServiceController

See Also

ServiceQuery Members
MSBuild.Community.Tasks Namespace


ServiceQuery Members

[image] [image]

.NET Framework Class Library
ServiceQuery Members
ServiceQuery Class Constructors Methods Fields Properties See Also Send Feedback

The ServiceQuery type exposes the following members.

Constructors

Name | Description
ServiceQuery | Initializes a new instance of the ServiceQuery class.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | Executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetServiceController | Gets the service controller.
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Fields

Name | Description
UNKNOWN_STATUS | The unknown Status returned when the service does not exist. The value is "Unknown".

Properties

Name | Description
BuildEngine | (Inherited from Task.)
CanPauseAndContinue | Gets a value indicating whether the service can be paused and resumed.
CanShutdown | Gets a value indicating whether the service should be notified when the system is shutting down.
CanStop | Gets a value indicating whether the service can be stopped after it has started.
DisplayName | Gets a friendly name for the service.
Exists | Gets a value indicating whether the service exists.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
MachineName | Gets or sets the name of the machine.
ServiceName | Gets or sets the name of the service.
Status | Gets or sets the status.
TaskResources | (Inherited from Task.)

See Also

ServiceQuery Class
MSBuild.Community.Tasks Namespace


ServiceQuery Constructor

[image]

.NET Framework Class Library
ServiceQuery Constructor
ServiceQuery Class See Also Send Feedback

Initializes a new instance of the ServiceQuery class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ServiceQuery()
Visual C++
public:
ServiceQuery()

See Also

ServiceQuery Class
MSBuild.Community.Tasks Namespace


ServiceQuery Fields

[image] [image]

.NET Framework Class Library
ServiceQuery Fields
ServiceQuery Class See Also Send Feedback

The ServiceQuery type exposes the following members.

Fields

Name | Description
UNKNOWN_STATUS | The unknown Status returned when the service does not exist. The value is "Unknown".

See Also

ServiceQuery Class
MSBuild.Community.Tasks Namespace


UNKNOWN_STATUS Field

[image]

.NET Framework Class Library
ServiceQuery..::.UNKNOWN_STATUS Field
ServiceQuery Class See Also Send Feedback

The unknown Status returned when the service does not exist. The value is "Unknown".

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Const UNKNOWN_STATUS As String
C#
public const string UNKNOWN_STATUS
Visual C++
public:
literal String^ UNKNOWN_STATUS

See Also

ServiceQuery Class
MSBuild.Community.Tasks Namespace


ServiceQuery Methods

[image] [image]

.NET Framework Class Library
ServiceQuery Methods
ServiceQuery Class See Also Send Feedback

The ServiceQuery type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | Executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetServiceController | Gets the service controller.
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

ServiceQuery Class
MSBuild.Community.Tasks Namespace


Execute Method

[image]

.NET Framework Class Library
ServiceQuery..::.Execute Method
ServiceQuery Class See Also Send Feedback

Executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

trueTruetruetrue (True in Visual Basic) if the task ran successfully; otherwise falseFalsefalsefalse (False in Visual Basic).

Implements

ITask..::.Execute()()()

See Also

ServiceQuery Class
MSBuild.Community.Tasks Namespace


GetServiceController Method

[image]

.NET Framework Class Library
ServiceQuery..::.GetServiceController Method
ServiceQuery Class See Also Send Feedback

Gets the service controller.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetServiceController As ServiceController
C#
protected ServiceController GetServiceController()
Visual C++
protected:
ServiceController^ GetServiceController()

Return Value

See Also

ServiceQuery Class
MSBuild.Community.Tasks Namespace


ServiceQuery Properties

[image] [image]

.NET Framework Class Library
ServiceQuery Properties
ServiceQuery Class See Also Send Feedback

The ServiceQuery type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
CanPauseAndContinue | Gets a value indicating whether the service can be paused and resumed.
CanShutdown | Gets a value indicating whether the service should be notified when the system is shutting down.
CanStop | Gets a value indicating whether the service can be stopped after it has started.
DisplayName | Gets a friendly name for the service.
Exists | Gets a value indicating whether the service exists.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
MachineName | Gets or sets the name of the machine.
ServiceName | Gets or sets the name of the service.
Status | Gets or sets the status.
TaskResources | (Inherited from Task.)

See Also

ServiceQuery Class
MSBuild.Community.Tasks Namespace


CanPauseAndContinue Property

[image]

.NET Framework Class Library
ServiceQuery..::.CanPauseAndContinue Property
ServiceQuery Class See Also Send Feedback

Gets a value indicating whether the service can be paused and resumed.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property CanPauseAndContinue As Boolean
C#
[OutputAttribute]
public bool CanPauseAndContinue { get; }
Visual C++
[OutputAttribute]
public:
property bool CanPauseAndContinue {
    bool get ();
}

Field Value

true if this instance can pause and continue; otherwise, false.

See Also

ServiceQuery Class
MSBuild.Community.Tasks Namespace


CanShutdown Property

[image]

.NET Framework Class Library
ServiceQuery..::.CanShutdown Property
ServiceQuery Class See Also Send Feedback

Gets a value indicating whether the service should be notified when the system is shutting down.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property CanShutdown As Boolean
C#
[OutputAttribute]
public bool CanShutdown { get; }
Visual C++
[OutputAttribute]
public:
property bool CanShutdown {
    bool get ();
}

Field Value

true if this instance can shutdown; otherwise, false.

See Also

ServiceQuery Class
MSBuild.Community.Tasks Namespace


CanStop Property

[image]

.NET Framework Class Library
ServiceQuery..::.CanStop Property
ServiceQuery Class See Also Send Feedback

Gets a value indicating whether the service can be stopped after it has started.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property CanStop As Boolean
C#
[OutputAttribute]
public bool CanStop { get; }
Visual C++
[OutputAttribute]
public:
property bool CanStop {
    bool get ();
}

Field Value

true if this instance can stop; otherwise, false.

See Also

ServiceQuery Class
MSBuild.Community.Tasks Namespace


DisplayName Property

[image]

.NET Framework Class Library
ServiceQuery..::.DisplayName Property
ServiceQuery Class See Also Send Feedback

Gets a friendly name for the service.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property DisplayName As String
C#
[OutputAttribute]
public string DisplayName { get; }
Visual C++
[OutputAttribute]
public:
property String^ DisplayName {
    String^ get ();
}

Field Value

The name of the display.

See Also

ServiceQuery Class
MSBuild.Community.Tasks Namespace


Exists Property

[image]

.NET Framework Class Library
ServiceQuery..::.Exists Property
ServiceQuery Class See Also Send Feedback

Gets a value indicating whether the service exists.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property Exists As Boolean
C#
[OutputAttribute]
public bool Exists { get; }
Visual C++
[OutputAttribute]
public:
property bool Exists {
    bool get ();
}

Field Value

true if the service exists; otherwise, false.

See Also

ServiceQuery Class
MSBuild.Community.Tasks Namespace


MachineName Property

[image]

.NET Framework Class Library
ServiceQuery..::.MachineName Property
ServiceQuery Class See Also Send Feedback

Gets or sets the name of the machine.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property MachineName As String
C#
public string MachineName { get; set; }
Visual C++
public:
property String^ MachineName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the machine.

See Also

ServiceQuery Class
MSBuild.Community.Tasks Namespace


ServiceName Property

[image]

.NET Framework Class Library
ServiceQuery..::.ServiceName Property
ServiceQuery Class See Also Send Feedback

Gets or sets the name of the service.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property ServiceName As String
C#
[RequiredAttribute]
public string ServiceName { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ ServiceName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the service.

See Also

ServiceQuery Class
MSBuild.Community.Tasks Namespace


Status Property

[image]

.NET Framework Class Library
ServiceQuery..::.Status Property
ServiceQuery Class See Also Send Feedback

Gets or sets the status.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public Property Status As String
C#
[OutputAttribute]
public string Status { get; set; }
Visual C++
[OutputAttribute]
public:
property String^ Status {
    String^ get ();
    void set (String^ value);
}

Field Value

The status of the service.

See Also

ServiceQuery Class
MSBuild.Community.Tasks Namespace


Sleep Class

[image]

.NET Framework Class Library
Sleep Class
Members Example See Also Send Feedback

A task for sleeping for a specified period of time.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Sleep _
    Inherits Task
C#
public class Sleep : Task
Visual C++
public ref class Sleep : public Task

Examples

Causes the build to sleep for 300 milliseconds.
Copy Code
            <Sleep Milliseconds="300" />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks..::.Sleep

See Also

Sleep Members
MSBuild.Community.Tasks Namespace


Sleep Members

[image] [image]

.NET Framework Class Library
Sleep Members
Sleep Class Constructors Methods Properties See Also Send Feedback

The Sleep type exposes the following members.

Constructors

Name | Description
Sleep |

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | Executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Hours | The number of hours to add to the time to sleep.
Log | (Inherited from Task.)
Milliseconds | The number of milliseconds to add to the time to sleep.
Minutes | The number of minutes to add to the time to sleep.
Seconds | The number of seconds to add to the time to sleep.
TaskResources | (Inherited from Task.)

See Also

Sleep Class
MSBuild.Community.Tasks Namespace


Sleep Constructor

[image]

.NET Framework Class Library
Sleep Constructor
Sleep Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Sleep()
Visual C++
public:
Sleep()

See Also

Sleep Class
MSBuild.Community.Tasks Namespace


Sleep Methods

[image] [image]

.NET Framework Class Library
Sleep Methods
Sleep Class See Also Send Feedback

The Sleep type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | Executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

Sleep Class
MSBuild.Community.Tasks Namespace


Execute Method

[image]

.NET Framework Class Library
Sleep..::.Execute Method
Sleep Class See Also Send Feedback

Executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

trueTruetruetrue (True in Visual Basic) if the task ran successfully; otherwise falseFalsefalsefalse (False in Visual Basic).

Implements

ITask..::.Execute()()()

See Also

Sleep Class
MSBuild.Community.Tasks Namespace


Sleep Properties

[image] [image]

.NET Framework Class Library
Sleep Properties
Sleep Class See Also Send Feedback

The Sleep type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Hours | The number of hours to add to the time to sleep.
Log | (Inherited from Task.)
Milliseconds | The number of milliseconds to add to the time to sleep.
Minutes | The number of minutes to add to the time to sleep.
Seconds | The number of seconds to add to the time to sleep.
TaskResources | (Inherited from Task.)

See Also

Sleep Class
MSBuild.Community.Tasks Namespace


Hours Property

[image]

.NET Framework Class Library
Sleep..::.Hours Property
Sleep Class See Also Send Feedback

The number of hours to add to the time to sleep.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Hours As Integer
C#
public int Hours { get; set; }
Visual C++
public:
property int Hours {
    int get ();
    void set (int value);
}

See Also

Sleep Class
MSBuild.Community.Tasks Namespace


Milliseconds Property

[image]

.NET Framework Class Library
Sleep..::.Milliseconds Property
Sleep Class See Also Send Feedback

The number of milliseconds to add to the time to sleep.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Milliseconds As Integer
C#
public int Milliseconds { get; set; }
Visual C++
public:
property int Milliseconds {
    int get ();
    void set (int value);
}

See Also

Sleep Class
MSBuild.Community.Tasks Namespace


Minutes Property

[image]

.NET Framework Class Library
Sleep..::.Minutes Property
Sleep Class See Also Send Feedback

The number of minutes to add to the time to sleep.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Minutes As Integer
C#
public int Minutes { get; set; }
Visual C++
public:
property int Minutes {
    int get ();
    void set (int value);
}

See Also

Sleep Class
MSBuild.Community.Tasks Namespace


Seconds Property

[image]

.NET Framework Class Library
Sleep..::.Seconds Property
Sleep Class See Also Send Feedback

The number of seconds to add to the time to sleep.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Seconds As Integer
C#
public int Seconds { get; set; }
Visual C++
public:
property int Seconds {
    int get ();
    void set (int value);
}

See Also

Sleep Class
MSBuild.Community.Tasks Namespace


Sound Class

[image]

.NET Framework Class Library
Sound Class
Members Example See Also Send Feedback

A task to play a sound from a .wav file path or URL.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Sound _
    Inherits Task
C#
public class Sound : Task
Visual C++
public ref class Sound : public Task

Remarks

You must specify either a file or URL (SoundLocation), a file relative to the SystemDirectory (SystemSoundFile), or a file within the MyMusic folder (MyMusicFile).

Examples

To play the windows XP startup sound, use
Copy Code
        <Sound SystemSoundFile="..\Media\Windows XP Startup.wav" />

Examples

To play a wav file from the "MyMusic" folder, use
Copy Code
        <Sound MyMusicFile="25881_acclivity_3beeps1000.wav" />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks..::.Sound

See Also

Sound Members
MSBuild.Community.Tasks Namespace


Sound Members

[image] [image]

.NET Framework Class Library
Sound Members
Sound Class Constructors Methods Properties See Also Send Feedback

The Sound type exposes the following members.

Constructors

Name | Description
Sound |

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | Loads the .wav file given by SoundLocation and plays the sound using a new thread. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
LoadTimeout | Gets or sets the time, in milliseconds, in which the .wav file must load.
Log | (Inherited from Task.)
MyMusicFile | Sets the file path of the .wav file to load as a relative path to MyMusic.
SoundLocation | Gets or sets the file path or URL of the .wav file to load.
Synchron | Gets or sets a value indicating whether to play the sound synchronously.
SystemSoundFile | Sets the file path of the .wav file to load as a relative path to SystemDirectory.
TaskResources | (Inherited from Task.)

See Also

Sound Class
MSBuild.Community.Tasks Namespace


Sound Constructor

[image]

.NET Framework Class Library
Sound Constructor
Sound Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Sound()
Visual C++
public:
Sound()

See Also

Sound Class
MSBuild.Community.Tasks Namespace


Sound Methods

[image] [image]

.NET Framework Class Library
Sound Methods
Sound Class See Also Send Feedback

The Sound type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | Loads the .wav file given by SoundLocation and plays the sound using a new thread. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

Sound Class
MSBuild.Community.Tasks Namespace


Execute Method

[image]

.NET Framework Class Library
Sound..::.Execute Method
Sound Class See Also Send Feedback

Loads the .wav file given by SoundLocation and plays the sound using a new thread.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

Returns trueTruetruetrue (True in Visual Basic) if the .wav file can successfully be played; otherwise, returns falseFalsefalsefalse (False in Visual Basic).

Implements

ITask..::.Execute()()()

See Also

Sound Class
MSBuild.Community.Tasks Namespace


Sound Properties

[image] [image]

.NET Framework Class Library
Sound Properties
Sound Class See Also Send Feedback

The Sound type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
LoadTimeout | Gets or sets the time, in milliseconds, in which the .wav file must load.
Log | (Inherited from Task.)
MyMusicFile | Sets the file path of the .wav file to load as a relative path to MyMusic.
SoundLocation | Gets or sets the file path or URL of the .wav file to load.
Synchron | Gets or sets a value indicating whether to play the sound synchronously.
SystemSoundFile | Sets the file path of the .wav file to load as a relative path to SystemDirectory.
TaskResources | (Inherited from Task.)

See Also

Sound Class
MSBuild.Community.Tasks Namespace


LoadTimeout Property

[image]

.NET Framework Class Library
Sound..::.LoadTimeout Property
Sound Class See Also Send Feedback

Gets or sets the time, in milliseconds, in which the .wav file must load.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property LoadTimeout As Integer
C#
public int LoadTimeout { get; set; }
Visual C++
public:
property int LoadTimeout {
    int get ();
    void set (int value);
}

Field Value

The number of milliseconds to wait. The default is 10000 (10 seconds).

Remarks

After this time has expired, the loading is canceled and the task execution fails.

See Also

Sound Class
MSBuild.Community.Tasks Namespace


MyMusicFile Property

[image]

.NET Framework Class Library
Sound..::.MyMusicFile Property
Sound Class See Also Send Feedback

Sets the file path of the .wav file to load as a relative path to MyMusic.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property MyMusicFile As String
C#
public string MyMusicFile { set; }
Visual C++
public:
property String^ MyMusicFile {
    void set (String^ value);
}

See Also

Sound Class
MSBuild.Community.Tasks Namespace


SoundLocation Property

[image]

.NET Framework Class Library
Sound..::.SoundLocation Property
Sound Class See Also Send Feedback

Gets or sets the file path or URL of the .wav file to load.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property SoundLocation As String
C#
public string SoundLocation { get; set; }
Visual C++
public:
property String^ SoundLocation {
    String^ get ();
    void set (String^ value);
}

See Also

Sound Class
MSBuild.Community.Tasks Namespace


Synchron Property

[image]

.NET Framework Class Library
Sound..::.Synchron Property
Sound Class See Also Send Feedback

Gets or sets a value indicating whether to play the sound synchronously.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Synchron As Boolean
C#
public bool Synchron { get; set; }
Visual C++
public:
property bool Synchron {
    bool get ();
    void set (bool value);
}

Field Value

trueTruetruetrue (True in Visual Basic) if playing the sound using the caller's thread (default); otherwise, falseFalsefalsefalse (False in Visual Basic) if playing the sound using a new thread.

See Also

Sound Class
MSBuild.Community.Tasks Namespace


SystemSoundFile Property

[image]

.NET Framework Class Library
Sound..::.SystemSoundFile Property
Sound Class Example See Also Send Feedback

Sets the file path of the .wav file to load as a relative path to SystemDirectory.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property SystemSoundFile As String
C#
public string SystemSoundFile { set; }
Visual C++
public:
property String^ SystemSoundFile {
    void set (String^ value);
}

Examples

For example, on a Windows XP platform, you can call
Copy Code
<Sound SystemSoundFile="..\Media\Windows XP Startup.wav" />

See Also

Sound Class
MSBuild.Community.Tasks Namespace


SqlExecute Class

[image]

.NET Framework Class Library
SqlExecute Class
Members Example See Also Send Feedback

Executes a SQL command.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlExecute _
    Inherits Task
C#
public class SqlExecute : Task
Visual C++
public ref class SqlExecute : public Task

Remarks

Execute a SQL command against a database. Target attributes to set: ConnectionString (required), Command (required, the SQL to execute), SelectMode (NonQuery, Scalar, or ScalarXml, default is NonQuery), OutputFile (required when SelectMode is Scalar or ScalarXml). Note: ScalarXml was created because of the 2033 byte limit on the sql return. See http://aspnetresources.com/blog/executescalar_truncates_xml.aspx for details.

Examples

Example of returning a count of items in a table. Uses the default SelectMode of NonQuery.
Copy Code
                <SqlExecute ConnectionString="server=MyServer;Database=MyDatabase;Trusted_Connection=yes;"
                    Command="create database MyDatabase" />
Example of returning the items of a table in an xml format.
Copy Code
                <SqlExecute ConnectionString="server=MyServer;Database=MyDatabase;Trusted_Connection=yes;"
                    Command="select * from SomeTable for xml auto"
                    SelectMode="ScalarXml"
                    OutputFile="SomeTable.xml" />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks..::.SqlExecute

See Also

SqlExecute Members
MSBuild.Community.Tasks Namespace


SqlExecute Members

[image] [image]

.NET Framework Class Library
SqlExecute Members
SqlExecute Class Constructors Methods Properties See Also Send Feedback

The SqlExecute type exposes the following members.

Constructors

Name | Description
SqlExecute |

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Command | The command to execute
ConnectionString | The connection string
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
OutputFile | The file name to write to
Result | Output the return count/value
SelectMode | The SQL Selection Mode. Set to NonQuery, Scalar, or ScalarXml. Default is NonQuery.
TaskResources | (Inherited from Task.)

See Also

SqlExecute Class
MSBuild.Community.Tasks Namespace


SqlExecute Constructor

[image]

.NET Framework Class Library
SqlExecute Constructor
SqlExecute Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlExecute()
Visual C++
public:
SqlExecute()

See Also

SqlExecute Class
MSBuild.Community.Tasks Namespace


SqlExecute Methods

[image] [image]

.NET Framework Class Library
SqlExecute Methods
SqlExecute Class See Also Send Feedback

The SqlExecute type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

SqlExecute Class
MSBuild.Community.Tasks Namespace


Execute Method

[image]

.NET Framework Class Library
SqlExecute..::.Execute Method
SqlExecute Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

SqlExecute Class
MSBuild.Community.Tasks Namespace


SqlExecute Properties

[image] [image]

.NET Framework Class Library
SqlExecute Properties
SqlExecute Class See Also Send Feedback

The SqlExecute type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Command | The command to execute
ConnectionString | The connection string
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
OutputFile | The file name to write to
Result | Output the return count/value
SelectMode | The SQL Selection Mode. Set to NonQuery, Scalar, or ScalarXml. Default is NonQuery.
TaskResources | (Inherited from Task.)

See Also

SqlExecute Class
MSBuild.Community.Tasks Namespace


Command Property

[image]

.NET Framework Class Library
SqlExecute..::.Command Property
SqlExecute Class See Also Send Feedback

The command to execute

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property Command As String
C#
[RequiredAttribute]
public string Command { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ Command {
    String^ get ();
    void set (String^ value);
}

See Also

SqlExecute Class
MSBuild.Community.Tasks Namespace


ConnectionString Property

[image]

.NET Framework Class Library
SqlExecute..::.ConnectionString Property
SqlExecute Class See Also Send Feedback

The connection string

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property ConnectionString As String
C#
[RequiredAttribute]
public string ConnectionString { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ ConnectionString {
    String^ get ();
    void set (String^ value);
}

See Also

SqlExecute Class
MSBuild.Community.Tasks Namespace


OutputFile Property

[image]

.NET Framework Class Library
SqlExecute..::.OutputFile Property
SqlExecute Class See Also Send Feedback

The file name to write to

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property OutputFile As String
C#
public string OutputFile { get; set; }
Visual C++
public:
property String^ OutputFile {
    String^ get ();
    void set (String^ value);
}

See Also

SqlExecute Class
MSBuild.Community.Tasks Namespace


Result Property

[image]

.NET Framework Class Library
SqlExecute..::.Result Property
SqlExecute Class See Also Send Feedback

Output the return count/value

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property Result As Integer
C#
[OutputAttribute]
public int Result { get; }
Visual C++
[OutputAttribute]
public:
property int Result {
    int get ();
}

See Also

SqlExecute Class
MSBuild.Community.Tasks Namespace


SelectMode Property

[image]

.NET Framework Class Library
SqlExecute..::.SelectMode Property
SqlExecute Class See Also Send Feedback

The SQL Selection Mode. Set to NonQuery, Scalar, or ScalarXml. Default is NonQuery.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectMode As String
C#
public string SelectMode { get; set; }
Visual C++
public:
property String^ SelectMode {
    String^ get ();
    void set (String^ value);
}

See Also

SqlExecute Class
MSBuild.Community.Tasks Namespace


TemplateFile Class

[image]

.NET Framework Class Library
TemplateFile Class
Members Example See Also Send Feedback

MSBuild task that replaces tokens in a template file and writes out a new file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class TemplateFile _
    Inherits Task
C#
public class TemplateFile : Task
Visual C++
public ref class TemplateFile : public Task

Remarks

Tokens in the template file are formatted using ${var} syntax and names are not case-sensitive, so ${Token} and ${TOKEN} are equivalent.

Examples

Copy Code
            <ItemGroup>
                <Tokens Include="Name">
                    <ReplacementValue>MSBuild Community Tasks</ReplacementValue>
                </Tokens>
            </ItemGroup>

            <TemplateFile TemplateFile="ATemplateFile.template" OutputFile="ReplacedFile.txt" Tokens="@(Tokens)" />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks..::.TemplateFile

See Also

TemplateFile Members
MSBuild.Community.Tasks Namespace


TemplateFile Members

[image] [image]

.NET Framework Class Library
TemplateFile Members
TemplateFile Class Constructors Methods Fields Properties See Also Send Feedback

The TemplateFile type exposes the following members.

Constructors

Name | Description
TemplateFile | Default constructor. Creates a new TemplateFile task.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | Executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Fields

Name | Description
MetadataValueTag | Meta data tag used for token replacement

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
OutputFile | The token replaced template file.
OutputFilename | The full path to the output file name. If no filename is specified (the default) the output file will be the Template filename with a .out extension.
TaskResources | (Inherited from Task.)
Template | The template file used. Tokens with values of ${Name} are replaced by name.
Tokens | List of tokens to replace in the template. Token name is taken from the TaskItem.ItemSpec and the replacement value comes from the ReplacementValue metadata of the item.

See Also

TemplateFile Class
MSBuild.Community.Tasks Namespace


TemplateFile Constructor

[image]

.NET Framework Class Library
TemplateFile Constructor
TemplateFile Class See Also Send Feedback

Default constructor. Creates a new TemplateFile task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public TemplateFile()
Visual C++
public:
TemplateFile()

See Also

TemplateFile Class
MSBuild.Community.Tasks Namespace


TemplateFile Fields

[image] [image]

.NET Framework Class Library
TemplateFile Fields
TemplateFile Class See Also Send Feedback

The TemplateFile type exposes the following members.

Fields

Name | Description
MetadataValueTag | Meta data tag used for token replacement

See Also

TemplateFile Class
MSBuild.Community.Tasks Namespace


MetadataValueTag Field

[image]

.NET Framework Class Library
TemplateFile..::.MetadataValueTag Field
TemplateFile Class See Also Send Feedback

Meta data tag used for token replacement

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MetadataValueTag As String
C#
public static readonly string MetadataValueTag
Visual C++
public:
static initonly String^ MetadataValueTag

See Also

TemplateFile Class
MSBuild.Community.Tasks Namespace


TemplateFile Methods

[image] [image]

.NET Framework Class Library
TemplateFile Methods
TemplateFile Class See Also Send Feedback

The TemplateFile type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | Executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

TemplateFile Class
MSBuild.Community.Tasks Namespace


Execute Method

[image]

.NET Framework Class Library
TemplateFile..::.Execute Method
TemplateFile Class See Also Send Feedback

Executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

Success or failure of the task.

Implements

ITask..::.Execute()()()

See Also

TemplateFile Class
MSBuild.Community.Tasks Namespace


TemplateFile Properties

[image] [image]

.NET Framework Class Library
TemplateFile Properties
TemplateFile Class See Also Send Feedback

The TemplateFile type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
OutputFile | The token replaced template file.
OutputFilename | The full path to the output file name. If no filename is specified (the default) the output file will be the Template filename with a .out extension.
TaskResources | (Inherited from Task.)
Template | The template file used. Tokens with values of ${Name} are replaced by name.
Tokens | List of tokens to replace in the template. Token name is taken from the TaskItem.ItemSpec and the replacement value comes from the ReplacementValue metadata of the item.

See Also

TemplateFile Class
MSBuild.Community.Tasks Namespace


OutputFile Property

[image]

.NET Framework Class Library
TemplateFile..::.OutputFile Property
TemplateFile Class See Also Send Feedback

The token replaced template file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public Property OutputFile As ITaskItem
C#
[OutputAttribute]
public ITaskItem OutputFile { get; set; }
Visual C++
[OutputAttribute]
public:
property ITaskItem^ OutputFile {
    ITaskItem^ get ();
    void set (ITaskItem^ value);
}

See Also

TemplateFile Class
MSBuild.Community.Tasks Namespace


OutputFilename Property

[image]

.NET Framework Class Library
TemplateFile..::.OutputFilename Property
TemplateFile Class See Also Send Feedback

The full path to the output file name. If no filename is specified (the default) the output file will be the Template filename with a .out extension.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property OutputFilename As String
C#
public string OutputFilename { get; set; }
Visual C++
public:
property String^ OutputFilename {
    String^ get ();
    void set (String^ value);
}

See Also

TemplateFile Class
MSBuild.Community.Tasks Namespace


Template Property

[image]

.NET Framework Class Library
TemplateFile..::.Template Property
TemplateFile Class See Also Send Feedback

The template file used. Tokens with values of ${Name} are replaced by name.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property Template As ITaskItem
C#
[RequiredAttribute]
public ITaskItem Template { get; set; }
Visual C++
[RequiredAttribute]
public:
property ITaskItem^ Template {
    ITaskItem^ get ();
    void set (ITaskItem^ value);
}

See Also

TemplateFile Class
MSBuild.Community.Tasks Namespace


Tokens Property

[image]

.NET Framework Class Library
TemplateFile..::.Tokens Property
TemplateFile Class See Also Send Feedback

List of tokens to replace in the template. Token name is taken from the TaskItem.ItemSpec and the replacement value comes from the ReplacementValue metadata of the item.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Tokens As ITaskItem()
C#
public ITaskItem[] Tokens { get; set; }
Visual C++
public:
property array<ITaskItem^>^ Tokens {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

See Also

TemplateFile Class
MSBuild.Community.Tasks Namespace


Time Class

[image]

.NET Framework Class Library
Time Class
Members Example See Also Send Feedback

Gets the current date and time.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Time _
    Inherits Task
C#
public class Time : Task
Visual C++
public ref class Time : public Task

Remarks

See DateTimeFormatInfo for the syntax of the format string.

Examples

Using the Time task to get the Month, Day, Year, Hour, Minute, and Second:
Copy Code
            <Time>
              <Output TaskParameter="Month" PropertyName="Month" />
              <Output TaskParameter="Day" PropertyName="Day" />
              <Output TaskParameter="Year" PropertyName="Year" />
              <Output TaskParameter="Hour" PropertyName="Hour" />
              <Output TaskParameter="Minute" PropertyName="Minute" />
              <Output TaskParameter="Second" PropertyName="Second" />
            </Time>
            <Message Text="Current Date and Time: $(Month)/$(Day)/$(Year) $(Hour):$(Minute):$(Second)" />
Set property "BuildDate" to the current date and time:
Copy Code
            <Time Format="yyyyMMddHHmmss">
                <Output TaskParameter="FormattedTime" PropertyName="buildDate" />
            </Time>

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks..::.Time

See Also

Time Members
MSBuild.Community.Tasks Namespace


Time Members

[image] [image]

.NET Framework Class Library
Time Members
Time Class Constructors Methods Properties See Also Send Feedback

The Time type exposes the following members.

Constructors

Name | Description
Time |

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
DateTimeValue | Gets the internal time value.
Day | Gets the day of the month represented by this instance.
DayOfWeek | Gets the day of the week represented by this instance.
DayOfYear | Gets the day of the year represented by this instance.
Format | Gets or sets the format string for output parameter FormattedTime.
FormattedTime | Gets the value of this instance to its equivalent string representation. If input parameter Format is provided, the value is formatted according to it.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Hour | Gets the hour component of the date represented by this instance.
Kind | Gets or sets a value that indicates whether the time represented by this instance is based on local time, Coordinated Universal Time (UTC), or neither.
Log | (Inherited from Task.)
LongDate | Gets the value of this instance to its equivalent long date string representation.
LongTime | Gets the value of this instance to its equivalent long time string representation.
Millisecond | Gets the milliseconds component of the date represented by this instance.
Minute | Gets the minute component of the date represented by this instance.
Month | Gets the month component of the date represented by this instance.
Second | Gets the seconds component of the date represented by this instance.
ShortDate | Gets the value of this instance to its equivalent short date string representation.
ShortTime | Gets the value of this instance to its equivalent short time string representation.
TaskResources | (Inherited from Task.)
Ticks | Gets the number of ticks that represent the date and time of this instance.
TimeOfDay | Gets the time of day for this instance.
Year | Gets the year component of the date represented by this instance.

See Also

Time Class
MSBuild.Community.Tasks Namespace


Time Constructor

[image]

.NET Framework Class Library
Time Constructor
Time Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Time()
Visual C++
public:
Time()

See Also

Time Class
MSBuild.Community.Tasks Namespace


Time Methods

[image] [image]

.NET Framework Class Library
Time Methods
Time Class See Also Send Feedback

The Time type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

Time Class
MSBuild.Community.Tasks Namespace


Execute Method

[image]

.NET Framework Class Library
Time..::.Execute Method
Time Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

True if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

Time Class
MSBuild.Community.Tasks Namespace


Time Properties

[image] [image]

.NET Framework Class Library
Time Properties
Time Class See Also Send Feedback

The Time type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
DateTimeValue | Gets the internal time value.
Day | Gets the day of the month represented by this instance.
DayOfWeek | Gets the day of the week represented by this instance.
DayOfYear | Gets the day of the year represented by this instance.
Format | Gets or sets the format string for output parameter FormattedTime.
FormattedTime | Gets the value of this instance to its equivalent string representation. If input parameter Format is provided, the value is formatted according to it.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Hour | Gets the hour component of the date represented by this instance.
Kind | Gets or sets a value that indicates whether the time represented by this instance is based on local time, Coordinated Universal Time (UTC), or neither.
Log | (Inherited from Task.)
LongDate | Gets the value of this instance to its equivalent long date string representation.
LongTime | Gets the value of this instance to its equivalent long time string representation.
Millisecond | Gets the milliseconds component of the date represented by this instance.
Minute | Gets the minute component of the date represented by this instance.
Month | Gets the month component of the date represented by this instance.
Second | Gets the seconds component of the date represented by this instance.
ShortDate | Gets the value of this instance to its equivalent short date string representation.
ShortTime | Gets the value of this instance to its equivalent short time string representation.
TaskResources | (Inherited from Task.)
Ticks | Gets the number of ticks that represent the date and time of this instance.
TimeOfDay | Gets the time of day for this instance.
Year | Gets the year component of the date represented by this instance.

See Also

Time Class
MSBuild.Community.Tasks Namespace


DateTimeValue Property

[image]

.NET Framework Class Library
Time..::.DateTimeValue Property
Time Class See Also Send Feedback

Gets the internal time value.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DateTimeValue As DateTime
C#
public DateTime DateTimeValue { get; }
Visual C++
public:
property DateTime DateTimeValue {
    DateTime get ();
}

See Also

Time Class
MSBuild.Community.Tasks Namespace


Day Property

[image]

.NET Framework Class Library
Time..::.Day Property
Time Class See Also Send Feedback

Gets the day of the month represented by this instance.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property Day As String
C#
[OutputAttribute]
public string Day { get; }
Visual C++
[OutputAttribute]
public:
property String^ Day {
    String^ get ();
}

See Also

Time Class
MSBuild.Community.Tasks Namespace


DayOfWeek Property

[image]

.NET Framework Class Library
Time..::.DayOfWeek Property
Time Class See Also Send Feedback

Gets the day of the week represented by this instance.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property DayOfWeek As String
C#
[OutputAttribute]
public string DayOfWeek { get; }
Visual C++
[OutputAttribute]
public:
property String^ DayOfWeek {
    String^ get ();
}

See Also

Time Class
MSBuild.Community.Tasks Namespace


DayOfYear Property

[image]

.NET Framework Class Library
Time..::.DayOfYear Property
Time Class See Also Send Feedback

Gets the day of the year represented by this instance.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property DayOfYear As String
C#
[OutputAttribute]
public string DayOfYear { get; }
Visual C++
[OutputAttribute]
public:
property String^ DayOfYear {
    String^ get ();
}

See Also

Time Class
MSBuild.Community.Tasks Namespace


Format Property

[image]

.NET Framework Class Library
Time..::.Format Property
Time Class See Also Send Feedback

Gets or sets the format string for output parameter FormattedTime.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Format As String
C#
public string Format { get; set; }
Visual C++
public:
property String^ Format {
    String^ get ();
    void set (String^ value);
}

Remarks

See DateTimeFormatInfo for the syntax of the format string.

See Also

Time Class
MSBuild.Community.Tasks Namespace


FormattedTime Property

[image]

.NET Framework Class Library
Time..::.FormattedTime Property
Time Class See Also Send Feedback

Gets the value of this instance to its equivalent string representation. If input parameter Format is provided, the value is formatted according to it.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property FormattedTime As String
C#
[OutputAttribute]
public string FormattedTime { get; }
Visual C++
[OutputAttribute]
public:
property String^ FormattedTime {
    String^ get ();
}

See Also

Time Class
MSBuild.Community.Tasks Namespace


Hour Property

[image]

.NET Framework Class Library
Time..::.Hour Property
Time Class See Also Send Feedback

Gets the hour component of the date represented by this instance.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property Hour As String
C#
[OutputAttribute]
public string Hour { get; }
Visual C++
[OutputAttribute]
public:
property String^ Hour {
    String^ get ();
}

See Also

Time Class
MSBuild.Community.Tasks Namespace


Kind Property

[image]

.NET Framework Class Library
Time..::.Kind Property
Time Class See Also Send Feedback

Gets or sets a value that indicates whether the time represented by this instance is based on local time, Coordinated Universal Time (UTC), or neither.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public Property Kind As String
C#
[OutputAttribute]
public string Kind { get; set; }
Visual C++
[OutputAttribute]
public:
property String^ Kind {
    String^ get ();
    void set (String^ value);
}

Remarks

Possible values are: Local (default), Utc, Unspecified

See Also

Time Class
MSBuild.Community.Tasks Namespace


LongDate Property

[image]

.NET Framework Class Library
Time..::.LongDate Property
Time Class See Also Send Feedback

Gets the value of this instance to its equivalent long date string representation.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property LongDate As String
C#
[OutputAttribute]
public string LongDate { get; }
Visual C++
[OutputAttribute]
public:
property String^ LongDate {
    String^ get ();
}

See Also

Time Class
MSBuild.Community.Tasks Namespace


LongTime Property

[image]

.NET Framework Class Library
Time..::.LongTime Property
Time Class See Also Send Feedback

Gets the value of this instance to its equivalent long time string representation.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property LongTime As String
C#
[OutputAttribute]
public string LongTime { get; }
Visual C++
[OutputAttribute]
public:
property String^ LongTime {
    String^ get ();
}

See Also

Time Class
MSBuild.Community.Tasks Namespace


Millisecond Property

[image]

.NET Framework Class Library
Time..::.Millisecond Property
Time Class See Also Send Feedback

Gets the milliseconds component of the date represented by this instance.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property Millisecond As String
C#
[OutputAttribute]
public string Millisecond { get; }
Visual C++
[OutputAttribute]
public:
property String^ Millisecond {
    String^ get ();
}

See Also

Time Class
MSBuild.Community.Tasks Namespace


Minute Property

[image]

.NET Framework Class Library
Time..::.Minute Property
Time Class See Also Send Feedback

Gets the minute component of the date represented by this instance.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property Minute As String
C#
[OutputAttribute]
public string Minute { get; }
Visual C++
[OutputAttribute]
public:
property String^ Minute {
    String^ get ();
}

See Also

Time Class
MSBuild.Community.Tasks Namespace


Month Property

[image]

.NET Framework Class Library
Time..::.Month Property
Time Class See Also Send Feedback

Gets the month component of the date represented by this instance.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property Month As String
C#
[OutputAttribute]
public string Month { get; }
Visual C++
[OutputAttribute]
public:
property String^ Month {
    String^ get ();
}

See Also

Time Class
MSBuild.Community.Tasks Namespace


Second Property

[image]

.NET Framework Class Library
Time..::.Second Property
Time Class See Also Send Feedback

Gets the seconds component of the date represented by this instance.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property Second As String
C#
[OutputAttribute]
public string Second { get; }
Visual C++
[OutputAttribute]
public:
property String^ Second {
    String^ get ();
}

See Also

Time Class
MSBuild.Community.Tasks Namespace


ShortDate Property

[image]

.NET Framework Class Library
Time..::.ShortDate Property
Time Class See Also Send Feedback

Gets the value of this instance to its equivalent short date string representation.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property ShortDate As String
C#
[OutputAttribute]
public string ShortDate { get; }
Visual C++
[OutputAttribute]
public:
property String^ ShortDate {
    String^ get ();
}

See Also

Time Class
MSBuild.Community.Tasks Namespace


ShortTime Property

[image]

.NET Framework Class Library
Time..::.ShortTime Property
Time Class See Also Send Feedback

Gets the value of this instance to its equivalent short time string representation.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property ShortTime As String
C#
[OutputAttribute]
public string ShortTime { get; }
Visual C++
[OutputAttribute]
public:
property String^ ShortTime {
    String^ get ();
}

See Also

Time Class
MSBuild.Community.Tasks Namespace


Ticks Property

[image]

.NET Framework Class Library
Time..::.Ticks Property
Time Class See Also Send Feedback

Gets the number of ticks that represent the date and time of this instance.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property Ticks As String
C#
[OutputAttribute]
public string Ticks { get; }
Visual C++
[OutputAttribute]
public:
property String^ Ticks {
    String^ get ();
}

See Also

Time Class
MSBuild.Community.Tasks Namespace


TimeOfDay Property

[image]

.NET Framework Class Library
Time..::.TimeOfDay Property
Time Class See Also Send Feedback

Gets the time of day for this instance.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property TimeOfDay As String
C#
[OutputAttribute]
public string TimeOfDay { get; }
Visual C++
[OutputAttribute]
public:
property String^ TimeOfDay {
    String^ get ();
}

See Also

Time Class
MSBuild.Community.Tasks Namespace


Year Property

[image]

.NET Framework Class Library
Time..::.Year Property
Time Class See Also Send Feedback

Gets the year component of the date represented by this instance.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property Year As String
C#
[OutputAttribute]
public string Year { get; }
Visual C++
[OutputAttribute]
public:
property String^ Year {
    String^ get ();
}

See Also

Time Class
MSBuild.Community.Tasks Namespace


Unzip Class

[image]

.NET Framework Class Library
Unzip Class
Members Example See Also Send Feedback

Unzip a file to a target directory.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Unzip _
    Inherits Task
C#
public class Unzip : Task
Visual C++
public ref class Unzip : public Task

Examples

Unzip file tasks
Copy Code
            <Unzip ZipFileName="MSBuild.Community.Tasks.zip"
                TargetDirectory="Backup"/>

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks..::.Unzip

See Also

Unzip Members
MSBuild.Community.Tasks Namespace


Unzip Members

[image] [image]

.NET Framework Class Library
Unzip Members
Unzip Class Constructors Methods Properties See Also Send Feedback

The Unzip type exposes the following members.

Constructors

Name | Description
Unzip | Initializes a new instance of the Unzip class.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
ExtractedFiles | Gets the files extracted from the zip.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
Overwrite | Gets or sets a value indicating whether to overwrite any existing files on extraction. Defaults to true.
TargetDirectory | Gets or sets the target directory.
TaskResources | (Inherited from Task.)
ZipFileName | Gets or sets the name of the zip file.

See Also

Unzip Class
MSBuild.Community.Tasks Namespace


Unzip Constructor

[image]

.NET Framework Class Library
Unzip Constructor
Unzip Class See Also Send Feedback

Initializes a new instance of the Unzip class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Unzip()
Visual C++
public:
Unzip()

See Also

Unzip Class
MSBuild.Community.Tasks Namespace


Unzip Methods

[image] [image]

.NET Framework Class Library
Unzip Methods
Unzip Class See Also Send Feedback

The Unzip type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

Unzip Class
MSBuild.Community.Tasks Namespace


Execute Method

[image]

.NET Framework Class Library
Unzip..::.Execute Method
Unzip Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

Unzip Class
MSBuild.Community.Tasks Namespace


Unzip Properties

[image] [image]

.NET Framework Class Library
Unzip Properties
Unzip Class See Also Send Feedback

The Unzip type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
ExtractedFiles | Gets the files extracted from the zip.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
Overwrite | Gets or sets a value indicating whether to overwrite any existing files on extraction. Defaults to true.
TargetDirectory | Gets or sets the target directory.
TaskResources | (Inherited from Task.)
ZipFileName | Gets or sets the name of the zip file.

See Also

Unzip Class
MSBuild.Community.Tasks Namespace


ExtractedFiles Property

[image]

.NET Framework Class Library
Unzip..::.ExtractedFiles Property
Unzip Class See Also Send Feedback

Gets the files extracted from the zip.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property ExtractedFiles As ITaskItem()
C#
[OutputAttribute]
public ITaskItem[] ExtractedFiles { get; }
Visual C++
[OutputAttribute]
public:
property array<ITaskItem^>^ ExtractedFiles {
    array<ITaskItem^>^ get ();
}

Field Value

The files extracted from the zip.

See Also

Unzip Class
MSBuild.Community.Tasks Namespace


Overwrite Property

[image]

.NET Framework Class Library
Unzip..::.Overwrite Property
Unzip Class See Also Send Feedback

Gets or sets a value indicating whether to overwrite any existing files on extraction. Defaults to true.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Overwrite As Boolean
C#
public bool Overwrite { get; set; }
Visual C++
public:
property bool Overwrite {
    bool get ();
    void set (bool value);
}

Field Value

true to overwrite any existing files on extraction; otherwise, false.

See Also

Unzip Class
MSBuild.Community.Tasks Namespace


TargetDirectory Property

[image]

.NET Framework Class Library
Unzip..::.TargetDirectory Property
Unzip Class See Also Send Feedback

Gets or sets the target directory.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property TargetDirectory As String
C#
[RequiredAttribute]
public string TargetDirectory { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ TargetDirectory {
    String^ get ();
    void set (String^ value);
}

Field Value

The target directory.

See Also

Unzip Class
MSBuild.Community.Tasks Namespace


ZipFileName Property

[image]

.NET Framework Class Library
Unzip..::.ZipFileName Property
Unzip Class See Also Send Feedback

Gets or sets the name of the zip file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property ZipFileName As String
C#
[RequiredAttribute]
public string ZipFileName { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ ZipFileName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the zip file.

See Also

Unzip Class
MSBuild.Community.Tasks Namespace


User Class

[image]

.NET Framework Class Library
User Class
Members Example See Also Send Feedback

Provides information about the build user.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class User _
    Inherits Task
C#
public class User : Task
Visual C++
public ref class User : public Task

Remarks

The following output parameters are set only if information about the build user can be retrieved from the Active Directory if one exists:
  • FirstName
  • LastName
  • MiddleInitial
  • FullName
  • Email
  • Phone

Examples

Get build user information.
Copy Code
            <User>
              <Output TaskParameter="UserNameWithDomain" PropertyName="BuildUserID" />
              <Output TaskParameter="FullName" PropertyName="BuildUserName" />
              <Output TaskParameter="Email" PropertyName="BuildUserEmail" />
              <Output TaskParameter="Phone" PropertyName="BuildUserPhone" />
            </User>

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks..::.User

See Also

User Members
MSBuild.Community.Tasks Namespace


User Members

[image] [image]

.NET Framework Class Library
User Members
User Class Constructors Methods Properties See Also Send Feedback

The User type exposes the following members.

Constructors

Name | Description
User | Initializes a new instance of the User class.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | Executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
DomainName | Gets the domain name of the build user.
Email | Gets the email address of the build user.
FirstName | Gets the first name of the build user.
FullName | Gets the full name of the build user in "[First name] [Middle initial]. [Last name]" format .
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
LastName | Gets the last name of the build user.
Log | (Inherited from Task.)
MiddleInitial | Gets the middle initial of the build user.
Phone | Gets the phone number of the build user.
TaskResources | (Inherited from Task.)
UserName | Gets the user name of the build user.
UserNameWithDomain | Gets the username and domain name of the build user in "[Domain name]\[User name]" format.

See Also

User Class
MSBuild.Community.Tasks Namespace


User Constructor

[image]

.NET Framework Class Library
User Constructor
User Class See Also Send Feedback

Initializes a new instance of the User class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public User()
Visual C++
public:
User()

See Also

User Class
MSBuild.Community.Tasks Namespace


User Methods

[image] [image]

.NET Framework Class Library
User Methods
User Class See Also Send Feedback

The User type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | Executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

User Class
MSBuild.Community.Tasks Namespace


Execute Method

[image]

.NET Framework Class Library
User..::.Execute Method
User Class See Also Send Feedback

Executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

trueTruetruetrue (True in Visual Basic) if the task ran successfully; otherwise falseFalsefalsefalse (False in Visual Basic).

Implements

ITask..::.Execute()()()

See Also

User Class
MSBuild.Community.Tasks Namespace


User Properties

[image] [image]

.NET Framework Class Library
User Properties
User Class See Also Send Feedback

The User type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
DomainName | Gets the domain name of the build user.
Email | Gets the email address of the build user.
FirstName | Gets the first name of the build user.
FullName | Gets the full name of the build user in "[First name] [Middle initial]. [Last name]" format .
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
LastName | Gets the last name of the build user.
Log | (Inherited from Task.)
MiddleInitial | Gets the middle initial of the build user.
Phone | Gets the phone number of the build user.
TaskResources | (Inherited from Task.)
UserName | Gets the user name of the build user.
UserNameWithDomain | Gets the username and domain name of the build user in "[Domain name]\[User name]" format.

See Also

User Class
MSBuild.Community.Tasks Namespace


DomainName Property

[image]

.NET Framework Class Library
User..::.DomainName Property
User Class See Also Send Feedback

Gets the domain name of the build user.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property DomainName As String
C#
[OutputAttribute]
public string DomainName { get; }
Visual C++
[OutputAttribute]
public:
property String^ DomainName {
    String^ get ();
}

See Also

User Class
MSBuild.Community.Tasks Namespace


Email Property

[image]

.NET Framework Class Library
User..::.Email Property
User Class See Also Send Feedback

Gets the email address of the build user.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property Email As String
C#
[OutputAttribute]
public string Email { get; }
Visual C++
[OutputAttribute]
public:
property String^ Email {
    String^ get ();
}

See Also

User Class
MSBuild.Community.Tasks Namespace


FirstName Property

[image]

.NET Framework Class Library
User..::.FirstName Property
User Class See Also Send Feedback

Gets the first name of the build user.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property FirstName As String
C#
[OutputAttribute]
public string FirstName { get; }
Visual C++
[OutputAttribute]
public:
property String^ FirstName {
    String^ get ();
}

See Also

User Class
MSBuild.Community.Tasks Namespace


FullName Property

[image]

.NET Framework Class Library
User..::.FullName Property
User Class See Also Send Feedback

Gets the full name of the build user in "[First name] [Middle initial]. [Last name]" format .

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property FullName As String
C#
[OutputAttribute]
public string FullName { get; }
Visual C++
[OutputAttribute]
public:
property String^ FullName {
    String^ get ();
}

See Also

User Class
MSBuild.Community.Tasks Namespace


LastName Property

[image]

.NET Framework Class Library
User..::.LastName Property
User Class See Also Send Feedback

Gets the last name of the build user.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property LastName As String
C#
[OutputAttribute]
public string LastName { get; }
Visual C++
[OutputAttribute]
public:
property String^ LastName {
    String^ get ();
}

See Also

User Class
MSBuild.Community.Tasks Namespace


MiddleInitial Property

[image]

.NET Framework Class Library
User..::.MiddleInitial Property
User Class See Also Send Feedback

Gets the middle initial of the build user.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property MiddleInitial As String
C#
[OutputAttribute]
public string MiddleInitial { get; }
Visual C++
[OutputAttribute]
public:
property String^ MiddleInitial {
    String^ get ();
}

See Also

User Class
MSBuild.Community.Tasks Namespace


Phone Property

[image]

.NET Framework Class Library
User..::.Phone Property
User Class See Also Send Feedback

Gets the phone number of the build user.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property Phone As String
C#
[OutputAttribute]
public string Phone { get; }
Visual C++
[OutputAttribute]
public:
property String^ Phone {
    String^ get ();
}

See Also

User Class
MSBuild.Community.Tasks Namespace


UserName Property

[image]

.NET Framework Class Library
User..::.UserName Property
User Class See Also Send Feedback

Gets the user name of the build user.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property UserName As String
C#
[OutputAttribute]
public string UserName { get; }
Visual C++
[OutputAttribute]
public:
property String^ UserName {
    String^ get ();
}

See Also

User Class
MSBuild.Community.Tasks Namespace


UserNameWithDomain Property

[image]

.NET Framework Class Library
User..::.UserNameWithDomain Property
User Class See Also Send Feedback

Gets the username and domain name of the build user in "[Domain name]\[User name]" format.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property UserNameWithDomain As String
C#
[OutputAttribute]
public string UserNameWithDomain { get; }
Visual C++
[OutputAttribute]
public:
property String^ UserNameWithDomain {
    String^ get ();
}

See Also

User Class
MSBuild.Community.Tasks Namespace


Version Class

[image]

.NET Framework Class Library
Version Class
Members Example See Also Send Feedback

Generates version information based on various algorithms

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Version _
    Inherits Task
C#
public class Version : Task
Visual C++
public ref class Version : public Task

Examples

Get version information from file and increment revision.
Copy Code
            <Version VersionFile="number.txt" BuildType="Automatic" RevisionType="Increment">
                <Output TaskParameter="Major" PropertyName="Major" />
                <Output TaskParameter="Minor" PropertyName="Minor" />
                <Output TaskParameter="Build" PropertyName="Build" />
                <Output TaskParameter="Revision" PropertyName="Revision" />
            </Version>
            <Message Text="Version: $(Major).$(Minor).$(Build).$(Revision)"/>

Examples

Specify Major and Minor version information and generate Build and Revision.
Copy Code
            <Version BuildType="Automatic" RevisionType="Automatic" Major="1" Minor="3" >
                <Output TaskParameter="Major" PropertyName="Major" />
                <Output TaskParameter="Minor" PropertyName="Minor" />
                <Output TaskParameter="Build" PropertyName="Build" />
                <Output TaskParameter="Revision" PropertyName="Revision" />
            </Version>
            <Message Text="Version: $(Major).$(Minor).$(Build).$(Revision)"/>

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks..::.Version

See Also

Version Members
MSBuild.Community.Tasks Namespace


Version Members

[image] [image]

.NET Framework Class Library
Version Members
Version Class Constructors Methods Properties See Also Send Feedback

The Version type exposes the following members.

Constructors

Name | Description
Version | Initializes a new instance of the Version class.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
Build | Gets or sets the build version number.
BuildEngine | (Inherited from Task.)
BuildType | Gets or sets the method used to generate a Build number
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
Major | Gets or sets the major version number.
MajorType | Gets or sets the method used to generate a Major number
Minor | Gets or sets the minor version number.
MinorType | Gets or sets the method used to generate a Minor number
Revision | Gets or sets the revision version number.
RevisionType | Gets or sets the method used to generate a Revision number
StartDate | Gets or sets the starting date used to calculate the Build number when BuildType is Automatic.
TaskResources | (Inherited from Task.)
VersionFile | Gets or sets the file used to initialize and persist the version.

See Also

Version Class
MSBuild.Community.Tasks Namespace


Version Constructor

[image]

.NET Framework Class Library
Version Constructor
Version Class See Also Send Feedback

Initializes a new instance of the Version class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Version()
Visual C++
public:
Version()

See Also

Version Class
MSBuild.Community.Tasks Namespace


Version Methods

[image] [image]

.NET Framework Class Library
Version Methods
Version Class See Also Send Feedback

The Version type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

Version Class
MSBuild.Community.Tasks Namespace


Execute Method

[image]

.NET Framework Class Library
Version..::.Execute Method
Version Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

Version Class
MSBuild.Community.Tasks Namespace


Version Properties

[image] [image]

.NET Framework Class Library
Version Properties
Version Class See Also Send Feedback

The Version type exposes the following members.

Properties

Name | Description
Build | Gets or sets the build version number.
BuildEngine | (Inherited from Task.)
BuildType | Gets or sets the method used to generate a Build number
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
Major | Gets or sets the major version number.
MajorType | Gets or sets the method used to generate a Major number
Minor | Gets or sets the minor version number.
MinorType | Gets or sets the method used to generate a Minor number
Revision | Gets or sets the revision version number.
RevisionType | Gets or sets the method used to generate a Revision number
StartDate | Gets or sets the starting date used to calculate the Build number when BuildType is Automatic.
TaskResources | (Inherited from Task.)
VersionFile | Gets or sets the file used to initialize and persist the version.

See Also

Version Class
MSBuild.Community.Tasks Namespace


Build Property

[image]

.NET Framework Class Library
Version..::.Build Property
Version Class See Also Send Feedback

Gets or sets the build version number.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public Property Build As Integer
C#
[OutputAttribute]
public int Build { get; set; }
Visual C++
[OutputAttribute]
public:
property int Build {
    int get ();
    void set (int value);
}

Field Value

The build version number.

See Also

Version Class
MSBuild.Community.Tasks Namespace
Version..::.BuildType


BuildType Property

[image]

.NET Framework Class Library
Version..::.BuildType Property
Version Class See Also Send Feedback

Gets or sets the method used to generate a Build number

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property BuildType As String
C#
public string BuildType { get; set; }
Visual C++
public:
property String^ BuildType {
    String^ get ();
    void set (String^ value);
}

Remarks

If value is not provided, None is assumed. The Build number is set according to the following table:
BuildType | Description
None | The number is not modified.
Automatic | The number of days since StartDate.
Increment | Increases the previous Build value by 1.
Reset | Resets the previous Build value to 0.

See Also

Version Class
MSBuild.Community.Tasks Namespace


Major Property

[image]

.NET Framework Class Library
Version..::.Major Property
Version Class See Also Send Feedback

Gets or sets the major version number.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public Property Major As Integer
C#
[OutputAttribute]
public int Major { get; set; }
Visual C++
[OutputAttribute]
public:
property int Major {
    int get ();
    void set (int value);
}

Field Value

The major version number.

See Also

Version Class
MSBuild.Community.Tasks Namespace


MajorType Property

[image]

.NET Framework Class Library
Version..::.MajorType Property
Version Class See Also Send Feedback

Gets or sets the method used to generate a Major number

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property MajorType As String
C#
public string MajorType { get; set; }
Visual C++
public:
property String^ MajorType {
    String^ get ();
    void set (String^ value);
}

Remarks

If value is not provided, None is assumed. The Major number is set according to the following table:
MajorType | Description
None | The number is not modified.
Increment | Increases the previous Major value by 1.

See Also

Version Class
MSBuild.Community.Tasks Namespace


Minor Property

[image]

.NET Framework Class Library
Version..::.Minor Property
Version Class See Also Send Feedback

Gets or sets the minor version number.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public Property Minor As Integer
C#
[OutputAttribute]
public int Minor { get; set; }
Visual C++
[OutputAttribute]
public:
property int Minor {
    int get ();
    void set (int value);
}

Field Value

The minor version number.

See Also

Version Class
MSBuild.Community.Tasks Namespace


MinorType Property

[image]

.NET Framework Class Library
Version..::.MinorType Property
Version Class See Also Send Feedback

Gets or sets the method used to generate a Minor number

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property MinorType As String
C#
public string MinorType { get; set; }
Visual C++
public:
property String^ MinorType {
    String^ get ();
    void set (String^ value);
}

Remarks

If value is not provided, None is assumed. The Minor number is set according to the following table:
MinorType | Description
None | The number is not modified.
Increment | Increases the previous Minor value by 1.
Reset | Resets the previous Minor value to 0.

See Also

Version Class
MSBuild.Community.Tasks Namespace


Revision Property

[image]

.NET Framework Class Library
Version..::.Revision Property
Version Class See Also Send Feedback

Gets or sets the revision version number.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public Property Revision As Integer
C#
[OutputAttribute]
public int Revision { get; set; }
Visual C++
[OutputAttribute]
public:
property int Revision {
    int get ();
    void set (int value);
}

Field Value

The revision version number.

See Also

Version Class
MSBuild.Community.Tasks Namespace
Version..::.RevisionType


RevisionType Property

[image]

.NET Framework Class Library
Version..::.RevisionType Property
Version Class See Also Send Feedback

Gets or sets the method used to generate a Revision number

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property RevisionType As String
C#
public string RevisionType { get; set; }
Visual C++
public:
property String^ RevisionType {
    String^ get ();
    void set (String^ value);
}

Remarks

If value is not provided, None is assumed. The Revision number is set according to the following table:
RevisionType | Description
None | The number is not modified.
Automatic | A number that starts at 0 at midnight, and constantly increases throughout the day (changing roughly every 1.3 seconds). Guaranteed to be safe for components of the AssemblyVersion attribute.
Increment | Increases the previous Revision value by 1.
BuildIncrement | Increases the previous Revision value by 1 when the value of Build is unchanged. If the value of Build has changed, Revision is reset to 0.
Reset | Resets the previous Revision value to 0.

See Also

Version Class
MSBuild.Community.Tasks Namespace


StartDate Property

[image]

.NET Framework Class Library
Version..::.StartDate Property
Version Class See Also Send Feedback

Gets or sets the starting date used to calculate the Build number when BuildType is Automatic.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property StartDate As String
C#
public string StartDate { get; set; }
Visual C++
public:
property String^ StartDate {
    String^ get ();
    void set (String^ value);
}

Field Value

The starting date for calculation of the build number.

Remarks

This value is only used when the BuildType is Automatic.

This default value is January 1, 2000.

See Also

Version Class
MSBuild.Community.Tasks Namespace


VersionFile Property

[image]

.NET Framework Class Library
Version..::.VersionFile Property
Version Class See Also Send Feedback

Gets or sets the file used to initialize and persist the version.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property VersionFile As String
C#
public string VersionFile { get; set; }
Visual C++
public:
property String^ VersionFile {
    String^ get ();
    void set (String^ value);
}

Field Value

The version file.

Remarks

When specified, the task will attempt to load the previous version information from the file. After updating the version, the new value will be saved to the file.

If you do not specify a value for this property, the version will be calculated based on the values passed to the Major, Minor, Build, and Revision properties. The new version will not be persisted.

See Also

Version Class
MSBuild.Community.Tasks Namespace


WebDownload Class

[image]

.NET Framework Class Library
WebDownload Class
Members Example See Also Send Feedback

Downloads a resource with the specified URI to a local file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class WebDownload _
    Inherits Task
C#
public class WebDownload : Task
Visual C++
public ref class WebDownload : public Task

Examples

Download the Microsoft.com home page.
Copy Code
            <WebDownload FileUri="http://www.microsoft.com/default.aspx"
                FileName="microsoft.html" />

Examples

Download a page from your local intranet protected by Windows Authentication
Copy Code
            <WebDownload FileUri="http://intranet/default.aspx" FileName="page.html" UseDefaultCredentials="True" />

Examples

Download a page from a password protected website
Copy Code
            <WebDownload FileUri="http://example.com/myscore.aspx" FileName="page.html" Username="joeuser" Password="password123" />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks..::.WebDownload

See Also

WebDownload Members
MSBuild.Community.Tasks Namespace


WebDownload Members

[image] [image]

.NET Framework Class Library
WebDownload Members
WebDownload Class Constructors Methods Properties See Also Send Feedback

The WebDownload type exposes the following members.

Constructors

Name | Description
WebDownload |

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetConfiguredCredentials | Determines which credentials to pass with the web request
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Domain | The domain of the user being used to authenticate against the remote web server. A value for Username must also be provided.
FileName | Gets or sets the name of the local file that is to receive the data.
FileUri | Gets or sets the URI from which to download data.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
Password | The password used to authenticate against the remote web server. A value for Username must also be provided.
TaskResources | (Inherited from Task.)
UseDefaultCredentials | When true, the current user's credentials are used to authenticate against the remote web server
Username | The username used to authenticate against the remote web server

See Also

WebDownload Class
MSBuild.Community.Tasks Namespace


WebDownload Constructor

[image]

.NET Framework Class Library
WebDownload Constructor
WebDownload Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public WebDownload()
Visual C++
public:
WebDownload()

See Also

WebDownload Class
MSBuild.Community.Tasks Namespace


WebDownload Methods

[image] [image]

.NET Framework Class Library
WebDownload Methods
WebDownload Class See Also Send Feedback

The WebDownload type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetConfiguredCredentials | Determines which credentials to pass with the web request
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

WebDownload Class
MSBuild.Community.Tasks Namespace


Execute Method

[image]

.NET Framework Class Library
WebDownload..::.Execute Method
WebDownload Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

WebDownload Class
MSBuild.Community.Tasks Namespace


GetConfiguredCredentials Method

[image]

.NET Framework Class Library
WebDownload..::.GetConfiguredCredentials Method
WebDownload Class See Also Send Feedback

Determines which credentials to pass with the web request

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Function GetConfiguredCredentials As ICredentials
C#
public ICredentials GetConfiguredCredentials()
Visual C++
public:
ICredentials^ GetConfiguredCredentials()

Return Value

See Also

WebDownload Class
MSBuild.Community.Tasks Namespace


WebDownload Properties

[image] [image]

.NET Framework Class Library
WebDownload Properties
WebDownload Class See Also Send Feedback

The WebDownload type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Domain | The domain of the user being used to authenticate against the remote web server. A value for Username must also be provided.
FileName | Gets or sets the name of the local file that is to receive the data.
FileUri | Gets or sets the URI from which to download data.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
Password | The password used to authenticate against the remote web server. A value for Username must also be provided.
TaskResources | (Inherited from Task.)
UseDefaultCredentials | When true, the current user's credentials are used to authenticate against the remote web server
Username | The username used to authenticate against the remote web server

See Also

WebDownload Class
MSBuild.Community.Tasks Namespace


Domain Property

[image]

.NET Framework Class Library
WebDownload..::.Domain Property
WebDownload Class See Also Send Feedback

The domain of the user being used to authenticate against the remote web server. A value for Username must also be provided.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Domain As String
C#
public string Domain { get; set; }
Visual C++
public:
property String^ Domain {
    String^ get ();
    void set (String^ value);
}

See Also

WebDownload Class
MSBuild.Community.Tasks Namespace


FileName Property

[image]

.NET Framework Class Library
WebDownload..::.FileName Property
WebDownload Class See Also Send Feedback

Gets or sets the name of the local file that is to receive the data.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property FileName As String
C#
[RequiredAttribute]
public string FileName { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the file.

See Also

WebDownload Class
MSBuild.Community.Tasks Namespace


FileUri Property

[image]

.NET Framework Class Library
WebDownload..::.FileUri Property
WebDownload Class See Also Send Feedback

Gets or sets the URI from which to download data.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property FileUri As String
C#
[RequiredAttribute]
public string FileUri { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ FileUri {
    String^ get ();
    void set (String^ value);
}

Field Value

The file URI.

See Also

WebDownload Class
MSBuild.Community.Tasks Namespace


Password Property

[image]

.NET Framework Class Library
WebDownload..::.Password Property
WebDownload Class See Also Send Feedback

The password used to authenticate against the remote web server. A value for Username must also be provided.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password { get; set; }
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

WebDownload Class
MSBuild.Community.Tasks Namespace


UseDefaultCredentials Property

[image]

.NET Framework Class Library
WebDownload..::.UseDefaultCredentials Property
WebDownload Class See Also Send Feedback

When true, the current user's credentials are used to authenticate against the remote web server

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property UseDefaultCredentials As Boolean
C#
public bool UseDefaultCredentials { get; set; }
Visual C++
public:
property bool UseDefaultCredentials {
    bool get ();
    void set (bool value);
}

Remarks

This value is ignored if the Username property is set to a non-empty value.

See Also

WebDownload Class
MSBuild.Community.Tasks Namespace


Username Property

[image]

.NET Framework Class Library
WebDownload..::.Username Property
WebDownload Class See Also Send Feedback

The username used to authenticate against the remote web server

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Username As String
C#
public string Username { get; set; }
Visual C++
public:
property String^ Username {
    String^ get ();
    void set (String^ value);
}

See Also

WebDownload Class
MSBuild.Community.Tasks Namespace


XmlRead Class

[image]

.NET Framework Class Library
XmlRead Class
Members Example See Also Send Feedback

Reads a value from a XML document using a XPath.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlRead _
    Inherits Task
C#
public class XmlRead : Task
Visual C++
public ref class XmlRead : public Task

Remarks

If the XPath returns multiple nodes, the Value will be a semicolon delimited list of the nodes text.

Examples

Read all targest from a build project.
Copy Code
            <XmlRead Prefix="n"
                Namespace="http://schemas.microsoft.com/developer/msbuild/2003"
                XPath="/n:Project/n:Target/@Name"
                XmlFileName="Subversion.proj">
                <Output TaskParameter="Value" PropertyName="BuildTargets" />
            </XmlRead>
            <Message Text="Build Targets: $(BuildTargets)"/>

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks..::.XmlRead

See Also

XmlRead Members
MSBuild.Community.Tasks Namespace


XmlRead Members

[image] [image]

.NET Framework Class Library
XmlRead Members
XmlRead Class Constructors Methods Properties See Also Send Feedback

The XmlRead type exposes the following members.

Constructors

Name | Description
XmlRead | Initializes a new instance of the XmlRead class.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
Namespace | Gets or sets the default namespace.
Prefix | Gets or sets the prefix to associate with the namespace being added.
TaskResources | (Inherited from Task.)
Value | Gets the value read from file.
XmlFileName | Gets or sets the name of the XML file.
XPath | Gets or sets the XPath.

See Also

XmlRead Class
MSBuild.Community.Tasks Namespace


XmlRead Constructor

[image]

.NET Framework Class Library
XmlRead Constructor
XmlRead Class See Also Send Feedback

Initializes a new instance of the XmlRead class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public XmlRead()
Visual C++
public:
XmlRead()

See Also

XmlRead Class
MSBuild.Community.Tasks Namespace


XmlRead Methods

[image] [image]

.NET Framework Class Library
XmlRead Methods
XmlRead Class See Also Send Feedback

The XmlRead type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

XmlRead Class
MSBuild.Community.Tasks Namespace


Execute Method

[image]

.NET Framework Class Library
XmlRead..::.Execute Method
XmlRead Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

XmlRead Class
MSBuild.Community.Tasks Namespace


XmlRead Properties

[image] [image]

.NET Framework Class Library
XmlRead Properties
XmlRead Class See Also Send Feedback

The XmlRead type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
Namespace | Gets or sets the default namespace.
Prefix | Gets or sets the prefix to associate with the namespace being added.
TaskResources | (Inherited from Task.)
Value | Gets the value read from file.
XmlFileName | Gets or sets the name of the XML file.
XPath | Gets or sets the XPath.

See Also

XmlRead Class
MSBuild.Community.Tasks Namespace


Namespace Property

[image]

.NET Framework Class Library
XmlRead..::.Namespace Property
XmlRead Class See Also Send Feedback

Gets or sets the default namespace.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Namespace As String
C#
public string Namespace { get; set; }
Visual C++
public:
property String^ Namespace {
    String^ get ();
    void set (String^ value);
}

Field Value

The namespace.

See Also

XmlRead Class
MSBuild.Community.Tasks Namespace


Prefix Property

[image]

.NET Framework Class Library
XmlRead..::.Prefix Property
XmlRead Class See Also Send Feedback

Gets or sets the prefix to associate with the namespace being added.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Prefix As String
C#
public string Prefix { get; set; }
Visual C++
public:
property String^ Prefix {
    String^ get ();
    void set (String^ value);
}

Field Value

The namespace prefix.

See Also

XmlRead Class
MSBuild.Community.Tasks Namespace


Value Property

[image]

.NET Framework Class Library
XmlRead..::.Value Property
XmlRead Class See Also Send Feedback

Gets the value read from file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property Value As String
C#
[OutputAttribute]
public string Value { get; }
Visual C++
[OutputAttribute]
public:
property String^ Value {
    String^ get ();
}

Field Value

The value.

Remarks

If the XPath returns multiple nodes, the values will be semicolon delimited.

See Also

XmlRead Class
MSBuild.Community.Tasks Namespace


XmlFileName Property

[image]

.NET Framework Class Library
XmlRead..::.XmlFileName Property
XmlRead Class See Also Send Feedback

Gets or sets the name of the XML file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property XmlFileName As String
C#
[RequiredAttribute]
public string XmlFileName { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ XmlFileName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the XML file.

See Also

XmlRead Class
MSBuild.Community.Tasks Namespace


XPath Property

[image]

.NET Framework Class Library
XmlRead..::.XPath Property
XmlRead Class See Also Send Feedback

Gets or sets the XPath.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property XPath As String
C#
[RequiredAttribute]
public string XPath { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ XPath {
    String^ get ();
    void set (String^ value);
}

Field Value

The XPath.

See Also

XmlRead Class
MSBuild.Community.Tasks Namespace


XmlUpdate Class

[image]

.NET Framework Class Library
XmlUpdate Class
Members Example See Also Send Feedback

Updates a XML document using a XPath.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlUpdate _
    Inherits Task
C#
public class XmlUpdate : Task
Visual C++
public ref class XmlUpdate : public Task

Remarks

The XML node being updated must exist before using the XmlUpdate task.

Examples

Update a XML element.
Copy Code
            <XmlUpdate Prefix="n"
                Namespace="http://schemas.microsoft.com/developer/msbuild/2003"
                XPath="/n:Project/n:PropertyGroup/n:TestUpdate"
                XmlFileName="Subversion.proj"
                Value="Test from $(MSBuildProjectFile)"/>

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks..::.XmlUpdate

See Also

XmlUpdate Members
MSBuild.Community.Tasks Namespace


XmlUpdate Members

[image] [image]

.NET Framework Class Library
XmlUpdate Members
XmlUpdate Class Constructors Methods Properties See Also Send Feedback

The XmlUpdate type exposes the following members.

Constructors

Name | Description
XmlUpdate | Initializes a new instance of the XmlUpdate class.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Delete | Gets or sets a value indicating whether the matched node is deleted.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
Namespace | Gets or sets the default namespace.
Prefix | Gets or sets the prefix to associate with the namespace being added.
TaskResources | (Inherited from Task.)
Value | Gets or sets the value to write.
XmlFileName | Gets or sets the name of the XML file.
XPath | Gets or sets the XPath.

See Also

XmlUpdate Class
MSBuild.Community.Tasks Namespace


XmlUpdate Constructor

[image]

.NET Framework Class Library
XmlUpdate Constructor
XmlUpdate Class See Also Send Feedback

Initializes a new instance of the XmlUpdate class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public XmlUpdate()
Visual C++
public:
XmlUpdate()

See Also

XmlUpdate Class
MSBuild.Community.Tasks Namespace


XmlUpdate Methods

[image] [image]

.NET Framework Class Library
XmlUpdate Methods
XmlUpdate Class See Also Send Feedback

The XmlUpdate type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

XmlUpdate Class
MSBuild.Community.Tasks Namespace


Execute Method

[image]

.NET Framework Class Library
XmlUpdate..::.Execute Method
XmlUpdate Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

XmlUpdate Class
MSBuild.Community.Tasks Namespace


XmlUpdate Properties

[image] [image]

.NET Framework Class Library
XmlUpdate Properties
XmlUpdate Class See Also Send Feedback

The XmlUpdate type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Delete | Gets or sets a value indicating whether the matched node is deleted.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
Namespace | Gets or sets the default namespace.
Prefix | Gets or sets the prefix to associate with the namespace being added.
TaskResources | (Inherited from Task.)
Value | Gets or sets the value to write.
XmlFileName | Gets or sets the name of the XML file.
XPath | Gets or sets the XPath.

See Also

XmlUpdate Class
MSBuild.Community.Tasks Namespace


Delete Property

[image]

.NET Framework Class Library
XmlUpdate..::.Delete Property
XmlUpdate Class See Also Send Feedback

Gets or sets a value indicating whether the matched node is deleted.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Delete As Boolean
C#
public bool Delete { get; set; }
Visual C++
public:
property bool Delete {
    bool get ();
    void set (bool value);
}

Field Value

true to delete matched node; otherwise, false.

See Also

XmlUpdate Class
MSBuild.Community.Tasks Namespace


Namespace Property

[image]

.NET Framework Class Library
XmlUpdate..::.Namespace Property
XmlUpdate Class See Also Send Feedback

Gets or sets the default namespace.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Namespace As String
C#
public string Namespace { get; set; }
Visual C++
public:
property String^ Namespace {
    String^ get ();
    void set (String^ value);
}

Field Value

The namespace.

See Also

XmlUpdate Class
MSBuild.Community.Tasks Namespace


Prefix Property

[image]

.NET Framework Class Library
XmlUpdate..::.Prefix Property
XmlUpdate Class See Also Send Feedback

Gets or sets the prefix to associate with the namespace being added.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Prefix As String
C#
public string Prefix { get; set; }
Visual C++
public:
property String^ Prefix {
    String^ get ();
    void set (String^ value);
}

Field Value

The namespace prefix.

See Also

XmlUpdate Class
MSBuild.Community.Tasks Namespace


Value Property

[image]

.NET Framework Class Library
XmlUpdate..::.Value Property
XmlUpdate Class See Also Send Feedback

Gets or sets the value to write.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As String
C#
public string Value { get; set; }
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Field Value

The value.

See Also

XmlUpdate Class
MSBuild.Community.Tasks Namespace


XmlFileName Property

[image]

.NET Framework Class Library
XmlUpdate..::.XmlFileName Property
XmlUpdate Class See Also Send Feedback

Gets or sets the name of the XML file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property XmlFileName As String
C#
[RequiredAttribute]
public string XmlFileName { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ XmlFileName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the XML file.

See Also

XmlUpdate Class
MSBuild.Community.Tasks Namespace


XPath Property

[image]

.NET Framework Class Library
XmlUpdate..::.XPath Property
XmlUpdate Class See Also Send Feedback

Gets or sets the XPath.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property XPath As String
C#
[RequiredAttribute]
public string XPath { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ XPath {
    String^ get ();
    void set (String^ value);
}

Field Value

The XPath.

See Also

XmlUpdate Class
MSBuild.Community.Tasks Namespace


Xslt Class

[image]

.NET Framework Class Library
Xslt Class
Members Example See Also Send Feedback

A task to merge and transform a set of xml files.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Xslt _
    Inherits Task
C#
public class Xslt : Task
Visual C++
public ref class Xslt : public Task

Remarks

The xml files of parameter Inputs are merged into one xml document, wrapped with a root tag RootTag

If only one input file is provided, merging and wrapping can be omitted by setting RootTag to an empty string.

The root tag can be given any number of attributes by providing a list of semicolon-delimited name/value pairs to parameter RootAttributes. For example:

Copy Code
RootAttributes="foo=bar;date=$(buildDate)"

Parameter RootAttributes defaults to one attribute with a name specified by CREATED_ATTRIBUTE, and a local time stamp as value. To suppress the default value, an empty parameter

Copy Code
RootAttributes=""
must be specified explicitely.

The xsl transformation file specified by parameter Xsl is applied on the input.

The ITaskItem Xsl can be given any number of metadata, which will be handed to the xsl transformation as parameters.

The output is written to the file specified by parameter Output.

Examples

This example for generating a report from a set of NUnit xml results:
Copy Code

<ItemGroup>
    <nunitReportXslFile Include="$(MSBuildCommunityTasksPath)\$(nunitReportXsl)">
        <project>$(project)</project>
        <configuration>$(configuration)</configuration>
        <msbuildFilename>$(MSBuildProjectFullPath)</msbuildFilename>
        <msbuildBinpath>$(MSBuildBinPath)</msbuildBinpath>
        <xslFile>$(MSBuildCommunityTasksPath)\$(nunitReportXsl)</xslFile>
    </nunitReportXslFile>
</ItemGroup>

<Target Name="test-report" >
    <Xslt Inputs="@(nunitFiles)"
        RootTag="mergedroot"
        Xsl="@(nunitReportXslFile)"
        Output="$(testDir)\TestReport.html" />
</Target>
This examples shows all available task attributes:
Copy Code

<Time Format="yyyyMMddHHmmss">
    <Output TaskParameter="LocalTimestamp" PropertyName="buildDate" />
</Time>

<Xslt
     Inputs="@(xmlfiles)"
     RootTag="mergedroot"
     RootAttributes="foo=bar;date=$(buildDate)"
     Xsl="transformation.xsl"
     Output="report.html"
/>

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks..::.Xslt

See Also

Xslt Members
MSBuild.Community.Tasks Namespace


Xslt Members

[image] [image]

.NET Framework Class Library
Xslt Members
Xslt Class Constructors Methods Fields Properties See Also Send Feedback

The Xslt type exposes the following members.

Constructors

Name | Description
Xslt |

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Fields

Name | Description
CREATED_ATTRIBUTE | The name of the default attribute of the RootTag. The value is "created", and the attribute will contain a local time stamp.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Inputs
Gets or sets the xml input files.
Log | (Inherited from Task.)
Output
Gets or sets the path of the output file.
RootAttributes
Gets or sets the list of semicolon-delimited name/value pairs of the RootTag. For example:
Copy Code
RootAttributes="foo=bar;date=$(buildDate)"
RootTag
Gets or sets the xml tag name of the root tag wrapped around the merged xml input files.
TaskResources | (Inherited from Task.)
Xsl
Gets or sets the path of the xsl transformation file to apply.

See Also

Xslt Class
MSBuild.Community.Tasks Namespace


Xslt Constructor

[image]

.NET Framework Class Library
Xslt Constructor
Xslt Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Xslt()
Visual C++
public:
Xslt()

See Also

Xslt Class
MSBuild.Community.Tasks Namespace


Xslt Fields

[image] [image]

.NET Framework Class Library
Xslt Fields
Xslt Class See Also Send Feedback

The Xslt type exposes the following members.

Fields

Name | Description
CREATED_ATTRIBUTE | The name of the default attribute of the RootTag. The value is "created", and the attribute will contain a local time stamp.

See Also

Xslt Class
MSBuild.Community.Tasks Namespace


CREATED_ATTRIBUTE Field

[image]

.NET Framework Class Library
Xslt..::.CREATED_ATTRIBUTE Field
Xslt Class See Also Send Feedback

The name of the default attribute of the RootTag. The value is "created", and the attribute will contain a local time stamp.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Const CREATED_ATTRIBUTE As String
C#
public const string CREATED_ATTRIBUTE
Visual C++
public:
literal String^ CREATED_ATTRIBUTE

See Also

Xslt Class
MSBuild.Community.Tasks Namespace


Xslt Methods

[image] [image]

.NET Framework Class Library
Xslt Methods
Xslt Class See Also Send Feedback

The Xslt type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

Xslt Class
MSBuild.Community.Tasks Namespace


Execute Method

[image]

.NET Framework Class Library
Xslt..::.Execute Method
Xslt Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

Returns true if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

Xslt Class
MSBuild.Community.Tasks Namespace


Xslt Properties

[image] [image]

.NET Framework Class Library
Xslt Properties
Xslt Class See Also Send Feedback

The Xslt type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Inputs
Gets or sets the xml input files.
Log | (Inherited from Task.)
Output
Gets or sets the path of the output file.
RootAttributes
Gets or sets the list of semicolon-delimited name/value pairs of the RootTag. For example:
Copy Code
RootAttributes="foo=bar;date=$(buildDate)"
RootTag
Gets or sets the xml tag name of the root tag wrapped around the merged xml input files.
TaskResources | (Inherited from Task.)
Xsl
Gets or sets the path of the xsl transformation file to apply.

See Also

Xslt Class
MSBuild.Community.Tasks Namespace


Inputs Property

[image]

.NET Framework Class Library
Xslt..::.Inputs Property
Xslt Class See Also Send Feedback

Gets or sets the xml input files.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property Inputs As ITaskItem()
C#
[RequiredAttribute]
public ITaskItem[] Inputs { get; set; }
Visual C++
[RequiredAttribute]
public:
property array<ITaskItem^>^ Inputs {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

See Also

Xslt Class
MSBuild.Community.Tasks Namespace


Output Property

[image]

.NET Framework Class Library
Xslt..::.Output Property
Xslt Class See Also Send Feedback

Gets or sets the path of the output file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property Output As String
C#
[RequiredAttribute]
public string Output { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ Output {
    String^ get ();
    void set (String^ value);
}

See Also

Xslt Class
MSBuild.Community.Tasks Namespace


RootAttributes Property

[image]

.NET Framework Class Library
Xslt..::.RootAttributes Property
Xslt Class See Also Send Feedback

Gets or sets the list of semicolon-delimited name/value pairs of the RootTag. For example:
Copy Code
RootAttributes="foo=bar;date=$(buildDate)"

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property RootAttributes As String
C#
public string RootAttributes { get; set; }
Visual C++
public:
property String^ RootAttributes {
    String^ get ();
    void set (String^ value);
}

See Also

Xslt Class
MSBuild.Community.Tasks Namespace


RootTag Property

[image]

.NET Framework Class Library
Xslt..::.RootTag Property
Xslt Class See Also Send Feedback

Gets or sets the xml tag name of the root tag wrapped around the merged xml input files.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property RootTag As String
C#
public string RootTag { get; set; }
Visual C++
public:
property String^ RootTag {
    String^ get ();
    void set (String^ value);
}

See Also

Xslt Class
MSBuild.Community.Tasks Namespace


Xsl Property

[image]

.NET Framework Class Library
Xslt..::.Xsl Property
Xslt Class See Also Send Feedback

Gets or sets the path of the xsl transformation file to apply.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property Xsl As ITaskItem
C#
[RequiredAttribute]
public ITaskItem Xsl { get; set; }
Visual C++
[RequiredAttribute]
public:
property ITaskItem^ Xsl {
    ITaskItem^ get ();
    void set (ITaskItem^ value);
}

Remarks

The property can be given any number of metadata, which will be handed to the xsl transformation as parameters.

See Also

Xslt Class
MSBuild.Community.Tasks Namespace


Zip Class

[image]

.NET Framework Class Library
Zip Class
Members Example See Also Send Feedback

Create a zip file with the files specified.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Zip _
    Inherits Task
C#
public class Zip : Task
Visual C++
public ref class Zip : public Task

Examples

Create a zip file
Copy Code
            <ItemGroup>
                <ZipFiles Include="**\*.*" Exclude="*.zip" />
            </ItemGroup>
            <Target Name="Zip">
                <Zip Files="@(ZipFiles)"
                    ZipFileName="MSBuild.Community.Tasks.zip" />
            </Target>
Create a zip file using a working directory.
Copy Code
            <ItemGroup>
                <RepoFiles Include="D:\svn\repo\**\*.*" />
            </ItemGroup>
            <Target Name="Zip">
                <Zip Files="@(RepoFiles)"
                    WorkingDirectory="D:\svn\repo"
                    ZipFileName="D:\svn\repo.zip" />
            </Target>

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks..::.Zip

See Also

Zip Members
MSBuild.Community.Tasks Namespace


Zip Members

[image] [image]

.NET Framework Class Library
Zip Members
Zip Class Constructors Methods Properties See Also Send Feedback

The Zip type exposes the following members.

Constructors

Name | Description
Zip | Initializes a new instance of the Zip class.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Comment | Gets or sets the comment.
Files | Gets or sets the files to zip.
Flatten | Gets or sets a value indicating whether this Zip is flatten.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
TaskResources | (Inherited from Task.)
WorkingDirectory | Gets or sets the working directory for the zip file.
ZipFileName | Gets or sets the name of the zip file.
ZipLevel | Gets or sets the zip level. Default is 6.

See Also

Zip Class
MSBuild.Community.Tasks Namespace


Zip Constructor

[image]

.NET Framework Class Library
Zip Constructor
Zip Class See Also Send Feedback

Initializes a new instance of the Zip class.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Zip()
Visual C++
public:
Zip()

See Also

Zip Class
MSBuild.Community.Tasks Namespace


Zip Methods

[image] [image]

.NET Framework Class Library
Zip Methods
Zip Class See Also Send Feedback

The Zip type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

Zip Class
MSBuild.Community.Tasks Namespace


Execute Method

[image]

.NET Framework Class Library
Zip..::.Execute Method
Zip Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

Zip Class
MSBuild.Community.Tasks Namespace


Zip Properties

[image] [image]

.NET Framework Class Library
Zip Properties
Zip Class See Also Send Feedback

The Zip type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Comment | Gets or sets the comment.
Files | Gets or sets the files to zip.
Flatten | Gets or sets a value indicating whether this Zip is flatten.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
TaskResources | (Inherited from Task.)
WorkingDirectory | Gets or sets the working directory for the zip file.
ZipFileName | Gets or sets the name of the zip file.
ZipLevel | Gets or sets the zip level. Default is 6.

See Also

Zip Class
MSBuild.Community.Tasks Namespace


Comment Property

[image]

.NET Framework Class Library
Zip..::.Comment Property
Zip Class See Also Send Feedback

Gets or sets the comment.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Comment As String
C#
public string Comment { get; set; }
Visual C++
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}

Field Value

The comment.

See Also

Zip Class
MSBuild.Community.Tasks Namespace


Files Property

[image]

.NET Framework Class Library
Zip..::.Files Property
Zip Class See Also Send Feedback

Gets or sets the files to zip.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property Files As ITaskItem()
C#
[RequiredAttribute]
public ITaskItem[] Files { get; set; }
Visual C++
[RequiredAttribute]
public:
property array<ITaskItem^>^ Files {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

Field Value

The files to zip.

See Also

Zip Class
MSBuild.Community.Tasks Namespace


Flatten Property

[image]

.NET Framework Class Library
Zip..::.Flatten Property
Zip Class See Also Send Feedback

Gets or sets a value indicating whether this Zip is flatten.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Flatten As Boolean
C#
public bool Flatten { get; set; }
Visual C++
public:
property bool Flatten {
    bool get ();
    void set (bool value);
}

Field Value

true if flatten; otherwise, false.

Remarks

Flattening the zip means that all directories will be removed and the files will be place at the root of the zip file

See Also

Zip Class
MSBuild.Community.Tasks Namespace


WorkingDirectory Property

[image]

.NET Framework Class Library
Zip..::.WorkingDirectory Property
Zip Class See Also Send Feedback

Gets or sets the working directory for the zip file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property WorkingDirectory As String
C#
public string WorkingDirectory { get; set; }
Visual C++
public:
property String^ WorkingDirectory {
    String^ get ();
    void set (String^ value);
}

Field Value

The working directory.

Remarks

The working directory is the base of the zip file. All files will be made relative from the working directory.

See Also

Zip Class
MSBuild.Community.Tasks Namespace


ZipFileName Property

[image]

.NET Framework Class Library
Zip..::.ZipFileName Property
Zip Class See Also Send Feedback

Gets or sets the name of the zip file.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property ZipFileName As String
C#
[RequiredAttribute]
public string ZipFileName { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ ZipFileName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the zip file.

See Also

Zip Class
MSBuild.Community.Tasks Namespace


ZipLevel Property

[image]

.NET Framework Class Library
Zip..::.ZipLevel Property
Zip Class See Also Send Feedback

Gets or sets the zip level. Default is 6.

Namespace: MSBuild.Community.Tasks
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ZipLevel As Integer
C#
public int ZipLevel { get; set; }
Visual C++
public:
property int ZipLevel {
    int get ();
    void set (int value);
}

Field Value

The zip level.

Remarks

0 - store only to 9 - means best compression

See Also

Zip Class
MSBuild.Community.Tasks Namespace


MSBuild.Community.Tasks.AspNet Namespace

[image]

.NET Framework Class Library
MSBuild.Community.Tasks.AspNet Namespace
Send Feedback

Classes

Class | Description
InstallAspNet | Installs and register script mappings for ASP.NET


InstallAspNet Class

[image]

.NET Framework Class Library
InstallAspNet Class
Members Example See Also Send Feedback

Installs and register script mappings for ASP.NET

Namespace: MSBuild.Community.Tasks.AspNet
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class InstallAspNet _
    Inherits ToolTask
C#
public class InstallAspNet : ToolTask
Visual C++
public ref class InstallAspNet : public ToolTask

Remarks

Uses the aspnet_regiis.exe tool included with the .NET Framework.

Examples

Install the latest version of ASP.NET on the server:
Copy Code
         <InstallAspNet />

Examples

Install the latest version of ASP.NET on the server, but do not update script maps:
Copy Code
         <InstallAspNet ApplyScriptMaps="Never" />

Examples

Install the script maps for ASP.NET 2.0 on a web directory on the default website:
Copy Code
         <InstallAspNet Path="MyApplication" Version="Version20" />

Examples

Install the script maps for ASP.NET 1.1 on a web directory on a non-default website:
Copy Code
         <InstallAspNet Path="MyApplication" Version="W3SVC/3/Root/Version11" />

Examples

Install client side script only for the latest version:
Copy Code
         <InstallAspNet ClientScriptsOnly="True" />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
Microsoft.Build.Utilities..::.ToolTask
MSBuild.Community.Tasks.AspNet..::.InstallAspNet

See Also

InstallAspNet Members
MSBuild.Community.Tasks.AspNet Namespace


InstallAspNet Members

[image] [image]

.NET Framework Class Library
InstallAspNet Members
InstallAspNet Class Constructors Methods Properties See Also Send Feedback

The InstallAspNet type exposes the following members.

Constructors

Name | Description
InstallAspNet |

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides ToolTask..::.Execute()()().)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
IsValidPropertyCombinations | Determines if the current property values can be used together
LogEventsFromTextOutput | (Inherited from ToolTask.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | (Inherited from ToolTask.)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

Properties

Name | Description
ApplyScriptMaps | The method used to determine if ASP.NET script mappings should be applied
BuildEngine | (Inherited from Task.)
ClientScriptsOnly | When trueTruetruetrue (True in Visual Basic), the aspnet_client scripts will be installed. No script mappings will be updated.
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
Path | The web application that should have its script maps updated.
Recursive | When trueTruetruetrue (True in Visual Basic), script maps are applied recursively under Path.
ResponseFileEncoding | (Inherited from ToolTask.)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | (Inherited from ToolTask.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)
Version | The version of ASP.NET to install

See Also

InstallAspNet Class
MSBuild.Community.Tasks.AspNet Namespace


InstallAspNet Constructor

[image]

.NET Framework Class Library
InstallAspNet Constructor
InstallAspNet Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.AspNet
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public InstallAspNet()
Visual C++
public:
InstallAspNet()

See Also

InstallAspNet Class
MSBuild.Community.Tasks.AspNet Namespace


InstallAspNet Methods

[image] [image]

.NET Framework Class Library
InstallAspNet Methods
InstallAspNet Class See Also Send Feedback

The InstallAspNet type exposes the following members.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides ToolTask..::.Execute()()().)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
IsValidPropertyCombinations | Determines if the current property values can be used together
LogEventsFromTextOutput | (Inherited from ToolTask.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | (Inherited from ToolTask.)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

See Also

InstallAspNet Class
MSBuild.Community.Tasks.AspNet Namespace


Execute Method

[image]

.NET Framework Class Library
InstallAspNet..::.Execute Method
InstallAspNet Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.AspNet
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

True if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

InstallAspNet Class
MSBuild.Community.Tasks.AspNet Namespace


GenerateCommandLineCommands Method

[image]

.NET Framework Class Library
InstallAspNet..::.GenerateCommandLineCommands Method
InstallAspNet Class See Also Send Feedback

Returns a string value containing the command line arguments to pass directly to the executable file.

Namespace: MSBuild.Community.Tasks.AspNet
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateCommandLineCommands As String
C#
protected override string GenerateCommandLineCommands()
Visual C++
protected:
virtual String^ GenerateCommandLineCommands() override

Return Value

A string value containing the command line arguments to pass directly to the executable file.

See Also

InstallAspNet Class
MSBuild.Community.Tasks.AspNet Namespace


GenerateFullPathToTool Method

[image]

.NET Framework Class Library
InstallAspNet..::.GenerateFullPathToTool Method
InstallAspNet Class See Also Send Feedback

Returns the fully qualified path to the executable file.

Namespace: MSBuild.Community.Tasks.AspNet
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateFullPathToTool As String
C#
protected override string GenerateFullPathToTool()
Visual C++
protected:
virtual String^ GenerateFullPathToTool() override

Return Value

The fully qualified path to the executable file.

See Also

InstallAspNet Class
MSBuild.Community.Tasks.AspNet Namespace


IsValidPropertyCombinations Method

[image]

.NET Framework Class Library
InstallAspNet..::.IsValidPropertyCombinations Method
InstallAspNet Class See Also Send Feedback

Determines if the current property values can be used together

Namespace: MSBuild.Community.Tasks.AspNet
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Function IsValidPropertyCombinations As Boolean
C#
public bool IsValidPropertyCombinations()
Visual C++
public:
bool IsValidPropertyCombinations()

Return Value

trueTruetruetrue (True in Visual Basic) when properties can be used together.

See Also

InstallAspNet Class
MSBuild.Community.Tasks.AspNet Namespace


InstallAspNet Properties

[image] [image]

.NET Framework Class Library
InstallAspNet Properties
InstallAspNet Class See Also Send Feedback

The InstallAspNet type exposes the following members.

Properties

Name | Description
ApplyScriptMaps | The method used to determine if ASP.NET script mappings should be applied
BuildEngine | (Inherited from Task.)
ClientScriptsOnly | When trueTruetruetrue (True in Visual Basic), the aspnet_client scripts will be installed. No script mappings will be updated.
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
Path | The web application that should have its script maps updated.
Recursive | When trueTruetruetrue (True in Visual Basic), script maps are applied recursively under Path.
ResponseFileEncoding | (Inherited from ToolTask.)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | (Inherited from ToolTask.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)
Version | The version of ASP.NET to install

See Also

InstallAspNet Class
MSBuild.Community.Tasks.AspNet Namespace


ApplyScriptMaps Property

[image]

.NET Framework Class Library
InstallAspNet..::.ApplyScriptMaps Property
InstallAspNet Class See Also Send Feedback

The method used to determine if ASP.NET script mappings should be applied

Namespace: MSBuild.Community.Tasks.AspNet
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ApplyScriptMaps As String
C#
public string ApplyScriptMaps { get; set; }
Visual C++
public:
property String^ ApplyScriptMaps {
    String^ get ();
    void set (String^ value);
}

Remarks

The default behavior is to register script mappings on all sites except those with a newer version of ASP.NET.
Value
Never | Register ASP.NET on the computer without updating any script mappings.
IfNoneExist | Register script mappings only on for sites that do not have any existing ASP.NET script mappings (not available for ASP.NET v1.1)
UnlessNewerExist | Register script mappings on all sites except those with a newer version of ASP.NET.
Always | Register script mappings on all sites, even if they already have a newer version of ASP.NET.

See Also

InstallAspNet Class
MSBuild.Community.Tasks.AspNet Namespace


ClientScriptsOnly Property

[image]

.NET Framework Class Library
InstallAspNet..::.ClientScriptsOnly Property
InstallAspNet Class See Also Send Feedback

When trueTruetruetrue (True in Visual Basic), the aspnet_client scripts will be installed. No script mappings will be updated.

Namespace: MSBuild.Community.Tasks.AspNet
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ClientScriptsOnly As Boolean
C#
public bool ClientScriptsOnly { get; set; }
Visual C++
public:
property bool ClientScriptsOnly {
    bool get ();
    void set (bool value);
}

Remarks

This cannot be trueTruetruetrue (True in Visual Basic) if a value for Path or ApplyScriptMaps has been specified.

See Also

InstallAspNet Class
MSBuild.Community.Tasks.AspNet Namespace


Path Property

[image]

.NET Framework Class Library
InstallAspNet..::.Path Property
InstallAspNet Class See Also Send Feedback

The web application that should have its script maps updated.

Namespace: MSBuild.Community.Tasks.AspNet
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Path As String
C#
public string Path { get; set; }
Visual C++
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}

Remarks

The path must be of the form W3SVC/[instance]/Root/[webdirectory], for example W3SVC/1/Root/SampleApp1. As a shortcut, you can specify just the web directory name, if the web directory is installed in the default website instance (W3SVC/1/Root).

You should not specify a value for ApplyScriptMaps when specifying a path.

See Also

InstallAspNet Class
MSBuild.Community.Tasks.AspNet Namespace


Recursive Property

[image]

.NET Framework Class Library
InstallAspNet..::.Recursive Property
InstallAspNet Class See Also Send Feedback

When trueTruetruetrue (True in Visual Basic), script maps are applied recursively under Path.

Namespace: MSBuild.Community.Tasks.AspNet
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Recursive As Boolean
C#
public bool Recursive { get; set; }
Visual C++
public:
property bool Recursive {
    bool get ();
    void set (bool value);
}

Remarks

This property is only valid when specifying a value for Path. It is trueTruetruetrue (True in Visual Basic) by default.

See Also

InstallAspNet Class
MSBuild.Community.Tasks.AspNet Namespace


ToolName Property

[image]

.NET Framework Class Library
InstallAspNet..::.ToolName Property
InstallAspNet Class See Also Send Feedback

Gets the name of the executable file to run.

Namespace: MSBuild.Community.Tasks.AspNet
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ToolName As String
C#
protected override string ToolName { get; }
Visual C++
protected:
virtual property String^ ToolName {
    String^ get () override;
}

Field Value

Return Value

The name of the executable file to run.

See Also

InstallAspNet Class
MSBuild.Community.Tasks.AspNet Namespace


Version Property

[image]

.NET Framework Class Library
InstallAspNet..::.Version Property
InstallAspNet Class See Also Send Feedback

The version of ASP.NET to install

Namespace: MSBuild.Community.Tasks.AspNet
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Version As String
C#
public string Version { get; set; }
Visual C++
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}

Remarks

The default behavior is to use the latest version of ASP.NET available on the computer.
Version
Version11 | ASP.NET v1.1
Version20 | ASP.NET v2.0
VersionLatest | The latest version of ASP.NET available

See Also

InstallAspNet Class
MSBuild.Community.Tasks.AspNet Namespace


MSBuild.Community.Tasks.Ftp Namespace

[image]

.NET Framework Class Library
MSBuild.Community.Tasks.Ftp Namespace
Send Feedback

Classes

Class | Description
FtpClientTaskBase | Ftp client base class.
FtpCreateRemoteDirectory | Creates a full remote directory on the remote server if not exists using the File Transfer Protocol (FTP). This can be one directory or a full path to create.
FtpDirectoryExists | Determ if a remote directory exists on a FTP server or not.
FtpEntry | Represents an remote file or directory on a FTP server.
FtpException | Exception returned by FTP server.
FtpReply | Represenatation of a FTP reply message.
FtpUploadDirectoryContent | Uploads a full directory content to a remote directory.


FtpClientTaskBase Class

[image]

.NET Framework Class Library
FtpClientTaskBase Class
Members See Also Send Feedback

Ftp client base class.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class FtpClientTaskBase _
    Inherits Task
C#
public abstract class FtpClientTaskBase : Task
Visual C++
public ref class FtpClientTaskBase abstract : public Task

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.Ftp..::.FtpClientTaskBase
MSBuild.Community.Tasks.Ftp..::.FtpCreateRemoteDirectory
MSBuild.Community.Tasks.Ftp..::.FtpDirectoryExists
MSBuild.Community.Tasks.Ftp..::.FtpUploadDirectoryContent

See Also

FtpClientTaskBase Members
MSBuild.Community.Tasks.Ftp Namespace


FtpClientTaskBase Members

[image] [image]

.NET Framework Class Library
FtpClientTaskBase Members
FtpClientTaskBase Class Constructors Methods Properties See Also Send Feedback

The FtpClientTaskBase type exposes the following members.

Constructors

Name | Description
FtpClientTaskBase | Initializes a new instance of the FtpClientTaskBase class.

Methods

Name | Description
CdUp | Change to the parent of the current working directory.
ChangeWorkingDirectory | Changes the working directory.
Close | Closes the connection to the server.
Connect | Connects this FTP server socket.
CreateDataStreamAndSendCommand | Create a data stream and send a raw command.
DirectoryExists | Determs whether a remote directory exists.
Equals | (Inherited from Object.)
Execute | (Inherited from Task.)
FileExists | Determs whether a remote file exists.
Finalize | (Inherited from Object.)
GetDirectoryDetails | Overloaded.
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
GetWorkingDirectory | Gets the working directory.
Login | Login to the FTP server with the specified credentials.
MakeDirectory | Creates a remote directory in the current working folder.
MemberwiseClone | (Inherited from Object.)
ReadResponse | Reads the ftp response from the client socket.
RemoveDirectory | Removes a remote directory.
SendCommand | Overloaded.
SendCommandAndReadResponse | Overloaded.
Store | Stores the specified localFile.
ToString | (Inherited from Object.)

Properties

Name | Description
BufferSize | Gets or sets the size of the data buffer.
BuildEngine | (Inherited from Task.)
ClientSocket | Gets or sets the client socket.
Connected | Gets a value indicating whether this FtpClientTaskBase is connected.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
LastReply | Gets the last recieved FTP response over the client socket.
Log | (Inherited from Task.)
Password | Gets or sets the password to login.
Port | Gets or sets the port number.
ServerHost | Gets or sets the server host.
TaskResources | (Inherited from Task.)
Username | Gets or sets the username to login.

See Also

FtpClientTaskBase Class
MSBuild.Community.Tasks.Ftp Namespace


FtpClientTaskBase Constructor

[image]

.NET Framework Class Library
FtpClientTaskBase Constructor
FtpClientTaskBase Class See Also Send Feedback

Initializes a new instance of the FtpClientTaskBase class.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FtpClientTaskBase()
Visual C++
public:
FtpClientTaskBase()

See Also

FtpClientTaskBase Class
MSBuild.Community.Tasks.Ftp Namespace


FtpClientTaskBase Methods

[image] [image]

.NET Framework Class Library
FtpClientTaskBase Methods
FtpClientTaskBase Class See Also Send Feedback

The FtpClientTaskBase type exposes the following members.

Methods

Name | Description
CdUp | Change to the parent of the current working directory.
ChangeWorkingDirectory | Changes the working directory.
Close | Closes the connection to the server.
Connect | Connects this FTP server socket.
CreateDataStreamAndSendCommand | Create a data stream and send a raw command.
DirectoryExists | Determs whether a remote directory exists.
Equals | (Inherited from Object.)
Execute | (Inherited from Task.)
FileExists | Determs whether a remote file exists.
Finalize | (Inherited from Object.)
GetDirectoryDetails | Overloaded.
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
GetWorkingDirectory | Gets the working directory.
Login | Login to the FTP server with the specified credentials.
MakeDirectory | Creates a remote directory in the current working folder.
MemberwiseClone | (Inherited from Object.)
ReadResponse | Reads the ftp response from the client socket.
RemoveDirectory | Removes a remote directory.
SendCommand | Overloaded.
SendCommandAndReadResponse | Overloaded.
Store | Stores the specified localFile.
ToString | (Inherited from Object.)

See Also

FtpClientTaskBase Class
MSBuild.Community.Tasks.Ftp Namespace


CdUp Method

[image]

.NET Framework Class Library
FtpClientTaskBase..::.CdUp Method
FtpClientTaskBase Class See Also Send Feedback

Change to the parent of the current working directory.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub CdUp
C#
public void CdUp()
Visual C++
public:
void CdUp()

Remarks

Sends the CDUP command.

Exceptions

Exception | Condition
MSBuild.Community.Tasks.Ftp..::.FtpException | Occurs if there where connection problems during the process or the FTP server doesn't support the CDUP command. See the Message of the exception for details.

See Also

FtpClientTaskBase Class
MSBuild.Community.Tasks.Ftp Namespace


ChangeWorkingDirectory Method

[image]

.NET Framework Class Library
FtpClientTaskBase..::.ChangeWorkingDirectory Method
FtpClientTaskBase Class See Also Send Feedback

Changes the working directory.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub ChangeWorkingDirectory ( _
    remoteDirectory As String _
)
C#
public void ChangeWorkingDirectory(
    string remoteDirectory
)
Visual C++
public:
void ChangeWorkingDirectory(
    String^ remoteDirectory
)

Parameters

remoteDirectory
Type: System..::.String
The remote directory.

Remarks

Sends the CWD command.

Exceptions

Exception | Condition
MSBuild.Community.Tasks.Ftp..::.FtpException | Occurs if there where connection problems during the process or the FTP server doesn't support the CWD command. See the Message of the exception for details.

See Also

FtpClientTaskBase Class
MSBuild.Community.Tasks.Ftp Namespace


Close Method

[image]

.NET Framework Class Library
FtpClientTaskBase..::.Close Method
FtpClientTaskBase Class See Also Send Feedback

Closes the connection to the server.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub Close
C#
public void Close()
Visual C++
public:
void Close()

See Also

FtpClientTaskBase Class
MSBuild.Community.Tasks.Ftp Namespace


Connect Method

[image]

.NET Framework Class Library
FtpClientTaskBase..::.Connect Method
FtpClientTaskBase Class See Also Send Feedback

Connects this FTP server socket.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub Connect
C#
public void Connect()
Visual C++
public:
void Connect()

Exceptions

Exception | Condition
MSBuild.Community.Tasks.Ftp..::.FtpException | Thrown when unable to connect.

See Also

FtpClientTaskBase Class
MSBuild.Community.Tasks.Ftp Namespace


CreateDataStreamAndSendCommand Method

[image]

.NET Framework Class Library
FtpClientTaskBase..::.CreateDataStreamAndSendCommand Method
FtpClientTaskBase Class See Also Send Feedback

Create a data stream and send a raw command.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateDataStreamAndSendCommand ( _
    rawCommand As String _
) As Stream
C#
public Stream CreateDataStreamAndSendCommand(
    string rawCommand
)
Visual C++
public:
Stream^ CreateDataStreamAndSendCommand(
    String^ rawCommand
)

Parameters

rawCommand
Type: System..::.String
The raw command to send.

Return Value

The data stream that was created.

See Also

FtpClientTaskBase Class
MSBuild.Community.Tasks.Ftp Namespace


DirectoryExists Method

[image]

.NET Framework Class Library
FtpClientTaskBase..::.DirectoryExists Method
FtpClientTaskBase Class See Also Send Feedback

Determs whether a remote directory exists.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Function DirectoryExists ( _
    remoteDirectory As String _
) As Boolean
C#
public bool DirectoryExists(
    string remoteDirectory
)
Visual C++
public:
bool DirectoryExists(
    String^ remoteDirectory
)

Parameters

remoteDirectory
Type: System..::.String
The remote directory.

Return Value

true if the directory exists remotely; otherwise false

Remarks

This method is based on the succeedness of a CWD command, this can give wrong indication at a rare number of FTP server!

Exceptions

Exception | Condition
MSBuild.Community.Tasks.Ftp..::.FtpException | Thrown if the opperation couldn't be executed.

See Also

FtpClientTaskBase Class
MSBuild.Community.Tasks.Ftp Namespace


FileExists Method

[image]

.NET Framework Class Library
FtpClientTaskBase..::.FileExists Method
FtpClientTaskBase Class See Also Send Feedback

Determs whether a remote file exists.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Function FileExists ( _
    remoteFile As String _
) As Boolean
C#
public bool FileExists(
    string remoteFile
)
Visual C++
public:
bool FileExists(
    String^ remoteFile
)

Parameters

remoteFile
Type: System..::.String
The remote file.

Return Value

Exceptions

Exception | Condition
MSBuild.Community.Tasks.Ftp..::.FtpException | Occurs if there where connection problems during the operation or if the FTP server doesn't support the SIZE command. See the Message of the exception for details.

See Also

FtpClientTaskBase Class
MSBuild.Community.Tasks.Ftp Namespace


GetDirectoryDetails Method

[image] [image]

.NET Framework Class Library
FtpClientTaskBase..::.GetDirectoryDetails Method
FtpClientTaskBase Class See Also Send Feedback

Overload List

Name | Description
GetDirectoryDetails()()() | Get the full directory details of the current directory.
GetDirectoryDetails(String) | Get the full directory details of the current directory.

See Also

FtpClientTaskBase Class
FtpClientTaskBase Members
MSBuild.Community.Tasks.Ftp Namespace


GetDirectoryDetails Method

[image]

.NET Framework Class Library
FtpClientTaskBase..::.GetDirectoryDetails Method
FtpClientTaskBase Class See Also Send Feedback

Get the full directory details of the current directory.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDirectoryDetails As FtpEntry()
C#
public FtpEntry[] GetDirectoryDetails()
Visual C++
public:
array<FtpEntry^>^ GetDirectoryDetails()

Return Value

A array that contains all the FTP files located in the currenct directory.

See Also

FtpClientTaskBase Class
GetDirectoryDetails Overload
MSBuild.Community.Tasks.Ftp Namespace


GetDirectoryDetails Method (String)

[image]

.NET Framework Class Library
FtpClientTaskBase..::.GetDirectoryDetails Method (String)
FtpClientTaskBase Class See Also Send Feedback

Get the full directory details of the current directory.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDirectoryDetails ( _
    remoteDirectory As String _
) As FtpEntry()
C#
public FtpEntry[] GetDirectoryDetails(
    string remoteDirectory
)
Visual C++
public:
array<FtpEntry^>^ GetDirectoryDetails(
    String^ remoteDirectory
)

Parameters

remoteDirectory
Type: System..::.String
The remove directory, emtpy or null will get the details of the current directory.

Return Value

A array that contains all the FTP files located in the currenct directory.

See Also

FtpClientTaskBase Class
GetDirectoryDetails Overload
MSBuild.Community.Tasks.Ftp Namespace


GetWorkingDirectory Method

[image]

.NET Framework Class Library
FtpClientTaskBase..::.GetWorkingDirectory Method
FtpClientTaskBase Class See Also Send Feedback

Gets the working directory.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Function GetWorkingDirectory As String
C#
public string GetWorkingDirectory()
Visual C++
public:
String^ GetWorkingDirectory()

Return Value

The current working directory.

See Also

FtpClientTaskBase Class
MSBuild.Community.Tasks.Ftp Namespace


Login Method

[image]

.NET Framework Class Library
FtpClientTaskBase..::.Login Method
FtpClientTaskBase Class See Also Send Feedback

Login to the FTP server with the specified credentials.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub Login
C#
public void Login()
Visual C++
public:
void Login()

See Also

FtpClientTaskBase Class
MSBuild.Community.Tasks.Ftp Namespace


MakeDirectory Method

[image]

.NET Framework Class Library
FtpClientTaskBase..::.MakeDirectory Method
FtpClientTaskBase Class See Also Send Feedback

Creates a remote directory in the current working folder.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub MakeDirectory ( _
    directoryName As String _
)
C#
public void MakeDirectory(
    string directoryName
)
Visual C++
public:
void MakeDirectory(
    String^ directoryName
)

Parameters

directoryName
Type: System..::.String
Name of the directory.

Exceptions

Exception | Condition
MSBuild.Community.Tasks.Ftp..::.FtpException | Occurs if there where connection problems during the process or the FTP server doesn't support the MMD command. See the Message of the exception for details.

See Also

FtpClientTaskBase Class
MSBuild.Community.Tasks.Ftp Namespace


ReadResponse Method

[image]

.NET Framework Class Library
FtpClientTaskBase..::.ReadResponse Method
FtpClientTaskBase Class See Also Send Feedback

Reads the ftp response from the client socket.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Function ReadResponse As FtpReply
C#
protected FtpReply ReadResponse()
Visual C++
protected:
FtpReply^ ReadResponse()

Return Value

The response of the FTP server.

See Also

FtpClientTaskBase Class
MSBuild.Community.Tasks.Ftp Namespace


RemoveDirectory Method

[image]

.NET Framework Class Library
FtpClientTaskBase..::.RemoveDirectory Method
FtpClientTaskBase Class See Also Send Feedback

Removes a remote directory.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub RemoveDirectory ( _
    directoryName As String _
)
C#
public void RemoveDirectory(
    string directoryName
)
Visual C++
public:
void RemoveDirectory(
    String^ directoryName
)

Parameters

directoryName
Type: System..::.String
The remote directory name.

Remarks

Sends the RMD command.

Exceptions

Exception | Condition
MSBuild.Community.Tasks.Ftp..::.FtpException | Occurs if there where connection problems during the process or the FTP server doesn't support the RMD command. See the Message of the exception for details.

See Also

FtpClientTaskBase Class
MSBuild.Community.Tasks.Ftp Namespace


SendCommand Method

[image] [image]

.NET Framework Class Library
FtpClientTaskBase..::.SendCommand Method
FtpClientTaskBase Class See Also Send Feedback

Overload List

Name | Description
SendCommand(String) | Send a command to the FTP server.
SendCommand(String, String) | Send a command to the FTP server.

See Also

FtpClientTaskBase Class
FtpClientTaskBase Members
MSBuild.Community.Tasks.Ftp Namespace


SendCommand Method (String)

[image]

.NET Framework Class Library
FtpClientTaskBase..::.SendCommand Method (String)
FtpClientTaskBase Class See Also Send Feedback

Send a command to the FTP server.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Sub SendCommand ( _
    rawCommand As String _
)
C#
protected void SendCommand(
    string rawCommand
)
Visual C++
protected:
void SendCommand(
    String^ rawCommand
)

Parameters

rawCommand
Type: System..::.String
The full command to send.

See Also

FtpClientTaskBase Class
SendCommand Overload
MSBuild.Community.Tasks.Ftp Namespace


SendCommand Method (String, String)

[image]

.NET Framework Class Library
FtpClientTaskBase..::.SendCommand Method (String, String)
FtpClientTaskBase Class See Also Send Feedback

Send a command to the FTP server.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Sub SendCommand ( _
    command As String, _
    value As String _
)
C#
protected void SendCommand(
    string command,
    string value
)
Visual C++
protected:
void SendCommand(
    String^ command,
    String^ value
)

Parameters

command
Type: System..::.String
The command, for example PWD.
value
Type: System..::.String
The value.

See Also

FtpClientTaskBase Class
SendCommand Overload
MSBuild.Community.Tasks.Ftp Namespace


SendCommandAndReadResponse Method

[image] [image]

.NET Framework Class Library
FtpClientTaskBase..::.SendCommandAndReadResponse Method
FtpClientTaskBase Class See Also Send Feedback

Overload List

Name | Description
SendCommandAndReadResponse(String) | Send a command to the FTP server and returns the response.
SendCommandAndReadResponse(String, String) | Send a command to the FTP server and returns the response.

See Also

FtpClientTaskBase Class
FtpClientTaskBase Members
MSBuild.Community.Tasks.Ftp Namespace


SendCommandAndReadResponse Method (String)

[image]

.NET Framework Class Library
FtpClientTaskBase..::.SendCommandAndReadResponse Method (String)
FtpClientTaskBase Class See Also Send Feedback

Send a command to the FTP server and returns the response.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Function SendCommandAndReadResponse ( _
    rawCommand As String _
) As FtpReply
C#
protected FtpReply SendCommandAndReadResponse(
    string rawCommand
)
Visual C++
protected:
FtpReply^ SendCommandAndReadResponse(
    String^ rawCommand
)

Parameters

rawCommand
Type: System..::.String
The raw command to send.

Return Value

The reply of the FTP server for this command.

See Also

FtpClientTaskBase Class
SendCommandAndReadResponse Overload
MSBuild.Community.Tasks.Ftp Namespace


SendCommandAndReadResponse Method (String, String)

[image]

.NET Framework Class Library
FtpClientTaskBase..::.SendCommandAndReadResponse Method (String, String)
FtpClientTaskBase Class See Also Send Feedback

Send a command to the FTP server and returns the response.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Function SendCommandAndReadResponse ( _
    command As String, _
    value As String _
) As FtpReply
C#
protected FtpReply SendCommandAndReadResponse(
    string command,
    string value
)
Visual C++
protected:
FtpReply^ SendCommandAndReadResponse(
    String^ command,
    String^ value
)

Parameters

command
Type: System..::.String
The command, for example PWD.
value
Type: System..::.String
The value

Return Value

The reply of the FTP server for this command.

See Also

FtpClientTaskBase Class
SendCommandAndReadResponse Overload
MSBuild.Community.Tasks.Ftp Namespace


Store Method

[image]

.NET Framework Class Library
FtpClientTaskBase..::.Store Method
FtpClientTaskBase Class See Also Send Feedback

Stores the specified localFile.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub Store ( _
    localFile As String, _
    remoteFileName As String _
)
C#
public void Store(
    string localFile,
    string remoteFileName
)
Visual C++
public:
void Store(
    String^ localFile,
    String^ remoteFileName
)

Parameters

localFile
Type: System..::.String
The localfile.
remoteFileName
Type: System..::.String
The remotefile.

See Also

FtpClientTaskBase Class
MSBuild.Community.Tasks.Ftp Namespace


FtpClientTaskBase Properties

[image] [image]

.NET Framework Class Library
FtpClientTaskBase Properties
FtpClientTaskBase Class See Also Send Feedback

The FtpClientTaskBase type exposes the following members.

Properties

Name | Description
BufferSize | Gets or sets the size of the data buffer.
BuildEngine | (Inherited from Task.)
ClientSocket | Gets or sets the client socket.
Connected | Gets a value indicating whether this FtpClientTaskBase is connected.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
LastReply | Gets the last recieved FTP response over the client socket.
Log | (Inherited from Task.)
Password | Gets or sets the password to login.
Port | Gets or sets the port number.
ServerHost | Gets or sets the server host.
TaskResources | (Inherited from Task.)
Username | Gets or sets the username to login.

See Also

FtpClientTaskBase Class
MSBuild.Community.Tasks.Ftp Namespace


BufferSize Property

[image]

.NET Framework Class Library
FtpClientTaskBase..::.BufferSize Property
FtpClientTaskBase Class See Also Send Feedback

Gets or sets the size of the data buffer.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property BufferSize As Integer
C#
public int BufferSize { get; set; }
Visual C++
public:
property int BufferSize {
    int get ();
    void set (int value);
}

See Also

FtpClientTaskBase Class
MSBuild.Community.Tasks.Ftp Namespace


ClientSocket Property

[image]

.NET Framework Class Library
FtpClientTaskBase..::.ClientSocket Property
FtpClientTaskBase Class See Also Send Feedback

Gets or sets the client socket.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property ClientSocket As Socket
C#
protected Socket ClientSocket { get; }
Visual C++
protected:
property Socket^ ClientSocket {
    Socket^ get ();
}

Field Value

The client socket.

See Also

FtpClientTaskBase Class
MSBuild.Community.Tasks.Ftp Namespace


Connected Property

[image]

.NET Framework Class Library
FtpClientTaskBase..::.Connected Property
FtpClientTaskBase Class See Also Send Feedback

Gets a value indicating whether this FtpClientTaskBase is connected.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Connected As Boolean
C#
protected bool Connected { get; }
Visual C++
protected:
property bool Connected {
    bool get ();
}

Field Value

true if connected; otherwise, false.

See Also

FtpClientTaskBase Class
MSBuild.Community.Tasks.Ftp Namespace


LastReply Property

[image]

.NET Framework Class Library
FtpClientTaskBase..::.LastReply Property
FtpClientTaskBase Class See Also Send Feedback

Gets the last recieved FTP response over the client socket.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property LastReply As FtpReply
C#
public FtpReply LastReply { get; set; }
Visual C++
public:
property FtpReply^ LastReply {
    FtpReply^ get ();
    void set (FtpReply^ value);
}

Field Value

The last recieved FTP response over the client socket.

See Also

FtpClientTaskBase Class
MSBuild.Community.Tasks.Ftp Namespace


Password Property

[image]

.NET Framework Class Library
FtpClientTaskBase..::.Password Property
FtpClientTaskBase Class See Also Send Feedback

Gets or sets the password to login.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password { get; set; }
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

Field Value

The password.

See Also

FtpClientTaskBase Class
MSBuild.Community.Tasks.Ftp Namespace


Port Property

[image]

.NET Framework Class Library
FtpClientTaskBase..::.Port Property
FtpClientTaskBase Class See Also Send Feedback

Gets or sets the port number.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Port As Integer
C#
public int Port { get; set; }
Visual C++
public:
property int Port {
    int get ();
    void set (int value);
}

Field Value

The port numer.

See Also

FtpClientTaskBase Class
MSBuild.Community.Tasks.Ftp Namespace


ServerHost Property

[image]

.NET Framework Class Library
FtpClientTaskBase..::.ServerHost Property
FtpClientTaskBase Class See Also Send Feedback

Gets or sets the server host.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property ServerHost As String
C#
[RequiredAttribute]
public string ServerHost { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ ServerHost {
    String^ get ();
    void set (String^ value);
}

Field Value

The server host.

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The lenght of the given value is greater then 126 characters.

See Also

FtpClientTaskBase Class
MSBuild.Community.Tasks.Ftp Namespace


Username Property

[image]

.NET Framework Class Library
FtpClientTaskBase..::.Username Property
FtpClientTaskBase Class See Also Send Feedback

Gets or sets the username to login.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Username As String
C#
public string Username { get; set; }
Visual C++
public:
property String^ Username {
    String^ get ();
    void set (String^ value);
}

Field Value

The username.

See Also

FtpClientTaskBase Class
MSBuild.Community.Tasks.Ftp Namespace


FtpCreateRemoteDirectory Class

[image]

.NET Framework Class Library
FtpCreateRemoteDirectory Class
Members Example See Also Send Feedback

Creates a full remote directory on the remote server if not exists using the File Transfer Protocol (FTP). This can be one directory or a full path to create.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class FtpCreateRemoteDirectory _
    Inherits FtpClientTaskBase
C#
public class FtpCreateRemoteDirectory : FtpClientTaskBase
Visual C++
public ref class FtpCreateRemoteDirectory : public FtpClientTaskBase

Remarks

The full remote directory path will be created. All directories that doesn't exists on the remote server will be created.

Examples

Create remote directory:
Copy Code
            <FtpCreateRemoteDirectoty
                ServerHost="ftp.myserver.com"
                Port="42"
                RemoteDirectory="Directory\Subdirectory\MyOtherSubdirectory"
                Username="user"
                Password="p@ssw0rd"
            />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.Ftp..::.FtpClientTaskBase
MSBuild.Community.Tasks.Ftp..::.FtpCreateRemoteDirectory

See Also

FtpCreateRemoteDirectory Members
MSBuild.Community.Tasks.Ftp Namespace


FtpCreateRemoteDirectory Members

[image] [image]

.NET Framework Class Library
FtpCreateRemoteDirectory Members
FtpCreateRemoteDirectory Class Constructors Methods Properties See Also Send Feedback

The FtpCreateRemoteDirectory type exposes the following members.

Constructors

Name | Description
FtpCreateRemoteDirectory |

Methods

Name | Description
CdUp | Change to the parent of the current working directory. (Inherited from FtpClientTaskBase.)
ChangeWorkingDirectory | Changes the working directory. (Inherited from FtpClientTaskBase.)
Close | Closes the connection to the server. (Inherited from FtpClientTaskBase.)
Connect | Connects this FTP server socket. (Inherited from FtpClientTaskBase.)
CreateDataStreamAndSendCommand | Create a data stream and send a raw command. (Inherited from FtpClientTaskBase.)
DirectoryExists | Determs whether a remote directory exists. (Inherited from FtpClientTaskBase.)
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
FileExists | Determs whether a remote file exists. (Inherited from FtpClientTaskBase.)
Finalize | (Inherited from Object.)
GetDirectoryDetails | Overloaded.
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
GetWorkingDirectory | Gets the working directory. (Inherited from FtpClientTaskBase.)
Login | Login to the FTP server with the specified credentials. (Inherited from FtpClientTaskBase.)
MakeDirectory | Creates a remote directory in the current working folder. (Inherited from FtpClientTaskBase.)
MemberwiseClone | (Inherited from Object.)
ReadResponse | Reads the ftp response from the client socket. (Inherited from FtpClientTaskBase.)
RemoveDirectory | Removes a remote directory. (Inherited from FtpClientTaskBase.)
SendCommand | Overloaded.
SendCommandAndReadResponse | Overloaded.
Store | Stores the specified localFile. (Inherited from FtpClientTaskBase.)
ToString | (Inherited from Object.)

Properties

Name | Description
BufferSize | Gets or sets the size of the data buffer. (Inherited from FtpClientTaskBase.)
BuildEngine | (Inherited from Task.)
ClientSocket | Gets or sets the client socket. (Inherited from FtpClientTaskBase.)
Connected | Gets a value indicating whether this FtpClientTaskBase is connected. (Inherited from FtpClientTaskBase.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
LastReply | Gets the last recieved FTP response over the client socket. (Inherited from FtpClientTaskBase.)
Log | (Inherited from Task.)
Password | Gets or sets the password to login. (Inherited from FtpClientTaskBase.)
Port | Gets or sets the port number. (Inherited from FtpClientTaskBase.)
RemoteDirectory | Gets or sets the remote directory to create.
ServerHost | Gets or sets the server host. (Inherited from FtpClientTaskBase.)
TaskResources | (Inherited from Task.)
Username | Gets or sets the username to login. (Inherited from FtpClientTaskBase.)

See Also

FtpCreateRemoteDirectory Class
MSBuild.Community.Tasks.Ftp Namespace


FtpCreateRemoteDirectory Constructor

[image]

.NET Framework Class Library
FtpCreateRemoteDirectory Constructor
FtpCreateRemoteDirectory Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FtpCreateRemoteDirectory()
Visual C++
public:
FtpCreateRemoteDirectory()

See Also

FtpCreateRemoteDirectory Class
MSBuild.Community.Tasks.Ftp Namespace


FtpCreateRemoteDirectory Methods

[image] [image]

.NET Framework Class Library
FtpCreateRemoteDirectory Methods
FtpCreateRemoteDirectory Class See Also Send Feedback

The FtpCreateRemoteDirectory type exposes the following members.

Methods

Name | Description
CdUp | Change to the parent of the current working directory. (Inherited from FtpClientTaskBase.)
ChangeWorkingDirectory | Changes the working directory. (Inherited from FtpClientTaskBase.)
Close | Closes the connection to the server. (Inherited from FtpClientTaskBase.)
Connect | Connects this FTP server socket. (Inherited from FtpClientTaskBase.)
CreateDataStreamAndSendCommand | Create a data stream and send a raw command. (Inherited from FtpClientTaskBase.)
DirectoryExists | Determs whether a remote directory exists. (Inherited from FtpClientTaskBase.)
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
FileExists | Determs whether a remote file exists. (Inherited from FtpClientTaskBase.)
Finalize | (Inherited from Object.)
GetDirectoryDetails | Overloaded.
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
GetWorkingDirectory | Gets the working directory. (Inherited from FtpClientTaskBase.)
Login | Login to the FTP server with the specified credentials. (Inherited from FtpClientTaskBase.)
MakeDirectory | Creates a remote directory in the current working folder. (Inherited from FtpClientTaskBase.)
MemberwiseClone | (Inherited from Object.)
ReadResponse | Reads the ftp response from the client socket. (Inherited from FtpClientTaskBase.)
RemoveDirectory | Removes a remote directory. (Inherited from FtpClientTaskBase.)
SendCommand | Overloaded.
SendCommandAndReadResponse | Overloaded.
Store | Stores the specified localFile. (Inherited from FtpClientTaskBase.)
ToString | (Inherited from Object.)

See Also

FtpCreateRemoteDirectory Class
MSBuild.Community.Tasks.Ftp Namespace


Execute Method

[image]

.NET Framework Class Library
FtpCreateRemoteDirectory..::.Execute Method
FtpCreateRemoteDirectory Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

FtpCreateRemoteDirectory Class
MSBuild.Community.Tasks.Ftp Namespace


GetDirectoryDetails Method

[image] [image]

.NET Framework Class Library
FtpCreateRemoteDirectory..::.GetDirectoryDetails Method
FtpCreateRemoteDirectory Class See Also Send Feedback

Overload List

Name | Description
GetDirectoryDetails()()() | Get the full directory details of the current directory. (Inherited from FtpClientTaskBase.)
GetDirectoryDetails(String) | Get the full directory details of the current directory. (Inherited from FtpClientTaskBase.)

See Also

FtpCreateRemoteDirectory Class
FtpCreateRemoteDirectory Members
MSBuild.Community.Tasks.Ftp Namespace


SendCommand Method

[image] [image]

.NET Framework Class Library
FtpCreateRemoteDirectory..::.SendCommand Method
FtpCreateRemoteDirectory Class See Also Send Feedback

Overload List

Name | Description
SendCommand(String) | Send a command to the FTP server. (Inherited from FtpClientTaskBase.)
SendCommand(String, String) | Send a command to the FTP server. (Inherited from FtpClientTaskBase.)

See Also

FtpCreateRemoteDirectory Class
FtpCreateRemoteDirectory Members
MSBuild.Community.Tasks.Ftp Namespace


SendCommandAndReadResponse Method

[image] [image]

.NET Framework Class Library
FtpCreateRemoteDirectory..::.SendCommandAndReadResponse Method
FtpCreateRemoteDirectory Class See Also Send Feedback

Overload List

Name | Description
SendCommandAndReadResponse(String) | Send a command to the FTP server and returns the response. (Inherited from FtpClientTaskBase.)
SendCommandAndReadResponse(String, String) | Send a command to the FTP server and returns the response. (Inherited from FtpClientTaskBase.)

See Also

FtpCreateRemoteDirectory Class
FtpCreateRemoteDirectory Members
MSBuild.Community.Tasks.Ftp Namespace


FtpCreateRemoteDirectory Properties

[image] [image]

.NET Framework Class Library
FtpCreateRemoteDirectory Properties
FtpCreateRemoteDirectory Class See Also Send Feedback

The FtpCreateRemoteDirectory type exposes the following members.

Properties

Name | Description
BufferSize | Gets or sets the size of the data buffer. (Inherited from FtpClientTaskBase.)
BuildEngine | (Inherited from Task.)
ClientSocket | Gets or sets the client socket. (Inherited from FtpClientTaskBase.)
Connected | Gets a value indicating whether this FtpClientTaskBase is connected. (Inherited from FtpClientTaskBase.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
LastReply | Gets the last recieved FTP response over the client socket. (Inherited from FtpClientTaskBase.)
Log | (Inherited from Task.)
Password | Gets or sets the password to login. (Inherited from FtpClientTaskBase.)
Port | Gets or sets the port number. (Inherited from FtpClientTaskBase.)
RemoteDirectory | Gets or sets the remote directory to create.
ServerHost | Gets or sets the server host. (Inherited from FtpClientTaskBase.)
TaskResources | (Inherited from Task.)
Username | Gets or sets the username to login. (Inherited from FtpClientTaskBase.)

See Also

FtpCreateRemoteDirectory Class
MSBuild.Community.Tasks.Ftp Namespace


RemoteDirectory Property

[image]

.NET Framework Class Library
FtpCreateRemoteDirectory..::.RemoteDirectory Property
FtpCreateRemoteDirectory Class Example See Also Send Feedback

Gets or sets the remote directory to create.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property RemoteDirectory As String
C#
[RequiredAttribute]
public string RemoteDirectory { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ RemoteDirectory {
    String^ get ();
    void set (String^ value);
}

Field Value

The remote directory.

Examples

This can be one directory name, like "Directory", or a directory path, like "Directory\Subdirectoy".

See Also

FtpCreateRemoteDirectory Class
MSBuild.Community.Tasks.Ftp Namespace


FtpDirectoryExists Class

[image]

.NET Framework Class Library
FtpDirectoryExists Class
Members Example See Also Send Feedback

Determ if a remote directory exists on a FTP server or not.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class FtpDirectoryExists _
    Inherits FtpClientTaskBase
C#
public class FtpDirectoryExists : FtpClientTaskBase
Visual C++
public ref class FtpDirectoryExists : public FtpClientTaskBase

Remarks

The full remote directory path will be created. All directories that doesn't exists on the remote server will be created.

Examples

Determ of Directory\1 exists:
Copy Code
            <Target Name="CheckIfDirectoryExists">
                <FtpDirectoryExists
                    ServerHost="ftp.myserver.com"
                    Port="42"
                    RemoteDirectory="1\2\3"
                    Username="user"
                    Password="p@ssw0rd"
                >
                    <Output TaskParameter="Exists" PropertyName="Exists" />
                </FtpDirectoryExists>
                <Message Text="Directory '1\2\3' exists: $(Exists)"/>
If the directory exists on the server you should see the following output in the console: Directory '1\2\3' exists: true

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.Ftp..::.FtpClientTaskBase
MSBuild.Community.Tasks.Ftp..::.FtpDirectoryExists

See Also

FtpDirectoryExists Members
MSBuild.Community.Tasks.Ftp Namespace


FtpDirectoryExists Members

[image] [image]

.NET Framework Class Library
FtpDirectoryExists Members
FtpDirectoryExists Class Constructors Methods Properties See Also Send Feedback

The FtpDirectoryExists type exposes the following members.

Constructors

Name | Description
FtpDirectoryExists |

Methods

Name | Description
CdUp | Change to the parent of the current working directory. (Inherited from FtpClientTaskBase.)
ChangeWorkingDirectory | Changes the working directory. (Inherited from FtpClientTaskBase.)
Close | Closes the connection to the server. (Inherited from FtpClientTaskBase.)
Connect | Connects this FTP server socket. (Inherited from FtpClientTaskBase.)
CreateDataStreamAndSendCommand | Create a data stream and send a raw command. (Inherited from FtpClientTaskBase.)
DirectoryExists | Determs whether a remote directory exists. (Inherited from FtpClientTaskBase.)
Equals | (Inherited from Object.)
Execute | Executes the current task. (Overrides Task..::.Execute()()().)
FileExists | Determs whether a remote file exists. (Inherited from FtpClientTaskBase.)
Finalize | (Inherited from Object.)
GetDirectoryDetails | Overloaded.
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
GetWorkingDirectory | Gets the working directory. (Inherited from FtpClientTaskBase.)
Login | Login to the FTP server with the specified credentials. (Inherited from FtpClientTaskBase.)
MakeDirectory | Creates a remote directory in the current working folder. (Inherited from FtpClientTaskBase.)
MemberwiseClone | (Inherited from Object.)
ReadResponse | Reads the ftp response from the client socket. (Inherited from FtpClientTaskBase.)
RemoveDirectory | Removes a remote directory. (Inherited from FtpClientTaskBase.)
SendCommand | Overloaded.
SendCommandAndReadResponse | Overloaded.
Store | Stores the specified localFile. (Inherited from FtpClientTaskBase.)
ToString | (Inherited from Object.)

Properties

Name | Description
BufferSize | Gets or sets the size of the data buffer. (Inherited from FtpClientTaskBase.)
BuildEngine | (Inherited from Task.)
ClientSocket | Gets or sets the client socket. (Inherited from FtpClientTaskBase.)
Connected | Gets a value indicating whether this FtpClientTaskBase is connected. (Inherited from FtpClientTaskBase.)
Exists | Gets an indication whether the directory exists on the server.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
LastReply | Gets the last recieved FTP response over the client socket. (Inherited from FtpClientTaskBase.)
Log | (Inherited from Task.)
Password | Gets or sets the password to login. (Inherited from FtpClientTaskBase.)
Port | Gets or sets the port number. (Inherited from FtpClientTaskBase.)
RemoteDirectory | Gets or sets the remote directory to create.
ServerHost | Gets or sets the server host. (Inherited from FtpClientTaskBase.)
TaskResources | (Inherited from Task.)
Username | Gets or sets the username to login. (Inherited from FtpClientTaskBase.)

See Also

FtpDirectoryExists Class
MSBuild.Community.Tasks.Ftp Namespace


FtpDirectoryExists Constructor

[image]

.NET Framework Class Library
FtpDirectoryExists Constructor
FtpDirectoryExists Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FtpDirectoryExists()
Visual C++
public:
FtpDirectoryExists()

See Also

FtpDirectoryExists Class
MSBuild.Community.Tasks.Ftp Namespace


FtpDirectoryExists Methods

[image] [image]

.NET Framework Class Library
FtpDirectoryExists Methods
FtpDirectoryExists Class See Also Send Feedback

The FtpDirectoryExists type exposes the following members.

Methods

Name | Description
CdUp | Change to the parent of the current working directory. (Inherited from FtpClientTaskBase.)
ChangeWorkingDirectory | Changes the working directory. (Inherited from FtpClientTaskBase.)
Close | Closes the connection to the server. (Inherited from FtpClientTaskBase.)
Connect | Connects this FTP server socket. (Inherited from FtpClientTaskBase.)
CreateDataStreamAndSendCommand | Create a data stream and send a raw command. (Inherited from FtpClientTaskBase.)
DirectoryExists | Determs whether a remote directory exists. (Inherited from FtpClientTaskBase.)
Equals | (Inherited from Object.)
Execute | Executes the current task. (Overrides Task..::.Execute()()().)
FileExists | Determs whether a remote file exists. (Inherited from FtpClientTaskBase.)
Finalize | (Inherited from Object.)
GetDirectoryDetails | Overloaded.
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
GetWorkingDirectory | Gets the working directory. (Inherited from FtpClientTaskBase.)
Login | Login to the FTP server with the specified credentials. (Inherited from FtpClientTaskBase.)
MakeDirectory | Creates a remote directory in the current working folder. (Inherited from FtpClientTaskBase.)
MemberwiseClone | (Inherited from Object.)
ReadResponse | Reads the ftp response from the client socket. (Inherited from FtpClientTaskBase.)
RemoveDirectory | Removes a remote directory. (Inherited from FtpClientTaskBase.)
SendCommand | Overloaded.
SendCommandAndReadResponse | Overloaded.
Store | Stores the specified localFile. (Inherited from FtpClientTaskBase.)
ToString | (Inherited from Object.)

See Also

FtpDirectoryExists Class
MSBuild.Community.Tasks.Ftp Namespace


Execute Method

[image]

.NET Framework Class Library
FtpDirectoryExists..::.Execute Method
FtpDirectoryExists Class See Also Send Feedback

Executes the current task.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

FtpDirectoryExists Class
MSBuild.Community.Tasks.Ftp Namespace


GetDirectoryDetails Method

[image] [image]

.NET Framework Class Library
FtpDirectoryExists..::.GetDirectoryDetails Method
FtpDirectoryExists Class See Also Send Feedback

Overload List

Name | Description
GetDirectoryDetails()()() | Get the full directory details of the current directory. (Inherited from FtpClientTaskBase.)
GetDirectoryDetails(String) | Get the full directory details of the current directory. (Inherited from FtpClientTaskBase.)

See Also

FtpDirectoryExists Class
FtpDirectoryExists Members
MSBuild.Community.Tasks.Ftp Namespace


SendCommand Method

[image] [image]

.NET Framework Class Library
FtpDirectoryExists..::.SendCommand Method
FtpDirectoryExists Class See Also Send Feedback

Overload List

Name | Description
SendCommand(String) | Send a command to the FTP server. (Inherited from FtpClientTaskBase.)
SendCommand(String, String) | Send a command to the FTP server. (Inherited from FtpClientTaskBase.)

See Also

FtpDirectoryExists Class
FtpDirectoryExists Members
MSBuild.Community.Tasks.Ftp Namespace


SendCommandAndReadResponse Method

[image] [image]

.NET Framework Class Library
FtpDirectoryExists..::.SendCommandAndReadResponse Method
FtpDirectoryExists Class See Also Send Feedback

Overload List

Name | Description
SendCommandAndReadResponse(String) | Send a command to the FTP server and returns the response. (Inherited from FtpClientTaskBase.)
SendCommandAndReadResponse(String, String) | Send a command to the FTP server and returns the response. (Inherited from FtpClientTaskBase.)

See Also

FtpDirectoryExists Class
FtpDirectoryExists Members
MSBuild.Community.Tasks.Ftp Namespace


FtpDirectoryExists Properties

[image] [image]

.NET Framework Class Library
FtpDirectoryExists Properties
FtpDirectoryExists Class See Also Send Feedback

The FtpDirectoryExists type exposes the following members.

Properties

Name | Description
BufferSize | Gets or sets the size of the data buffer. (Inherited from FtpClientTaskBase.)
BuildEngine | (Inherited from Task.)
ClientSocket | Gets or sets the client socket. (Inherited from FtpClientTaskBase.)
Connected | Gets a value indicating whether this FtpClientTaskBase is connected. (Inherited from FtpClientTaskBase.)
Exists | Gets an indication whether the directory exists on the server.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
LastReply | Gets the last recieved FTP response over the client socket. (Inherited from FtpClientTaskBase.)
Log | (Inherited from Task.)
Password | Gets or sets the password to login. (Inherited from FtpClientTaskBase.)
Port | Gets or sets the port number. (Inherited from FtpClientTaskBase.)
RemoteDirectory | Gets or sets the remote directory to create.
ServerHost | Gets or sets the server host. (Inherited from FtpClientTaskBase.)
TaskResources | (Inherited from Task.)
Username | Gets or sets the username to login. (Inherited from FtpClientTaskBase.)

See Also

FtpDirectoryExists Class
MSBuild.Community.Tasks.Ftp Namespace


Exists Property

[image]

.NET Framework Class Library
FtpDirectoryExists..::.Exists Property
FtpDirectoryExists Class See Also Send Feedback

Gets an indication whether the directory exists on the server.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property Exists As Boolean
C#
[OutputAttribute]
public bool Exists { get; }
Visual C++
[OutputAttribute]
public:
property bool Exists {
    bool get ();
}

Field Value

true when the directory exists on the server; otherwise false.

See Also

FtpDirectoryExists Class
MSBuild.Community.Tasks.Ftp Namespace


RemoteDirectory Property

[image]

.NET Framework Class Library
FtpDirectoryExists..::.RemoteDirectory Property
FtpDirectoryExists Class Example See Also Send Feedback

Gets or sets the remote directory to create.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property RemoteDirectory As String
C#
[RequiredAttribute]
public string RemoteDirectory { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ RemoteDirectory {
    String^ get ();
    void set (String^ value);
}

Field Value

The remote directory.

Examples

This can be one directory name, like "Directory", or a directory path, like "Directory\Subdirectoy".

See Also

FtpDirectoryExists Class
MSBuild.Community.Tasks.Ftp Namespace


FtpEntry Class

[image]

.NET Framework Class Library
FtpEntry Class
Members See Also Send Feedback

Represents an remote file or directory on a FTP server.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class FtpEntry
C#
public class FtpEntry
Visual C++
public ref class FtpEntry

Inheritance Hierarchy

System..::.Object
MSBuild.Community.Tasks.Ftp..::.FtpEntry

See Also

FtpEntry Members
MSBuild.Community.Tasks.Ftp Namespace


FtpEntry Members

[image] [image]

.NET Framework Class Library
FtpEntry Members
FtpEntry Class Constructors Methods Properties See Also Send Feedback

The FtpEntry type exposes the following members.

Constructors

Name | Description
FtpEntry | Initializes a new instance of the FtpEntry class.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ParseDirList | Parses the dir list.
ToString | (Inherited from Object.)

Properties

Name | Description
IsDirectory | Gets or sets a value indicating whether this instance represents a directory.
Name | Gets or sets the name.

See Also

FtpEntry Class
MSBuild.Community.Tasks.Ftp Namespace


FtpEntry Constructor

[image]

.NET Framework Class Library
FtpEntry Constructor
FtpEntry Class See Also Send Feedback

Initializes a new instance of the FtpEntry class.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    isDirectory As Boolean, _
    name As String _
)
C#
public FtpEntry(
    bool isDirectory,
    string name
)
Visual C++
public:
FtpEntry(
    bool isDirectory,
    String^ name
)

Parameters

isDirectory
Type: System..::.Boolean
if set to true this instance represents a directory; otherwise, false.
name
Type: System..::.String
The name.

See Also

FtpEntry Class
MSBuild.Community.Tasks.Ftp Namespace


FtpEntry Methods

[image] [image]

.NET Framework Class Library
FtpEntry Methods
FtpEntry Class See Also Send Feedback

The FtpEntry type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ParseDirList | Parses the dir list.
ToString | (Inherited from Object.)

See Also

FtpEntry Class
MSBuild.Community.Tasks.Ftp Namespace


ParseDirList Method

[image]

.NET Framework Class Library
FtpEntry..::.ParseDirList Method
FtpEntry Class See Also Send Feedback

Parses the dir list.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ParseDirList ( _
    entryLines As String() _
) As FtpEntry()
C#
public static FtpEntry[] ParseDirList(
    string[] entryLines
)
Visual C++
public:
static array<FtpEntry^>^ ParseDirList(
    array<String^>^ entryLines
)

Parameters

entryLines
Type: array< System..::.String >[]()[]
The entry lines.

Return Value

See Also

FtpEntry Class
MSBuild.Community.Tasks.Ftp Namespace


FtpEntry Properties

[image] [image]

.NET Framework Class Library
FtpEntry Properties
FtpEntry Class See Also Send Feedback

The FtpEntry type exposes the following members.

Properties

Name | Description
IsDirectory | Gets or sets a value indicating whether this instance represents a directory.
Name | Gets or sets the name.

See Also

FtpEntry Class
MSBuild.Community.Tasks.Ftp Namespace


IsDirectory Property

[image]

.NET Framework Class Library
FtpEntry..::.IsDirectory Property
FtpEntry Class See Also Send Feedback

Gets or sets a value indicating whether this instance represents a directory.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property IsDirectory As Boolean
C#
public bool IsDirectory { get; set; }
Visual C++
public:
property bool IsDirectory {
    bool get ();
    void set (bool value);
}

Field Value

true if this instance represents a directory; otherwise, false.

See Also

FtpEntry Class
MSBuild.Community.Tasks.Ftp Namespace


Name Property

[image]

.NET Framework Class Library
FtpEntry..::.Name Property
FtpEntry Class See Also Send Feedback

Gets or sets the name.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Field Value

The name.

See Also

FtpEntry Class
MSBuild.Community.Tasks.Ftp Namespace


FtpException Class

[image]

.NET Framework Class Library
FtpException Class
Members See Also Send Feedback

Exception returned by FTP server.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class FtpException _
    Inherits Exception
C#
public class FtpException : Exception
Visual C++
public ref class FtpException : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
MSBuild.Community.Tasks.Ftp..::.FtpException

See Also

FtpException Members
MSBuild.Community.Tasks.Ftp Namespace


FtpException Members

[image] [image]

.NET Framework Class Library
FtpException Members
FtpException Class Constructors Methods Properties See Also Send Feedback

The FtpException type exposes the following members.

Constructors

Name | Description
FtpException | Overloaded.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetBaseException | (Inherited from Exception.)
GetHashCode | (Inherited from Object.)
GetObjectData | (Inherited from Exception.)
GetType | (Inherited from Exception.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Exception.)

Properties

Name | Description
Data | (Inherited from Exception.)
HelpLink | (Inherited from Exception.)
HResult | (Inherited from Exception.)
InnerException | (Inherited from Exception.)
Message | (Inherited from Exception.)
Source | (Inherited from Exception.)
StackTrace | (Inherited from Exception.)
TargetSite | (Inherited from Exception.)

See Also

FtpException Class
MSBuild.Community.Tasks.Ftp Namespace


FtpException Constructor

[image] [image]

.NET Framework Class Library
FtpException Constructor
FtpException Class See Also Send Feedback

Overload List

Name | Description
FtpException(String) | Initializes a new instance of the FtpException class.
FtpException(String, Exception) | Initializes a new instance of the FtpException class.

See Also

FtpException Class
FtpException Members
MSBuild.Community.Tasks.Ftp Namespace


FtpException Constructor (String)

[image]

.NET Framework Class Library
FtpException Constructor (String)
FtpException Class See Also Send Feedback

Initializes a new instance of the FtpException class.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public FtpException(
    string message
)
Visual C++
public:
FtpException(
    String^ message
)

Parameters

message
Type: System..::.String
The message.

See Also

FtpException Class
FtpException Overload
MSBuild.Community.Tasks.Ftp Namespace


FtpException Constructor (String, Exception)

[image]

.NET Framework Class Library
FtpException Constructor (String, Exception)
FtpException Class See Also Send Feedback

Initializes a new instance of the FtpException class.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
C#
public FtpException(
    string message,
    Exception innerException
)
Visual C++
public:
FtpException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::.String
The message.
innerException
Type: System..::.Exception
The inner exception.

See Also

FtpException Class
FtpException Overload
MSBuild.Community.Tasks.Ftp Namespace


FtpException Methods

[image] [image]

.NET Framework Class Library
FtpException Methods
FtpException Class See Also Send Feedback

The FtpException type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetBaseException | (Inherited from Exception.)
GetHashCode | (Inherited from Object.)
GetObjectData | (Inherited from Exception.)
GetType | (Inherited from Exception.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Exception.)

See Also

FtpException Class
MSBuild.Community.Tasks.Ftp Namespace


FtpException Properties

[image] [image]

.NET Framework Class Library
FtpException Properties
FtpException Class See Also Send Feedback

The FtpException type exposes the following members.

Properties

Name | Description
Data | (Inherited from Exception.)
HelpLink | (Inherited from Exception.)
HResult | (Inherited from Exception.)
InnerException | (Inherited from Exception.)
Message | (Inherited from Exception.)
Source | (Inherited from Exception.)
StackTrace | (Inherited from Exception.)
TargetSite | (Inherited from Exception.)

See Also

FtpException Class
MSBuild.Community.Tasks.Ftp Namespace


FtpReply Class

[image]

.NET Framework Class Library
FtpReply Class
Members See Also Send Feedback

Represenatation of a FTP reply message.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class FtpReply
C#
public class FtpReply
Visual C++
public ref class FtpReply

Inheritance Hierarchy

System..::.Object
MSBuild.Community.Tasks.Ftp..::.FtpReply

See Also

FtpReply Members
MSBuild.Community.Tasks.Ftp Namespace


FtpReply Members

[image] [image]

.NET Framework Class Library
FtpReply Members
FtpReply Class Constructors Methods Properties See Also Send Feedback

The FtpReply type exposes the following members.

Constructors

Name | Description
FtpReply | Initializes a new instance of the FtpReply class.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
Message | Gets or sets the message.
ResultCode | Gets or sets the result code.

See Also

FtpReply Class
MSBuild.Community.Tasks.Ftp Namespace


FtpReply Constructor

[image]

.NET Framework Class Library
FtpReply Constructor
FtpReply Class See Also Send Feedback

Initializes a new instance of the FtpReply class.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    resultCode As Integer, _
    message As String _
)
C#
public FtpReply(
    int resultCode,
    string message
)
Visual C++
public:
FtpReply(
    int resultCode,
    String^ message
)

Parameters

resultCode
Type: System..::.Int32
The result code of the FTP response.
message
Type: System..::.String
The response message.

See Also

FtpReply Class
MSBuild.Community.Tasks.Ftp Namespace


FtpReply Methods

[image] [image]

.NET Framework Class Library
FtpReply Methods
FtpReply Class See Also Send Feedback

The FtpReply type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

FtpReply Class
MSBuild.Community.Tasks.Ftp Namespace


FtpReply Properties

[image] [image]

.NET Framework Class Library
FtpReply Properties
FtpReply Class See Also Send Feedback

The FtpReply type exposes the following members.

Properties

Name | Description
Message | Gets or sets the message.
ResultCode | Gets or sets the result code.

See Also

FtpReply Class
MSBuild.Community.Tasks.Ftp Namespace


Message Property

[image]

.NET Framework Class Library
FtpReply..::.Message Property
FtpReply Class See Also Send Feedback

Gets or sets the message.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Message As String
C#
public string Message { get; set; }
Visual C++
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}

Field Value

The message.

See Also

FtpReply Class
MSBuild.Community.Tasks.Ftp Namespace


ResultCode Property

[image]

.NET Framework Class Library
FtpReply..::.ResultCode Property
FtpReply Class See Also Send Feedback

Gets or sets the result code.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ResultCode As Integer
C#
public int ResultCode { get; set; }
Visual C++
public:
property int ResultCode {
    int get ();
    void set (int value);
}

Field Value

The result code.

See Also

FtpReply Class
MSBuild.Community.Tasks.Ftp Namespace


FtpUploadDirectoryContent Class

[image]

.NET Framework Class Library
FtpUploadDirectoryContent Class
Members Example See Also Send Feedback

Uploads a full directory content to a remote directory.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class FtpUploadDirectoryContent _
    Inherits FtpClientTaskBase
C#
public class FtpUploadDirectoryContent : FtpClientTaskBase
Visual C++
public ref class FtpUploadDirectoryContent : public FtpClientTaskBase

Examples

Uploads directory content, including all subdirectories and subdirectory content:
Copy Code
            <Target Name="DeployWebsite">
                <FtpUploadDirectoryContent
                    ServerHost="ftp.myserver.com"
                    Port="42"
                    Username="user"
                    Password="p@ssw0rd"
                    LocalDirectory="c:\build\mywebsite"
                    RemoteDirectory="root\www\mywebsite"
                    Recursive="true"
                />
To go a little step further. If the local directory looked like this:
Copy Code
            [mywebsite]
                [images]
                    1.gif
                    2.gif
                    3.gif
                [js]
                    clientscript.js
                    nofocus.js
                [css]
                    print.css
                    main.css
                index.htm
                contact.htm
                downloads.htm
All directories and there content will be uploaded and a excact copy of the content of mywebsite directory will be created remotely.

Remarks

If Recursive is set the false; only index.htm, contact.htm and downloads.htm will be uploaded and no subdirectories will be created remotely.

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.Ftp..::.FtpClientTaskBase
MSBuild.Community.Tasks.Ftp..::.FtpUploadDirectoryContent

See Also

FtpUploadDirectoryContent Members
MSBuild.Community.Tasks.Ftp Namespace


FtpUploadDirectoryContent Members

[image] [image]

.NET Framework Class Library
FtpUploadDirectoryContent Members
FtpUploadDirectoryContent Class Constructors Methods Properties See Also Send Feedback

The FtpUploadDirectoryContent type exposes the following members.

Constructors

Name | Description
FtpUploadDirectoryContent |

Methods

Name | Description
CdUp | Change to the parent of the current working directory. (Inherited from FtpClientTaskBase.)
ChangeWorkingDirectory | Changes the working directory. (Inherited from FtpClientTaskBase.)
Close | Closes the connection to the server. (Inherited from FtpClientTaskBase.)
Connect | Connects this FTP server socket. (Inherited from FtpClientTaskBase.)
CreateDataStreamAndSendCommand | Create a data stream and send a raw command. (Inherited from FtpClientTaskBase.)
DirectoryExists | Determs whether a remote directory exists. (Inherited from FtpClientTaskBase.)
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
FileExists | Determs whether a remote file exists. (Inherited from FtpClientTaskBase.)
Finalize | (Inherited from Object.)
GetDirectoryDetails | Overloaded.
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
GetWorkingDirectory | Gets the working directory. (Inherited from FtpClientTaskBase.)
Login | Login to the FTP server with the specified credentials. (Inherited from FtpClientTaskBase.)
MakeDirectory | Creates a remote directory in the current working folder. (Inherited from FtpClientTaskBase.)
MemberwiseClone | (Inherited from Object.)
ReadResponse | Reads the ftp response from the client socket. (Inherited from FtpClientTaskBase.)
RemoveDirectory | Removes a remote directory. (Inherited from FtpClientTaskBase.)
SendCommand | Overloaded.
SendCommandAndReadResponse | Overloaded.
Store | Stores the specified localFile. (Inherited from FtpClientTaskBase.)
ToString | (Inherited from Object.)
UploadDirectory | Overloaded.

Properties

Name | Description
BufferSize | Gets or sets the size of the data buffer. (Inherited from FtpClientTaskBase.)
BuildEngine | (Inherited from Task.)
ClientSocket | Gets or sets the client socket. (Inherited from FtpClientTaskBase.)
Connected | Gets a value indicating whether this FtpClientTaskBase is connected. (Inherited from FtpClientTaskBase.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
LastReply | Gets the last recieved FTP response over the client socket. (Inherited from FtpClientTaskBase.)
LocalDirectory | Gets or sets the local directory that contains the content to upload.
Log | (Inherited from Task.)
Password | Gets or sets the password to login. (Inherited from FtpClientTaskBase.)
Port | Gets or sets the port number. (Inherited from FtpClientTaskBase.)
Recursive | Gets or sets a value indicating whether the subdirectories of the local directory should be created remotely and the content of these should also be uploaded.
RemoteDirectory | Gets or sets the remote directory destination for the local files.
ServerHost | Gets or sets the server host. (Inherited from FtpClientTaskBase.)
TaskResources | (Inherited from Task.)
Username | Gets or sets the username to login. (Inherited from FtpClientTaskBase.)

See Also

FtpUploadDirectoryContent Class
MSBuild.Community.Tasks.Ftp Namespace


FtpUploadDirectoryContent Constructor

[image]

.NET Framework Class Library
FtpUploadDirectoryContent Constructor
FtpUploadDirectoryContent Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FtpUploadDirectoryContent()
Visual C++
public:
FtpUploadDirectoryContent()

See Also

FtpUploadDirectoryContent Class
MSBuild.Community.Tasks.Ftp Namespace


FtpUploadDirectoryContent Methods

[image] [image]

.NET Framework Class Library
FtpUploadDirectoryContent Methods
FtpUploadDirectoryContent Class See Also Send Feedback

The FtpUploadDirectoryContent type exposes the following members.

Methods

Name | Description
CdUp | Change to the parent of the current working directory. (Inherited from FtpClientTaskBase.)
ChangeWorkingDirectory | Changes the working directory. (Inherited from FtpClientTaskBase.)
Close | Closes the connection to the server. (Inherited from FtpClientTaskBase.)
Connect | Connects this FTP server socket. (Inherited from FtpClientTaskBase.)
CreateDataStreamAndSendCommand | Create a data stream and send a raw command. (Inherited from FtpClientTaskBase.)
DirectoryExists | Determs whether a remote directory exists. (Inherited from FtpClientTaskBase.)
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
FileExists | Determs whether a remote file exists. (Inherited from FtpClientTaskBase.)
Finalize | (Inherited from Object.)
GetDirectoryDetails | Overloaded.
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
GetWorkingDirectory | Gets the working directory. (Inherited from FtpClientTaskBase.)
Login | Login to the FTP server with the specified credentials. (Inherited from FtpClientTaskBase.)
MakeDirectory | Creates a remote directory in the current working folder. (Inherited from FtpClientTaskBase.)
MemberwiseClone | (Inherited from Object.)
ReadResponse | Reads the ftp response from the client socket. (Inherited from FtpClientTaskBase.)
RemoveDirectory | Removes a remote directory. (Inherited from FtpClientTaskBase.)
SendCommand | Overloaded.
SendCommandAndReadResponse | Overloaded.
Store | Stores the specified localFile. (Inherited from FtpClientTaskBase.)
ToString | (Inherited from Object.)
UploadDirectory | Overloaded.

See Also

FtpUploadDirectoryContent Class
MSBuild.Community.Tasks.Ftp Namespace


Execute Method

[image]

.NET Framework Class Library
FtpUploadDirectoryContent..::.Execute Method
FtpUploadDirectoryContent Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

FtpUploadDirectoryContent Class
MSBuild.Community.Tasks.Ftp Namespace


GetDirectoryDetails Method

[image] [image]

.NET Framework Class Library
FtpUploadDirectoryContent..::.GetDirectoryDetails Method
FtpUploadDirectoryContent Class See Also Send Feedback

Overload List

Name | Description
GetDirectoryDetails()()() | Get the full directory details of the current directory. (Inherited from FtpClientTaskBase.)
GetDirectoryDetails(String) | Get the full directory details of the current directory. (Inherited from FtpClientTaskBase.)

See Also

FtpUploadDirectoryContent Class
FtpUploadDirectoryContent Members
MSBuild.Community.Tasks.Ftp Namespace


SendCommand Method

[image] [image]

.NET Framework Class Library
FtpUploadDirectoryContent..::.SendCommand Method
FtpUploadDirectoryContent Class See Also Send Feedback

Overload List

Name | Description
SendCommand(String) | Send a command to the FTP server. (Inherited from FtpClientTaskBase.)
SendCommand(String, String) | Send a command to the FTP server. (Inherited from FtpClientTaskBase.)

See Also

FtpUploadDirectoryContent Class
FtpUploadDirectoryContent Members
MSBuild.Community.Tasks.Ftp Namespace


SendCommandAndReadResponse Method

[image] [image]

.NET Framework Class Library
FtpUploadDirectoryContent..::.SendCommandAndReadResponse Method
FtpUploadDirectoryContent Class See Also Send Feedback

Overload List

Name | Description
SendCommandAndReadResponse(String) | Send a command to the FTP server and returns the response. (Inherited from FtpClientTaskBase.)
SendCommandAndReadResponse(String, String) | Send a command to the FTP server and returns the response. (Inherited from FtpClientTaskBase.)

See Also

FtpUploadDirectoryContent Class
FtpUploadDirectoryContent Members
MSBuild.Community.Tasks.Ftp Namespace


UploadDirectory Method

[image] [image]

.NET Framework Class Library
FtpUploadDirectoryContent..::.UploadDirectory Method
FtpUploadDirectoryContent Class See Also Send Feedback

Overload List

Name | Description
UploadDirectory(String, Boolean) | Upload a directory and its file contents.
UploadDirectory(String, String, Boolean) | Upload a directory and its file contents.

See Also

FtpUploadDirectoryContent Class
FtpUploadDirectoryContent Members
MSBuild.Community.Tasks.Ftp Namespace


UploadDirectory Method (String, Boolean)

[image]

.NET Framework Class Library
FtpUploadDirectoryContent..::.UploadDirectory Method (String, Boolean)
FtpUploadDirectoryContent Class See Also Send Feedback

Upload a directory and its file contents.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Sub UploadDirectory ( _
    localPath As String, _
    recurse As Boolean _
)
C#
protected void UploadDirectory(
    string localPath,
    bool recurse
)
Visual C++
protected:
void UploadDirectory(
    String^ localPath,
    bool recurse
)

Parameters

localPath
Type: System..::.String
The local path.
recurse
Type: System..::.Boolean
if set to true all subdurectiries will be included.

See Also

FtpUploadDirectoryContent Class
UploadDirectory Overload
MSBuild.Community.Tasks.Ftp Namespace


UploadDirectory Method (String, String, Boolean)

[image]

.NET Framework Class Library
FtpUploadDirectoryContent..::.UploadDirectory Method (String, String, Boolean)
FtpUploadDirectoryContent Class See Also Send Feedback

Upload a directory and its file contents.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Sub UploadDirectory ( _
    localPath As String, _
    mask As String, _
    recursive As Boolean _
)
C#
protected void UploadDirectory(
    string localPath,
    string mask,
    bool recursive
)
Visual C++
protected:
void UploadDirectory(
    String^ localPath,
    String^ mask,
    bool recursive
)

Parameters

localPath
Type: System..::.String
The local path.
mask
Type: System..::.String
Only upload files that compli to the mask.
recursive
Type: System..::.Boolean
if set to true all subdurectiries will be included.

See Also

FtpUploadDirectoryContent Class
UploadDirectory Overload
MSBuild.Community.Tasks.Ftp Namespace


FtpUploadDirectoryContent Properties

[image] [image]

.NET Framework Class Library
FtpUploadDirectoryContent Properties
FtpUploadDirectoryContent Class See Also Send Feedback

The FtpUploadDirectoryContent type exposes the following members.

Properties

Name | Description
BufferSize | Gets or sets the size of the data buffer. (Inherited from FtpClientTaskBase.)
BuildEngine | (Inherited from Task.)
ClientSocket | Gets or sets the client socket. (Inherited from FtpClientTaskBase.)
Connected | Gets a value indicating whether this FtpClientTaskBase is connected. (Inherited from FtpClientTaskBase.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
LastReply | Gets the last recieved FTP response over the client socket. (Inherited from FtpClientTaskBase.)
LocalDirectory | Gets or sets the local directory that contains the content to upload.
Log | (Inherited from Task.)
Password | Gets or sets the password to login. (Inherited from FtpClientTaskBase.)
Port | Gets or sets the port number. (Inherited from FtpClientTaskBase.)
Recursive | Gets or sets a value indicating whether the subdirectories of the local directory should be created remotely and the content of these should also be uploaded.
RemoteDirectory | Gets or sets the remote directory destination for the local files.
ServerHost | Gets or sets the server host. (Inherited from FtpClientTaskBase.)
TaskResources | (Inherited from Task.)
Username | Gets or sets the username to login. (Inherited from FtpClientTaskBase.)

See Also

FtpUploadDirectoryContent Class
MSBuild.Community.Tasks.Ftp Namespace


LocalDirectory Property

[image]

.NET Framework Class Library
FtpUploadDirectoryContent..::.LocalDirectory Property
FtpUploadDirectoryContent Class See Also Send Feedback

Gets or sets the local directory that contains the content to upload.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property LocalDirectory As String
C#
public string LocalDirectory { get; set; }
Visual C++
public:
property String^ LocalDirectory {
    String^ get ();
    void set (String^ value);
}

Field Value

The local directory.

See Also

FtpUploadDirectoryContent Class
MSBuild.Community.Tasks.Ftp Namespace


Recursive Property

[image]

.NET Framework Class Library
FtpUploadDirectoryContent..::.Recursive Property
FtpUploadDirectoryContent Class See Also Send Feedback

Gets or sets a value indicating whether the subdirectories of the local directory should be created remotely and the content of these should also be uploaded.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Recursive As Boolean
C#
public bool Recursive { get; set; }
Visual C++
public:
property bool Recursive {
    bool get ();
    void set (bool value);
}

Field Value

true if recursive; otherwise, false.

See Also

FtpUploadDirectoryContent Class
MSBuild.Community.Tasks.Ftp Namespace


RemoteDirectory Property

[image]

.NET Framework Class Library
FtpUploadDirectoryContent..::.RemoteDirectory Property
FtpUploadDirectoryContent Class See Also Send Feedback

Gets or sets the remote directory destination for the local files.

Namespace: MSBuild.Community.Tasks.Ftp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property RemoteDirectory As String
C#
public string RemoteDirectory { get; set; }
Visual C++
public:
property String^ RemoteDirectory {
    String^ get ();
    void set (String^ value);
}

Field Value

The remote directory.

See Also

FtpUploadDirectoryContent Class
MSBuild.Community.Tasks.Ftp Namespace


MSBuild.Community.Tasks.Fusion Namespace

[image]

.NET Framework Class Library
MSBuild.Community.Tasks.Fusion Namespace
Send Feedback

Classes

Class | Description
FusionWrapper | A class wrapping fusion api calls

Enumerations

Enumeration | Description
UninstallStatus | The status of an uninstall.


FusionWrapper Class

[image]

.NET Framework Class Library
FusionWrapper Class
Members See Also Send Feedback

A class wrapping fusion api calls

Namespace: MSBuild.Community.Tasks.Fusion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class FusionWrapper
C#
public static class FusionWrapper
Visual C++
public ref class FusionWrapper abstract sealed

Inheritance Hierarchy

System..::.Object
MSBuild.Community.Tasks.Fusion..::.FusionWrapper

See Also

FusionWrapper Members
MSBuild.Community.Tasks.Fusion Namespace


FusionWrapper Members

[image] [image]

.NET Framework Class Library
FusionWrapper Members
FusionWrapper Class Methods See Also Send Feedback

The FusionWrapper type exposes the following members.

Methods

Name | Description
GetAssemblyName | Gets the name of the assembly.
GetAssemblyPath | Gets the assembly path.
InstallAssembly | Installs the assembly.
UninstallAssembly | Overloaded.

See Also

FusionWrapper Class
MSBuild.Community.Tasks.Fusion Namespace


FusionWrapper Methods

[image] [image]

.NET Framework Class Library
FusionWrapper Methods
FusionWrapper Class See Also Send Feedback

The FusionWrapper type exposes the following members.

Methods

Name | Description
GetAssemblyName | Gets the name of the assembly.
GetAssemblyPath | Gets the assembly path.
InstallAssembly | Installs the assembly.
UninstallAssembly | Overloaded.

See Also

FusionWrapper Class
MSBuild.Community.Tasks.Fusion Namespace


GetAssemblyName Method

[image]

.NET Framework Class Library
FusionWrapper..::.GetAssemblyName Method
FusionWrapper Class See Also Send Feedback

Gets the name of the assembly.

Namespace: MSBuild.Community.Tasks.Fusion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetAssemblyName ( _
    assemblyName As String _
) As AssemblyName
C#
public static AssemblyName GetAssemblyName(
    string assemblyName
)
Visual C++
public:
static AssemblyName^ GetAssemblyName(
    String^ assemblyName
)

Parameters

assemblyName
Type: System..::.String
Name of the assembly.

Return Value

An AssemblyName instance.

See Also

FusionWrapper Class
MSBuild.Community.Tasks.Fusion Namespace


GetAssemblyPath Method

[image]

.NET Framework Class Library
FusionWrapper..::.GetAssemblyPath Method
FusionWrapper Class See Also Send Feedback

Gets the assembly path.

Namespace: MSBuild.Community.Tasks.Fusion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetAssemblyPath ( _
    assemblyName As String _
) As String
C#
public static string GetAssemblyPath(
    string assemblyName
)
Visual C++
public:
static String^ GetAssemblyPath(
    String^ assemblyName
)

Parameters

assemblyName
Type: System..::.String
Name of the assembly.

Return Value

The path to the assembly in the GAC.

See Also

FusionWrapper Class
MSBuild.Community.Tasks.Fusion Namespace


InstallAssembly Method

[image]

.NET Framework Class Library
FusionWrapper..::.InstallAssembly Method
FusionWrapper Class See Also Send Feedback

Installs the assembly.

Namespace: MSBuild.Community.Tasks.Fusion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub InstallAssembly ( _
    assemblyPath As String, _
    force As Boolean _
)
C#
public static void InstallAssembly(
    string assemblyPath,
    bool force
)
Visual C++
public:
static void InstallAssembly(
    String^ assemblyPath,
    bool force
)

Parameters

assemblyPath
Type: System..::.String
The assembly path.
force
Type: System..::.Boolean
if set to true force.

See Also

FusionWrapper Class
MSBuild.Community.Tasks.Fusion Namespace


UninstallAssembly Method

[image] [image]

.NET Framework Class Library
FusionWrapper..::.UninstallAssembly Method
FusionWrapper Class See Also Send Feedback

Overload List

Name | Description
UninstallAssembly(String, Boolean) | Uninstalls the assembly.
UninstallAssembly(String, Boolean, UninstallStatus%) | Uninstalls the assembly.

See Also

FusionWrapper Class
FusionWrapper Members
MSBuild.Community.Tasks.Fusion Namespace


UninstallAssembly Method (String, Boolean)

[image]

.NET Framework Class Library
FusionWrapper..::.UninstallAssembly Method (String, Boolean)
FusionWrapper Class See Also Send Feedback

Uninstalls the assembly.

Namespace: MSBuild.Community.Tasks.Fusion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function UninstallAssembly ( _
    assemblyName As String, _
    force As Boolean _
) As Boolean
C#
public static bool UninstallAssembly(
    string assemblyName,
    bool force
)
Visual C++
public:
static bool UninstallAssembly(
    String^ assemblyName,
    bool force
)

Parameters

assemblyName
Type: System..::.String
Name of the assembly.
force
Type: System..::.Boolean
if set to true force.

Return Value

Returns true if uninstall successful.

See Also

FusionWrapper Class
UninstallAssembly Overload
MSBuild.Community.Tasks.Fusion Namespace


UninstallAssembly Method (String, Boolean, UninstallStatus)

[image]

.NET Framework Class Library
FusionWrapper..::.UninstallAssembly Method (String, Boolean, UninstallStatus%)
FusionWrapper Class See Also Send Feedback

Uninstalls the assembly.

Namespace: MSBuild.Community.Tasks.Fusion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function UninstallAssembly ( _
    assemblyName As String, _
    force As Boolean, _
    <OutAttribute> ByRef result As UninstallStatus _
) As Boolean
C#
public static bool UninstallAssembly(
    string assemblyName,
    bool force,
    out UninstallStatus result
)
Visual C++
public:
static bool UninstallAssembly(
    String^ assemblyName,
    bool force,
    [OutAttribute] UninstallStatus% result
)

Parameters

assemblyName
Type: System..::.String
Name of the assembly.
force
Type: System..::.Boolean
if set to true force.
result
Type: MSBuild.Community.Tasks.Fusion..::.UninstallStatus %
The UninstallStatus result.

Return Value

Returns true if uninstall successful.

See Also

FusionWrapper Class
UninstallAssembly Overload
MSBuild.Community.Tasks.Fusion Namespace


UninstallStatus Enumeration

[image]

.NET Framework Class Library
UninstallStatus Enumeration
See Also Send Feedback

The status of an uninstall.

Namespace: MSBuild.Community.Tasks.Fusion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration UninstallStatus
C#
public enum UninstallStatus
Visual C++
public enum class UninstallStatus

Members

Member name | Description
None | No status.
Uninstalled | Uninstalled successfully.
StillInUse | Assembly is still in use.
AlreadyUninstalled | Assembly already uninstalled or not found.
DeletePending | Assembly delete is pending.
HasInstallReferences | Assembly has a reference to an installed application.
ReferenceNotFound | Assembly not found.

See Also

MSBuild.Community.Tasks.Fusion Namespace


MSBuild.Community.Tasks.HtmlHelp Namespace

[image]

.NET Framework Class Library
MSBuild.Community.Tasks.HtmlHelp Namespace
Send Feedback

Classes

Class | Description
ChmCompiler | Html Help 1x compiler task.
HxCompiler | A Html Help 2.0 compiler task.


ChmCompiler Class

[image]

.NET Framework Class Library
ChmCompiler Class
Members See Also Send Feedback

Html Help 1x compiler task.

Namespace: MSBuild.Community.Tasks.HtmlHelp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class ChmCompiler _
    Inherits ToolTask
C#
public class ChmCompiler : ToolTask
Visual C++
public ref class ChmCompiler : public ToolTask

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
Microsoft.Build.Utilities..::.ToolTask
MSBuild.Community.Tasks.HtmlHelp..::.ChmCompiler

See Also

ChmCompiler Members
MSBuild.Community.Tasks.HtmlHelp Namespace


ChmCompiler Members

[image] [image]

.NET Framework Class Library
ChmCompiler Members
ChmCompiler Class Constructors Methods Properties See Also Send Feedback

The ChmCompiler type exposes the following members.

Constructors

Name | Description
ChmCompiler |

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from ToolTask.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (Overrides ToolTask..::.HandleTaskExecutionErrors()()().)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | (Inherited from ToolTask.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Overrides ToolTask..::.LogToolCommand(String).)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
ProjectFile | Gets or sets the project file path.
ResponseFileEncoding | (Inherited from ToolTask.)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Overrides ToolTask..::.StandardOutputLoggingImportance.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)

See Also

ChmCompiler Class
MSBuild.Community.Tasks.HtmlHelp Namespace


ChmCompiler Constructor

[image]

.NET Framework Class Library
ChmCompiler Constructor
ChmCompiler Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.HtmlHelp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ChmCompiler()
Visual C++
public:
ChmCompiler()

See Also

ChmCompiler Class
MSBuild.Community.Tasks.HtmlHelp Namespace


ChmCompiler Methods

[image] [image]

.NET Framework Class Library
ChmCompiler Methods
ChmCompiler Class See Also Send Feedback

The ChmCompiler type exposes the following members.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from ToolTask.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (Overrides ToolTask..::.HandleTaskExecutionErrors()()().)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | (Inherited from ToolTask.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Overrides ToolTask..::.LogToolCommand(String).)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

See Also

ChmCompiler Class
MSBuild.Community.Tasks.HtmlHelp Namespace


GenerateCommandLineCommands Method

[image]

.NET Framework Class Library
ChmCompiler..::.GenerateCommandLineCommands Method
ChmCompiler Class See Also Send Feedback

Returns a string value containing the command line arguments to pass directly to the executable file.

Namespace: MSBuild.Community.Tasks.HtmlHelp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateCommandLineCommands As String
C#
protected override string GenerateCommandLineCommands()
Visual C++
protected:
virtual String^ GenerateCommandLineCommands() override

Return Value

A string value containing the command line arguments to pass directly to the executable file.

See Also

ChmCompiler Class
MSBuild.Community.Tasks.HtmlHelp Namespace


GenerateFullPathToTool Method

[image]

.NET Framework Class Library
ChmCompiler..::.GenerateFullPathToTool Method
ChmCompiler Class See Also Send Feedback

Returns the fully qualified path to the executable file.

Namespace: MSBuild.Community.Tasks.HtmlHelp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateFullPathToTool As String
C#
protected override string GenerateFullPathToTool()
Visual C++
protected:
virtual String^ GenerateFullPathToTool() override

Return Value

The fully qualified path to the executable file.

See Also

ChmCompiler Class
MSBuild.Community.Tasks.HtmlHelp Namespace


HandleTaskExecutionErrors Method

[image]

.NET Framework Class Library
ChmCompiler..::.HandleTaskExecutionErrors Method
ChmCompiler Class See Also Send Feedback

Handles execution errors raised by the executable file.

Namespace: MSBuild.Community.Tasks.HtmlHelp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function HandleTaskExecutionErrors As Boolean
C#
protected override bool HandleTaskExecutionErrors()
Visual C++
protected:
virtual bool HandleTaskExecutionErrors() override

Return Value

true if the method runs successfully; otherwise, false.

See Also

ChmCompiler Class
MSBuild.Community.Tasks.HtmlHelp Namespace


LogToolCommand Method

[image]

.NET Framework Class Library
ChmCompiler..::.LogToolCommand Method
ChmCompiler Class See Also Send Feedback

Logs the starting point of the run to all registered loggers.

Namespace: MSBuild.Community.Tasks.HtmlHelp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub LogToolCommand ( _
    message As String _
)
C#
protected override void LogToolCommand(
    string message
)
Visual C++
protected:
virtual void LogToolCommand(
    String^ message
) override

Parameters

message
Type: System..::.String
A descriptive message to provide loggers, usually the command line and switches.

See Also

ChmCompiler Class
MSBuild.Community.Tasks.HtmlHelp Namespace


ChmCompiler Properties

[image] [image]

.NET Framework Class Library
ChmCompiler Properties
ChmCompiler Class See Also Send Feedback

The ChmCompiler type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
ProjectFile | Gets or sets the project file path.
ResponseFileEncoding | (Inherited from ToolTask.)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Overrides ToolTask..::.StandardOutputLoggingImportance.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)

See Also

ChmCompiler Class
MSBuild.Community.Tasks.HtmlHelp Namespace


ProjectFile Property

[image]

.NET Framework Class Library
ChmCompiler..::.ProjectFile Property
ChmCompiler Class See Also Send Feedback

Gets or sets the project file path.

Namespace: MSBuild.Community.Tasks.HtmlHelp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property ProjectFile As ITaskItem
C#
[RequiredAttribute]
public ITaskItem ProjectFile { get; set; }
Visual C++
[RequiredAttribute]
public:
property ITaskItem^ ProjectFile {
    ITaskItem^ get ();
    void set (ITaskItem^ value);
}

Field Value

The project file path.

See Also

ChmCompiler Class
MSBuild.Community.Tasks.HtmlHelp Namespace


StandardOutputLoggingImportance Property

[image]

.NET Framework Class Library
ChmCompiler..::.StandardOutputLoggingImportance Property
ChmCompiler Class See Also Send Feedback

Gets the MessageImportance with which to log errors.

Namespace: MSBuild.Community.Tasks.HtmlHelp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property StandardOutputLoggingImportance As MessageImportance
C#
protected override MessageImportance StandardOutputLoggingImportance { get; }
Visual C++
protected:
virtual property MessageImportance StandardOutputLoggingImportance {
    MessageImportance get () override;
}

Field Value

Return Value

The MessageImportance with which to log errors.

See Also

ChmCompiler Class
MSBuild.Community.Tasks.HtmlHelp Namespace


ToolName Property

[image]

.NET Framework Class Library
ChmCompiler..::.ToolName Property
ChmCompiler Class See Also Send Feedback

Gets the name of the executable file to run.

Namespace: MSBuild.Community.Tasks.HtmlHelp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ToolName As String
C#
protected override string ToolName { get; }
Visual C++
protected:
virtual property String^ ToolName {
    String^ get () override;
}

Field Value

Return Value

The name of the executable file to run.

See Also

ChmCompiler Class
MSBuild.Community.Tasks.HtmlHelp Namespace


HxCompiler Class

[image]

.NET Framework Class Library
HxCompiler Class
Members See Also Send Feedback

A Html Help 2.0 compiler task.

Namespace: MSBuild.Community.Tasks.HtmlHelp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class HxCompiler _
    Inherits ToolTask
C#
public class HxCompiler : ToolTask
Visual C++
public ref class HxCompiler : public ToolTask

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
Microsoft.Build.Utilities..::.ToolTask
MSBuild.Community.Tasks.HtmlHelp..::.HxCompiler

See Also

HxCompiler Members
MSBuild.Community.Tasks.HtmlHelp Namespace


HxCompiler Members

[image] [image]

.NET Framework Class Library
HxCompiler Members
HxCompiler Class Constructors Methods Properties See Also Send Feedback

The HxCompiler type exposes the following members.

Constructors

Name | Description
HxCompiler |

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from ToolTask.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (Overrides ToolTask..::.HandleTaskExecutionErrors()()().)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | (Inherited from ToolTask.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Overrides ToolTask..::.LogToolCommand(String).)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
LogFile | Gets or sets the log file.
NoErrorMessages | Gets or sets a value indicating whether no error messages will be output.
NoInfoMessages | Gets or sets a value indicating whether no info messages will be output.
NoWarningMessages | Gets or sets a value indicating whether no warning messages will be output.
OutputFile | Gets or sets the output file.
ProjectFile | Gets or sets the project file path.
ProjectRoot | Gets or sets the project root.
QuiteMode | Gets or sets a value indicating quite mode.
ResponseFileEncoding | (Inherited from ToolTask.)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Overrides ToolTask..::.StandardOutputLoggingImportance.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)
UncompileDirectory | Gets or sets the uncompile directory.
UncompileFile | Gets or sets the uncompile file.

See Also

HxCompiler Class
MSBuild.Community.Tasks.HtmlHelp Namespace


HxCompiler Constructor

[image]

.NET Framework Class Library
HxCompiler Constructor
HxCompiler Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.HtmlHelp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public HxCompiler()
Visual C++
public:
HxCompiler()

See Also

HxCompiler Class
MSBuild.Community.Tasks.HtmlHelp Namespace


HxCompiler Methods

[image] [image]

.NET Framework Class Library
HxCompiler Methods
HxCompiler Class See Also Send Feedback

The HxCompiler type exposes the following members.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from ToolTask.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (Overrides ToolTask..::.HandleTaskExecutionErrors()()().)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | (Inherited from ToolTask.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Overrides ToolTask..::.LogToolCommand(String).)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

See Also

HxCompiler Class
MSBuild.Community.Tasks.HtmlHelp Namespace


GenerateCommandLineCommands Method

[image]

.NET Framework Class Library
HxCompiler..::.GenerateCommandLineCommands Method
HxCompiler Class See Also Send Feedback

Returns a string value containing the command line arguments to pass directly to the executable file.

Namespace: MSBuild.Community.Tasks.HtmlHelp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateCommandLineCommands As String
C#
protected override string GenerateCommandLineCommands()
Visual C++
protected:
virtual String^ GenerateCommandLineCommands() override

Return Value

A string value containing the command line arguments to pass directly to the executable file.

See Also

HxCompiler Class
MSBuild.Community.Tasks.HtmlHelp Namespace


GenerateFullPathToTool Method

[image]

.NET Framework Class Library
HxCompiler..::.GenerateFullPathToTool Method
HxCompiler Class See Also Send Feedback

Returns the fully qualified path to the executable file.

Namespace: MSBuild.Community.Tasks.HtmlHelp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateFullPathToTool As String
C#
protected override string GenerateFullPathToTool()
Visual C++
protected:
virtual String^ GenerateFullPathToTool() override

Return Value

The fully qualified path to the executable file.

See Also

HxCompiler Class
MSBuild.Community.Tasks.HtmlHelp Namespace


HandleTaskExecutionErrors Method

[image]

.NET Framework Class Library
HxCompiler..::.HandleTaskExecutionErrors Method
HxCompiler Class See Also Send Feedback

Handles execution errors raised by the executable file.

Namespace: MSBuild.Community.Tasks.HtmlHelp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function HandleTaskExecutionErrors As Boolean
C#
protected override bool HandleTaskExecutionErrors()
Visual C++
protected:
virtual bool HandleTaskExecutionErrors() override

Return Value

true if the method runs successfully; otherwise, false.

See Also

HxCompiler Class
MSBuild.Community.Tasks.HtmlHelp Namespace


LogToolCommand Method

[image]

.NET Framework Class Library
HxCompiler..::.LogToolCommand Method
HxCompiler Class See Also Send Feedback

Logs the starting point of the run to all registered loggers.

Namespace: MSBuild.Community.Tasks.HtmlHelp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub LogToolCommand ( _
    message As String _
)
C#
protected override void LogToolCommand(
    string message
)
Visual C++
protected:
virtual void LogToolCommand(
    String^ message
) override

Parameters

message
Type: System..::.String
A descriptive message to provide loggers, usually the command line and switches.

See Also

HxCompiler Class
MSBuild.Community.Tasks.HtmlHelp Namespace


HxCompiler Properties

[image] [image]

.NET Framework Class Library
HxCompiler Properties
HxCompiler Class See Also Send Feedback

The HxCompiler type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
LogFile | Gets or sets the log file.
NoErrorMessages | Gets or sets a value indicating whether no error messages will be output.
NoInfoMessages | Gets or sets a value indicating whether no info messages will be output.
NoWarningMessages | Gets or sets a value indicating whether no warning messages will be output.
OutputFile | Gets or sets the output file.
ProjectFile | Gets or sets the project file path.
ProjectRoot | Gets or sets the project root.
QuiteMode | Gets or sets a value indicating quite mode.
ResponseFileEncoding | (Inherited from ToolTask.)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Overrides ToolTask..::.StandardOutputLoggingImportance.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)
UncompileDirectory | Gets or sets the uncompile directory.
UncompileFile | Gets or sets the uncompile file.

See Also

HxCompiler Class
MSBuild.Community.Tasks.HtmlHelp Namespace


LogFile Property

[image]

.NET Framework Class Library
HxCompiler..::.LogFile Property
HxCompiler Class See Also Send Feedback

Gets or sets the log file.

Namespace: MSBuild.Community.Tasks.HtmlHelp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property LogFile As String
C#
public string LogFile { get; set; }
Visual C++
public:
property String^ LogFile {
    String^ get ();
    void set (String^ value);
}

Field Value

The log file.

See Also

HxCompiler Class
MSBuild.Community.Tasks.HtmlHelp Namespace


NoErrorMessages Property

[image]

.NET Framework Class Library
HxCompiler..::.NoErrorMessages Property
HxCompiler Class See Also Send Feedback

Gets or sets a value indicating whether no error messages will be output.

Namespace: MSBuild.Community.Tasks.HtmlHelp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property NoErrorMessages As Boolean
C#
public bool NoErrorMessages { get; set; }
Visual C++
public:
property bool NoErrorMessages {
    bool get ();
    void set (bool value);
}

Field Value

true if no error messages; otherwise, false.

See Also

HxCompiler Class
MSBuild.Community.Tasks.HtmlHelp Namespace


NoInfoMessages Property

[image]

.NET Framework Class Library
HxCompiler..::.NoInfoMessages Property
HxCompiler Class See Also Send Feedback

Gets or sets a value indicating whether no info messages will be output.

Namespace: MSBuild.Community.Tasks.HtmlHelp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property NoInfoMessages As Boolean
C#
public bool NoInfoMessages { get; set; }
Visual C++
public:
property bool NoInfoMessages {
    bool get ();
    void set (bool value);
}

Field Value

true if no info messages; otherwise, false.

See Also

HxCompiler Class
MSBuild.Community.Tasks.HtmlHelp Namespace


NoWarningMessages Property

[image]

.NET Framework Class Library
HxCompiler..::.NoWarningMessages Property
HxCompiler Class See Also Send Feedback

Gets or sets a value indicating whether no warning messages will be output.

Namespace: MSBuild.Community.Tasks.HtmlHelp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property NoWarningMessages As Boolean
C#
public bool NoWarningMessages { get; set; }
Visual C++
public:
property bool NoWarningMessages {
    bool get ();
    void set (bool value);
}

Field Value

true if no warning messages; otherwise, false.

See Also

HxCompiler Class
MSBuild.Community.Tasks.HtmlHelp Namespace


OutputFile Property

[image]

.NET Framework Class Library
HxCompiler..::.OutputFile Property
HxCompiler Class See Also Send Feedback

Gets or sets the output file.

Namespace: MSBuild.Community.Tasks.HtmlHelp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property OutputFile As ITaskItem
C#
public ITaskItem OutputFile { get; set; }
Visual C++
public:
property ITaskItem^ OutputFile {
    ITaskItem^ get ();
    void set (ITaskItem^ value);
}

Field Value

The output file.

See Also

HxCompiler Class
MSBuild.Community.Tasks.HtmlHelp Namespace


ProjectFile Property

[image]

.NET Framework Class Library
HxCompiler..::.ProjectFile Property
HxCompiler Class See Also Send Feedback

Gets or sets the project file path.

Namespace: MSBuild.Community.Tasks.HtmlHelp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property ProjectFile As ITaskItem
C#
[RequiredAttribute]
public ITaskItem ProjectFile { get; set; }
Visual C++
[RequiredAttribute]
public:
property ITaskItem^ ProjectFile {
    ITaskItem^ get ();
    void set (ITaskItem^ value);
}

Field Value

The project file path.

See Also

HxCompiler Class
MSBuild.Community.Tasks.HtmlHelp Namespace


ProjectRoot Property

[image]

.NET Framework Class Library
HxCompiler..::.ProjectRoot Property
HxCompiler Class See Also Send Feedback

Gets or sets the project root.

Namespace: MSBuild.Community.Tasks.HtmlHelp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ProjectRoot As String
C#
public string ProjectRoot { get; set; }
Visual C++
public:
property String^ ProjectRoot {
    String^ get ();
    void set (String^ value);
}

Field Value

The project root.

See Also

HxCompiler Class
MSBuild.Community.Tasks.HtmlHelp Namespace


QuiteMode Property

[image]

.NET Framework Class Library
HxCompiler..::.QuiteMode Property
HxCompiler Class See Also Send Feedback

Gets or sets a value indicating quite mode.

Namespace: MSBuild.Community.Tasks.HtmlHelp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property QuiteMode As Boolean
C#
public bool QuiteMode { get; set; }
Visual C++
public:
property bool QuiteMode {
    bool get ();
    void set (bool value);
}

Field Value

true if quite mode; otherwise, false.

See Also

HxCompiler Class
MSBuild.Community.Tasks.HtmlHelp Namespace


StandardOutputLoggingImportance Property

[image]

.NET Framework Class Library
HxCompiler..::.StandardOutputLoggingImportance Property
HxCompiler Class See Also Send Feedback

Gets the MessageImportance with which to log errors.

Namespace: MSBuild.Community.Tasks.HtmlHelp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property StandardOutputLoggingImportance As MessageImportance
C#
protected override MessageImportance StandardOutputLoggingImportance { get; }
Visual C++
protected:
virtual property MessageImportance StandardOutputLoggingImportance {
    MessageImportance get () override;
}

Field Value

Return Value

The MessageImportance with which to log errors.

See Also

HxCompiler Class
MSBuild.Community.Tasks.HtmlHelp Namespace


ToolName Property

[image]

.NET Framework Class Library
HxCompiler..::.ToolName Property
HxCompiler Class See Also Send Feedback

Gets the name of the executable file to run.

Namespace: MSBuild.Community.Tasks.HtmlHelp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ToolName As String
C#
protected override string ToolName { get; }
Visual C++
protected:
virtual property String^ ToolName {
    String^ get () override;
}

Field Value

Return Value

The name of the executable file to run.

See Also

HxCompiler Class
MSBuild.Community.Tasks.HtmlHelp Namespace


UncompileDirectory Property

[image]

.NET Framework Class Library
HxCompiler..::.UncompileDirectory Property
HxCompiler Class See Also Send Feedback

Gets or sets the uncompile directory.

Namespace: MSBuild.Community.Tasks.HtmlHelp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property UncompileDirectory As String
C#
public string UncompileDirectory { get; set; }
Visual C++
public:
property String^ UncompileDirectory {
    String^ get ();
    void set (String^ value);
}

Field Value

The uncompile directory.

See Also

HxCompiler Class
MSBuild.Community.Tasks.HtmlHelp Namespace


UncompileFile Property

[image]

.NET Framework Class Library
HxCompiler..::.UncompileFile Property
HxCompiler Class See Also Send Feedback

Gets or sets the uncompile file.

Namespace: MSBuild.Community.Tasks.HtmlHelp
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property UncompileFile As ITaskItem
C#
public ITaskItem UncompileFile { get; set; }
Visual C++
public:
property ITaskItem^ UncompileFile {
    ITaskItem^ get ();
    void set (ITaskItem^ value);
}

Field Value

The uncompile file.

See Also

HxCompiler Class
MSBuild.Community.Tasks.HtmlHelp Namespace


MSBuild.Community.Tasks.IIS Namespace

[image]

.NET Framework Class Library
MSBuild.Community.Tasks.IIS Namespace
Send Feedback

Classes

Class | Description
AppPoolController | Allows control for an application pool on a local or remote machine with IIS installed. The default is to control the application pool on the local machine. If connecting to a remote machine, you can specify the Username and Password for the task to run under.
AppPoolCreate | Creates a new application pool on a local or remote machine with IIS installed. The default is to create the new application pool on the local machine. If connecting to a remote machine, you can specify the Username and Password for the task to run under.
AppPoolDelete | Deletes an existing application pool on a local or remote machine with IIS installed. The default is to delete an existing application pool on the local machine. If connecting to a remote machine, you can specify the Username and Password for the task to run under.
WebBase | Base task for any IIS-related task.
WebDirectoryCreate | Creates a new web directory on a local or remote machine with IIS installed. The default is to create the new web directory on the local machine. The physical path is required to already exist on the target machine. If connecting to a remote machine, you can specify the Username and Password for the task to run under.
WebDirectoryDelete | Deletes a web directory on a local or remote machine with IIS installed. The default is to delete the web directory on the local machine. If connecting to a remote machine, you can specify the Username and Password for the task to run under.
WebDirectoryScriptMap | Sets an application mapping for a filename extension on an existing web directory.
WebDirectorySetting | Reads and modifies a web directory configuration setting.

Enumerations

Enumeration | Description
AppPoolControllerActions | Actions the AppPoolController can do.
WebBase..::.ApplicationPoolAction | Defines the possible application pool actions to be performed.
WebBase..::.ApplicationPoolState | Defines the current application pool state.
WebBase..::.IISVersion | Defines the possible IIS versions supported by the task.


AppPoolController Class

[image]

.NET Framework Class Library
AppPoolController Class
Members Example See Also Send Feedback

Allows control for an application pool on a local or remote machine with IIS installed. The default is to control the application pool on the local machine. If connecting to a remote machine, you can specify the Username and Password for the task to run under.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class AppPoolController _
    Inherits WebBase
C#
public class AppPoolController : WebBase
Visual C++
public ref class AppPoolController : public WebBase

Examples

Restart an application pool on the local machine.
Copy Code
            <AppPoolController AppPoolName="MyAppPool" Action="Restart" />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.IIS..::.WebBase
MSBuild.Community.Tasks.IIS..::.AppPoolController

See Also

AppPoolController Members
MSBuild.Community.Tasks.IIS Namespace


AppPoolController Members

[image] [image]

.NET Framework Class Library
AppPoolController Members
AppPoolController Class Constructors Methods Fields Properties See Also Send Feedback

The AppPoolController type exposes the following members.

Constructors

Name | Description
AppPoolController |

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetIISVersion | Gets the IIS version. (Inherited from WebBase.)
GetRemoteOSVersion | Gets the remote machine OS version. (Inherited from WebBase.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)
VerifyIISRoot | Verifies that the IIS root exists based on the ServerName and ServerPort. (Inherited from WebBase.)

Fields

Name | Description
mIISVersion | IIS version. (Inherited from WebBase.)

Properties

Name | Description
Action | Gets or sets the application pool action.
ApplicationPoolName | Gets or sets the name of the app pool.
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostHeaderName | Gets or sets host header. Used when you have more than one website in IIS that have the same port but different host headers. (Inherited from WebBase.)
HostObject | (Inherited from Task.)
IISApplicationPath | Gets or sets the application path. (Inherited from WebBase.)
IISAppPoolPath | Gets or sets the IIS application pool path. (Inherited from WebBase.)
IISServerPath | Gets or sets the IIS server path. (Inherited from WebBase.)
Log | (Inherited from Task.)
Password | Gets or sets the password for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (Inherited from WebBase.)
ServerName | Gets or sets the name of the server. The default value is 'localhost'. (Inherited from WebBase.)
ServerPort | Gets or sets the server port. (Inherited from WebBase.)
TaskResources | (Inherited from Task.)
Username | Gets or sets the username for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (Inherited from WebBase.)

See Also

AppPoolController Class
MSBuild.Community.Tasks.IIS Namespace


AppPoolController Constructor

[image]

.NET Framework Class Library
AppPoolController Constructor
AppPoolController Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public AppPoolController()
Visual C++
public:
AppPoolController()

See Also

AppPoolController Class
MSBuild.Community.Tasks.IIS Namespace


AppPoolController Fields

[image] [image]

.NET Framework Class Library
AppPoolController Fields
AppPoolController Class See Also Send Feedback

The AppPoolController type exposes the following members.

Fields

Name | Description
mIISVersion | IIS version. (Inherited from WebBase.)

See Also

AppPoolController Class
MSBuild.Community.Tasks.IIS Namespace


AppPoolController Methods

[image] [image]

.NET Framework Class Library
AppPoolController Methods
AppPoolController Class See Also Send Feedback

The AppPoolController type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetIISVersion | Gets the IIS version. (Inherited from WebBase.)
GetRemoteOSVersion | Gets the remote machine OS version. (Inherited from WebBase.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)
VerifyIISRoot | Verifies that the IIS root exists based on the ServerName and ServerPort. (Inherited from WebBase.)

See Also

AppPoolController Class
MSBuild.Community.Tasks.IIS Namespace


Execute Method

[image]

.NET Framework Class Library
AppPoolController..::.Execute Method
AppPoolController Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

True if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

AppPoolController Class
MSBuild.Community.Tasks.IIS Namespace


AppPoolController Properties

[image] [image]

.NET Framework Class Library
AppPoolController Properties
AppPoolController Class See Also Send Feedback

The AppPoolController type exposes the following members.

Properties

Name | Description
Action | Gets or sets the application pool action.
ApplicationPoolName | Gets or sets the name of the app pool.
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostHeaderName | Gets or sets host header. Used when you have more than one website in IIS that have the same port but different host headers. (Inherited from WebBase.)
HostObject | (Inherited from Task.)
IISApplicationPath | Gets or sets the application path. (Inherited from WebBase.)
IISAppPoolPath | Gets or sets the IIS application pool path. (Inherited from WebBase.)
IISServerPath | Gets or sets the IIS server path. (Inherited from WebBase.)
Log | (Inherited from Task.)
Password | Gets or sets the password for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (Inherited from WebBase.)
ServerName | Gets or sets the name of the server. The default value is 'localhost'. (Inherited from WebBase.)
ServerPort | Gets or sets the server port. (Inherited from WebBase.)
TaskResources | (Inherited from Task.)
Username | Gets or sets the username for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (Inherited from WebBase.)

See Also

AppPoolController Class
MSBuild.Community.Tasks.IIS Namespace


Action Property

[image]

.NET Framework Class Library
AppPoolController..::.Action Property
AppPoolController Class See Also Send Feedback

Gets or sets the application pool action.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property Action As String
C#
[RequiredAttribute]
public string Action { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ Action {
    String^ get ();
    void set (String^ value);
}

Field Value

The application pool action.

See Also

AppPoolController Class
MSBuild.Community.Tasks.IIS Namespace


ApplicationPoolName Property

[image]

.NET Framework Class Library
AppPoolController..::.ApplicationPoolName Property
AppPoolController Class See Also Send Feedback

Gets or sets the name of the app pool.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property ApplicationPoolName As String
C#
[RequiredAttribute]
public string ApplicationPoolName { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ ApplicationPoolName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the app pool.

See Also

AppPoolController Class
MSBuild.Community.Tasks.IIS Namespace


AppPoolControllerActions Enumeration

[image]

.NET Framework Class Library
AppPoolControllerActions Enumeration
See Also Send Feedback

Actions the AppPoolController can do.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration AppPoolControllerActions
C#
public enum AppPoolControllerActions
Visual C++
public enum class AppPoolControllerActions

Members

Member name | Description
Start | Start the applicaiton pool
Stop | Stop the applicaiton pool
Restart | Restart the applicaiton pool
Recycle | Recycle the applicaiton pool

See Also

MSBuild.Community.Tasks.IIS Namespace


AppPoolCreate Class

[image]

.NET Framework Class Library
AppPoolCreate Class
Members Example See Also Send Feedback

Creates a new application pool on a local or remote machine with IIS installed. The default is to create the new application pool on the local machine. If connecting to a remote machine, you can specify the Username and Password for the task to run under.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class AppPoolCreate _
    Inherits WebBase
C#
public class AppPoolCreate : WebBase
Visual C++
public ref class AppPoolCreate : public WebBase

Examples

Create a new application pool on the local machine.
Copy Code
            <AppPoolCreate AppPoolName="MyAppPool" />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.IIS..::.WebBase
MSBuild.Community.Tasks.IIS..::.AppPoolCreate

See Also

AppPoolCreate Members
MSBuild.Community.Tasks.IIS Namespace


AppPoolCreate Members

[image] [image]

.NET Framework Class Library
AppPoolCreate Members
AppPoolCreate Class Constructors Methods Fields Properties See Also Send Feedback

The AppPoolCreate type exposes the following members.

Constructors

Name | Description
AppPoolCreate |

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetIISVersion | Gets the IIS version. (Inherited from WebBase.)
GetRemoteOSVersion | Gets the remote machine OS version. (Inherited from WebBase.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)
VerifyIISRoot | Verifies that the IIS root exists based on the ServerName and ServerPort. (Inherited from WebBase.)

Fields

Name | Description
mIISVersion | IIS version. (Inherited from WebBase.)

Properties

Name | Description
ApplicationPoolName | Gets or sets the name of the application pool.
AppPoolAutoStart | The AppPoolAutoStart property indicates to the World Wide Web Publishing Service (WWW service) to automatically start an application pool when the application pool is created or when IIS is started, if the value of this property is set to true.
AppPoolIdentityType | The AppPoolIdentityType property allows application pools to run as a specific user account: 0 - The application pool runs as NT AUTHORITY\SYSTEM. 1 - The application pool runs as NT AUTHORITY\LOCAL SERVICE. 2 - The application pool runs as NT AUTHORITY\NETWORK SERVICE. 3 - The application pool runs as a specific user account, defined by the WAMUserName property.
AppPoolQueueLength | The AppPoolQueueLength property indicates to the Universal Listener how many requests to queue up for an application pool before rejecting future requests. When the limit for this property is exceeded, IIS rejects the additional requests with a 503 error.
AutoShutdownAppPoolExe | The AutoShutdownAppPoolExe property specifies an executable to run when the World Wide Web Publishing Service (WWW service) shuts down an application pool for rapid fail protection. You can use the AutoShutdownAppPoolParams property to send parameters to the executable.
AutoShutdownAppPoolParams | The AutoShutdownAppPoolParams property specifies any command-line parameters for the executable that is specified in the AutoShutdownAppPoolExe property. You can use these two properties in the following way to send e-mail, for example, when the World Wide Web Publishing Service (WWW service) shuts down an application pool for rapid fail protection: AutoShutdownAppPoolExe = "C:\LogAndSendMail.bat" AutoShutdownAppPoolParams = "-AppPoolName %1%" where %1% represents the application pool name.
BuildEngine | (Inherited from Task.)
CPUAction | The CPUAction property configures the action(s) that IIS takes when Microsoft Windows NT ® job objects run. Only one Windows NT job object exists per application pool, therefore the CPUAction property is configured on a per application pool basis. Possible values: 0 - No action is taken except that a warning is written to the event log when the CPU limit is exceeded. 1 - Application pool worker processes that exceed their CPU limit will be forced to shut down.
CPULimit | The CPULimit property configures the maximum percentage of CPU resources that worker processes in an application pool are allowed to consume over a period of time, as indicated by the CPUResetInterval property. Set this property by specifying a percentage of CPU usage, multiplied by 1000. For example, if you want the CPU usage limit to be 50%, set CPULimit to 50,000.
CPUResetInterval | The CPUResetInterval property specifies the reset period (in minutes) for CPU monitoring and throttling limits on the application pool. When the number of minutes elapsed since the last process accounting reset equals the number specified by this property, IIS will reset the CPU timers for both the logging and limit intervals. Setting the value of this property to 0 disables CPU monitoring.
DisallowOverlappingRotation | The DisallowOverlappingRotation property specifies whether or not the World Wide Web Publishing Service (WWW Service) should start up another worker process to replace the existing worker process while it is shutting down.
DisallowRotationOnConfigChange | The DisallowRotationOnConfigChange property specifies whether or not the World Wide Web Publishing Service (WWW Service) should rotate worker processes in an application pool when the configuration has changed. This means that the worker processes will not pick up application pool changes to values passed to the worker process, such as IdleTimeout and PeriodicRestartRequests.
HelpKeywordPrefix | (Inherited from Task.)
HostHeaderName | Gets or sets host header. Used when you have more than one website in IIS that have the same port but different host headers. (Inherited from WebBase.)
HostObject | (Inherited from Task.)
IdleTimeout | The IdleTimeout property specifies how long (in minutes) a worker process should run idle if no new requests are received and the worker process is not processing requests. After the allotted time passes, the worker process should request to be shut down by the World Wide Web Publishing Service (WWW Service).
IISApplicationPath | Gets or sets the application path. (Inherited from WebBase.)
IISAppPoolPath | Gets or sets the IIS application pool path. (Inherited from WebBase.)
IISServerPath | Gets or sets the IIS server path. (Inherited from WebBase.)
LoadBalancerCapabilities | The LoadBalancerCapabilities property specifies behavior when a service is unavailable. A setting of 1 terminates the connection. A setting of 2 sends error code 503.
Log | (Inherited from Task.)
LogEventOnRecycle | The LogEventOnRecycle property specifies that IIS should log an event when an application pool is recycled. Application pools recycle for a variety of reasons. In order for IIS to log the event, the LogEventOnRecycle property must have a bit set corresponding to the reason for the recycle.
LogonMethod | The LogonMethod property contains an integer that specifies the logon method for cleartext logons. Valid settings are: 0 for interactive logon. 1 for batch logon. 2 for network logon. 3 for cleartext logon.
MaxProcesses | The MaxProcesses property determines the maximum number of worker processes an application pool allows to service requests for an application pool. This property cannot be set to 0 because there are no unmanaged pools.
OrphanActionExe | The OrphanActionExe property specifies an executable to run when the World Wide Web Publishing Service (WWW service) orphans a worker process. You can use the OrphanActionParams property to send parameters to the executable.
OrphanActionParams | The OrphanActionParams property specifies command-line parameters for the executable specified by the OrphanActionExe property.
OrphanWorkerProcess | The OrphanWorkerProcess property, when set to true, notifies the World Wide Web Publishing Service (WWW Service) not to terminate a worker process that fails to respond to pings, but to instead orphan the worker process in the application pool if the worker process suffers fatal errors.
Password | Gets or sets the password for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (Inherited from WebBase.)
PeriodicRestartMemory | The PeriodicRestartMemory property specifies the amount of virtual memory (in KB) that a worker process can use before the worker process recycles. The maximum value supported for this property is 4,294,967 KB.
PeriodicRestartPrivateMemory | The PeriodicRestartPrivateMemory property specifies the amount of private memory (in KB) that a worker process can use before the worker process recycles. The maximum value supported for this property is 4,294,967 KB.
PeriodicRestartRequests | The PeriodicRestartRequests property indicates the number of requests the OOP application should process, after which it is recycled.
PeriodicRestartSchedule | The PeriodicRestartSchedule property specifies the time (in 24 hour format) that the application will be rotated. Each time is in local time and is specified in the following format: PeriodicRestartSchedule="hh:mm,hh:mm,hh:mm"
PeriodicRestartTime | The PeriodicRestartTime property specifies the period of time, in minutes, after which IIS rotates an isolated OOP application. Setting the value of this property to 0 disables the property. The maximum supported value for this property is 71,582.
PingingEnabled | The PingingEnabled property specifies whether the World Wide Web Publishing Service (WWW Service) should periodically monitor the health of a worker process. Setting the value of this property to true indicates to the WWW service to monitor the worker processes to ensure that the they are running and healthy.
PingInterval | The PingInterval property specifies the period of time (in seconds) between health-monitoring pings that the World Wide Web Publishing Service (WWW Service) sends to a worker process.
PingResponseTime | The PingResponseTime property specifies the amount of time (in seconds) that a worker process is given to respond to a health monitoring ping. After the time limit is exceeded, the World Wide Web Publishing Service (WWW Service) terminates the worker process.
RapidFailProtection | Setting the RapidFailProtection property to true instructs the World Wide Web Publishing Service (WWW service) to put all applications in an application pool out of service if the number of worker process crashes has reached the maximum specified by the RapidFailProtectionMaxCrashes property, within the number of minutes specified by the RapidFailProtectionInterval property.
RapidFailProtectionInterval | The RapidFailProtectionInterval property specifies the number of minutes before the failure count for a process is reset. See RapidFailProtection.
RapidFailProtectionMaxCrashes | The RapidFailProtectionMaxCrashes property specifies the maximum number of failures allowed within the number of minutes specified by the RapidFailProtectionInterval property. See RapidFailProtection.
ServerName | Gets or sets the name of the server. The default value is 'localhost'. (Inherited from WebBase.)
ServerPort | Gets or sets the server port. (Inherited from WebBase.)
ShutdownTimeLimit | The ShutdownTimeLimit property specifies the amount of time (in seconds) after a recycle threshold has been reached that IIS waits for all old requests to finish running in a worker process before terminating the worker process.
SMPAffinitized | Setting the SMPAffinitized property to true indicates that a particular worker process assigned to an application pool should be assigned to a given CPU. This property is used in conjunction with the SMPProcessorAffinityMask property to configure a particular processor a worker process will be assigned to.
SMPProcessorAffinityMask | The SMPProcessorAffinityMask property configures the hexadecimal processor mask. The hexadecimal processor mask indicates to which CPU the worker processes in an application pool should be bound. Before this property takes affect, the SMPAffinitized property must be set to true for the application pool. These properties cannot be set through IIS Manager. Do not set this property to zero. Doing so causes no SMP affinity to be configured, creating an error condition. The default DWORD value is 4294967295 (or -1), which is represented in hexadecimal as 0xFFFFFFFF. A value of 0xFFFFFFFF in SMPProcessorAffinityMask indicates that all processors are enabled.
StartupTimeLimit | The value of the StartupTimeLimit property specifies the amount of time (in seconds) that the World Wide Web Publishing Service (WWW Service) should wait for a worker process to finish starting up and reporting to the WWW Service.
TaskResources | (Inherited from Task.)
Username | Gets or sets the username for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (Inherited from WebBase.)
WAMUserName | The WAMUserName property specifies the account user name that IIS uses by default as the COM+ application identity for newly created IIS out-of-process applications. The values of this property and its companion property, WAMUserPass, are set when IIS is installed, and match the user name and password values in the Microsoft Windows user account, which is established at the same time. Changing the value of this property is not recommended. If you do, change it to a valid Windows user account, and change WAMUserPass to the corresponding password for the new account. Important: Changes to WAMUserName and WAMUserPass may disrupt the operation of existing IIS out-of-process applications. You can synchronize application identities using Component Services to edit the user name and password values, found on the Identity tab of the property sheet for each package. In-process applications are not affected by these property values.
WAMUserPass | The WAMUserPass property specifies the password for the account that IIS uses by default as the COM+ application identity for newly created IIS out-of-process applications. The values of this property and its companion property, WAMUserName, are set when IIS is installed, and match the password and user name values in the Microsoft Windows user account (IWAM_ MachineName, where MachineName is the name of the machine on which IIS is installed) established at the same time. Important: Changing the value of this property is not recommended. If you do, you must change the Windows account password to the identical value. You must also synchronize existing IIS out-of-process application identities, using Component Services to edit the user name and password values, which are found on the Identity tab of the property sheet for each package. In-process applications are not affected by these property values.

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


AppPoolCreate Constructor

[image]

.NET Framework Class Library
AppPoolCreate Constructor
AppPoolCreate Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public AppPoolCreate()
Visual C++
public:
AppPoolCreate()

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


AppPoolCreate Fields

[image] [image]

.NET Framework Class Library
AppPoolCreate Fields
AppPoolCreate Class See Also Send Feedback

The AppPoolCreate type exposes the following members.

Fields

Name | Description
mIISVersion | IIS version. (Inherited from WebBase.)

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


AppPoolCreate Methods

[image] [image]

.NET Framework Class Library
AppPoolCreate Methods
AppPoolCreate Class See Also Send Feedback

The AppPoolCreate type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetIISVersion | Gets the IIS version. (Inherited from WebBase.)
GetRemoteOSVersion | Gets the remote machine OS version. (Inherited from WebBase.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)
VerifyIISRoot | Verifies that the IIS root exists based on the ServerName and ServerPort. (Inherited from WebBase.)

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


Execute Method

[image]

.NET Framework Class Library
AppPoolCreate..::.Execute Method
AppPoolCreate Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

True if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


AppPoolCreate Properties

[image] [image]

.NET Framework Class Library
AppPoolCreate Properties
AppPoolCreate Class See Also Send Feedback

The AppPoolCreate type exposes the following members.

Properties

Name | Description
ApplicationPoolName | Gets or sets the name of the application pool.
AppPoolAutoStart | The AppPoolAutoStart property indicates to the World Wide Web Publishing Service (WWW service) to automatically start an application pool when the application pool is created or when IIS is started, if the value of this property is set to true.
AppPoolIdentityType | The AppPoolIdentityType property allows application pools to run as a specific user account: 0 - The application pool runs as NT AUTHORITY\SYSTEM. 1 - The application pool runs as NT AUTHORITY\LOCAL SERVICE. 2 - The application pool runs as NT AUTHORITY\NETWORK SERVICE. 3 - The application pool runs as a specific user account, defined by the WAMUserName property.
AppPoolQueueLength | The AppPoolQueueLength property indicates to the Universal Listener how many requests to queue up for an application pool before rejecting future requests. When the limit for this property is exceeded, IIS rejects the additional requests with a 503 error.
AutoShutdownAppPoolExe | The AutoShutdownAppPoolExe property specifies an executable to run when the World Wide Web Publishing Service (WWW service) shuts down an application pool for rapid fail protection. You can use the AutoShutdownAppPoolParams property to send parameters to the executable.
AutoShutdownAppPoolParams | The AutoShutdownAppPoolParams property specifies any command-line parameters for the executable that is specified in the AutoShutdownAppPoolExe property. You can use these two properties in the following way to send e-mail, for example, when the World Wide Web Publishing Service (WWW service) shuts down an application pool for rapid fail protection: AutoShutdownAppPoolExe = "C:\LogAndSendMail.bat" AutoShutdownAppPoolParams = "-AppPoolName %1%" where %1% represents the application pool name.
BuildEngine | (Inherited from Task.)
CPUAction | The CPUAction property configures the action(s) that IIS takes when Microsoft Windows NT ® job objects run. Only one Windows NT job object exists per application pool, therefore the CPUAction property is configured on a per application pool basis. Possible values: 0 - No action is taken except that a warning is written to the event log when the CPU limit is exceeded. 1 - Application pool worker processes that exceed their CPU limit will be forced to shut down.
CPULimit | The CPULimit property configures the maximum percentage of CPU resources that worker processes in an application pool are allowed to consume over a period of time, as indicated by the CPUResetInterval property. Set this property by specifying a percentage of CPU usage, multiplied by 1000. For example, if you want the CPU usage limit to be 50%, set CPULimit to 50,000.
CPUResetInterval | The CPUResetInterval property specifies the reset period (in minutes) for CPU monitoring and throttling limits on the application pool. When the number of minutes elapsed since the last process accounting reset equals the number specified by this property, IIS will reset the CPU timers for both the logging and limit intervals. Setting the value of this property to 0 disables CPU monitoring.
DisallowOverlappingRotation | The DisallowOverlappingRotation property specifies whether or not the World Wide Web Publishing Service (WWW Service) should start up another worker process to replace the existing worker process while it is shutting down.
DisallowRotationOnConfigChange | The DisallowRotationOnConfigChange property specifies whether or not the World Wide Web Publishing Service (WWW Service) should rotate worker processes in an application pool when the configuration has changed. This means that the worker processes will not pick up application pool changes to values passed to the worker process, such as IdleTimeout and PeriodicRestartRequests.
HelpKeywordPrefix | (Inherited from Task.)
HostHeaderName | Gets or sets host header. Used when you have more than one website in IIS that have the same port but different host headers. (Inherited from WebBase.)
HostObject | (Inherited from Task.)
IdleTimeout | The IdleTimeout property specifies how long (in minutes) a worker process should run idle if no new requests are received and the worker process is not processing requests. After the allotted time passes, the worker process should request to be shut down by the World Wide Web Publishing Service (WWW Service).
IISApplicationPath | Gets or sets the application path. (Inherited from WebBase.)
IISAppPoolPath | Gets or sets the IIS application pool path. (Inherited from WebBase.)
IISServerPath | Gets or sets the IIS server path. (Inherited from WebBase.)
LoadBalancerCapabilities | The LoadBalancerCapabilities property specifies behavior when a service is unavailable. A setting of 1 terminates the connection. A setting of 2 sends error code 503.
Log | (Inherited from Task.)
LogEventOnRecycle | The LogEventOnRecycle property specifies that IIS should log an event when an application pool is recycled. Application pools recycle for a variety of reasons. In order for IIS to log the event, the LogEventOnRecycle property must have a bit set corresponding to the reason for the recycle.
LogonMethod | The LogonMethod property contains an integer that specifies the logon method for cleartext logons. Valid settings are: 0 for interactive logon. 1 for batch logon. 2 for network logon. 3 for cleartext logon.
MaxProcesses | The MaxProcesses property determines the maximum number of worker processes an application pool allows to service requests for an application pool. This property cannot be set to 0 because there are no unmanaged pools.
OrphanActionExe | The OrphanActionExe property specifies an executable to run when the World Wide Web Publishing Service (WWW service) orphans a worker process. You can use the OrphanActionParams property to send parameters to the executable.
OrphanActionParams | The OrphanActionParams property specifies command-line parameters for the executable specified by the OrphanActionExe property.
OrphanWorkerProcess | The OrphanWorkerProcess property, when set to true, notifies the World Wide Web Publishing Service (WWW Service) not to terminate a worker process that fails to respond to pings, but to instead orphan the worker process in the application pool if the worker process suffers fatal errors.
Password | Gets or sets the password for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (Inherited from WebBase.)
PeriodicRestartMemory | The PeriodicRestartMemory property specifies the amount of virtual memory (in KB) that a worker process can use before the worker process recycles. The maximum value supported for this property is 4,294,967 KB.
PeriodicRestartPrivateMemory | The PeriodicRestartPrivateMemory property specifies the amount of private memory (in KB) that a worker process can use before the worker process recycles. The maximum value supported for this property is 4,294,967 KB.
PeriodicRestartRequests | The PeriodicRestartRequests property indicates the number of requests the OOP application should process, after which it is recycled.
PeriodicRestartSchedule | The PeriodicRestartSchedule property specifies the time (in 24 hour format) that the application will be rotated. Each time is in local time and is specified in the following format: PeriodicRestartSchedule="hh:mm,hh:mm,hh:mm"
PeriodicRestartTime | The PeriodicRestartTime property specifies the period of time, in minutes, after which IIS rotates an isolated OOP application. Setting the value of this property to 0 disables the property. The maximum supported value for this property is 71,582.
PingingEnabled | The PingingEnabled property specifies whether the World Wide Web Publishing Service (WWW Service) should periodically monitor the health of a worker process. Setting the value of this property to true indicates to the WWW service to monitor the worker processes to ensure that the they are running and healthy.
PingInterval | The PingInterval property specifies the period of time (in seconds) between health-monitoring pings that the World Wide Web Publishing Service (WWW Service) sends to a worker process.
PingResponseTime | The PingResponseTime property specifies the amount of time (in seconds) that a worker process is given to respond to a health monitoring ping. After the time limit is exceeded, the World Wide Web Publishing Service (WWW Service) terminates the worker process.
RapidFailProtection | Setting the RapidFailProtection property to true instructs the World Wide Web Publishing Service (WWW service) to put all applications in an application pool out of service if the number of worker process crashes has reached the maximum specified by the RapidFailProtectionMaxCrashes property, within the number of minutes specified by the RapidFailProtectionInterval property.
RapidFailProtectionInterval | The RapidFailProtectionInterval property specifies the number of minutes before the failure count for a process is reset. See RapidFailProtection.
RapidFailProtectionMaxCrashes | The RapidFailProtectionMaxCrashes property specifies the maximum number of failures allowed within the number of minutes specified by the RapidFailProtectionInterval property. See RapidFailProtection.
ServerName | Gets or sets the name of the server. The default value is 'localhost'. (Inherited from WebBase.)
ServerPort | Gets or sets the server port. (Inherited from WebBase.)
ShutdownTimeLimit | The ShutdownTimeLimit property specifies the amount of time (in seconds) after a recycle threshold has been reached that IIS waits for all old requests to finish running in a worker process before terminating the worker process.
SMPAffinitized | Setting the SMPAffinitized property to true indicates that a particular worker process assigned to an application pool should be assigned to a given CPU. This property is used in conjunction with the SMPProcessorAffinityMask property to configure a particular processor a worker process will be assigned to.
SMPProcessorAffinityMask | The SMPProcessorAffinityMask property configures the hexadecimal processor mask. The hexadecimal processor mask indicates to which CPU the worker processes in an application pool should be bound. Before this property takes affect, the SMPAffinitized property must be set to true for the application pool. These properties cannot be set through IIS Manager. Do not set this property to zero. Doing so causes no SMP affinity to be configured, creating an error condition. The default DWORD value is 4294967295 (or -1), which is represented in hexadecimal as 0xFFFFFFFF. A value of 0xFFFFFFFF in SMPProcessorAffinityMask indicates that all processors are enabled.
StartupTimeLimit | The value of the StartupTimeLimit property specifies the amount of time (in seconds) that the World Wide Web Publishing Service (WWW Service) should wait for a worker process to finish starting up and reporting to the WWW Service.
TaskResources | (Inherited from Task.)
Username | Gets or sets the username for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (Inherited from WebBase.)
WAMUserName | The WAMUserName property specifies the account user name that IIS uses by default as the COM+ application identity for newly created IIS out-of-process applications. The values of this property and its companion property, WAMUserPass, are set when IIS is installed, and match the user name and password values in the Microsoft Windows user account, which is established at the same time. Changing the value of this property is not recommended. If you do, change it to a valid Windows user account, and change WAMUserPass to the corresponding password for the new account. Important: Changes to WAMUserName and WAMUserPass may disrupt the operation of existing IIS out-of-process applications. You can synchronize application identities using Component Services to edit the user name and password values, found on the Identity tab of the property sheet for each package. In-process applications are not affected by these property values.
WAMUserPass | The WAMUserPass property specifies the password for the account that IIS uses by default as the COM+ application identity for newly created IIS out-of-process applications. The values of this property and its companion property, WAMUserName, are set when IIS is installed, and match the password and user name values in the Microsoft Windows user account (IWAM_ MachineName, where MachineName is the name of the machine on which IIS is installed) established at the same time. Important: Changing the value of this property is not recommended. If you do, you must change the Windows account password to the identical value. You must also synchronize existing IIS out-of-process application identities, using Component Services to edit the user name and password values, which are found on the Identity tab of the property sheet for each package. In-process applications are not affected by these property values.

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


ApplicationPoolName Property

[image]

.NET Framework Class Library
AppPoolCreate..::.ApplicationPoolName Property
AppPoolCreate Class See Also Send Feedback

Gets or sets the name of the application pool.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property ApplicationPoolName As String
C#
[RequiredAttribute]
public string ApplicationPoolName { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ ApplicationPoolName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the application pool.

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


AppPoolAutoStart Property

[image]

.NET Framework Class Library
AppPoolCreate..::.AppPoolAutoStart Property
AppPoolCreate Class See Also Send Feedback

The AppPoolAutoStart property indicates to the World Wide Web Publishing Service (WWW service) to automatically start an application pool when the application pool is created or when IIS is started, if the value of this property is set to true.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AppPoolAutoStart As Boolean
C#
public bool AppPoolAutoStart { get; set; }
Visual C++
public:
property bool AppPoolAutoStart {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if AppPoolAutoStart is enabled or disabled.

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


AppPoolIdentityType Property

[image]

.NET Framework Class Library
AppPoolCreate..::.AppPoolIdentityType Property
AppPoolCreate Class See Also Send Feedback

The AppPoolIdentityType property allows application pools to run as a specific user account: 0 - The application pool runs as NT AUTHORITY\SYSTEM. 1 - The application pool runs as NT AUTHORITY\LOCAL SERVICE. 2 - The application pool runs as NT AUTHORITY\NETWORK SERVICE. 3 - The application pool runs as a specific user account, defined by the WAMUserName property.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AppPoolIdentityType As Integer
C#
public int AppPoolIdentityType { get; set; }
Visual C++
public:
property int AppPoolIdentityType {
    int get ();
    void set (int value);
}

Field Value

Value indicating the application pool identity type.

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


AppPoolQueueLength Property

[image]

.NET Framework Class Library
AppPoolCreate..::.AppPoolQueueLength Property
AppPoolCreate Class See Also Send Feedback

The AppPoolQueueLength property indicates to the Universal Listener how many requests to queue up for an application pool before rejecting future requests. When the limit for this property is exceeded, IIS rejects the additional requests with a 503 error.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AppPoolQueueLength As Integer
C#
public int AppPoolQueueLength { get; set; }
Visual C++
public:
property int AppPoolQueueLength {
    int get ();
    void set (int value);
}

Field Value

Value indicating the application pool queue length.

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


AutoShutdownAppPoolExe Property

[image]

.NET Framework Class Library
AppPoolCreate..::.AutoShutdownAppPoolExe Property
AppPoolCreate Class See Also Send Feedback

The AutoShutdownAppPoolExe property specifies an executable to run when the World Wide Web Publishing Service (WWW service) shuts down an application pool for rapid fail protection. You can use the AutoShutdownAppPoolParams property to send parameters to the executable.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AutoShutdownAppPoolExe As String
C#
public string AutoShutdownAppPoolExe { get; set; }
Visual C++
public:
property String^ AutoShutdownAppPoolExe {
    String^ get ();
    void set (String^ value);
}

Field Value

Value indicating the application pool auto shutdown executable.

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


AutoShutdownAppPoolParams Property

[image]

.NET Framework Class Library
AppPoolCreate..::.AutoShutdownAppPoolParams Property
AppPoolCreate Class See Also Send Feedback

The AutoShutdownAppPoolParams property specifies any command-line parameters for the executable that is specified in the AutoShutdownAppPoolExe property. You can use these two properties in the following way to send e-mail, for example, when the World Wide Web Publishing Service (WWW service) shuts down an application pool for rapid fail protection: AutoShutdownAppPoolExe = "C:\LogAndSendMail.bat" AutoShutdownAppPoolParams = "-AppPoolName %1%" where %1% represents the application pool name.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AutoShutdownAppPoolParams As String
C#
public string AutoShutdownAppPoolParams { get; set; }
Visual C++
public:
property String^ AutoShutdownAppPoolParams {
    String^ get ();
    void set (String^ value);
}

Field Value

Value indicating the parameters for the application pool auto shutdown executable.

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


CPUAction Property

[image]

.NET Framework Class Library
AppPoolCreate..::.CPUAction Property
AppPoolCreate Class See Also Send Feedback

The CPUAction property configures the action(s) that IIS takes when Microsoft Windows NT ® job objects run. Only one Windows NT job object exists per application pool, therefore the CPUAction property is configured on a per application pool basis. Possible values: 0 - No action is taken except that a warning is written to the event log when the CPU limit is exceeded. 1 - Application pool worker processes that exceed their CPU limit will be forced to shut down.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property CPUAction As Integer
C#
public int CPUAction { get; set; }
Visual C++
public:
property int CPUAction {
    int get ();
    void set (int value);
}

Field Value

Value indicating the CPU action.

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


CPULimit Property

[image]

.NET Framework Class Library
AppPoolCreate..::.CPULimit Property
AppPoolCreate Class See Also Send Feedback

The CPULimit property configures the maximum percentage of CPU resources that worker processes in an application pool are allowed to consume over a period of time, as indicated by the CPUResetInterval property. Set this property by specifying a percentage of CPU usage, multiplied by 1000. For example, if you want the CPU usage limit to be 50%, set CPULimit to 50,000.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property CPULimit As Integer
C#
public int CPULimit { get; set; }
Visual C++
public:
property int CPULimit {
    int get ();
    void set (int value);
}

Field Value

Value indicating the CPU limit.

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


CPUResetInterval Property

[image]

.NET Framework Class Library
AppPoolCreate..::.CPUResetInterval Property
AppPoolCreate Class See Also Send Feedback

The CPUResetInterval property specifies the reset period (in minutes) for CPU monitoring and throttling limits on the application pool. When the number of minutes elapsed since the last process accounting reset equals the number specified by this property, IIS will reset the CPU timers for both the logging and limit intervals. Setting the value of this property to 0 disables CPU monitoring.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property CPUResetInterval As Integer
C#
public int CPUResetInterval { get; set; }
Visual C++
public:
property int CPUResetInterval {
    int get ();
    void set (int value);
}

Field Value

Value indicating the CPU reset interval.

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


DisallowOverlappingRotation Property

[image]

.NET Framework Class Library
AppPoolCreate..::.DisallowOverlappingRotation Property
AppPoolCreate Class See Also Send Feedback

The DisallowOverlappingRotation property specifies whether or not the World Wide Web Publishing Service (WWW Service) should start up another worker process to replace the existing worker process while it is shutting down.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property DisallowOverlappingRotation As Boolean
C#
public bool DisallowOverlappingRotation { get; set; }
Visual C++
public:
property bool DisallowOverlappingRotation {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating the DisallowOverlappingRotation.

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


DisallowRotationOnConfigChange Property

[image]

.NET Framework Class Library
AppPoolCreate..::.DisallowRotationOnConfigChange Property
AppPoolCreate Class See Also Send Feedback

The DisallowRotationOnConfigChange property specifies whether or not the World Wide Web Publishing Service (WWW Service) should rotate worker processes in an application pool when the configuration has changed. This means that the worker processes will not pick up application pool changes to values passed to the worker process, such as IdleTimeout and PeriodicRestartRequests.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property DisallowRotationOnConfigChange As Boolean
C#
public bool DisallowRotationOnConfigChange { get; set; }
Visual C++
public:
property bool DisallowRotationOnConfigChange {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating the DisallowRotationOnConfigChange.

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


IdleTimeout Property

[image]

.NET Framework Class Library
AppPoolCreate..::.IdleTimeout Property
AppPoolCreate Class See Also Send Feedback

The IdleTimeout property specifies how long (in minutes) a worker process should run idle if no new requests are received and the worker process is not processing requests. After the allotted time passes, the worker process should request to be shut down by the World Wide Web Publishing Service (WWW Service).

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property IdleTimeout As Integer
C#
public int IdleTimeout { get; set; }
Visual C++
public:
property int IdleTimeout {
    int get ();
    void set (int value);
}

Field Value

Value indicating the idle timeout.

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


LoadBalancerCapabilities Property

[image]

.NET Framework Class Library
AppPoolCreate..::.LoadBalancerCapabilities Property
AppPoolCreate Class See Also Send Feedback

The LoadBalancerCapabilities property specifies behavior when a service is unavailable. A setting of 1 terminates the connection. A setting of 2 sends error code 503.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property LoadBalancerCapabilities As Integer
C#
public int LoadBalancerCapabilities { get; set; }
Visual C++
public:
property int LoadBalancerCapabilities {
    int get ();
    void set (int value);
}

Field Value

Value indicating the load balancer capabilities.

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


LogEventOnRecycle Property

[image]

.NET Framework Class Library
AppPoolCreate..::.LogEventOnRecycle Property
AppPoolCreate Class See Also Send Feedback

The LogEventOnRecycle property specifies that IIS should log an event when an application pool is recycled. Application pools recycle for a variety of reasons. In order for IIS to log the event, the LogEventOnRecycle property must have a bit set corresponding to the reason for the recycle.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property LogEventOnRecycle As Integer
C#
public int LogEventOnRecycle { get; set; }
Visual C++
public:
property int LogEventOnRecycle {
    int get ();
    void set (int value);
}

Field Value

Value indicating which recycle events to log.

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


LogonMethod Property

[image]

.NET Framework Class Library
AppPoolCreate..::.LogonMethod Property
AppPoolCreate Class See Also Send Feedback

The LogonMethod property contains an integer that specifies the logon method for cleartext logons. Valid settings are: 0 for interactive logon. 1 for batch logon. 2 for network logon. 3 for cleartext logon.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property LogonMethod As Integer
C#
public int LogonMethod { get; set; }
Visual C++
public:
property int LogonMethod {
    int get ();
    void set (int value);
}

Field Value

Value indicating the logon method.

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


MaxProcesses Property

[image]

.NET Framework Class Library
AppPoolCreate..::.MaxProcesses Property
AppPoolCreate Class See Also Send Feedback

The MaxProcesses property determines the maximum number of worker processes an application pool allows to service requests for an application pool. This property cannot be set to 0 because there are no unmanaged pools.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxProcesses As Integer
C#
public int MaxProcesses { get; set; }
Visual C++
public:
property int MaxProcesses {
    int get ();
    void set (int value);
}

Field Value

Value indicating the maximum number of worker processes allowed by the application pool.

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


OrphanActionExe Property

[image]

.NET Framework Class Library
AppPoolCreate..::.OrphanActionExe Property
AppPoolCreate Class See Also Send Feedback

The OrphanActionExe property specifies an executable to run when the World Wide Web Publishing Service (WWW service) orphans a worker process. You can use the OrphanActionParams property to send parameters to the executable.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property OrphanActionExe As String
C#
public string OrphanActionExe { get; set; }
Visual C++
public:
property String^ OrphanActionExe {
    String^ get ();
    void set (String^ value);
}

Field Value

The value for the orphan action executable.

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


OrphanActionParams Property

[image]

.NET Framework Class Library
AppPoolCreate..::.OrphanActionParams Property
AppPoolCreate Class See Also Send Feedback

The OrphanActionParams property specifies command-line parameters for the executable specified by the OrphanActionExe property.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property OrphanActionParams As String
C#
public string OrphanActionParams { get; set; }
Visual C++
public:
property String^ OrphanActionParams {
    String^ get ();
    void set (String^ value);
}

Field Value

Value indicating the orphan action parameters.

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


OrphanWorkerProcess Property

[image]

.NET Framework Class Library
AppPoolCreate..::.OrphanWorkerProcess Property
AppPoolCreate Class See Also Send Feedback

The OrphanWorkerProcess property, when set to true, notifies the World Wide Web Publishing Service (WWW Service) not to terminate a worker process that fails to respond to pings, but to instead orphan the worker process in the application pool if the worker process suffers fatal errors.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property OrphanWorkerProcess As Boolean
C#
public bool OrphanWorkerProcess { get; set; }
Visual C++
public:
property bool OrphanWorkerProcess {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating the orphan worker process.

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


PeriodicRestartMemory Property

[image]

.NET Framework Class Library
AppPoolCreate..::.PeriodicRestartMemory Property
AppPoolCreate Class See Also Send Feedback

The PeriodicRestartMemory property specifies the amount of virtual memory (in KB) that a worker process can use before the worker process recycles. The maximum value supported for this property is 4,294,967 KB.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property PeriodicRestartMemory As Integer
C#
public int PeriodicRestartMemory { get; set; }
Visual C++
public:
property int PeriodicRestartMemory {
    int get ();
    void set (int value);
}

Field Value

Value indicating the amount of memory.

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


PeriodicRestartPrivateMemory Property

[image]

.NET Framework Class Library
AppPoolCreate..::.PeriodicRestartPrivateMemory Property
AppPoolCreate Class See Also Send Feedback

The PeriodicRestartPrivateMemory property specifies the amount of private memory (in KB) that a worker process can use before the worker process recycles. The maximum value supported for this property is 4,294,967 KB.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property PeriodicRestartPrivateMemory As Integer
C#
public int PeriodicRestartPrivateMemory { get; set; }
Visual C++
public:
property int PeriodicRestartPrivateMemory {
    int get ();
    void set (int value);
}

Field Value

Value indicating the amount of memory.

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


PeriodicRestartRequests Property

[image]

.NET Framework Class Library
AppPoolCreate..::.PeriodicRestartRequests Property
AppPoolCreate Class See Also Send Feedback

The PeriodicRestartRequests property indicates the number of requests the OOP application should process, after which it is recycled.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property PeriodicRestartRequests As Integer
C#
public int PeriodicRestartRequests { get; set; }
Visual C++
public:
property int PeriodicRestartRequests {
    int get ();
    void set (int value);
}

Field Value

Value indicating the number of requests.

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


PeriodicRestartSchedule Property

[image]

.NET Framework Class Library
AppPoolCreate..::.PeriodicRestartSchedule Property
AppPoolCreate Class See Also Send Feedback

The PeriodicRestartSchedule property specifies the time (in 24 hour format) that the application will be rotated. Each time is in local time and is specified in the following format: PeriodicRestartSchedule="hh:mm,hh:mm,hh:mm"

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property PeriodicRestartSchedule As String
C#
public string PeriodicRestartSchedule { get; set; }
Visual C++
public:
property String^ PeriodicRestartSchedule {
    String^ get ();
    void set (String^ value);
}

Field Value

Value indicating the restart schedule.

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


PeriodicRestartTime Property

[image]

.NET Framework Class Library
AppPoolCreate..::.PeriodicRestartTime Property
AppPoolCreate Class See Also Send Feedback

The PeriodicRestartTime property specifies the period of time, in minutes, after which IIS rotates an isolated OOP application. Setting the value of this property to 0 disables the property. The maximum supported value for this property is 71,582.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property PeriodicRestartTime As Integer
C#
public int PeriodicRestartTime { get; set; }
Visual C++
public:
property int PeriodicRestartTime {
    int get ();
    void set (int value);
}

Field Value

Value indicating the restart time period.

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


PingingEnabled Property

[image]

.NET Framework Class Library
AppPoolCreate..::.PingingEnabled Property
AppPoolCreate Class See Also Send Feedback

The PingingEnabled property specifies whether the World Wide Web Publishing Service (WWW Service) should periodically monitor the health of a worker process. Setting the value of this property to true indicates to the WWW service to monitor the worker processes to ensure that the they are running and healthy.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property PingingEnabled As Boolean
C#
public bool PingingEnabled { get; set; }
Visual C++
public:
property bool PingingEnabled {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if pinging is enabled or disabled.

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


PingInterval Property

[image]

.NET Framework Class Library
AppPoolCreate..::.PingInterval Property
AppPoolCreate Class See Also Send Feedback

The PingInterval property specifies the period of time (in seconds) between health-monitoring pings that the World Wide Web Publishing Service (WWW Service) sends to a worker process.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property PingInterval As Integer
C#
public int PingInterval { get; set; }
Visual C++
public:
property int PingInterval {
    int get ();
    void set (int value);
}

Field Value

Value indicating the ping interval.

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


PingResponseTime Property

[image]

.NET Framework Class Library
AppPoolCreate..::.PingResponseTime Property
AppPoolCreate Class See Also Send Feedback

The PingResponseTime property specifies the amount of time (in seconds) that a worker process is given to respond to a health monitoring ping. After the time limit is exceeded, the World Wide Web Publishing Service (WWW Service) terminates the worker process.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property PingResponseTime As Integer
C#
public int PingResponseTime { get; set; }
Visual C++
public:
property int PingResponseTime {
    int get ();
    void set (int value);
}

Field Value

Value indicating the ping response time.

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


RapidFailProtection Property

[image]

.NET Framework Class Library
AppPoolCreate..::.RapidFailProtection Property
AppPoolCreate Class See Also Send Feedback

Setting the RapidFailProtection property to true instructs the World Wide Web Publishing Service (WWW service) to put all applications in an application pool out of service if the number of worker process crashes has reached the maximum specified by the RapidFailProtectionMaxCrashes property, within the number of minutes specified by the RapidFailProtectionInterval property.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property RapidFailProtection As Boolean
C#
public bool RapidFailProtection { get; set; }
Visual C++
public:
property bool RapidFailProtection {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if rapid fail protection is enabled or disabled.

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


RapidFailProtectionInterval Property

[image]

.NET Framework Class Library
AppPoolCreate..::.RapidFailProtectionInterval Property
AppPoolCreate Class See Also Send Feedback

The RapidFailProtectionInterval property specifies the number of minutes before the failure count for a process is reset. See RapidFailProtection.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property RapidFailProtectionInterval As Integer
C#
public int RapidFailProtectionInterval { get; set; }
Visual C++
public:
property int RapidFailProtectionInterval {
    int get ();
    void set (int value);
}

Field Value

Value indicating the rapid fail protection interval.

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


RapidFailProtectionMaxCrashes Property

[image]

.NET Framework Class Library
AppPoolCreate..::.RapidFailProtectionMaxCrashes Property
AppPoolCreate Class See Also Send Feedback

The RapidFailProtectionMaxCrashes property specifies the maximum number of failures allowed within the number of minutes specified by the RapidFailProtectionInterval property. See RapidFailProtection.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property RapidFailProtectionMaxCrashes As Integer
C#
public int RapidFailProtectionMaxCrashes { get; set; }
Visual C++
public:
property int RapidFailProtectionMaxCrashes {
    int get ();
    void set (int value);
}

Field Value

Value indicating the maximum number of crashes.

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


ShutdownTimeLimit Property

[image]

.NET Framework Class Library
AppPoolCreate..::.ShutdownTimeLimit Property
AppPoolCreate Class See Also Send Feedback

The ShutdownTimeLimit property specifies the amount of time (in seconds) after a recycle threshold has been reached that IIS waits for all old requests to finish running in a worker process before terminating the worker process.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ShutdownTimeLimit As Integer
C#
public int ShutdownTimeLimit { get; set; }
Visual C++
public:
property int ShutdownTimeLimit {
    int get ();
    void set (int value);
}

Field Value

Value indicating the shutdown time limit.

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


SMPAffinitized Property

[image]

.NET Framework Class Library
AppPoolCreate..::.SMPAffinitized Property
AppPoolCreate Class See Also Send Feedback

Setting the SMPAffinitized property to true indicates that a particular worker process assigned to an application pool should be assigned to a given CPU. This property is used in conjunction with the SMPProcessorAffinityMask property to configure a particular processor a worker process will be assigned to.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property SMPAffinitized As Boolean
C#
public bool SMPAffinitized { get; set; }
Visual C++
public:
property bool SMPAffinitized {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if SMPAffinitized is enabled or disabled.

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


SMPProcessorAffinityMask Property

[image]

.NET Framework Class Library
AppPoolCreate..::.SMPProcessorAffinityMask Property
AppPoolCreate Class See Also Send Feedback

The SMPProcessorAffinityMask property configures the hexadecimal processor mask. The hexadecimal processor mask indicates to which CPU the worker processes in an application pool should be bound. Before this property takes affect, the SMPAffinitized property must be set to true for the application pool. These properties cannot be set through IIS Manager. Do not set this property to zero. Doing so causes no SMP affinity to be configured, creating an error condition. The default DWORD value is 4294967295 (or -1), which is represented in hexadecimal as 0xFFFFFFFF. A value of 0xFFFFFFFF in SMPProcessorAffinityMask indicates that all processors are enabled.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property SMPProcessorAffinityMask As Long
C#
public long SMPProcessorAffinityMask { get; set; }
Visual C++
public:
property long long SMPProcessorAffinityMask {
    long long get ();
    void set (long long value);
}

Field Value

Value indicating the SMP processor affinity bit mask.

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


StartupTimeLimit Property

[image]

.NET Framework Class Library
AppPoolCreate..::.StartupTimeLimit Property
AppPoolCreate Class See Also Send Feedback

The value of the StartupTimeLimit property specifies the amount of time (in seconds) that the World Wide Web Publishing Service (WWW Service) should wait for a worker process to finish starting up and reporting to the WWW Service.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property StartupTimeLimit As Integer
C#
public int StartupTimeLimit { get; set; }
Visual C++
public:
property int StartupTimeLimit {
    int get ();
    void set (int value);
}

Field Value

Value indicating the startup time limit.

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


WAMUserName Property

[image]

.NET Framework Class Library
AppPoolCreate..::.WAMUserName Property
AppPoolCreate Class See Also Send Feedback

The WAMUserName property specifies the account user name that IIS uses by default as the COM+ application identity for newly created IIS out-of-process applications. The values of this property and its companion property, WAMUserPass, are set when IIS is installed, and match the user name and password values in the Microsoft Windows user account, which is established at the same time. Changing the value of this property is not recommended. If you do, change it to a valid Windows user account, and change WAMUserPass to the corresponding password for the new account. Important: Changes to WAMUserName and WAMUserPass may disrupt the operation of existing IIS out-of-process applications. You can synchronize application identities using Component Services to edit the user name and password values, found on the Identity tab of the property sheet for each package. In-process applications are not affected by these property values.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property WAMUserName As String
C#
public string WAMUserName { get; set; }
Visual C++
public:
property String^ WAMUserName {
    String^ get ();
    void set (String^ value);
}

Field Value

Value indicating the username.

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


WAMUserPass Property

[image]

.NET Framework Class Library
AppPoolCreate..::.WAMUserPass Property
AppPoolCreate Class See Also Send Feedback

The WAMUserPass property specifies the password for the account that IIS uses by default as the COM+ application identity for newly created IIS out-of-process applications. The values of this property and its companion property, WAMUserName, are set when IIS is installed, and match the password and user name values in the Microsoft Windows user account (IWAM_ MachineName, where MachineName is the name of the machine on which IIS is installed) established at the same time. Important: Changing the value of this property is not recommended. If you do, you must change the Windows account password to the identical value. You must also synchronize existing IIS out-of-process application identities, using Component Services to edit the user name and password values, which are found on the Identity tab of the property sheet for each package. In-process applications are not affected by these property values.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property WAMUserPass As String
C#
public string WAMUserPass { get; set; }
Visual C++
public:
property String^ WAMUserPass {
    String^ get ();
    void set (String^ value);
}

Field Value

Value indicating the password.

See Also

AppPoolCreate Class
MSBuild.Community.Tasks.IIS Namespace


AppPoolDelete Class

[image]

.NET Framework Class Library
AppPoolDelete Class
Members Example See Also Send Feedback

Deletes an existing application pool on a local or remote machine with IIS installed. The default is to delete an existing application pool on the local machine. If connecting to a remote machine, you can specify the Username and Password for the task to run under.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class AppPoolDelete _
    Inherits WebBase
C#
public class AppPoolDelete : WebBase
Visual C++
public ref class AppPoolDelete : public WebBase

Examples

Delete an existing application pool on the local machine.
Copy Code
            <AppPoolDelete AppPoolName="MyAppPool" />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.IIS..::.WebBase
MSBuild.Community.Tasks.IIS..::.AppPoolDelete

See Also

AppPoolDelete Members
MSBuild.Community.Tasks.IIS Namespace


AppPoolDelete Members

[image] [image]

.NET Framework Class Library
AppPoolDelete Members
AppPoolDelete Class Constructors Methods Fields Properties See Also Send Feedback

The AppPoolDelete type exposes the following members.

Constructors

Name | Description
AppPoolDelete |

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetIISVersion | Gets the IIS version. (Inherited from WebBase.)
GetRemoteOSVersion | Gets the remote machine OS version. (Inherited from WebBase.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)
VerifyIISRoot | Verifies that the IIS root exists based on the ServerName and ServerPort. (Inherited from WebBase.)

Fields

Name | Description
mIISVersion | IIS version. (Inherited from WebBase.)

Properties

Name | Description
ApplicationPoolName | Gets or sets the name of the application pool.
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostHeaderName | Gets or sets host header. Used when you have more than one website in IIS that have the same port but different host headers. (Inherited from WebBase.)
HostObject | (Inherited from Task.)
IISApplicationPath | Gets or sets the application path. (Inherited from WebBase.)
IISAppPoolPath | Gets or sets the IIS application pool path. (Inherited from WebBase.)
IISServerPath | Gets or sets the IIS server path. (Inherited from WebBase.)
Log | (Inherited from Task.)
Password | Gets or sets the password for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (Inherited from WebBase.)
ServerName | Gets or sets the name of the server. The default value is 'localhost'. (Inherited from WebBase.)
ServerPort | Gets or sets the server port. (Inherited from WebBase.)
TaskResources | (Inherited from Task.)
Username | Gets or sets the username for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (Inherited from WebBase.)

See Also

AppPoolDelete Class
MSBuild.Community.Tasks.IIS Namespace


AppPoolDelete Constructor

[image]

.NET Framework Class Library
AppPoolDelete Constructor
AppPoolDelete Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public AppPoolDelete()
Visual C++
public:
AppPoolDelete()

See Also

AppPoolDelete Class
MSBuild.Community.Tasks.IIS Namespace


AppPoolDelete Fields

[image] [image]

.NET Framework Class Library
AppPoolDelete Fields
AppPoolDelete Class See Also Send Feedback

The AppPoolDelete type exposes the following members.

Fields

Name | Description
mIISVersion | IIS version. (Inherited from WebBase.)

See Also

AppPoolDelete Class
MSBuild.Community.Tasks.IIS Namespace


AppPoolDelete Methods

[image] [image]

.NET Framework Class Library
AppPoolDelete Methods
AppPoolDelete Class See Also Send Feedback

The AppPoolDelete type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetIISVersion | Gets the IIS version. (Inherited from WebBase.)
GetRemoteOSVersion | Gets the remote machine OS version. (Inherited from WebBase.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)
VerifyIISRoot | Verifies that the IIS root exists based on the ServerName and ServerPort. (Inherited from WebBase.)

See Also

AppPoolDelete Class
MSBuild.Community.Tasks.IIS Namespace


Execute Method

[image]

.NET Framework Class Library
AppPoolDelete..::.Execute Method
AppPoolDelete Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

True if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

AppPoolDelete Class
MSBuild.Community.Tasks.IIS Namespace


AppPoolDelete Properties

[image] [image]

.NET Framework Class Library
AppPoolDelete Properties
AppPoolDelete Class See Also Send Feedback

The AppPoolDelete type exposes the following members.

Properties

Name | Description
ApplicationPoolName | Gets or sets the name of the application pool.
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostHeaderName | Gets or sets host header. Used when you have more than one website in IIS that have the same port but different host headers. (Inherited from WebBase.)
HostObject | (Inherited from Task.)
IISApplicationPath | Gets or sets the application path. (Inherited from WebBase.)
IISAppPoolPath | Gets or sets the IIS application pool path. (Inherited from WebBase.)
IISServerPath | Gets or sets the IIS server path. (Inherited from WebBase.)
Log | (Inherited from Task.)
Password | Gets or sets the password for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (Inherited from WebBase.)
ServerName | Gets or sets the name of the server. The default value is 'localhost'. (Inherited from WebBase.)
ServerPort | Gets or sets the server port. (Inherited from WebBase.)
TaskResources | (Inherited from Task.)
Username | Gets or sets the username for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (Inherited from WebBase.)

See Also

AppPoolDelete Class
MSBuild.Community.Tasks.IIS Namespace


ApplicationPoolName Property

[image]

.NET Framework Class Library
AppPoolDelete..::.ApplicationPoolName Property
AppPoolDelete Class See Also Send Feedback

Gets or sets the name of the application pool.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property ApplicationPoolName As String
C#
[RequiredAttribute]
public string ApplicationPoolName { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ ApplicationPoolName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the application pool.

See Also

AppPoolDelete Class
MSBuild.Community.Tasks.IIS Namespace


WebBase Class

[image]

.NET Framework Class Library
WebBase Class
Members See Also Send Feedback

Base task for any IIS-related task.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class WebBase _
    Inherits Task
C#
public abstract class WebBase : Task
Visual C++
public ref class WebBase abstract : public Task

Remarks

Stores the base logic for gathering the IIS version and server and port checking. This base task also stores common properties for other related tasks.

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.IIS..::.WebBase
MSBuild.Community.Tasks.IIS..::.AppPoolController
MSBuild.Community.Tasks.IIS..::.AppPoolCreate
MSBuild.Community.Tasks.IIS..::.AppPoolDelete
MSBuild.Community.Tasks.IIS..::.WebDirectoryCreate
MSBuild.Community.Tasks.IIS..::.WebDirectoryDelete
MSBuild.Community.Tasks.IIS..::.WebDirectoryScriptMap
MSBuild.Community.Tasks.IIS..::.WebDirectorySetting

See Also

WebBase Members
MSBuild.Community.Tasks.IIS Namespace


WebBase Members

[image] [image]

.NET Framework Class Library
WebBase Members
WebBase Class Constructors Methods Fields Properties See Also Send Feedback

The WebBase type exposes the following members.

Constructors

Name | Description
WebBase |

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | (Inherited from Task.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetIISVersion | Gets the IIS version.
GetRemoteOSVersion | Gets the remote machine OS version.
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)
VerifyIISRoot | Verifies that the IIS root exists based on the ServerName and ServerPort.

Fields

Name | Description
mIISVersion | IIS version.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostHeaderName | Gets or sets host header. Used when you have more than one website in IIS that have the same port but different host headers.
HostObject | (Inherited from Task.)
IISApplicationPath | Gets or sets the application path.
IISAppPoolPath | Gets or sets the IIS application pool path.
IISServerPath | Gets or sets the IIS server path.
Log | (Inherited from Task.)
Password | Gets or sets the password for the account the task will run under. This property is needed if you specified a ServerName for a remote machine.
ServerName | Gets or sets the name of the server. The default value is 'localhost'.
ServerPort | Gets or sets the server port.
TaskResources | (Inherited from Task.)
Username | Gets or sets the username for the account the task will run under. This property is needed if you specified a ServerName for a remote machine.

See Also

WebBase Class
MSBuild.Community.Tasks.IIS Namespace


WebBase Constructor

[image]

.NET Framework Class Library
WebBase Constructor
WebBase Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New
C#
protected WebBase()
Visual C++
protected:
WebBase()

See Also

WebBase Class
MSBuild.Community.Tasks.IIS Namespace


WebBase Fields

[image] [image]

.NET Framework Class Library
WebBase Fields
WebBase Class See Also Send Feedback

The WebBase type exposes the following members.

Fields

Name | Description
mIISVersion | IIS version.

See Also

WebBase Class
MSBuild.Community.Tasks.IIS Namespace


mIISVersion Field

[image]

.NET Framework Class Library
WebBase..::.mIISVersion Field
WebBase Class See Also Send Feedback

IIS version.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected mIISVersion As WebBase..::.IISVersion
C#
protected WebBase..::.IISVersion mIISVersion
Visual C++
protected:
WebBase..::.IISVersion mIISVersion

See Also

WebBase Class
MSBuild.Community.Tasks.IIS Namespace


WebBase Methods

[image] [image]

.NET Framework Class Library
WebBase Methods
WebBase Class See Also Send Feedback

The WebBase type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | (Inherited from Task.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetIISVersion | Gets the IIS version.
GetRemoteOSVersion | Gets the remote machine OS version.
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)
VerifyIISRoot | Verifies that the IIS root exists based on the ServerName and ServerPort.

See Also

WebBase Class
MSBuild.Community.Tasks.IIS Namespace


GetIISVersion Method

[image]

.NET Framework Class Library
WebBase..::.GetIISVersion Method
WebBase Class See Also Send Feedback

Gets the IIS version.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetIISVersion As WebBase..::.IISVersion
C#
protected WebBase..::.IISVersion GetIISVersion()
Visual C++
protected:
WebBase..::.IISVersion GetIISVersion()

Return Value

The WebBase..::.IISVersion for IIS.

See Also

WebBase Class
MSBuild.Community.Tasks.IIS Namespace


GetRemoteOSVersion Method

[image]

.NET Framework Class Library
WebBase..::.GetRemoteOSVersion Method
WebBase Class See Also Send Feedback

Gets the remote machine OS version.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetRemoteOSVersion As Version
C#
protected Version GetRemoteOSVersion()
Visual C++
protected:
Version^ GetRemoteOSVersion()

Return Value

Returns a Version of the operating system.

See Also

WebBase Class
MSBuild.Community.Tasks.IIS Namespace


VerifyIISRoot Method

[image]

.NET Framework Class Library
WebBase..::.VerifyIISRoot Method
WebBase Class See Also Send Feedback

Verifies that the IIS root exists based on the ServerName and ServerPort.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Sub VerifyIISRoot
C#
protected void VerifyIISRoot()
Visual C++
protected:
void VerifyIISRoot()

See Also

WebBase Class
MSBuild.Community.Tasks.IIS Namespace


WebBase Properties

[image] [image]

.NET Framework Class Library
WebBase Properties
WebBase Class See Also Send Feedback

The WebBase type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostHeaderName | Gets or sets host header. Used when you have more than one website in IIS that have the same port but different host headers.
HostObject | (Inherited from Task.)
IISApplicationPath | Gets or sets the application path.
IISAppPoolPath | Gets or sets the IIS application pool path.
IISServerPath | Gets or sets the IIS server path.
Log | (Inherited from Task.)
Password | Gets or sets the password for the account the task will run under. This property is needed if you specified a ServerName for a remote machine.
ServerName | Gets or sets the name of the server. The default value is 'localhost'.
ServerPort | Gets or sets the server port.
TaskResources | (Inherited from Task.)
Username | Gets or sets the username for the account the task will run under. This property is needed if you specified a ServerName for a remote machine.

See Also

WebBase Class
MSBuild.Community.Tasks.IIS Namespace


HostHeaderName Property

[image]

.NET Framework Class Library
WebBase..::.HostHeaderName Property
WebBase Class See Also Send Feedback

Gets or sets host header. Used when you have more than one website in IIS that have the same port but different host headers.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property HostHeaderName As String
C#
public string HostHeaderName { get; set; }
Visual C++
public:
property String^ HostHeaderName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the host header.

See Also

WebBase Class
MSBuild.Community.Tasks.IIS Namespace


IISApplicationPath Property

[image]

.NET Framework Class Library
WebBase..::.IISApplicationPath Property
WebBase Class See Also Send Feedback

Gets or sets the application path.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Property IISApplicationPath As String
C#
protected string IISApplicationPath { get; set; }
Visual C++
protected:
property String^ IISApplicationPath {
    String^ get ();
    void set (String^ value);
}

Field Value

The application path.

Remarks

Is in the form '/LM/W3SVC/1/Root'.

See Also

WebBase Class
MSBuild.Community.Tasks.IIS Namespace


IISAppPoolPath Property

[image]

.NET Framework Class Library
WebBase..::.IISAppPoolPath Property
WebBase Class See Also Send Feedback

Gets or sets the IIS application pool path.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Property IISAppPoolPath As String
C#
protected string IISAppPoolPath { get; set; }
Visual C++
protected:
property String^ IISAppPoolPath {
    String^ get ();
    void set (String^ value);
}

Field Value

The IIS application pool path.

Remarks

Is in the form 'IIS://localhost/W3SVC/AppPools'.

See Also

WebBase Class
MSBuild.Community.Tasks.IIS Namespace


IISServerPath Property

[image]

.NET Framework Class Library
WebBase..::.IISServerPath Property
WebBase Class See Also Send Feedback

Gets or sets the IIS server path.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Property IISServerPath As String
C#
protected string IISServerPath { get; set; }
Visual C++
protected:
property String^ IISServerPath {
    String^ get ();
    void set (String^ value);
}

Field Value

The IIS server path.

Remarks

Is in the form 'IIS://localhost/W3SVC/1/Root'.

See Also

WebBase Class
MSBuild.Community.Tasks.IIS Namespace


Password Property

[image]

.NET Framework Class Library
WebBase..::.Password Property
WebBase Class See Also Send Feedback

Gets or sets the password for the account the task will run under. This property is needed if you specified a ServerName for a remote machine.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password { get; set; }
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

Field Value

The password of the account.

See Also

WebBase Class
MSBuild.Community.Tasks.IIS Namespace


ServerName Property

[image]

.NET Framework Class Library
WebBase..::.ServerName Property
WebBase Class See Also Send Feedback

Gets or sets the name of the server. The default value is 'localhost'.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ServerName As String
C#
public string ServerName { get; set; }
Visual C++
public:
property String^ ServerName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the server.

See Also

WebBase Class
MSBuild.Community.Tasks.IIS Namespace


ServerPort Property

[image]

.NET Framework Class Library
WebBase..::.ServerPort Property
WebBase Class See Also Send Feedback

Gets or sets the server port.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ServerPort As Integer
C#
public int ServerPort { get; set; }
Visual C++
public:
property int ServerPort {
    int get ();
    void set (int value);
}

Field Value

The server port.

See Also

WebBase Class
MSBuild.Community.Tasks.IIS Namespace


Username Property

[image]

.NET Framework Class Library
WebBase..::.Username Property
WebBase Class See Also Send Feedback

Gets or sets the username for the account the task will run under. This property is needed if you specified a ServerName for a remote machine.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Username As String
C#
public string Username { get; set; }
Visual C++
public:
property String^ Username {
    String^ get ();
    void set (String^ value);
}

Field Value

The username of the account.

See Also

WebBase Class
MSBuild.Community.Tasks.IIS Namespace


WebBase.ApplicationPoolAction Enumeration

[image]

.NET Framework Class Library
WebBase..::.ApplicationPoolAction Enumeration
WebBase Class See Also Send Feedback

Defines the possible application pool actions to be performed.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration ApplicationPoolAction
C#
public enum ApplicationPoolAction
Visual C++
public enum class ApplicationPoolAction

Members

Member name | Description
Recycle | Recycles an application pool.
Restart | Stops and restarts the application pool.
Start | Starts the application pool.
Stop | Stops the application pool.

See Also

MSBuild.Community.Tasks.IIS Namespace


WebBase.ApplicationPoolState Enumeration

[image]

.NET Framework Class Library
WebBase..::.ApplicationPoolState Enumeration
WebBase Class See Also Send Feedback

Defines the current application pool state.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Enumeration ApplicationPoolState
C#
protected enum ApplicationPoolState
Visual C++
protected enum class ApplicationPoolState

Members

Member name | Description
Starting | The application pool is starting.
Started | The application pool has started.
Stopping | The application pool is stopping.
Stopped | The application pool has stopped.

See Also

MSBuild.Community.Tasks.IIS Namespace


WebBase.IISVersion Enumeration

[image]

.NET Framework Class Library
WebBase..::.IISVersion Enumeration
WebBase Class See Also Send Feedback

Defines the possible IIS versions supported by the task.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Enumeration IISVersion
C#
protected enum IISVersion
Visual C++
protected enum class IISVersion

Members

Member name | Description
Four | IIS version 4.x
Five | IIS version 5.x
Six | IIS version 6.x

See Also

MSBuild.Community.Tasks.IIS Namespace


WebDirectoryCreate Class

[image]

.NET Framework Class Library
WebDirectoryCreate Class
Members Example See Also Send Feedback

Creates a new web directory on a local or remote machine with IIS installed. The default is to create the new web directory on the local machine. The physical path is required to already exist on the target machine. If connecting to a remote machine, you can specify the Username and Password for the task to run under.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class WebDirectoryCreate _
    Inherits WebBase
C#
public class WebDirectoryCreate : WebBase
Visual C++
public ref class WebDirectoryCreate : public WebBase

Examples

Create a new web directory on the local machine.
Copy Code
            <WebDirectoryCreate VirtualDirectoryName="MyVirDir"
                VirtualDirectoryPhysicalPath="C:\Inetpub\MyWebDir" />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.IIS..::.WebBase
MSBuild.Community.Tasks.IIS..::.WebDirectoryCreate

See Also

WebDirectoryCreate Members
MSBuild.Community.Tasks.IIS Namespace


WebDirectoryCreate Members

[image] [image]

.NET Framework Class Library
WebDirectoryCreate Members
WebDirectoryCreate Class Constructors Methods Fields Properties See Also Send Feedback

The WebDirectoryCreate type exposes the following members.

Constructors

Name | Description
WebDirectoryCreate |

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetIISVersion | Gets the IIS version. (Inherited from WebBase.)
GetRemoteOSVersion | Gets the remote machine OS version. (Inherited from WebBase.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)
VerifyIISRoot | Verifies that the IIS root exists based on the ServerName and ServerPort. (Inherited from WebBase.)

Fields

Name | Description
mIISVersion | IIS version. (Inherited from WebBase.)

Properties

Name | Description
AccessExecute | Gets or sets a value that indicates if the file or the contents of the folder may be executed, regardless of file type.
AccessNoRemoteExecute | A value of true indicates that remote requests to execute applications are denied; only requests from the same computer as the IIS server succeed if the AccessExecute property is set to true. You cannot set AccessNoRemoteExecute to false to enable remote requests, and set AccessExecute to false to disable local requests.
AccessNoRemoteRead | A value of true indicates that remote requests to view files are denied; only requests from the same computer as the IIS server succeed if the AccessRead property is set to true. You cannot set AccessNoRemoteRead to false to enable remote requests, and set AccessRead to false to disable local requests.
AccessNoRemoteScript | A value of true indicates that remote requests to view dynamic content are denied; only requests from the same computer as the IIS server succeed if the AccessScript property is set to true. You cannot set AccessNoRemoteScript to false to enable remote requests, and set AccessScript to false to disable local requests.
AccessNoRemoteWrite | A value of true indicates that remote requests to create or change files are denied; only requests from the same computer as the IIS server succeed if the AccessWrite property is set to true. You cannot set AccessNoRemoteWrite to false to enable remote requests, and set AccessWrite to false to disable local requests.
AccessRead | A value of true indicates that the file or the contents of the folder may be read through Microsoft Internet Explorer.
AccessScript | A value of true indicates that the file or the contents of the folder may be executed if they are script files or static content. A value of false only allows static files, such as HTML files, to be served.
AccessSource | A value of true indicates that users are allowed to access source code if either Read or Write permissions are set. Source code includes scripts in Microsoft ® Active Server Pages (ASP) applications.
AccessSsl | A value of true indicates that file access requires SSL file permission processing, with or without a client certificate.
AccessSsl128 | A value of true indicates that file access requires SSL file permission processing with a minimum key size of 128 bits, with or without a client certificate.
AccessSslMapCert | A value of true indicates that SSL file permission processing maps a client certificate to a Microsoft Windows ® operating system user-account. The AccessSslNegotiateCert property must also be set to true for the mapping to occur.
AccessSslNegotiateCert | A value of true indicates that SSL file access processing requests a certificate from the client. A value of false indicates that access continues if the client does not have a certificate. Some versions of Internet Explorer will close the connection if the server requests a certificate and a certificate is not available (even if AccessSslRequireCert is also set to true).
AccessSslRequireCert | A value of true indicates that SSL file access processing requests a certificate from the client. If the client provides no certificate, the connection is closed. AccessSslNegotiateCert must also be set to true when using AccessSSLRequireCert.
AccessWrite | A value of true indicates that users are allowed to upload files and their associated properties to the enabled directory on your server or to change content in a Write-enabled file. Write can be implemented only with a browser that supports the PUT feature of the HTTP 1.1 protocol standard.
AnonymousPasswordSync | The AnonymousPasswordSync property indicates whether IIS should handle the user password for anonymous users attempting to access resources.
AppAllowClientDebug | The AppAllowClientDebug property specifies whether ASP client-side debugging is enabled. This property is independent of AppAllowDebugging, which applies to server-side debugging.
AppAllowDebugging | The AppAllowDebugging property specifies whether ASP debugging is enabled on the server. This property is independent of the AppAllowClientDebug property, which applies to client-side debugging.
AspAllowSessionState | The AspAllowSessionState property enables session state persistence for the ASP application.
AspBufferingOn | The AspBufferingOn property specifies whether output from an ASP application will be buffered.
AspEnableApplicationRestart | The AspEnableApplicationRestart determines whether an ASP application can be automatically restarted. When changes are made to Global.asa or metabase properties that affect an application, the application will not restart unless the AspEnableApplicationRestart property is set to true.
AspEnableAspHtmlFallback | The AspEnableAspHtmlFallback property controls the behavior of ASP when a new request is to be rejected due to a full request queue.
AspEnableChunkedEncoding | The AspEnableChunkedEncoding property specifies whether HTTP 1.1 chunked transfer encoding is enabled for the World Wide Web Publishing Service (WWW service).
AspEnableParentPaths | The AspEnableParentPaths property specifies whether an ASP page allows paths relative to the current directory (using the ..\ notation) or above the current directory.
AspEnableTypelibCache | The AspEnableTypelibCache property specifies whether type libraries are cached on the server. The World Wide Web Publishing Service (WWW service) setting for this property is applicable to all in-process and pooled out-of-process application nodes, at all levels. Metabase settings at the Web server level or lower are ignored for in-process and pooled out-of-process applications. However, settings at the Web server level or lower are used if that node is an isolated out-of-process application.
AspErrorsToNTLog | The AspErrorsToNTLog property specifies which ASP errors are written to the Windows event log. ASP errors are written to the client browser and to the IIS log files by default.
AspExceptionCatchEnable | The AspExceptionCatchEnable property specifies whether ASP pages trap exceptions thrown by components.
AspLogErrorRequests | The AspLogErrorRequests property controls whether the Web server writes ASP errors to the application section of the Windows event log. ASP errors are written to the client browser and to the IIS log files by default.
AspScriptErrorMessage | The AspScriptErrorMessage property specifies the error message to send to the browser if specific debugging errors are not sent to the client (if AspScriptErrorSentToBrowser is set to false).
AspScriptErrorSentToBrowser | The AspScriptErrorSentToBrowser property specifies whether the Web server writes debugging specifics (file name, error, line number, description) to the client browser, in addition to logging them to the Windows Event Log. The AspScriptErrorMessage property provides the error message to be sent if this property is set to false.
AspTrackThreadingModel | The AspTrackThreadingModel property specifies whether IIS checks the threading model of any components (COM objects) that your application creates. The preferred setting of this metabase property is false.
AuthAnonymous | Specifies Anonymous authentication as one of the possible Windows authentication schemes returned to clients as being available.
AuthBasic | Specifies Basic authentication as one of the possible Windows authentication schemes returned to clients as being available.
AuthNtlm | Specifies Integrated Windows authentication (also known as Challenge/Response or NTLM authentication) as one of the possible Windows authentication schemes returned to clients as being available.
AuthPersistSingleRequest | Setting this flag to true specifies that authentication persists only for a single request on a connection. IIS resets the authentication at the end of each request, and forces re-authentication on the next request of the session.
AuthPersistSingleRequestAlwaysIfProxy | Setting this flag to true specifies that authentication is valid for a single request if by proxy. IIS will reset the authentication at the end of the request and force re-authentication on the next request if the current authenticated request is by proxy of any type.
AuthPersistSingleRequestIfProxy | Setting this flag to true specifies authentication will persist only across single requests on a connection if the connection is by proxy. IIS will reset the authentication at the end of the request if the current authenticated request is by proxy and it is not the special case where IIS is running MSPROXY.
BuildEngine | (Inherited from Task.)
CacheControlNoCache | The CacheControlNoCache property specifies the HTTP 1.1 directive to prevent caching of content.
CacheIsapi | The CacheISAPI property indicates whether ISAPI extensions are cached in memory after first use.
ContentIndexed | The ContentIndexed property specifies whether the installed content indexer should index content under this directory tree.
CpuAppEnabled | This property specifies whether process accounting and throttling should be performed for ISAPI extensions and ASP applications. To perform process accounting on CGI applications, use the property CpuCgiEnabled.
CpuCgiEnabled | This property indicates whether IIS should perform process accounting for CGI applications. To effectively throttle CGI applications, use the CgiTimeout property. To use process accounting for ISAPI and ASP applications, use CpuAppEnabled.
CreateCgiWithNewConsole | The CreateCGIWithNewConsole property indicates whether a CGI application runs in its own console.
CreateProcessAsUser | The CreateProcessAsUser property specifies whether a CGI process is created in the system context or in the context of the requesting user.
DefaultDoc | The DefaultDoc contains one or more file names of default documents that will be returned to the client if no file name is included in the client's request. The default document will be returned if the EnableDefaultDoc flag of the DirBrowseFlags property is set to true for the directory. This property can contain a list of default document file names separated by a comma and a space, for example Default.htm, Default.asp.
DirBrowseShowDate | When set to true, date information is displayed when browsing directories.
DirBrowseShowExtension | When set to true, file name extensions are displayed when browsing directories.
DirBrowseShowLongDate | When set to true, date information is displayed in extended format when displaying directories.
DirBrowseShowSize | When set to true, file size information is displayed when browsing directories.
DirBrowseShowTime | When set to true, file time information is displayed when displaying directories.
DontLog | The DontLog property specifies whether client requests are written to the IIS log files.
EnableDefaultDoc | When set to true, the default document (specified by the DefaultDoc property) for a directory is loaded when the directory is browsed.
EnableDirBrowsing | When set to true, directory browsing is enabled.
EnableDocFooter | The EnableDocFooter property enables or disables custom footers specified by the DefaultDocFooter property.
EnableReverseDns | The EnableReverseDns property enables or disables reverse Domain Name Server (DNS) lookups for the World Wide Web Publishing Service (WWW service). Reverse lookups involve looking up the domain name when the IP address is known. Reverse DNS lookups can use significant resources and time.
HelpKeywordPrefix | (Inherited from Task.)
HostHeaderName | Gets or sets host header. Used when you have more than one website in IIS that have the same port but different host headers. (Inherited from WebBase.)
HostObject | (Inherited from Task.)
IISApplicationPath | Gets or sets the application path. (Inherited from WebBase.)
IISAppPoolPath | Gets or sets the IIS application pool path. (Inherited from WebBase.)
IISServerPath | Gets or sets the IIS server path. (Inherited from WebBase.)
Log | (Inherited from Task.)
Password | Gets or sets the password for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (Inherited from WebBase.)
ServerName | Gets or sets the name of the server. The default value is 'localhost'. (Inherited from WebBase.)
ServerPort | Gets or sets the server port. (Inherited from WebBase.)
SsiExecDisable | The SSIExecDisable property specifies whether server-side include (SSI) #exec directives are disabled under this path.
TaskResources | (Inherited from Task.)
UncAuthenticationPassthrough | The UNCAuthenticationPassthrough property enables user authentication passthrough for Universal Naming Convention (UNC) virtual root access (for authentication schemes that support delegation).
Username | Gets or sets the username for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (Inherited from WebBase.)
VirtualDirectoryName | Gets or sets the name of the virtual directory.
VirtualDirectoryPhysicalPath | Gets or sets the virtual directory physical path. The physical directory must exist before this task executes.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


WebDirectoryCreate Constructor

[image]

.NET Framework Class Library
WebDirectoryCreate Constructor
WebDirectoryCreate Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public WebDirectoryCreate()
Visual C++
public:
WebDirectoryCreate()

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


WebDirectoryCreate Fields

[image] [image]

.NET Framework Class Library
WebDirectoryCreate Fields
WebDirectoryCreate Class See Also Send Feedback

The WebDirectoryCreate type exposes the following members.

Fields

Name | Description
mIISVersion | IIS version. (Inherited from WebBase.)

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


WebDirectoryCreate Methods

[image] [image]

.NET Framework Class Library
WebDirectoryCreate Methods
WebDirectoryCreate Class See Also Send Feedback

The WebDirectoryCreate type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetIISVersion | Gets the IIS version. (Inherited from WebBase.)
GetRemoteOSVersion | Gets the remote machine OS version. (Inherited from WebBase.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)
VerifyIISRoot | Verifies that the IIS root exists based on the ServerName and ServerPort. (Inherited from WebBase.)

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


Execute Method

[image]

.NET Framework Class Library
WebDirectoryCreate..::.Execute Method
WebDirectoryCreate Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

True if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


WebDirectoryCreate Properties

[image] [image]

.NET Framework Class Library
WebDirectoryCreate Properties
WebDirectoryCreate Class See Also Send Feedback

The WebDirectoryCreate type exposes the following members.

Properties

Name | Description
AccessExecute | Gets or sets a value that indicates if the file or the contents of the folder may be executed, regardless of file type.
AccessNoRemoteExecute | A value of true indicates that remote requests to execute applications are denied; only requests from the same computer as the IIS server succeed if the AccessExecute property is set to true. You cannot set AccessNoRemoteExecute to false to enable remote requests, and set AccessExecute to false to disable local requests.
AccessNoRemoteRead | A value of true indicates that remote requests to view files are denied; only requests from the same computer as the IIS server succeed if the AccessRead property is set to true. You cannot set AccessNoRemoteRead to false to enable remote requests, and set AccessRead to false to disable local requests.
AccessNoRemoteScript | A value of true indicates that remote requests to view dynamic content are denied; only requests from the same computer as the IIS server succeed if the AccessScript property is set to true. You cannot set AccessNoRemoteScript to false to enable remote requests, and set AccessScript to false to disable local requests.
AccessNoRemoteWrite | A value of true indicates that remote requests to create or change files are denied; only requests from the same computer as the IIS server succeed if the AccessWrite property is set to true. You cannot set AccessNoRemoteWrite to false to enable remote requests, and set AccessWrite to false to disable local requests.
AccessRead | A value of true indicates that the file or the contents of the folder may be read through Microsoft Internet Explorer.
AccessScript | A value of true indicates that the file or the contents of the folder may be executed if they are script files or static content. A value of false only allows static files, such as HTML files, to be served.
AccessSource | A value of true indicates that users are allowed to access source code if either Read or Write permissions are set. Source code includes scripts in Microsoft ® Active Server Pages (ASP) applications.
AccessSsl | A value of true indicates that file access requires SSL file permission processing, with or without a client certificate.
AccessSsl128 | A value of true indicates that file access requires SSL file permission processing with a minimum key size of 128 bits, with or without a client certificate.
AccessSslMapCert | A value of true indicates that SSL file permission processing maps a client certificate to a Microsoft Windows ® operating system user-account. The AccessSslNegotiateCert property must also be set to true for the mapping to occur.
AccessSslNegotiateCert | A value of true indicates that SSL file access processing requests a certificate from the client. A value of false indicates that access continues if the client does not have a certificate. Some versions of Internet Explorer will close the connection if the server requests a certificate and a certificate is not available (even if AccessSslRequireCert is also set to true).
AccessSslRequireCert | A value of true indicates that SSL file access processing requests a certificate from the client. If the client provides no certificate, the connection is closed. AccessSslNegotiateCert must also be set to true when using AccessSSLRequireCert.
AccessWrite | A value of true indicates that users are allowed to upload files and their associated properties to the enabled directory on your server or to change content in a Write-enabled file. Write can be implemented only with a browser that supports the PUT feature of the HTTP 1.1 protocol standard.
AnonymousPasswordSync | The AnonymousPasswordSync property indicates whether IIS should handle the user password for anonymous users attempting to access resources.
AppAllowClientDebug | The AppAllowClientDebug property specifies whether ASP client-side debugging is enabled. This property is independent of AppAllowDebugging, which applies to server-side debugging.
AppAllowDebugging | The AppAllowDebugging property specifies whether ASP debugging is enabled on the server. This property is independent of the AppAllowClientDebug property, which applies to client-side debugging.
AspAllowSessionState | The AspAllowSessionState property enables session state persistence for the ASP application.
AspBufferingOn | The AspBufferingOn property specifies whether output from an ASP application will be buffered.
AspEnableApplicationRestart | The AspEnableApplicationRestart determines whether an ASP application can be automatically restarted. When changes are made to Global.asa or metabase properties that affect an application, the application will not restart unless the AspEnableApplicationRestart property is set to true.
AspEnableAspHtmlFallback | The AspEnableAspHtmlFallback property controls the behavior of ASP when a new request is to be rejected due to a full request queue.
AspEnableChunkedEncoding | The AspEnableChunkedEncoding property specifies whether HTTP 1.1 chunked transfer encoding is enabled for the World Wide Web Publishing Service (WWW service).
AspEnableParentPaths | The AspEnableParentPaths property specifies whether an ASP page allows paths relative to the current directory (using the ..\ notation) or above the current directory.
AspEnableTypelibCache | The AspEnableTypelibCache property specifies whether type libraries are cached on the server. The World Wide Web Publishing Service (WWW service) setting for this property is applicable to all in-process and pooled out-of-process application nodes, at all levels. Metabase settings at the Web server level or lower are ignored for in-process and pooled out-of-process applications. However, settings at the Web server level or lower are used if that node is an isolated out-of-process application.
AspErrorsToNTLog | The AspErrorsToNTLog property specifies which ASP errors are written to the Windows event log. ASP errors are written to the client browser and to the IIS log files by default.
AspExceptionCatchEnable | The AspExceptionCatchEnable property specifies whether ASP pages trap exceptions thrown by components.
AspLogErrorRequests | The AspLogErrorRequests property controls whether the Web server writes ASP errors to the application section of the Windows event log. ASP errors are written to the client browser and to the IIS log files by default.
AspScriptErrorMessage | The AspScriptErrorMessage property specifies the error message to send to the browser if specific debugging errors are not sent to the client (if AspScriptErrorSentToBrowser is set to false).
AspScriptErrorSentToBrowser | The AspScriptErrorSentToBrowser property specifies whether the Web server writes debugging specifics (file name, error, line number, description) to the client browser, in addition to logging them to the Windows Event Log. The AspScriptErrorMessage property provides the error message to be sent if this property is set to false.
AspTrackThreadingModel | The AspTrackThreadingModel property specifies whether IIS checks the threading model of any components (COM objects) that your application creates. The preferred setting of this metabase property is false.
AuthAnonymous | Specifies Anonymous authentication as one of the possible Windows authentication schemes returned to clients as being available.
AuthBasic | Specifies Basic authentication as one of the possible Windows authentication schemes returned to clients as being available.
AuthNtlm | Specifies Integrated Windows authentication (also known as Challenge/Response or NTLM authentication) as one of the possible Windows authentication schemes returned to clients as being available.
AuthPersistSingleRequest | Setting this flag to true specifies that authentication persists only for a single request on a connection. IIS resets the authentication at the end of each request, and forces re-authentication on the next request of the session.
AuthPersistSingleRequestAlwaysIfProxy | Setting this flag to true specifies that authentication is valid for a single request if by proxy. IIS will reset the authentication at the end of the request and force re-authentication on the next request if the current authenticated request is by proxy of any type.
AuthPersistSingleRequestIfProxy | Setting this flag to true specifies authentication will persist only across single requests on a connection if the connection is by proxy. IIS will reset the authentication at the end of the request if the current authenticated request is by proxy and it is not the special case where IIS is running MSPROXY.
BuildEngine | (Inherited from Task.)
CacheControlNoCache | The CacheControlNoCache property specifies the HTTP 1.1 directive to prevent caching of content.
CacheIsapi | The CacheISAPI property indicates whether ISAPI extensions are cached in memory after first use.
ContentIndexed | The ContentIndexed property specifies whether the installed content indexer should index content under this directory tree.
CpuAppEnabled | This property specifies whether process accounting and throttling should be performed for ISAPI extensions and ASP applications. To perform process accounting on CGI applications, use the property CpuCgiEnabled.
CpuCgiEnabled | This property indicates whether IIS should perform process accounting for CGI applications. To effectively throttle CGI applications, use the CgiTimeout property. To use process accounting for ISAPI and ASP applications, use CpuAppEnabled.
CreateCgiWithNewConsole | The CreateCGIWithNewConsole property indicates whether a CGI application runs in its own console.
CreateProcessAsUser | The CreateProcessAsUser property specifies whether a CGI process is created in the system context or in the context of the requesting user.
DefaultDoc | The DefaultDoc contains one or more file names of default documents that will be returned to the client if no file name is included in the client's request. The default document will be returned if the EnableDefaultDoc flag of the DirBrowseFlags property is set to true for the directory. This property can contain a list of default document file names separated by a comma and a space, for example Default.htm, Default.asp.
DirBrowseShowDate | When set to true, date information is displayed when browsing directories.
DirBrowseShowExtension | When set to true, file name extensions are displayed when browsing directories.
DirBrowseShowLongDate | When set to true, date information is displayed in extended format when displaying directories.
DirBrowseShowSize | When set to true, file size information is displayed when browsing directories.
DirBrowseShowTime | When set to true, file time information is displayed when displaying directories.
DontLog | The DontLog property specifies whether client requests are written to the IIS log files.
EnableDefaultDoc | When set to true, the default document (specified by the DefaultDoc property) for a directory is loaded when the directory is browsed.
EnableDirBrowsing | When set to true, directory browsing is enabled.
EnableDocFooter | The EnableDocFooter property enables or disables custom footers specified by the DefaultDocFooter property.
EnableReverseDns | The EnableReverseDns property enables or disables reverse Domain Name Server (DNS) lookups for the World Wide Web Publishing Service (WWW service). Reverse lookups involve looking up the domain name when the IP address is known. Reverse DNS lookups can use significant resources and time.
HelpKeywordPrefix | (Inherited from Task.)
HostHeaderName | Gets or sets host header. Used when you have more than one website in IIS that have the same port but different host headers. (Inherited from WebBase.)
HostObject | (Inherited from Task.)
IISApplicationPath | Gets or sets the application path. (Inherited from WebBase.)
IISAppPoolPath | Gets or sets the IIS application pool path. (Inherited from WebBase.)
IISServerPath | Gets or sets the IIS server path. (Inherited from WebBase.)
Log | (Inherited from Task.)
Password | Gets or sets the password for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (Inherited from WebBase.)
ServerName | Gets or sets the name of the server. The default value is 'localhost'. (Inherited from WebBase.)
ServerPort | Gets or sets the server port. (Inherited from WebBase.)
SsiExecDisable | The SSIExecDisable property specifies whether server-side include (SSI) #exec directives are disabled under this path.
TaskResources | (Inherited from Task.)
UncAuthenticationPassthrough | The UNCAuthenticationPassthrough property enables user authentication passthrough for Universal Naming Convention (UNC) virtual root access (for authentication schemes that support delegation).
Username | Gets or sets the username for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (Inherited from WebBase.)
VirtualDirectoryName | Gets or sets the name of the virtual directory.
VirtualDirectoryPhysicalPath | Gets or sets the virtual directory physical path. The physical directory must exist before this task executes.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


AccessExecute Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.AccessExecute Property
WebDirectoryCreate Class See Also Send Feedback

Gets or sets a value that indicates if the file or the contents of the folder may be executed, regardless of file type.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AccessExecute As Boolean
C#
public bool AccessExecute { get; set; }
Visual C++
public:
property bool AccessExecute {
    bool get ();
    void set (bool value);
}

Field Value

A value indicating if AccessExecute is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


AccessNoRemoteExecute Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.AccessNoRemoteExecute Property
WebDirectoryCreate Class See Also Send Feedback

A value of true indicates that remote requests to execute applications are denied; only requests from the same computer as the IIS server succeed if the AccessExecute property is set to true. You cannot set AccessNoRemoteExecute to false to enable remote requests, and set AccessExecute to false to disable local requests.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AccessNoRemoteExecute As Boolean
C#
public bool AccessNoRemoteExecute { get; set; }
Visual C++
public:
property bool AccessNoRemoteExecute {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if AccessNoRemoteExecute is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


AccessNoRemoteRead Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.AccessNoRemoteRead Property
WebDirectoryCreate Class See Also Send Feedback

A value of true indicates that remote requests to view files are denied; only requests from the same computer as the IIS server succeed if the AccessRead property is set to true. You cannot set AccessNoRemoteRead to false to enable remote requests, and set AccessRead to false to disable local requests.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AccessNoRemoteRead As Boolean
C#
public bool AccessNoRemoteRead { get; set; }
Visual C++
public:
property bool AccessNoRemoteRead {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if AccessNoRemoteRead is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


AccessNoRemoteScript Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.AccessNoRemoteScript Property
WebDirectoryCreate Class See Also Send Feedback

A value of true indicates that remote requests to view dynamic content are denied; only requests from the same computer as the IIS server succeed if the AccessScript property is set to true. You cannot set AccessNoRemoteScript to false to enable remote requests, and set AccessScript to false to disable local requests.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AccessNoRemoteScript As Boolean
C#
public bool AccessNoRemoteScript { get; set; }
Visual C++
public:
property bool AccessNoRemoteScript {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if AccessNoRemoteScript is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


AccessNoRemoteWrite Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.AccessNoRemoteWrite Property
WebDirectoryCreate Class See Also Send Feedback

A value of true indicates that remote requests to create or change files are denied; only requests from the same computer as the IIS server succeed if the AccessWrite property is set to true. You cannot set AccessNoRemoteWrite to false to enable remote requests, and set AccessWrite to false to disable local requests.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AccessNoRemoteWrite As Boolean
C#
public bool AccessNoRemoteWrite { get; set; }
Visual C++
public:
property bool AccessNoRemoteWrite {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if AccessNoRemoteWrite is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


AccessRead Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.AccessRead Property
WebDirectoryCreate Class See Also Send Feedback

A value of true indicates that the file or the contents of the folder may be read through Microsoft Internet Explorer.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AccessRead As Boolean
C#
public bool AccessRead { get; set; }
Visual C++
public:
property bool AccessRead {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if AccessRead is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


AccessScript Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.AccessScript Property
WebDirectoryCreate Class See Also Send Feedback

A value of true indicates that the file or the contents of the folder may be executed if they are script files or static content. A value of false only allows static files, such as HTML files, to be served.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AccessScript As Boolean
C#
public bool AccessScript { get; set; }
Visual C++
public:
property bool AccessScript {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if AccessScript is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


AccessSource Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.AccessSource Property
WebDirectoryCreate Class See Also Send Feedback

A value of true indicates that users are allowed to access source code if either Read or Write permissions are set. Source code includes scripts in Microsoft ® Active Server Pages (ASP) applications.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AccessSource As Boolean
C#
public bool AccessSource { get; set; }
Visual C++
public:
property bool AccessSource {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if AccessSource is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


AccessSsl Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.AccessSsl Property
WebDirectoryCreate Class See Also Send Feedback

A value of true indicates that file access requires SSL file permission processing, with or without a client certificate.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AccessSsl As Boolean
C#
public bool AccessSsl { get; set; }
Visual C++
public:
property bool AccessSsl {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if AccessSsl is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


AccessSsl128 Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.AccessSsl128 Property
WebDirectoryCreate Class See Also Send Feedback

A value of true indicates that file access requires SSL file permission processing with a minimum key size of 128 bits, with or without a client certificate.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AccessSsl128 As Boolean
C#
public bool AccessSsl128 { get; set; }
Visual C++
public:
property bool AccessSsl128 {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if AccessSsl128 is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


AccessSslMapCert Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.AccessSslMapCert Property
WebDirectoryCreate Class See Also Send Feedback

A value of true indicates that SSL file permission processing maps a client certificate to a Microsoft Windows ® operating system user-account. The AccessSslNegotiateCert property must also be set to true for the mapping to occur.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AccessSslMapCert As Boolean
C#
public bool AccessSslMapCert { get; set; }
Visual C++
public:
property bool AccessSslMapCert {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if AccessSslMapCert is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


AccessSslNegotiateCert Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.AccessSslNegotiateCert Property
WebDirectoryCreate Class See Also Send Feedback

A value of true indicates that SSL file access processing requests a certificate from the client. A value of false indicates that access continues if the client does not have a certificate. Some versions of Internet Explorer will close the connection if the server requests a certificate and a certificate is not available (even if AccessSslRequireCert is also set to true).

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AccessSslNegotiateCert As Boolean
C#
public bool AccessSslNegotiateCert { get; set; }
Visual C++
public:
property bool AccessSslNegotiateCert {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if AccessSslNegotiateCert is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


AccessSslRequireCert Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.AccessSslRequireCert Property
WebDirectoryCreate Class See Also Send Feedback

A value of true indicates that SSL file access processing requests a certificate from the client. If the client provides no certificate, the connection is closed. AccessSslNegotiateCert must also be set to true when using AccessSSLRequireCert.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AccessSslRequireCert As Boolean
C#
public bool AccessSslRequireCert { get; set; }
Visual C++
public:
property bool AccessSslRequireCert {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if AccessSslRequireCert is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


AccessWrite Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.AccessWrite Property
WebDirectoryCreate Class See Also Send Feedback

A value of true indicates that users are allowed to upload files and their associated properties to the enabled directory on your server or to change content in a Write-enabled file. Write can be implemented only with a browser that supports the PUT feature of the HTTP 1.1 protocol standard.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AccessWrite As Boolean
C#
public bool AccessWrite { get; set; }
Visual C++
public:
property bool AccessWrite {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if AccessWrite is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


AnonymousPasswordSync Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.AnonymousPasswordSync Property
WebDirectoryCreate Class See Also Send Feedback

The AnonymousPasswordSync property indicates whether IIS should handle the user password for anonymous users attempting to access resources.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AnonymousPasswordSync As Boolean
C#
public bool AnonymousPasswordSync { get; set; }
Visual C++
public:
property bool AnonymousPasswordSync {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if AnonymousPasswordSync is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


AppAllowClientDebug Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.AppAllowClientDebug Property
WebDirectoryCreate Class See Also Send Feedback

The AppAllowClientDebug property specifies whether ASP client-side debugging is enabled. This property is independent of AppAllowDebugging, which applies to server-side debugging.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AppAllowClientDebug As Boolean
C#
public bool AppAllowClientDebug { get; set; }
Visual C++
public:
property bool AppAllowClientDebug {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if AppAllowClientDebug is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


AppAllowDebugging Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.AppAllowDebugging Property
WebDirectoryCreate Class See Also Send Feedback

The AppAllowDebugging property specifies whether ASP debugging is enabled on the server. This property is independent of the AppAllowClientDebug property, which applies to client-side debugging.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AppAllowDebugging As Boolean
C#
public bool AppAllowDebugging { get; set; }
Visual C++
public:
property bool AppAllowDebugging {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if AppAllowDebugging is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


AspAllowSessionState Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.AspAllowSessionState Property
WebDirectoryCreate Class See Also Send Feedback

The AspAllowSessionState property enables session state persistence for the ASP application.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AspAllowSessionState As Boolean
C#
public bool AspAllowSessionState { get; set; }
Visual C++
public:
property bool AspAllowSessionState {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if the AspAllowSessionState is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


AspBufferingOn Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.AspBufferingOn Property
WebDirectoryCreate Class See Also Send Feedback

The AspBufferingOn property specifies whether output from an ASP application will be buffered.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AspBufferingOn As Boolean
C#
public bool AspBufferingOn { get; set; }
Visual C++
public:
property bool AspBufferingOn {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if the AspBufferingOn is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


AspEnableApplicationRestart Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.AspEnableApplicationRestart Property
WebDirectoryCreate Class See Also Send Feedback

The AspEnableApplicationRestart determines whether an ASP application can be automatically restarted. When changes are made to Global.asa or metabase properties that affect an application, the application will not restart unless the AspEnableApplicationRestart property is set to true.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AspEnableApplicationRestart As Boolean
C#
public bool AspEnableApplicationRestart { get; set; }
Visual C++
public:
property bool AspEnableApplicationRestart {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if AspEnableApplicationRestart is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


AspEnableAspHtmlFallback Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.AspEnableAspHtmlFallback Property
WebDirectoryCreate Class See Also Send Feedback

The AspEnableAspHtmlFallback property controls the behavior of ASP when a new request is to be rejected due to a full request queue.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AspEnableAspHtmlFallback As Boolean
C#
public bool AspEnableAspHtmlFallback { get; set; }
Visual C++
public:
property bool AspEnableAspHtmlFallback {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if AspEnableAspHtmlFallback is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


AspEnableChunkedEncoding Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.AspEnableChunkedEncoding Property
WebDirectoryCreate Class See Also Send Feedback

The AspEnableChunkedEncoding property specifies whether HTTP 1.1 chunked transfer encoding is enabled for the World Wide Web Publishing Service (WWW service).

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AspEnableChunkedEncoding As Boolean
C#
public bool AspEnableChunkedEncoding { get; set; }
Visual C++
public:
property bool AspEnableChunkedEncoding {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if AspEnableChunkedEncoding is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


AspEnableParentPaths Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.AspEnableParentPaths Property
WebDirectoryCreate Class See Also Send Feedback

The AspEnableParentPaths property specifies whether an ASP page allows paths relative to the current directory (using the ..\ notation) or above the current directory.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AspEnableParentPaths As Boolean
C#
public bool AspEnableParentPaths { get; set; }
Visual C++
public:
property bool AspEnableParentPaths {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if AspEnableParentPaths is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


AspEnableTypelibCache Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.AspEnableTypelibCache Property
WebDirectoryCreate Class See Also Send Feedback

The AspEnableTypelibCache property specifies whether type libraries are cached on the server. The World Wide Web Publishing Service (WWW service) setting for this property is applicable to all in-process and pooled out-of-process application nodes, at all levels. Metabase settings at the Web server level or lower are ignored for in-process and pooled out-of-process applications. However, settings at the Web server level or lower are used if that node is an isolated out-of-process application.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AspEnableTypelibCache As Boolean
C#
public bool AspEnableTypelibCache { get; set; }
Visual C++
public:
property bool AspEnableTypelibCache {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if AspEnableTypelibCache is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


AspErrorsToNTLog Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.AspErrorsToNTLog Property
WebDirectoryCreate Class See Also Send Feedback

The AspErrorsToNTLog property specifies which ASP errors are written to the Windows event log. ASP errors are written to the client browser and to the IIS log files by default.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AspErrorsToNTLog As Boolean
C#
public bool AspErrorsToNTLog { get; set; }
Visual C++
public:
property bool AspErrorsToNTLog {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if AspErrorsToNTLog is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


AspExceptionCatchEnable Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.AspExceptionCatchEnable Property
WebDirectoryCreate Class See Also Send Feedback

The AspExceptionCatchEnable property specifies whether ASP pages trap exceptions thrown by components.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AspExceptionCatchEnable As Boolean
C#
public bool AspExceptionCatchEnable { get; set; }
Visual C++
public:
property bool AspExceptionCatchEnable {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if AspExceptionCatchEnable is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


AspLogErrorRequests Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.AspLogErrorRequests Property
WebDirectoryCreate Class See Also Send Feedback

The AspLogErrorRequests property controls whether the Web server writes ASP errors to the application section of the Windows event log. ASP errors are written to the client browser and to the IIS log files by default.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AspLogErrorRequests As Boolean
C#
public bool AspLogErrorRequests { get; set; }
Visual C++
public:
property bool AspLogErrorRequests {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if AspLogErrorRequests is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


AspScriptErrorMessage Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.AspScriptErrorMessage Property
WebDirectoryCreate Class See Also Send Feedback

The AspScriptErrorMessage property specifies the error message to send to the browser if specific debugging errors are not sent to the client (if AspScriptErrorSentToBrowser is set to false).

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AspScriptErrorMessage As String
C#
public string AspScriptErrorMessage { get; set; }
Visual C++
public:
property String^ AspScriptErrorMessage {
    String^ get ();
    void set (String^ value);
}

Field Value

Value indicating if AspScriptErrorMessage is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


AspScriptErrorSentToBrowser Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.AspScriptErrorSentToBrowser Property
WebDirectoryCreate Class See Also Send Feedback

The AspScriptErrorSentToBrowser property specifies whether the Web server writes debugging specifics (file name, error, line number, description) to the client browser, in addition to logging them to the Windows Event Log. The AspScriptErrorMessage property provides the error message to be sent if this property is set to false.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AspScriptErrorSentToBrowser As Boolean
C#
public bool AspScriptErrorSentToBrowser { get; set; }
Visual C++
public:
property bool AspScriptErrorSentToBrowser {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if AspScriptErrorSentToBrowser is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


AspTrackThreadingModel Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.AspTrackThreadingModel Property
WebDirectoryCreate Class See Also Send Feedback

The AspTrackThreadingModel property specifies whether IIS checks the threading model of any components (COM objects) that your application creates. The preferred setting of this metabase property is false.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AspTrackThreadingModel As Boolean
C#
public bool AspTrackThreadingModel { get; set; }
Visual C++
public:
property bool AspTrackThreadingModel {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if AspTrackThreadingModel is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


AuthAnonymous Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.AuthAnonymous Property
WebDirectoryCreate Class See Also Send Feedback

Specifies Anonymous authentication as one of the possible Windows authentication schemes returned to clients as being available.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AuthAnonymous As Boolean
C#
public bool AuthAnonymous { get; set; }
Visual C++
public:
property bool AuthAnonymous {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if AuthAnonymous is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


AuthBasic Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.AuthBasic Property
WebDirectoryCreate Class See Also Send Feedback

Specifies Basic authentication as one of the possible Windows authentication schemes returned to clients as being available.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AuthBasic As Boolean
C#
public bool AuthBasic { get; set; }
Visual C++
public:
property bool AuthBasic {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if AuthBasic is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


AuthNtlm Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.AuthNtlm Property
WebDirectoryCreate Class See Also Send Feedback

Specifies Integrated Windows authentication (also known as Challenge/Response or NTLM authentication) as one of the possible Windows authentication schemes returned to clients as being available.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AuthNtlm As Boolean
C#
public bool AuthNtlm { get; set; }
Visual C++
public:
property bool AuthNtlm {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if AuthNtlm is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


AuthPersistSingleRequest Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.AuthPersistSingleRequest Property
WebDirectoryCreate Class See Also Send Feedback

Setting this flag to true specifies that authentication persists only for a single request on a connection. IIS resets the authentication at the end of each request, and forces re-authentication on the next request of the session.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AuthPersistSingleRequest As Boolean
C#
public bool AuthPersistSingleRequest { get; set; }
Visual C++
public:
property bool AuthPersistSingleRequest {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if AuthPersistSingleRequest is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


AuthPersistSingleRequestAlwaysIfProxy Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.AuthPersistSingleRequestAlwaysIfProxy Property
WebDirectoryCreate Class See Also Send Feedback

Setting this flag to true specifies that authentication is valid for a single request if by proxy. IIS will reset the authentication at the end of the request and force re-authentication on the next request if the current authenticated request is by proxy of any type.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AuthPersistSingleRequestAlwaysIfProxy As Boolean
C#
public bool AuthPersistSingleRequestAlwaysIfProxy { get; set; }
Visual C++
public:
property bool AuthPersistSingleRequestAlwaysIfProxy {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if AuthPersistSingleRequestAlwaysIfProxy is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


AuthPersistSingleRequestIfProxy Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.AuthPersistSingleRequestIfProxy Property
WebDirectoryCreate Class See Also Send Feedback

Setting this flag to true specifies authentication will persist only across single requests on a connection if the connection is by proxy. IIS will reset the authentication at the end of the request if the current authenticated request is by proxy and it is not the special case where IIS is running MSPROXY.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AuthPersistSingleRequestIfProxy As Boolean
C#
public bool AuthPersistSingleRequestIfProxy { get; set; }
Visual C++
public:
property bool AuthPersistSingleRequestIfProxy {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if AuthPersistSingleRequestIfProxy is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


CacheControlNoCache Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.CacheControlNoCache Property
WebDirectoryCreate Class See Also Send Feedback

The CacheControlNoCache property specifies the HTTP 1.1 directive to prevent caching of content.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property CacheControlNoCache As Boolean
C#
public bool CacheControlNoCache { get; set; }
Visual C++
public:
property bool CacheControlNoCache {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if CacheControlNoCache is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


CacheIsapi Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.CacheIsapi Property
WebDirectoryCreate Class See Also Send Feedback

The CacheISAPI property indicates whether ISAPI extensions are cached in memory after first use.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property CacheIsapi As Boolean
C#
public bool CacheIsapi { get; set; }
Visual C++
public:
property bool CacheIsapi {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if CacheIsapi is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


ContentIndexed Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.ContentIndexed Property
WebDirectoryCreate Class See Also Send Feedback

The ContentIndexed property specifies whether the installed content indexer should index content under this directory tree.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ContentIndexed As Boolean
C#
public bool ContentIndexed { get; set; }
Visual C++
public:
property bool ContentIndexed {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if ContentIndexed is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


CpuAppEnabled Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.CpuAppEnabled Property
WebDirectoryCreate Class See Also Send Feedback

This property specifies whether process accounting and throttling should be performed for ISAPI extensions and ASP applications. To perform process accounting on CGI applications, use the property CpuCgiEnabled.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property CpuAppEnabled As Boolean
C#
public bool CpuAppEnabled { get; set; }
Visual C++
public:
property bool CpuAppEnabled {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if CpuAppEnabled is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


CpuCgiEnabled Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.CpuCgiEnabled Property
WebDirectoryCreate Class See Also Send Feedback

This property indicates whether IIS should perform process accounting for CGI applications. To effectively throttle CGI applications, use the CgiTimeout property. To use process accounting for ISAPI and ASP applications, use CpuAppEnabled.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property CpuCgiEnabled As Boolean
C#
public bool CpuCgiEnabled { get; set; }
Visual C++
public:
property bool CpuCgiEnabled {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if CpuCgiEnabled is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


CreateCgiWithNewConsole Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.CreateCgiWithNewConsole Property
WebDirectoryCreate Class See Also Send Feedback

The CreateCGIWithNewConsole property indicates whether a CGI application runs in its own console.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property CreateCgiWithNewConsole As Boolean
C#
public bool CreateCgiWithNewConsole { get; set; }
Visual C++
public:
property bool CreateCgiWithNewConsole {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if CreateCgiWithNewConsole is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


CreateProcessAsUser Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.CreateProcessAsUser Property
WebDirectoryCreate Class See Also Send Feedback

The CreateProcessAsUser property specifies whether a CGI process is created in the system context or in the context of the requesting user.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property CreateProcessAsUser As Boolean
C#
public bool CreateProcessAsUser { get; set; }
Visual C++
public:
property bool CreateProcessAsUser {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if CreateProcessAsUser is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


DefaultDoc Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.DefaultDoc Property
WebDirectoryCreate Class See Also Send Feedback

The DefaultDoc contains one or more file names of default documents that will be returned to the client if no file name is included in the client's request. The default document will be returned if the EnableDefaultDoc flag of the DirBrowseFlags property is set to true for the directory. This property can contain a list of default document file names separated by a comma and a space, for example Default.htm, Default.asp.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultDoc As String
C#
public string DefaultDoc { get; set; }
Visual C++
public:
property String^ DefaultDoc {
    String^ get ();
    void set (String^ value);
}

Field Value

Listing of the default documents for the web application.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


DirBrowseShowDate Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.DirBrowseShowDate Property
WebDirectoryCreate Class See Also Send Feedback

When set to true, date information is displayed when browsing directories.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property DirBrowseShowDate As Boolean
C#
public bool DirBrowseShowDate { get; set; }
Visual C++
public:
property bool DirBrowseShowDate {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if DirBrowseShowDate is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


DirBrowseShowExtension Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.DirBrowseShowExtension Property
WebDirectoryCreate Class See Also Send Feedback

When set to true, file name extensions are displayed when browsing directories.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property DirBrowseShowExtension As Boolean
C#
public bool DirBrowseShowExtension { get; set; }
Visual C++
public:
property bool DirBrowseShowExtension {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if DirBrowseShowExtension is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


DirBrowseShowLongDate Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.DirBrowseShowLongDate Property
WebDirectoryCreate Class See Also Send Feedback

When set to true, date information is displayed in extended format when displaying directories.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property DirBrowseShowLongDate As Boolean
C#
public bool DirBrowseShowLongDate { get; set; }
Visual C++
public:
property bool DirBrowseShowLongDate {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if DirBrowseShowLongDate is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


DirBrowseShowSize Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.DirBrowseShowSize Property
WebDirectoryCreate Class See Also Send Feedback

When set to true, file size information is displayed when browsing directories.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property DirBrowseShowSize As Boolean
C#
public bool DirBrowseShowSize { get; set; }
Visual C++
public:
property bool DirBrowseShowSize {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if DirBrowseShowSize is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


DirBrowseShowTime Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.DirBrowseShowTime Property
WebDirectoryCreate Class See Also Send Feedback

When set to true, file time information is displayed when displaying directories.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property DirBrowseShowTime As Boolean
C#
public bool DirBrowseShowTime { get; set; }
Visual C++
public:
property bool DirBrowseShowTime {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if DirBrowseShowTime is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


DontLog Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.DontLog Property
WebDirectoryCreate Class See Also Send Feedback

The DontLog property specifies whether client requests are written to the IIS log files.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property DontLog As Boolean
C#
public bool DontLog { get; set; }
Visual C++
public:
property bool DontLog {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if DontLog is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


EnableDefaultDoc Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.EnableDefaultDoc Property
WebDirectoryCreate Class See Also Send Feedback

When set to true, the default document (specified by the DefaultDoc property) for a directory is loaded when the directory is browsed.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property EnableDefaultDoc As Boolean
C#
public bool EnableDefaultDoc { get; set; }
Visual C++
public:
property bool EnableDefaultDoc {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if EnableDefaultDoc is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


EnableDirBrowsing Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.EnableDirBrowsing Property
WebDirectoryCreate Class See Also Send Feedback

When set to true, directory browsing is enabled.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property EnableDirBrowsing As Boolean
C#
public bool EnableDirBrowsing { get; set; }
Visual C++
public:
property bool EnableDirBrowsing {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if EnableDirBrowsing is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


EnableDocFooter Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.EnableDocFooter Property
WebDirectoryCreate Class See Also Send Feedback

The EnableDocFooter property enables or disables custom footers specified by the DefaultDocFooter property.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property EnableDocFooter As Boolean
C#
public bool EnableDocFooter { get; set; }
Visual C++
public:
property bool EnableDocFooter {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if EnableDocFooter is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


EnableReverseDns Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.EnableReverseDns Property
WebDirectoryCreate Class See Also Send Feedback

The EnableReverseDns property enables or disables reverse Domain Name Server (DNS) lookups for the World Wide Web Publishing Service (WWW service). Reverse lookups involve looking up the domain name when the IP address is known. Reverse DNS lookups can use significant resources and time.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property EnableReverseDns As Boolean
C#
public bool EnableReverseDns { get; set; }
Visual C++
public:
property bool EnableReverseDns {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if EnableReverseDns is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


SsiExecDisable Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.SsiExecDisable Property
WebDirectoryCreate Class See Also Send Feedback

The SSIExecDisable property specifies whether server-side include (SSI) #exec directives are disabled under this path.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property SsiExecDisable As Boolean
C#
public bool SsiExecDisable { get; set; }
Visual C++
public:
property bool SsiExecDisable {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if SsiExecDisable is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


UncAuthenticationPassthrough Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.UncAuthenticationPassthrough Property
WebDirectoryCreate Class See Also Send Feedback

The UNCAuthenticationPassthrough property enables user authentication passthrough for Universal Naming Convention (UNC) virtual root access (for authentication schemes that support delegation).

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property UncAuthenticationPassthrough As Boolean
C#
public bool UncAuthenticationPassthrough { get; set; }
Visual C++
public:
property bool UncAuthenticationPassthrough {
    bool get ();
    void set (bool value);
}

Field Value

Value indicating if UncAuthenticationPassthrough is enabled or disabled.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


VirtualDirectoryName Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.VirtualDirectoryName Property
WebDirectoryCreate Class See Also Send Feedback

Gets or sets the name of the virtual directory.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property VirtualDirectoryName As String
C#
[RequiredAttribute]
public string VirtualDirectoryName { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ VirtualDirectoryName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the virtual directory.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


VirtualDirectoryPhysicalPath Property

[image]

.NET Framework Class Library
WebDirectoryCreate..::.VirtualDirectoryPhysicalPath Property
WebDirectoryCreate Class See Also Send Feedback

Gets or sets the virtual directory physical path. The physical directory must exist before this task executes.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property VirtualDirectoryPhysicalPath As String
C#
[RequiredAttribute]
public string VirtualDirectoryPhysicalPath { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ VirtualDirectoryPhysicalPath {
    String^ get ();
    void set (String^ value);
}

Field Value

The virtual directory physical path.

See Also

WebDirectoryCreate Class
MSBuild.Community.Tasks.IIS Namespace


WebDirectoryDelete Class

[image]

.NET Framework Class Library
WebDirectoryDelete Class
Members Example See Also Send Feedback

Deletes a web directory on a local or remote machine with IIS installed. The default is to delete the web directory on the local machine. If connecting to a remote machine, you can specify the Username and Password for the task to run under.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class WebDirectoryDelete _
    Inherits WebBase
C#
public class WebDirectoryDelete : WebBase
Visual C++
public ref class WebDirectoryDelete : public WebBase

Examples

Deletes a web directory on the local machine.
Copy Code
            <WebDirectoryDelete VirtualDirectoryName="MyVirDir" />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.IIS..::.WebBase
MSBuild.Community.Tasks.IIS..::.WebDirectoryDelete

See Also

WebDirectoryDelete Members
MSBuild.Community.Tasks.IIS Namespace


WebDirectoryDelete Members

[image] [image]

.NET Framework Class Library
WebDirectoryDelete Members
WebDirectoryDelete Class Constructors Methods Fields Properties See Also Send Feedback

The WebDirectoryDelete type exposes the following members.

Constructors

Name | Description
WebDirectoryDelete |

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetIISVersion | Gets the IIS version. (Inherited from WebBase.)
GetRemoteOSVersion | Gets the remote machine OS version. (Inherited from WebBase.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)
VerifyIISRoot | Verifies that the IIS root exists based on the ServerName and ServerPort. (Inherited from WebBase.)

Fields

Name | Description
mIISVersion | IIS version. (Inherited from WebBase.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostHeaderName | Gets or sets host header. Used when you have more than one website in IIS that have the same port but different host headers. (Inherited from WebBase.)
HostObject | (Inherited from Task.)
IISApplicationPath | Gets or sets the application path. (Inherited from WebBase.)
IISAppPoolPath | Gets or sets the IIS application pool path. (Inherited from WebBase.)
IISServerPath | Gets or sets the IIS server path. (Inherited from WebBase.)
Log | (Inherited from Task.)
Password | Gets or sets the password for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (Inherited from WebBase.)
ServerName | Gets or sets the name of the server. The default value is 'localhost'. (Inherited from WebBase.)
ServerPort | Gets or sets the server port. (Inherited from WebBase.)
TaskResources | (Inherited from Task.)
Username | Gets or sets the username for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (Inherited from WebBase.)
VirtualDirectoryName | Gets or sets the name of the virtual directory.

See Also

WebDirectoryDelete Class
MSBuild.Community.Tasks.IIS Namespace


WebDirectoryDelete Constructor

[image]

.NET Framework Class Library
WebDirectoryDelete Constructor
WebDirectoryDelete Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public WebDirectoryDelete()
Visual C++
public:
WebDirectoryDelete()

See Also

WebDirectoryDelete Class
MSBuild.Community.Tasks.IIS Namespace


WebDirectoryDelete Fields

[image] [image]

.NET Framework Class Library
WebDirectoryDelete Fields
WebDirectoryDelete Class See Also Send Feedback

The WebDirectoryDelete type exposes the following members.

Fields

Name | Description
mIISVersion | IIS version. (Inherited from WebBase.)

See Also

WebDirectoryDelete Class
MSBuild.Community.Tasks.IIS Namespace


WebDirectoryDelete Methods

[image] [image]

.NET Framework Class Library
WebDirectoryDelete Methods
WebDirectoryDelete Class See Also Send Feedback

The WebDirectoryDelete type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetIISVersion | Gets the IIS version. (Inherited from WebBase.)
GetRemoteOSVersion | Gets the remote machine OS version. (Inherited from WebBase.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)
VerifyIISRoot | Verifies that the IIS root exists based on the ServerName and ServerPort. (Inherited from WebBase.)

See Also

WebDirectoryDelete Class
MSBuild.Community.Tasks.IIS Namespace


Execute Method

[image]

.NET Framework Class Library
WebDirectoryDelete..::.Execute Method
WebDirectoryDelete Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

True if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

WebDirectoryDelete Class
MSBuild.Community.Tasks.IIS Namespace


WebDirectoryDelete Properties

[image] [image]

.NET Framework Class Library
WebDirectoryDelete Properties
WebDirectoryDelete Class See Also Send Feedback

The WebDirectoryDelete type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostHeaderName | Gets or sets host header. Used when you have more than one website in IIS that have the same port but different host headers. (Inherited from WebBase.)
HostObject | (Inherited from Task.)
IISApplicationPath | Gets or sets the application path. (Inherited from WebBase.)
IISAppPoolPath | Gets or sets the IIS application pool path. (Inherited from WebBase.)
IISServerPath | Gets or sets the IIS server path. (Inherited from WebBase.)
Log | (Inherited from Task.)
Password | Gets or sets the password for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (Inherited from WebBase.)
ServerName | Gets or sets the name of the server. The default value is 'localhost'. (Inherited from WebBase.)
ServerPort | Gets or sets the server port. (Inherited from WebBase.)
TaskResources | (Inherited from Task.)
Username | Gets or sets the username for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (Inherited from WebBase.)
VirtualDirectoryName | Gets or sets the name of the virtual directory.

See Also

WebDirectoryDelete Class
MSBuild.Community.Tasks.IIS Namespace


VirtualDirectoryName Property

[image]

.NET Framework Class Library
WebDirectoryDelete..::.VirtualDirectoryName Property
WebDirectoryDelete Class See Also Send Feedback

Gets or sets the name of the virtual directory.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property VirtualDirectoryName As String
C#
[RequiredAttribute]
public string VirtualDirectoryName { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ VirtualDirectoryName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the virtual directory.

See Also

WebDirectoryDelete Class
MSBuild.Community.Tasks.IIS Namespace


WebDirectoryScriptMap Class

[image]

.NET Framework Class Library
WebDirectoryScriptMap Class
Members Example See Also Send Feedback

Sets an application mapping for a filename extension on an existing web directory.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class WebDirectoryScriptMap _
    Inherits WebBase
C#
public class WebDirectoryScriptMap : WebBase
Visual C++
public ref class WebDirectoryScriptMap : public WebBase

Examples

Map the .axd extension to the lastest version of ASP.NET:
Copy Code
            <WebDirectoryScriptMap VirtualDirectoryName="MyWeb" Extension=".axd" MapToAspNet="True" VerifyFileExists="False" />

Examples

Map GET requests to the .rss extension to a specific executable:
Copy Code
            <WebDirectoryScriptMap VirtualDirectoryName="MyWeb" Extension=".rss" Verbs="GET" ExecutablePath="$(WINDIR)\Microsoft.Net\Framework\1.0.3705\aspnet_isapi.dll" />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.IIS..::.WebBase
MSBuild.Community.Tasks.IIS..::.WebDirectoryScriptMap

See Also

WebDirectoryScriptMap Members
MSBuild.Community.Tasks.IIS Namespace


WebDirectoryScriptMap Members

[image] [image]

.NET Framework Class Library
WebDirectoryScriptMap Members
WebDirectoryScriptMap Class Constructors Methods Fields Properties See Also Send Feedback

The WebDirectoryScriptMap type exposes the following members.

Constructors

Name | Description
WebDirectoryScriptMap |

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetIISVersion | Gets the IIS version. (Inherited from WebBase.)
GetRemoteOSVersion | Gets the remote machine OS version. (Inherited from WebBase.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)
VerifyIISRoot | Verifies that the IIS root exists based on the ServerName and ServerPort. (Inherited from WebBase.)

Fields

Name | Description
mIISVersion | IIS version. (Inherited from WebBase.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
EnableScriptEngine | Set to true when you want the application to run in a directory without Execute permissions.
ExecutablePath | The full path to the executable used to respond to requests for a Uri ending with Extension
Extension | The filename extension that will be mapped to an executable.
HelpKeywordPrefix | (Inherited from Task.)
HostHeaderName | Gets or sets host header. Used when you have more than one website in IIS that have the same port but different host headers. (Inherited from WebBase.)
HostObject | (Inherited from Task.)
IISApplicationPath | Gets or sets the application path. (Inherited from WebBase.)
IISAppPoolPath | Gets or sets the IIS application pool path. (Inherited from WebBase.)
IISServerPath | Gets or sets the IIS server path. (Inherited from WebBase.)
Log | (Inherited from Task.)
MapToAspNet | Indicates whether Extension should be mapped to the ASP.NET runtime.
Password | Gets or sets the password for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (Inherited from WebBase.)
ServerName | Gets or sets the name of the server. The default value is 'localhost'. (Inherited from WebBase.)
ServerPort | Gets or sets the server port. (Inherited from WebBase.)
TaskResources | (Inherited from Task.)
Username | Gets or sets the username for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (Inherited from WebBase.)
Verbs | A comma-separated list of the HTTP verbs to include in the application mapping.
VerifyFileExists | Set to true to instruct the Web server to verify the existence of the requested script file and to ensure that the requesting user has access permission for that script file.
VirtualDirectoryName | Gets or sets the name of the virtual directory.

See Also

WebDirectoryScriptMap Class
MSBuild.Community.Tasks.IIS Namespace


WebDirectoryScriptMap Constructor

[image]

.NET Framework Class Library
WebDirectoryScriptMap Constructor
WebDirectoryScriptMap Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public WebDirectoryScriptMap()
Visual C++
public:
WebDirectoryScriptMap()

See Also

WebDirectoryScriptMap Class
MSBuild.Community.Tasks.IIS Namespace


WebDirectoryScriptMap Fields

[image] [image]

.NET Framework Class Library
WebDirectoryScriptMap Fields
WebDirectoryScriptMap Class See Also Send Feedback

The WebDirectoryScriptMap type exposes the following members.

Fields

Name | Description
mIISVersion | IIS version. (Inherited from WebBase.)

See Also

WebDirectoryScriptMap Class
MSBuild.Community.Tasks.IIS Namespace


WebDirectoryScriptMap Methods

[image] [image]

.NET Framework Class Library
WebDirectoryScriptMap Methods
WebDirectoryScriptMap Class See Also Send Feedback

The WebDirectoryScriptMap type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetIISVersion | Gets the IIS version. (Inherited from WebBase.)
GetRemoteOSVersion | Gets the remote machine OS version. (Inherited from WebBase.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)
VerifyIISRoot | Verifies that the IIS root exists based on the ServerName and ServerPort. (Inherited from WebBase.)

See Also

WebDirectoryScriptMap Class
MSBuild.Community.Tasks.IIS Namespace


Execute Method

[image]

.NET Framework Class Library
WebDirectoryScriptMap..::.Execute Method
WebDirectoryScriptMap Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

True if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

WebDirectoryScriptMap Class
MSBuild.Community.Tasks.IIS Namespace


WebDirectoryScriptMap Properties

[image] [image]

.NET Framework Class Library
WebDirectoryScriptMap Properties
WebDirectoryScriptMap Class See Also Send Feedback

The WebDirectoryScriptMap type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
EnableScriptEngine | Set to true when you want the application to run in a directory without Execute permissions.
ExecutablePath | The full path to the executable used to respond to requests for a Uri ending with Extension
Extension | The filename extension that will be mapped to an executable.
HelpKeywordPrefix | (Inherited from Task.)
HostHeaderName | Gets or sets host header. Used when you have more than one website in IIS that have the same port but different host headers. (Inherited from WebBase.)
HostObject | (Inherited from Task.)
IISApplicationPath | Gets or sets the application path. (Inherited from WebBase.)
IISAppPoolPath | Gets or sets the IIS application pool path. (Inherited from WebBase.)
IISServerPath | Gets or sets the IIS server path. (Inherited from WebBase.)
Log | (Inherited from Task.)
MapToAspNet | Indicates whether Extension should be mapped to the ASP.NET runtime.
Password | Gets or sets the password for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (Inherited from WebBase.)
ServerName | Gets or sets the name of the server. The default value is 'localhost'. (Inherited from WebBase.)
ServerPort | Gets or sets the server port. (Inherited from WebBase.)
TaskResources | (Inherited from Task.)
Username | Gets or sets the username for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (Inherited from WebBase.)
Verbs | A comma-separated list of the HTTP verbs to include in the application mapping.
VerifyFileExists | Set to true to instruct the Web server to verify the existence of the requested script file and to ensure that the requesting user has access permission for that script file.
VirtualDirectoryName | Gets or sets the name of the virtual directory.

See Also

WebDirectoryScriptMap Class
MSBuild.Community.Tasks.IIS Namespace


EnableScriptEngine Property

[image]

.NET Framework Class Library
WebDirectoryScriptMap..::.EnableScriptEngine Property
WebDirectoryScriptMap Class See Also Send Feedback

Set to true when you want the application to run in a directory without Execute permissions.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property EnableScriptEngine As Boolean
C#
public bool EnableScriptEngine { get; set; }
Visual C++
public:
property bool EnableScriptEngine {
    bool get ();
    void set (bool value);
}

See Also

WebDirectoryScriptMap Class
MSBuild.Community.Tasks.IIS Namespace


ExecutablePath Property

[image]

.NET Framework Class Library
WebDirectoryScriptMap..::.ExecutablePath Property
WebDirectoryScriptMap Class See Also Send Feedback

The full path to the executable used to respond to requests for a Uri ending with Extension

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ExecutablePath As String
C#
public string ExecutablePath { get; set; }
Visual C++
public:
property String^ ExecutablePath {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is required when MapToAspNet is false (the default).

See Also

WebDirectoryScriptMap Class
MSBuild.Community.Tasks.IIS Namespace


Extension Property

[image]

.NET Framework Class Library
WebDirectoryScriptMap..::.Extension Property
WebDirectoryScriptMap Class See Also Send Feedback

The filename extension that will be mapped to an executable.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property Extension As String
C#
[RequiredAttribute]
public string Extension { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ Extension {
    String^ get ();
    void set (String^ value);
}

See Also

WebDirectoryScriptMap Class
MSBuild.Community.Tasks.IIS Namespace


MapToAspNet Property

[image]

.NET Framework Class Library
WebDirectoryScriptMap..::.MapToAspNet Property
WebDirectoryScriptMap Class See Also Send Feedback

Indicates whether Extension should be mapped to the ASP.NET runtime.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property MapToAspNet As Boolean
C#
public bool MapToAspNet { get; set; }
Visual C++
public:
property bool MapToAspNet {
    bool get ();
    void set (bool value);
}

Remarks

When true, ExecutablePath is set to aspnet_isapi.dll in the installation folder of the latest version of the .NET Framework.

See Also

WebDirectoryScriptMap Class
MSBuild.Community.Tasks.IIS Namespace


Verbs Property

[image]

.NET Framework Class Library
WebDirectoryScriptMap..::.Verbs Property
WebDirectoryScriptMap Class See Also Send Feedback

A comma-separated list of the HTTP verbs to include in the application mapping.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Verbs As String
C#
public string Verbs { get; set; }
Visual C++
public:
property String^ Verbs {
    String^ get ();
    void set (String^ value);
}

Remarks

The default behavior (when this property is empty or unspecified) is to map all verbs.

A semi-colon-separated list will also be recognized, allowing you to use an MSBuild Item.

See Also

WebDirectoryScriptMap Class
MSBuild.Community.Tasks.IIS Namespace


VerifyFileExists Property

[image]

.NET Framework Class Library
WebDirectoryScriptMap..::.VerifyFileExists Property
WebDirectoryScriptMap Class See Also Send Feedback

Set to true to instruct the Web server to verify the existence of the requested script file and to ensure that the requesting user has access permission for that script file.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property VerifyFileExists As Boolean
C#
public bool VerifyFileExists { get; set; }
Visual C++
public:
property bool VerifyFileExists {
    bool get ();
    void set (bool value);
}

See Also

WebDirectoryScriptMap Class
MSBuild.Community.Tasks.IIS Namespace


VirtualDirectoryName Property

[image]

.NET Framework Class Library
WebDirectoryScriptMap..::.VirtualDirectoryName Property
WebDirectoryScriptMap Class See Also Send Feedback

Gets or sets the name of the virtual directory.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property VirtualDirectoryName As String
C#
[RequiredAttribute]
public string VirtualDirectoryName { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ VirtualDirectoryName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the virtual directory.

See Also

WebDirectoryScriptMap Class
MSBuild.Community.Tasks.IIS Namespace


WebDirectorySetting Class

[image]

.NET Framework Class Library
WebDirectorySetting Class
Members Example See Also Send Feedback

Reads and modifies a web directory configuration setting.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class WebDirectorySetting _
    Inherits WebBase
C#
public class WebDirectorySetting : WebBase
Visual C++
public ref class WebDirectorySetting : public WebBase

Examples

Display the file system path of the MyWeb web directory:
Copy Code
            <WebDirectorySetting VirtualDirectoryName="MyWeb" SettingName="Path">
                <Output TaskParameter="SettingValue" PropertyName="LocalPath" />
            </WebDirectorySetting>
            <Message Text="MyWeb is located at $(LocalPath)" />

Examples

Set the default document for the MyWeb directory to Default.aspx:
Copy Code
            <WebDirectorySetting VirtualDirectoryName="MyWeb" SettingName="DefaultDoc" SettingValue="Default.aspx" />
            <WebDirectorySetting VirtualDirectoryName="MyWeb" SettingName="EnableDefaultDoc" SettingValue="True" />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.IIS..::.WebBase
MSBuild.Community.Tasks.IIS..::.WebDirectorySetting

See Also

WebDirectorySetting Members
MSBuild.Community.Tasks.IIS Namespace


WebDirectorySetting Members

[image] [image]

.NET Framework Class Library
WebDirectorySetting Members
WebDirectorySetting Class Constructors Methods Fields Properties See Also Send Feedback

The WebDirectorySetting type exposes the following members.

Constructors

Name | Description
WebDirectorySetting |

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetIISVersion | Gets the IIS version. (Inherited from WebBase.)
GetRemoteOSVersion | Gets the remote machine OS version. (Inherited from WebBase.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)
VerifyIISRoot | Verifies that the IIS root exists based on the ServerName and ServerPort. (Inherited from WebBase.)

Fields

Name | Description
mIISVersion | IIS version. (Inherited from WebBase.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostHeaderName | Gets or sets host header. Used when you have more than one website in IIS that have the same port but different host headers. (Inherited from WebBase.)
HostObject | (Inherited from Task.)
IISApplicationPath | Gets or sets the application path. (Inherited from WebBase.)
IISAppPoolPath | Gets or sets the IIS application pool path. (Inherited from WebBase.)
IISServerPath | Gets or sets the IIS server path. (Inherited from WebBase.)
Log | (Inherited from Task.)
Password | Gets or sets the password for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (Inherited from WebBase.)
ServerName | Gets or sets the name of the server. The default value is 'localhost'. (Inherited from WebBase.)
ServerPort | Gets or sets the server port. (Inherited from WebBase.)
SettingName | Gets or sets the configuration setting to read or modify.
SettingValue | Gets or sets the value of SettingName on the web directory
TaskResources | (Inherited from Task.)
Username | Gets or sets the username for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (Inherited from WebBase.)
VirtualDirectoryName | Gets or sets the name of the virtual directory.

See Also

WebDirectorySetting Class
MSBuild.Community.Tasks.IIS Namespace


WebDirectorySetting Constructor

[image]

.NET Framework Class Library
WebDirectorySetting Constructor
WebDirectorySetting Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public WebDirectorySetting()
Visual C++
public:
WebDirectorySetting()

See Also

WebDirectorySetting Class
MSBuild.Community.Tasks.IIS Namespace


WebDirectorySetting Fields

[image] [image]

.NET Framework Class Library
WebDirectorySetting Fields
WebDirectorySetting Class See Also Send Feedback

The WebDirectorySetting type exposes the following members.

Fields

Name | Description
mIISVersion | IIS version. (Inherited from WebBase.)

See Also

WebDirectorySetting Class
MSBuild.Community.Tasks.IIS Namespace


WebDirectorySetting Methods

[image] [image]

.NET Framework Class Library
WebDirectorySetting Methods
WebDirectorySetting Class See Also Send Feedback

The WebDirectorySetting type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetIISVersion | Gets the IIS version. (Inherited from WebBase.)
GetRemoteOSVersion | Gets the remote machine OS version. (Inherited from WebBase.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)
VerifyIISRoot | Verifies that the IIS root exists based on the ServerName and ServerPort. (Inherited from WebBase.)

See Also

WebDirectorySetting Class
MSBuild.Community.Tasks.IIS Namespace


Execute Method

[image]

.NET Framework Class Library
WebDirectorySetting..::.Execute Method
WebDirectorySetting Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

True if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

WebDirectorySetting Class
MSBuild.Community.Tasks.IIS Namespace


WebDirectorySetting Properties

[image] [image]

.NET Framework Class Library
WebDirectorySetting Properties
WebDirectorySetting Class See Also Send Feedback

The WebDirectorySetting type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostHeaderName | Gets or sets host header. Used when you have more than one website in IIS that have the same port but different host headers. (Inherited from WebBase.)
HostObject | (Inherited from Task.)
IISApplicationPath | Gets or sets the application path. (Inherited from WebBase.)
IISAppPoolPath | Gets or sets the IIS application pool path. (Inherited from WebBase.)
IISServerPath | Gets or sets the IIS server path. (Inherited from WebBase.)
Log | (Inherited from Task.)
Password | Gets or sets the password for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (Inherited from WebBase.)
ServerName | Gets or sets the name of the server. The default value is 'localhost'. (Inherited from WebBase.)
ServerPort | Gets or sets the server port. (Inherited from WebBase.)
SettingName | Gets or sets the configuration setting to read or modify.
SettingValue | Gets or sets the value of SettingName on the web directory
TaskResources | (Inherited from Task.)
Username | Gets or sets the username for the account the task will run under. This property is needed if you specified a ServerName for a remote machine. (Inherited from WebBase.)
VirtualDirectoryName | Gets or sets the name of the virtual directory.

See Also

WebDirectorySetting Class
MSBuild.Community.Tasks.IIS Namespace


SettingName Property

[image]

.NET Framework Class Library
WebDirectorySetting..::.SettingName Property
WebDirectorySetting Class See Also Send Feedback

Gets or sets the configuration setting to read or modify.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property SettingName As String
C#
[RequiredAttribute]
public string SettingName { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ SettingName {
    String^ get ();
    void set (String^ value);
}

See Also

WebDirectorySetting Class
MSBuild.Community.Tasks.IIS Namespace


SettingValue Property

[image]

.NET Framework Class Library
WebDirectorySetting..::.SettingValue Property
WebDirectorySetting Class See Also Send Feedback

Gets or sets the value of SettingName on the web directory

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public Property SettingValue As String
C#
[OutputAttribute]
public string SettingValue { get; set; }
Visual C++
[OutputAttribute]
public:
property String^ SettingValue {
    String^ get ();
    void set (String^ value);
}

See Also

WebDirectorySetting Class
MSBuild.Community.Tasks.IIS Namespace


VirtualDirectoryName Property

[image]

.NET Framework Class Library
WebDirectorySetting..::.VirtualDirectoryName Property
WebDirectorySetting Class See Also Send Feedback

Gets or sets the name of the virtual directory.

Namespace: MSBuild.Community.Tasks.IIS
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property VirtualDirectoryName As String
C#
[RequiredAttribute]
public string VirtualDirectoryName { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ VirtualDirectoryName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the virtual directory.

See Also

WebDirectorySetting Class
MSBuild.Community.Tasks.IIS Namespace


MSBuild.Community.Tasks.Install Namespace

[image]

.NET Framework Class Library
MSBuild.Community.Tasks.Install Namespace
Send Feedback

Classes

Class | Description
InstallAssembly | Installs assemblies.
UninstallAssembly | Uninstalls assemblies.


InstallAssembly Class

[image]

.NET Framework Class Library
InstallAssembly Class
Members Example See Also Send Feedback

Installs assemblies.

Namespace: MSBuild.Community.Tasks.Install
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class InstallAssembly _
    Inherits ToolTask
C#
public class InstallAssembly : ToolTask
Visual C++
public ref class InstallAssembly : public ToolTask

Remarks

Uses InstallUtil.exe to execute the Install method of Installer classes contained within specified assemblies.

Examples

Install multiple assemblies by specifying the file names:
Copy Code

<InstallAssembly AssemblyFiles="Engine.dll;Presenter.dll" />

Examples

Install an assembly using the assembly name. Also disable the log file by setting it to a single space:
Copy Code

<InstallAssembly AssemblyNames="Engine,Version=1.5.0.0,Culture=neutral" LogFile=" "/>

Examples

You can easily chain an install to the result of a build:
Copy Code

<MSBuild Projects="Project1.csproj;Project2.csproj">
 <Output TaskParameter="TargetOutputs" ItemName="ProjectBinaries" />
</MSBuild>
<InstallAssembly AssemblyFiles="@(ProjectBinaries)" />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
Microsoft.Build.Utilities..::.ToolTask
MSBuild.Community.Tasks.Install..::.InstallAssembly
MSBuild.Community.Tasks.Install..::.UninstallAssembly

See Also

InstallAssembly Members
MSBuild.Community.Tasks.Install Namespace


InstallAssembly Members

[image] [image]

.NET Framework Class Library
InstallAssembly Members
InstallAssembly Class Constructors Methods Properties See Also Send Feedback

The InstallAssembly type exposes the following members.

Constructors

Name | Description
InstallAssembly |

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from ToolTask.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | (Inherited from ToolTask.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | (Inherited from ToolTask.)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

Properties

Name | Description
AssemblyFiles | The assemblies to process, identified by their filename.
AssemblyNames | The assemblies to process, identified by their assembly name.
BuildEngine | (Inherited from Task.)
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
IsUninstall | Determines whether assemblies are installed or uninstalled.
Log | (Inherited from Task.)
LogFile | The file to write installation progress to.
ResponseFileEncoding | (Inherited from ToolTask.)
ShowCallStack | If an exception occurs at any point during installation, the call stack will be printed to the log.
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | (Inherited from ToolTask.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)

See Also

InstallAssembly Class
MSBuild.Community.Tasks.Install Namespace


InstallAssembly Constructor

[image]

.NET Framework Class Library
InstallAssembly Constructor
InstallAssembly Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Install
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public InstallAssembly()
Visual C++
public:
InstallAssembly()

See Also

InstallAssembly Class
MSBuild.Community.Tasks.Install Namespace


InstallAssembly Methods

[image] [image]

.NET Framework Class Library
InstallAssembly Methods
InstallAssembly Class See Also Send Feedback

The InstallAssembly type exposes the following members.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from ToolTask.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | (Inherited from ToolTask.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | (Inherited from ToolTask.)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

See Also

InstallAssembly Class
MSBuild.Community.Tasks.Install Namespace


GenerateCommandLineCommands Method

[image]

.NET Framework Class Library
InstallAssembly..::.GenerateCommandLineCommands Method
InstallAssembly Class See Also Send Feedback

Returns a string value containing the command line arguments to pass directly to the executable file.

Namespace: MSBuild.Community.Tasks.Install
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateCommandLineCommands As String
C#
protected override string GenerateCommandLineCommands()
Visual C++
protected:
virtual String^ GenerateCommandLineCommands() override

Return Value

A string value containing the command line arguments to pass directly to the executable file.

See Also

InstallAssembly Class
MSBuild.Community.Tasks.Install Namespace


GenerateFullPathToTool Method

[image]

.NET Framework Class Library
InstallAssembly..::.GenerateFullPathToTool Method
InstallAssembly Class See Also Send Feedback

Returns the fully qualified path to the executable file.

Namespace: MSBuild.Community.Tasks.Install
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateFullPathToTool As String
C#
protected override string GenerateFullPathToTool()
Visual C++
protected:
virtual String^ GenerateFullPathToTool() override

Return Value

The fully qualified path to the executable file.

See Also

InstallAssembly Class
MSBuild.Community.Tasks.Install Namespace


InstallAssembly Properties

[image] [image]

.NET Framework Class Library
InstallAssembly Properties
InstallAssembly Class See Also Send Feedback

The InstallAssembly type exposes the following members.

Properties

Name | Description
AssemblyFiles | The assemblies to process, identified by their filename.
AssemblyNames | The assemblies to process, identified by their assembly name.
BuildEngine | (Inherited from Task.)
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
IsUninstall | Determines whether assemblies are installed or uninstalled.
Log | (Inherited from Task.)
LogFile | The file to write installation progress to.
ResponseFileEncoding | (Inherited from ToolTask.)
ShowCallStack | If an exception occurs at any point during installation, the call stack will be printed to the log.
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | (Inherited from ToolTask.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)

See Also

InstallAssembly Class
MSBuild.Community.Tasks.Install Namespace


AssemblyFiles Property

[image]

.NET Framework Class Library
InstallAssembly..::.AssemblyFiles Property
InstallAssembly Class See Also Send Feedback

The assemblies to process, identified by their filename.

Namespace: MSBuild.Community.Tasks.Install
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyFiles As ITaskItem()
C#
public ITaskItem[] AssemblyFiles { get; set; }
Visual C++
public:
property array<ITaskItem^>^ AssemblyFiles {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

See Also

InstallAssembly Class
MSBuild.Community.Tasks.Install Namespace


AssemblyNames Property

[image]

.NET Framework Class Library
InstallAssembly..::.AssemblyNames Property
InstallAssembly Class See Also Send Feedback

The assemblies to process, identified by their assembly name.

Namespace: MSBuild.Community.Tasks.Install
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property AssemblyNames As ITaskItem()
C#
public ITaskItem[] AssemblyNames { get; set; }
Visual C++
public:
property array<ITaskItem^>^ AssemblyNames {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

See Also

InstallAssembly Class
MSBuild.Community.Tasks.Install Namespace


IsUninstall Property

[image]

.NET Framework Class Library
InstallAssembly..::.IsUninstall Property
InstallAssembly Class See Also Send Feedback

Determines whether assemblies are installed or uninstalled.

Namespace: MSBuild.Community.Tasks.Install
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property IsUninstall As Boolean
C#
protected virtual bool IsUninstall { get; }
Visual C++
protected:
virtual property bool IsUninstall {
    bool get ();
}

See Also

InstallAssembly Class
MSBuild.Community.Tasks.Install Namespace


LogFile Property

[image]

.NET Framework Class Library
InstallAssembly..::.LogFile Property
InstallAssembly Class See Also Send Feedback

The file to write installation progress to.

Namespace: MSBuild.Community.Tasks.Install
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property LogFile As String
C#
public string LogFile { get; set; }
Visual C++
public:
property String^ LogFile {
    String^ get ();
    void set (String^ value);
}

Remarks

Set to a single space to disable logging to a file.

If not specified, the default is to log to [assemblyname].installLog

See Also

InstallAssembly Class
MSBuild.Community.Tasks.Install Namespace


ShowCallStack Property

[image]

.NET Framework Class Library
InstallAssembly..::.ShowCallStack Property
InstallAssembly Class See Also Send Feedback

If an exception occurs at any point during installation, the call stack will be printed to the log.

Namespace: MSBuild.Community.Tasks.Install
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ShowCallStack As Boolean
C#
public bool ShowCallStack { get; set; }
Visual C++
public:
property bool ShowCallStack {
    bool get ();
    void set (bool value);
}

See Also

InstallAssembly Class
MSBuild.Community.Tasks.Install Namespace


ToolName Property

[image]

.NET Framework Class Library
InstallAssembly..::.ToolName Property
InstallAssembly Class See Also Send Feedback

Gets the name of the executable file to run.

Namespace: MSBuild.Community.Tasks.Install
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ToolName As String
C#
protected override string ToolName { get; }
Visual C++
protected:
virtual property String^ ToolName {
    String^ get () override;
}

Field Value

Return Value

The name of the executable file to run.

See Also

InstallAssembly Class
MSBuild.Community.Tasks.Install Namespace


UninstallAssembly Class

[image]

.NET Framework Class Library
UninstallAssembly Class
Members Example See Also Send Feedback

Uninstalls assemblies.

Namespace: MSBuild.Community.Tasks.Install
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class UninstallAssembly _
    Inherits InstallAssembly
C#
public class UninstallAssembly : InstallAssembly
Visual C++
public ref class UninstallAssembly : public InstallAssembly

Remarks

Uses InstallUtil.exe to execute the Uninstall method of Installer classes contained within specified assemblies.

Examples

Uninstall multiple assemblies by specifying the file names:
Copy Code
            <UninstallAssembly AssemblyFiles="Engine.dll;Presenter.dll" />

Examples

Unnstall an assembly using the assembly name. Also disable the log file by setting it to a single space:
Copy Code
            <UninstallAssembly AssemblyNames="Engine,Version=1.5.0.0,Culture=neutral" LogFile=" "/>

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
Microsoft.Build.Utilities..::.ToolTask
MSBuild.Community.Tasks.Install..::.InstallAssembly
MSBuild.Community.Tasks.Install..::.UninstallAssembly

See Also

UninstallAssembly Members
MSBuild.Community.Tasks.Install Namespace


UninstallAssembly Members

[image] [image]

.NET Framework Class Library
UninstallAssembly Members
UninstallAssembly Class Constructors Methods Properties See Also Send Feedback

The UninstallAssembly type exposes the following members.

Constructors

Name | Description
UninstallAssembly |

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from ToolTask.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Inherited from InstallAssembly.)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Inherited from InstallAssembly.)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | (Inherited from ToolTask.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | (Inherited from ToolTask.)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

Properties

Name | Description
AssemblyFiles | The assemblies to process, identified by their filename. (Inherited from InstallAssembly.)
AssemblyNames | The assemblies to process, identified by their assembly name. (Inherited from InstallAssembly.)
BuildEngine | (Inherited from Task.)
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
IsUninstall | Determines whether assemblies are installed or uninstalled. (Overrides InstallAssembly..::.IsUninstall.)
Log | (Inherited from Task.)
LogFile | The file to write installation progress to. (Inherited from InstallAssembly.)
ResponseFileEncoding | (Inherited from ToolTask.)
ShowCallStack | If an exception occurs at any point during installation, the call stack will be printed to the log. (Inherited from InstallAssembly.)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | (Inherited from ToolTask.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Inherited from InstallAssembly.)
ToolPath | (Inherited from ToolTask.)

See Also

UninstallAssembly Class
MSBuild.Community.Tasks.Install Namespace


UninstallAssembly Constructor

[image]

.NET Framework Class Library
UninstallAssembly Constructor
UninstallAssembly Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Install
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public UninstallAssembly()
Visual C++
public:
UninstallAssembly()

See Also

UninstallAssembly Class
MSBuild.Community.Tasks.Install Namespace


UninstallAssembly Methods

[image] [image]

.NET Framework Class Library
UninstallAssembly Methods
UninstallAssembly Class See Also Send Feedback

The UninstallAssembly type exposes the following members.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from ToolTask.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Inherited from InstallAssembly.)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Inherited from InstallAssembly.)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | (Inherited from ToolTask.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | (Inherited from ToolTask.)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

See Also

UninstallAssembly Class
MSBuild.Community.Tasks.Install Namespace


UninstallAssembly Properties

[image] [image]

.NET Framework Class Library
UninstallAssembly Properties
UninstallAssembly Class See Also Send Feedback

The UninstallAssembly type exposes the following members.

Properties

Name | Description
AssemblyFiles | The assemblies to process, identified by their filename. (Inherited from InstallAssembly.)
AssemblyNames | The assemblies to process, identified by their assembly name. (Inherited from InstallAssembly.)
BuildEngine | (Inherited from Task.)
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
IsUninstall | Determines whether assemblies are installed or uninstalled. (Overrides InstallAssembly..::.IsUninstall.)
Log | (Inherited from Task.)
LogFile | The file to write installation progress to. (Inherited from InstallAssembly.)
ResponseFileEncoding | (Inherited from ToolTask.)
ShowCallStack | If an exception occurs at any point during installation, the call stack will be printed to the log. (Inherited from InstallAssembly.)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | (Inherited from ToolTask.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Inherited from InstallAssembly.)
ToolPath | (Inherited from ToolTask.)

See Also

UninstallAssembly Class
MSBuild.Community.Tasks.Install Namespace


IsUninstall Property

[image]

.NET Framework Class Library
UninstallAssembly..::.IsUninstall Property
UninstallAssembly Class See Also Send Feedback

Determines whether assemblies are installed or uninstalled.

Namespace: MSBuild.Community.Tasks.Install
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property IsUninstall As Boolean
C#
protected override bool IsUninstall { get; }
Visual C++
protected:
virtual property bool IsUninstall {
    bool get () override;
}

See Also

UninstallAssembly Class
MSBuild.Community.Tasks.Install Namespace


MSBuild.Community.Tasks.JavaScript Namespace

[image]

.NET Framework Class Library
MSBuild.Community.Tasks.JavaScript Namespace
Send Feedback

Classes

Class | Description
JSCompress | Compresses JavaScript source by removing comments and unnecessary whitespace. It typically reduces the size of the script by half, resulting in faster downloads and code that is harder to read.


JSCompress Class

[image]

.NET Framework Class Library
JSCompress Class
Members See Also Send Feedback

Compresses JavaScript source by removing comments and unnecessary whitespace. It typically reduces the size of the script by half, resulting in faster downloads and code that is harder to read.

Namespace: MSBuild.Community.Tasks.JavaScript
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class JSCompress _
    Inherits Task
C#
public class JSCompress : Task
Visual C++
public ref class JSCompress : public Task

Remarks

This task does not change the behavior of the program that it is compressing. The resulting code will be harder to debug as well as harder to read.

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.JavaScript..::.JSCompress

See Also

JSCompress Members
MSBuild.Community.Tasks.JavaScript Namespace


JSCompress Members

[image] [image]

.NET Framework Class Library
JSCompress Members
JSCompress Class Constructors Methods Properties See Also Send Feedback

The JSCompress type exposes the following members.

Constructors

Name | Description
JSCompress |

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
CompressedFiles | Gets the files that were successfully source-compressed.
Encoding | Encoding to use to read and write files.
Files | Gets or sets the files to source-compress.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
TaskResources | (Inherited from Task.)

See Also

JSCompress Class
MSBuild.Community.Tasks.JavaScript Namespace


JSCompress Constructor

[image]

.NET Framework Class Library
JSCompress Constructor
JSCompress Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.JavaScript
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public JSCompress()
Visual C++
public:
JSCompress()

See Also

JSCompress Class
MSBuild.Community.Tasks.JavaScript Namespace


JSCompress Methods

[image] [image]

.NET Framework Class Library
JSCompress Methods
JSCompress Class See Also Send Feedback

The JSCompress type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

JSCompress Class
MSBuild.Community.Tasks.JavaScript Namespace


Execute Method

[image]

.NET Framework Class Library
JSCompress..::.Execute Method
JSCompress Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.JavaScript
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

JSCompress Class
MSBuild.Community.Tasks.JavaScript Namespace


JSCompress Properties

[image] [image]

.NET Framework Class Library
JSCompress Properties
JSCompress Class See Also Send Feedback

The JSCompress type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
CompressedFiles | Gets the files that were successfully source-compressed.
Encoding | Encoding to use to read and write files.
Files | Gets or sets the files to source-compress.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
TaskResources | (Inherited from Task.)

See Also

JSCompress Class
MSBuild.Community.Tasks.JavaScript Namespace


CompressedFiles Property

[image]

.NET Framework Class Library
JSCompress..::.CompressedFiles Property
JSCompress Class See Also Send Feedback

Gets the files that were successfully source-compressed.

Namespace: MSBuild.Community.Tasks.JavaScript
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property CompressedFiles As ITaskItem()
C#
[OutputAttribute]
public ITaskItem[] CompressedFiles { get; }
Visual C++
[OutputAttribute]
public:
property array<ITaskItem^>^ CompressedFiles {
    array<ITaskItem^>^ get ();
}

See Also

JSCompress Class
MSBuild.Community.Tasks.JavaScript Namespace


Encoding Property

[image]

.NET Framework Class Library
JSCompress..::.Encoding Property
JSCompress Class See Also Send Feedback

Encoding to use to read and write files.

Namespace: MSBuild.Community.Tasks.JavaScript
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Encoding As String
C#
public string Encoding { get; set; }
Visual C++
public:
property String^ Encoding {
    String^ get ();
    void set (String^ value);
}

See Also

JSCompress Class
MSBuild.Community.Tasks.JavaScript Namespace


Files Property

[image]

.NET Framework Class Library
JSCompress..::.Files Property
JSCompress Class See Also Send Feedback

Gets or sets the files to source-compress.

Namespace: MSBuild.Community.Tasks.JavaScript
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property Files As ITaskItem()
C#
[RequiredAttribute]
public ITaskItem[] Files { get; set; }
Visual C++
[RequiredAttribute]
public:
property array<ITaskItem^>^ Files {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

See Also

JSCompress Class
MSBuild.Community.Tasks.JavaScript Namespace


MSBuild.Community.Tasks.Math Namespace

[image]

.NET Framework Class Library
MSBuild.Community.Tasks.Math Namespace
Send Feedback

Classes

Class | Description
Add | Add numbers
Divide | Divide numbers
MathBase | Math task base class
Modulo | Performs the modulo operation on numbers.
Multiple | Multiple numbers
Subtract | Subtract numbers


Add Class

[image]

.NET Framework Class Library
Add Class
Members Example See Also Send Feedback

Add numbers

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Add _
    Inherits MathBase
C#
public class Add : MathBase
Visual C++
public ref class Add : public MathBase

Examples

Adding numbers:
Copy Code
            <Math.Add Numbers="4;3">
                <Output TaskParameter="Result" PropertyName="Result" />
            </Math.Add>
            <Message Text="Add 4+3= $(Result)"/>

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.Math..::.MathBase
MSBuild.Community.Tasks.Math..::.Add

See Also

Add Members
MSBuild.Community.Tasks.Math Namespace


Add Members

[image] [image]

.NET Framework Class Library
Add Members
Add Class Constructors Methods Properties See Also Send Feedback

The Add type exposes the following members.

Constructors

Name | Description
Add |

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides MathBase..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
StringArrayToDecimalArray | Strings array to decimal array. (Inherited from MathBase.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
Numbers | Gets or sets the numbers to work with. (Inherited from MathBase.)
NumericFormat | Gets or sets the numeric format. (Inherited from MathBase.)
Result | Gets or sets the result. (Inherited from MathBase.)
TaskResources | (Inherited from Task.)

See Also

Add Class
MSBuild.Community.Tasks.Math Namespace


Add Constructor

[image]

.NET Framework Class Library
Add Constructor
Add Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Add()
Visual C++
public:
Add()

See Also

Add Class
MSBuild.Community.Tasks.Math Namespace


Add Methods

[image] [image]

.NET Framework Class Library
Add Methods
Add Class See Also Send Feedback

The Add type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides MathBase..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
StringArrayToDecimalArray | Strings array to decimal array. (Inherited from MathBase.)
ToString | (Inherited from Object.)

See Also

Add Class
MSBuild.Community.Tasks.Math Namespace


Execute Method

[image]

.NET Framework Class Library
Add..::.Execute Method
Add Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

Add Class
MSBuild.Community.Tasks.Math Namespace


Add Properties

[image] [image]

.NET Framework Class Library
Add Properties
Add Class See Also Send Feedback

The Add type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
Numbers | Gets or sets the numbers to work with. (Inherited from MathBase.)
NumericFormat | Gets or sets the numeric format. (Inherited from MathBase.)
Result | Gets or sets the result. (Inherited from MathBase.)
TaskResources | (Inherited from Task.)

See Also

Add Class
MSBuild.Community.Tasks.Math Namespace


Divide Class

[image]

.NET Framework Class Library
Divide Class
Members Example See Also Send Feedback

Divide numbers

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Divide _
    Inherits MathBase
C#
public class Divide : MathBase
Visual C++
public ref class Divide : public MathBase

Examples

Copy Code

<Math.Divide Numbers="1;2">
    <Output TaskParameter="Result" PropertyName="Result" />
</Math.Divide>
<Message Text="Divide 1/2= $(Result)"/>
Above example will display:
Copy Code
Divide 1/2= 0.5

Examples

Truncate the result to always return an integer:
Copy Code

<Math.Divide Numbers="7;3" TruncateResult="true">
    <Output TaskParameter="Result" PropertyName="Result" />
</Math.Divide>
<Message Text="Divide 7/3= $(Result)"/>
Above example will display:
Copy Code
Divide 7/3= 2

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.Math..::.MathBase
MSBuild.Community.Tasks.Math..::.Divide

See Also

Divide Members
MSBuild.Community.Tasks.Math Namespace


Divide Members

[image] [image]

.NET Framework Class Library
Divide Members
Divide Class Constructors Methods Properties See Also Send Feedback

The Divide type exposes the following members.

Constructors

Name | Description
Divide |

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides MathBase..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
StringArrayToDecimalArray | Strings array to decimal array. (Inherited from MathBase.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
Numbers | Gets or sets the numbers to work with. (Inherited from MathBase.)
NumericFormat | Gets or sets the numeric format. (Inherited from MathBase.)
Result | Gets or sets the result. (Inherited from MathBase.)
TaskResources | (Inherited from Task.)
TruncateResult | When trueTruetruetrue (True in Visual Basic), uses integer division to truncate the result. Default is falseFalsefalsefalse (False in Visual Basic)

See Also

Divide Class
MSBuild.Community.Tasks.Math Namespace


Divide Constructor

[image]

.NET Framework Class Library
Divide Constructor
Divide Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Divide()
Visual C++
public:
Divide()

See Also

Divide Class
MSBuild.Community.Tasks.Math Namespace


Divide Methods

[image] [image]

.NET Framework Class Library
Divide Methods
Divide Class See Also Send Feedback

The Divide type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides MathBase..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
StringArrayToDecimalArray | Strings array to decimal array. (Inherited from MathBase.)
ToString | (Inherited from Object.)

See Also

Divide Class
MSBuild.Community.Tasks.Math Namespace


Execute Method

[image]

.NET Framework Class Library
Divide..::.Execute Method
Divide Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

Divide Class
MSBuild.Community.Tasks.Math Namespace


Divide Properties

[image] [image]

.NET Framework Class Library
Divide Properties
Divide Class See Also Send Feedback

The Divide type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
Numbers | Gets or sets the numbers to work with. (Inherited from MathBase.)
NumericFormat | Gets or sets the numeric format. (Inherited from MathBase.)
Result | Gets or sets the result. (Inherited from MathBase.)
TaskResources | (Inherited from Task.)
TruncateResult | When trueTruetruetrue (True in Visual Basic), uses integer division to truncate the result. Default is falseFalsefalsefalse (False in Visual Basic)

See Also

Divide Class
MSBuild.Community.Tasks.Math Namespace


TruncateResult Property

[image]

.NET Framework Class Library
Divide..::.TruncateResult Property
Divide Class See Also Send Feedback

When trueTruetruetrue (True in Visual Basic), uses integer division to truncate the result. Default is falseFalsefalsefalse (False in Visual Basic)

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property TruncateResult As Boolean
C#
public bool TruncateResult { get; set; }
Visual C++
public:
property bool TruncateResult {
    bool get ();
    void set (bool value);
}

Remarks

Any remainder in the result is dropped, and the closest integer to zero is returned.

Refer to the documentation for the \ Operator for more information about integer division.

See Also

Divide Class
MSBuild.Community.Tasks.Math Namespace


MathBase Class

[image]

.NET Framework Class Library
MathBase Class
Members See Also Send Feedback

Math task base class

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class MathBase _
    Inherits Task
C#
public abstract class MathBase : Task
Visual C++
public ref class MathBase abstract : public Task

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.Math..::.MathBase
MSBuild.Community.Tasks.Math..::.Add
MSBuild.Community.Tasks.Math..::.Divide
MSBuild.Community.Tasks.Math..::.Modulo
MSBuild.Community.Tasks.Math..::.Multiple
MSBuild.Community.Tasks.Math..::.Subtract

See Also

MathBase Members
MSBuild.Community.Tasks.Math Namespace


MathBase Members

[image] [image]

.NET Framework Class Library
MathBase Members
MathBase Class Constructors Methods Properties See Also Send Feedback

The MathBase type exposes the following members.

Constructors

Name | Description
MathBase |

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
StringArrayToDecimalArray | Strings array to decimal array.
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
Numbers | Gets or sets the numbers to work with.
NumericFormat | Gets or sets the numeric format.
Result | Gets or sets the result.
TaskResources | (Inherited from Task.)

See Also

MathBase Class
MSBuild.Community.Tasks.Math Namespace


MathBase Constructor

[image]

.NET Framework Class Library
MathBase Constructor
MathBase Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New
C#
protected MathBase()
Visual C++
protected:
MathBase()

See Also

MathBase Class
MSBuild.Community.Tasks.Math Namespace


MathBase Methods

[image] [image]

.NET Framework Class Library
MathBase Methods
MathBase Class See Also Send Feedback

The MathBase type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
StringArrayToDecimalArray | Strings array to decimal array.
ToString | (Inherited from Object.)

See Also

MathBase Class
MSBuild.Community.Tasks.Math Namespace


Execute Method

[image]

.NET Framework Class Library
MathBase..::.Execute Method
MathBase Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

MathBase Class
MSBuild.Community.Tasks.Math Namespace


StringArrayToDecimalArray Method

[image]

.NET Framework Class Library
MathBase..::.StringArrayToDecimalArray Method
MathBase Class See Also Send Feedback

Strings array to decimal array.

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Function StringArrayToDecimalArray ( _
    numbers As String() _
) As Decimal()
C#
protected decimal[] StringArrayToDecimalArray(
    string[] numbers
)
Visual C++
protected:
array<Decimal>^ StringArrayToDecimalArray(
    array<String^>^ numbers
)

Parameters

numbers
Type: array< System..::.String >[]()[]
The numbers.

Return Value

See Also

MathBase Class
MSBuild.Community.Tasks.Math Namespace


MathBase Properties

[image] [image]

.NET Framework Class Library
MathBase Properties
MathBase Class See Also Send Feedback

The MathBase type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
Numbers | Gets or sets the numbers to work with.
NumericFormat | Gets or sets the numeric format.
Result | Gets or sets the result.
TaskResources | (Inherited from Task.)

See Also

MathBase Class
MSBuild.Community.Tasks.Math Namespace


Numbers Property

[image]

.NET Framework Class Library
MathBase..::.Numbers Property
MathBase Class See Also Send Feedback

Gets or sets the numbers to work with.

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property Numbers As String()
C#
[RequiredAttribute]
public string[] Numbers { get; set; }
Visual C++
[RequiredAttribute]
public:
property array<String^>^ Numbers {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Field Value

The numbers.

See Also

MathBase Class
MSBuild.Community.Tasks.Math Namespace


NumericFormat Property

[image]

.NET Framework Class Library
MathBase..::.NumericFormat Property
MathBase Class See Also Send Feedback

Gets or sets the numeric format.

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property NumericFormat As String
C#
public string NumericFormat { get; set; }
Visual C++
public:
property String^ NumericFormat {
    String^ get ();
    void set (String^ value);
}

Field Value

The numeric format.

See Also

MathBase Class
MSBuild.Community.Tasks.Math Namespace


Result Property

[image]

.NET Framework Class Library
MathBase..::.Result Property
MathBase Class See Also Send Feedback

Gets or sets the result.

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public Property Result As String
C#
[OutputAttribute]
public string Result { get; set; }
Visual C++
[OutputAttribute]
public:
property String^ Result {
    String^ get ();
    void set (String^ value);
}

Field Value

The result.

See Also

MathBase Class
MSBuild.Community.Tasks.Math Namespace


Modulo Class

[image]

.NET Framework Class Library
Modulo Class
Members Example See Also Send Feedback

Performs the modulo operation on numbers.

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Modulo _
    Inherits MathBase
C#
public class Modulo : MathBase
Visual C++
public ref class Modulo : public MathBase

Remarks

The modulo operation finds the remainder of the division of one number by another.

When the second number (modulus) is a fractional value, the result can be a fractional value.

Equivalent to the % operator in C# or the Mod operator in Visual Basic.

Examples

Numbers evenly divide:
Copy Code

<Math.Modulo Numbers="12;4">
    <Output TaskParameter="Result" PropertyName="Result" />
</Math.Modulo>
<Message Text="12 modulo 4 = $(Result)"/>
Above example will display:
Copy Code
12 modulo 4 = 0

Examples

Division on the numbers produces a remainder:
Copy Code

<Math.Modulo Numbers="14;4">
    <Output TaskParameter="Result" PropertyName="Result" />
</Math.Modulo>
<Message Text="14 modulo 4 = $(Result)"/>
Above example will display:
Copy Code
14 modulo 4 = 2

Examples

Modulus is a fractional value:
Copy Code

<Math.Modulo Numbers="12;3.5">
    <Output TaskParameter="Result" PropertyName="Result" />
</Math.Modulo>
<Message Text="12 modulo 3.5 = $(Result)"/>
Above example will display:
Copy Code
12 modulo 3.5 = 1.5

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.Math..::.MathBase
MSBuild.Community.Tasks.Math..::.Modulo

See Also

Modulo Members
MSBuild.Community.Tasks.Math Namespace


Modulo Members

[image] [image]

.NET Framework Class Library
Modulo Members
Modulo Class Constructors Methods Properties See Also Send Feedback

The Modulo type exposes the following members.

Constructors

Name | Description
Modulo |

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides MathBase..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
StringArrayToDecimalArray | Strings array to decimal array. (Inherited from MathBase.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
Numbers | Gets or sets the numbers to work with. (Inherited from MathBase.)
NumericFormat | Gets or sets the numeric format. (Inherited from MathBase.)
Result | Gets or sets the result. (Inherited from MathBase.)
TaskResources | (Inherited from Task.)

See Also

Modulo Class
MSBuild.Community.Tasks.Math Namespace


Modulo Constructor

[image]

.NET Framework Class Library
Modulo Constructor
Modulo Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Modulo()
Visual C++
public:
Modulo()

See Also

Modulo Class
MSBuild.Community.Tasks.Math Namespace


Modulo Methods

[image] [image]

.NET Framework Class Library
Modulo Methods
Modulo Class See Also Send Feedback

The Modulo type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides MathBase..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
StringArrayToDecimalArray | Strings array to decimal array. (Inherited from MathBase.)
ToString | (Inherited from Object.)

See Also

Modulo Class
MSBuild.Community.Tasks.Math Namespace


Execute Method

[image]

.NET Framework Class Library
Modulo..::.Execute Method
Modulo Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

Modulo Class
MSBuild.Community.Tasks.Math Namespace


Modulo Properties

[image] [image]

.NET Framework Class Library
Modulo Properties
Modulo Class See Also Send Feedback

The Modulo type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
Numbers | Gets or sets the numbers to work with. (Inherited from MathBase.)
NumericFormat | Gets or sets the numeric format. (Inherited from MathBase.)
Result | Gets or sets the result. (Inherited from MathBase.)
TaskResources | (Inherited from Task.)

See Also

Modulo Class
MSBuild.Community.Tasks.Math Namespace


Multiple Class

[image]

.NET Framework Class Library
Multiple Class
Members Example See Also Send Feedback

Multiple numbers

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Multiple _
    Inherits MathBase
C#
public class Multiple : MathBase
Visual C++
public ref class Multiple : public MathBase

Examples

Copy Code
            <Math.Multiple Numbers="10;3">
                <Output TaskParameter="Result" PropertyName="Result" />
            </Math.Multiple>
            <Message Text="Multiple 10*3= $(Result)"/>

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.Math..::.MathBase
MSBuild.Community.Tasks.Math..::.Multiple

See Also

Multiple Members
MSBuild.Community.Tasks.Math Namespace


Multiple Members

[image] [image]

.NET Framework Class Library
Multiple Members
Multiple Class Constructors Methods Properties See Also Send Feedback

The Multiple type exposes the following members.

Constructors

Name | Description
Multiple |

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides MathBase..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
StringArrayToDecimalArray | Strings array to decimal array. (Inherited from MathBase.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
Numbers | Gets or sets the numbers to work with. (Inherited from MathBase.)
NumericFormat | Gets or sets the numeric format. (Inherited from MathBase.)
Result | Gets or sets the result. (Inherited from MathBase.)
TaskResources | (Inherited from Task.)

See Also

Multiple Class
MSBuild.Community.Tasks.Math Namespace


Multiple Constructor

[image]

.NET Framework Class Library
Multiple Constructor
Multiple Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Multiple()
Visual C++
public:
Multiple()

See Also

Multiple Class
MSBuild.Community.Tasks.Math Namespace


Multiple Methods

[image] [image]

.NET Framework Class Library
Multiple Methods
Multiple Class See Also Send Feedback

The Multiple type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides MathBase..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
StringArrayToDecimalArray | Strings array to decimal array. (Inherited from MathBase.)
ToString | (Inherited from Object.)

See Also

Multiple Class
MSBuild.Community.Tasks.Math Namespace


Execute Method

[image]

.NET Framework Class Library
Multiple..::.Execute Method
Multiple Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

Multiple Class
MSBuild.Community.Tasks.Math Namespace


Multiple Properties

[image] [image]

.NET Framework Class Library
Multiple Properties
Multiple Class See Also Send Feedback

The Multiple type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
Numbers | Gets or sets the numbers to work with. (Inherited from MathBase.)
NumericFormat | Gets or sets the numeric format. (Inherited from MathBase.)
Result | Gets or sets the result. (Inherited from MathBase.)
TaskResources | (Inherited from Task.)

See Also

Multiple Class
MSBuild.Community.Tasks.Math Namespace


Subtract Class

[image]

.NET Framework Class Library
Subtract Class
Members Example See Also Send Feedback

Subtract numbers

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Subtract _
    Inherits MathBase
C#
public class Subtract : MathBase
Visual C++
public ref class Subtract : public MathBase

Examples

Copy Code
            <Math.Subtract Numbers="10;3">
                <Output TaskParameter="Result" PropertyName="Result" />
            </Math.Subtract>
            <Message Text="Subtract 10-3= $(Result)"/>

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.Math..::.MathBase
MSBuild.Community.Tasks.Math..::.Subtract

See Also

Subtract Members
MSBuild.Community.Tasks.Math Namespace


Subtract Members

[image] [image]

.NET Framework Class Library
Subtract Members
Subtract Class Constructors Methods Properties See Also Send Feedback

The Subtract type exposes the following members.

Constructors

Name | Description
Subtract |

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides MathBase..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
StringArrayToDecimalArray | Strings array to decimal array. (Inherited from MathBase.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
Numbers | Gets or sets the numbers to work with. (Inherited from MathBase.)
NumericFormat | Gets or sets the numeric format. (Inherited from MathBase.)
Result | Gets or sets the result. (Inherited from MathBase.)
TaskResources | (Inherited from Task.)

See Also

Subtract Class
MSBuild.Community.Tasks.Math Namespace


Subtract Constructor

[image]

.NET Framework Class Library
Subtract Constructor
Subtract Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Subtract()
Visual C++
public:
Subtract()

See Also

Subtract Class
MSBuild.Community.Tasks.Math Namespace


Subtract Methods

[image] [image]

.NET Framework Class Library
Subtract Methods
Subtract Class See Also Send Feedback

The Subtract type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides MathBase..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
StringArrayToDecimalArray | Strings array to decimal array. (Inherited from MathBase.)
ToString | (Inherited from Object.)

See Also

Subtract Class
MSBuild.Community.Tasks.Math Namespace


Execute Method

[image]

.NET Framework Class Library
Subtract..::.Execute Method
Subtract Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.Math
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

Subtract Class
MSBuild.Community.Tasks.Math Namespace


Subtract Properties

[image] [image]

.NET Framework Class Library
Subtract Properties
Subtract Class See Also Send Feedback

The Subtract type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
Numbers | Gets or sets the numbers to work with. (Inherited from MathBase.)
NumericFormat | Gets or sets the numeric format. (Inherited from MathBase.)
Result | Gets or sets the result. (Inherited from MathBase.)
TaskResources | (Inherited from Task.)

See Also

Subtract Class
MSBuild.Community.Tasks.Math Namespace


MSBuild.Community.Tasks.Net Namespace

[image]

.NET Framework Class Library
MSBuild.Community.Tasks.Net Namespace
Send Feedback

Classes

Class | Description
HttpRequest | Makes an HTTP request, optionally validating the result and writing it to a file.


HttpRequest Class

[image]

.NET Framework Class Library
HttpRequest Class
Members Example See Also Send Feedback

Makes an HTTP request, optionally validating the result and writing it to a file.

Namespace: MSBuild.Community.Tasks.Net
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class HttpRequest _
    Inherits Task
C#
public class HttpRequest : Task
Visual C++
public ref class HttpRequest : public Task

Remarks

Execute a http request to hit the database update. Target attributes to set: Url (required), FailOnNon2xxResponse (200 responses generally means successful http request. default=true), EnsureResponseContains (string to check for), WriteResponseTo (file name to write to),

Examples

Example of a update request ensuring "Database upgrade check completed successfully." was returned.
Copy Code
                <HttpRequest Url="http://mydomain.com/index.php?checkdb=1"
                    EnsureResponseContains="Database upgrade check completed successfully."
                    FailOnNon2xxResponse="true" />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.Net..::.HttpRequest

See Also

HttpRequest Members
MSBuild.Community.Tasks.Net Namespace


HttpRequest Members

[image] [image]

.NET Framework Class Library
HttpRequest Members
HttpRequest Class Constructors Methods Properties See Also Send Feedback

The HttpRequest type exposes the following members.

Constructors

Name | Description
HttpRequest | Constructor to set the default parameters for http request

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | Entry Point inherited from Task (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
EnsureResponseContains | Optional: if set then the task fails if the response text doesn't contain the text specified.
FailOnNon2xxResponse | Default is true. When true, if the web server returns a status code less than 200 or greater than 299 then the task fails.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
TaskResources | (Inherited from Task.)
Url | The URL to make an HTTP request against.
WriteResponseTo | Optional; the name of the file to write the response to.

See Also

HttpRequest Class
MSBuild.Community.Tasks.Net Namespace


HttpRequest Constructor

[image]

.NET Framework Class Library
HttpRequest Constructor
HttpRequest Class See Also Send Feedback

Constructor to set the default parameters for http request

Namespace: MSBuild.Community.Tasks.Net
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public HttpRequest()
Visual C++
public:
HttpRequest()

See Also

HttpRequest Class
MSBuild.Community.Tasks.Net Namespace


HttpRequest Methods

[image] [image]

.NET Framework Class Library
HttpRequest Methods
HttpRequest Class See Also Send Feedback

The HttpRequest type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | Entry Point inherited from Task (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

HttpRequest Class
MSBuild.Community.Tasks.Net Namespace


Execute Method

[image]

.NET Framework Class Library
HttpRequest..::.Execute Method
HttpRequest Class See Also Send Feedback

Entry Point inherited from Task

Namespace: MSBuild.Community.Tasks.Net
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Implements

ITask..::.Execute()()()

See Also

HttpRequest Class
MSBuild.Community.Tasks.Net Namespace


HttpRequest Properties

[image] [image]

.NET Framework Class Library
HttpRequest Properties
HttpRequest Class See Also Send Feedback

The HttpRequest type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
EnsureResponseContains | Optional: if set then the task fails if the response text doesn't contain the text specified.
FailOnNon2xxResponse | Default is true. When true, if the web server returns a status code less than 200 or greater than 299 then the task fails.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
TaskResources | (Inherited from Task.)
Url | The URL to make an HTTP request against.
WriteResponseTo | Optional; the name of the file to write the response to.

See Also

HttpRequest Class
MSBuild.Community.Tasks.Net Namespace


EnsureResponseContains Property

[image]

.NET Framework Class Library
HttpRequest..::.EnsureResponseContains Property
HttpRequest Class See Also Send Feedback

Optional: if set then the task fails if the response text doesn't contain the text specified.

Namespace: MSBuild.Community.Tasks.Net
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property EnsureResponseContains As String
C#
public string EnsureResponseContains { get; set; }
Visual C++
public:
property String^ EnsureResponseContains {
    String^ get ();
    void set (String^ value);
}

See Also

HttpRequest Class
MSBuild.Community.Tasks.Net Namespace


FailOnNon2xxResponse Property

[image]

.NET Framework Class Library
HttpRequest..::.FailOnNon2xxResponse Property
HttpRequest Class See Also Send Feedback

Default is true. When true, if the web server returns a status code less than 200 or greater than 299 then the task fails.

Namespace: MSBuild.Community.Tasks.Net
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property FailOnNon2xxResponse As Boolean
C#
public bool FailOnNon2xxResponse { get; set; }
Visual C++
public:
property bool FailOnNon2xxResponse {
    bool get ();
    void set (bool value);
}

See Also

HttpRequest Class
MSBuild.Community.Tasks.Net Namespace


Url Property

[image]

.NET Framework Class Library
HttpRequest..::.Url Property
HttpRequest Class See Also Send Feedback

The URL to make an HTTP request against.

Namespace: MSBuild.Community.Tasks.Net
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property Url As String
C#
[RequiredAttribute]
public string Url { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ Url {
    String^ get ();
    void set (String^ value);
}

See Also

HttpRequest Class
MSBuild.Community.Tasks.Net Namespace


WriteResponseTo Property

[image]

.NET Framework Class Library
HttpRequest..::.WriteResponseTo Property
HttpRequest Class See Also Send Feedback

Optional; the name of the file to write the response to.

Namespace: MSBuild.Community.Tasks.Net
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property WriteResponseTo As String
C#
public string WriteResponseTo { get; set; }
Visual C++
public:
property String^ WriteResponseTo {
    String^ get ();
    void set (String^ value);
}

See Also

HttpRequest Class
MSBuild.Community.Tasks.Net Namespace


MSBuild.Community.Tasks.Oracle Namespace

[image]

.NET Framework Class Library
MSBuild.Community.Tasks.Oracle Namespace
Send Feedback

Classes

Class | Description
AddTnsName | Defines a database host within the Oracle TNSNAMES.ORA file.
TnsEntry | Contains information about a TNS definition
TnsParser | Locates host entries within a TNSNAMES.ORA file


AddTnsName Class

[image]

.NET Framework Class Library
AddTnsName Class
Members Example See Also Send Feedback

Defines a database host within the Oracle TNSNAMES.ORA file.

Namespace: MSBuild.Community.Tasks.Oracle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class AddTnsName _
    Inherits Task
C#
public class AddTnsName : Task
Visual C++
public ref class AddTnsName : public Task

Examples

Add an entry to the system default TNSNAMES.ORA file and update any entry that already exists:
Copy Code
 <AddTnsName AllowUpdates="True" EntryName="northwind.world" EntryText="(DESCRIPTION = (ADDRESS_LIST = (ADDRESS = (PROTOCOL = TCP)(HOST = northwinddb01)(PORT = 1521))) (CONNECT_DATA = (SERVICE_NAME = northwind.world)))"  />

Examples

Add an entry to a specific file and fail if the entry already exists:
Copy Code
 <AddTnsName TnsNamesFile="c:\oracle\network\admin\tnsnames.ora" AllowUpdates="False" EntryName="northwind.world" EntryText="(DESCRIPTION = (ADDRESS_LIST = (ADDRESS = (PROTOCOL = TCP)(HOST = northwinddb01)(PORT = 1521))) (CONNECT_DATA = (SERVICE_NAME = northwind.world)))"  />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.Oracle..::.AddTnsName

See Also

AddTnsName Members
MSBuild.Community.Tasks.Oracle Namespace


AddTnsName Members

[image] [image]

.NET Framework Class Library
AddTnsName Members
AddTnsName Class Constructors Methods Properties See Also Send Feedback

The AddTnsName type exposes the following members.

Constructors

Name | Description
AddTnsName | Overloaded.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetEffectivePathToTnsNamesFile | Determines which TNSNAMES.ORA file to update based on task input and the current system environment.
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
AllowUpdates | When true, the task will update an existing entry with EntryName. If false, the task will fail if EntryName already exists.
BuildEngine | (Inherited from Task.)
EntryName | The name of the host entry to add.
EntryText | The definition of the host entry to add.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
ModifiedFile | The path to the TNSNAMES.ORA that was used by task.
ModifiedFileText | The contents of the TNSNAMES.ORA file after the task executes.
OriginalFileText | The contents of the TNSNAMES.ORA file before any changes are made.
TaskResources | (Inherited from Task.)
TnsNamesFile | The path to a specific TNSNAMES.ORA file to update.

See Also

AddTnsName Class
MSBuild.Community.Tasks.Oracle Namespace


AddTnsName Constructor

[image] [image]

.NET Framework Class Library
AddTnsName Constructor
AddTnsName Class See Also Send Feedback

Overload List

Name | Description
AddTnsName()()() | Creates a new instance of the AddTnsName task using the default system services.
AddTnsName(IRegistry, IFilesSystem) | Creates a new instance of the AddTnsName task using dependency injection.

See Also

AddTnsName Class
AddTnsName Members
MSBuild.Community.Tasks.Oracle Namespace


AddTnsName Constructor

[image]

.NET Framework Class Library
AddTnsName Constructor
AddTnsName Class See Also Send Feedback

Creates a new instance of the AddTnsName task using the default system services.

Namespace: MSBuild.Community.Tasks.Oracle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public AddTnsName()
Visual C++
public:
AddTnsName()

See Also

AddTnsName Class
AddTnsName Overload
MSBuild.Community.Tasks.Oracle Namespace


AddTnsName Constructor (IRegistry, IFilesSystem)

[image]

.NET Framework Class Library
AddTnsName Constructor (IRegistry, IFilesSystem)
AddTnsName Class See Also Send Feedback

Creates a new instance of the AddTnsName task using dependency injection.

Namespace: MSBuild.Community.Tasks.Oracle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    registry As IRegistry, _
    fileSystem As IFilesSystem _
)
C#
public AddTnsName(
    IRegistry registry,
    IFilesSystem fileSystem
)
Visual C++
public:
AddTnsName(
    IRegistry^ registry,
    IFilesSystem^ fileSystem
)

Parameters

registry
Type: MSBuild.Community.Tasks.Services..::.IRegistry
A service that provides access to the Windows registry.
fileSystem
Type: MSBuild.Community.Tasks.Services..::.IFilesSystem
A service that provides access to the file system.

See Also

AddTnsName Class
AddTnsName Overload
MSBuild.Community.Tasks.Oracle Namespace


AddTnsName Methods

[image] [image]

.NET Framework Class Library
AddTnsName Methods
AddTnsName Class See Also Send Feedback

The AddTnsName type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetEffectivePathToTnsNamesFile | Determines which TNSNAMES.ORA file to update based on task input and the current system environment.
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

AddTnsName Class
MSBuild.Community.Tasks.Oracle Namespace


Execute Method

[image]

.NET Framework Class Library
AddTnsName..::.Execute Method
AddTnsName Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.Oracle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

AddTnsName Class
MSBuild.Community.Tasks.Oracle Namespace


GetEffectivePathToTnsNamesFile Method

[image]

.NET Framework Class Library
AddTnsName..::.GetEffectivePathToTnsNamesFile Method
AddTnsName Class See Also Send Feedback

Determines which TNSNAMES.ORA file to update based on task input and the current system environment.

Namespace: MSBuild.Community.Tasks.Oracle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEffectivePathToTnsNamesFile As String
C#
public string GetEffectivePathToTnsNamesFile()
Visual C++
public:
String^ GetEffectivePathToTnsNamesFile()

Return Value

The path of the TNSNAMES.ORA file that will be used by the task.

See Also

AddTnsName Class
MSBuild.Community.Tasks.Oracle Namespace


AddTnsName Properties

[image] [image]

.NET Framework Class Library
AddTnsName Properties
AddTnsName Class See Also Send Feedback

The AddTnsName type exposes the following members.

Properties

Name | Description
AllowUpdates | When true, the task will update an existing entry with EntryName. If false, the task will fail if EntryName already exists.
BuildEngine | (Inherited from Task.)
EntryName | The name of the host entry to add.
EntryText | The definition of the host entry to add.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
ModifiedFile | The path to the TNSNAMES.ORA that was used by task.
ModifiedFileText | The contents of the TNSNAMES.ORA file after the task executes.
OriginalFileText | The contents of the TNSNAMES.ORA file before any changes are made.
TaskResources | (Inherited from Task.)
TnsNamesFile | The path to a specific TNSNAMES.ORA file to update.

See Also

AddTnsName Class
MSBuild.Community.Tasks.Oracle Namespace


AllowUpdates Property

[image]

.NET Framework Class Library
AddTnsName..::.AllowUpdates Property
AddTnsName Class See Also Send Feedback

When true, the task will update an existing entry with EntryName. If false, the task will fail if EntryName already exists.

Namespace: MSBuild.Community.Tasks.Oracle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property AllowUpdates As Boolean
C#
public bool AllowUpdates { set; }
Visual C++
public:
property bool AllowUpdates {
    void set (bool value);
}

See Also

AddTnsName Class
MSBuild.Community.Tasks.Oracle Namespace


EntryName Property

[image]

.NET Framework Class Library
AddTnsName..::.EntryName Property
AddTnsName Class See Also Send Feedback

The name of the host entry to add.

Namespace: MSBuild.Community.Tasks.Oracle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public WriteOnly Property EntryName As String
C#
[RequiredAttribute]
public string EntryName { set; }
Visual C++
[RequiredAttribute]
public:
property String^ EntryName {
    void set (String^ value);
}

Remarks

To be properly recognized by Oracle, the value must contain a period, followed by a suffix. For example: mydatabase.world

See Also

AddTnsName Class
MSBuild.Community.Tasks.Oracle Namespace


EntryText Property

[image]

.NET Framework Class Library
AddTnsName..::.EntryText Property
AddTnsName Class See Also Send Feedback

The definition of the host entry to add.

Namespace: MSBuild.Community.Tasks.Oracle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property EntryText As String
C#
public string EntryText { set; }
Visual C++
public:
property String^ EntryText {
    void set (String^ value);
}

Remarks

To be properly recognized by Oracle, the value must be surrounded by parentheses.

See Also

AddTnsName Class
MSBuild.Community.Tasks.Oracle Namespace


ModifiedFile Property

[image]

.NET Framework Class Library
AddTnsName..::.ModifiedFile Property
AddTnsName Class See Also Send Feedback

The path to the TNSNAMES.ORA that was used by task.

Namespace: MSBuild.Community.Tasks.Oracle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property ModifiedFile As String
C#
[OutputAttribute]
public string ModifiedFile { get; }
Visual C++
[OutputAttribute]
public:
property String^ ModifiedFile {
    String^ get ();
}

See Also

AddTnsName Class
MSBuild.Community.Tasks.Oracle Namespace


ModifiedFileText Property

[image]

.NET Framework Class Library
AddTnsName..::.ModifiedFileText Property
AddTnsName Class See Also Send Feedback

The contents of the TNSNAMES.ORA file after the task executes.

Namespace: MSBuild.Community.Tasks.Oracle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property ModifiedFileText As String
C#
[OutputAttribute]
public string ModifiedFileText { get; }
Visual C++
[OutputAttribute]
public:
property String^ ModifiedFileText {
    String^ get ();
}

See Also

AddTnsName Class
MSBuild.Community.Tasks.Oracle Namespace


OriginalFileText Property

[image]

.NET Framework Class Library
AddTnsName..::.OriginalFileText Property
AddTnsName Class See Also Send Feedback

The contents of the TNSNAMES.ORA file before any changes are made.

Namespace: MSBuild.Community.Tasks.Oracle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property OriginalFileText As String
C#
[OutputAttribute]
public string OriginalFileText { get; }
Visual C++
[OutputAttribute]
public:
property String^ OriginalFileText {
    String^ get ();
}

See Also

AddTnsName Class
MSBuild.Community.Tasks.Oracle Namespace


TnsNamesFile Property

[image]

.NET Framework Class Library
AddTnsName..::.TnsNamesFile Property
AddTnsName Class See Also Send Feedback

The path to a specific TNSNAMES.ORA file to update.

Namespace: MSBuild.Community.Tasks.Oracle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property TnsNamesFile As String
C#
public string TnsNamesFile { set; }
Visual C++
public:
property String^ TnsNamesFile {
    void set (String^ value);
}

Remarks

If not specified, the default is %ORACLE_HOME%\network\admin\tnsnames.ora

See Also

AddTnsName Class
MSBuild.Community.Tasks.Oracle Namespace


TnsEntry Class

[image]

.NET Framework Class Library
TnsEntry Class
Members See Also Send Feedback

Contains information about a TNS definition

Namespace: MSBuild.Community.Tasks.Oracle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class TnsEntry
C#
public class TnsEntry
Visual C++
public ref class TnsEntry

Inheritance Hierarchy

System..::.Object
MSBuild.Community.Tasks.Oracle..::.TnsEntry

See Also

TnsEntry Members
MSBuild.Community.Tasks.Oracle Namespace


TnsEntry Members

[image] [image]

.NET Framework Class Library
TnsEntry Members
TnsEntry Class Constructors Methods Properties See Also Send Feedback

The TnsEntry type exposes the following members.

Constructors

Name | Description
TnsEntry | Creates a new instance of a TnsEntry

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
Length | The length of the entry definition within the TNSNAMES.ORA file
StartPosition | The position of the entry within a TNSNAMES.ORA file

See Also

TnsEntry Class
MSBuild.Community.Tasks.Oracle Namespace


TnsEntry Constructor

[image]

.NET Framework Class Library
TnsEntry Constructor
TnsEntry Class See Also Send Feedback

Creates a new instance of a TnsEntry

Namespace: MSBuild.Community.Tasks.Oracle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    startPosition As Integer, _
    length As Integer _
)
C#
public TnsEntry(
    int startPosition,
    int length
)
Visual C++
public:
TnsEntry(
    int startPosition,
    int length
)

Parameters

startPosition
Type: System..::.Int32
The position of the entry within a TNSNAMES.ORA file
length
Type: System..::.Int32
The length of the entry definition within the TNSNAMES.ORA file

See Also

TnsEntry Class
MSBuild.Community.Tasks.Oracle Namespace


TnsEntry Methods

[image] [image]

.NET Framework Class Library
TnsEntry Methods
TnsEntry Class See Also Send Feedback

The TnsEntry type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

TnsEntry Class
MSBuild.Community.Tasks.Oracle Namespace


TnsEntry Properties

[image] [image]

.NET Framework Class Library
TnsEntry Properties
TnsEntry Class See Also Send Feedback

The TnsEntry type exposes the following members.

Properties

Name | Description
Length | The length of the entry definition within the TNSNAMES.ORA file
StartPosition | The position of the entry within a TNSNAMES.ORA file

See Also

TnsEntry Class
MSBuild.Community.Tasks.Oracle Namespace


Length Property

[image]

.NET Framework Class Library
TnsEntry..::.Length Property
TnsEntry Class See Also Send Feedback

The length of the entry definition within the TNSNAMES.ORA file

Namespace: MSBuild.Community.Tasks.Oracle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Length As Integer
C#
public int Length { get; }
Visual C++
public:
property int Length {
    int get ();
}

See Also

TnsEntry Class
MSBuild.Community.Tasks.Oracle Namespace


StartPosition Property

[image]

.NET Framework Class Library
TnsEntry..::.StartPosition Property
TnsEntry Class See Also Send Feedback

The position of the entry within a TNSNAMES.ORA file

Namespace: MSBuild.Community.Tasks.Oracle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StartPosition As Integer
C#
public int StartPosition { get; }
Visual C++
public:
property int StartPosition {
    int get ();
}

See Also

TnsEntry Class
MSBuild.Community.Tasks.Oracle Namespace


TnsParser Class

[image]

.NET Framework Class Library
TnsParser Class
Members See Also Send Feedback

Locates host entries within a TNSNAMES.ORA file

Namespace: MSBuild.Community.Tasks.Oracle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class TnsParser
C#
public class TnsParser
Visual C++
public ref class TnsParser

Inheritance Hierarchy

System..::.Object
MSBuild.Community.Tasks.Oracle..::.TnsParser

See Also

TnsParser Members
MSBuild.Community.Tasks.Oracle Namespace


TnsParser Members

[image] [image]

.NET Framework Class Library
TnsParser Members
TnsParser Class Constructors Methods See Also Send Feedback

The TnsParser type exposes the following members.

Constructors

Name | Description
TnsParser | Initializes a new instance of the parser using the contents of a TNSNAMES.ORA file.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
FindEntry | Locates a host entry by its name.
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

TnsParser Class
MSBuild.Community.Tasks.Oracle Namespace


TnsParser Constructor

[image]

.NET Framework Class Library
TnsParser Constructor
TnsParser Class See Also Send Feedback

Initializes a new instance of the parser using the contents of a TNSNAMES.ORA file.

Namespace: MSBuild.Community.Tasks.Oracle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    content As String _
)
C#
public TnsParser(
    string content
)
Visual C++
public:
TnsParser(
    String^ content
)

Parameters

content
Type: System..::.String

See Also

TnsParser Class
MSBuild.Community.Tasks.Oracle Namespace


TnsParser Methods

[image] [image]

.NET Framework Class Library
TnsParser Methods
TnsParser Class See Also Send Feedback

The TnsParser type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
FindEntry | Locates a host entry by its name.
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

TnsParser Class
MSBuild.Community.Tasks.Oracle Namespace


FindEntry Method

[image]

.NET Framework Class Library
TnsParser..::.FindEntry Method
TnsParser Class See Also Send Feedback

Locates a host entry by its name.

Namespace: MSBuild.Community.Tasks.Oracle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Function FindEntry ( _
    name As String _
) As TnsEntry
C#
public TnsEntry FindEntry(
    string name
)
Visual C++
public:
TnsEntry^ FindEntry(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the entry to find.

Return Value

A TnsEntry which contains information about the location of the entry within the file.

See Also

TnsParser Class
MSBuild.Community.Tasks.Oracle Namespace


MSBuild.Community.Tasks.Sandcastle Namespace

[image]

.NET Framework Class Library
MSBuild.Community.Tasks.Sandcastle Namespace
Send Feedback

Classes

Class | Description
BuildAssembler | BuildAssembler task for Sandcastle.
ChmBuilder | ChmBuilder task for Sandcastle.
DBCSFix | DBCSFix task for Sandcastle.
MRefBuilder | MRefBuilder task for Sandcastle.
Sandcastle | The Sandcastle task.
SandcastleEnviroment | A class representing the sandcastle enviroment.
SandcastleToolBase | A base class for Sandcastle Tools,
XslTransform | XslTransform task for Sandcastle.


BuildAssembler Class

[image]

.NET Framework Class Library
BuildAssembler Class
Members See Also Send Feedback

BuildAssembler task for Sandcastle.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class BuildAssembler _
    Inherits SandcastleToolBase
C#
public class BuildAssembler : SandcastleToolBase
Visual C++
public ref class BuildAssembler : public SandcastleToolBase

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
Microsoft.Build.Utilities..::.ToolTask
MSBuild.Community.Tasks.Sandcastle..::.SandcastleToolBase
MSBuild.Community.Tasks.Sandcastle..::.BuildAssembler

See Also

BuildAssembler Members
MSBuild.Community.Tasks.Sandcastle Namespace


BuildAssembler Members

[image] [image]

.NET Framework Class Library
BuildAssembler Members
BuildAssembler Class Constructors Methods Properties See Also Send Feedback

The BuildAssembler type exposes the following members.

Constructors

Name | Description
BuildAssembler |

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from ToolTask.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Inherited from SandcastleToolBase.)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | Logs the events from text output. (Inherited from SandcastleToolBase.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Inherited from SandcastleToolBase.)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
ConfigFile | Gets or sets the configuration file.
EnvironmentOverride | Gets the override value of the PATH environment variable. (Inherited from SandcastleToolBase.)
ExitCode | (Inherited from ToolTask.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
ManifestFile | Gets or sets the manifest file.
NoInfoMessages | Gets or sets a value indicating whether no info messages will be output. (Inherited from SandcastleToolBase.)
NoWarnMessages | Gets or sets a value indicating whether no warning messages will be output. (Inherited from SandcastleToolBase.)
ResponseFileEncoding | (Inherited from ToolTask.)
SandcastleRoot | Gets or sets the sandcastle install root directory. (Inherited from SandcastleToolBase.)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Inherited from SandcastleToolBase.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)

See Also

BuildAssembler Class
MSBuild.Community.Tasks.Sandcastle Namespace


BuildAssembler Constructor

[image]

.NET Framework Class Library
BuildAssembler Constructor
BuildAssembler Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BuildAssembler()
Visual C++
public:
BuildAssembler()

See Also

BuildAssembler Class
MSBuild.Community.Tasks.Sandcastle Namespace


BuildAssembler Methods

[image] [image]

.NET Framework Class Library
BuildAssembler Methods
BuildAssembler Class See Also Send Feedback

The BuildAssembler type exposes the following members.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from ToolTask.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Inherited from SandcastleToolBase.)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | Logs the events from text output. (Inherited from SandcastleToolBase.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Inherited from SandcastleToolBase.)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

See Also

BuildAssembler Class
MSBuild.Community.Tasks.Sandcastle Namespace


GenerateCommandLineCommands Method

[image]

.NET Framework Class Library
BuildAssembler..::.GenerateCommandLineCommands Method
BuildAssembler Class See Also Send Feedback

Returns a string value containing the command line arguments to pass directly to the executable file.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateCommandLineCommands As String
C#
protected override string GenerateCommandLineCommands()
Visual C++
protected:
virtual String^ GenerateCommandLineCommands() override

Return Value

A string value containing the command line arguments to pass directly to the executable file.

See Also

BuildAssembler Class
MSBuild.Community.Tasks.Sandcastle Namespace


BuildAssembler Properties

[image] [image]

.NET Framework Class Library
BuildAssembler Properties
BuildAssembler Class See Also Send Feedback

The BuildAssembler type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
ConfigFile | Gets or sets the configuration file.
EnvironmentOverride | Gets the override value of the PATH environment variable. (Inherited from SandcastleToolBase.)
ExitCode | (Inherited from ToolTask.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
ManifestFile | Gets or sets the manifest file.
NoInfoMessages | Gets or sets a value indicating whether no info messages will be output. (Inherited from SandcastleToolBase.)
NoWarnMessages | Gets or sets a value indicating whether no warning messages will be output. (Inherited from SandcastleToolBase.)
ResponseFileEncoding | (Inherited from ToolTask.)
SandcastleRoot | Gets or sets the sandcastle install root directory. (Inherited from SandcastleToolBase.)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Inherited from SandcastleToolBase.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)

See Also

BuildAssembler Class
MSBuild.Community.Tasks.Sandcastle Namespace


ConfigFile Property

[image]

.NET Framework Class Library
BuildAssembler..::.ConfigFile Property
BuildAssembler Class See Also Send Feedback

Gets or sets the configuration file.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property ConfigFile As ITaskItem
C#
[RequiredAttribute]
public ITaskItem ConfigFile { get; set; }
Visual C++
[RequiredAttribute]
public:
property ITaskItem^ ConfigFile {
    ITaskItem^ get ();
    void set (ITaskItem^ value);
}

Field Value

The configuration file.

See Also

BuildAssembler Class
MSBuild.Community.Tasks.Sandcastle Namespace


ManifestFile Property

[image]

.NET Framework Class Library
BuildAssembler..::.ManifestFile Property
BuildAssembler Class See Also Send Feedback

Gets or sets the manifest file.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property ManifestFile As ITaskItem
C#
[RequiredAttribute]
public ITaskItem ManifestFile { get; set; }
Visual C++
[RequiredAttribute]
public:
property ITaskItem^ ManifestFile {
    ITaskItem^ get ();
    void set (ITaskItem^ value);
}

Field Value

The manifest file.

See Also

BuildAssembler Class
MSBuild.Community.Tasks.Sandcastle Namespace


ToolName Property

[image]

.NET Framework Class Library
BuildAssembler..::.ToolName Property
BuildAssembler Class See Also Send Feedback

Gets the name of the executable file to run.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ToolName As String
C#
protected override string ToolName { get; }
Visual C++
protected:
virtual property String^ ToolName {
    String^ get () override;
}

Field Value

Return Value

The name of the executable file to run.

See Also

BuildAssembler Class
MSBuild.Community.Tasks.Sandcastle Namespace


ChmBuilder Class

[image]

.NET Framework Class Library
ChmBuilder Class
Members See Also Send Feedback

ChmBuilder task for Sandcastle.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class ChmBuilder _
    Inherits SandcastleToolBase
C#
public class ChmBuilder : SandcastleToolBase
Visual C++
public ref class ChmBuilder : public SandcastleToolBase

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
Microsoft.Build.Utilities..::.ToolTask
MSBuild.Community.Tasks.Sandcastle..::.SandcastleToolBase
MSBuild.Community.Tasks.Sandcastle..::.ChmBuilder

See Also

ChmBuilder Members
MSBuild.Community.Tasks.Sandcastle Namespace


ChmBuilder Members

[image] [image]

.NET Framework Class Library
ChmBuilder Members
ChmBuilder Class Constructors Methods Properties See Also Send Feedback

The ChmBuilder type exposes the following members.

Constructors

Name | Description
ChmBuilder |

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from ToolTask.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Inherited from SandcastleToolBase.)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | Logs the events from text output. (Inherited from SandcastleToolBase.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Inherited from SandcastleToolBase.)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
EnvironmentOverride | Gets the override value of the PATH environment variable. (Inherited from SandcastleToolBase.)
ExitCode | (Inherited from ToolTask.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
HtmlDirectory | Gets or sets the HTML directory.
LanguageId | Gets or sets the language id.
Log | (Inherited from Task.)
Metadata | Gets or sets a value indicating whether this ChmBuilder is metadata.
NoInfoMessages | Gets or sets a value indicating whether no info messages will be output. (Inherited from SandcastleToolBase.)
NoWarnMessages | Gets or sets a value indicating whether no warning messages will be output. (Inherited from SandcastleToolBase.)
OutputDirectory | Gets or sets the output file.
ProjectName | Gets or sets the name of the project.
ResponseFileEncoding | (Inherited from ToolTask.)
SandcastleRoot | Gets or sets the sandcastle install root directory. (Inherited from SandcastleToolBase.)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Inherited from SandcastleToolBase.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
TocFile | Gets or sets the toc file.
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)

See Also

ChmBuilder Class
MSBuild.Community.Tasks.Sandcastle Namespace


ChmBuilder Constructor

[image]

.NET Framework Class Library
ChmBuilder Constructor
ChmBuilder Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ChmBuilder()
Visual C++
public:
ChmBuilder()

See Also

ChmBuilder Class
MSBuild.Community.Tasks.Sandcastle Namespace


ChmBuilder Methods

[image] [image]

.NET Framework Class Library
ChmBuilder Methods
ChmBuilder Class See Also Send Feedback

The ChmBuilder type exposes the following members.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from ToolTask.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Inherited from SandcastleToolBase.)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | Logs the events from text output. (Inherited from SandcastleToolBase.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Inherited from SandcastleToolBase.)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

See Also

ChmBuilder Class
MSBuild.Community.Tasks.Sandcastle Namespace


GenerateCommandLineCommands Method

[image]

.NET Framework Class Library
ChmBuilder..::.GenerateCommandLineCommands Method
ChmBuilder Class See Also Send Feedback

Returns a string value containing the command line arguments to pass directly to the executable file.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateCommandLineCommands As String
C#
protected override string GenerateCommandLineCommands()
Visual C++
protected:
virtual String^ GenerateCommandLineCommands() override

Return Value

A string value containing the command line arguments to pass directly to the executable file.

See Also

ChmBuilder Class
MSBuild.Community.Tasks.Sandcastle Namespace


ChmBuilder Properties

[image] [image]

.NET Framework Class Library
ChmBuilder Properties
ChmBuilder Class See Also Send Feedback

The ChmBuilder type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
EnvironmentOverride | Gets the override value of the PATH environment variable. (Inherited from SandcastleToolBase.)
ExitCode | (Inherited from ToolTask.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
HtmlDirectory | Gets or sets the HTML directory.
LanguageId | Gets or sets the language id.
Log | (Inherited from Task.)
Metadata | Gets or sets a value indicating whether this ChmBuilder is metadata.
NoInfoMessages | Gets or sets a value indicating whether no info messages will be output. (Inherited from SandcastleToolBase.)
NoWarnMessages | Gets or sets a value indicating whether no warning messages will be output. (Inherited from SandcastleToolBase.)
OutputDirectory | Gets or sets the output file.
ProjectName | Gets or sets the name of the project.
ResponseFileEncoding | (Inherited from ToolTask.)
SandcastleRoot | Gets or sets the sandcastle install root directory. (Inherited from SandcastleToolBase.)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Inherited from SandcastleToolBase.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
TocFile | Gets or sets the toc file.
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)

See Also

ChmBuilder Class
MSBuild.Community.Tasks.Sandcastle Namespace


HtmlDirectory Property

[image]

.NET Framework Class Library
ChmBuilder..::.HtmlDirectory Property
ChmBuilder Class See Also Send Feedback

Gets or sets the HTML directory.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property HtmlDirectory As String
C#
public string HtmlDirectory { get; set; }
Visual C++
public:
property String^ HtmlDirectory {
    String^ get ();
    void set (String^ value);
}

Field Value

The HTML directory.

See Also

ChmBuilder Class
MSBuild.Community.Tasks.Sandcastle Namespace


LanguageId Property

[image]

.NET Framework Class Library
ChmBuilder..::.LanguageId Property
ChmBuilder Class See Also Send Feedback

Gets or sets the language id.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property LanguageId As String
C#
public string LanguageId { get; set; }
Visual C++
public:
property String^ LanguageId {
    String^ get ();
    void set (String^ value);
}

Field Value

The language id.

See Also

ChmBuilder Class
MSBuild.Community.Tasks.Sandcastle Namespace


Metadata Property

[image]

.NET Framework Class Library
ChmBuilder..::.Metadata Property
ChmBuilder Class See Also Send Feedback

Gets or sets a value indicating whether this ChmBuilder is metadata.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Metadata As Boolean
C#
public bool Metadata { get; set; }
Visual C++
public:
property bool Metadata {
    bool get ();
    void set (bool value);
}

Field Value

true if metadata; otherwise, false.

See Also

ChmBuilder Class
MSBuild.Community.Tasks.Sandcastle Namespace


OutputDirectory Property

[image]

.NET Framework Class Library
ChmBuilder..::.OutputDirectory Property
ChmBuilder Class See Also Send Feedback

Gets or sets the output file.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property OutputDirectory As String
C#
public string OutputDirectory { get; set; }
Visual C++
public:
property String^ OutputDirectory {
    String^ get ();
    void set (String^ value);
}

Field Value

The output file.

See Also

ChmBuilder Class
MSBuild.Community.Tasks.Sandcastle Namespace


ProjectName Property

[image]

.NET Framework Class Library
ChmBuilder..::.ProjectName Property
ChmBuilder Class See Also Send Feedback

Gets or sets the name of the project.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ProjectName As String
C#
public string ProjectName { get; set; }
Visual C++
public:
property String^ ProjectName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the project.

See Also

ChmBuilder Class
MSBuild.Community.Tasks.Sandcastle Namespace


TocFile Property

[image]

.NET Framework Class Library
ChmBuilder..::.TocFile Property
ChmBuilder Class See Also Send Feedback

Gets or sets the toc file.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property TocFile As ITaskItem
C#
public ITaskItem TocFile { get; set; }
Visual C++
public:
property ITaskItem^ TocFile {
    ITaskItem^ get ();
    void set (ITaskItem^ value);
}

Field Value

The toc file.

See Also

ChmBuilder Class
MSBuild.Community.Tasks.Sandcastle Namespace


ToolName Property

[image]

.NET Framework Class Library
ChmBuilder..::.ToolName Property
ChmBuilder Class See Also Send Feedback

Gets the name of the executable file to run.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ToolName As String
C#
protected override string ToolName { get; }
Visual C++
protected:
virtual property String^ ToolName {
    String^ get () override;
}

Field Value

Return Value

The name of the executable file to run.

See Also

ChmBuilder Class
MSBuild.Community.Tasks.Sandcastle Namespace


DBCSFix Class

[image]

.NET Framework Class Library
DBCSFix Class
Members See Also Send Feedback

DBCSFix task for Sandcastle.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class DBCSFix _
    Inherits SandcastleToolBase
C#
public class DBCSFix : SandcastleToolBase
Visual C++
public ref class DBCSFix : public SandcastleToolBase

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
Microsoft.Build.Utilities..::.ToolTask
MSBuild.Community.Tasks.Sandcastle..::.SandcastleToolBase
MSBuild.Community.Tasks.Sandcastle..::.DBCSFix

See Also

DBCSFix Members
MSBuild.Community.Tasks.Sandcastle Namespace


DBCSFix Members

[image] [image]

.NET Framework Class Library
DBCSFix Members
DBCSFix Class Constructors Methods Properties See Also Send Feedback

The DBCSFix type exposes the following members.

Constructors

Name | Description
DBCSFix |

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from ToolTask.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Inherited from SandcastleToolBase.)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | Logs the events from text output. (Inherited from SandcastleToolBase.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Inherited from SandcastleToolBase.)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
ChmDirectory | Gets or sets the CHM directory.
EnvironmentOverride | Gets the override value of the PATH environment variable. (Inherited from SandcastleToolBase.)
ExitCode | (Inherited from ToolTask.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
LanguageId | Gets or sets the language id.
Log | (Inherited from Task.)
NoInfoMessages | Gets or sets a value indicating whether no info messages will be output. (Inherited from SandcastleToolBase.)
NoWarnMessages | Gets or sets a value indicating whether no warning messages will be output. (Inherited from SandcastleToolBase.)
ResponseFileEncoding | (Inherited from ToolTask.)
SandcastleRoot | Gets or sets the sandcastle install root directory. (Inherited from SandcastleToolBase.)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Inherited from SandcastleToolBase.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)

See Also

DBCSFix Class
MSBuild.Community.Tasks.Sandcastle Namespace


DBCSFix Constructor

[image]

.NET Framework Class Library
DBCSFix Constructor
DBCSFix Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DBCSFix()
Visual C++
public:
DBCSFix()

See Also

DBCSFix Class
MSBuild.Community.Tasks.Sandcastle Namespace


DBCSFix Methods

[image] [image]

.NET Framework Class Library
DBCSFix Methods
DBCSFix Class See Also Send Feedback

The DBCSFix type exposes the following members.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from ToolTask.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Inherited from SandcastleToolBase.)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | Logs the events from text output. (Inherited from SandcastleToolBase.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Inherited from SandcastleToolBase.)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

See Also

DBCSFix Class
MSBuild.Community.Tasks.Sandcastle Namespace


GenerateCommandLineCommands Method

[image]

.NET Framework Class Library
DBCSFix..::.GenerateCommandLineCommands Method
DBCSFix Class See Also Send Feedback

Returns a string value containing the command line arguments to pass directly to the executable file.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateCommandLineCommands As String
C#
protected override string GenerateCommandLineCommands()
Visual C++
protected:
virtual String^ GenerateCommandLineCommands() override

Return Value

A string value containing the command line arguments to pass directly to the executable file.

See Also

DBCSFix Class
MSBuild.Community.Tasks.Sandcastle Namespace


DBCSFix Properties

[image] [image]

.NET Framework Class Library
DBCSFix Properties
DBCSFix Class See Also Send Feedback

The DBCSFix type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
ChmDirectory | Gets or sets the CHM directory.
EnvironmentOverride | Gets the override value of the PATH environment variable. (Inherited from SandcastleToolBase.)
ExitCode | (Inherited from ToolTask.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
LanguageId | Gets or sets the language id.
Log | (Inherited from Task.)
NoInfoMessages | Gets or sets a value indicating whether no info messages will be output. (Inherited from SandcastleToolBase.)
NoWarnMessages | Gets or sets a value indicating whether no warning messages will be output. (Inherited from SandcastleToolBase.)
ResponseFileEncoding | (Inherited from ToolTask.)
SandcastleRoot | Gets or sets the sandcastle install root directory. (Inherited from SandcastleToolBase.)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Inherited from SandcastleToolBase.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)

See Also

DBCSFix Class
MSBuild.Community.Tasks.Sandcastle Namespace


ChmDirectory Property

[image]

.NET Framework Class Library
DBCSFix..::.ChmDirectory Property
DBCSFix Class See Also Send Feedback

Gets or sets the CHM directory.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ChmDirectory As String
C#
public string ChmDirectory { get; set; }
Visual C++
public:
property String^ ChmDirectory {
    String^ get ();
    void set (String^ value);
}

Field Value

The CHM directory.

See Also

DBCSFix Class
MSBuild.Community.Tasks.Sandcastle Namespace


LanguageId Property

[image]

.NET Framework Class Library
DBCSFix..::.LanguageId Property
DBCSFix Class See Also Send Feedback

Gets or sets the language id.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property LanguageId As String
C#
public string LanguageId { get; set; }
Visual C++
public:
property String^ LanguageId {
    String^ get ();
    void set (String^ value);
}

Field Value

The language id.

See Also

DBCSFix Class
MSBuild.Community.Tasks.Sandcastle Namespace


ToolName Property

[image]

.NET Framework Class Library
DBCSFix..::.ToolName Property
DBCSFix Class See Also Send Feedback

Gets the name of the executable file to run.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ToolName As String
C#
protected override string ToolName { get; }
Visual C++
protected:
virtual property String^ ToolName {
    String^ get () override;
}

Field Value

Return Value

The name of the executable file to run.

See Also

DBCSFix Class
MSBuild.Community.Tasks.Sandcastle Namespace


MRefBuilder Class

[image]

.NET Framework Class Library
MRefBuilder Class
Members See Also Send Feedback

MRefBuilder task for Sandcastle.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class MRefBuilder _
    Inherits SandcastleToolBase
C#
public class MRefBuilder : SandcastleToolBase
Visual C++
public ref class MRefBuilder : public SandcastleToolBase

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
Microsoft.Build.Utilities..::.ToolTask
MSBuild.Community.Tasks.Sandcastle..::.SandcastleToolBase
MSBuild.Community.Tasks.Sandcastle..::.MRefBuilder

See Also

MRefBuilder Members
MSBuild.Community.Tasks.Sandcastle Namespace


MRefBuilder Members

[image] [image]

.NET Framework Class Library
MRefBuilder Members
MRefBuilder Class Constructors Methods Properties See Also Send Feedback

The MRefBuilder type exposes the following members.

Constructors

Name | Description
MRefBuilder |

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from ToolTask.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Inherited from SandcastleToolBase.)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | Logs the events from text output. (Inherited from SandcastleToolBase.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Inherited from SandcastleToolBase.)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

Properties

Name | Description
Assemblies | Gets or sets the assemblies.
BuildEngine | (Inherited from Task.)
ConfigFile | Gets or sets the config file.
EnvironmentOverride | Gets the override value of the PATH environment variable. (Inherited from SandcastleToolBase.)
ExitCode | (Inherited from ToolTask.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
IncludeInternal | Gets or sets a value indicating whether to include internal members.
Log | (Inherited from Task.)
NoInfoMessages | Gets or sets a value indicating whether no info messages will be output. (Inherited from SandcastleToolBase.)
NoWarnMessages | Gets or sets a value indicating whether no warning messages will be output. (Inherited from SandcastleToolBase.)
OutputFile | Gets or sets the output file.
References | Gets or sets the references.
ResponseFileEncoding | (Inherited from ToolTask.)
SandcastleRoot | Gets or sets the sandcastle install root directory. (Inherited from SandcastleToolBase.)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Inherited from SandcastleToolBase.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)

See Also

MRefBuilder Class
MSBuild.Community.Tasks.Sandcastle Namespace


MRefBuilder Constructor

[image]

.NET Framework Class Library
MRefBuilder Constructor
MRefBuilder Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MRefBuilder()
Visual C++
public:
MRefBuilder()

See Also

MRefBuilder Class
MSBuild.Community.Tasks.Sandcastle Namespace


MRefBuilder Methods

[image] [image]

.NET Framework Class Library
MRefBuilder Methods
MRefBuilder Class See Also Send Feedback

The MRefBuilder type exposes the following members.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from ToolTask.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Inherited from SandcastleToolBase.)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | Logs the events from text output. (Inherited from SandcastleToolBase.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Inherited from SandcastleToolBase.)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

See Also

MRefBuilder Class
MSBuild.Community.Tasks.Sandcastle Namespace


GenerateCommandLineCommands Method

[image]

.NET Framework Class Library
MRefBuilder..::.GenerateCommandLineCommands Method
MRefBuilder Class See Also Send Feedback

Returns a string value containing the command line arguments to pass directly to the executable file.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateCommandLineCommands As String
C#
protected override string GenerateCommandLineCommands()
Visual C++
protected:
virtual String^ GenerateCommandLineCommands() override

Return Value

A string value containing the command line arguments to pass directly to the executable file.

See Also

MRefBuilder Class
MSBuild.Community.Tasks.Sandcastle Namespace


MRefBuilder Properties

[image] [image]

.NET Framework Class Library
MRefBuilder Properties
MRefBuilder Class See Also Send Feedback

The MRefBuilder type exposes the following members.

Properties

Name | Description
Assemblies | Gets or sets the assemblies.
BuildEngine | (Inherited from Task.)
ConfigFile | Gets or sets the config file.
EnvironmentOverride | Gets the override value of the PATH environment variable. (Inherited from SandcastleToolBase.)
ExitCode | (Inherited from ToolTask.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
IncludeInternal | Gets or sets a value indicating whether to include internal members.
Log | (Inherited from Task.)
NoInfoMessages | Gets or sets a value indicating whether no info messages will be output. (Inherited from SandcastleToolBase.)
NoWarnMessages | Gets or sets a value indicating whether no warning messages will be output. (Inherited from SandcastleToolBase.)
OutputFile | Gets or sets the output file.
References | Gets or sets the references.
ResponseFileEncoding | (Inherited from ToolTask.)
SandcastleRoot | Gets or sets the sandcastle install root directory. (Inherited from SandcastleToolBase.)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Inherited from SandcastleToolBase.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)

See Also

MRefBuilder Class
MSBuild.Community.Tasks.Sandcastle Namespace


Assemblies Property

[image]

.NET Framework Class Library
MRefBuilder..::.Assemblies Property
MRefBuilder Class See Also Send Feedback

Gets or sets the assemblies.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property Assemblies As ITaskItem()
C#
[RequiredAttribute]
public ITaskItem[] Assemblies { get; set; }
Visual C++
[RequiredAttribute]
public:
property array<ITaskItem^>^ Assemblies {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

Field Value

The assemblies.

See Also

MRefBuilder Class
MSBuild.Community.Tasks.Sandcastle Namespace


ConfigFile Property

[image]

.NET Framework Class Library
MRefBuilder..::.ConfigFile Property
MRefBuilder Class See Also Send Feedback

Gets or sets the config file.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ConfigFile As ITaskItem
C#
public ITaskItem ConfigFile { get; set; }
Visual C++
public:
property ITaskItem^ ConfigFile {
    ITaskItem^ get ();
    void set (ITaskItem^ value);
}

Field Value

The config file.

See Also

MRefBuilder Class
MSBuild.Community.Tasks.Sandcastle Namespace


IncludeInternal Property

[image]

.NET Framework Class Library
MRefBuilder..::.IncludeInternal Property
MRefBuilder Class See Also Send Feedback

Gets or sets a value indicating whether to include internal members.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property IncludeInternal As Boolean
C#
public bool IncludeInternal { get; set; }
Visual C++
public:
property bool IncludeInternal {
    bool get ();
    void set (bool value);
}

Field Value

true to include internal; otherwise, false.

See Also

MRefBuilder Class
MSBuild.Community.Tasks.Sandcastle Namespace


OutputFile Property

[image]

.NET Framework Class Library
MRefBuilder..::.OutputFile Property
MRefBuilder Class See Also Send Feedback

Gets or sets the output file.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property OutputFile As ITaskItem
C#
[RequiredAttribute]
public ITaskItem OutputFile { get; set; }
Visual C++
[RequiredAttribute]
public:
property ITaskItem^ OutputFile {
    ITaskItem^ get ();
    void set (ITaskItem^ value);
}

Field Value

The output file.

See Also

MRefBuilder Class
MSBuild.Community.Tasks.Sandcastle Namespace


References Property

[image]

.NET Framework Class Library
MRefBuilder..::.References Property
MRefBuilder Class See Also Send Feedback

Gets or sets the references.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property References As ITaskItem()
C#
public ITaskItem[] References { get; set; }
Visual C++
public:
property array<ITaskItem^>^ References {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

Field Value

The references.

See Also

MRefBuilder Class
MSBuild.Community.Tasks.Sandcastle Namespace


ToolName Property

[image]

.NET Framework Class Library
MRefBuilder..::.ToolName Property
MRefBuilder Class See Also Send Feedback

Gets the name of the executable file to run.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ToolName As String
C#
protected override string ToolName { get; }
Visual C++
protected:
virtual property String^ ToolName {
    String^ get () override;
}

Field Value

Return Value

The name of the executable file to run.

See Also

MRefBuilder Class
MSBuild.Community.Tasks.Sandcastle Namespace


Sandcastle Class

[image]

.NET Framework Class Library
Sandcastle Class
Members Example See Also Send Feedback

The Sandcastle task.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Sandcastle _
    Inherits Task
C#
public class Sandcastle : Task
Visual C++
public ref class Sandcastle : public Task

Examples

Create the Html Help for MSBuild Community Task project.
Copy Code
            <Sandcastle TopicStyle="vs2005"
                WorkingDirectory="$(MSBuildProjectDirectory)\Help"
                Assemblies="@(Assemblies)"
                Comments="@(Comments)"
                References="@(References)"
                ChmName="MSBuildTasks"
                HxName="MSBuildTasks" />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.Sandcastle..::.Sandcastle

See Also

Sandcastle Members
MSBuild.Community.Tasks.Sandcastle Namespace


Sandcastle Members

[image] [image]

.NET Framework Class Library
Sandcastle Members
Sandcastle Class Constructors Methods Properties See Also Send Feedback

The Sandcastle type exposes the following members.

Constructors

Name | Description
Sandcastle | Initializes a new instance of the Sandcastle class.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
Assemblies | Gets or sets the assemblies.
BuildEngine | (Inherited from Task.)
ChmName | Gets or sets the name of the CHM.
Clean | Gets or sets a value indicating whether working directory is cleaned.
Comments | Gets or sets the comments.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
HxName | Gets or sets a value indicating a Html Help 2x project will be created.
LanguageId | Gets or sets the language id.
Log | (Inherited from Task.)
NoInfoMessages | Gets or sets a value indicating whether no info messages will be output.
NoWarnMessages | Gets or sets a value indicating whether no warning messages will be output.
References | Gets or sets the references.
SandcastleConfig | Gets or sets the build assembler config file.
SandcastleRoot | Gets or sets the sandcastle install root directory.
TaskResources | (Inherited from Task.)
TopicStyle | Gets or sets the html help topic style.
WorkingDirectory | Gets or sets the working directory.

See Also

Sandcastle Class
MSBuild.Community.Tasks.Sandcastle Namespace


Sandcastle Constructor

[image]

.NET Framework Class Library
Sandcastle Constructor
Sandcastle Class See Also Send Feedback

Initializes a new instance of the Sandcastle class.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Sandcastle()
Visual C++
public:
Sandcastle()

See Also

Sandcastle Class
MSBuild.Community.Tasks.Sandcastle Namespace


Sandcastle Methods

[image] [image]

.NET Framework Class Library
Sandcastle Methods
Sandcastle Class See Also Send Feedback

The Sandcastle type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

Sandcastle Class
MSBuild.Community.Tasks.Sandcastle Namespace


Execute Method

[image]

.NET Framework Class Library
Sandcastle..::.Execute Method
Sandcastle Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

Sandcastle Class
MSBuild.Community.Tasks.Sandcastle Namespace


Sandcastle Properties

[image] [image]

.NET Framework Class Library
Sandcastle Properties
Sandcastle Class See Also Send Feedback

The Sandcastle type exposes the following members.

Properties

Name | Description
Assemblies | Gets or sets the assemblies.
BuildEngine | (Inherited from Task.)
ChmName | Gets or sets the name of the CHM.
Clean | Gets or sets a value indicating whether working directory is cleaned.
Comments | Gets or sets the comments.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
HxName | Gets or sets a value indicating a Html Help 2x project will be created.
LanguageId | Gets or sets the language id.
Log | (Inherited from Task.)
NoInfoMessages | Gets or sets a value indicating whether no info messages will be output.
NoWarnMessages | Gets or sets a value indicating whether no warning messages will be output.
References | Gets or sets the references.
SandcastleConfig | Gets or sets the build assembler config file.
SandcastleRoot | Gets or sets the sandcastle install root directory.
TaskResources | (Inherited from Task.)
TopicStyle | Gets or sets the html help topic style.
WorkingDirectory | Gets or sets the working directory.

See Also

Sandcastle Class
MSBuild.Community.Tasks.Sandcastle Namespace


Assemblies Property

[image]

.NET Framework Class Library
Sandcastle..::.Assemblies Property
Sandcastle Class See Also Send Feedback

Gets or sets the assemblies.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property Assemblies As ITaskItem()
C#
[RequiredAttribute]
public ITaskItem[] Assemblies { get; set; }
Visual C++
[RequiredAttribute]
public:
property array<ITaskItem^>^ Assemblies {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

Field Value

The assemblies.

See Also

Sandcastle Class
MSBuild.Community.Tasks.Sandcastle Namespace


ChmName Property

[image]

.NET Framework Class Library
Sandcastle..::.ChmName Property
Sandcastle Class See Also Send Feedback

Gets or sets the name of the CHM.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ChmName As String
C#
public string ChmName { get; set; }
Visual C++
public:
property String^ ChmName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the CHM.

See Also

Sandcastle Class
MSBuild.Community.Tasks.Sandcastle Namespace


Clean Property

[image]

.NET Framework Class Library
Sandcastle..::.Clean Property
Sandcastle Class See Also Send Feedback

Gets or sets a value indicating whether working directory is cleaned.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Clean As Boolean
C#
public bool Clean { get; set; }
Visual C++
public:
property bool Clean {
    bool get ();
    void set (bool value);
}

Field Value

true if clean; otherwise, false.

See Also

Sandcastle Class
MSBuild.Community.Tasks.Sandcastle Namespace


Comments Property

[image]

.NET Framework Class Library
Sandcastle..::.Comments Property
Sandcastle Class See Also Send Feedback

Gets or sets the comments.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property Comments As ITaskItem()
C#
[RequiredAttribute]
public ITaskItem[] Comments { get; set; }
Visual C++
[RequiredAttribute]
public:
property array<ITaskItem^>^ Comments {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

Field Value

The comments.

See Also

Sandcastle Class
MSBuild.Community.Tasks.Sandcastle Namespace


HxName Property

[image]

.NET Framework Class Library
Sandcastle..::.HxName Property
Sandcastle Class See Also Send Feedback

Gets or sets a value indicating a Html Help 2x project will be created.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property HxName As String
C#
public string HxName { get; set; }
Visual C++
public:
property String^ HxName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the Html Help 2x project.

See Also

Sandcastle Class
MSBuild.Community.Tasks.Sandcastle Namespace


LanguageId Property

[image]

.NET Framework Class Library
Sandcastle..::.LanguageId Property
Sandcastle Class See Also Send Feedback

Gets or sets the language id.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property LanguageId As String
C#
public string LanguageId { get; set; }
Visual C++
public:
property String^ LanguageId {
    String^ get ();
    void set (String^ value);
}

Field Value

The language id.

See Also

Sandcastle Class
MSBuild.Community.Tasks.Sandcastle Namespace


NoInfoMessages Property

[image]

.NET Framework Class Library
Sandcastle..::.NoInfoMessages Property
Sandcastle Class See Also Send Feedback

Gets or sets a value indicating whether no info messages will be output.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property NoInfoMessages As Boolean
C#
public bool NoInfoMessages { get; set; }
Visual C++
public:
property bool NoInfoMessages {
    bool get ();
    void set (bool value);
}

Field Value

true if no info messages; otherwise, false.

See Also

Sandcastle Class
MSBuild.Community.Tasks.Sandcastle Namespace


NoWarnMessages Property

[image]

.NET Framework Class Library
Sandcastle..::.NoWarnMessages Property
Sandcastle Class See Also Send Feedback

Gets or sets a value indicating whether no warning messages will be output.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property NoWarnMessages As Boolean
C#
public bool NoWarnMessages { get; set; }
Visual C++
public:
property bool NoWarnMessages {
    bool get ();
    void set (bool value);
}

Field Value

true if no warning messages; otherwise, false.

See Also

Sandcastle Class
MSBuild.Community.Tasks.Sandcastle Namespace


References Property

[image]

.NET Framework Class Library
Sandcastle..::.References Property
Sandcastle Class See Also Send Feedback

Gets or sets the references.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property References As ITaskItem()
C#
public ITaskItem[] References { get; set; }
Visual C++
public:
property array<ITaskItem^>^ References {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

Field Value

The references.

See Also

Sandcastle Class
MSBuild.Community.Tasks.Sandcastle Namespace


SandcastleConfig Property

[image]

.NET Framework Class Library
Sandcastle..::.SandcastleConfig Property
Sandcastle Class See Also Send Feedback

Gets or sets the build assembler config file.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property SandcastleConfig As ITaskItem
C#
public ITaskItem SandcastleConfig { get; set; }
Visual C++
public:
property ITaskItem^ SandcastleConfig {
    ITaskItem^ get ();
    void set (ITaskItem^ value);
}

Field Value

The build assembler config.

See Also

Sandcastle Class
MSBuild.Community.Tasks.Sandcastle Namespace


SandcastleRoot Property

[image]

.NET Framework Class Library
Sandcastle..::.SandcastleRoot Property
Sandcastle Class See Also Send Feedback

Gets or sets the sandcastle install root directory.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property SandcastleRoot As String
C#
public string SandcastleRoot { get; set; }
Visual C++
public:
property String^ SandcastleRoot {
    String^ get ();
    void set (String^ value);
}

Field Value

The sandcastle root directory.

See Also

Sandcastle Class
MSBuild.Community.Tasks.Sandcastle Namespace


TopicStyle Property

[image]

.NET Framework Class Library
Sandcastle..::.TopicStyle Property
Sandcastle Class See Also Send Feedback

Gets or sets the html help topic style.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property TopicStyle As String
C#
public string TopicStyle { get; set; }
Visual C++
public:
property String^ TopicStyle {
    String^ get ();
    void set (String^ value);
}

Field Value

The html help topic style.

Remarks

The styles supported are hana, prototype and vs2005. The default style is vs2005.

See Also

Sandcastle Class
MSBuild.Community.Tasks.Sandcastle Namespace


WorkingDirectory Property

[image]

.NET Framework Class Library
Sandcastle..::.WorkingDirectory Property
Sandcastle Class See Also Send Feedback

Gets or sets the working directory.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property WorkingDirectory As String
C#
public string WorkingDirectory { get; set; }
Visual C++
public:
property String^ WorkingDirectory {
    String^ get ();
    void set (String^ value);
}

Field Value

The working directory.

See Also

Sandcastle Class
MSBuild.Community.Tasks.Sandcastle Namespace


SandcastleEnviroment Class

[image]

.NET Framework Class Library
SandcastleEnviroment Class
Members See Also Send Feedback

A class representing the sandcastle enviroment.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class SandcastleEnviroment
C#
public class SandcastleEnviroment
Visual C++
public ref class SandcastleEnviroment

Inheritance Hierarchy

System..::.Object
MSBuild.Community.Tasks.Sandcastle..::.SandcastleEnviroment

See Also

SandcastleEnviroment Members
MSBuild.Community.Tasks.Sandcastle Namespace


SandcastleEnviroment Members

[image] [image]

.NET Framework Class Library
SandcastleEnviroment Members
SandcastleEnviroment Class Constructors Methods Properties See Also Send Feedback

The SandcastleEnviroment type exposes the following members.

Constructors

Name | Description
SandcastleEnviroment | Overloaded.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
PresentationDirectory | Gets or sets the presentation directory.
SandcastleRoot | Gets or sets the sandcastle root.
ToolsDirectory | Gets or sets the tools directory.
TransformsDirectory | Gets or sets the transforms directory.

See Also

SandcastleEnviroment Class
MSBuild.Community.Tasks.Sandcastle Namespace


SandcastleEnviroment Constructor

[image] [image]

.NET Framework Class Library
SandcastleEnviroment Constructor
SandcastleEnviroment Class See Also Send Feedback

Overload List

Name | Description
SandcastleEnviroment()()() | Initializes a new instance of the SandcastleEnviroment class.
SandcastleEnviroment(String) | Initializes a new instance of the SandcastleEnviroment class.

See Also

SandcastleEnviroment Class
SandcastleEnviroment Members
MSBuild.Community.Tasks.Sandcastle Namespace


SandcastleEnviroment Constructor

[image]

.NET Framework Class Library
SandcastleEnviroment Constructor
SandcastleEnviroment Class See Also Send Feedback

Initializes a new instance of the SandcastleEnviroment class.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SandcastleEnviroment()
Visual C++
public:
SandcastleEnviroment()

See Also

SandcastleEnviroment Class
SandcastleEnviroment Overload
MSBuild.Community.Tasks.Sandcastle Namespace


SandcastleEnviroment Constructor (String)

[image]

.NET Framework Class Library
SandcastleEnviroment Constructor (String)
SandcastleEnviroment Class See Also Send Feedback

Initializes a new instance of the SandcastleEnviroment class.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    sandcastleRoot As String _
)
C#
public SandcastleEnviroment(
    string sandcastleRoot
)
Visual C++
public:
SandcastleEnviroment(
    String^ sandcastleRoot
)

Parameters

sandcastleRoot
Type: System..::.String
The sandcastle root.

See Also

SandcastleEnviroment Class
SandcastleEnviroment Overload
MSBuild.Community.Tasks.Sandcastle Namespace


SandcastleEnviroment Methods

[image] [image]

.NET Framework Class Library
SandcastleEnviroment Methods
SandcastleEnviroment Class See Also Send Feedback

The SandcastleEnviroment type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

SandcastleEnviroment Class
MSBuild.Community.Tasks.Sandcastle Namespace


SandcastleEnviroment Properties

[image] [image]

.NET Framework Class Library
SandcastleEnviroment Properties
SandcastleEnviroment Class See Also Send Feedback

The SandcastleEnviroment type exposes the following members.

Properties

Name | Description
PresentationDirectory | Gets or sets the presentation directory.
SandcastleRoot | Gets or sets the sandcastle root.
ToolsDirectory | Gets or sets the tools directory.
TransformsDirectory | Gets or sets the transforms directory.

See Also

SandcastleEnviroment Class
MSBuild.Community.Tasks.Sandcastle Namespace


PresentationDirectory Property

[image]

.NET Framework Class Library
SandcastleEnviroment..::.PresentationDirectory Property
SandcastleEnviroment Class See Also Send Feedback

Gets or sets the presentation directory.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property PresentationDirectory As String
C#
public string PresentationDirectory { get; set; }
Visual C++
public:
property String^ PresentationDirectory {
    String^ get ();
    void set (String^ value);
}

Field Value

The presentation directory.

See Also

SandcastleEnviroment Class
MSBuild.Community.Tasks.Sandcastle Namespace


SandcastleRoot Property

[image]

.NET Framework Class Library
SandcastleEnviroment..::.SandcastleRoot Property
SandcastleEnviroment Class See Also Send Feedback

Gets or sets the sandcastle root.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property SandcastleRoot As String
C#
public string SandcastleRoot { get; set; }
Visual C++
public:
property String^ SandcastleRoot {
    String^ get ();
    void set (String^ value);
}

Field Value

The sandcastle root.

See Also

SandcastleEnviroment Class
MSBuild.Community.Tasks.Sandcastle Namespace


ToolsDirectory Property

[image]

.NET Framework Class Library
SandcastleEnviroment..::.ToolsDirectory Property
SandcastleEnviroment Class See Also Send Feedback

Gets or sets the tools directory.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ToolsDirectory As String
C#
public string ToolsDirectory { get; set; }
Visual C++
public:
property String^ ToolsDirectory {
    String^ get ();
    void set (String^ value);
}

Field Value

The tools directory.

See Also

SandcastleEnviroment Class
MSBuild.Community.Tasks.Sandcastle Namespace


TransformsDirectory Property

[image]

.NET Framework Class Library
SandcastleEnviroment..::.TransformsDirectory Property
SandcastleEnviroment Class See Also Send Feedback

Gets or sets the transforms directory.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property TransformsDirectory As String
C#
public string TransformsDirectory { get; set; }
Visual C++
public:
property String^ TransformsDirectory {
    String^ get ();
    void set (String^ value);
}

Field Value

The transforms directory.

See Also

SandcastleEnviroment Class
MSBuild.Community.Tasks.Sandcastle Namespace


SandcastleToolBase Class

[image]

.NET Framework Class Library
SandcastleToolBase Class
Members See Also Send Feedback

A base class for Sandcastle Tools,

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class SandcastleToolBase _
    Inherits ToolTask
C#
public abstract class SandcastleToolBase : ToolTask
Visual C++
public ref class SandcastleToolBase abstract : public ToolTask

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
Microsoft.Build.Utilities..::.ToolTask
MSBuild.Community.Tasks.Sandcastle..::.SandcastleToolBase
MSBuild.Community.Tasks.Sandcastle..::.BuildAssembler
MSBuild.Community.Tasks.Sandcastle..::.ChmBuilder
MSBuild.Community.Tasks.Sandcastle..::.DBCSFix
MSBuild.Community.Tasks.Sandcastle..::.MRefBuilder
MSBuild.Community.Tasks.Sandcastle..::.XslTransform

See Also

SandcastleToolBase Members
MSBuild.Community.Tasks.Sandcastle Namespace


SandcastleToolBase Members

[image] [image]

.NET Framework Class Library
SandcastleToolBase Members
SandcastleToolBase Class Constructors Methods Properties See Also Send Feedback

The SandcastleToolBase type exposes the following members.

Constructors

Name | Description
SandcastleToolBase | Initializes a new instance of the SandcastleToolBase class.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from ToolTask.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | (Inherited from ToolTask.)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | Logs the events from text output. (Overrides ToolTask..::.LogEventsFromTextOutput(String, MessageImportance).)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Overrides ToolTask..::.LogToolCommand(String).)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
EnvironmentOverride | Gets the override value of the PATH environment variable. (Overrides ToolTask..::.EnvironmentOverride.)
ExitCode | (Inherited from ToolTask.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
NoInfoMessages | Gets or sets a value indicating whether no info messages will be output.
NoWarnMessages | Gets or sets a value indicating whether no warning messages will be output.
ResponseFileEncoding | (Inherited from ToolTask.)
SandcastleRoot | Gets or sets the sandcastle install root directory.
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Overrides ToolTask..::.StandardOutputLoggingImportance.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | (Inherited from ToolTask.)
ToolPath | (Inherited from ToolTask.)

See Also

SandcastleToolBase Class
MSBuild.Community.Tasks.Sandcastle Namespace


SandcastleToolBase Constructor

[image]

.NET Framework Class Library
SandcastleToolBase Constructor
SandcastleToolBase Class See Also Send Feedback

Initializes a new instance of the SandcastleToolBase class.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SandcastleToolBase()
Visual C++
public:
SandcastleToolBase()

See Also

SandcastleToolBase Class
MSBuild.Community.Tasks.Sandcastle Namespace


SandcastleToolBase Methods

[image] [image]

.NET Framework Class Library
SandcastleToolBase Methods
SandcastleToolBase Class See Also Send Feedback

The SandcastleToolBase type exposes the following members.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from ToolTask.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | (Inherited from ToolTask.)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | Logs the events from text output. (Overrides ToolTask..::.LogEventsFromTextOutput(String, MessageImportance).)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Overrides ToolTask..::.LogToolCommand(String).)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

See Also

SandcastleToolBase Class
MSBuild.Community.Tasks.Sandcastle Namespace


GenerateFullPathToTool Method

[image]

.NET Framework Class Library
SandcastleToolBase..::.GenerateFullPathToTool Method
SandcastleToolBase Class See Also Send Feedback

Returns the fully qualified path to the executable file.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateFullPathToTool As String
C#
protected override string GenerateFullPathToTool()
Visual C++
protected:
virtual String^ GenerateFullPathToTool() override

Return Value

The fully qualified path to the executable file.

See Also

SandcastleToolBase Class
MSBuild.Community.Tasks.Sandcastle Namespace


LogEventsFromTextOutput Method

[image]

.NET Framework Class Library
SandcastleToolBase..::.LogEventsFromTextOutput Method
SandcastleToolBase Class See Also Send Feedback

Logs the events from text output.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub LogEventsFromTextOutput ( _
    singleLine As String, _
    messageImportance As MessageImportance _
)
C#
protected override void LogEventsFromTextOutput(
    string singleLine,
    MessageImportance messageImportance
)
Visual C++
protected:
virtual void LogEventsFromTextOutput(
    String^ singleLine,
    MessageImportance messageImportance
) override

Parameters

singleLine
Type: System..::.String
The single line.
messageImportance
Type: Microsoft.Build.Framework..::.MessageImportance
The message importance.

See Also

SandcastleToolBase Class
MSBuild.Community.Tasks.Sandcastle Namespace


LogToolCommand Method

[image]

.NET Framework Class Library
SandcastleToolBase..::.LogToolCommand Method
SandcastleToolBase Class See Also Send Feedback

Logs the starting point of the run to all registered loggers.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub LogToolCommand ( _
    message As String _
)
C#
protected override void LogToolCommand(
    string message
)
Visual C++
protected:
virtual void LogToolCommand(
    String^ message
) override

Parameters

message
Type: System..::.String
A descriptive message to provide loggers, usually the command line and switches.

See Also

SandcastleToolBase Class
MSBuild.Community.Tasks.Sandcastle Namespace


SandcastleToolBase Properties

[image] [image]

.NET Framework Class Library
SandcastleToolBase Properties
SandcastleToolBase Class See Also Send Feedback

The SandcastleToolBase type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
EnvironmentOverride | Gets the override value of the PATH environment variable. (Overrides ToolTask..::.EnvironmentOverride.)
ExitCode | (Inherited from ToolTask.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
NoInfoMessages | Gets or sets a value indicating whether no info messages will be output.
NoWarnMessages | Gets or sets a value indicating whether no warning messages will be output.
ResponseFileEncoding | (Inherited from ToolTask.)
SandcastleRoot | Gets or sets the sandcastle install root directory.
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Overrides ToolTask..::.StandardOutputLoggingImportance.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | (Inherited from ToolTask.)
ToolPath | (Inherited from ToolTask.)

See Also

SandcastleToolBase Class
MSBuild.Community.Tasks.Sandcastle Namespace


EnvironmentOverride Property

[image]

.NET Framework Class Library
SandcastleToolBase..::.EnvironmentOverride Property
SandcastleToolBase Class See Also Send Feedback

Gets the override value of the PATH environment variable.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property EnvironmentOverride As StringDictionary
C#
protected override StringDictionary EnvironmentOverride { get; }
Visual C++
protected:
virtual property StringDictionary^ EnvironmentOverride {
    StringDictionary^ get () override;
}

Field Value

Return Value

The override value of the PATH environment variable.

See Also

SandcastleToolBase Class
MSBuild.Community.Tasks.Sandcastle Namespace


NoInfoMessages Property

[image]

.NET Framework Class Library
SandcastleToolBase..::.NoInfoMessages Property
SandcastleToolBase Class See Also Send Feedback

Gets or sets a value indicating whether no info messages will be output.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property NoInfoMessages As Boolean
C#
public bool NoInfoMessages { get; set; }
Visual C++
public:
property bool NoInfoMessages {
    bool get ();
    void set (bool value);
}

Field Value

true if no info messages; otherwise, false.

See Also

SandcastleToolBase Class
MSBuild.Community.Tasks.Sandcastle Namespace


NoWarnMessages Property

[image]

.NET Framework Class Library
SandcastleToolBase..::.NoWarnMessages Property
SandcastleToolBase Class See Also Send Feedback

Gets or sets a value indicating whether no warning messages will be output.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property NoWarnMessages As Boolean
C#
public bool NoWarnMessages { get; set; }
Visual C++
public:
property bool NoWarnMessages {
    bool get ();
    void set (bool value);
}

Field Value

true if no warning messages; otherwise, false.

See Also

SandcastleToolBase Class
MSBuild.Community.Tasks.Sandcastle Namespace


SandcastleRoot Property

[image]

.NET Framework Class Library
SandcastleToolBase..::.SandcastleRoot Property
SandcastleToolBase Class See Also Send Feedback

Gets or sets the sandcastle install root directory.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property SandcastleRoot As String
C#
public string SandcastleRoot { get; set; }
Visual C++
public:
property String^ SandcastleRoot {
    String^ get ();
    void set (String^ value);
}

Field Value

The sandcastle root directory.

See Also

SandcastleToolBase Class
MSBuild.Community.Tasks.Sandcastle Namespace


StandardOutputLoggingImportance Property

[image]

.NET Framework Class Library
SandcastleToolBase..::.StandardOutputLoggingImportance Property
SandcastleToolBase Class See Also Send Feedback

Gets the MessageImportance with which to log errors.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property StandardOutputLoggingImportance As MessageImportance
C#
protected override MessageImportance StandardOutputLoggingImportance { get; }
Visual C++
protected:
virtual property MessageImportance StandardOutputLoggingImportance {
    MessageImportance get () override;
}

Field Value

Return Value

The MessageImportance with which to log errors.

See Also

SandcastleToolBase Class
MSBuild.Community.Tasks.Sandcastle Namespace


XslTransform Class

[image]

.NET Framework Class Library
XslTransform Class
Members See Also Send Feedback

XslTransform task for Sandcastle.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class XslTransform _
    Inherits SandcastleToolBase
C#
public class XslTransform : SandcastleToolBase
Visual C++
public ref class XslTransform : public SandcastleToolBase

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
Microsoft.Build.Utilities..::.ToolTask
MSBuild.Community.Tasks.Sandcastle..::.SandcastleToolBase
MSBuild.Community.Tasks.Sandcastle..::.XslTransform

See Also

XslTransform Members
MSBuild.Community.Tasks.Sandcastle Namespace


XslTransform Members

[image] [image]

.NET Framework Class Library
XslTransform Members
XslTransform Class Constructors Methods Properties See Also Send Feedback

The XslTransform type exposes the following members.

Constructors

Name | Description
XslTransform |

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from ToolTask.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Inherited from SandcastleToolBase.)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | Logs the events from text output. (Inherited from SandcastleToolBase.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Inherited from SandcastleToolBase.)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

Properties

Name | Description
Arguments | Gets or sets the arguments.
BuildEngine | (Inherited from Task.)
EnvironmentOverride | Gets the override value of the PATH environment variable. (Inherited from SandcastleToolBase.)
ExitCode | (Inherited from ToolTask.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
NoInfoMessages | Gets or sets a value indicating whether no info messages will be output. (Inherited from SandcastleToolBase.)
NoWarnMessages | Gets or sets a value indicating whether no warning messages will be output. (Inherited from SandcastleToolBase.)
OutputFile | Gets or sets the output file.
ResponseFileEncoding | (Inherited from ToolTask.)
SandcastleRoot | Gets or sets the sandcastle install root directory. (Inherited from SandcastleToolBase.)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Inherited from SandcastleToolBase.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)
XmlFile | Gets or sets the XML files.
XsltFiles | Gets or sets the XSLT files.

See Also

XslTransform Class
MSBuild.Community.Tasks.Sandcastle Namespace


XslTransform Constructor

[image]

.NET Framework Class Library
XslTransform Constructor
XslTransform Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public XslTransform()
Visual C++
public:
XslTransform()

See Also

XslTransform Class
MSBuild.Community.Tasks.Sandcastle Namespace


XslTransform Methods

[image] [image]

.NET Framework Class Library
XslTransform Methods
XslTransform Class See Also Send Feedback

The XslTransform type exposes the following members.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from ToolTask.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Inherited from SandcastleToolBase.)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | Logs the events from text output. (Inherited from SandcastleToolBase.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Inherited from SandcastleToolBase.)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

See Also

XslTransform Class
MSBuild.Community.Tasks.Sandcastle Namespace


GenerateCommandLineCommands Method

[image]

.NET Framework Class Library
XslTransform..::.GenerateCommandLineCommands Method
XslTransform Class See Also Send Feedback

Returns a string value containing the command line arguments to pass directly to the executable file.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateCommandLineCommands As String
C#
protected override string GenerateCommandLineCommands()
Visual C++
protected:
virtual String^ GenerateCommandLineCommands() override

Return Value

A string value containing the command line arguments to pass directly to the executable file.

See Also

XslTransform Class
MSBuild.Community.Tasks.Sandcastle Namespace


XslTransform Properties

[image] [image]

.NET Framework Class Library
XslTransform Properties
XslTransform Class See Also Send Feedback

The XslTransform type exposes the following members.

Properties

Name | Description
Arguments | Gets or sets the arguments.
BuildEngine | (Inherited from Task.)
EnvironmentOverride | Gets the override value of the PATH environment variable. (Inherited from SandcastleToolBase.)
ExitCode | (Inherited from ToolTask.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
NoInfoMessages | Gets or sets a value indicating whether no info messages will be output. (Inherited from SandcastleToolBase.)
NoWarnMessages | Gets or sets a value indicating whether no warning messages will be output. (Inherited from SandcastleToolBase.)
OutputFile | Gets or sets the output file.
ResponseFileEncoding | (Inherited from ToolTask.)
SandcastleRoot | Gets or sets the sandcastle install root directory. (Inherited from SandcastleToolBase.)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Inherited from SandcastleToolBase.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)
XmlFile | Gets or sets the XML files.
XsltFiles | Gets or sets the XSLT files.

See Also

XslTransform Class
MSBuild.Community.Tasks.Sandcastle Namespace


Arguments Property

[image]

.NET Framework Class Library
XslTransform..::.Arguments Property
XslTransform Class See Also Send Feedback

Gets or sets the arguments.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Arguments As String()
C#
public string[] Arguments { get; set; }
Visual C++
public:
property array<String^>^ Arguments {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Field Value

The arguments.

See Also

XslTransform Class
MSBuild.Community.Tasks.Sandcastle Namespace


OutputFile Property

[image]

.NET Framework Class Library
XslTransform..::.OutputFile Property
XslTransform Class See Also Send Feedback

Gets or sets the output file.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property OutputFile As ITaskItem
C#
[RequiredAttribute]
public ITaskItem OutputFile { get; set; }
Visual C++
[RequiredAttribute]
public:
property ITaskItem^ OutputFile {
    ITaskItem^ get ();
    void set (ITaskItem^ value);
}

Field Value

The output file.

See Also

XslTransform Class
MSBuild.Community.Tasks.Sandcastle Namespace


ToolName Property

[image]

.NET Framework Class Library
XslTransform..::.ToolName Property
XslTransform Class See Also Send Feedback

Gets the name of the executable file to run.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ToolName As String
C#
protected override string ToolName { get; }
Visual C++
protected:
virtual property String^ ToolName {
    String^ get () override;
}

Field Value

Return Value

The name of the executable file to run.

See Also

XslTransform Class
MSBuild.Community.Tasks.Sandcastle Namespace


XmlFile Property

[image]

.NET Framework Class Library
XslTransform..::.XmlFile Property
XslTransform Class See Also Send Feedback

Gets or sets the XML files.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property XmlFile As ITaskItem
C#
public ITaskItem XmlFile { get; set; }
Visual C++
public:
property ITaskItem^ XmlFile {
    ITaskItem^ get ();
    void set (ITaskItem^ value);
}

Field Value

The XML files.

See Also

XslTransform Class
MSBuild.Community.Tasks.Sandcastle Namespace


XsltFiles Property

[image]

.NET Framework Class Library
XslTransform..::.XsltFiles Property
XslTransform Class See Also Send Feedback

Gets or sets the XSLT files.

Namespace: MSBuild.Community.Tasks.Sandcastle
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property XsltFiles As ITaskItem()
C#
public ITaskItem[] XsltFiles { get; set; }
Visual C++
public:
property array<ITaskItem^>^ XsltFiles {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

Field Value

The XSLT files.

See Also

XslTransform Class
MSBuild.Community.Tasks.Sandcastle Namespace


MSBuild.Community.Tasks.Schema Namespace

[image]

.NET Framework Class Library
MSBuild.Community.Tasks.Schema Namespace
Send Feedback

Classes

Class | Description
TaskSchema | A Task that generates a XSD schema of the tasks in an assembly.

Enumerations

Enumeration | Description
TaskListAssemblyFormatType | Different ways to specify the assembly in a UsingTask element.


TaskListAssemblyFormatType Enumeration

[image]

.NET Framework Class Library
TaskListAssemblyFormatType Enumeration
See Also Send Feedback

Different ways to specify the assembly in a UsingTask element.

Namespace: MSBuild.Community.Tasks.Schema
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration TaskListAssemblyFormatType
C#
public enum TaskListAssemblyFormatType
Visual C++
public enum class TaskListAssemblyFormatType

Members

Member name | Description
AssemblyFileName | Assembly file name (Default): <UsingTask AssemblyFile="foo.dll" />
AssemblyFileFullPath | Assembly location: <UsingTask AssemblyName="foo" />
AssemblyName | Assembly Name: <UsingTask AssemblyFile="bin\debug\foo.dll" />
AssemblyFullName | Assembly fully qualified name: <UsingTask AssemblyName="foo.dll,version ...." />

See Also

MSBuild.Community.Tasks.Schema Namespace


TaskSchema Class

[image]

.NET Framework Class Library
TaskSchema Class
Members Example See Also Send Feedback

A Task that generates a XSD schema of the tasks in an assembly.

Namespace: MSBuild.Community.Tasks.Schema
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class TaskSchema _
    Inherits AppDomainIsolatedTask
C#
public class TaskSchema : AppDomainIsolatedTask
Visual C++
public ref class TaskSchema : public AppDomainIsolatedTask

Examples

Creates schema for MSBuild Community Task project

Copy Code
            <TaskSchema Assemblies="Build\MSBuild.Community.Tasks.dll"
                OutputPath="Build"
                CreateTaskList="true"
                IgnoreMsBuildSchema="true"
                Includes="Microsoft.Build.Commontypes.xsd"/>

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
Microsoft.Build.Utilities..::.AppDomainIsolatedTask
MSBuild.Community.Tasks.Schema..::.TaskSchema

See Also

TaskSchema Members
MSBuild.Community.Tasks.Schema Namespace


TaskSchema Members

[image] [image]

.NET Framework Class Library
TaskSchema Members
TaskSchema Class Constructors Methods Properties See Also Send Feedback

The TaskSchema type exposes the following members.

Constructors

Name | Description
TaskSchema |

Methods

Name | Description
CreateObjRef | (Inherited from MarshalByRefObject.)
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides AppDomainIsolatedTask..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetLifetimeService | (Inherited from MarshalByRefObject.)
GetType | (Inherited from Object.)
InitializeLifetimeService | (Inherited from AppDomainIsolatedTask.)
MemberwiseClone | Overloaded.
ToString | (Inherited from Object.)

Properties

Name | Description
Assemblies | Gets or sets the list of Assembly path to analyse.
BuildEngine | (Inherited from AppDomainIsolatedTask.)
CreateTaskList | Gets or sets a value indicating if the task list (using UsingTask) has to be genereted.
HelpKeywordPrefix | (Inherited from AppDomainIsolatedTask.)
HostObject | (Inherited from AppDomainIsolatedTask.)
IgnoreDocumentation | Gets or sets a value indicating wheter documentation should be ignored even if available (Default is false).
IgnoreMsBuildSchema | Gets or sets a value indicating if the MsBuild schema inclusing should be ignored
Includes | Gets or sets a list of included schemas
Log | (Inherited from AppDomainIsolatedTask.)
OutputPath | Gets or sets the output path for the generated files.
Schemas | Gets the list of path to the generated XSD schema.
TaskListAssemblyFormat | Gets or sets a value indicating how the assembly is specified in the UsingTask element.
TaskLists | Gets the path to the task list if it was generated.
TaskResources | (Inherited from AppDomainIsolatedTask.)

See Also

TaskSchema Class
MSBuild.Community.Tasks.Schema Namespace


TaskSchema Constructor

[image]

.NET Framework Class Library
TaskSchema Constructor
TaskSchema Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Schema
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public TaskSchema()
Visual C++
public:
TaskSchema()

See Also

TaskSchema Class
MSBuild.Community.Tasks.Schema Namespace


TaskSchema Methods

[image] [image]

.NET Framework Class Library
TaskSchema Methods
TaskSchema Class See Also Send Feedback

The TaskSchema type exposes the following members.

Methods

Name | Description
CreateObjRef | (Inherited from MarshalByRefObject.)
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides AppDomainIsolatedTask..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetLifetimeService | (Inherited from MarshalByRefObject.)
GetType | (Inherited from Object.)
InitializeLifetimeService | (Inherited from AppDomainIsolatedTask.)
MemberwiseClone | Overloaded.
ToString | (Inherited from Object.)

See Also

TaskSchema Class
MSBuild.Community.Tasks.Schema Namespace


Execute Method

[image]

.NET Framework Class Library
TaskSchema..::.Execute Method
TaskSchema Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.Schema
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

TaskSchema Class
MSBuild.Community.Tasks.Schema Namespace


MemberwiseClone Method

[image] [image]

.NET Framework Class Library
TaskSchema..::.MemberwiseClone Method
TaskSchema Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | (Inherited from Object.)
MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)

See Also

TaskSchema Class
TaskSchema Members
MSBuild.Community.Tasks.Schema Namespace


TaskSchema Properties

[image] [image]

.NET Framework Class Library
TaskSchema Properties
TaskSchema Class See Also Send Feedback

The TaskSchema type exposes the following members.

Properties

Name | Description
Assemblies | Gets or sets the list of Assembly path to analyse.
BuildEngine | (Inherited from AppDomainIsolatedTask.)
CreateTaskList | Gets or sets a value indicating if the task list (using UsingTask) has to be genereted.
HelpKeywordPrefix | (Inherited from AppDomainIsolatedTask.)
HostObject | (Inherited from AppDomainIsolatedTask.)
IgnoreDocumentation | Gets or sets a value indicating wheter documentation should be ignored even if available (Default is false).
IgnoreMsBuildSchema | Gets or sets a value indicating if the MsBuild schema inclusing should be ignored
Includes | Gets or sets a list of included schemas
Log | (Inherited from AppDomainIsolatedTask.)
OutputPath | Gets or sets the output path for the generated files.
Schemas | Gets the list of path to the generated XSD schema.
TaskListAssemblyFormat | Gets or sets a value indicating how the assembly is specified in the UsingTask element.
TaskLists | Gets the path to the task list if it was generated.
TaskResources | (Inherited from AppDomainIsolatedTask.)

See Also

TaskSchema Class
MSBuild.Community.Tasks.Schema Namespace


Assemblies Property

[image]

.NET Framework Class Library
TaskSchema..::.Assemblies Property
TaskSchema Class See Also Send Feedback

Gets or sets the list of Assembly path to analyse.

Namespace: MSBuild.Community.Tasks.Schema
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property Assemblies As ITaskItem()
C#
[RequiredAttribute]
public ITaskItem[] Assemblies { get; set; }
Visual C++
[RequiredAttribute]
public:
property array<ITaskItem^>^ Assemblies {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

See Also

TaskSchema Class
MSBuild.Community.Tasks.Schema Namespace


CreateTaskList Property

[image]

.NET Framework Class Library
TaskSchema..::.CreateTaskList Property
TaskSchema Class See Also Send Feedback

Gets or sets a value indicating if the task list (using UsingTask) has to be genereted.

Namespace: MSBuild.Community.Tasks.Schema
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property CreateTaskList As Boolean
C#
public bool CreateTaskList { get; set; }
Visual C++
public:
property bool CreateTaskList {
    bool get ();
    void set (bool value);
}

See Also

TaskSchema Class
MSBuild.Community.Tasks.Schema Namespace


IgnoreDocumentation Property

[image]

.NET Framework Class Library
TaskSchema..::.IgnoreDocumentation Property
TaskSchema Class See Also Send Feedback

Gets or sets a value indicating wheter documentation should be ignored even if available (Default is false).

Namespace: MSBuild.Community.Tasks.Schema
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property IgnoreDocumentation As Boolean
C#
public bool IgnoreDocumentation { get; set; }
Visual C++
public:
property bool IgnoreDocumentation {
    bool get ();
    void set (bool value);
}

See Also

TaskSchema Class
MSBuild.Community.Tasks.Schema Namespace


IgnoreMsBuildSchema Property

[image]

.NET Framework Class Library
TaskSchema..::.IgnoreMsBuildSchema Property
TaskSchema Class See Also Send Feedback

Gets or sets a value indicating if the MsBuild schema inclusing should be ignored

Namespace: MSBuild.Community.Tasks.Schema
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property IgnoreMsBuildSchema As Boolean
C#
public bool IgnoreMsBuildSchema { get; set; }
Visual C++
public:
property bool IgnoreMsBuildSchema {
    bool get ();
    void set (bool value);
}

See Also

TaskSchema Class
MSBuild.Community.Tasks.Schema Namespace


Includes Property

[image]

.NET Framework Class Library
TaskSchema..::.Includes Property
TaskSchema Class See Also Send Feedback

Gets or sets a list of included schemas

Namespace: MSBuild.Community.Tasks.Schema
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Includes As ITaskItem()
C#
public ITaskItem[] Includes { get; set; }
Visual C++
public:
property array<ITaskItem^>^ Includes {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

See Also

TaskSchema Class
MSBuild.Community.Tasks.Schema Namespace


OutputPath Property

[image]

.NET Framework Class Library
TaskSchema..::.OutputPath Property
TaskSchema Class See Also Send Feedback

Gets or sets the output path for the generated files.

Namespace: MSBuild.Community.Tasks.Schema
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property OutputPath As String
C#
public string OutputPath { get; set; }
Visual C++
public:
property String^ OutputPath {
    String^ get ();
    void set (String^ value);
}

See Also

TaskSchema Class
MSBuild.Community.Tasks.Schema Namespace


Schemas Property

[image]

.NET Framework Class Library
TaskSchema..::.Schemas Property
TaskSchema Class See Also Send Feedback

Gets the list of path to the generated XSD schema.

Namespace: MSBuild.Community.Tasks.Schema
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property Schemas As ITaskItem()
C#
[OutputAttribute]
public ITaskItem[] Schemas { get; }
Visual C++
[OutputAttribute]
public:
property array<ITaskItem^>^ Schemas {
    array<ITaskItem^>^ get ();
}

See Also

TaskSchema Class
MSBuild.Community.Tasks.Schema Namespace


TaskListAssemblyFormat Property

[image]

.NET Framework Class Library
TaskSchema..::.TaskListAssemblyFormat Property
TaskSchema Class See Also Send Feedback

Gets or sets a value indicating how the assembly is specified in the UsingTask element.

Namespace: MSBuild.Community.Tasks.Schema
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property TaskListAssemblyFormat As String
C#
public string TaskListAssemblyFormat { get; set; }
Visual C++
public:
property String^ TaskListAssemblyFormat {
    String^ get ();
    void set (String^ value);
}

See Also

TaskSchema Class
MSBuild.Community.Tasks.Schema Namespace


TaskLists Property

[image]

.NET Framework Class Library
TaskSchema..::.TaskLists Property
TaskSchema Class See Also Send Feedback

Gets the path to the task list if it was generated.

Namespace: MSBuild.Community.Tasks.Schema
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property TaskLists As ITaskItem()
C#
[OutputAttribute]
public ITaskItem[] TaskLists { get; }
Visual C++
[OutputAttribute]
public:
property array<ITaskItem^>^ TaskLists {
    array<ITaskItem^>^ get ();
}

See Also

TaskSchema Class
MSBuild.Community.Tasks.Schema Namespace


MSBuild.Community.Tasks.Services Namespace

[image]

.NET Framework Class Library
MSBuild.Community.Tasks.Services Namespace
Send Feedback

Classes

Class | Description
FileSystem | Provides access to the file system.
Win32Registry | Provides access to the Windows registry.

Interfaces

Interface | Description
IFilesSystem | The contract for a service that will provide access to the file system.
IRegistry | The contract for a service that will provide access to the registry.


FileSystem Class

[image]

.NET Framework Class Library
FileSystem Class
Members See Also Send Feedback

Provides access to the file system.

Namespace: MSBuild.Community.Tasks.Services
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class FileSystem _
    Implements IFilesSystem
C#
public class FileSystem : IFilesSystem
Visual C++
public ref class FileSystem : IFilesSystem

Inheritance Hierarchy

System..::.Object
MSBuild.Community.Tasks.Services..::.FileSystem

See Also

FileSystem Members
MSBuild.Community.Tasks.Services Namespace


FileSystem Members

[image] [image]

.NET Framework Class Library
FileSystem Members
FileSystem Class Constructors Methods See Also Send Feedback

The FileSystem type exposes the following members.

Constructors

Name | Description
FileSystem |

Methods

Name | Description
Equals | (Inherited from Object.)
FileExists | Determines whether the specified file exists.
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ReadTextFromFile | Returns the contents of a file.
ToString | (Inherited from Object.)
WriteTextToFile | Writes text to a file.

See Also

FileSystem Class
MSBuild.Community.Tasks.Services Namespace


FileSystem Constructor

[image]

.NET Framework Class Library
FileSystem Constructor
FileSystem Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Services
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FileSystem()
Visual C++
public:
FileSystem()

See Also

FileSystem Class
MSBuild.Community.Tasks.Services Namespace


FileSystem Methods

[image] [image]

.NET Framework Class Library
FileSystem Methods
FileSystem Class See Also Send Feedback

The FileSystem type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
FileExists | Determines whether the specified file exists.
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ReadTextFromFile | Returns the contents of a file.
ToString | (Inherited from Object.)
WriteTextToFile | Writes text to a file.

See Also

FileSystem Class
MSBuild.Community.Tasks.Services Namespace


FileExists Method

[image]

.NET Framework Class Library
FileSystem..::.FileExists Method
FileSystem Class See Also Send Feedback

Determines whether the specified file exists.

Namespace: MSBuild.Community.Tasks.Services
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Function FileExists ( _
    path As String _
) As Boolean
C#
public bool FileExists(
    string path
)
Visual C++
public:
virtual bool FileExists(
    String^ path
) sealed

Parameters

path
Type: System..::.String
The path of the file to check.

Return Value

True if the file exists on the filesystem.

Implements

IFilesSystem..::.FileExists(String)

See Also

FileSystem Class
MSBuild.Community.Tasks.Services Namespace


ReadTextFromFile Method

[image]

.NET Framework Class Library
FileSystem..::.ReadTextFromFile Method
FileSystem Class See Also Send Feedback

Returns the contents of a file.

Namespace: MSBuild.Community.Tasks.Services
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Function ReadTextFromFile ( _
    fileName As String _
) As String
C#
public string ReadTextFromFile(
    string fileName
)
Visual C++
public:
virtual String^ ReadTextFromFile(
    String^ fileName
) sealed

Parameters

fileName
Type: System..::.String
The path of the file to read.

Return Value

The text with the specified file.

Implements

IFilesSystem..::.ReadTextFromFile(String)

See Also

FileSystem Class
MSBuild.Community.Tasks.Services Namespace


WriteTextToFile Method

[image]

.NET Framework Class Library
FileSystem..::.WriteTextToFile Method
FileSystem Class See Also Send Feedback

Writes text to a file.

Namespace: MSBuild.Community.Tasks.Services
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteTextToFile ( _
    fileName As String, _
    contents As String _
)
C#
public void WriteTextToFile(
    string fileName,
    string contents
)
Visual C++
public:
virtual void WriteTextToFile(
    String^ fileName,
    String^ contents
) sealed

Parameters

fileName
Type: System..::.String
The path of the file to write.
contents
Type: System..::.String
The text to write to the file.

Implements

IFilesSystem..::.WriteTextToFile(String, String)

See Also

FileSystem Class
MSBuild.Community.Tasks.Services Namespace


IFilesSystem Interface

[image]

.NET Framework Class Library
IFilesSystem Interface
Members See Also Send Feedback

The contract for a service that will provide access to the file system.

Namespace: MSBuild.Community.Tasks.Services
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Interface IFilesSystem
C#
public interface IFilesSystem
Visual C++
public interface class IFilesSystem

See Also

IFilesSystem Members
MSBuild.Community.Tasks.Services Namespace


IFilesSystem Members

[image] [image]

.NET Framework Class Library
IFilesSystem Members
IFilesSystem Interface Methods See Also Send Feedback

The IFilesSystem type exposes the following members.

Methods

Name | Description
FileExists | Determines whether the specified file exists.
ReadTextFromFile | Returns the contents of a file.
WriteTextToFile | Writes text to a file.

See Also

IFilesSystem Interface
MSBuild.Community.Tasks.Services Namespace


IFilesSystem Methods

[image] [image]

.NET Framework Class Library
IFilesSystem Methods
IFilesSystem Interface See Also Send Feedback

The IFilesSystem type exposes the following members.

Methods

Name | Description
FileExists | Determines whether the specified file exists.
ReadTextFromFile | Returns the contents of a file.
WriteTextToFile | Writes text to a file.

See Also

IFilesSystem Interface
MSBuild.Community.Tasks.Services Namespace


FileExists Method

[image]

.NET Framework Class Library
IFilesSystem..::.FileExists Method
IFilesSystem Interface See Also Send Feedback

Determines whether the specified file exists.

Namespace: MSBuild.Community.Tasks.Services
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Function FileExists ( _
    path As String _
) As Boolean
C#
bool FileExists(
    string path
)
Visual C++
bool FileExists(
    String^ path
)

Parameters

path
Type: System..::.String
The path of the file to check.

Return Value

True if the file exists on the filesystem.

See Also

IFilesSystem Interface
MSBuild.Community.Tasks.Services Namespace


ReadTextFromFile Method

[image]

.NET Framework Class Library
IFilesSystem..::.ReadTextFromFile Method
IFilesSystem Interface See Also Send Feedback

Returns the contents of a file.

Namespace: MSBuild.Community.Tasks.Services
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Function ReadTextFromFile ( _
    fileName As String _
) As String
C#
string ReadTextFromFile(
    string fileName
)
Visual C++
String^ ReadTextFromFile(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
The path of the file to read.

Return Value

The text with the specified file.

See Also

IFilesSystem Interface
MSBuild.Community.Tasks.Services Namespace


WriteTextToFile Method

[image]

.NET Framework Class Library
IFilesSystem..::.WriteTextToFile Method
IFilesSystem Interface See Also Send Feedback

Writes text to a file.

Namespace: MSBuild.Community.Tasks.Services
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Sub WriteTextToFile ( _
    fileName As String, _
    contents As String _
)
C#
void WriteTextToFile(
    string fileName,
    string contents
)
Visual C++
void WriteTextToFile(
    String^ fileName,
    String^ contents
)

Parameters

fileName
Type: System..::.String
The path of the file to write.
contents
Type: System..::.String
The text to write to the file.

See Also

IFilesSystem Interface
MSBuild.Community.Tasks.Services Namespace


IRegistry Interface

[image]

.NET Framework Class Library
IRegistry Interface
Members See Also Send Feedback

The contract for a service that will provide access to the registry.

Namespace: MSBuild.Community.Tasks.Services
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Interface IRegistry
C#
public interface IRegistry
Visual C++
public interface class IRegistry

See Also

IRegistry Members
MSBuild.Community.Tasks.Services Namespace


IRegistry Members

[image] [image]

.NET Framework Class Library
IRegistry Members
IRegistry Interface Methods See Also Send Feedback

The IRegistry type exposes the following members.

Methods

Name | Description
GetSubKeys | Returns the names of the subkeys under the provided key.
GetValue | Returns the value of an entry in the registry.

See Also

IRegistry Interface
MSBuild.Community.Tasks.Services Namespace


IRegistry Methods

[image] [image]

.NET Framework Class Library
IRegistry Methods
IRegistry Interface See Also Send Feedback

The IRegistry type exposes the following members.

Methods

Name | Description
GetSubKeys | Returns the names of the subkeys under the provided key.
GetValue | Returns the value of an entry in the registry.

See Also

IRegistry Interface
MSBuild.Community.Tasks.Services Namespace


GetSubKeys Method

[image]

.NET Framework Class Library
IRegistry..::.GetSubKeys Method
IRegistry Interface See Also Send Feedback

Returns the names of the subkeys under the provided key.

Namespace: MSBuild.Community.Tasks.Services
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Function GetSubKeys ( _
    hive As RegistryHive, _
    key As String _
) As String()
C#
string[] GetSubKeys(
    RegistryHive hive,
    string key
)
Visual C++
array<String^>^ GetSubKeys(
    RegistryHive hive,
    String^ key
)

Parameters

hive
Type: Microsoft.Win32..::.RegistryHive
The hive where key is located.
key
Type: System..::.String
The key to search.

Return Value

A list of subkeys.

See Also

IRegistry Interface
MSBuild.Community.Tasks.Services Namespace


GetValue Method

[image]

.NET Framework Class Library
IRegistry..::.GetValue Method
IRegistry Interface See Also Send Feedback

Returns the value of an entry in the registry.

Namespace: MSBuild.Community.Tasks.Services
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Function GetValue ( _
    key As String, _
    valueName As String _
) As Object
C#
Object GetValue(
    string key,
    string valueName
)
Visual C++
Object^ GetValue(
    String^ key,
    String^ valueName
)

Parameters

key
Type: System..::.String
The key of the registry entry that contains valueName
valueName
Type: System..::.String
The name of the value to return.

Return Value

The value of the registry entry.

See Also

IRegistry Interface
MSBuild.Community.Tasks.Services Namespace


Win32Registry Class

[image]

.NET Framework Class Library
Win32Registry Class
Members See Also Send Feedback

Provides access to the Windows registry.

Namespace: MSBuild.Community.Tasks.Services
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Win32Registry _
    Implements IRegistry
C#
public class Win32Registry : IRegistry
Visual C++
public ref class Win32Registry : IRegistry

Inheritance Hierarchy

System..::.Object
MSBuild.Community.Tasks.Services..::.Win32Registry

See Also

Win32Registry Members
MSBuild.Community.Tasks.Services Namespace


Win32Registry Members

[image] [image]

.NET Framework Class Library
Win32Registry Members
Win32Registry Class Constructors Methods See Also Send Feedback

The Win32Registry type exposes the following members.

Constructors

Name | Description
Win32Registry |

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetSubKeys | Returns the names of the subkeys under the provided key.
GetType | (Inherited from Object.)
GetValue | Returns the value of an entry in the registry.
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

Win32Registry Class
MSBuild.Community.Tasks.Services Namespace


Win32Registry Constructor

[image]

.NET Framework Class Library
Win32Registry Constructor
Win32Registry Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Services
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Win32Registry()
Visual C++
public:
Win32Registry()

See Also

Win32Registry Class
MSBuild.Community.Tasks.Services Namespace


Win32Registry Methods

[image] [image]

.NET Framework Class Library
Win32Registry Methods
Win32Registry Class See Also Send Feedback

The Win32Registry type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetSubKeys | Returns the names of the subkeys under the provided key.
GetType | (Inherited from Object.)
GetValue | Returns the value of an entry in the registry.
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

Win32Registry Class
MSBuild.Community.Tasks.Services Namespace


GetSubKeys Method

[image]

.NET Framework Class Library
Win32Registry..::.GetSubKeys Method
Win32Registry Class See Also Send Feedback

Returns the names of the subkeys under the provided key.

Namespace: MSBuild.Community.Tasks.Services
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSubKeys ( _
    hive As RegistryHive, _
    key As String _
) As String()
C#
public string[] GetSubKeys(
    RegistryHive hive,
    string key
)
Visual C++
public:
virtual array<String^>^ GetSubKeys(
    RegistryHive hive,
    String^ key
) sealed

Parameters

hive
Type: Microsoft.Win32..::.RegistryHive
The hive where key is located.
key
Type: System..::.String
The key to search.

Return Value

A list of subkeys.

Implements

IRegistry..::.GetSubKeys(RegistryHive, String)

See Also

Win32Registry Class
MSBuild.Community.Tasks.Services Namespace


GetValue Method

[image]

.NET Framework Class Library
Win32Registry..::.GetValue Method
Win32Registry Class See Also Send Feedback

Returns the value of an entry in the registry.

Namespace: MSBuild.Community.Tasks.Services
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValue ( _
    key As String, _
    valueName As String _
) As Object
C#
public Object GetValue(
    string key,
    string valueName
)
Visual C++
public:
virtual Object^ GetValue(
    String^ key,
    String^ valueName
) sealed

Parameters

key
Type: System..::.String
The key of the registry entry that contains valueName
valueName
Type: System..::.String
The name of the value to return.

Return Value

The value of the registry entry.

Implements

IRegistry..::.GetValue(String, String)

See Also

Win32Registry Class
MSBuild.Community.Tasks.Services Namespace


MSBuild.Community.Tasks.SourceSafe Namespace

[image]

.NET Framework Class Library
MSBuild.Community.Tasks.SourceSafe Namespace
Send Feedback

Classes

Class | Description
VssAdd | Task that adds files to a Visual SourceSafe database.
VssBase | Base class for all of the Visual SourceSafe tasks.
VssCheckin | Task that executes a checkin against a VSS Database.
VssCheckout | Task that executes a checkout of files or projects against a Visual SourceSafe database.
VssClean | Task that can strip the source control information from a Visual Studio Solution and subprojects.
VssDiff | Task that records differences between the latest version of all the items in a Visual SourceSafe project and another version or label to a file.
VssGet | Task that retireves an item or project from a Visual SourceSafe database.
VssHistory | Generates an XML file containing details of all changes made to a Visual SourceSafe project or file between specified labels or dates.
VssLabel | Task that applies a label to a Visual SourceSafe item.
VssRecursiveBase | Base class for VSS tasks that can act recursively.
VssUndoCheckout | Task that undoes a checkout of files or projects against a Visual SourceSafe database.


VssAdd Class

[image]

.NET Framework Class Library
VssAdd Class
Members See Also Send Feedback

Task that adds files to a Visual SourceSafe database.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class VssAdd _
    Inherits VssBase
C#
public class VssAdd : VssBase
Visual C++
public ref class VssAdd : public VssBase

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.SourceSafe..::.VssBase
MSBuild.Community.Tasks.SourceSafe..::.VssAdd

See Also

VssAdd Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssAdd Members

[image] [image]

.NET Framework Class Library
VssAdd Members
VssAdd Class Constructors Methods Properties See Also Send Feedback

The VssAdd type exposes the following members.

Constructors

Name | Description
VssAdd |

Methods

Name | Description
ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified. (Inherited from VssBase.)
Equals | (Inherited from Object.)
Execute | Executes the task. (Overrides VssBase..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
LogErrorFromException | Logs an exception using the MSBuild logging framework. (Inherited from VssBase.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Comment | The comment to be applied to the newly added file.
Database | Represents the VSS Database (Inherited from VssBase.)
DatabasePath | The path to the folder that contains the srcsafe.ini file. (Inherited from VssBase.)
Files | List of files that should be added to SourceSafe.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Item | Represents the VSS item selected (file or project). (Inherited from VssBase.)
Log | (Inherited from Task.)
Password | The password to use to log in to SourceSafe. (Inherited from VssBase.)
Path | The Visual SourceSafe project or file to perform the action on (starts with "$/"). (Inherited from VssBase.)
TaskResources | (Inherited from Task.)
UserName | The name of the user accessing the SourceSafe database. (Inherited from VssBase.)
Version | A version of the Path to reference. (Inherited from VssBase.)

See Also

VssAdd Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssAdd Constructor

[image]

.NET Framework Class Library
VssAdd Constructor
VssAdd Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public VssAdd()
Visual C++
public:
VssAdd()

See Also

VssAdd Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssAdd Methods

[image] [image]

.NET Framework Class Library
VssAdd Methods
VssAdd Class See Also Send Feedback

The VssAdd type exposes the following members.

Methods

Name | Description
ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified. (Inherited from VssBase.)
Equals | (Inherited from Object.)
Execute | Executes the task. (Overrides VssBase..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
LogErrorFromException | Logs an exception using the MSBuild logging framework. (Inherited from VssBase.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

VssAdd Class
MSBuild.Community.Tasks.SourceSafe Namespace


Execute Method

[image]

.NET Framework Class Library
VssAdd..::.Execute Method
VssAdd Class See Also Send Feedback

Executes the task.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

trueTruetruetrue (True in Visual Basic) if the task ran successfully; otherwise falseFalsefalsefalse (False in Visual Basic).

Implements

ITask..::.Execute()()()

See Also

VssAdd Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssAdd Properties

[image] [image]

.NET Framework Class Library
VssAdd Properties
VssAdd Class See Also Send Feedback

The VssAdd type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Comment | The comment to be applied to the newly added file.
Database | Represents the VSS Database (Inherited from VssBase.)
DatabasePath | The path to the folder that contains the srcsafe.ini file. (Inherited from VssBase.)
Files | List of files that should be added to SourceSafe.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Item | Represents the VSS item selected (file or project). (Inherited from VssBase.)
Log | (Inherited from Task.)
Password | The password to use to log in to SourceSafe. (Inherited from VssBase.)
Path | The Visual SourceSafe project or file to perform the action on (starts with "$/"). (Inherited from VssBase.)
TaskResources | (Inherited from Task.)
UserName | The name of the user accessing the SourceSafe database. (Inherited from VssBase.)
Version | A version of the Path to reference. (Inherited from VssBase.)

See Also

VssAdd Class
MSBuild.Community.Tasks.SourceSafe Namespace


Comment Property

[image]

.NET Framework Class Library
VssAdd..::.Comment Property
VssAdd Class See Also Send Feedback

The comment to be applied to the newly added file.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Comment As String
C#
public string Comment { get; set; }
Visual C++
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}

See Also

VssAdd Class
MSBuild.Community.Tasks.SourceSafe Namespace


Files Property

[image]

.NET Framework Class Library
VssAdd..::.Files Property
VssAdd Class See Also Send Feedback

List of files that should be added to SourceSafe.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property Files As ITaskItem()
C#
[RequiredAttribute]
public ITaskItem[] Files { get; set; }
Visual C++
[RequiredAttribute]
public:
property array<ITaskItem^>^ Files {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

See Also

VssAdd Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssBase Class

[image]

.NET Framework Class Library
VssBase Class
Members See Also Send Feedback

Base class for all of the Visual SourceSafe tasks.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class VssBase _
    Inherits Task
C#
public abstract class VssBase : Task
Visual C++
public ref class VssBase abstract : public Task

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.SourceSafe..::.VssBase
MSBuild.Community.Tasks.SourceSafe..::.VssAdd
MSBuild.Community.Tasks.SourceSafe..::.VssDiff
MSBuild.Community.Tasks.SourceSafe..::.VssRecursiveBase

See Also

VssBase Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssBase Members

[image] [image]

.NET Framework Class Library
VssBase Members
VssBase Class Constructors Methods Properties See Also Send Feedback

The VssBase type exposes the following members.

Constructors

Name | Description
VssBase |

Methods

Name | Description
ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified.
Equals | (Inherited from Object.)
Execute | Reserved. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
LogErrorFromException | Logs an exception using the MSBuild logging framework.
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Database | Represents the VSS Database
DatabasePath | The path to the folder that contains the srcsafe.ini file.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Item | Represents the VSS item selected (file or project).
Log | (Inherited from Task.)
Password | The password to use to log in to SourceSafe.
Path | The Visual SourceSafe project or file to perform the action on (starts with "$/").
TaskResources | (Inherited from Task.)
UserName | The name of the user accessing the SourceSafe database.
Version | A version of the Path to reference.

See Also

VssBase Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssBase Constructor

[image]

.NET Framework Class Library
VssBase Constructor
VssBase Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New
C#
protected VssBase()
Visual C++
protected:
VssBase()

See Also

VssBase Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssBase Methods

[image] [image]

.NET Framework Class Library
VssBase Methods
VssBase Class See Also Send Feedback

The VssBase type exposes the following members.

Methods

Name | Description
ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified.
Equals | (Inherited from Object.)
Execute | Reserved. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
LogErrorFromException | Logs an exception using the MSBuild logging framework.
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

VssBase Class
MSBuild.Community.Tasks.SourceSafe Namespace


ConnectToDatabase Method

[image]

.NET Framework Class Library
VssBase..::.ConnectToDatabase Method
VssBase Class See Also Send Feedback

Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Sub ConnectToDatabase
C#
protected void ConnectToDatabase()
Visual C++
protected:
void ConnectToDatabase()

See Also

VssBase Class
MSBuild.Community.Tasks.SourceSafe Namespace


Execute Method

[image]

.NET Framework Class Library
VssBase..::.Execute Method
VssBase Class See Also Send Feedback

Reserved.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

Reserved.

Implements

ITask..::.Execute()()()

See Also

VssBase Class
MSBuild.Community.Tasks.SourceSafe Namespace


LogErrorFromException Method

[image]

.NET Framework Class Library
VssBase..::.LogErrorFromException Method
VssBase Class See Also Send Feedback

Logs an exception using the MSBuild logging framework.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Sub LogErrorFromException ( _
    e As Exception _
)
C#
protected void LogErrorFromException(
    Exception e
)
Visual C++
protected:
void LogErrorFromException(
    Exception^ e
)

Parameters

e
Type: System..::.Exception
The Exception to log.

See Also

VssBase Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssBase Properties

[image] [image]

.NET Framework Class Library
VssBase Properties
VssBase Class See Also Send Feedback

The VssBase type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Database | Represents the VSS Database
DatabasePath | The path to the folder that contains the srcsafe.ini file.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Item | Represents the VSS item selected (file or project).
Log | (Inherited from Task.)
Password | The password to use to log in to SourceSafe.
Path | The Visual SourceSafe project or file to perform the action on (starts with "$/").
TaskResources | (Inherited from Task.)
UserName | The name of the user accessing the SourceSafe database.
Version | A version of the Path to reference.

See Also

VssBase Class
MSBuild.Community.Tasks.SourceSafe Namespace


Database Property

[image]

.NET Framework Class Library
VssBase..::.Database Property
VssBase Class See Also Send Feedback

Represents the VSS Database

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Property Database As VSSDatabase
C#
protected VSSDatabase Database { get; set; }
Visual C++
protected:
property VSSDatabase^ Database {
    VSSDatabase^ get ();
    void set (VSSDatabase^ value);
}

See Also

VssBase Class
MSBuild.Community.Tasks.SourceSafe Namespace


DatabasePath Property

[image]

.NET Framework Class Library
VssBase..::.DatabasePath Property
VssBase Class See Also Send Feedback

The path to the folder that contains the srcsafe.ini file.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property DatabasePath As String
C#
[RequiredAttribute]
public string DatabasePath { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ DatabasePath {
    String^ get ();
    void set (String^ value);
}

See Also

VssBase Class
MSBuild.Community.Tasks.SourceSafe Namespace


Item Property

[image]

.NET Framework Class Library
VssBase..::.Item Property
VssBase Class See Also Send Feedback

Represents the VSS item selected (file or project).

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Property Item As IVSSItem
C#
protected IVSSItem Item { get; set; }
Visual C++
protected:
property IVSSItem^ Item {
    IVSSItem^ get ();
    void set (IVSSItem^ value);
}

See Also

VssBase Class
MSBuild.Community.Tasks.SourceSafe Namespace


Password Property

[image]

.NET Framework Class Library
VssBase..::.Password Property
VssBase Class See Also Send Feedback

The password to use to log in to SourceSafe.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password { get; set; }
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

VssBase Class
MSBuild.Community.Tasks.SourceSafe Namespace


Path Property

[image]

.NET Framework Class Library
VssBase..::.Path Property
VssBase Class See Also Send Feedback

The Visual SourceSafe project or file to perform the action on (starts with "$/").

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property Path As String
C#
[RequiredAttribute]
public string Path { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}

See Also

VssBase Class
MSBuild.Community.Tasks.SourceSafe Namespace


UserName Property

[image]

.NET Framework Class Library
VssBase..::.UserName Property
VssBase Class See Also Send Feedback

The name of the user accessing the SourceSafe database.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property UserName As String
C#
[RequiredAttribute]
public string UserName { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

See Also

VssBase Class
MSBuild.Community.Tasks.SourceSafe Namespace


Version Property

[image]

.NET Framework Class Library
VssBase..::.Version Property
VssBase Class See Also Send Feedback

A version of the Path to reference.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Version As String
C#
public string Version { get; set; }
Visual C++
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}

See Also

VssBase Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssCheckin Class

[image]

.NET Framework Class Library
VssCheckin Class
Members Example See Also Send Feedback

Task that executes a checkin against a VSS Database.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class VssCheckin _
    Inherits VssRecursiveBase
C#
public class VssCheckin : VssRecursiveBase
Visual C++
public ref class VssCheckin : public VssRecursiveBase

Examples

Copy Code
<VssCheckin UserName="ccnet_build"
              Password="build"
              LocalPath="C:\Dev\MyProjects\Project\TestFile.cs"
              Recursive="False"
              DatabasePath="\\VSSServer\VSS\srcsafe.ini"
              Path="$/Test/TestFile.cs"
            />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.SourceSafe..::.VssBase
MSBuild.Community.Tasks.SourceSafe..::.VssRecursiveBase
MSBuild.Community.Tasks.SourceSafe..::.VssCheckin

See Also

VssCheckin Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssCheckin Members

[image] [image]

.NET Framework Class Library
VssCheckin Members
VssCheckin Class Constructors Methods Properties See Also Send Feedback

The VssCheckin type exposes the following members.

Constructors

Name | Description
VssCheckin |

Methods

Name | Description
ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified. (Inherited from VssBase.)
Equals | (Inherited from Object.)
Execute | Executes the task. (Overrides VssRecursiveBase..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
LogErrorFromException | Logs an exception using the MSBuild logging framework. (Inherited from VssBase.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Comment | The checkin comment.
Database | Represents the VSS Database (Inherited from VssBase.)
DatabasePath | The path to the folder that contains the srcsafe.ini file. (Inherited from VssBase.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Item | Represents the VSS item selected (file or project). (Inherited from VssBase.)
LocalPath | The path to the local working directory.
Log | (Inherited from Task.)
Password | The password to use to log in to SourceSafe. (Inherited from VssBase.)
Path | The Visual SourceSafe project or file to perform the action on (starts with "$/"). (Inherited from VssBase.)
Recursive | Determines whether to perform the SourceSafe operation recursively. The default is trueTruetruetrue (True in Visual Basic). (Inherited from VssRecursiveBase.)
TaskResources | (Inherited from Task.)
UserName | The name of the user accessing the SourceSafe database. (Inherited from VssBase.)
Version | A version of the Path to reference. (Inherited from VssBase.)
Writable | Determines whether to leave the file(s) as writable once the checkin is complete. The default is falseFalsefalsefalse (False in Visual Basic).

See Also

VssCheckin Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssCheckin Constructor

[image]

.NET Framework Class Library
VssCheckin Constructor
VssCheckin Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public VssCheckin()
Visual C++
public:
VssCheckin()

See Also

VssCheckin Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssCheckin Methods

[image] [image]

.NET Framework Class Library
VssCheckin Methods
VssCheckin Class See Also Send Feedback

The VssCheckin type exposes the following members.

Methods

Name | Description
ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified. (Inherited from VssBase.)
Equals | (Inherited from Object.)
Execute | Executes the task. (Overrides VssRecursiveBase..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
LogErrorFromException | Logs an exception using the MSBuild logging framework. (Inherited from VssBase.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

VssCheckin Class
MSBuild.Community.Tasks.SourceSafe Namespace


Execute Method

[image]

.NET Framework Class Library
VssCheckin..::.Execute Method
VssCheckin Class See Also Send Feedback

Executes the task.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

trueTruetruetrue (True in Visual Basic) if the task ran successfully; otherwise falseFalsefalsefalse (False in Visual Basic).

Implements

ITask..::.Execute()()()

See Also

VssCheckin Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssCheckin Properties

[image] [image]

.NET Framework Class Library
VssCheckin Properties
VssCheckin Class See Also Send Feedback

The VssCheckin type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Comment | The checkin comment.
Database | Represents the VSS Database (Inherited from VssBase.)
DatabasePath | The path to the folder that contains the srcsafe.ini file. (Inherited from VssBase.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Item | Represents the VSS item selected (file or project). (Inherited from VssBase.)
LocalPath | The path to the local working directory.
Log | (Inherited from Task.)
Password | The password to use to log in to SourceSafe. (Inherited from VssBase.)
Path | The Visual SourceSafe project or file to perform the action on (starts with "$/"). (Inherited from VssBase.)
Recursive | Determines whether to perform the SourceSafe operation recursively. The default is trueTruetruetrue (True in Visual Basic). (Inherited from VssRecursiveBase.)
TaskResources | (Inherited from Task.)
UserName | The name of the user accessing the SourceSafe database. (Inherited from VssBase.)
Version | A version of the Path to reference. (Inherited from VssBase.)
Writable | Determines whether to leave the file(s) as writable once the checkin is complete. The default is falseFalsefalsefalse (False in Visual Basic).

See Also

VssCheckin Class
MSBuild.Community.Tasks.SourceSafe Namespace


Comment Property

[image]

.NET Framework Class Library
VssCheckin..::.Comment Property
VssCheckin Class See Also Send Feedback

The checkin comment.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Comment As String
C#
public string Comment { get; set; }
Visual C++
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}

See Also

VssCheckin Class
MSBuild.Community.Tasks.SourceSafe Namespace


LocalPath Property

[image]

.NET Framework Class Library
VssCheckin..::.LocalPath Property
VssCheckin Class See Also Send Feedback

The path to the local working directory.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property LocalPath As String
C#
[RequiredAttribute]
public string LocalPath { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ LocalPath {
    String^ get ();
    void set (String^ value);
}

See Also

VssCheckin Class
MSBuild.Community.Tasks.SourceSafe Namespace


Writable Property

[image]

.NET Framework Class Library
VssCheckin..::.Writable Property
VssCheckin Class See Also Send Feedback

Determines whether to leave the file(s) as writable once the checkin is complete. The default is falseFalsefalsefalse (False in Visual Basic).

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Writable As Boolean
C#
public bool Writable { get; set; }
Visual C++
public:
property bool Writable {
    bool get ();
    void set (bool value);
}

See Also

VssCheckin Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssCheckout Class

[image]

.NET Framework Class Library
VssCheckout Class
Members Example See Also Send Feedback

Task that executes a checkout of files or projects against a Visual SourceSafe database.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class VssCheckout _
    Inherits VssRecursiveBase
C#
public class VssCheckout : VssRecursiveBase
Visual C++
public ref class VssCheckout : public VssRecursiveBase

Examples

Copy Code
<VssCheckout UserName="ccnet_build"
              Password="build"
              LocalPath="C:\Dev\MyProjects\Project"
              Recursive="False"
              DatabasePath="\\VSSServer\VSS\srcsafe.ini"
              Path="$/Test/TestFile.cs"
            />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.SourceSafe..::.VssBase
MSBuild.Community.Tasks.SourceSafe..::.VssRecursiveBase
MSBuild.Community.Tasks.SourceSafe..::.VssCheckout

See Also

VssCheckout Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssCheckout Members

[image] [image]

.NET Framework Class Library
VssCheckout Members
VssCheckout Class Constructors Methods Properties See Also Send Feedback

The VssCheckout type exposes the following members.

Constructors

Name | Description
VssCheckout |

Methods

Name | Description
ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified. (Inherited from VssBase.)
Equals | (Inherited from Object.)
Execute | Executes the task. (Overrides VssRecursiveBase..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
LogErrorFromException | Logs an exception using the MSBuild logging framework. (Inherited from VssBase.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Database | Represents the VSS Database (Inherited from VssBase.)
DatabasePath | The path to the folder that contains the srcsafe.ini file. (Inherited from VssBase.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Item | Represents the VSS item selected (file or project). (Inherited from VssBase.)
LocalPath | The path to the local working directory.
Log | (Inherited from Task.)
Password | The password to use to log in to SourceSafe. (Inherited from VssBase.)
Path | The Visual SourceSafe project or file to perform the action on (starts with "$/"). (Inherited from VssBase.)
Recursive | Determines whether to perform the SourceSafe operation recursively. The default is trueTruetruetrue (True in Visual Basic). (Inherited from VssRecursiveBase.)
TaskResources | (Inherited from Task.)
UserName | The name of the user accessing the SourceSafe database. (Inherited from VssBase.)
Version | A version of the Path to reference. (Inherited from VssBase.)
Writable | Determines whether files will be writable once retrieved from the repository. The default is falseFalsefalsefalse (False in Visual Basic).

See Also

VssCheckout Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssCheckout Constructor

[image]

.NET Framework Class Library
VssCheckout Constructor
VssCheckout Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public VssCheckout()
Visual C++
public:
VssCheckout()

See Also

VssCheckout Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssCheckout Methods

[image] [image]

.NET Framework Class Library
VssCheckout Methods
VssCheckout Class See Also Send Feedback

The VssCheckout type exposes the following members.

Methods

Name | Description
ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified. (Inherited from VssBase.)
Equals | (Inherited from Object.)
Execute | Executes the task. (Overrides VssRecursiveBase..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
LogErrorFromException | Logs an exception using the MSBuild logging framework. (Inherited from VssBase.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

VssCheckout Class
MSBuild.Community.Tasks.SourceSafe Namespace


Execute Method

[image]

.NET Framework Class Library
VssCheckout..::.Execute Method
VssCheckout Class See Also Send Feedback

Executes the task.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

trueTruetruetrue (True in Visual Basic) if the task ran successfully; otherwise falseFalsefalsefalse (False in Visual Basic).

Implements

ITask..::.Execute()()()

See Also

VssCheckout Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssCheckout Properties

[image] [image]

.NET Framework Class Library
VssCheckout Properties
VssCheckout Class See Also Send Feedback

The VssCheckout type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Database | Represents the VSS Database (Inherited from VssBase.)
DatabasePath | The path to the folder that contains the srcsafe.ini file. (Inherited from VssBase.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Item | Represents the VSS item selected (file or project). (Inherited from VssBase.)
LocalPath | The path to the local working directory.
Log | (Inherited from Task.)
Password | The password to use to log in to SourceSafe. (Inherited from VssBase.)
Path | The Visual SourceSafe project or file to perform the action on (starts with "$/"). (Inherited from VssBase.)
Recursive | Determines whether to perform the SourceSafe operation recursively. The default is trueTruetruetrue (True in Visual Basic). (Inherited from VssRecursiveBase.)
TaskResources | (Inherited from Task.)
UserName | The name of the user accessing the SourceSafe database. (Inherited from VssBase.)
Version | A version of the Path to reference. (Inherited from VssBase.)
Writable | Determines whether files will be writable once retrieved from the repository. The default is falseFalsefalsefalse (False in Visual Basic).

See Also

VssCheckout Class
MSBuild.Community.Tasks.SourceSafe Namespace


LocalPath Property

[image]

.NET Framework Class Library
VssCheckout..::.LocalPath Property
VssCheckout Class See Also Send Feedback

The path to the local working directory.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property LocalPath As String
C#
[RequiredAttribute]
public string LocalPath { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ LocalPath {
    String^ get ();
    void set (String^ value);
}

See Also

VssCheckout Class
MSBuild.Community.Tasks.SourceSafe Namespace


Writable Property

[image]

.NET Framework Class Library
VssCheckout..::.Writable Property
VssCheckout Class See Also Send Feedback

Determines whether files will be writable once retrieved from the repository. The default is falseFalsefalsefalse (False in Visual Basic).

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Writable As Boolean
C#
public bool Writable { get; set; }
Visual C++
public:
property bool Writable {
    bool get ();
    void set (bool value);
}

See Also

VssCheckout Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssClean Class

[image]

.NET Framework Class Library
VssClean Class
Members See Also Send Feedback

Task that can strip the source control information from a Visual Studio Solution and subprojects.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class VssClean _
    Inherits Task
C#
public class VssClean : Task
Visual C++
public ref class VssClean : public Task

Remarks

This task is useful if you keep an archive of the source tree at each build milestone, because it's irritating to have to remove source control binding manually once you've copied a version of the code from your archive.

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.SourceSafe..::.VssClean

See Also

VssClean Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssClean Members

[image] [image]

.NET Framework Class Library
VssClean Members
VssClean Class Constructors Methods Properties See Also Send Feedback

The VssClean type exposes the following members.

Constructors

Name | Description
VssClean |

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | Executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
TaskResources | (Inherited from Task.)

See Also

VssClean Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssClean Constructor

[image]

.NET Framework Class Library
VssClean Constructor
VssClean Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public VssClean()
Visual C++
public:
VssClean()

See Also

VssClean Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssClean Methods

[image] [image]

.NET Framework Class Library
VssClean Methods
VssClean Class See Also Send Feedback

The VssClean type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | Executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

VssClean Class
MSBuild.Community.Tasks.SourceSafe Namespace


Execute Method

[image]

.NET Framework Class Library
VssClean..::.Execute Method
VssClean Class See Also Send Feedback

Executes the task.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

trueTruetruetrue (True in Visual Basic) if the task ran successfully; otherwise falseFalsefalsefalse (False in Visual Basic).

Implements

ITask..::.Execute()()()

See Also

VssClean Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssClean Properties

[image] [image]

.NET Framework Class Library
VssClean Properties
VssClean Class See Also Send Feedback

The VssClean type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
TaskResources | (Inherited from Task.)

See Also

VssClean Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssDiff Class

[image]

.NET Framework Class Library
VssDiff Class
Members Example See Also Send Feedback

Task that records differences between the latest version of all the items in a Visual SourceSafe project and another version or label to a file.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class VssDiff _
    Inherits VssBase
C#
public class VssDiff : VssBase
Visual C++
public ref class VssDiff : public VssBase

Examples

Generates a file containing all of the differences between the current version and the label "Test Label"

Copy Code
<VssDiff UserName="uid"
             Password="pwd"
             DatabasePath="\\VSSServer\VSS2\srcsafe.ini"
             Path="$/Test"
             OutputFile="Diff.xml"
             Label="Test Label"
            />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.SourceSafe..::.VssBase
MSBuild.Community.Tasks.SourceSafe..::.VssDiff

See Also

VssDiff Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssDiff Members

[image] [image]

.NET Framework Class Library
VssDiff Members
VssDiff Class Constructors Methods Properties See Also Send Feedback

The VssDiff type exposes the following members.

Constructors

Name | Description
VssDiff |

Methods

Name | Description
ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified. (Inherited from VssBase.)
Equals | (Inherited from Object.)
Execute | Executes the task. (Overrides VssBase..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
LogErrorFromException | Logs an exception using the MSBuild logging framework. (Inherited from VssBase.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Database | Represents the VSS Database (Inherited from VssBase.)
DatabasePath | The path to the folder that contains the srcsafe.ini file. (Inherited from VssBase.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Item | Represents the VSS item selected (file or project). (Inherited from VssBase.)
Label | The value of the label to compare to.
Log | (Inherited from Task.)
OutputFile | The name of the file to send the output to.
Password | The password to use to log in to SourceSafe. (Inherited from VssBase.)
Path | The Visual SourceSafe project or file to perform the action on (starts with "$/"). (Inherited from VssBase.)
TaskResources | (Inherited from Task.)
UserName | The name of the user accessing the SourceSafe database. (Inherited from VssBase.)
Version | A version of the Path to reference. (Inherited from VssBase.)

See Also

VssDiff Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssDiff Constructor

[image]

.NET Framework Class Library
VssDiff Constructor
VssDiff Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public VssDiff()
Visual C++
public:
VssDiff()

See Also

VssDiff Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssDiff Methods

[image] [image]

.NET Framework Class Library
VssDiff Methods
VssDiff Class See Also Send Feedback

The VssDiff type exposes the following members.

Methods

Name | Description
ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified. (Inherited from VssBase.)
Equals | (Inherited from Object.)
Execute | Executes the task. (Overrides VssBase..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
LogErrorFromException | Logs an exception using the MSBuild logging framework. (Inherited from VssBase.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

VssDiff Class
MSBuild.Community.Tasks.SourceSafe Namespace


Execute Method

[image]

.NET Framework Class Library
VssDiff..::.Execute Method
VssDiff Class See Also Send Feedback

Executes the task.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

trueTruetruetrue (True in Visual Basic) if the task ran successfully; otherwise falseFalsefalsefalse (False in Visual Basic).

Implements

ITask..::.Execute()()()

See Also

VssDiff Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssDiff Properties

[image] [image]

.NET Framework Class Library
VssDiff Properties
VssDiff Class See Also Send Feedback

The VssDiff type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Database | Represents the VSS Database (Inherited from VssBase.)
DatabasePath | The path to the folder that contains the srcsafe.ini file. (Inherited from VssBase.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Item | Represents the VSS item selected (file or project). (Inherited from VssBase.)
Label | The value of the label to compare to.
Log | (Inherited from Task.)
OutputFile | The name of the file to send the output to.
Password | The password to use to log in to SourceSafe. (Inherited from VssBase.)
Path | The Visual SourceSafe project or file to perform the action on (starts with "$/"). (Inherited from VssBase.)
TaskResources | (Inherited from Task.)
UserName | The name of the user accessing the SourceSafe database. (Inherited from VssBase.)
Version | A version of the Path to reference. (Inherited from VssBase.)

See Also

VssDiff Class
MSBuild.Community.Tasks.SourceSafe Namespace


Label Property

[image]

.NET Framework Class Library
VssDiff..::.Label Property
VssDiff Class See Also Send Feedback

The value of the label to compare to.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property Label As String
C#
[RequiredAttribute]
public string Label { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ Label {
    String^ get ();
    void set (String^ value);
}

See Also

VssDiff Class
MSBuild.Community.Tasks.SourceSafe Namespace


OutputFile Property

[image]

.NET Framework Class Library
VssDiff..::.OutputFile Property
VssDiff Class See Also Send Feedback

The name of the file to send the output to.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property OutputFile As String
C#
[RequiredAttribute]
public string OutputFile { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ OutputFile {
    String^ get ();
    void set (String^ value);
}

See Also

VssDiff Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssGet Class

[image]

.NET Framework Class Library
VssGet Class
Members Example See Also Send Feedback

Task that retireves an item or project from a Visual SourceSafe database.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class VssGet _
    Inherits VssRecursiveBase
C#
public class VssGet : VssRecursiveBase
Visual C++
public ref class VssGet : public VssRecursiveBase

Examples

Get the latest version (recursive) of a file from a VSS database and place in the specified local folder.

Copy Code
            <VssGet UserName="user"
                Password="password"
                LocalPath="C:\Dev\MyProjects\Project"
                Recursive="True"
                DatabasePath="\\VSSServer\VSS\srcsafe.ini"
                Path="$/Project"

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.SourceSafe..::.VssBase
MSBuild.Community.Tasks.SourceSafe..::.VssRecursiveBase
MSBuild.Community.Tasks.SourceSafe..::.VssGet

See Also

VssGet Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssGet Members

[image] [image]

.NET Framework Class Library
VssGet Members
VssGet Class Constructors Methods Properties See Also Send Feedback

The VssGet type exposes the following members.

Constructors

Name | Description
VssGet |

Methods

Name | Description
ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified. (Inherited from VssBase.)
Equals | (Inherited from Object.)
Execute | Runs the task using the specified parameters. (Overrides VssRecursiveBase..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
LogErrorFromException | Logs an exception using the MSBuild logging framework. (Inherited from VssBase.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Database | Represents the VSS Database (Inherited from VssBase.)
DatabasePath | The path to the folder that contains the srcsafe.ini file. (Inherited from VssBase.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Item | Represents the VSS item selected (file or project). (Inherited from VssBase.)
LocalPath | The path to the local working directory.
Log | (Inherited from Task.)
Password | The password to use to log in to SourceSafe. (Inherited from VssBase.)
Path | The Visual SourceSafe project or file to perform the action on (starts with "$/"). (Inherited from VssBase.)
Recursive | Determines whether to perform the SourceSafe operation recursively. The default is trueTruetruetrue (True in Visual Basic). (Inherited from VssRecursiveBase.)
Replace | Determines whether to replace writable files. The default is falseFalsefalsefalse (False in Visual Basic).
TaskResources | (Inherited from Task.)
UserName | The name of the user accessing the SourceSafe database. (Inherited from VssBase.)
Version | A version of the Path to reference. (Inherited from VssBase.)
Writable | Determines whether files will be writable once retrieved from the repository. The default is falseFalsefalsefalse (False in Visual Basic).

See Also

VssGet Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssGet Constructor

[image]

.NET Framework Class Library
VssGet Constructor
VssGet Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public VssGet()
Visual C++
public:
VssGet()

See Also

VssGet Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssGet Methods

[image] [image]

.NET Framework Class Library
VssGet Methods
VssGet Class See Also Send Feedback

The VssGet type exposes the following members.

Methods

Name | Description
ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified. (Inherited from VssBase.)
Equals | (Inherited from Object.)
Execute | Runs the task using the specified parameters. (Overrides VssRecursiveBase..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
LogErrorFromException | Logs an exception using the MSBuild logging framework. (Inherited from VssBase.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

VssGet Class
MSBuild.Community.Tasks.SourceSafe Namespace


Execute Method

[image]

.NET Framework Class Library
VssGet..::.Execute Method
VssGet Class See Also Send Feedback

Runs the task using the specified parameters.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

trueTruetruetrue (True in Visual Basic) if the task ran successfully; otherwise falseFalsefalsefalse (False in Visual Basic).

Implements

ITask..::.Execute()()()

See Also

VssGet Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssGet Properties

[image] [image]

.NET Framework Class Library
VssGet Properties
VssGet Class See Also Send Feedback

The VssGet type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Database | Represents the VSS Database (Inherited from VssBase.)
DatabasePath | The path to the folder that contains the srcsafe.ini file. (Inherited from VssBase.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Item | Represents the VSS item selected (file or project). (Inherited from VssBase.)
LocalPath | The path to the local working directory.
Log | (Inherited from Task.)
Password | The password to use to log in to SourceSafe. (Inherited from VssBase.)
Path | The Visual SourceSafe project or file to perform the action on (starts with "$/"). (Inherited from VssBase.)
Recursive | Determines whether to perform the SourceSafe operation recursively. The default is trueTruetruetrue (True in Visual Basic). (Inherited from VssRecursiveBase.)
Replace | Determines whether to replace writable files. The default is falseFalsefalsefalse (False in Visual Basic).
TaskResources | (Inherited from Task.)
UserName | The name of the user accessing the SourceSafe database. (Inherited from VssBase.)
Version | A version of the Path to reference. (Inherited from VssBase.)
Writable | Determines whether files will be writable once retrieved from the repository. The default is falseFalsefalsefalse (False in Visual Basic).

See Also

VssGet Class
MSBuild.Community.Tasks.SourceSafe Namespace


LocalPath Property

[image]

.NET Framework Class Library
VssGet..::.LocalPath Property
VssGet Class See Also Send Feedback

The path to the local working directory.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property LocalPath As String
C#
[RequiredAttribute]
public string LocalPath { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ LocalPath {
    String^ get ();
    void set (String^ value);
}

See Also

VssGet Class
MSBuild.Community.Tasks.SourceSafe Namespace


Replace Property

[image]

.NET Framework Class Library
VssGet..::.Replace Property
VssGet Class See Also Send Feedback

Determines whether to replace writable files. The default is falseFalsefalsefalse (False in Visual Basic).

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Replace As Boolean
C#
public bool Replace { get; set; }
Visual C++
public:
property bool Replace {
    bool get ();
    void set (bool value);
}

See Also

VssGet Class
MSBuild.Community.Tasks.SourceSafe Namespace


Writable Property

[image]

.NET Framework Class Library
VssGet..::.Writable Property
VssGet Class See Also Send Feedback

Determines whether files will be writable once retrieved from the repository. The default is falseFalsefalsefalse (False in Visual Basic).

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Writable As Boolean
C#
public bool Writable { get; set; }
Visual C++
public:
property bool Writable {
    bool get ();
    void set (bool value);
}

See Also

VssGet Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssHistory Class

[image]

.NET Framework Class Library
VssHistory Class
Members Example See Also Send Feedback

Generates an XML file containing details of all changes made to a Visual SourceSafe project or file between specified labels or dates.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class VssHistory _
    Inherits VssRecursiveBase
C#
public class VssHistory : VssRecursiveBase
Visual C++
public ref class VssHistory : public VssRecursiveBase

Examples

Generates a file containing details of all the changes made to the $/Test project by a user called joe.bloggs

Copy Code
<VssHistory UserName="uid"
             Password="pwd"
             DatabasePath="\\VSSServer\VSS\srcsafe.ini"
             Path="$/Test"
             User="joe.bloggs"
             OutputFile="History.xml"
             Recursive="True"
            />

Examples

Generates a file containing details of all the changes made between the labels Build1 and Build2 in the $/Test project.

Copy Code
<VssHistory UserName="uid"
             Password="pwd"
             DatabasePath="\\VSSServer\VSS\srcsafe.ini"
             Path="$/Test"
             FromLabel="Build1"
             ToLabel="Build2"
             OutputFile="History.xml"
             Recursive="True"
            />

Examples

Generates a file containing details of all the changes made between the 1st December 2005 and 10th December 2005in the $/Test project.

Copy Code
<VssHistory UserName="uid"
             Password="pwd"
             DatabasePath="\\VSSServer\VSS\srcsafe.ini"
             Path="$/Test"
             FromDate="2005-12-01 00:00"
             ToDate="2005-12-10 00:00"
             OutputFile="History.xml"
             Recursive="True"
            />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.SourceSafe..::.VssBase
MSBuild.Community.Tasks.SourceSafe..::.VssRecursiveBase
MSBuild.Community.Tasks.SourceSafe..::.VssHistory

See Also

VssHistory Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssHistory Members

[image] [image]

.NET Framework Class Library
VssHistory Members
VssHistory Class Constructors Methods Properties See Also Send Feedback

The VssHistory type exposes the following members.

Constructors

Name | Description
VssHistory |

Methods

Name | Description
ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified. (Inherited from VssBase.)
Equals | (Inherited from Object.)
Execute | Executes the task. (Overrides VssRecursiveBase..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
LogErrorFromException | Logs an exception using the MSBuild logging framework. (Inherited from VssBase.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Database | Represents the VSS Database (Inherited from VssBase.)
DatabasePath | The path to the folder that contains the srcsafe.ini file. (Inherited from VssBase.)
FromDate | The End Date for the history.
FromLabel | The label to compare up to.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Item | Represents the VSS item selected (file or project). (Inherited from VssBase.)
Log | (Inherited from Task.)
OutputFile | The name and path of the XML output file.
Password | The password to use to log in to SourceSafe. (Inherited from VssBase.)
Path | The Visual SourceSafe project or file to perform the action on (starts with "$/"). (Inherited from VssBase.)
Recursive | Determines whether to perform the SourceSafe operation recursively. The default is trueTruetruetrue (True in Visual Basic). (Inherited from VssRecursiveBase.)
TaskResources | (Inherited from Task.)
ToDate | The Start Date for the history.
ToLabel | The label to start comparing to.
User | The name of the user whose changes should be listed in the history.
UserName | The name of the user accessing the SourceSafe database. (Inherited from VssBase.)
Version | A version of the Path to reference. (Inherited from VssBase.)

See Also

VssHistory Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssHistory Constructor

[image]

.NET Framework Class Library
VssHistory Constructor
VssHistory Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public VssHistory()
Visual C++
public:
VssHistory()

See Also

VssHistory Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssHistory Methods

[image] [image]

.NET Framework Class Library
VssHistory Methods
VssHistory Class See Also Send Feedback

The VssHistory type exposes the following members.

Methods

Name | Description
ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified. (Inherited from VssBase.)
Equals | (Inherited from Object.)
Execute | Executes the task. (Overrides VssRecursiveBase..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
LogErrorFromException | Logs an exception using the MSBuild logging framework. (Inherited from VssBase.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

VssHistory Class
MSBuild.Community.Tasks.SourceSafe Namespace


Execute Method

[image]

.NET Framework Class Library
VssHistory..::.Execute Method
VssHistory Class See Also Send Feedback

Executes the task.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

trueTruetruetrue (True in Visual Basic) if the task ran successfully; otherwise falseFalsefalsefalse (False in Visual Basic).

Implements

ITask..::.Execute()()()

See Also

VssHistory Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssHistory Properties

[image] [image]

.NET Framework Class Library
VssHistory Properties
VssHistory Class See Also Send Feedback

The VssHistory type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Database | Represents the VSS Database (Inherited from VssBase.)
DatabasePath | The path to the folder that contains the srcsafe.ini file. (Inherited from VssBase.)
FromDate | The End Date for the history.
FromLabel | The label to compare up to.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Item | Represents the VSS item selected (file or project). (Inherited from VssBase.)
Log | (Inherited from Task.)
OutputFile | The name and path of the XML output file.
Password | The password to use to log in to SourceSafe. (Inherited from VssBase.)
Path | The Visual SourceSafe project or file to perform the action on (starts with "$/"). (Inherited from VssBase.)
Recursive | Determines whether to perform the SourceSafe operation recursively. The default is trueTruetruetrue (True in Visual Basic). (Inherited from VssRecursiveBase.)
TaskResources | (Inherited from Task.)
ToDate | The Start Date for the history.
ToLabel | The label to start comparing to.
User | The name of the user whose changes should be listed in the history.
UserName | The name of the user accessing the SourceSafe database. (Inherited from VssBase.)
Version | A version of the Path to reference. (Inherited from VssBase.)

See Also

VssHistory Class
MSBuild.Community.Tasks.SourceSafe Namespace


FromDate Property

[image]

.NET Framework Class Library
VssHistory..::.FromDate Property
VssHistory Class See Also Send Feedback

The End Date for the history.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property FromDate As DateTime
C#
public DateTime FromDate { get; set; }
Visual C++
public:
property DateTime FromDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

VssHistory Class
MSBuild.Community.Tasks.SourceSafe Namespace


FromLabel Property

[image]

.NET Framework Class Library
VssHistory..::.FromLabel Property
VssHistory Class See Also Send Feedback

The label to compare up to.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property FromLabel As String
C#
public string FromLabel { get; set; }
Visual C++
public:
property String^ FromLabel {
    String^ get ();
    void set (String^ value);
}

See Also

VssHistory Class
MSBuild.Community.Tasks.SourceSafe Namespace


OutputFile Property

[image]

.NET Framework Class Library
VssHistory..::.OutputFile Property
VssHistory Class See Also Send Feedback

The name and path of the XML output file.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property OutputFile As String
C#
[RequiredAttribute]
public string OutputFile { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ OutputFile {
    String^ get ();
    void set (String^ value);
}

See Also

VssHistory Class
MSBuild.Community.Tasks.SourceSafe Namespace


ToDate Property

[image]

.NET Framework Class Library
VssHistory..::.ToDate Property
VssHistory Class See Also Send Feedback

The Start Date for the history.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ToDate As DateTime
C#
public DateTime ToDate { get; set; }
Visual C++
public:
property DateTime ToDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

VssHistory Class
MSBuild.Community.Tasks.SourceSafe Namespace


ToLabel Property

[image]

.NET Framework Class Library
VssHistory..::.ToLabel Property
VssHistory Class See Also Send Feedback

The label to start comparing to.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ToLabel As String
C#
public string ToLabel { get; set; }
Visual C++
public:
property String^ ToLabel {
    String^ get ();
    void set (String^ value);
}

See Also

VssHistory Class
MSBuild.Community.Tasks.SourceSafe Namespace


User Property

[image]

.NET Framework Class Library
VssHistory..::.User Property
VssHistory Class See Also Send Feedback

The name of the user whose changes should be listed in the history.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property User As String
C#
public string User { get; set; }
Visual C++
public:
property String^ User {
    String^ get ();
    void set (String^ value);
}

See Also

VssHistory Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssLabel Class

[image]

.NET Framework Class Library
VssLabel Class
Members See Also Send Feedback

Task that applies a label to a Visual SourceSafe item.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class VssLabel _
    Inherits VssRecursiveBase
C#
public class VssLabel : VssRecursiveBase
Visual C++
public ref class VssLabel : public VssRecursiveBase

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.SourceSafe..::.VssBase
MSBuild.Community.Tasks.SourceSafe..::.VssRecursiveBase
MSBuild.Community.Tasks.SourceSafe..::.VssLabel

See Also

VssLabel Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssLabel Members

[image] [image]

.NET Framework Class Library
VssLabel Members
VssLabel Class Constructors Methods Properties See Also Send Feedback

The VssLabel type exposes the following members.

Constructors

Name | Description
VssLabel |

Methods

Name | Description
ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified. (Inherited from VssBase.)
Equals | (Inherited from Object.)
Execute | Executes the task. (Overrides VssRecursiveBase..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
LogErrorFromException | Logs an exception using the MSBuild logging framework. (Inherited from VssBase.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Comment | An optional comment.
Database | Represents the VSS Database (Inherited from VssBase.)
DatabasePath | The path to the folder that contains the srcsafe.ini file. (Inherited from VssBase.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Item | Represents the VSS item selected (file or project). (Inherited from VssBase.)
Label | The text of the label.
Log | (Inherited from Task.)
Password | The password to use to log in to SourceSafe. (Inherited from VssBase.)
Path | The Visual SourceSafe project or file to perform the action on (starts with "$/"). (Inherited from VssBase.)
Recursive | Determines whether to perform the SourceSafe operation recursively. The default is trueTruetruetrue (True in Visual Basic). (Inherited from VssRecursiveBase.)
TaskResources | (Inherited from Task.)
UserName | The name of the user accessing the SourceSafe database. (Inherited from VssBase.)
Version | A version of the Path to reference. (Inherited from VssBase.)

See Also

VssLabel Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssLabel Constructor

[image]

.NET Framework Class Library
VssLabel Constructor
VssLabel Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public VssLabel()
Visual C++
public:
VssLabel()

See Also

VssLabel Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssLabel Methods

[image] [image]

.NET Framework Class Library
VssLabel Methods
VssLabel Class See Also Send Feedback

The VssLabel type exposes the following members.

Methods

Name | Description
ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified. (Inherited from VssBase.)
Equals | (Inherited from Object.)
Execute | Executes the task. (Overrides VssRecursiveBase..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
LogErrorFromException | Logs an exception using the MSBuild logging framework. (Inherited from VssBase.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

VssLabel Class
MSBuild.Community.Tasks.SourceSafe Namespace


Execute Method

[image]

.NET Framework Class Library
VssLabel..::.Execute Method
VssLabel Class See Also Send Feedback

Executes the task.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

trueTruetruetrue (True in Visual Basic) if the task ran successfully; otherwise falseFalsefalsefalse (False in Visual Basic).

Implements

ITask..::.Execute()()()

See Also

VssLabel Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssLabel Properties

[image] [image]

.NET Framework Class Library
VssLabel Properties
VssLabel Class See Also Send Feedback

The VssLabel type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Comment | An optional comment.
Database | Represents the VSS Database (Inherited from VssBase.)
DatabasePath | The path to the folder that contains the srcsafe.ini file. (Inherited from VssBase.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Item | Represents the VSS item selected (file or project). (Inherited from VssBase.)
Label | The text of the label.
Log | (Inherited from Task.)
Password | The password to use to log in to SourceSafe. (Inherited from VssBase.)
Path | The Visual SourceSafe project or file to perform the action on (starts with "$/"). (Inherited from VssBase.)
Recursive | Determines whether to perform the SourceSafe operation recursively. The default is trueTruetruetrue (True in Visual Basic). (Inherited from VssRecursiveBase.)
TaskResources | (Inherited from Task.)
UserName | The name of the user accessing the SourceSafe database. (Inherited from VssBase.)
Version | A version of the Path to reference. (Inherited from VssBase.)

See Also

VssLabel Class
MSBuild.Community.Tasks.SourceSafe Namespace


Comment Property

[image]

.NET Framework Class Library
VssLabel..::.Comment Property
VssLabel Class See Also Send Feedback

An optional comment.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Comment As String
C#
public string Comment { get; set; }
Visual C++
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}

See Also

VssLabel Class
MSBuild.Community.Tasks.SourceSafe Namespace


Label Property

[image]

.NET Framework Class Library
VssLabel..::.Label Property
VssLabel Class See Also Send Feedback

The text of the label.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property Label As String
C#
[RequiredAttribute]
public string Label { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ Label {
    String^ get ();
    void set (String^ value);
}

See Also

VssLabel Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssRecursiveBase Class

[image]

.NET Framework Class Library
VssRecursiveBase Class
Members See Also Send Feedback

Base class for VSS tasks that can act recursively.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class VssRecursiveBase _
    Inherits VssBase
C#
public abstract class VssRecursiveBase : VssBase
Visual C++
public ref class VssRecursiveBase abstract : public VssBase

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.SourceSafe..::.VssBase
MSBuild.Community.Tasks.SourceSafe..::.VssRecursiveBase
MSBuild.Community.Tasks.SourceSafe..::.VssCheckin
MSBuild.Community.Tasks.SourceSafe..::.VssCheckout
MSBuild.Community.Tasks.SourceSafe..::.VssGet
MSBuild.Community.Tasks.SourceSafe..::.VssHistory
MSBuild.Community.Tasks.SourceSafe..::.VssLabel
MSBuild.Community.Tasks.SourceSafe..::.VssUndoCheckout

See Also

VssRecursiveBase Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssRecursiveBase Members

[image] [image]

.NET Framework Class Library
VssRecursiveBase Members
VssRecursiveBase Class Constructors Methods Properties See Also Send Feedback

The VssRecursiveBase type exposes the following members.

Constructors

Name | Description
VssRecursiveBase |

Methods

Name | Description
ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified. (Inherited from VssBase.)
Equals | (Inherited from Object.)
Execute | Reserved. (Overrides VssBase..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
LogErrorFromException | Logs an exception using the MSBuild logging framework. (Inherited from VssBase.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Database | Represents the VSS Database (Inherited from VssBase.)
DatabasePath | The path to the folder that contains the srcsafe.ini file. (Inherited from VssBase.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Item | Represents the VSS item selected (file or project). (Inherited from VssBase.)
Log | (Inherited from Task.)
Password | The password to use to log in to SourceSafe. (Inherited from VssBase.)
Path | The Visual SourceSafe project or file to perform the action on (starts with "$/"). (Inherited from VssBase.)
Recursive | Determines whether to perform the SourceSafe operation recursively. The default is trueTruetruetrue (True in Visual Basic).
TaskResources | (Inherited from Task.)
UserName | The name of the user accessing the SourceSafe database. (Inherited from VssBase.)
Version | A version of the Path to reference. (Inherited from VssBase.)

See Also

VssRecursiveBase Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssRecursiveBase Constructor

[image]

.NET Framework Class Library
VssRecursiveBase Constructor
VssRecursiveBase Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New
C#
protected VssRecursiveBase()
Visual C++
protected:
VssRecursiveBase()

See Also

VssRecursiveBase Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssRecursiveBase Methods

[image] [image]

.NET Framework Class Library
VssRecursiveBase Methods
VssRecursiveBase Class See Also Send Feedback

The VssRecursiveBase type exposes the following members.

Methods

Name | Description
ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified. (Inherited from VssBase.)
Equals | (Inherited from Object.)
Execute | Reserved. (Overrides VssBase..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
LogErrorFromException | Logs an exception using the MSBuild logging framework. (Inherited from VssBase.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

VssRecursiveBase Class
MSBuild.Community.Tasks.SourceSafe Namespace


Execute Method

[image]

.NET Framework Class Library
VssRecursiveBase..::.Execute Method
VssRecursiveBase Class See Also Send Feedback

Reserved.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

Reserved.

Implements

ITask..::.Execute()()()

See Also

VssRecursiveBase Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssRecursiveBase Properties

[image] [image]

.NET Framework Class Library
VssRecursiveBase Properties
VssRecursiveBase Class See Also Send Feedback

The VssRecursiveBase type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Database | Represents the VSS Database (Inherited from VssBase.)
DatabasePath | The path to the folder that contains the srcsafe.ini file. (Inherited from VssBase.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Item | Represents the VSS item selected (file or project). (Inherited from VssBase.)
Log | (Inherited from Task.)
Password | The password to use to log in to SourceSafe. (Inherited from VssBase.)
Path | The Visual SourceSafe project or file to perform the action on (starts with "$/"). (Inherited from VssBase.)
Recursive | Determines whether to perform the SourceSafe operation recursively. The default is trueTruetruetrue (True in Visual Basic).
TaskResources | (Inherited from Task.)
UserName | The name of the user accessing the SourceSafe database. (Inherited from VssBase.)
Version | A version of the Path to reference. (Inherited from VssBase.)

See Also

VssRecursiveBase Class
MSBuild.Community.Tasks.SourceSafe Namespace


Recursive Property

[image]

.NET Framework Class Library
VssRecursiveBase..::.Recursive Property
VssRecursiveBase Class See Also Send Feedback

Determines whether to perform the SourceSafe operation recursively. The default is trueTruetruetrue (True in Visual Basic).

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Recursive As Boolean
C#
public bool Recursive { get; set; }
Visual C++
public:
property bool Recursive {
    bool get ();
    void set (bool value);
}

See Also

VssRecursiveBase Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssUndoCheckout Class

[image]

.NET Framework Class Library
VssUndoCheckout Class
Members Example See Also Send Feedback

Task that undoes a checkout of files or projects against a Visual SourceSafe database.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class VssUndoCheckout _
    Inherits VssRecursiveBase
C#
public class VssUndoCheckout : VssRecursiveBase
Visual C++
public ref class VssUndoCheckout : public VssRecursiveBase

Examples

Copy Code
<VssUndoCheckout UserName="ccnet_build"
              Password="build"
              LocalPath="C:\Dev\MyProjects\Project"
              Recursive="False"
              DatabasePath="\\VSSServer\VSS\srcsafe.ini"
              Path="$/Test/TestFile.cs"
            />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.SourceSafe..::.VssBase
MSBuild.Community.Tasks.SourceSafe..::.VssRecursiveBase
MSBuild.Community.Tasks.SourceSafe..::.VssUndoCheckout

See Also

VssUndoCheckout Members
MSBuild.Community.Tasks.SourceSafe Namespace


VssUndoCheckout Members

[image] [image]

.NET Framework Class Library
VssUndoCheckout Members
VssUndoCheckout Class Constructors Methods Properties See Also Send Feedback

The VssUndoCheckout type exposes the following members.

Constructors

Name | Description
VssUndoCheckout |

Methods

Name | Description
ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified. (Inherited from VssBase.)
Equals | (Inherited from Object.)
Execute | Executes the task. (Overrides VssRecursiveBase..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
LogErrorFromException | Logs an exception using the MSBuild logging framework. (Inherited from VssBase.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Database | Represents the VSS Database (Inherited from VssBase.)
DatabasePath | The path to the folder that contains the srcsafe.ini file. (Inherited from VssBase.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Item | Represents the VSS item selected (file or project). (Inherited from VssBase.)
LocalPath | The path to the local working directory.
Log | (Inherited from Task.)
Password | The password to use to log in to SourceSafe. (Inherited from VssBase.)
Path | The Visual SourceSafe project or file to perform the action on (starts with "$/"). (Inherited from VssBase.)
Recursive | Determines whether to perform the SourceSafe operation recursively. The default is trueTruetruetrue (True in Visual Basic). (Inherited from VssRecursiveBase.)
TaskResources | (Inherited from Task.)
UserName | The name of the user accessing the SourceSafe database. (Inherited from VssBase.)
Version | A version of the Path to reference. (Inherited from VssBase.)

See Also

VssUndoCheckout Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssUndoCheckout Constructor

[image]

.NET Framework Class Library
VssUndoCheckout Constructor
VssUndoCheckout Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public VssUndoCheckout()
Visual C++
public:
VssUndoCheckout()

See Also

VssUndoCheckout Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssUndoCheckout Methods

[image] [image]

.NET Framework Class Library
VssUndoCheckout Methods
VssUndoCheckout Class See Also Send Feedback

The VssUndoCheckout type exposes the following members.

Methods

Name | Description
ConnectToDatabase | Attempts to connect to the SourceSafe Database and load the specified item, or version of the item, if specified. (Inherited from VssBase.)
Equals | (Inherited from Object.)
Execute | Executes the task. (Overrides VssRecursiveBase..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
LogErrorFromException | Logs an exception using the MSBuild logging framework. (Inherited from VssBase.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

VssUndoCheckout Class
MSBuild.Community.Tasks.SourceSafe Namespace


Execute Method

[image]

.NET Framework Class Library
VssUndoCheckout..::.Execute Method
VssUndoCheckout Class See Also Send Feedback

Executes the task.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

trueTruetruetrue (True in Visual Basic) if the task ran successfully; otherwise falseFalsefalsefalse (False in Visual Basic).

Implements

ITask..::.Execute()()()

See Also

VssUndoCheckout Class
MSBuild.Community.Tasks.SourceSafe Namespace


VssUndoCheckout Properties

[image] [image]

.NET Framework Class Library
VssUndoCheckout Properties
VssUndoCheckout Class See Also Send Feedback

The VssUndoCheckout type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Database | Represents the VSS Database (Inherited from VssBase.)
DatabasePath | The path to the folder that contains the srcsafe.ini file. (Inherited from VssBase.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Item | Represents the VSS item selected (file or project). (Inherited from VssBase.)
LocalPath | The path to the local working directory.
Log | (Inherited from Task.)
Password | The password to use to log in to SourceSafe. (Inherited from VssBase.)
Path | The Visual SourceSafe project or file to perform the action on (starts with "$/"). (Inherited from VssBase.)
Recursive | Determines whether to perform the SourceSafe operation recursively. The default is trueTruetruetrue (True in Visual Basic). (Inherited from VssRecursiveBase.)
TaskResources | (Inherited from Task.)
UserName | The name of the user accessing the SourceSafe database. (Inherited from VssBase.)
Version | A version of the Path to reference. (Inherited from VssBase.)

See Also

VssUndoCheckout Class
MSBuild.Community.Tasks.SourceSafe Namespace


LocalPath Property

[image]

.NET Framework Class Library
VssUndoCheckout..::.LocalPath Property
VssUndoCheckout Class See Also Send Feedback

The path to the local working directory.

Namespace: MSBuild.Community.Tasks.SourceSafe
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property LocalPath As String
C#
[RequiredAttribute]
public string LocalPath { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ LocalPath {
    String^ get ();
    void set (String^ value);
}

See Also

VssUndoCheckout Class
MSBuild.Community.Tasks.SourceSafe Namespace


MSBuild.Community.Tasks.SourceServer Namespace

[image]

.NET Framework Class Library
MSBuild.Community.Tasks.SourceServer Namespace
Send Feedback

Classes

Class | Description
FileBase | A base class that has a file.
PdbStr | A task for the pdbstr from source server.
SourceFile | A class representing a source file.
SourceIndexBase | A base class for source indexing a pdb symbol file.
SrcTool | A task for the srctool from source server.
SvnSourceIndex | A subversion source index task.
SymbolFile | A class representing a symbol file.

Enumerations

Enumeration | Description
PdbStrCommands | Commands for the PdbStr tasks.


FileBase Class

[image]

.NET Framework Class Library
FileBase Class
Members See Also Send Feedback

A base class that has a file.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class FileBase
C#
public class FileBase
Visual C++
public ref class FileBase

Inheritance Hierarchy

System..::.Object
MSBuild.Community.Tasks.SourceServer..::.FileBase
MSBuild.Community.Tasks.SourceServer..::.SourceFile
MSBuild.Community.Tasks.SourceServer..::.SymbolFile

See Also

FileBase Members
MSBuild.Community.Tasks.SourceServer Namespace


FileBase Members

[image] [image]

.NET Framework Class Library
FileBase Members
FileBase Class Constructors Methods Properties See Also Send Feedback

The FileBase type exposes the following members.

Constructors

Name | Description
FileBase | Overloaded.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | Returns a String that represents this instance. (Overrides Object..::.ToString()()().)

Operators

Name | Description
Implicit | Performs an implicit conversion from FileBase to String.

Properties

Name | Description
File | Gets or sets the file.

See Also

FileBase Class
MSBuild.Community.Tasks.SourceServer Namespace


FileBase Constructor

[image] [image]

.NET Framework Class Library
FileBase Constructor
FileBase Class See Also Send Feedback

Overload List

Name | Description
FileBase(FileInfo) | Initializes a new instance of the FileBase class.
FileBase(String) | Initializes a new instance of the FileBase class.

See Also

FileBase Class
FileBase Members
MSBuild.Community.Tasks.SourceServer Namespace


FileBase Constructor (FileInfo)

[image]

.NET Framework Class Library
FileBase Constructor (FileInfo)
FileBase Class See Also Send Feedback

Initializes a new instance of the FileBase class.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    fileInfo As FileInfo _
)
C#
public FileBase(
    FileInfo fileInfo
)
Visual C++
public:
FileBase(
    FileInfo^ fileInfo
)

Parameters

fileInfo
Type: System.IO..::.FileInfo
The file info.

See Also

FileBase Class
FileBase Overload
MSBuild.Community.Tasks.SourceServer Namespace


FileBase Constructor (String)

[image]

.NET Framework Class Library
FileBase Constructor (String)
FileBase Class See Also Send Feedback

Initializes a new instance of the FileBase class.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    fileName As String _
)
C#
public FileBase(
    string fileName
)
Visual C++
public:
FileBase(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
Name of the file.

See Also

FileBase Class
FileBase Overload
MSBuild.Community.Tasks.SourceServer Namespace


FileBase Methods

[image] [image]

.NET Framework Class Library
FileBase Methods
FileBase Class See Also Send Feedback

The FileBase type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | Returns a String that represents this instance. (Overrides Object..::.ToString()()().)

Operators

Name | Description
Implicit | Performs an implicit conversion from FileBase to String.

See Also

FileBase Class
MSBuild.Community.Tasks.SourceServer Namespace


Implicit Operator

[image]

.NET Framework Class Library
FileBase..::.Implicit Operator
FileBase Class See Also Send Feedback

Performs an implicit conversion from FileBase to String.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    file As FileBase _
) As String
C#
public static implicit operator string (
    FileBase file
)
Visual C++
static implicit operator String^ (
    FileBase^ file
)

Parameters

file
Type: MSBuild.Community.Tasks.SourceServer..::.FileBase
The output file.

Return Value

The result of the conversion.

See Also

FileBase Class
MSBuild.Community.Tasks.SourceServer Namespace


ToString Method

[image]

.NET Framework Class Library
FileBase..::.ToString Method
FileBase Class See Also Send Feedback

Returns a String that represents this instance.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

Return Value

A String that represents this instance.

See Also

FileBase Class
MSBuild.Community.Tasks.SourceServer Namespace


FileBase Properties

[image] [image]

.NET Framework Class Library
FileBase Properties
FileBase Class See Also Send Feedback

The FileBase type exposes the following members.

Properties

Name | Description
File | Gets or sets the file.

See Also

FileBase Class
MSBuild.Community.Tasks.SourceServer Namespace


File Property

[image]

.NET Framework Class Library
FileBase..::.File Property
FileBase Class See Also Send Feedback

Gets or sets the file.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property File As FileInfo
C#
public FileInfo File { get; private set; }
Visual C++
public:
property FileInfo^ File {
    FileInfo^ get ();
    void set (FileInfo^ value);
}

Field Value

The file.

See Also

FileBase Class
MSBuild.Community.Tasks.SourceServer Namespace


PdbStr Class

[image]

.NET Framework Class Library
PdbStr Class
Members See Also Send Feedback

A task for the pdbstr from source server.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class PdbStr _
    Inherits ToolTask
C#
public class PdbStr : ToolTask
Visual C++
public ref class PdbStr : public ToolTask

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
Microsoft.Build.Utilities..::.ToolTask
MSBuild.Community.Tasks.SourceServer..::.PdbStr

See Also

PdbStr Members
MSBuild.Community.Tasks.SourceServer Namespace


PdbStr Members

[image] [image]

.NET Framework Class Library
PdbStr Members
PdbStr Class Constructors Methods Properties See Also Send Feedback

The PdbStr type exposes the following members.

Constructors

Name | Description
PdbStr |

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from ToolTask.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | (Inherited from ToolTask.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | (Inherited from ToolTask.)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Command | Gets or sets the command.
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
PdbFile | Gets or sets the PDB file.
ResponseFileEncoding | (Inherited from ToolTask.)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | (Inherited from ToolTask.)
StreamFile | Gets or sets the stream file.
StreamName | Gets or sets the name of the stream.
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)

See Also

PdbStr Class
MSBuild.Community.Tasks.SourceServer Namespace


PdbStr Constructor

[image]

.NET Framework Class Library
PdbStr Constructor
PdbStr Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PdbStr()
Visual C++
public:
PdbStr()

See Also

PdbStr Class
MSBuild.Community.Tasks.SourceServer Namespace


PdbStr Methods

[image] [image]

.NET Framework Class Library
PdbStr Methods
PdbStr Class See Also Send Feedback

The PdbStr type exposes the following members.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from ToolTask.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | (Inherited from ToolTask.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | (Inherited from ToolTask.)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

See Also

PdbStr Class
MSBuild.Community.Tasks.SourceServer Namespace


GenerateCommandLineCommands Method

[image]

.NET Framework Class Library
PdbStr..::.GenerateCommandLineCommands Method
PdbStr Class See Also Send Feedback

Returns a string value containing the command line arguments to pass directly to the executable file.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateCommandLineCommands As String
C#
protected override string GenerateCommandLineCommands()
Visual C++
protected:
virtual String^ GenerateCommandLineCommands() override

Return Value

A string value containing the command line arguments to pass directly to the executable file.

See Also

PdbStr Class
MSBuild.Community.Tasks.SourceServer Namespace


GenerateFullPathToTool Method

[image]

.NET Framework Class Library
PdbStr..::.GenerateFullPathToTool Method
PdbStr Class See Also Send Feedback

Returns the fully qualified path to the executable file.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateFullPathToTool As String
C#
protected override string GenerateFullPathToTool()
Visual C++
protected:
virtual String^ GenerateFullPathToTool() override

Return Value

The fully qualified path to the executable file.

See Also

PdbStr Class
MSBuild.Community.Tasks.SourceServer Namespace


PdbStr Properties

[image] [image]

.NET Framework Class Library
PdbStr Properties
PdbStr Class See Also Send Feedback

The PdbStr type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Command | Gets or sets the command.
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
PdbFile | Gets or sets the PDB file.
ResponseFileEncoding | (Inherited from ToolTask.)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | (Inherited from ToolTask.)
StreamFile | Gets or sets the stream file.
StreamName | Gets or sets the name of the stream.
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)

See Also

PdbStr Class
MSBuild.Community.Tasks.SourceServer Namespace


Command Property

[image]

.NET Framework Class Library
PdbStr..::.Command Property
PdbStr Class See Also Send Feedback

Gets or sets the command.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Command As String
C#
public string Command { get; set; }
Visual C++
public:
property String^ Command {
    String^ get ();
    void set (String^ value);
}

Field Value

The command.

See Also

PdbStr Class
MSBuild.Community.Tasks.SourceServer Namespace


PdbFile Property

[image]

.NET Framework Class Library
PdbStr..::.PdbFile Property
PdbStr Class See Also Send Feedback

Gets or sets the PDB file.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property PdbFile As ITaskItem
C#
public ITaskItem PdbFile { get; set; }
Visual C++
public:
property ITaskItem^ PdbFile {
    ITaskItem^ get ();
    void set (ITaskItem^ value);
}

Field Value

The PDB file.

See Also

PdbStr Class
MSBuild.Community.Tasks.SourceServer Namespace


StreamFile Property

[image]

.NET Framework Class Library
PdbStr..::.StreamFile Property
PdbStr Class See Also Send Feedback

Gets or sets the stream file.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property StreamFile As ITaskItem
C#
public ITaskItem StreamFile { get; set; }
Visual C++
public:
property ITaskItem^ StreamFile {
    ITaskItem^ get ();
    void set (ITaskItem^ value);
}

Field Value

The stream file.

See Also

PdbStr Class
MSBuild.Community.Tasks.SourceServer Namespace


StreamName Property

[image]

.NET Framework Class Library
PdbStr..::.StreamName Property
PdbStr Class See Also Send Feedback

Gets or sets the name of the stream.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property StreamName As String
C#
public string StreamName { get; set; }
Visual C++
public:
property String^ StreamName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the stream.

See Also

PdbStr Class
MSBuild.Community.Tasks.SourceServer Namespace


ToolName Property

[image]

.NET Framework Class Library
PdbStr..::.ToolName Property
PdbStr Class See Also Send Feedback

Gets the name of the executable file to run.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ToolName As String
C#
protected override string ToolName { get; }
Visual C++
protected:
virtual property String^ ToolName {
    String^ get () override;
}

Field Value

Return Value

The name of the executable file to run.

See Also

PdbStr Class
MSBuild.Community.Tasks.SourceServer Namespace


PdbStrCommands Enumeration

[image]

.NET Framework Class Library
PdbStrCommands Enumeration
See Also Send Feedback

Commands for the PdbStr tasks.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration PdbStrCommands
C#
public enum PdbStrCommands
Visual C++
public enum class PdbStrCommands

Members

Member name | Description
read | Read stream from pdb symbol file.
write | Write stream to pdb symbol file.

See Also

MSBuild.Community.Tasks.SourceServer Namespace


SourceFile Class

[image]

.NET Framework Class Library
SourceFile Class
Members See Also Send Feedback

A class representing a source file.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class SourceFile _
    Inherits FileBase
C#
public class SourceFile : FileBase
Visual C++
public ref class SourceFile : public FileBase

Inheritance Hierarchy

System..::.Object
MSBuild.Community.Tasks.SourceServer..::.FileBase
MSBuild.Community.Tasks.SourceServer..::.SourceFile

See Also

SourceFile Members
MSBuild.Community.Tasks.SourceServer Namespace


SourceFile Members

[image] [image]

.NET Framework Class Library
SourceFile Members
SourceFile Class Constructors Methods Properties See Also Send Feedback

The SourceFile type exposes the following members.

Constructors

Name | Description
SourceFile | Overloaded.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToSourceString | Creates the source string.
ToString | Returns a String that represents this instance. (Inherited from FileBase.)

Properties

Name | Description
File | Gets or sets the file. (Inherited from FileBase.)
IsResolved | Gets or sets a value indicating whether this instance is resolved.
Properties | Gets or sets the properties.

See Also

SourceFile Class
MSBuild.Community.Tasks.SourceServer Namespace


SourceFile Constructor

[image] [image]

.NET Framework Class Library
SourceFile Constructor
SourceFile Class See Also Send Feedback

Overload List

Name | Description
SourceFile(FileInfo) | Initializes a new instance of the SourceFile class.
SourceFile(String) | Initializes a new instance of the SourceFile class.

See Also

SourceFile Class
SourceFile Members
MSBuild.Community.Tasks.SourceServer Namespace


SourceFile Constructor (FileInfo)

[image]

.NET Framework Class Library
SourceFile Constructor (FileInfo)
SourceFile Class See Also Send Feedback

Initializes a new instance of the SourceFile class.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    fileInfo As FileInfo _
)
C#
public SourceFile(
    FileInfo fileInfo
)
Visual C++
public:
SourceFile(
    FileInfo^ fileInfo
)

Parameters

fileInfo
Type: System.IO..::.FileInfo
The file info.

See Also

SourceFile Class
SourceFile Overload
MSBuild.Community.Tasks.SourceServer Namespace


SourceFile Constructor (String)

[image]

.NET Framework Class Library
SourceFile Constructor (String)
SourceFile Class See Also Send Feedback

Initializes a new instance of the SourceFile class.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    fileName As String _
)
C#
public SourceFile(
    string fileName
)
Visual C++
public:
SourceFile(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
Name of the file.

See Also

SourceFile Class
SourceFile Overload
MSBuild.Community.Tasks.SourceServer Namespace


SourceFile Methods

[image] [image]

.NET Framework Class Library
SourceFile Methods
SourceFile Class See Also Send Feedback

The SourceFile type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToSourceString | Creates the source string.
ToString | Returns a String that represents this instance. (Inherited from FileBase.)

See Also

SourceFile Class
MSBuild.Community.Tasks.SourceServer Namespace


ToSourceString Method

[image]

.NET Framework Class Library
SourceFile..::.ToSourceString Method
SourceFile Class See Also Send Feedback

Creates the source string.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Function ToSourceString ( _
    format As String _
) As String
C#
public string ToSourceString(
    string format
)
Visual C++
public:
String^ ToSourceString(
    String^ format
)

Parameters

format
Type: System..::.String
The format.

Return Value

See Also

SourceFile Class
MSBuild.Community.Tasks.SourceServer Namespace


SourceFile Properties

[image] [image]

.NET Framework Class Library
SourceFile Properties
SourceFile Class See Also Send Feedback

The SourceFile type exposes the following members.

Properties

Name | Description
File | Gets or sets the file. (Inherited from FileBase.)
IsResolved | Gets or sets a value indicating whether this instance is resolved.
Properties | Gets or sets the properties.

See Also

SourceFile Class
MSBuild.Community.Tasks.SourceServer Namespace


IsResolved Property

[image]

.NET Framework Class Library
SourceFile..::.IsResolved Property
SourceFile Class See Also Send Feedback

Gets or sets a value indicating whether this instance is resolved.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property IsResolved As Boolean
C#
public bool IsResolved { get; set; }
Visual C++
public:
property bool IsResolved {
    bool get ();
    void set (bool value);
}

Field Value

true if this instance is resolved; otherwise, false.

See Also

SourceFile Class
MSBuild.Community.Tasks.SourceServer Namespace


Properties Property

[image]

.NET Framework Class Library
SourceFile..::.Properties Property
SourceFile Class See Also Send Feedback

Gets or sets the properties.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Properties As IDictionary(Of String, Object)
C#
public IDictionary<string, Object> Properties { get; private set; }
Visual C++
public:
property IDictionary<String^, Object^>^ Properties {
    IDictionary<String^, Object^>^ get ();
    void set (IDictionary<String^, Object^>^ value);
}

Field Value

The properties.

See Also

SourceFile Class
MSBuild.Community.Tasks.SourceServer Namespace


SourceIndexBase Class

[image]

.NET Framework Class Library
SourceIndexBase Class
Members See Also Send Feedback

A base class for source indexing a pdb symbol file.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class SourceIndexBase _
    Inherits Task
C#
public abstract class SourceIndexBase : Task
Visual C++
public ref class SourceIndexBase abstract : public Task

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.SourceServer..::.SourceIndexBase
MSBuild.Community.Tasks.SourceServer..::.SvnSourceIndex

See Also

SourceIndexBase Members
MSBuild.Community.Tasks.SourceServer Namespace


SourceIndexBase Members

[image] [image]

.NET Framework Class Library
SourceIndexBase Members
SourceIndexBase Class Constructors Methods Fields Properties See Also Send Feedback

The SourceIndexBase type exposes the following members.

Constructors

Name | Description
SourceIndexBase |

Methods

Name | Description
AddSourceProperties | Adds the source properties to the symbol file.
CopyBuildEngine | Copies the build engine to the task.
CreateSourceIndexFile | Creates the source index file.
CreateSymbolFile | Creates an instance of SymbolFile from the symbol file task item and add the source file list to it.
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
IndexSymbolFile | Indexes the symbol file.
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)
WriteSourceIndex | Writes the source index file to the symbol file.

Fields

Name | Description
Failed |
Skipped |
Successful |

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
SourceCommandFormat | Gets or sets the source command format. The SRCSRVCMD environment variable.
SourceServerName | Gets or sets the name of the source server.
SourceServerSdkPath | Gets or sets the source server SDK path.
SourceTargetFormat | Gets or sets the source target format. The SRCSRVTRG environment variable.
SymbolFiles | Gets or sets the symbol files to have to source index added.
TaskResources | (Inherited from Task.)

See Also

SourceIndexBase Class
MSBuild.Community.Tasks.SourceServer Namespace


SourceIndexBase Constructor

[image]

.NET Framework Class Library
SourceIndexBase Constructor
SourceIndexBase Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New
C#
protected SourceIndexBase()
Visual C++
protected:
SourceIndexBase()

See Also

SourceIndexBase Class
MSBuild.Community.Tasks.SourceServer Namespace


SourceIndexBase Fields

[image] [image]

.NET Framework Class Library
SourceIndexBase Fields
SourceIndexBase Class See Also Send Feedback

The SourceIndexBase type exposes the following members.

Fields

Name | Description
Failed |
Skipped |
Successful |

See Also

SourceIndexBase Class
MSBuild.Community.Tasks.SourceServer Namespace


Failed Field

[image]

.NET Framework Class Library
SourceIndexBase..::.Failed Field
SourceIndexBase Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Failed As Integer
C#
protected int Failed
Visual C++
protected:
int Failed

Remarks

See Also

SourceIndexBase Class
MSBuild.Community.Tasks.SourceServer Namespace


Skipped Field

[image]

.NET Framework Class Library
SourceIndexBase..::.Skipped Field
SourceIndexBase Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Skipped As Integer
C#
protected int Skipped
Visual C++
protected:
int Skipped

Remarks

See Also

SourceIndexBase Class
MSBuild.Community.Tasks.SourceServer Namespace


Successful Field

[image]

.NET Framework Class Library
SourceIndexBase..::.Successful Field
SourceIndexBase Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Successful As Integer
C#
protected int Successful
Visual C++
protected:
int Successful

Remarks

See Also

SourceIndexBase Class
MSBuild.Community.Tasks.SourceServer Namespace


SourceIndexBase Methods

[image] [image]

.NET Framework Class Library
SourceIndexBase Methods
SourceIndexBase Class See Also Send Feedback

The SourceIndexBase type exposes the following members.

Methods

Name | Description
AddSourceProperties | Adds the source properties to the symbol file.
CopyBuildEngine | Copies the build engine to the task.
CreateSourceIndexFile | Creates the source index file.
CreateSymbolFile | Creates an instance of SymbolFile from the symbol file task item and add the source file list to it.
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
IndexSymbolFile | Indexes the symbol file.
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)
WriteSourceIndex | Writes the source index file to the symbol file.

See Also

SourceIndexBase Class
MSBuild.Community.Tasks.SourceServer Namespace


AddSourceProperties Method

[image]

.NET Framework Class Library
SourceIndexBase..::.AddSourceProperties Method
SourceIndexBase Class See Also Send Feedback

Adds the source properties to the symbol file.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function AddSourceProperties ( _
    symbolFile As SymbolFile _
) As Boolean
C#
protected abstract bool AddSourceProperties(
    SymbolFile symbolFile
)
Visual C++
protected:
virtual bool AddSourceProperties(
    SymbolFile^ symbolFile
) abstract

Parameters

symbolFile
Type: MSBuild.Community.Tasks.SourceServer..::.SymbolFile
The symbol file to add the source properties to.

Return Value

true if successful; otherwise false.

See Also

SourceIndexBase Class
MSBuild.Community.Tasks.SourceServer Namespace


CopyBuildEngine Method

[image]

.NET Framework Class Library
SourceIndexBase..::.CopyBuildEngine Method
SourceIndexBase Class See Also Send Feedback

Copies the build engine to the task.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Sub CopyBuildEngine ( _
    task As ITask _
)
C#
protected void CopyBuildEngine(
    ITask task
)
Visual C++
protected:
void CopyBuildEngine(
    ITask^ task
)

Parameters

task
Type: Microsoft.Build.Framework..::.ITask
The task.

See Also

SourceIndexBase Class
MSBuild.Community.Tasks.SourceServer Namespace


CreateSourceIndexFile Method

[image]

.NET Framework Class Library
SourceIndexBase..::.CreateSourceIndexFile Method
SourceIndexBase Class See Also Send Feedback

Creates the source index file.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function CreateSourceIndexFile ( _
    symbolFile As SymbolFile, _
    sourceIndexFile As String _
) As Boolean
C#
protected abstract bool CreateSourceIndexFile(
    SymbolFile symbolFile,
    string sourceIndexFile
)
Visual C++
protected:
virtual bool CreateSourceIndexFile(
    SymbolFile^ symbolFile,
    String^ sourceIndexFile
) abstract

Parameters

symbolFile
Type: MSBuild.Community.Tasks.SourceServer..::.SymbolFile
The symbol file to create the index file from.
sourceIndexFile
Type: System..::.String
The source index file.

Return Value

true if successful; otherwise false.

See Also

SourceIndexBase Class
MSBuild.Community.Tasks.SourceServer Namespace


CreateSymbolFile Method

[image]

.NET Framework Class Library
SourceIndexBase..::.CreateSymbolFile Method
SourceIndexBase Class See Also Send Feedback

Creates an instance of SymbolFile from the symbol file task item and add the source file list to it.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateSymbolFile ( _
    item As ITaskItem _
) As SymbolFile
C#
protected virtual SymbolFile CreateSymbolFile(
    ITaskItem item
)
Visual C++
protected:
virtual SymbolFile^ CreateSymbolFile(
    ITaskItem^ item
)

Parameters

item
Type: Microsoft.Build.Framework..::.ITaskItem
The symbol file task item.

Return Value

An instance of SymbolFile or null if there was an error.

See Also

SourceIndexBase Class
MSBuild.Community.Tasks.SourceServer Namespace


Execute Method

[image]

.NET Framework Class Library
SourceIndexBase..::.Execute Method
SourceIndexBase Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

SourceIndexBase Class
MSBuild.Community.Tasks.SourceServer Namespace


IndexSymbolFile Method

[image]

.NET Framework Class Library
SourceIndexBase..::.IndexSymbolFile Method
SourceIndexBase Class See Also Send Feedback

Indexes the symbol file.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Function IndexSymbolFile ( _
    item As ITaskItem _
) As Boolean
C#
protected bool IndexSymbolFile(
    ITaskItem item
)
Visual C++
protected:
bool IndexSymbolFile(
    ITaskItem^ item
)

Parameters

item
Type: Microsoft.Build.Framework..::.ITaskItem
The symbol file task item.

Return Value

true if index successfully; otherwise false.

See Also

SourceIndexBase Class
MSBuild.Community.Tasks.SourceServer Namespace


WriteSourceIndex Method

[image]

.NET Framework Class Library
SourceIndexBase..::.WriteSourceIndex Method
SourceIndexBase Class See Also Send Feedback

Writes the source index file to the symbol file.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function WriteSourceIndex ( _
    symbolFile As SymbolFile, _
    sourceIndexFile As String _
) As Boolean
C#
protected virtual bool WriteSourceIndex(
    SymbolFile symbolFile,
    string sourceIndexFile
)
Visual C++
protected:
virtual bool WriteSourceIndex(
    SymbolFile^ symbolFile,
    String^ sourceIndexFile
)

Parameters

symbolFile
Type: MSBuild.Community.Tasks.SourceServer..::.SymbolFile
The symbol file.
sourceIndexFile
Type: System..::.String
The source index file.

Return Value

true if successful; otherwise false.

See Also

SourceIndexBase Class
MSBuild.Community.Tasks.SourceServer Namespace


SourceIndexBase Properties

[image] [image]

.NET Framework Class Library
SourceIndexBase Properties
SourceIndexBase Class See Also Send Feedback

The SourceIndexBase type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
SourceCommandFormat | Gets or sets the source command format. The SRCSRVCMD environment variable.
SourceServerName | Gets or sets the name of the source server.
SourceServerSdkPath | Gets or sets the source server SDK path.
SourceTargetFormat | Gets or sets the source target format. The SRCSRVTRG environment variable.
SymbolFiles | Gets or sets the symbol files to have to source index added.
TaskResources | (Inherited from Task.)

See Also

SourceIndexBase Class
MSBuild.Community.Tasks.SourceServer Namespace


SourceCommandFormat Property

[image]

.NET Framework Class Library
SourceIndexBase..::.SourceCommandFormat Property
SourceIndexBase Class See Also Send Feedback

Gets or sets the source command format. The SRCSRVCMD environment variable.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property SourceCommandFormat As String
C#
public string SourceCommandFormat { get; set; }
Visual C++
public:
property String^ SourceCommandFormat {
    String^ get ();
    void set (String^ value);
}

Field Value

The source command format.

Remarks

Describes how to build the command to extract the file from source control. This includes the name of the executable file and its command-line parameters. See srcsrv.doc for full documentation on SRCSRVCMD.

See Also

SourceIndexBase Class
MSBuild.Community.Tasks.SourceServer Namespace


SourceServerName Property

[image]

.NET Framework Class Library
SourceIndexBase..::.SourceServerName Property
SourceIndexBase Class See Also Send Feedback

Gets or sets the name of the source server.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property SourceServerName As String
C#
[RequiredAttribute]
public string SourceServerName { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ SourceServerName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the source server.

See Also

SourceIndexBase Class
MSBuild.Community.Tasks.SourceServer Namespace


SourceServerSdkPath Property

[image]

.NET Framework Class Library
SourceIndexBase..::.SourceServerSdkPath Property
SourceIndexBase Class See Also Send Feedback

Gets or sets the source server SDK path.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property SourceServerSdkPath As String
C#
public string SourceServerSdkPath { get; set; }
Visual C++
public:
property String^ SourceServerSdkPath {
    String^ get ();
    void set (String^ value);
}

Field Value

The source server SDK path.

See Also

SourceIndexBase Class
MSBuild.Community.Tasks.SourceServer Namespace


SourceTargetFormat Property

[image]

.NET Framework Class Library
SourceIndexBase..::.SourceTargetFormat Property
SourceIndexBase Class See Also Send Feedback

Gets or sets the source target format. The SRCSRVTRG environment variable.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property SourceTargetFormat As String
C#
public string SourceTargetFormat { get; set; }
Visual C++
public:
property String^ SourceTargetFormat {
    String^ get ();
    void set (String^ value);
}

Field Value

The source target format.

Remarks

Describes how to build the target path for the extracted file. See srcsrv.doc for full documentation on SRCSRVTRG.

See Also

SourceIndexBase Class
MSBuild.Community.Tasks.SourceServer Namespace


SymbolFiles Property

[image]

.NET Framework Class Library
SourceIndexBase..::.SymbolFiles Property
SourceIndexBase Class See Also Send Feedback

Gets or sets the symbol files to have to source index added.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property SymbolFiles As ITaskItem()
C#
[RequiredAttribute]
public ITaskItem[] SymbolFiles { get; set; }
Visual C++
[RequiredAttribute]
public:
property array<ITaskItem^>^ SymbolFiles {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

Field Value

The symbol files.

See Also

SourceIndexBase Class
MSBuild.Community.Tasks.SourceServer Namespace


SrcTool Class

[image]

.NET Framework Class Library
SrcTool Class
Members See Also Send Feedback

A task for the srctool from source server.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class SrcTool _
    Inherits ToolTask
C#
public class SrcTool : ToolTask
Visual C++
public ref class SrcTool : public ToolTask

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
Microsoft.Build.Utilities..::.ToolTask
MSBuild.Community.Tasks.SourceServer..::.SrcTool

See Also

SrcTool Members
MSBuild.Community.Tasks.SourceServer Namespace


SrcTool Members

[image] [image]

.NET Framework Class Library
SrcTool Members
SrcTool Class Constructors Methods Properties See Also Send Feedback

The SrcTool type exposes the following members.

Constructors

Name | Description
SrcTool |

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from ToolTask.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (Overrides ToolTask..::.HandleTaskExecutionErrors()()().)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | Parses a single line of text to identify any errors or warnings in canonical format. (Overrides ToolTask..::.LogEventsFromTextOutput(String, MessageImportance).)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Overrides ToolTask..::.LogToolCommand(String).)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
CountOnly | Gets or sets a value indicating whether to get the count of indexed files. The -c switch.
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
Extract | Gets or sets a value indicating whether to extracts the files, instead of simply listing them. The -x switch.
ExtractDirectory | Gets or sets the directory to extract to. The -d switch.
ExtractedFiles | Gets the extracted files. Populated when Extract is true.
Filter | Gets or sets the filter to only source files that match this regular expression. The -l switch.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
PdbFile | Gets or sets the PDB file.
ResponseFileEncoding | (Inherited from ToolTask.)
SourceCount | Gets or sets the number of source files.
SourceFiles | Gets the source files. Populated when SourceOnly is true.
SourceOnly | Gets or sets a value indicating whether to dumps raw source data from the PDB. The -r switch.
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Overrides ToolTask..::.StandardOutputLoggingImportance.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)

See Also

SrcTool Class
MSBuild.Community.Tasks.SourceServer Namespace


SrcTool Constructor

[image]

.NET Framework Class Library
SrcTool Constructor
SrcTool Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SrcTool()
Visual C++
public:
SrcTool()

See Also

SrcTool Class
MSBuild.Community.Tasks.SourceServer Namespace


SrcTool Methods

[image] [image]

.NET Framework Class Library
SrcTool Methods
SrcTool Class See Also Send Feedback

The SrcTool type exposes the following members.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from ToolTask.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | Handles execution errors raised by the executable file. (Overrides ToolTask..::.HandleTaskExecutionErrors()()().)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | Parses a single line of text to identify any errors or warnings in canonical format. (Overrides ToolTask..::.LogEventsFromTextOutput(String, MessageImportance).)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Overrides ToolTask..::.LogToolCommand(String).)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

See Also

SrcTool Class
MSBuild.Community.Tasks.SourceServer Namespace


GenerateCommandLineCommands Method

[image]

.NET Framework Class Library
SrcTool..::.GenerateCommandLineCommands Method
SrcTool Class See Also Send Feedback

Returns a string value containing the command line arguments to pass directly to the executable file.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateCommandLineCommands As String
C#
protected override string GenerateCommandLineCommands()
Visual C++
protected:
virtual String^ GenerateCommandLineCommands() override

Return Value

A string value containing the command line arguments to pass directly to the executable file.

See Also

SrcTool Class
MSBuild.Community.Tasks.SourceServer Namespace


GenerateFullPathToTool Method

[image]

.NET Framework Class Library
SrcTool..::.GenerateFullPathToTool Method
SrcTool Class See Also Send Feedback

Returns the fully qualified path to the executable file.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateFullPathToTool As String
C#
protected override string GenerateFullPathToTool()
Visual C++
protected:
virtual String^ GenerateFullPathToTool() override

Return Value

The fully qualified path to the executable file.

See Also

SrcTool Class
MSBuild.Community.Tasks.SourceServer Namespace


HandleTaskExecutionErrors Method

[image]

.NET Framework Class Library
SrcTool..::.HandleTaskExecutionErrors Method
SrcTool Class See Also Send Feedback

Handles execution errors raised by the executable file.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function HandleTaskExecutionErrors As Boolean
C#
protected override bool HandleTaskExecutionErrors()
Visual C++
protected:
virtual bool HandleTaskExecutionErrors() override

Return Value

true if the method runs successfully; otherwise, false.

See Also

SrcTool Class
MSBuild.Community.Tasks.SourceServer Namespace


LogEventsFromTextOutput Method

[image]

.NET Framework Class Library
SrcTool..::.LogEventsFromTextOutput Method
SrcTool Class See Also Send Feedback

Parses a single line of text to identify any errors or warnings in canonical format.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub LogEventsFromTextOutput ( _
    singleLine As String, _
    messageImportance As MessageImportance _
)
C#
protected override void LogEventsFromTextOutput(
    string singleLine,
    MessageImportance messageImportance
)
Visual C++
protected:
virtual void LogEventsFromTextOutput(
    String^ singleLine,
    MessageImportance messageImportance
) override

Parameters

singleLine
Type: System..::.String
A single line of text for the method to parse.
messageImportance
Type: Microsoft.Build.Framework..::.MessageImportance
A value of MessageImportance that indicates the importance level with which to log the message.

See Also

SrcTool Class
MSBuild.Community.Tasks.SourceServer Namespace


LogToolCommand Method

[image]

.NET Framework Class Library
SrcTool..::.LogToolCommand Method
SrcTool Class See Also Send Feedback

Logs the starting point of the run to all registered loggers.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub LogToolCommand ( _
    message As String _
)
C#
protected override void LogToolCommand(
    string message
)
Visual C++
protected:
virtual void LogToolCommand(
    String^ message
) override

Parameters

message
Type: System..::.String
A descriptive message to provide loggers, usually the command line and switches.

See Also

SrcTool Class
MSBuild.Community.Tasks.SourceServer Namespace


SrcTool Properties

[image] [image]

.NET Framework Class Library
SrcTool Properties
SrcTool Class See Also Send Feedback

The SrcTool type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
CountOnly | Gets or sets a value indicating whether to get the count of indexed files. The -c switch.
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
Extract | Gets or sets a value indicating whether to extracts the files, instead of simply listing them. The -x switch.
ExtractDirectory | Gets or sets the directory to extract to. The -d switch.
ExtractedFiles | Gets the extracted files. Populated when Extract is true.
Filter | Gets or sets the filter to only source files that match this regular expression. The -l switch.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
PdbFile | Gets or sets the PDB file.
ResponseFileEncoding | (Inherited from ToolTask.)
SourceCount | Gets or sets the number of source files.
SourceFiles | Gets the source files. Populated when SourceOnly is true.
SourceOnly | Gets or sets a value indicating whether to dumps raw source data from the PDB. The -r switch.
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Overrides ToolTask..::.StandardOutputLoggingImportance.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)

See Also

SrcTool Class
MSBuild.Community.Tasks.SourceServer Namespace


CountOnly Property

[image]

.NET Framework Class Library
SrcTool..::.CountOnly Property
SrcTool Class See Also Send Feedback

Gets or sets a value indicating whether to get the count of indexed files. The -c switch.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property CountOnly As Boolean
C#
public bool CountOnly { get; set; }
Visual C++
public:
property bool CountOnly {
    bool get ();
    void set (bool value);
}

Field Value

true if count only; otherwise, false.

See Also

SrcTool Class
MSBuild.Community.Tasks.SourceServer Namespace


Extract Property

[image]

.NET Framework Class Library
SrcTool..::.Extract Property
SrcTool Class See Also Send Feedback

Gets or sets a value indicating whether to extracts the files, instead of simply listing them. The -x switch.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Extract As Boolean
C#
public bool Extract { get; set; }
Visual C++
public:
property bool Extract {
    bool get ();
    void set (bool value);
}

Field Value

true if extract; otherwise, false.

See Also

SrcTool Class
MSBuild.Community.Tasks.SourceServer Namespace


ExtractDirectory Property

[image]

.NET Framework Class Library
SrcTool..::.ExtractDirectory Property
SrcTool Class See Also Send Feedback

Gets or sets the directory to extract to. The -d switch.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtractDirectory As String
C#
public string ExtractDirectory { get; set; }
Visual C++
public:
property String^ ExtractDirectory {
    String^ get ();
    void set (String^ value);
}

Field Value

The extract directory.

See Also

SrcTool Class
MSBuild.Community.Tasks.SourceServer Namespace


ExtractedFiles Property

[image]

.NET Framework Class Library
SrcTool..::.ExtractedFiles Property
SrcTool Class See Also Send Feedback

Gets the extracted files. Populated when Extract is true.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property ExtractedFiles As String()
C#
[OutputAttribute]
public string[] ExtractedFiles { get; }
Visual C++
[OutputAttribute]
public:
property array<String^>^ ExtractedFiles {
    array<String^>^ get ();
}

Field Value

The extracted files.

See Also

SrcTool Class
MSBuild.Community.Tasks.SourceServer Namespace


Filter Property

[image]

.NET Framework Class Library
SrcTool..::.Filter Property
SrcTool Class See Also Send Feedback

Gets or sets the filter to only source files that match this regular expression. The -l switch.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Filter As String
C#
public string Filter { get; set; }
Visual C++
public:
property String^ Filter {
    String^ get ();
    void set (String^ value);
}

Field Value

The filter regular expression.

See Also

SrcTool Class
MSBuild.Community.Tasks.SourceServer Namespace


PdbFile Property

[image]

.NET Framework Class Library
SrcTool..::.PdbFile Property
SrcTool Class See Also Send Feedback

Gets or sets the PDB file.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property PdbFile As ITaskItem
C#
public ITaskItem PdbFile { get; set; }
Visual C++
public:
property ITaskItem^ PdbFile {
    ITaskItem^ get ();
    void set (ITaskItem^ value);
}

Field Value

The PDB file.

See Also

SrcTool Class
MSBuild.Community.Tasks.SourceServer Namespace


SourceCount Property

[image]

.NET Framework Class Library
SrcTool..::.SourceCount Property
SrcTool Class See Also Send Feedback

Gets or sets the number of source files.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public Property SourceCount As Integer
C#
[OutputAttribute]
public int SourceCount { get; set; }
Visual C++
[OutputAttribute]
public:
property int SourceCount {
    int get ();
    void set (int value);
}

Field Value

The number of source files.

See Also

SrcTool Class
MSBuild.Community.Tasks.SourceServer Namespace


SourceFiles Property

[image]

.NET Framework Class Library
SrcTool..::.SourceFiles Property
SrcTool Class See Also Send Feedback

Gets the source files. Populated when SourceOnly is true.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property SourceFiles As String()
C#
[OutputAttribute]
public string[] SourceFiles { get; }
Visual C++
[OutputAttribute]
public:
property array<String^>^ SourceFiles {
    array<String^>^ get ();
}

Field Value

The source files.

See Also

SrcTool Class
MSBuild.Community.Tasks.SourceServer Namespace


SourceOnly Property

[image]

.NET Framework Class Library
SrcTool..::.SourceOnly Property
SrcTool Class See Also Send Feedback

Gets or sets a value indicating whether to dumps raw source data from the PDB. The -r switch.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property SourceOnly As Boolean
C#
public bool SourceOnly { get; set; }
Visual C++
public:
property bool SourceOnly {
    bool get ();
    void set (bool value);
}

Field Value

true if source only; otherwise, false.

See Also

SrcTool Class
MSBuild.Community.Tasks.SourceServer Namespace


StandardOutputLoggingImportance Property

[image]

.NET Framework Class Library
SrcTool..::.StandardOutputLoggingImportance Property
SrcTool Class See Also Send Feedback

Gets the MessageImportance with which to log errors.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property StandardOutputLoggingImportance As MessageImportance
C#
protected override MessageImportance StandardOutputLoggingImportance { get; }
Visual C++
protected:
virtual property MessageImportance StandardOutputLoggingImportance {
    MessageImportance get () override;
}

Field Value

Return Value

The MessageImportance with which to log errors.

See Also

SrcTool Class
MSBuild.Community.Tasks.SourceServer Namespace


ToolName Property

[image]

.NET Framework Class Library
SrcTool..::.ToolName Property
SrcTool Class See Also Send Feedback

Gets the name of the executable file to run.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ToolName As String
C#
protected override string ToolName { get; }
Visual C++
protected:
virtual property String^ ToolName {
    String^ get () override;
}

Field Value

Return Value

The name of the executable file to run.

See Also

SrcTool Class
MSBuild.Community.Tasks.SourceServer Namespace


SvnSourceIndex Class

[image]

.NET Framework Class Library
SvnSourceIndex Class
Members See Also Send Feedback

A subversion source index task.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class SvnSourceIndex _
    Inherits SourceIndexBase
C#
public class SvnSourceIndex : SourceIndexBase
Visual C++
public ref class SvnSourceIndex : public SourceIndexBase

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.SourceServer..::.SourceIndexBase
MSBuild.Community.Tasks.SourceServer..::.SvnSourceIndex

See Also

SvnSourceIndex Members
MSBuild.Community.Tasks.SourceServer Namespace


SvnSourceIndex Members

[image] [image]

.NET Framework Class Library
SvnSourceIndex Members
SvnSourceIndex Class Constructors Methods Fields Properties See Also Send Feedback

The SvnSourceIndex type exposes the following members.

Constructors

Name | Description
SvnSourceIndex | Initializes a new instance of the SvnSourceIndex class.

Methods

Name | Description
AddSourceProperties | Adds the source properties to the symbol file. (Overrides SourceIndexBase..::.AddSourceProperties(SymbolFile).)
CopyBuildEngine | Copies the build engine to the task. (Inherited from SourceIndexBase.)
CreateSourceIndexFile | Creates the source index file. (Overrides SourceIndexBase..::.CreateSourceIndexFile(SymbolFile, String).)
CreateSymbolFile | Creates an instance of SymbolFile from the symbol file task item and add the source file list to it. (Inherited from SourceIndexBase.)
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Inherited from SourceIndexBase.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
IndexSymbolFile | Indexes the symbol file. (Inherited from SourceIndexBase.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)
WriteSourceIndex | Writes the source index file to the symbol file. (Inherited from SourceIndexBase.)

Fields

Name | Description
Failed | (Inherited from SourceIndexBase.)
Skipped | (Inherited from SourceIndexBase.)
Successful | (Inherited from SourceIndexBase.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
SourceCommandFormat | Gets or sets the source command format. The SRCSRVCMD environment variable. (Inherited from SourceIndexBase.)
SourceServerName | Gets or sets the name of the source server. (Inherited from SourceIndexBase.)
SourceServerSdkPath | Gets or sets the source server SDK path. (Inherited from SourceIndexBase.)
SourceTargetFormat | Gets or sets the source target format. The SRCSRVTRG environment variable. (Inherited from SourceIndexBase.)
SymbolFiles | Gets or sets the symbol files to have to source index added. (Inherited from SourceIndexBase.)
TaskResources | (Inherited from Task.)

See Also

SvnSourceIndex Class
MSBuild.Community.Tasks.SourceServer Namespace


SvnSourceIndex Constructor

[image]

.NET Framework Class Library
SvnSourceIndex Constructor
SvnSourceIndex Class See Also Send Feedback

Initializes a new instance of the SvnSourceIndex class.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SvnSourceIndex()
Visual C++
public:
SvnSourceIndex()

See Also

SvnSourceIndex Class
MSBuild.Community.Tasks.SourceServer Namespace


SvnSourceIndex Fields

[image] [image]

.NET Framework Class Library
SvnSourceIndex Fields
SvnSourceIndex Class See Also Send Feedback

The SvnSourceIndex type exposes the following members.

Fields

Name | Description
Failed | (Inherited from SourceIndexBase.)
Skipped | (Inherited from SourceIndexBase.)
Successful | (Inherited from SourceIndexBase.)

See Also

SvnSourceIndex Class
MSBuild.Community.Tasks.SourceServer Namespace


SvnSourceIndex Methods

[image] [image]

.NET Framework Class Library
SvnSourceIndex Methods
SvnSourceIndex Class See Also Send Feedback

The SvnSourceIndex type exposes the following members.

Methods

Name | Description
AddSourceProperties | Adds the source properties to the symbol file. (Overrides SourceIndexBase..::.AddSourceProperties(SymbolFile).)
CopyBuildEngine | Copies the build engine to the task. (Inherited from SourceIndexBase.)
CreateSourceIndexFile | Creates the source index file. (Overrides SourceIndexBase..::.CreateSourceIndexFile(SymbolFile, String).)
CreateSymbolFile | Creates an instance of SymbolFile from the symbol file task item and add the source file list to it. (Inherited from SourceIndexBase.)
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Inherited from SourceIndexBase.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
IndexSymbolFile | Indexes the symbol file. (Inherited from SourceIndexBase.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)
WriteSourceIndex | Writes the source index file to the symbol file. (Inherited from SourceIndexBase.)

See Also

SvnSourceIndex Class
MSBuild.Community.Tasks.SourceServer Namespace


AddSourceProperties Method

[image]

.NET Framework Class Library
SvnSourceIndex..::.AddSourceProperties Method
SvnSourceIndex Class See Also Send Feedback

Adds the source properties to the symbol file.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function AddSourceProperties ( _
    symbolFile As SymbolFile _
) As Boolean
C#
protected override bool AddSourceProperties(
    SymbolFile symbolFile
)
Visual C++
protected:
virtual bool AddSourceProperties(
    SymbolFile^ symbolFile
) override

Parameters

symbolFile
Type: MSBuild.Community.Tasks.SourceServer..::.SymbolFile
The symbol file to add the source properties to.

Return Value

true if successful; otherwise false.

See Also

SvnSourceIndex Class
MSBuild.Community.Tasks.SourceServer Namespace


CreateSourceIndexFile Method

[image]

.NET Framework Class Library
SvnSourceIndex..::.CreateSourceIndexFile Method
SvnSourceIndex Class See Also Send Feedback

Creates the source index file.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateSourceIndexFile ( _
    symbolFile As SymbolFile, _
    sourceIndexFile As String _
) As Boolean
C#
protected override bool CreateSourceIndexFile(
    SymbolFile symbolFile,
    string sourceIndexFile
)
Visual C++
protected:
virtual bool CreateSourceIndexFile(
    SymbolFile^ symbolFile,
    String^ sourceIndexFile
) override

Parameters

symbolFile
Type: MSBuild.Community.Tasks.SourceServer..::.SymbolFile
The symbol file to create the index file from.
sourceIndexFile
Type: System..::.String
The source index file.

Return Value

true if successful; otherwise false.

See Also

SvnSourceIndex Class
MSBuild.Community.Tasks.SourceServer Namespace


SvnSourceIndex Properties

[image] [image]

.NET Framework Class Library
SvnSourceIndex Properties
SvnSourceIndex Class See Also Send Feedback

The SvnSourceIndex type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
SourceCommandFormat | Gets or sets the source command format. The SRCSRVCMD environment variable. (Inherited from SourceIndexBase.)
SourceServerName | Gets or sets the name of the source server. (Inherited from SourceIndexBase.)
SourceServerSdkPath | Gets or sets the source server SDK path. (Inherited from SourceIndexBase.)
SourceTargetFormat | Gets or sets the source target format. The SRCSRVTRG environment variable. (Inherited from SourceIndexBase.)
SymbolFiles | Gets or sets the symbol files to have to source index added. (Inherited from SourceIndexBase.)
TaskResources | (Inherited from Task.)

See Also

SvnSourceIndex Class
MSBuild.Community.Tasks.SourceServer Namespace


SymbolFile Class

[image]

.NET Framework Class Library
SymbolFile Class
Members See Also Send Feedback

A class representing a symbol file.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class SymbolFile _
    Inherits FileBase
C#
public class SymbolFile : FileBase
Visual C++
public ref class SymbolFile : public FileBase

Inheritance Hierarchy

System..::.Object
MSBuild.Community.Tasks.SourceServer..::.FileBase
MSBuild.Community.Tasks.SourceServer..::.SymbolFile

See Also

SymbolFile Members
MSBuild.Community.Tasks.SourceServer Namespace


SymbolFile Members

[image] [image]

.NET Framework Class Library
SymbolFile Members
SymbolFile Class Constructors Methods Properties See Also Send Feedback

The SymbolFile type exposes the following members.

Constructors

Name | Description
SymbolFile | Overloaded.

Methods

Name | Description
AddSourceFiles | Adds the source files.
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | Returns a String that represents this instance. (Inherited from FileBase.)

Properties

Name | Description
File | Gets or sets the file. (Inherited from FileBase.)
IsIndexed | Gets or sets a value indicating whether this instance is indexed.
SourceFiles | Gets the source files.

See Also

SymbolFile Class
MSBuild.Community.Tasks.SourceServer Namespace


SymbolFile Constructor

[image] [image]

.NET Framework Class Library
SymbolFile Constructor
SymbolFile Class See Also Send Feedback

Overload List

Name | Description
SymbolFile(FileInfo) | Initializes a new instance of the SymbolFile class.
SymbolFile(String) | Initializes a new instance of the SymbolFile class.

See Also

SymbolFile Class
SymbolFile Members
MSBuild.Community.Tasks.SourceServer Namespace


SymbolFile Constructor (FileInfo)

[image]

.NET Framework Class Library
SymbolFile Constructor (FileInfo)
SymbolFile Class See Also Send Feedback

Initializes a new instance of the SymbolFile class.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    fileInfo As FileInfo _
)
C#
public SymbolFile(
    FileInfo fileInfo
)
Visual C++
public:
SymbolFile(
    FileInfo^ fileInfo
)

Parameters

fileInfo
Type: System.IO..::.FileInfo
The file info.

See Also

SymbolFile Class
SymbolFile Overload
MSBuild.Community.Tasks.SourceServer Namespace


SymbolFile Constructor (String)

[image]

.NET Framework Class Library
SymbolFile Constructor (String)
SymbolFile Class See Also Send Feedback

Initializes a new instance of the SymbolFile class.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    fileName As String _
)
C#
public SymbolFile(
    string fileName
)
Visual C++
public:
SymbolFile(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
Name of the file.

See Also

SymbolFile Class
SymbolFile Overload
MSBuild.Community.Tasks.SourceServer Namespace


SymbolFile Methods

[image] [image]

.NET Framework Class Library
SymbolFile Methods
SymbolFile Class See Also Send Feedback

The SymbolFile type exposes the following members.

Methods

Name | Description
AddSourceFiles | Adds the source files.
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | Returns a String that represents this instance. (Inherited from FileBase.)

See Also

SymbolFile Class
MSBuild.Community.Tasks.SourceServer Namespace


AddSourceFiles Method

[image]

.NET Framework Class Library
SymbolFile..::.AddSourceFiles Method
SymbolFile Class See Also Send Feedback

Adds the source files.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddSourceFiles ( _
    files As IEnumerable(Of String) _
)
C#
public void AddSourceFiles(
    IEnumerable<string> files
)
Visual C++
public:
void AddSourceFiles(
    IEnumerable<String^>^ files
)

Parameters

files
Type: System.Collections.Generic..::.IEnumerable <(Of <( String >)>)
The files.

See Also

SymbolFile Class
MSBuild.Community.Tasks.SourceServer Namespace


SymbolFile Properties

[image] [image]

.NET Framework Class Library
SymbolFile Properties
SymbolFile Class See Also Send Feedback

The SymbolFile type exposes the following members.

Properties

Name | Description
File | Gets or sets the file. (Inherited from FileBase.)
IsIndexed | Gets or sets a value indicating whether this instance is indexed.
SourceFiles | Gets the source files.

See Also

SymbolFile Class
MSBuild.Community.Tasks.SourceServer Namespace


IsIndexed Property

[image]

.NET Framework Class Library
SymbolFile..::.IsIndexed Property
SymbolFile Class See Also Send Feedback

Gets or sets a value indicating whether this instance is indexed.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property IsIndexed As Boolean
C#
public bool IsIndexed { get; set; }
Visual C++
public:
property bool IsIndexed {
    bool get ();
    void set (bool value);
}

Field Value

true if this instance is indexed; otherwise, false.

See Also

SymbolFile Class
MSBuild.Community.Tasks.SourceServer Namespace


SourceFiles Property

[image]

.NET Framework Class Library
SymbolFile..::.SourceFiles Property
SymbolFile Class See Also Send Feedback

Gets the source files.

Namespace: MSBuild.Community.Tasks.SourceServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property SourceFiles As IList(Of SourceFile)
C#
public IList<SourceFile> SourceFiles { get; private set; }
Visual C++
public:
property IList<SourceFile^>^ SourceFiles {
    IList<SourceFile^>^ get ();
    void set (IList<SourceFile^>^ value);
}

Field Value

The source files.

See Also

SymbolFile Class
MSBuild.Community.Tasks.SourceServer Namespace


MSBuild.Community.Tasks.SqlServer Namespace

[image]

.NET Framework Class Library
MSBuild.Community.Tasks.SqlServer Namespace
Send Feedback

Classes

Class | Description
ExecuteDDL | MSBuild task to execute DDL and SQL statements.
SqlPubWiz | The Database Publishing Wizard enables the deployment of SQL Server databases (both schema and data) into a shared hosting environment.

Enumerations

Enumeration | Description
SqlPubCommands | The SqlPubWiz commands


ExecuteDDL Class

[image]

.NET Framework Class Library
ExecuteDDL Class
Members Example See Also Send Feedback

MSBuild task to execute DDL and SQL statements.

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class ExecuteDDL _
    Inherits Task
C#
public class ExecuteDDL : Task
Visual C++
public ref class ExecuteDDL : public Task

Remarks

Requires the the SQL Server libraries and dynamically loads the required Microsoft.SqlServer.ConnectionInfo assembly.

Examples

Copy Code
             <PropertyGroup>
                    <ConnectionString>Server=localhost;Integrated Security=True</ConnectionString>
                </PropertyGroup>

             <Target Name="ExecuteDDL">
                    <ExecuteDDL ConnectionString="$(ConnectionString)" Files="SqlBatchScript.sql" ContinueOnError="false" />
             </Target>

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.SqlServer..::.ExecuteDDL

See Also

ExecuteDDL Members
MSBuild.Community.Tasks.SqlServer Namespace


ExecuteDDL Members

[image] [image]

.NET Framework Class Library
ExecuteDDL Members
ExecuteDDL Class Constructors Methods Properties See Also Send Feedback

The ExecuteDDL type exposes the following members.

Constructors

Name | Description
ExecuteDDL |

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | Executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BatchSeparator | Gets or sets the batch delimter string.
BuildEngine | (Inherited from Task.)
ConnectionString | The connection string
Files | Gets or sets the DDL/SQL files.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
Results | Output the return count/values
StatementTimeout | Timeout to execute a DDL statement.
TaskResources | (Inherited from Task.)

See Also

ExecuteDDL Class
MSBuild.Community.Tasks.SqlServer Namespace


ExecuteDDL Constructor

[image]

.NET Framework Class Library
ExecuteDDL Constructor
ExecuteDDL Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ExecuteDDL()
Visual C++
public:
ExecuteDDL()

See Also

ExecuteDDL Class
MSBuild.Community.Tasks.SqlServer Namespace


ExecuteDDL Methods

[image] [image]

.NET Framework Class Library
ExecuteDDL Methods
ExecuteDDL Class See Also Send Feedback

The ExecuteDDL type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | Executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

ExecuteDDL Class
MSBuild.Community.Tasks.SqlServer Namespace


Execute Method

[image]

.NET Framework Class Library
ExecuteDDL..::.Execute Method
ExecuteDDL Class See Also Send Feedback

Executes the task.

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

true if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

ExecuteDDL Class
MSBuild.Community.Tasks.SqlServer Namespace


ExecuteDDL Properties

[image] [image]

.NET Framework Class Library
ExecuteDDL Properties
ExecuteDDL Class See Also Send Feedback

The ExecuteDDL type exposes the following members.

Properties

Name | Description
BatchSeparator | Gets or sets the batch delimter string.
BuildEngine | (Inherited from Task.)
ConnectionString | The connection string
Files | Gets or sets the DDL/SQL files.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
Results | Output the return count/values
StatementTimeout | Timeout to execute a DDL statement.
TaskResources | (Inherited from Task.)

See Also

ExecuteDDL Class
MSBuild.Community.Tasks.SqlServer Namespace


BatchSeparator Property

[image]

.NET Framework Class Library
ExecuteDDL..::.BatchSeparator Property
ExecuteDDL Class See Also Send Feedback

Gets or sets the batch delimter string.

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property BatchSeparator As String
C#
public string BatchSeparator { get; set; }
Visual C++
public:
property String^ BatchSeparator {
    String^ get ();
    void set (String^ value);
}

Remarks

Default is "GO" for T-SQL.

See Also

ExecuteDDL Class
MSBuild.Community.Tasks.SqlServer Namespace


ConnectionString Property

[image]

.NET Framework Class Library
ExecuteDDL..::.ConnectionString Property
ExecuteDDL Class See Also Send Feedback

The connection string

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property ConnectionString As String
C#
[RequiredAttribute]
public string ConnectionString { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ ConnectionString {
    String^ get ();
    void set (String^ value);
}

See Also

ExecuteDDL Class
MSBuild.Community.Tasks.SqlServer Namespace


Files Property

[image]

.NET Framework Class Library
ExecuteDDL..::.Files Property
ExecuteDDL Class See Also Send Feedback

Gets or sets the DDL/SQL files.

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property Files As ITaskItem()
C#
[RequiredAttribute]
public ITaskItem[] Files { get; set; }
Visual C++
[RequiredAttribute]
public:
property array<ITaskItem^>^ Files {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

Field Value

The assemblies.

See Also

ExecuteDDL Class
MSBuild.Community.Tasks.SqlServer Namespace


Results Property

[image]

.NET Framework Class Library
ExecuteDDL..::.Results Property
ExecuteDDL Class See Also Send Feedback

Output the return count/values

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property Results As Integer()
C#
[OutputAttribute]
public int[] Results { get; }
Visual C++
[OutputAttribute]
public:
property array<int>^ Results {
    array<int>^ get ();
}

See Also

ExecuteDDL Class
MSBuild.Community.Tasks.SqlServer Namespace


StatementTimeout Property

[image]

.NET Framework Class Library
ExecuteDDL..::.StatementTimeout Property
ExecuteDDL Class See Also Send Feedback

Timeout to execute a DDL statement.

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property StatementTimeout As Integer
C#
public int StatementTimeout { get; set; }
Visual C++
public:
property int StatementTimeout {
    int get ();
    void set (int value);
}

Remarks

Defaults to 30 seconds. Set to 0 for an infinite timeout period.

See Also

ExecuteDDL Class
MSBuild.Community.Tasks.SqlServer Namespace


SqlPubCommands Enumeration

[image]

.NET Framework Class Library
SqlPubCommands Enumeration
See Also Send Feedback

The SqlPubWiz commands

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration SqlPubCommands
C#
public enum SqlPubCommands
Visual C++
public enum class SqlPubCommands

Members

Member name | Description
Script | Scripts a local database to one or more files
Publish | Publishes a local database to a web service provided by a hoster.

See Also

MSBuild.Community.Tasks.SqlServer Namespace


SqlPubWiz Class

[image]

.NET Framework Class Library
SqlPubWiz Class
Members Example See Also Send Feedback

The Database Publishing Wizard enables the deployment of SQL Server databases (both schema and data) into a shared hosting environment.

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class SqlPubWiz _
    Inherits ToolTask
C#
public class SqlPubWiz : ToolTask
Visual C++
public ref class SqlPubWiz : public ToolTask

Examples

Generate the database script for Northwind on localhost.
Copy Code
            <SqlPubWiz
                Database="Northwind"
                Output="Northwind.sql"
                SchemaOnly="true" />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
Microsoft.Build.Utilities..::.ToolTask
MSBuild.Community.Tasks.SqlServer..::.SqlPubWiz

See Also

SqlPubWiz Members
MSBuild.Community.Tasks.SqlServer Namespace


SqlPubWiz Members

[image] [image]

.NET Framework Class Library
SqlPubWiz Members
SqlPubWiz Class Constructors Methods Properties See Also Send Feedback

The SqlPubWiz type exposes the following members.

Constructors

Name | Description
SqlPubWiz |

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from ToolTask.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | (Inherited from ToolTask.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Overrides ToolTask..::.LogToolCommand(String).)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Command | Gets or sets the database publishing command.
ConnectionString | Gets or sets the full connection string to the local database.
Database | Gets or sets the name of the local database to be scripted.
DataOnly | Gets or sets a value indicating whether the data but not the schema should be scripted.
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
HelpKeywordPrefix | (Inherited from Task.)
HosterName | Gets or sets the friendly name of previously configured hosting Web service.
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
NoDropExisting | Gets or sets a value indicating whether the produced script should not drop pre-existing objects.
NoSchemaQualify | Gets or sets a value indicating whether objects will not be qualified with a schema.
NoTransaction | Gets or sets a value indicating whether the publish operation should not be executed within a single transaction.
Output | Gets or sets the full file path for the script file generated.
Password | Gets or sets the password to use for connection to the source database.
Quiet | Gets or sets a value indicating output message suppression.
ResponseFileEncoding | (Inherited from ToolTask.)
SchemaOnly | Gets or sets a value indicating whether the schema, but not the data, should be scripted.
Server | Gets or sets the name or IP address for the local database connection.
ServiceDatabase | Gets or sets the remote database server name.
ServiceDatabaseServer | Gets or sets the database name to publish to on the remote server.
ServicePassword | Gets or sets the password for the remote Web service endpoint.
ServiceUsername | Gets or sets the username on the hosting Web service endpoint.
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Overrides ToolTask..::.StandardOutputLoggingImportance.)
TargetServer | Gets or sets the target server the script should target.
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)
Username | Gets or sets the SQL Server user name to use for connection to the source database.
WebServiceAddress | Gets or sets the configuration of the hosting Web service endpoint.

See Also

SqlPubWiz Class
MSBuild.Community.Tasks.SqlServer Namespace


SqlPubWiz Constructor

[image]

.NET Framework Class Library
SqlPubWiz Constructor
SqlPubWiz Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SqlPubWiz()
Visual C++
public:
SqlPubWiz()

See Also

SqlPubWiz Class
MSBuild.Community.Tasks.SqlServer Namespace


SqlPubWiz Methods

[image] [image]

.NET Framework Class Library
SqlPubWiz Methods
SqlPubWiz Class See Also Send Feedback

The SqlPubWiz type exposes the following members.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from ToolTask.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | (Inherited from ToolTask.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Overrides ToolTask..::.LogToolCommand(String).)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

See Also

SqlPubWiz Class
MSBuild.Community.Tasks.SqlServer Namespace


GenerateCommandLineCommands Method

[image]

.NET Framework Class Library
SqlPubWiz..::.GenerateCommandLineCommands Method
SqlPubWiz Class See Also Send Feedback

Returns a string value containing the command line arguments to pass directly to the executable file.

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateCommandLineCommands As String
C#
protected override string GenerateCommandLineCommands()
Visual C++
protected:
virtual String^ GenerateCommandLineCommands() override

Return Value

A string value containing the command line arguments to pass directly to the executable file.

See Also

SqlPubWiz Class
MSBuild.Community.Tasks.SqlServer Namespace


GenerateFullPathToTool Method

[image]

.NET Framework Class Library
SqlPubWiz..::.GenerateFullPathToTool Method
SqlPubWiz Class See Also Send Feedback

Returns the fully qualified path to the executable file.

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateFullPathToTool As String
C#
protected override string GenerateFullPathToTool()
Visual C++
protected:
virtual String^ GenerateFullPathToTool() override

Return Value

The fully qualified path to the executable file.

See Also

SqlPubWiz Class
MSBuild.Community.Tasks.SqlServer Namespace


LogToolCommand Method

[image]

.NET Framework Class Library
SqlPubWiz..::.LogToolCommand Method
SqlPubWiz Class See Also Send Feedback

Logs the starting point of the run to all registered loggers.

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub LogToolCommand ( _
    message As String _
)
C#
protected override void LogToolCommand(
    string message
)
Visual C++
protected:
virtual void LogToolCommand(
    String^ message
) override

Parameters

message
Type: System..::.String
A descriptive message to provide loggers, usually the command line and switches.

See Also

SqlPubWiz Class
MSBuild.Community.Tasks.SqlServer Namespace


SqlPubWiz Properties

[image] [image]

.NET Framework Class Library
SqlPubWiz Properties
SqlPubWiz Class See Also Send Feedback

The SqlPubWiz type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Command | Gets or sets the database publishing command.
ConnectionString | Gets or sets the full connection string to the local database.
Database | Gets or sets the name of the local database to be scripted.
DataOnly | Gets or sets a value indicating whether the data but not the schema should be scripted.
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
HelpKeywordPrefix | (Inherited from Task.)
HosterName | Gets or sets the friendly name of previously configured hosting Web service.
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
NoDropExisting | Gets or sets a value indicating whether the produced script should not drop pre-existing objects.
NoSchemaQualify | Gets or sets a value indicating whether objects will not be qualified with a schema.
NoTransaction | Gets or sets a value indicating whether the publish operation should not be executed within a single transaction.
Output | Gets or sets the full file path for the script file generated.
Password | Gets or sets the password to use for connection to the source database.
Quiet | Gets or sets a value indicating output message suppression.
ResponseFileEncoding | (Inherited from ToolTask.)
SchemaOnly | Gets or sets a value indicating whether the schema, but not the data, should be scripted.
Server | Gets or sets the name or IP address for the local database connection.
ServiceDatabase | Gets or sets the remote database server name.
ServiceDatabaseServer | Gets or sets the database name to publish to on the remote server.
ServicePassword | Gets or sets the password for the remote Web service endpoint.
ServiceUsername | Gets or sets the username on the hosting Web service endpoint.
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Overrides ToolTask..::.StandardOutputLoggingImportance.)
TargetServer | Gets or sets the target server the script should target.
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)
Username | Gets or sets the SQL Server user name to use for connection to the source database.
WebServiceAddress | Gets or sets the configuration of the hosting Web service endpoint.

See Also

SqlPubWiz Class
MSBuild.Community.Tasks.SqlServer Namespace


Command Property

[image]

.NET Framework Class Library
SqlPubWiz..::.Command Property
SqlPubWiz Class See Also Send Feedback

Gets or sets the database publishing command.

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Command As String
C#
public string Command { get; set; }
Visual C++
public:
property String^ Command {
    String^ get ();
    void set (String^ value);
}

Field Value

The database publishing command.

Remarks

Use either script or publish. Use script to script a local database to a file on the local computer. Use publish to transfer database objects directly to a hosted database via a web service. script and publish enable some of the same options and switches. Some options and switches are only enabled only by one of these verbs.

See Also

SqlPubWiz Class
MSBuild.Community.Tasks.SqlServer Namespace


ConnectionString Property

[image]

.NET Framework Class Library
SqlPubWiz..::.ConnectionString Property
SqlPubWiz Class See Also Send Feedback

Gets or sets the full connection string to the local database.

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ConnectionString As String
C#
public string ConnectionString { get; set; }
Visual C++
public:
property String^ ConnectionString {
    String^ get ();
    void set (String^ value);
}

Field Value

The connection string.

Remarks

Provides a full connection string to connect to the local database. This connection string encapsulates all connection options to the server. Incompatible with Username, Password or, Server.

See Also

SqlPubWiz Class
MSBuild.Community.Tasks.SqlServer Namespace


Database Property

[image]

.NET Framework Class Library
SqlPubWiz..::.Database Property
SqlPubWiz Class See Also Send Feedback

Gets or sets the name of the local database to be scripted.

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Database As String
C#
public string Database { get; set; }
Visual C++
public:
property String^ Database {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the database to be scripted.

See Also

SqlPubWiz Class
MSBuild.Community.Tasks.SqlServer Namespace


DataOnly Property

[image]

.NET Framework Class Library
SqlPubWiz..::.DataOnly Property
SqlPubWiz Class See Also Send Feedback

Gets or sets a value indicating whether the data but not the schema should be scripted.

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property DataOnly As Boolean
C#
public bool DataOnly { get; set; }
Visual C++
public:
property bool DataOnly {
    bool get ();
    void set (bool value);
}

Field Value

true if only the data is scripted; otherwise, false.

Remarks

Specifies that the data but not the schema should be scripted. Incompatible with NoDropExisting or SchemaOnly. If neither SchemaOnly nor DataOnly are specified, both the schema and data are scripted.

See Also

SqlPubWiz Class
MSBuild.Community.Tasks.SqlServer Namespace


HosterName Property

[image]

.NET Framework Class Library
SqlPubWiz..::.HosterName Property
SqlPubWiz Class See Also Send Feedback

Gets or sets the friendly name of previously configured hosting Web service.

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property HosterName As String
C#
public string HosterName { get; set; }
Visual C++
public:
property String^ HosterName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the hoster.

See Also

SqlPubWiz Class
MSBuild.Community.Tasks.SqlServer Namespace


NoDropExisting Property

[image]

.NET Framework Class Library
SqlPubWiz..::.NoDropExisting Property
SqlPubWiz Class See Also Send Feedback

Gets or sets a value indicating whether the produced script should not drop pre-existing objects.

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property NoDropExisting As Boolean
C#
public bool NoDropExisting { get; set; }
Visual C++
public:
property bool NoDropExisting {
    bool get ();
    void set (bool value);
}

Field Value

true if pre-existing objects should not be dropped; otherwise, false.

See Also

SqlPubWiz Class
MSBuild.Community.Tasks.SqlServer Namespace


NoSchemaQualify Property

[image]

.NET Framework Class Library
SqlPubWiz..::.NoSchemaQualify Property
SqlPubWiz Class See Also Send Feedback

Gets or sets a value indicating whether objects will not be qualified with a schema.

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property NoSchemaQualify As Boolean
C#
public bool NoSchemaQualify { get; set; }
Visual C++
public:
property bool NoSchemaQualify {
    bool get ();
    void set (bool value);
}

Field Value

true if objects will not be schema qualified; otherwise, false.

See Also

SqlPubWiz Class
MSBuild.Community.Tasks.SqlServer Namespace


NoTransaction Property

[image]

.NET Framework Class Library
SqlPubWiz..::.NoTransaction Property
SqlPubWiz Class See Also Send Feedback

Gets or sets a value indicating whether the publish operation should not be executed within a single transaction.

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property NoTransaction As Boolean
C#
public bool NoTransaction { get; set; }
Visual C++
public:
property bool NoTransaction {
    bool get ();
    void set (bool value);
}

Field Value

true to not publish in a single transaction; otherwise, false.

Remarks

Specifies that the publish operation should not be executed within a single transaction. This reduces logging overhead on the target server, but if the publish is interrupted, the target database may be left in a partially populated state.

See Also

SqlPubWiz Class
MSBuild.Community.Tasks.SqlServer Namespace


Output Property

[image]

.NET Framework Class Library
SqlPubWiz..::.Output Property
SqlPubWiz Class See Also Send Feedback

Gets or sets the full file path for the script file generated.

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Output As ITaskItem
C#
public ITaskItem Output { get; set; }
Visual C++
public:
property ITaskItem^ Output {
    ITaskItem^ get ();
    void set (ITaskItem^ value);
}

Field Value

The full file path.

Remarks

Use only with script. Specifies the full file path for the script file generated by the sqlpubwiz.

See Also

SqlPubWiz Class
MSBuild.Community.Tasks.SqlServer Namespace


Password Property

[image]

.NET Framework Class Library
SqlPubWiz..::.Password Property
SqlPubWiz Class See Also Send Feedback

Gets or sets the password to use for connection to the source database.

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password { get; set; }
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

Field Value

The password.

Remarks

Specifies the password to use for connection to the source database. Requires Username. Incompatible with ConnectionString.

See Also

SqlPubWiz Class
MSBuild.Community.Tasks.SqlServer Namespace


Quiet Property

[image]

.NET Framework Class Library
SqlPubWiz..::.Quiet Property
SqlPubWiz Class See Also Send Feedback

Gets or sets a value indicating output message suppression.

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Quiet As Boolean
C#
public bool Quiet { get; set; }
Visual C++
public:
property bool Quiet {
    bool get ();
    void set (bool value);
}

Field Value

true to suppress messages; otherwise, false.

See Also

SqlPubWiz Class
MSBuild.Community.Tasks.SqlServer Namespace


SchemaOnly Property

[image]

.NET Framework Class Library
SqlPubWiz..::.SchemaOnly Property
SqlPubWiz Class See Also Send Feedback

Gets or sets a value indicating whether the schema, but not the data, should be scripted.

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property SchemaOnly As Boolean
C#
public bool SchemaOnly { get; set; }
Visual C++
public:
property bool SchemaOnly {
    bool get ();
    void set (bool value);
}

Field Value

true if only the schema should be scripted; otherwise, false.

Remarks

Specifies that the schema, but not the data, should be scripted. Incompatible with DataOnly. If neither SchemaOnly nor DataOnly are specified, both the schema and data are scripted.

See Also

SqlPubWiz Class
MSBuild.Community.Tasks.SqlServer Namespace


Server Property

[image]

.NET Framework Class Library
SqlPubWiz..::.Server Property
SqlPubWiz Class See Also Send Feedback

Gets or sets the name or IP address for the local database connection.

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Server As String
C#
public string Server { get; set; }
Visual C++
public:
property String^ Server {
    String^ get ();
    void set (String^ value);
}

Field Value

The name or IP address of server.

Remarks

Specifies the name or IP address for the local database connection. The default is localhost. Incompatible with ConnectionString.

See Also

SqlPubWiz Class
MSBuild.Community.Tasks.SqlServer Namespace


ServiceDatabase Property

[image]

.NET Framework Class Library
SqlPubWiz..::.ServiceDatabase Property
SqlPubWiz Class See Also Send Feedback

Gets or sets the remote database server name.

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ServiceDatabase As String
C#
public string ServiceDatabase { get; set; }
Visual C++
public:
property String^ ServiceDatabase {
    String^ get ();
    void set (String^ value);
}

Field Value

The service database.

See Also

SqlPubWiz Class
MSBuild.Community.Tasks.SqlServer Namespace


ServiceDatabaseServer Property

[image]

.NET Framework Class Library
SqlPubWiz..::.ServiceDatabaseServer Property
SqlPubWiz Class See Also Send Feedback

Gets or sets the database name to publish to on the remote server.

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ServiceDatabaseServer As String
C#
public string ServiceDatabaseServer { get; set; }
Visual C++
public:
property String^ ServiceDatabaseServer {
    String^ get ();
    void set (String^ value);
}

Field Value

The service database server.

See Also

SqlPubWiz Class
MSBuild.Community.Tasks.SqlServer Namespace


ServicePassword Property

[image]

.NET Framework Class Library
SqlPubWiz..::.ServicePassword Property
SqlPubWiz Class See Also Send Feedback

Gets or sets the password for the remote Web service endpoint.

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ServicePassword As String
C#
public string ServicePassword { get; set; }
Visual C++
public:
property String^ ServicePassword {
    String^ get ();
    void set (String^ value);
}

Field Value

The service password.

See Also

SqlPubWiz Class
MSBuild.Community.Tasks.SqlServer Namespace


ServiceUsername Property

[image]

.NET Framework Class Library
SqlPubWiz..::.ServiceUsername Property
SqlPubWiz Class See Also Send Feedback

Gets or sets the username on the hosting Web service endpoint.

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ServiceUsername As String
C#
public string ServiceUsername { get; set; }
Visual C++
public:
property String^ ServiceUsername {
    String^ get ();
    void set (String^ value);
}

Field Value

The service username.

See Also

SqlPubWiz Class
MSBuild.Community.Tasks.SqlServer Namespace


StandardOutputLoggingImportance Property

[image]

.NET Framework Class Library
SqlPubWiz..::.StandardOutputLoggingImportance Property
SqlPubWiz Class See Also Send Feedback

Gets the MessageImportance with which to log errors.

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property StandardOutputLoggingImportance As MessageImportance
C#
protected override MessageImportance StandardOutputLoggingImportance { get; }
Visual C++
protected:
virtual property MessageImportance StandardOutputLoggingImportance {
    MessageImportance get () override;
}

Field Value

Return Value

The MessageImportance with which to log errors.

See Also

SqlPubWiz Class
MSBuild.Community.Tasks.SqlServer Namespace


TargetServer Property

[image]

.NET Framework Class Library
SqlPubWiz..::.TargetServer Property
SqlPubWiz Class See Also Send Feedback

Gets or sets the target server the script should target.

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property TargetServer As String
C#
public string TargetServer { get; set; }
Visual C++
public:
property String^ TargetServer {
    String^ get ();
    void set (String^ value);
}

Field Value

The target server the script should target.

Remarks

Specifies that the script to be generated should target a SQL Server 2000 or SQL Server 2005 instance. The default is SQL Server 2005.

See Also

SqlPubWiz Class
MSBuild.Community.Tasks.SqlServer Namespace


ToolName Property

[image]

.NET Framework Class Library
SqlPubWiz..::.ToolName Property
SqlPubWiz Class See Also Send Feedback

Gets the name of the executable file to run.

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ToolName As String
C#
protected override string ToolName { get; }
Visual C++
protected:
virtual property String^ ToolName {
    String^ get () override;
}

Field Value

Return Value

The name of the executable file to run.

See Also

SqlPubWiz Class
MSBuild.Community.Tasks.SqlServer Namespace


Username Property

[image]

.NET Framework Class Library
SqlPubWiz..::.Username Property
SqlPubWiz Class See Also Send Feedback

Gets or sets the SQL Server user name to use for connection to the source database.

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Username As String
C#
public string Username { get; set; }
Visual C++
public:
property String^ Username {
    String^ get ();
    void set (String^ value);
}

Field Value

The SQL Server user name.

Remarks

Specifies the SQL Server User name to use for connection to the source database. Requires Password. Incompatible with ConnectionString.

See Also

SqlPubWiz Class
MSBuild.Community.Tasks.SqlServer Namespace


WebServiceAddress Property

[image]

.NET Framework Class Library
SqlPubWiz..::.WebServiceAddress Property
SqlPubWiz Class See Also Send Feedback

Gets or sets the configuration of the hosting Web service endpoint.

Namespace: MSBuild.Community.Tasks.SqlServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property WebServiceAddress As String
C#
public string WebServiceAddress { get; set; }
Visual C++
public:
property String^ WebServiceAddress {
    String^ get ();
    void set (String^ value);
}

Field Value

The web service address.

See Also

SqlPubWiz Class
MSBuild.Community.Tasks.SqlServer Namespace


MSBuild.Community.Tasks.Subversion Namespace

[image]

.NET Framework Class Library
MSBuild.Community.Tasks.Subversion Namespace
Send Feedback

Classes

Class | Description
Entry |
EntryCollection |
Info |
LastCommit |
Repository |
SvnCheckout | Checkout a local working copy of a Subversion repository.
SvnClient | Subversion client base class
SvnCommit | Subversion Commit command
SvnCopy | Copy a file or folder in Subversion
SvnExport | Export a folder from a Subversion repository
SvnInfo | Run the "svn info" command and parse the output
SvnUpdate | Subversion Update command
SvnVersion | Summarize the local revision(s) of a working copy.
WorkingCopy |

Enumerations

Enumeration | Description
NodeKind | The kind of Subversion node. The names match the text output by "svn info".
Schedule | The Subversion schedule type.


Entry Class

[image]

.NET Framework Class Library
Entry Class
Members See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Entry
C#
public class Entry
Visual C++
public ref class Entry

Remarks

Inheritance Hierarchy

System..::.Object
MSBuild.Community.Tasks.Subversion..::.Entry

See Also

Entry Members
MSBuild.Community.Tasks.Subversion Namespace


Entry Members

[image] [image]

.NET Framework Class Library
Entry Members
Entry Class Constructors Methods Properties See Also Send Feedback

The Entry type exposes the following members.

Constructors

Name | Description
Entry |

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
Commit |
Kind |
Path |
Repository |
Revision |
Url |
WorkingCopy |

See Also

Entry Class
MSBuild.Community.Tasks.Subversion Namespace


Entry Constructor

[image]

.NET Framework Class Library
Entry Constructor
Entry Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Entry()
Visual C++
public:
Entry()

Remarks

See Also

Entry Class
MSBuild.Community.Tasks.Subversion Namespace


Entry Methods

[image] [image]

.NET Framework Class Library
Entry Methods
Entry Class See Also Send Feedback

The Entry type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

Entry Class
MSBuild.Community.Tasks.Subversion Namespace


Entry Properties

[image] [image]

.NET Framework Class Library
Entry Properties
Entry Class See Also Send Feedback

The Entry type exposes the following members.

Properties

Name | Description
Commit |
Kind |
Path |
Repository |
Revision |
Url |
WorkingCopy |

See Also

Entry Class
MSBuild.Community.Tasks.Subversion Namespace


Commit Property

[image]

.NET Framework Class Library
Entry..::.Commit Property
Entry Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Commit As LastCommit
C#
public LastCommit Commit { get; set; }
Visual C++
public:
property LastCommit^ Commit {
    LastCommit^ get ();
    void set (LastCommit^ value);
}

Remarks

See Also

Entry Class
MSBuild.Community.Tasks.Subversion Namespace


Kind Property

[image]

.NET Framework Class Library
Entry..::.Kind Property
Entry Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Kind As String
C#
public string Kind { get; set; }
Visual C++
public:
property String^ Kind {
    String^ get ();
    void set (String^ value);
}

Remarks

See Also

Entry Class
MSBuild.Community.Tasks.Subversion Namespace


Path Property

[image]

.NET Framework Class Library
Entry..::.Path Property
Entry Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Path As String
C#
public string Path { get; set; }
Visual C++
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}

Remarks

See Also

Entry Class
MSBuild.Community.Tasks.Subversion Namespace


Repository Property

[image]

.NET Framework Class Library
Entry..::.Repository Property
Entry Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Repository As Repository
C#
public Repository Repository { get; set; }
Visual C++
public:
property Repository^ Repository {
    Repository^ get ();
    void set (Repository^ value);
}

Remarks

See Also

Entry Class
MSBuild.Community.Tasks.Subversion Namespace


Revision Property

[image]

.NET Framework Class Library
Entry..::.Revision Property
Entry Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Revision As Long
C#
public long Revision { get; set; }
Visual C++
public:
property long long Revision {
    long long get ();
    void set (long long value);
}

Remarks

See Also

Entry Class
MSBuild.Community.Tasks.Subversion Namespace


Url Property

[image]

.NET Framework Class Library
Entry..::.Url Property
Entry Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Url As String
C#
public string Url { get; set; }
Visual C++
public:
property String^ Url {
    String^ get ();
    void set (String^ value);
}

Remarks

See Also

Entry Class
MSBuild.Community.Tasks.Subversion Namespace


WorkingCopy Property

[image]

.NET Framework Class Library
Entry..::.WorkingCopy Property
Entry Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property WorkingCopy As WorkingCopy
C#
public WorkingCopy WorkingCopy { get; set; }
Visual C++
public:
property WorkingCopy^ WorkingCopy {
    WorkingCopy^ get ();
    void set (WorkingCopy^ value);
}

Remarks

See Also

Entry Class
MSBuild.Community.Tasks.Subversion Namespace


EntryCollection Class

[image]

.NET Framework Class Library
EntryCollection Class
Members See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class EntryCollection _
    Inherits KeyedCollection(Of String, Entry)
C#
public class EntryCollection : KeyedCollection<string, Entry>
Visual C++
public ref class EntryCollection : public KeyedCollection<String^, Entry^>

Remarks

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <( Entry >)>)
System.Collections.ObjectModel..::.KeyedCollection <(Of <( String, Entry >)>)
MSBuild.Community.Tasks.Subversion..::.EntryCollection

See Also

EntryCollection Members
MSBuild.Community.Tasks.Subversion Namespace


EntryCollection Members

[image] [image]

.NET Framework Class Library
EntryCollection Members
EntryCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The EntryCollection type exposes the following members.

Constructors

Name | Description
EntryCollection |

Methods

Name | Description
Add | (Inherited from Collection <(Of <( Entry >)>).)
ChangeItemKey | (Inherited from KeyedCollection <(Of <( String, Entry >)>).)
Clear | (Inherited from Collection <(Of <( Entry >)>).)
ClearItems | (Inherited from KeyedCollection <(Of <( String, Entry >)>).)
Contains | Overloaded.
CopyTo | (Inherited from Collection <(Of <( Entry >)>).)
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetEnumerator | (Inherited from Collection <(Of <( Entry >)>).)
GetHashCode | (Inherited from Object.)
GetKeyForItem | (Overrides KeyedCollection<(Of <(TKey, TItem>)>)..::.GetKeyForItem(TItem).)
GetType | (Inherited from Object.)
IndexOf | (Inherited from Collection <(Of <( Entry >)>).)
Insert | (Inherited from Collection <(Of <( Entry >)>).)
InsertItem | (Inherited from KeyedCollection <(Of <( String, Entry >)>).)
MemberwiseClone | (Inherited from Object.)
Remove | Overloaded.
RemoveAt | (Inherited from Collection <(Of <( Entry >)>).)
RemoveItem | (Inherited from KeyedCollection <(Of <( String, Entry >)>).)
SetItem | (Inherited from KeyedCollection <(Of <( String, Entry >)>).)
ToString | (Inherited from Object.)

Properties

Name | Description
Comparer | (Inherited from KeyedCollection <(Of <( String, Entry >)>).)
Count | (Inherited from Collection <(Of <( Entry >)>).)
Dictionary | (Inherited from KeyedCollection <(Of <( String, Entry >)>).)
Item | Overloaded.
Items | (Inherited from Collection <(Of <( Entry >)>).)

Explicit Interface Implementations

Name | Description
IList..::.Add | (Inherited from Collection <(Of <( Entry >)>).)
IList..::.Contains | (Inherited from Collection <(Of <( Entry >)>).)
ICollection..::.CopyTo | (Inherited from Collection <(Of <( Entry >)>).)
IEnumerable..::.GetEnumerator | (Inherited from Collection <(Of <( Entry >)>).)
IList..::.IndexOf | (Inherited from Collection <(Of <( Entry >)>).)
IList..::.Insert | (Inherited from Collection <(Of <( Entry >)>).)
IList..::.IsFixedSize | (Inherited from Collection <(Of <( Entry >)>).)
System#Collections#Generic#ICollection{T}#IsReadOnly | (Inherited from Collection <(Of <( Entry >)>).)
IList..::.IsReadOnly | (Inherited from Collection <(Of <( Entry >)>).)
ICollection..::.IsSynchronized | (Inherited from Collection <(Of <( Entry >)>).)
IList..::.Item | (Inherited from Collection <(Of <( Entry >)>).)
IList..::.Remove | (Inherited from Collection <(Of <( Entry >)>).)
ICollection..::.SyncRoot | (Inherited from Collection <(Of <( Entry >)>).)

See Also

EntryCollection Class
MSBuild.Community.Tasks.Subversion Namespace


EntryCollection Constructor

[image]

.NET Framework Class Library
EntryCollection Constructor
EntryCollection Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public EntryCollection()
Visual C++
public:
EntryCollection()

Remarks

See Also

EntryCollection Class
MSBuild.Community.Tasks.Subversion Namespace


EntryCollection Methods

[image] [image]

.NET Framework Class Library
EntryCollection Methods
EntryCollection Class See Also Send Feedback

The EntryCollection type exposes the following members.

Methods

Name | Description
Add | (Inherited from Collection <(Of <( Entry >)>).)
ChangeItemKey | (Inherited from KeyedCollection <(Of <( String, Entry >)>).)
Clear | (Inherited from Collection <(Of <( Entry >)>).)
ClearItems | (Inherited from KeyedCollection <(Of <( String, Entry >)>).)
Contains | Overloaded.
CopyTo | (Inherited from Collection <(Of <( Entry >)>).)
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetEnumerator | (Inherited from Collection <(Of <( Entry >)>).)
GetHashCode | (Inherited from Object.)
GetKeyForItem | (Overrides KeyedCollection<(Of <(TKey, TItem>)>)..::.GetKeyForItem(TItem).)
GetType | (Inherited from Object.)
IndexOf | (Inherited from Collection <(Of <( Entry >)>).)
Insert | (Inherited from Collection <(Of <( Entry >)>).)
InsertItem | (Inherited from KeyedCollection <(Of <( String, Entry >)>).)
MemberwiseClone | (Inherited from Object.)
Remove | Overloaded.
RemoveAt | (Inherited from Collection <(Of <( Entry >)>).)
RemoveItem | (Inherited from KeyedCollection <(Of <( String, Entry >)>).)
SetItem | (Inherited from KeyedCollection <(Of <( String, Entry >)>).)
ToString | (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IList..::.Add | (Inherited from Collection <(Of <( Entry >)>).)
IList..::.Contains | (Inherited from Collection <(Of <( Entry >)>).)
ICollection..::.CopyTo | (Inherited from Collection <(Of <( Entry >)>).)
IEnumerable..::.GetEnumerator | (Inherited from Collection <(Of <( Entry >)>).)
IList..::.IndexOf | (Inherited from Collection <(Of <( Entry >)>).)
IList..::.Insert | (Inherited from Collection <(Of <( Entry >)>).)
IList..::.Remove | (Inherited from Collection <(Of <( Entry >)>).)

See Also

EntryCollection Class
MSBuild.Community.Tasks.Subversion Namespace


Contains Method

[image] [image]

.NET Framework Class Library
EntryCollection..::.Contains Method
EntryCollection Class See Also Send Feedback

Overload List

Name | Description
Contains(TKey) | (Inherited from KeyedCollection <(Of <( String, Entry >)>).)
Contains(T) | (Inherited from Collection <(Of <( Entry >)>).)

See Also

EntryCollection Class
EntryCollection Members
MSBuild.Community.Tasks.Subversion Namespace


GetKeyForItem Method

[image]

.NET Framework Class Library
EntryCollection..::.GetKeyForItem Method
EntryCollection Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetKeyForItem ( _
    item As Entry _
) As String
C#
protected override string GetKeyForItem(
    Entry item
)
Visual C++
protected:
virtual String^ GetKeyForItem(
    Entry^ item
) override

Parameters

item
Type: MSBuild.Community.Tasks.Subversion..::.Entry

Remarks

See Also

EntryCollection Class
MSBuild.Community.Tasks.Subversion Namespace


Remove Method

[image] [image]

.NET Framework Class Library
EntryCollection..::.Remove Method
EntryCollection Class See Also Send Feedback

Overload List

Name | Description
Remove(TKey) | (Inherited from KeyedCollection <(Of <( String, Entry >)>).)
Remove(T) | (Inherited from Collection <(Of <( Entry >)>).)

See Also

EntryCollection Class
EntryCollection Members
MSBuild.Community.Tasks.Subversion Namespace


EntryCollection Properties

[image] [image]

.NET Framework Class Library
EntryCollection Properties
EntryCollection Class See Also Send Feedback

The EntryCollection type exposes the following members.

Properties

Name | Description
Comparer | (Inherited from KeyedCollection <(Of <( String, Entry >)>).)
Count | (Inherited from Collection <(Of <( Entry >)>).)
Dictionary | (Inherited from KeyedCollection <(Of <( String, Entry >)>).)
Item | Overloaded.
Items | (Inherited from Collection <(Of <( Entry >)>).)

Explicit Interface Implementations

Name | Description
IList..::.IsFixedSize | (Inherited from Collection <(Of <( Entry >)>).)
System#Collections#Generic#ICollection{T}#IsReadOnly | (Inherited from Collection <(Of <( Entry >)>).)
IList..::.IsReadOnly | (Inherited from Collection <(Of <( Entry >)>).)
ICollection..::.IsSynchronized | (Inherited from Collection <(Of <( Entry >)>).)
IList..::.Item | (Inherited from Collection <(Of <( Entry >)>).)
ICollection..::.SyncRoot | (Inherited from Collection <(Of <( Entry >)>).)

See Also

EntryCollection Class
MSBuild.Community.Tasks.Subversion Namespace


Item Property

[image] [image]

.NET Framework Class Library
EntryCollection..::.Item Property
EntryCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(TKey])]) | (Inherited from KeyedCollection <(Of <( String, Entry >)>).)
Item[([(Int32])]) | (Inherited from Collection <(Of <( Entry >)>).)

See Also

EntryCollection Class
EntryCollection Members
MSBuild.Community.Tasks.Subversion Namespace


Info Class

[image]

.NET Framework Class Library
Info Class
Members See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Info
C#
public class Info
Visual C++
public ref class Info

Remarks

Inheritance Hierarchy

System..::.Object
MSBuild.Community.Tasks.Subversion..::.Info

See Also

Info Members
MSBuild.Community.Tasks.Subversion Namespace


Info Members

[image] [image]

.NET Framework Class Library
Info Members
Info Class Constructors Methods Properties See Also Send Feedback

The Info type exposes the following members.

Constructors

Name | Description
Info |

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
Entries |

See Also

Info Class
MSBuild.Community.Tasks.Subversion Namespace


Info Constructor

[image]

.NET Framework Class Library
Info Constructor
Info Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Info()
Visual C++
public:
Info()

Remarks

See Also

Info Class
MSBuild.Community.Tasks.Subversion Namespace


Info Methods

[image] [image]

.NET Framework Class Library
Info Methods
Info Class See Also Send Feedback

The Info type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

Info Class
MSBuild.Community.Tasks.Subversion Namespace


Info Properties

[image] [image]

.NET Framework Class Library
Info Properties
Info Class See Also Send Feedback

The Info type exposes the following members.

Properties

Name | Description
Entries |

See Also

Info Class
MSBuild.Community.Tasks.Subversion Namespace


Entries Property

[image]

.NET Framework Class Library
Info..::.Entries Property
Info Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Entries As EntryCollection
C#
public EntryCollection Entries { get; set; }
Visual C++
public:
property EntryCollection^ Entries {
    EntryCollection^ get ();
    void set (EntryCollection^ value);
}

Remarks

See Also

Info Class
MSBuild.Community.Tasks.Subversion Namespace


LastCommit Class

[image]

.NET Framework Class Library
LastCommit Class
Members See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class LastCommit
C#
public class LastCommit
Visual C++
public ref class LastCommit

Remarks

Inheritance Hierarchy

System..::.Object
MSBuild.Community.Tasks.Subversion..::.LastCommit

See Also

LastCommit Members
MSBuild.Community.Tasks.Subversion Namespace


LastCommit Members

[image] [image]

.NET Framework Class Library
LastCommit Members
LastCommit Class Constructors Methods Properties See Also Send Feedback

The LastCommit type exposes the following members.

Constructors

Name | Description
LastCommit |

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
Author |
Date |
DateSpecified |
Revision |

See Also

LastCommit Class
MSBuild.Community.Tasks.Subversion Namespace


LastCommit Constructor

[image]

.NET Framework Class Library
LastCommit Constructor
LastCommit Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LastCommit()
Visual C++
public:
LastCommit()

See Also

LastCommit Class
MSBuild.Community.Tasks.Subversion Namespace


LastCommit Methods

[image] [image]

.NET Framework Class Library
LastCommit Methods
LastCommit Class See Also Send Feedback

The LastCommit type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

LastCommit Class
MSBuild.Community.Tasks.Subversion Namespace


LastCommit Properties

[image] [image]

.NET Framework Class Library
LastCommit Properties
LastCommit Class See Also Send Feedback

The LastCommit type exposes the following members.

Properties

Name | Description
Author |
Date |
DateSpecified |
Revision |

See Also

LastCommit Class
MSBuild.Community.Tasks.Subversion Namespace


Author Property

[image]

.NET Framework Class Library
LastCommit..::.Author Property
LastCommit Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Author As String
C#
public string Author { get; set; }
Visual C++
public:
property String^ Author {
    String^ get ();
    void set (String^ value);
}

Remarks

See Also

LastCommit Class
MSBuild.Community.Tasks.Subversion Namespace


Date Property

[image]

.NET Framework Class Library
LastCommit..::.Date Property
LastCommit Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Date As DateTime
C#
public DateTime Date { get; set; }
Visual C++
public:
property DateTime Date {
    DateTime get ();
    void set (DateTime value);
}

Remarks

See Also

LastCommit Class
MSBuild.Community.Tasks.Subversion Namespace


DateSpecified Property

[image]

.NET Framework Class Library
LastCommit..::.DateSpecified Property
LastCommit Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property DateSpecified As Boolean
C#
public bool DateSpecified { get; set; }
Visual C++
public:
property bool DateSpecified {
    bool get ();
    void set (bool value);
}

Remarks

See Also

LastCommit Class
MSBuild.Community.Tasks.Subversion Namespace


Revision Property

[image]

.NET Framework Class Library
LastCommit..::.Revision Property
LastCommit Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Revision As Long
C#
public long Revision { get; set; }
Visual C++
public:
property long long Revision {
    long long get ();
    void set (long long value);
}

Remarks

See Also

LastCommit Class
MSBuild.Community.Tasks.Subversion Namespace


NodeKind Enumeration

[image]

.NET Framework Class Library
NodeKind Enumeration
See Also Send Feedback

The kind of Subversion node. The names match the text output by "svn info".

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration NodeKind
C#
public enum NodeKind
Visual C++
public enum class NodeKind

Members

Member name | Description
file | Node is a file
dir | Node is a directory
unknown | Unknown node type

See Also

MSBuild.Community.Tasks.Subversion Namespace


Repository Class

[image]

.NET Framework Class Library
Repository Class
Members See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class Repository
C#
public class Repository
Visual C++
public ref class Repository

Remarks

Inheritance Hierarchy

System..::.Object
MSBuild.Community.Tasks.Subversion..::.Repository

See Also

Repository Members
MSBuild.Community.Tasks.Subversion Namespace


Repository Members

[image] [image]

.NET Framework Class Library
Repository Members
Repository Class Constructors Methods Properties See Also Send Feedback

The Repository type exposes the following members.

Constructors

Name | Description
Repository |

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
Root |
Uuid |

See Also

Repository Class
MSBuild.Community.Tasks.Subversion Namespace


Repository Constructor

[image]

.NET Framework Class Library
Repository Constructor
Repository Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Repository()
Visual C++
public:
Repository()

See Also

Repository Class
MSBuild.Community.Tasks.Subversion Namespace


Repository Methods

[image] [image]

.NET Framework Class Library
Repository Methods
Repository Class See Also Send Feedback

The Repository type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

Repository Class
MSBuild.Community.Tasks.Subversion Namespace


Repository Properties

[image] [image]

.NET Framework Class Library
Repository Properties
Repository Class See Also Send Feedback

The Repository type exposes the following members.

Properties

Name | Description
Root |
Uuid |

See Also

Repository Class
MSBuild.Community.Tasks.Subversion Namespace


Root Property

[image]

.NET Framework Class Library
Repository..::.Root Property
Repository Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Root As String
C#
public string Root { get; set; }
Visual C++
public:
property String^ Root {
    String^ get ();
    void set (String^ value);
}

Remarks

See Also

Repository Class
MSBuild.Community.Tasks.Subversion Namespace


Uuid Property

[image]

.NET Framework Class Library
Repository..::.Uuid Property
Repository Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Uuid As String
C#
public string Uuid { get; set; }
Visual C++
public:
property String^ Uuid {
    String^ get ();
    void set (String^ value);
}

Remarks

See Also

Repository Class
MSBuild.Community.Tasks.Subversion Namespace


Schedule Enumeration

[image]

.NET Framework Class Library
Schedule Enumeration
See Also Send Feedback

The Subversion schedule type.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration Schedule
C#
public enum Schedule
Visual C++
public enum class Schedule

Members

Member name | Description
normal | Normal schedule
unknown | Unknown schedule.

See Also

MSBuild.Community.Tasks.Subversion Namespace


SvnCheckout Class

[image]

.NET Framework Class Library
SvnCheckout Class
Members Example See Also Send Feedback

Checkout a local working copy of a Subversion repository.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class SvnCheckout _
    Inherits SvnClient
C#
public class SvnCheckout : SvnClient
Visual C++
public ref class SvnCheckout : public SvnClient

Examples

Checkout a working copy
Copy Code
            <Target Name="Checkout">
              <RemoveDir Directories="$(MSBuildProjectDirectory)\Test\Checkout" />
              <SvnCheckout RepositoryPath="file:///d:/svn/repo/Test/trunk"
                           LocalPath="$(MSBuildProjectDirectory)\Test\Checkout">
                <Output TaskParameter="Revision" PropertyName="Revision" />
              </SvnCheckout>
              <Message Text="Revision: $(Revision)"/>
            </Target>

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
Microsoft.Build.Utilities..::.ToolTask
MSBuild.Community.Tasks.Subversion..::.SvnClient
MSBuild.Community.Tasks.Subversion..::.SvnCheckout

See Also

SvnCheckout Members
MSBuild.Community.Tasks.Subversion Namespace


SvnCheckout Members

[image] [image]

.NET Framework Class Library
SvnCheckout Members
SvnCheckout Class Constructors Methods Properties See Also Send Feedback

The SvnCheckout type exposes the following members.

Constructors

Name | Description
SvnCheckout | Initializes a new instance of the SvnCheckout class.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from SvnClient.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Inherited from SvnClient.)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Inherited from SvnClient.)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GenerateSvnArguments | Generates the SVN arguments. (Inherited from SvnClient.)
GenerateSvnCommand | Generates the SVN command. (Inherited from SvnClient.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | Logs the events from text output. (Inherited from SvnClient.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Inherited from SvnClient.)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | Indicates whether all task paratmeters are valid. (Overrides SvnClient..::.ValidateParameters()()().)

Properties

Name | Description
Arguments | Gets or sets the arguments. (Inherited from SvnClient.)
BuildEngine | (Inherited from Task.)
Command | Gets or sets the command. (Inherited from SvnClient.)
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
Force | Gets or sets the force. (Inherited from SvnClient.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
LocalPath | Gets or sets the local path. (Inherited from SvnClient.)
Log | (Inherited from Task.)
Message | Gets or sets the message. (Inherited from SvnClient.)
MessageFile | Gets or sets the message file. (Inherited from SvnClient.)
NoAuthCache | Gets or sets a value indicating no auth cache. (Inherited from SvnClient.)
NonInteractive | Gets or sets a value indicating the command is non interactive]. (Inherited from SvnClient.)
Password | Gets or sets the password. (Inherited from SvnClient.)
RepositoryPath | Gets or sets the repository path. (Inherited from SvnClient.)
ResponseFileEncoding | (Inherited from ToolTask.)
Revision | Gets or sets the revision. (Inherited from SvnClient.)
StandardError | Gets the error output of SVN command-line client. (Inherited from SvnClient.)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutput | Gets the output of SVN command-line client. (Inherited from SvnClient.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Inherited from SvnClient.)
TargetFile | Gets or sets the target file. (Inherited from SvnClient.)
Targets | Gets or sets the targets. (Inherited from SvnClient.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Inherited from SvnClient.)
ToolPath | (Inherited from ToolTask.)
TrustServerCert | Gets or sets a value indicating whether to trust the server cert. (Inherited from SvnClient.)
Username | Gets or sets the username. (Inherited from SvnClient.)
Verbose | Gets or sets the verbose. (Inherited from SvnClient.)
Xml | Gets or sets a value indicating the output is XML. (Inherited from SvnClient.)

See Also

SvnCheckout Class
MSBuild.Community.Tasks.Subversion Namespace


SvnCheckout Constructor

[image]

.NET Framework Class Library
SvnCheckout Constructor
SvnCheckout Class See Also Send Feedback

Initializes a new instance of the SvnCheckout class.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SvnCheckout()
Visual C++
public:
SvnCheckout()

See Also

SvnCheckout Class
MSBuild.Community.Tasks.Subversion Namespace


SvnCheckout Methods

[image] [image]

.NET Framework Class Library
SvnCheckout Methods
SvnCheckout Class See Also Send Feedback

The SvnCheckout type exposes the following members.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from SvnClient.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Inherited from SvnClient.)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Inherited from SvnClient.)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GenerateSvnArguments | Generates the SVN arguments. (Inherited from SvnClient.)
GenerateSvnCommand | Generates the SVN command. (Inherited from SvnClient.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | Logs the events from text output. (Inherited from SvnClient.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Inherited from SvnClient.)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | Indicates whether all task paratmeters are valid. (Overrides SvnClient..::.ValidateParameters()()().)

See Also

SvnCheckout Class
MSBuild.Community.Tasks.Subversion Namespace


ValidateParameters Method

[image]

.NET Framework Class Library
SvnCheckout..::.ValidateParameters Method
SvnCheckout Class See Also Send Feedback

Indicates whether all task paratmeters are valid.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function ValidateParameters As Boolean
C#
protected override bool ValidateParameters()
Visual C++
protected:
virtual bool ValidateParameters() override

Return Value

true if all task parameters are valid; otherwise, false.

See Also

SvnCheckout Class
MSBuild.Community.Tasks.Subversion Namespace


SvnCheckout Properties

[image] [image]

.NET Framework Class Library
SvnCheckout Properties
SvnCheckout Class See Also Send Feedback

The SvnCheckout type exposes the following members.

Properties

Name | Description
Arguments | Gets or sets the arguments. (Inherited from SvnClient.)
BuildEngine | (Inherited from Task.)
Command | Gets or sets the command. (Inherited from SvnClient.)
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
Force | Gets or sets the force. (Inherited from SvnClient.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
LocalPath | Gets or sets the local path. (Inherited from SvnClient.)
Log | (Inherited from Task.)
Message | Gets or sets the message. (Inherited from SvnClient.)
MessageFile | Gets or sets the message file. (Inherited from SvnClient.)
NoAuthCache | Gets or sets a value indicating no auth cache. (Inherited from SvnClient.)
NonInteractive | Gets or sets a value indicating the command is non interactive]. (Inherited from SvnClient.)
Password | Gets or sets the password. (Inherited from SvnClient.)
RepositoryPath | Gets or sets the repository path. (Inherited from SvnClient.)
ResponseFileEncoding | (Inherited from ToolTask.)
Revision | Gets or sets the revision. (Inherited from SvnClient.)
StandardError | Gets the error output of SVN command-line client. (Inherited from SvnClient.)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutput | Gets the output of SVN command-line client. (Inherited from SvnClient.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Inherited from SvnClient.)
TargetFile | Gets or sets the target file. (Inherited from SvnClient.)
Targets | Gets or sets the targets. (Inherited from SvnClient.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Inherited from SvnClient.)
ToolPath | (Inherited from ToolTask.)
TrustServerCert | Gets or sets a value indicating whether to trust the server cert. (Inherited from SvnClient.)
Username | Gets or sets the username. (Inherited from SvnClient.)
Verbose | Gets or sets the verbose. (Inherited from SvnClient.)
Xml | Gets or sets a value indicating the output is XML. (Inherited from SvnClient.)

See Also

SvnCheckout Class
MSBuild.Community.Tasks.Subversion Namespace


SvnClient Class

[image]

.NET Framework Class Library
SvnClient Class
Members See Also Send Feedback

Subversion client base class

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class SvnClient _
    Inherits ToolTask
C#
public class SvnClient : ToolTask
Visual C++
public ref class SvnClient : public ToolTask

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
Microsoft.Build.Utilities..::.ToolTask
MSBuild.Community.Tasks.Subversion..::.SvnClient
MSBuild.Community.Tasks.Subversion..::.SvnCheckout
MSBuild.Community.Tasks.Subversion..::.SvnCommit
MSBuild.Community.Tasks.Subversion..::.SvnCopy
MSBuild.Community.Tasks.Subversion..::.SvnExport
MSBuild.Community.Tasks.Subversion..::.SvnInfo
MSBuild.Community.Tasks.Subversion..::.SvnUpdate

See Also

SvnClient Members
MSBuild.Community.Tasks.Subversion Namespace


SvnClient Members

[image] [image]

.NET Framework Class Library
SvnClient Members
SvnClient Class Constructors Methods Properties See Also Send Feedback

The SvnClient type exposes the following members.

Constructors

Name | Description
SvnClient |

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Overrides ToolTask..::.Execute()()().)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
FindToolPath | Finds the tool path.
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GenerateSvnArguments | Generates the SVN arguments.
GenerateSvnCommand | Generates the SVN command.
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | Logs the events from text output. (Overrides ToolTask..::.LogEventsFromTextOutput(String, MessageImportance).)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Overrides ToolTask..::.LogToolCommand(String).)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | Indicates whether all task paratmeters are valid. (Overrides ToolTask..::.ValidateParameters()()().)

Properties

Name | Description
Arguments | Gets or sets the arguments.
BuildEngine | (Inherited from Task.)
Command | Gets or sets the command.
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
Force | Gets or sets the force.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
LocalPath | Gets or sets the local path.
Log | (Inherited from Task.)
Message | Gets or sets the message.
MessageFile | Gets or sets the message file.
NoAuthCache | Gets or sets a value indicating no auth cache.
NonInteractive | Gets or sets a value indicating the command is non interactive].
Password | Gets or sets the password.
RepositoryPath | Gets or sets the repository path.
ResponseFileEncoding | (Inherited from ToolTask.)
Revision | Gets or sets the revision.
StandardError | Gets the error output of SVN command-line client.
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutput | Gets the output of SVN command-line client.
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Overrides ToolTask..::.StandardOutputLoggingImportance.)
TargetFile | Gets or sets the target file.
Targets | Gets or sets the targets.
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)
TrustServerCert | Gets or sets a value indicating whether to trust the server cert.
Username | Gets or sets the username.
Verbose | Gets or sets the verbose.
Xml | Gets or sets a value indicating the output is XML.

See Also

SvnClient Class
MSBuild.Community.Tasks.Subversion Namespace


SvnClient Constructor

[image]

.NET Framework Class Library
SvnClient Constructor
SvnClient Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SvnClient()
Visual C++
public:
SvnClient()

See Also

SvnClient Class
MSBuild.Community.Tasks.Subversion Namespace


SvnClient Methods

[image] [image]

.NET Framework Class Library
SvnClient Methods
SvnClient Class See Also Send Feedback

The SvnClient type exposes the following members.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Overrides ToolTask..::.Execute()()().)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
FindToolPath | Finds the tool path.
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GenerateSvnArguments | Generates the SVN arguments.
GenerateSvnCommand | Generates the SVN command.
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | Logs the events from text output. (Overrides ToolTask..::.LogEventsFromTextOutput(String, MessageImportance).)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Overrides ToolTask..::.LogToolCommand(String).)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | Indicates whether all task paratmeters are valid. (Overrides ToolTask..::.ValidateParameters()()().)

See Also

SvnClient Class
MSBuild.Community.Tasks.Subversion Namespace


Execute Method

[image]

.NET Framework Class Library
SvnClient..::.Execute Method
SvnClient Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Implements

ITask..::.Execute()()()

See Also

SvnClient Class
MSBuild.Community.Tasks.Subversion Namespace


FindToolPath Method

[image]

.NET Framework Class Library
SvnClient..::.FindToolPath Method
SvnClient Class See Also Send Feedback

Finds the tool path.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function FindToolPath ( _
    toolName As String _
) As String
C#
public static string FindToolPath(
    string toolName
)
Visual C++
public:
static String^ FindToolPath(
    String^ toolName
)

Parameters

toolName
Type: System..::.String
Name of the tool.

Return Value

See Also

SvnClient Class
MSBuild.Community.Tasks.Subversion Namespace


GenerateCommandLineCommands Method

[image]

.NET Framework Class Library
SvnClient..::.GenerateCommandLineCommands Method
SvnClient Class See Also Send Feedback

Returns a string value containing the command line arguments to pass directly to the executable file.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateCommandLineCommands As String
C#
protected override string GenerateCommandLineCommands()
Visual C++
protected:
virtual String^ GenerateCommandLineCommands() override

Return Value

A string value containing the command line arguments to pass directly to the executable file.

See Also

SvnClient Class
MSBuild.Community.Tasks.Subversion Namespace


GenerateFullPathToTool Method

[image]

.NET Framework Class Library
SvnClient..::.GenerateFullPathToTool Method
SvnClient Class See Also Send Feedback

Returns the fully qualified path to the executable file.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateFullPathToTool As String
C#
protected override string GenerateFullPathToTool()
Visual C++
protected:
virtual String^ GenerateFullPathToTool() override

Return Value

The fully qualified path to the executable file.

See Also

SvnClient Class
MSBuild.Community.Tasks.Subversion Namespace


GenerateSvnArguments Method

[image]

.NET Framework Class Library
SvnClient..::.GenerateSvnArguments Method
SvnClient Class See Also Send Feedback

Generates the SVN arguments.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function GenerateSvnArguments As String
C#
protected virtual string GenerateSvnArguments()
Visual C++
protected:
virtual String^ GenerateSvnArguments()

Return Value

See Also

SvnClient Class
MSBuild.Community.Tasks.Subversion Namespace


GenerateSvnCommand Method

[image]

.NET Framework Class Library
SvnClient..::.GenerateSvnCommand Method
SvnClient Class See Also Send Feedback

Generates the SVN command.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function GenerateSvnCommand As String
C#
protected virtual string GenerateSvnCommand()
Visual C++
protected:
virtual String^ GenerateSvnCommand()

Return Value

See Also

SvnClient Class
MSBuild.Community.Tasks.Subversion Namespace


LogEventsFromTextOutput Method

[image]

.NET Framework Class Library
SvnClient..::.LogEventsFromTextOutput Method
SvnClient Class See Also Send Feedback

Logs the events from text output.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub LogEventsFromTextOutput ( _
    singleLine As String, _
    messageImportance As MessageImportance _
)
C#
protected override void LogEventsFromTextOutput(
    string singleLine,
    MessageImportance messageImportance
)
Visual C++
protected:
virtual void LogEventsFromTextOutput(
    String^ singleLine,
    MessageImportance messageImportance
) override

Parameters

singleLine
Type: System..::.String
The single line.
messageImportance
Type: Microsoft.Build.Framework..::.MessageImportance
The message importance.

See Also

SvnClient Class
MSBuild.Community.Tasks.Subversion Namespace


LogToolCommand Method

[image]

.NET Framework Class Library
SvnClient..::.LogToolCommand Method
SvnClient Class See Also Send Feedback

Logs the starting point of the run to all registered loggers.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub LogToolCommand ( _
    message As String _
)
C#
protected override void LogToolCommand(
    string message
)
Visual C++
protected:
virtual void LogToolCommand(
    String^ message
) override

Parameters

message
Type: System..::.String
A descriptive message to provide loggers, usually the command line and switches.

See Also

SvnClient Class
MSBuild.Community.Tasks.Subversion Namespace


ValidateParameters Method

[image]

.NET Framework Class Library
SvnClient..::.ValidateParameters Method
SvnClient Class See Also Send Feedback

Indicates whether all task paratmeters are valid.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function ValidateParameters As Boolean
C#
protected override bool ValidateParameters()
Visual C++
protected:
virtual bool ValidateParameters() override

Return Value

true if all task parameters are valid; otherwise, false.

See Also

SvnClient Class
MSBuild.Community.Tasks.Subversion Namespace


SvnClient Properties

[image] [image]

.NET Framework Class Library
SvnClient Properties
SvnClient Class See Also Send Feedback

The SvnClient type exposes the following members.

Properties

Name | Description
Arguments | Gets or sets the arguments.
BuildEngine | (Inherited from Task.)
Command | Gets or sets the command.
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
Force | Gets or sets the force.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
LocalPath | Gets or sets the local path.
Log | (Inherited from Task.)
Message | Gets or sets the message.
MessageFile | Gets or sets the message file.
NoAuthCache | Gets or sets a value indicating no auth cache.
NonInteractive | Gets or sets a value indicating the command is non interactive].
Password | Gets or sets the password.
RepositoryPath | Gets or sets the repository path.
ResponseFileEncoding | (Inherited from ToolTask.)
Revision | Gets or sets the revision.
StandardError | Gets the error output of SVN command-line client.
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutput | Gets the output of SVN command-line client.
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Overrides ToolTask..::.StandardOutputLoggingImportance.)
TargetFile | Gets or sets the target file.
Targets | Gets or sets the targets.
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)
TrustServerCert | Gets or sets a value indicating whether to trust the server cert.
Username | Gets or sets the username.
Verbose | Gets or sets the verbose.
Xml | Gets or sets a value indicating the output is XML.

See Also

SvnClient Class
MSBuild.Community.Tasks.Subversion Namespace


Arguments Property

[image]

.NET Framework Class Library
SvnClient..::.Arguments Property
SvnClient Class See Also Send Feedback

Gets or sets the arguments.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Arguments As String
C#
public string Arguments { get; set; }
Visual C++
public:
property String^ Arguments {
    String^ get ();
    void set (String^ value);
}

Field Value

The arguments.

See Also

SvnClient Class
MSBuild.Community.Tasks.Subversion Namespace


Command Property

[image]

.NET Framework Class Library
SvnClient..::.Command Property
SvnClient Class See Also Send Feedback

Gets or sets the command.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Command As String
C#
public string Command { get; set; }
Visual C++
public:
property String^ Command {
    String^ get ();
    void set (String^ value);
}

Field Value

The command.

See Also

SvnClient Class
MSBuild.Community.Tasks.Subversion Namespace


Force Property

[image]

.NET Framework Class Library
SvnClient..::.Force Property
SvnClient Class See Also Send Feedback

Gets or sets the force.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Force As Boolean
C#
public bool Force { get; set; }
Visual C++
public:
property bool Force {
    bool get ();
    void set (bool value);
}

Field Value

The force.

See Also

SvnClient Class
MSBuild.Community.Tasks.Subversion Namespace


LocalPath Property

[image]

.NET Framework Class Library
SvnClient..::.LocalPath Property
SvnClient Class See Also Send Feedback

Gets or sets the local path.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property LocalPath As String
C#
public string LocalPath { get; set; }
Visual C++
public:
property String^ LocalPath {
    String^ get ();
    void set (String^ value);
}

Field Value

The local path.

See Also

SvnClient Class
MSBuild.Community.Tasks.Subversion Namespace


Message Property

[image]

.NET Framework Class Library
SvnClient..::.Message Property
SvnClient Class See Also Send Feedback

Gets or sets the message.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Message As String
C#
public string Message { get; set; }
Visual C++
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}

Field Value

The message.

See Also

SvnClient Class
MSBuild.Community.Tasks.Subversion Namespace


MessageFile Property

[image]

.NET Framework Class Library
SvnClient..::.MessageFile Property
SvnClient Class See Also Send Feedback

Gets or sets the message file.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property MessageFile As String
C#
public string MessageFile { get; set; }
Visual C++
public:
property String^ MessageFile {
    String^ get ();
    void set (String^ value);
}

Field Value

The message file.

Remarks

Uses the contents of the named file for the specified subcommand, though different subcommands do different things with this content.

See Also

SvnClient Class
MSBuild.Community.Tasks.Subversion Namespace


NoAuthCache Property

[image]

.NET Framework Class Library
SvnClient..::.NoAuthCache Property
SvnClient Class See Also Send Feedback

Gets or sets a value indicating no auth cache.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property NoAuthCache As Boolean
C#
public bool NoAuthCache { get; set; }
Visual C++
public:
property bool NoAuthCache {
    bool get ();
    void set (bool value);
}

Field Value

true if no auth cache; otherwise, false.

See Also

SvnClient Class
MSBuild.Community.Tasks.Subversion Namespace


NonInteractive Property

[image]

.NET Framework Class Library
SvnClient..::.NonInteractive Property
SvnClient Class See Also Send Feedback

Gets or sets a value indicating the command is non interactive].

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property NonInteractive As Boolean
C#
public bool NonInteractive { get; set; }
Visual C++
public:
property bool NonInteractive {
    bool get ();
    void set (bool value);
}

Field Value

true if non interactive; otherwise, false.

See Also

SvnClient Class
MSBuild.Community.Tasks.Subversion Namespace


Password Property

[image]

.NET Framework Class Library
SvnClient..::.Password Property
SvnClient Class See Also Send Feedback

Gets or sets the password.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password { get; set; }
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

Field Value

The password.

See Also

SvnClient Class
MSBuild.Community.Tasks.Subversion Namespace


RepositoryPath Property

[image]

.NET Framework Class Library
SvnClient..::.RepositoryPath Property
SvnClient Class See Also Send Feedback

Gets or sets the repository path.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public Property RepositoryPath As String
C#
[OutputAttribute]
public string RepositoryPath { get; set; }
Visual C++
[OutputAttribute]
public:
property String^ RepositoryPath {
    String^ get ();
    void set (String^ value);
}

Field Value

The repository path.

See Also

SvnClient Class
MSBuild.Community.Tasks.Subversion Namespace


Revision Property

[image]

.NET Framework Class Library
SvnClient..::.Revision Property
SvnClient Class See Also Send Feedback

Gets or sets the revision.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public Property Revision As Integer
C#
[OutputAttribute]
public int Revision { get; set; }
Visual C++
[OutputAttribute]
public:
property int Revision {
    int get ();
    void set (int value);
}

Field Value

The revision.

See Also

SvnClient Class
MSBuild.Community.Tasks.Subversion Namespace


StandardError Property

[image]

.NET Framework Class Library
SvnClient..::.StandardError Property
SvnClient Class See Also Send Feedback

Gets the error output of SVN command-line client.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property StandardError As String
C#
[OutputAttribute]
public string StandardError { get; }
Visual C++
[OutputAttribute]
public:
property String^ StandardError {
    String^ get ();
}

See Also

SvnClient Class
MSBuild.Community.Tasks.Subversion Namespace


StandardOutput Property

[image]

.NET Framework Class Library
SvnClient..::.StandardOutput Property
SvnClient Class See Also Send Feedback

Gets the output of SVN command-line client.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property StandardOutput As String
C#
[OutputAttribute]
public string StandardOutput { get; }
Visual C++
[OutputAttribute]
public:
property String^ StandardOutput {
    String^ get ();
}

See Also

SvnClient Class
MSBuild.Community.Tasks.Subversion Namespace


StandardOutputLoggingImportance Property

[image]

.NET Framework Class Library
SvnClient..::.StandardOutputLoggingImportance Property
SvnClient Class See Also Send Feedback

Gets the MessageImportance with which to log errors.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property StandardOutputLoggingImportance As MessageImportance
C#
protected override MessageImportance StandardOutputLoggingImportance { get; }
Visual C++
protected:
virtual property MessageImportance StandardOutputLoggingImportance {
    MessageImportance get () override;
}

Field Value

Return Value

The MessageImportance with which to log errors.

See Also

SvnClient Class
MSBuild.Community.Tasks.Subversion Namespace


TargetFile Property

[image]

.NET Framework Class Library
SvnClient..::.TargetFile Property
SvnClient Class See Also Send Feedback

Gets or sets the target file.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property TargetFile As String
C#
public string TargetFile { get; set; }
Visual C++
public:
property String^ TargetFile {
    String^ get ();
    void set (String^ value);
}

Field Value

The target file.

Remarks

Tells Subversion to get the list of files that you wish to operate on from the filename that you provide instead of listing all the files on the command line.

See Also

SvnClient Class
MSBuild.Community.Tasks.Subversion Namespace


Targets Property

[image]

.NET Framework Class Library
SvnClient..::.Targets Property
SvnClient Class See Also Send Feedback

Gets or sets the targets.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Targets As ITaskItem()
C#
public ITaskItem[] Targets { get; set; }
Visual C++
public:
property array<ITaskItem^>^ Targets {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

Field Value

The targets.

See Also

SvnClient Class
MSBuild.Community.Tasks.Subversion Namespace


ToolName Property

[image]

.NET Framework Class Library
SvnClient..::.ToolName Property
SvnClient Class See Also Send Feedback

Gets the name of the executable file to run.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ToolName As String
C#
protected override string ToolName { get; }
Visual C++
protected:
virtual property String^ ToolName {
    String^ get () override;
}

Field Value

Return Value

The name of the executable file to run.

See Also

SvnClient Class
MSBuild.Community.Tasks.Subversion Namespace


TrustServerCert Property

[image]

.NET Framework Class Library
SvnClient..::.TrustServerCert Property
SvnClient Class See Also Send Feedback

Gets or sets a value indicating whether to trust the server cert.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property TrustServerCert As Boolean
C#
public bool TrustServerCert { get; set; }
Visual C++
public:
property bool TrustServerCert {
    bool get ();
    void set (bool value);
}

Field Value

true to trust the server cert; otherwise, false.

See Also

SvnClient Class
MSBuild.Community.Tasks.Subversion Namespace


Username Property

[image]

.NET Framework Class Library
SvnClient..::.Username Property
SvnClient Class See Also Send Feedback

Gets or sets the username.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Username As String
C#
public string Username { get; set; }
Visual C++
public:
property String^ Username {
    String^ get ();
    void set (String^ value);
}

Field Value

The username.

See Also

SvnClient Class
MSBuild.Community.Tasks.Subversion Namespace


Verbose Property

[image]

.NET Framework Class Library
SvnClient..::.Verbose Property
SvnClient Class See Also Send Feedback

Gets or sets the verbose.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Verbose As Boolean
C#
public bool Verbose { get; set; }
Visual C++
public:
property bool Verbose {
    bool get ();
    void set (bool value);
}

Field Value

The verbose.

See Also

SvnClient Class
MSBuild.Community.Tasks.Subversion Namespace


Xml Property

[image]

.NET Framework Class Library
SvnClient..::.Xml Property
SvnClient Class See Also Send Feedback

Gets or sets a value indicating the output is XML.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Xml As Boolean
C#
public bool Xml { get; set; }
Visual C++
public:
property bool Xml {
    bool get ();
    void set (bool value);
}

Field Value

true to output in XML; otherwise, false.

See Also

SvnClient Class
MSBuild.Community.Tasks.Subversion Namespace


SvnCommit Class

[image]

.NET Framework Class Library
SvnCommit Class
Members See Also Send Feedback

Subversion Commit command

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class SvnCommit _
    Inherits SvnClient
C#
public class SvnCommit : SvnClient
Visual C++
public ref class SvnCommit : public SvnClient

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
Microsoft.Build.Utilities..::.ToolTask
MSBuild.Community.Tasks.Subversion..::.SvnClient
MSBuild.Community.Tasks.Subversion..::.SvnCommit

See Also

SvnCommit Members
MSBuild.Community.Tasks.Subversion Namespace


SvnCommit Members

[image] [image]

.NET Framework Class Library
SvnCommit Members
SvnCommit Class Constructors Methods Properties See Also Send Feedback

The SvnCommit type exposes the following members.

Constructors

Name | Description
SvnCommit | Initializes a new instance of the SvnCommit class.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from SvnClient.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Inherited from SvnClient.)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Inherited from SvnClient.)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GenerateSvnArguments | Generates the SVN arguments. (Inherited from SvnClient.)
GenerateSvnCommand | Generates the SVN command. (Inherited from SvnClient.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | Logs the events from text output. (Inherited from SvnClient.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Inherited from SvnClient.)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | Indicates whether all task paratmeters are valid. (Overrides SvnClient..::.ValidateParameters()()().)

Properties

Name | Description
Arguments | Gets or sets the arguments. (Inherited from SvnClient.)
BuildEngine | (Inherited from Task.)
Command | Gets or sets the command. (Inherited from SvnClient.)
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
Force | Gets or sets the force. (Inherited from SvnClient.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
LocalPath | Gets or sets the local path. (Inherited from SvnClient.)
Log | (Inherited from Task.)
Message | Gets or sets the message. (Inherited from SvnClient.)
MessageFile | Gets or sets the message file. (Inherited from SvnClient.)
NoAuthCache | Gets or sets a value indicating no auth cache. (Inherited from SvnClient.)
NonInteractive | Gets or sets a value indicating the command is non interactive]. (Inherited from SvnClient.)
Password | Gets or sets the password. (Inherited from SvnClient.)
RepositoryPath | Gets or sets the repository path. (Inherited from SvnClient.)
ResponseFileEncoding | (Inherited from ToolTask.)
Revision | Gets or sets the revision. (Inherited from SvnClient.)
StandardError | Gets the error output of SVN command-line client. (Inherited from SvnClient.)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutput | Gets the output of SVN command-line client. (Inherited from SvnClient.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Inherited from SvnClient.)
TargetFile | Gets or sets the target file. (Inherited from SvnClient.)
Targets | Gets or sets the targets. (Inherited from SvnClient.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Inherited from SvnClient.)
ToolPath | (Inherited from ToolTask.)
TrustServerCert | Gets or sets a value indicating whether to trust the server cert. (Inherited from SvnClient.)
Username | Gets or sets the username. (Inherited from SvnClient.)
Verbose | Gets or sets the verbose. (Inherited from SvnClient.)
Xml | Gets or sets a value indicating the output is XML. (Inherited from SvnClient.)

See Also

SvnCommit Class
MSBuild.Community.Tasks.Subversion Namespace


SvnCommit Constructor

[image]

.NET Framework Class Library
SvnCommit Constructor
SvnCommit Class See Also Send Feedback

Initializes a new instance of the SvnCommit class.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SvnCommit()
Visual C++
public:
SvnCommit()

See Also

SvnCommit Class
MSBuild.Community.Tasks.Subversion Namespace


SvnCommit Methods

[image] [image]

.NET Framework Class Library
SvnCommit Methods
SvnCommit Class See Also Send Feedback

The SvnCommit type exposes the following members.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from SvnClient.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Inherited from SvnClient.)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Inherited from SvnClient.)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GenerateSvnArguments | Generates the SVN arguments. (Inherited from SvnClient.)
GenerateSvnCommand | Generates the SVN command. (Inherited from SvnClient.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | Logs the events from text output. (Inherited from SvnClient.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Inherited from SvnClient.)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | Indicates whether all task paratmeters are valid. (Overrides SvnClient..::.ValidateParameters()()().)

See Also

SvnCommit Class
MSBuild.Community.Tasks.Subversion Namespace


ValidateParameters Method

[image]

.NET Framework Class Library
SvnCommit..::.ValidateParameters Method
SvnCommit Class See Also Send Feedback

Indicates whether all task paratmeters are valid.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function ValidateParameters As Boolean
C#
protected override bool ValidateParameters()
Visual C++
protected:
virtual bool ValidateParameters() override

Return Value

true if all task parameters are valid; otherwise, false.

See Also

SvnCommit Class
MSBuild.Community.Tasks.Subversion Namespace


SvnCommit Properties

[image] [image]

.NET Framework Class Library
SvnCommit Properties
SvnCommit Class See Also Send Feedback

The SvnCommit type exposes the following members.

Properties

Name | Description
Arguments | Gets or sets the arguments. (Inherited from SvnClient.)
BuildEngine | (Inherited from Task.)
Command | Gets or sets the command. (Inherited from SvnClient.)
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
Force | Gets or sets the force. (Inherited from SvnClient.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
LocalPath | Gets or sets the local path. (Inherited from SvnClient.)
Log | (Inherited from Task.)
Message | Gets or sets the message. (Inherited from SvnClient.)
MessageFile | Gets or sets the message file. (Inherited from SvnClient.)
NoAuthCache | Gets or sets a value indicating no auth cache. (Inherited from SvnClient.)
NonInteractive | Gets or sets a value indicating the command is non interactive]. (Inherited from SvnClient.)
Password | Gets or sets the password. (Inherited from SvnClient.)
RepositoryPath | Gets or sets the repository path. (Inherited from SvnClient.)
ResponseFileEncoding | (Inherited from ToolTask.)
Revision | Gets or sets the revision. (Inherited from SvnClient.)
StandardError | Gets the error output of SVN command-line client. (Inherited from SvnClient.)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutput | Gets the output of SVN command-line client. (Inherited from SvnClient.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Inherited from SvnClient.)
TargetFile | Gets or sets the target file. (Inherited from SvnClient.)
Targets | Gets or sets the targets. (Inherited from SvnClient.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Inherited from SvnClient.)
ToolPath | (Inherited from ToolTask.)
TrustServerCert | Gets or sets a value indicating whether to trust the server cert. (Inherited from SvnClient.)
Username | Gets or sets the username. (Inherited from SvnClient.)
Verbose | Gets or sets the verbose. (Inherited from SvnClient.)
Xml | Gets or sets a value indicating the output is XML. (Inherited from SvnClient.)

See Also

SvnCommit Class
MSBuild.Community.Tasks.Subversion Namespace


SvnCopy Class

[image]

.NET Framework Class Library
SvnCopy Class
Members Example See Also Send Feedback

Copy a file or folder in Subversion

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class SvnCopy _
    Inherits SvnClient
C#
public class SvnCopy : SvnClient
Visual C++
public ref class SvnCopy : public SvnClient

Remarks

This is most useful for automatically tagging your source code during a build. You can create a tag by copying a path from one server location to another.

Examples

Create a tag of the trunk with the current Cruise Control build number:
Copy Code
            <Target Name="TagTheBuild">
              <SvnCopy SourcePath="file:///d:/svn/repo/Test/trunk"
                       DestinationPath="file:///d:/svn/repo/Test/tags/BUILD-$(CCNetLabel)"
                       Message="Automatic build of $(CCNetProject)" />
            </Target>

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
Microsoft.Build.Utilities..::.ToolTask
MSBuild.Community.Tasks.Subversion..::.SvnClient
MSBuild.Community.Tasks.Subversion..::.SvnCopy

See Also

SvnCopy Members
MSBuild.Community.Tasks.Subversion Namespace


SvnCopy Members

[image] [image]

.NET Framework Class Library
SvnCopy Members
SvnCopy Class Constructors Methods Properties See Also Send Feedback

The SvnCopy type exposes the following members.

Constructors

Name | Description
SvnCopy | Initializes a new instance of the SvnCopy class.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from SvnClient.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Inherited from SvnClient.)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Inherited from SvnClient.)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GenerateSvnArguments | Generates the SVN arguments. (Inherited from SvnClient.)
GenerateSvnCommand | Generates the SVN command. (Overrides SvnClient..::.GenerateSvnCommand()()().)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | Logs the events from text output. (Inherited from SvnClient.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Inherited from SvnClient.)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | Indicates whether all task paratmeters are valid. (Overrides SvnClient..::.ValidateParameters()()().)

Properties

Name | Description
Arguments | Gets or sets the arguments. (Inherited from SvnClient.)
BuildEngine | (Inherited from Task.)
Command | Gets or sets the command. (Inherited from SvnClient.)
DestinationPath | The path to which the SourcePath should be copied
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
Force | Gets or sets the force. (Inherited from SvnClient.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
LocalPath | Gets or sets the local path. (Inherited from SvnClient.)
Log | (Inherited from Task.)
Message | Gets or sets the message. (Inherited from SvnClient.)
MessageFile | Gets or sets the message file. (Inherited from SvnClient.)
NoAuthCache | Gets or sets a value indicating no auth cache. (Inherited from SvnClient.)
NonInteractive | Gets or sets a value indicating the command is non interactive]. (Inherited from SvnClient.)
Password | Gets or sets the password. (Inherited from SvnClient.)
RepositoryPath | Gets or sets the repository path. (Inherited from SvnClient.)
ResponseFileEncoding | (Inherited from ToolTask.)
Revision | Gets or sets the revision. (Inherited from SvnClient.)
SourcePath | The path of the source file or folder that should be copied
StandardError | Gets the error output of SVN command-line client. (Inherited from SvnClient.)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutput | Gets the output of SVN command-line client. (Inherited from SvnClient.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Inherited from SvnClient.)
TargetFile | Gets or sets the target file. (Inherited from SvnClient.)
Targets | Gets or sets the targets. (Inherited from SvnClient.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Inherited from SvnClient.)
ToolPath | (Inherited from ToolTask.)
TrustServerCert | Gets or sets a value indicating whether to trust the server cert. (Inherited from SvnClient.)
Username | Gets or sets the username. (Inherited from SvnClient.)
Verbose | Gets or sets the verbose. (Inherited from SvnClient.)
Xml | Gets or sets a value indicating the output is XML. (Inherited from SvnClient.)

See Also

SvnCopy Class
MSBuild.Community.Tasks.Subversion Namespace


SvnCopy Constructor

[image]

.NET Framework Class Library
SvnCopy Constructor
SvnCopy Class See Also Send Feedback

Initializes a new instance of the SvnCopy class.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SvnCopy()
Visual C++
public:
SvnCopy()

See Also

SvnCopy Class
MSBuild.Community.Tasks.Subversion Namespace


SvnCopy Methods

[image] [image]

.NET Framework Class Library
SvnCopy Methods
SvnCopy Class See Also Send Feedback

The SvnCopy type exposes the following members.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from SvnClient.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Inherited from SvnClient.)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Inherited from SvnClient.)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GenerateSvnArguments | Generates the SVN arguments. (Inherited from SvnClient.)
GenerateSvnCommand | Generates the SVN command. (Overrides SvnClient..::.GenerateSvnCommand()()().)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | Logs the events from text output. (Inherited from SvnClient.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Inherited from SvnClient.)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | Indicates whether all task paratmeters are valid. (Overrides SvnClient..::.ValidateParameters()()().)

See Also

SvnCopy Class
MSBuild.Community.Tasks.Subversion Namespace


GenerateSvnCommand Method

[image]

.NET Framework Class Library
SvnCopy..::.GenerateSvnCommand Method
SvnCopy Class See Also Send Feedback

Generates the SVN command.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateSvnCommand As String
C#
protected override string GenerateSvnCommand()
Visual C++
protected:
virtual String^ GenerateSvnCommand() override

Return Value

See Also

SvnCopy Class
MSBuild.Community.Tasks.Subversion Namespace


ValidateParameters Method

[image]

.NET Framework Class Library
SvnCopy..::.ValidateParameters Method
SvnCopy Class See Also Send Feedback

Indicates whether all task paratmeters are valid.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function ValidateParameters As Boolean
C#
protected override bool ValidateParameters()
Visual C++
protected:
virtual bool ValidateParameters() override

Return Value

true if all task parameters are valid; otherwise, false.

See Also

SvnCopy Class
MSBuild.Community.Tasks.Subversion Namespace


SvnCopy Properties

[image] [image]

.NET Framework Class Library
SvnCopy Properties
SvnCopy Class See Also Send Feedback

The SvnCopy type exposes the following members.

Properties

Name | Description
Arguments | Gets or sets the arguments. (Inherited from SvnClient.)
BuildEngine | (Inherited from Task.)
Command | Gets or sets the command. (Inherited from SvnClient.)
DestinationPath | The path to which the SourcePath should be copied
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
Force | Gets or sets the force. (Inherited from SvnClient.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
LocalPath | Gets or sets the local path. (Inherited from SvnClient.)
Log | (Inherited from Task.)
Message | Gets or sets the message. (Inherited from SvnClient.)
MessageFile | Gets or sets the message file. (Inherited from SvnClient.)
NoAuthCache | Gets or sets a value indicating no auth cache. (Inherited from SvnClient.)
NonInteractive | Gets or sets a value indicating the command is non interactive]. (Inherited from SvnClient.)
Password | Gets or sets the password. (Inherited from SvnClient.)
RepositoryPath | Gets or sets the repository path. (Inherited from SvnClient.)
ResponseFileEncoding | (Inherited from ToolTask.)
Revision | Gets or sets the revision. (Inherited from SvnClient.)
SourcePath | The path of the source file or folder that should be copied
StandardError | Gets the error output of SVN command-line client. (Inherited from SvnClient.)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutput | Gets the output of SVN command-line client. (Inherited from SvnClient.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Inherited from SvnClient.)
TargetFile | Gets or sets the target file. (Inherited from SvnClient.)
Targets | Gets or sets the targets. (Inherited from SvnClient.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Inherited from SvnClient.)
ToolPath | (Inherited from ToolTask.)
TrustServerCert | Gets or sets a value indicating whether to trust the server cert. (Inherited from SvnClient.)
Username | Gets or sets the username. (Inherited from SvnClient.)
Verbose | Gets or sets the verbose. (Inherited from SvnClient.)
Xml | Gets or sets a value indicating the output is XML. (Inherited from SvnClient.)

See Also

SvnCopy Class
MSBuild.Community.Tasks.Subversion Namespace


DestinationPath Property

[image]

.NET Framework Class Library
SvnCopy..::.DestinationPath Property
SvnCopy Class See Also Send Feedback

The path to which the SourcePath should be copied

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property DestinationPath As String
C#
public string DestinationPath { get; set; }
Visual C++
public:
property String^ DestinationPath {
    String^ get ();
    void set (String^ value);
}

See Also

SvnCopy Class
MSBuild.Community.Tasks.Subversion Namespace


SourcePath Property

[image]

.NET Framework Class Library
SvnCopy..::.SourcePath Property
SvnCopy Class See Also Send Feedback

The path of the source file or folder that should be copied

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property SourcePath As String
C#
public string SourcePath { get; set; }
Visual C++
public:
property String^ SourcePath {
    String^ get ();
    void set (String^ value);
}

See Also

SvnCopy Class
MSBuild.Community.Tasks.Subversion Namespace


SvnExport Class

[image]

.NET Framework Class Library
SvnExport Class
Members Example See Also Send Feedback

Export a folder from a Subversion repository

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class SvnExport _
    Inherits SvnClient
C#
public class SvnExport : SvnClient
Visual C++
public ref class SvnExport : public SvnClient

Examples

Export from repository
Copy Code
            <Target Name="Export">
              <MakeDir Directories="$(MSBuildProjectDirectory)\Test" />
              <RemoveDir Directories="$(MSBuildProjectDirectory)\Test\Export" />
              <SvnExport RepositoryPath="file:///d:/svn/repo/Test/trunk"
                LocalPath="$(MSBuildProjectDirectory)\Test\Export">
                <Output TaskParameter="Revision" PropertyName="Revision" />
              </SvnExport>
              <Message Text="Revision: $(Revision)"/>
            </Target>

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
Microsoft.Build.Utilities..::.ToolTask
MSBuild.Community.Tasks.Subversion..::.SvnClient
MSBuild.Community.Tasks.Subversion..::.SvnExport

See Also

SvnExport Members
MSBuild.Community.Tasks.Subversion Namespace


SvnExport Members

[image] [image]

.NET Framework Class Library
SvnExport Members
SvnExport Class Constructors Methods Properties See Also Send Feedback

The SvnExport type exposes the following members.

Constructors

Name | Description
SvnExport | Initializes a new instance of the SvnExport class.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from SvnClient.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Inherited from SvnClient.)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Inherited from SvnClient.)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GenerateSvnArguments | Generates the SVN arguments. (Inherited from SvnClient.)
GenerateSvnCommand | Generates the SVN command. (Inherited from SvnClient.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | Logs the events from text output. (Inherited from SvnClient.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Inherited from SvnClient.)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | Indicates whether all task paratmeters are valid. (Overrides SvnClient..::.ValidateParameters()()().)

Properties

Name | Description
Arguments | Gets or sets the arguments. (Inherited from SvnClient.)
BuildEngine | (Inherited from Task.)
Command | Gets or sets the command. (Inherited from SvnClient.)
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
Force | Gets or sets the force. (Inherited from SvnClient.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
LocalPath | Gets or sets the local path. (Inherited from SvnClient.)
Log | (Inherited from Task.)
Message | Gets or sets the message. (Inherited from SvnClient.)
MessageFile | Gets or sets the message file. (Inherited from SvnClient.)
NoAuthCache | Gets or sets a value indicating no auth cache. (Inherited from SvnClient.)
NonInteractive | Gets or sets a value indicating the command is non interactive]. (Inherited from SvnClient.)
Password | Gets or sets the password. (Inherited from SvnClient.)
RepositoryPath | Gets or sets the repository path. (Inherited from SvnClient.)
ResponseFileEncoding | (Inherited from ToolTask.)
Revision | Gets or sets the revision. (Inherited from SvnClient.)
StandardError | Gets the error output of SVN command-line client. (Inherited from SvnClient.)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutput | Gets the output of SVN command-line client. (Inherited from SvnClient.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Inherited from SvnClient.)
TargetFile | Gets or sets the target file. (Inherited from SvnClient.)
Targets | Gets or sets the targets. (Inherited from SvnClient.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Inherited from SvnClient.)
ToolPath | (Inherited from ToolTask.)
TrustServerCert | Gets or sets a value indicating whether to trust the server cert. (Inherited from SvnClient.)
Username | Gets or sets the username. (Inherited from SvnClient.)
Verbose | Gets or sets the verbose. (Inherited from SvnClient.)
Xml | Gets or sets a value indicating the output is XML. (Inherited from SvnClient.)

See Also

SvnExport Class
MSBuild.Community.Tasks.Subversion Namespace


SvnExport Constructor

[image]

.NET Framework Class Library
SvnExport Constructor
SvnExport Class See Also Send Feedback

Initializes a new instance of the SvnExport class.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SvnExport()
Visual C++
public:
SvnExport()

See Also

SvnExport Class
MSBuild.Community.Tasks.Subversion Namespace


SvnExport Methods

[image] [image]

.NET Framework Class Library
SvnExport Methods
SvnExport Class See Also Send Feedback

The SvnExport type exposes the following members.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from SvnClient.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Inherited from SvnClient.)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Inherited from SvnClient.)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GenerateSvnArguments | Generates the SVN arguments. (Inherited from SvnClient.)
GenerateSvnCommand | Generates the SVN command. (Inherited from SvnClient.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | Logs the events from text output. (Inherited from SvnClient.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Inherited from SvnClient.)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | Indicates whether all task paratmeters are valid. (Overrides SvnClient..::.ValidateParameters()()().)

See Also

SvnExport Class
MSBuild.Community.Tasks.Subversion Namespace


ValidateParameters Method

[image]

.NET Framework Class Library
SvnExport..::.ValidateParameters Method
SvnExport Class See Also Send Feedback

Indicates whether all task paratmeters are valid.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function ValidateParameters As Boolean
C#
protected override bool ValidateParameters()
Visual C++
protected:
virtual bool ValidateParameters() override

Return Value

true if all task parameters are valid; otherwise, false.

See Also

SvnExport Class
MSBuild.Community.Tasks.Subversion Namespace


SvnExport Properties

[image] [image]

.NET Framework Class Library
SvnExport Properties
SvnExport Class See Also Send Feedback

The SvnExport type exposes the following members.

Properties

Name | Description
Arguments | Gets or sets the arguments. (Inherited from SvnClient.)
BuildEngine | (Inherited from Task.)
Command | Gets or sets the command. (Inherited from SvnClient.)
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
Force | Gets or sets the force. (Inherited from SvnClient.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
LocalPath | Gets or sets the local path. (Inherited from SvnClient.)
Log | (Inherited from Task.)
Message | Gets or sets the message. (Inherited from SvnClient.)
MessageFile | Gets or sets the message file. (Inherited from SvnClient.)
NoAuthCache | Gets or sets a value indicating no auth cache. (Inherited from SvnClient.)
NonInteractive | Gets or sets a value indicating the command is non interactive]. (Inherited from SvnClient.)
Password | Gets or sets the password. (Inherited from SvnClient.)
RepositoryPath | Gets or sets the repository path. (Inherited from SvnClient.)
ResponseFileEncoding | (Inherited from ToolTask.)
Revision | Gets or sets the revision. (Inherited from SvnClient.)
StandardError | Gets the error output of SVN command-line client. (Inherited from SvnClient.)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutput | Gets the output of SVN command-line client. (Inherited from SvnClient.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Inherited from SvnClient.)
TargetFile | Gets or sets the target file. (Inherited from SvnClient.)
Targets | Gets or sets the targets. (Inherited from SvnClient.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Inherited from SvnClient.)
ToolPath | (Inherited from ToolTask.)
TrustServerCert | Gets or sets a value indicating whether to trust the server cert. (Inherited from SvnClient.)
Username | Gets or sets the username. (Inherited from SvnClient.)
Verbose | Gets or sets the verbose. (Inherited from SvnClient.)
Xml | Gets or sets a value indicating the output is XML. (Inherited from SvnClient.)

See Also

SvnExport Class
MSBuild.Community.Tasks.Subversion Namespace


SvnInfo Class

[image]

.NET Framework Class Library
SvnInfo Class
Members Example See Also Send Feedback

Run the "svn info" command and parse the output

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class SvnInfo _
    Inherits SvnClient
C#
public class SvnInfo : SvnClient
Visual C++
public ref class SvnInfo : public SvnClient

Remarks

You can retrieve Subversion information for a LocalPath or RepositoryPath. If you do not provide a value for LocalPath or RepositoryPath, the current directory is assumed.

Examples

This example will determine the Subversion repository root for a working directory and print it out.
Copy Code
            <Target Name="printinfo">
              <SvnInfo LocalPath="c:\code\myapp">
                <Output TaskParameter="RepositoryRoot" PropertyName="root" />
              </SvnInfo>
              <Message Text="root: $(root)" />
            </Target>

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
Microsoft.Build.Utilities..::.ToolTask
MSBuild.Community.Tasks.Subversion..::.SvnClient
MSBuild.Community.Tasks.Subversion..::.SvnInfo

See Also

SvnInfo Members
MSBuild.Community.Tasks.Subversion Namespace


SvnInfo Members

[image] [image]

.NET Framework Class Library
SvnInfo Members
SvnInfo Class Constructors Methods Properties See Also Send Feedback

The SvnInfo type exposes the following members.

Constructors

Name | Description
SvnInfo | Initializes a new instance of the SvnInfo class.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | Execute the task. (Overrides SvnClient..::.Execute()()().)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Inherited from SvnClient.)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Inherited from SvnClient.)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GenerateSvnArguments | Generates the SVN arguments. (Inherited from SvnClient.)
GenerateSvnCommand | Generates the SVN command. (Inherited from SvnClient.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | Logs the events from text output. (Inherited from SvnClient.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Inherited from SvnClient.)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | Indicates whether all task paratmeters are valid. (Inherited from SvnClient.)

Properties

Name | Description
Arguments | Gets or sets the arguments. (Inherited from SvnClient.)
BuildEngine | (Inherited from Task.)
Command | Gets or sets the command. (Inherited from SvnClient.)
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
Force | Gets or sets the force. (Inherited from SvnClient.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
LastChangedAuthor | The author who last changed this node.
LastChangedDate | The date this node was last changed.
LastChangedRevision | The last changed revision number.
LocalPath | Gets or sets the local path. (Inherited from SvnClient.)
Log | (Inherited from Task.)
Message | Gets or sets the message. (Inherited from SvnClient.)
MessageFile | Gets or sets the message file. (Inherited from SvnClient.)
NoAuthCache | Gets or sets a value indicating no auth cache. (Inherited from SvnClient.)
NodeKind | The Subversion node kind.
NonInteractive | Gets or sets a value indicating the command is non interactive]. (Inherited from SvnClient.)
Password | Gets or sets the password. (Inherited from SvnClient.)
RepositoryPath | Gets or sets the repository path. (Inherited from SvnClient.)
RepositoryRoot | Return the repository root or null if not set by Subversion.
RepositoryUuid | Return the repository UUID value from Subversion.
ResponseFileEncoding | (Inherited from ToolTask.)
Revision | Gets or sets the revision. (Inherited from SvnClient.)
Schedule | The Subversion schedule type.
StandardError | Gets the error output of SVN command-line client. (Inherited from SvnClient.)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutput | Gets the output of SVN command-line client. (Inherited from SvnClient.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Inherited from SvnClient.)
TargetFile | Gets or sets the target file. (Inherited from SvnClient.)
Targets | Gets or sets the targets. (Inherited from SvnClient.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Inherited from SvnClient.)
ToolPath | (Inherited from ToolTask.)
TrustServerCert | Gets or sets a value indicating whether to trust the server cert. (Inherited from SvnClient.)
Username | Gets or sets the username. (Inherited from SvnClient.)
Verbose | Gets or sets the verbose. (Inherited from SvnClient.)
Xml | Gets or sets a value indicating the output is XML. (Inherited from SvnClient.)

See Also

SvnInfo Class
MSBuild.Community.Tasks.Subversion Namespace


SvnInfo Constructor

[image]

.NET Framework Class Library
SvnInfo Constructor
SvnInfo Class See Also Send Feedback

Initializes a new instance of the SvnInfo class.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SvnInfo()
Visual C++
public:
SvnInfo()

See Also

SvnInfo Class
MSBuild.Community.Tasks.Subversion Namespace


SvnInfo Methods

[image] [image]

.NET Framework Class Library
SvnInfo Methods
SvnInfo Class See Also Send Feedback

The SvnInfo type exposes the following members.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | Execute the task. (Overrides SvnClient..::.Execute()()().)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Inherited from SvnClient.)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Inherited from SvnClient.)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GenerateSvnArguments | Generates the SVN arguments. (Inherited from SvnClient.)
GenerateSvnCommand | Generates the SVN command. (Inherited from SvnClient.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | Logs the events from text output. (Inherited from SvnClient.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Inherited from SvnClient.)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | Indicates whether all task paratmeters are valid. (Inherited from SvnClient.)

See Also

SvnInfo Class
MSBuild.Community.Tasks.Subversion Namespace


Execute Method

[image]

.NET Framework Class Library
SvnInfo..::.Execute Method
SvnInfo Class See Also Send Feedback

Execute the task.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

true if execution is successful, false if not.

Implements

ITask..::.Execute()()()

See Also

SvnInfo Class
MSBuild.Community.Tasks.Subversion Namespace


SvnInfo Properties

[image] [image]

.NET Framework Class Library
SvnInfo Properties
SvnInfo Class See Also Send Feedback

The SvnInfo type exposes the following members.

Properties

Name | Description
Arguments | Gets or sets the arguments. (Inherited from SvnClient.)
BuildEngine | (Inherited from Task.)
Command | Gets or sets the command. (Inherited from SvnClient.)
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
Force | Gets or sets the force. (Inherited from SvnClient.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
LastChangedAuthor | The author who last changed this node.
LastChangedDate | The date this node was last changed.
LastChangedRevision | The last changed revision number.
LocalPath | Gets or sets the local path. (Inherited from SvnClient.)
Log | (Inherited from Task.)
Message | Gets or sets the message. (Inherited from SvnClient.)
MessageFile | Gets or sets the message file. (Inherited from SvnClient.)
NoAuthCache | Gets or sets a value indicating no auth cache. (Inherited from SvnClient.)
NodeKind | The Subversion node kind.
NonInteractive | Gets or sets a value indicating the command is non interactive]. (Inherited from SvnClient.)
Password | Gets or sets the password. (Inherited from SvnClient.)
RepositoryPath | Gets or sets the repository path. (Inherited from SvnClient.)
RepositoryRoot | Return the repository root or null if not set by Subversion.
RepositoryUuid | Return the repository UUID value from Subversion.
ResponseFileEncoding | (Inherited from ToolTask.)
Revision | Gets or sets the revision. (Inherited from SvnClient.)
Schedule | The Subversion schedule type.
StandardError | Gets the error output of SVN command-line client. (Inherited from SvnClient.)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutput | Gets the output of SVN command-line client. (Inherited from SvnClient.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Inherited from SvnClient.)
TargetFile | Gets or sets the target file. (Inherited from SvnClient.)
Targets | Gets or sets the targets. (Inherited from SvnClient.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Inherited from SvnClient.)
ToolPath | (Inherited from ToolTask.)
TrustServerCert | Gets or sets a value indicating whether to trust the server cert. (Inherited from SvnClient.)
Username | Gets or sets the username. (Inherited from SvnClient.)
Verbose | Gets or sets the verbose. (Inherited from SvnClient.)
Xml | Gets or sets a value indicating the output is XML. (Inherited from SvnClient.)

See Also

SvnInfo Class
MSBuild.Community.Tasks.Subversion Namespace


LastChangedAuthor Property

[image]

.NET Framework Class Library
SvnInfo..::.LastChangedAuthor Property
SvnInfo Class See Also Send Feedback

The author who last changed this node.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public Property LastChangedAuthor As String
C#
[OutputAttribute]
public string LastChangedAuthor { get; private set; }
Visual C++
[OutputAttribute]
public:
property String^ LastChangedAuthor {
    String^ get ();
    void set (String^ value);
}

See Also

SvnInfo Class
MSBuild.Community.Tasks.Subversion Namespace


LastChangedDate Property

[image]

.NET Framework Class Library
SvnInfo..::.LastChangedDate Property
SvnInfo Class See Also Send Feedback

The date this node was last changed.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public Property LastChangedDate As DateTime
C#
[OutputAttribute]
public DateTime LastChangedDate { get; private set; }
Visual C++
[OutputAttribute]
public:
property DateTime LastChangedDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

SvnInfo Class
MSBuild.Community.Tasks.Subversion Namespace


LastChangedRevision Property

[image]

.NET Framework Class Library
SvnInfo..::.LastChangedRevision Property
SvnInfo Class See Also Send Feedback

The last changed revision number.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public Property LastChangedRevision As Integer
C#
[OutputAttribute]
public int LastChangedRevision { get; private set; }
Visual C++
[OutputAttribute]
public:
property int LastChangedRevision {
    int get ();
    void set (int value);
}

See Also

SvnInfo Class
MSBuild.Community.Tasks.Subversion Namespace


NodeKind Property

[image]

.NET Framework Class Library
SvnInfo..::.NodeKind Property
SvnInfo Class See Also Send Feedback

The Subversion node kind.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public Property NodeKind As String
C#
[OutputAttribute]
public string NodeKind { get; private set; }
Visual C++
[OutputAttribute]
public:
property String^ NodeKind {
    String^ get ();
    void set (String^ value);
}

See Also

SvnInfo Class
MSBuild.Community.Tasks.Subversion Namespace


RepositoryRoot Property

[image]

.NET Framework Class Library
SvnInfo..::.RepositoryRoot Property
SvnInfo Class See Also Send Feedback

Return the repository root or null if not set by Subversion.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public Property RepositoryRoot As String
C#
[OutputAttribute]
public string RepositoryRoot { get; private set; }
Visual C++
[OutputAttribute]
public:
property String^ RepositoryRoot {
    String^ get ();
    void set (String^ value);
}

See Also

SvnInfo Class
MSBuild.Community.Tasks.Subversion Namespace


RepositoryUuid Property

[image]

.NET Framework Class Library
SvnInfo..::.RepositoryUuid Property
SvnInfo Class See Also Send Feedback

Return the repository UUID value from Subversion.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public Property RepositoryUuid As String
C#
[OutputAttribute]
public string RepositoryUuid { get; private set; }
Visual C++
[OutputAttribute]
public:
property String^ RepositoryUuid {
    String^ get ();
    void set (String^ value);
}

See Also

SvnInfo Class
MSBuild.Community.Tasks.Subversion Namespace


Schedule Property

[image]

.NET Framework Class Library
SvnInfo..::.Schedule Property
SvnInfo Class See Also Send Feedback

The Subversion schedule type.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public Property Schedule As String
C#
[OutputAttribute]
public string Schedule { get; private set; }
Visual C++
[OutputAttribute]
public:
property String^ Schedule {
    String^ get ();
    void set (String^ value);
}

See Also

SvnInfo Class
MSBuild.Community.Tasks.Subversion Namespace


SvnUpdate Class

[image]

.NET Framework Class Library
SvnUpdate Class
Members See Also Send Feedback

Subversion Update command

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class SvnUpdate _
    Inherits SvnClient
C#
public class SvnUpdate : SvnClient
Visual C++
public ref class SvnUpdate : public SvnClient

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
Microsoft.Build.Utilities..::.ToolTask
MSBuild.Community.Tasks.Subversion..::.SvnClient
MSBuild.Community.Tasks.Subversion..::.SvnUpdate

See Also

SvnUpdate Members
MSBuild.Community.Tasks.Subversion Namespace


SvnUpdate Members

[image] [image]

.NET Framework Class Library
SvnUpdate Members
SvnUpdate Class Constructors Methods Properties See Also Send Feedback

The SvnUpdate type exposes the following members.

Constructors

Name | Description
SvnUpdate | Initializes a new instance of the SvnUpdate class.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from SvnClient.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Inherited from SvnClient.)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Inherited from SvnClient.)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GenerateSvnArguments | Generates the SVN arguments. (Inherited from SvnClient.)
GenerateSvnCommand | Generates the SVN command. (Inherited from SvnClient.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | Logs the events from text output. (Inherited from SvnClient.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Inherited from SvnClient.)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | Indicates whether all task paratmeters are valid. (Overrides SvnClient..::.ValidateParameters()()().)

Properties

Name | Description
Arguments | Gets or sets the arguments. (Inherited from SvnClient.)
BuildEngine | (Inherited from Task.)
Command | Gets or sets the command. (Inherited from SvnClient.)
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
Force | Gets or sets the force. (Inherited from SvnClient.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
LocalPath | Gets or sets the local path. (Inherited from SvnClient.)
Log | (Inherited from Task.)
Message | Gets or sets the message. (Inherited from SvnClient.)
MessageFile | Gets or sets the message file. (Inherited from SvnClient.)
NoAuthCache | Gets or sets a value indicating no auth cache. (Inherited from SvnClient.)
NonInteractive | Gets or sets a value indicating the command is non interactive]. (Inherited from SvnClient.)
Password | Gets or sets the password. (Inherited from SvnClient.)
RepositoryPath | Gets or sets the repository path. (Inherited from SvnClient.)
ResponseFileEncoding | (Inherited from ToolTask.)
Revision | Gets or sets the revision. (Inherited from SvnClient.)
StandardError | Gets the error output of SVN command-line client. (Inherited from SvnClient.)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutput | Gets the output of SVN command-line client. (Inherited from SvnClient.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Inherited from SvnClient.)
TargetFile | Gets or sets the target file. (Inherited from SvnClient.)
Targets | Gets or sets the targets. (Inherited from SvnClient.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Inherited from SvnClient.)
ToolPath | (Inherited from ToolTask.)
TrustServerCert | Gets or sets a value indicating whether to trust the server cert. (Inherited from SvnClient.)
Username | Gets or sets the username. (Inherited from SvnClient.)
Verbose | Gets or sets the verbose. (Inherited from SvnClient.)
Xml | Gets or sets a value indicating the output is XML. (Inherited from SvnClient.)

See Also

SvnUpdate Class
MSBuild.Community.Tasks.Subversion Namespace


SvnUpdate Constructor

[image]

.NET Framework Class Library
SvnUpdate Constructor
SvnUpdate Class See Also Send Feedback

Initializes a new instance of the SvnUpdate class.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SvnUpdate()
Visual C++
public:
SvnUpdate()

See Also

SvnUpdate Class
MSBuild.Community.Tasks.Subversion Namespace


SvnUpdate Methods

[image] [image]

.NET Framework Class Library
SvnUpdate Methods
SvnUpdate Class See Also Send Feedback

The SvnUpdate type exposes the following members.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from SvnClient.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Inherited from SvnClient.)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Inherited from SvnClient.)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GenerateSvnArguments | Generates the SVN arguments. (Inherited from SvnClient.)
GenerateSvnCommand | Generates the SVN command. (Inherited from SvnClient.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | Logs the events from text output. (Inherited from SvnClient.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Inherited from SvnClient.)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | Indicates whether all task paratmeters are valid. (Overrides SvnClient..::.ValidateParameters()()().)

See Also

SvnUpdate Class
MSBuild.Community.Tasks.Subversion Namespace


ValidateParameters Method

[image]

.NET Framework Class Library
SvnUpdate..::.ValidateParameters Method
SvnUpdate Class See Also Send Feedback

Indicates whether all task paratmeters are valid.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function ValidateParameters As Boolean
C#
protected override bool ValidateParameters()
Visual C++
protected:
virtual bool ValidateParameters() override

Return Value

true if all task parameters are valid; otherwise, false.

See Also

SvnUpdate Class
MSBuild.Community.Tasks.Subversion Namespace


SvnUpdate Properties

[image] [image]

.NET Framework Class Library
SvnUpdate Properties
SvnUpdate Class See Also Send Feedback

The SvnUpdate type exposes the following members.

Properties

Name | Description
Arguments | Gets or sets the arguments. (Inherited from SvnClient.)
BuildEngine | (Inherited from Task.)
Command | Gets or sets the command. (Inherited from SvnClient.)
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
Force | Gets or sets the force. (Inherited from SvnClient.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
LocalPath | Gets or sets the local path. (Inherited from SvnClient.)
Log | (Inherited from Task.)
Message | Gets or sets the message. (Inherited from SvnClient.)
MessageFile | Gets or sets the message file. (Inherited from SvnClient.)
NoAuthCache | Gets or sets a value indicating no auth cache. (Inherited from SvnClient.)
NonInteractive | Gets or sets a value indicating the command is non interactive]. (Inherited from SvnClient.)
Password | Gets or sets the password. (Inherited from SvnClient.)
RepositoryPath | Gets or sets the repository path. (Inherited from SvnClient.)
ResponseFileEncoding | (Inherited from ToolTask.)
Revision | Gets or sets the revision. (Inherited from SvnClient.)
StandardError | Gets the error output of SVN command-line client. (Inherited from SvnClient.)
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutput | Gets the output of SVN command-line client. (Inherited from SvnClient.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Inherited from SvnClient.)
TargetFile | Gets or sets the target file. (Inherited from SvnClient.)
Targets | Gets or sets the targets. (Inherited from SvnClient.)
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Inherited from SvnClient.)
ToolPath | (Inherited from ToolTask.)
TrustServerCert | Gets or sets a value indicating whether to trust the server cert. (Inherited from SvnClient.)
Username | Gets or sets the username. (Inherited from SvnClient.)
Verbose | Gets or sets the verbose. (Inherited from SvnClient.)
Xml | Gets or sets a value indicating the output is XML. (Inherited from SvnClient.)

See Also

SvnUpdate Class
MSBuild.Community.Tasks.Subversion Namespace


SvnVersion Class

[image]

.NET Framework Class Library
SvnVersion Class
Members Example See Also Send Feedback

Summarize the local revision(s) of a working copy.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class SvnVersion _
    Inherits ToolTask
C#
public class SvnVersion : ToolTask
Visual C++
public ref class SvnVersion : public ToolTask

Examples

The following example gets the revision of the current folder.
Copy Code
            <Target Name="Version">
              <SvnVersion LocalPath=".">
                <Output TaskParameter="Revision" PropertyName="Revision" />
              </SvnVersion>
              <Message Text="Revision: $(Revision)"/>
            </Target>

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
Microsoft.Build.Utilities..::.ToolTask
MSBuild.Community.Tasks.Subversion..::.SvnVersion

See Also

SvnVersion Members
MSBuild.Community.Tasks.Subversion Namespace


SvnVersion Members

[image] [image]

.NET Framework Class Library
SvnVersion Members
SvnVersion Class Constructors Methods Properties See Also Send Feedback

The SvnVersion type exposes the following members.

Constructors

Name | Description
SvnVersion | Initializes a new instance of the SvnVersion class.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | Runs the exectuable file with the specified task parameters. (Overrides ToolTask..::.Execute()()().)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | Logs the events from text output. (Overrides ToolTask..::.LogEventsFromTextOutput(String, MessageImportance).)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Overrides ToolTask..::.LogToolCommand(String).)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
Exported | True if invoked on a directory that is not a working copy, svnversion assumes it is an exported working copy and prints "exported".
HelpKeywordPrefix | (Inherited from Task.)
HighRevision | High revision number of the local working repository revision range.
HostObject | (Inherited from Task.)
LocalPath | Path to local working copy.
Log | (Inherited from Task.)
LowRevision | Low revision number of the local working repository revision range.
Modifications | True if working copy contains modifications.
ResponseFileEncoding | (Inherited from ToolTask.)
Revision | Revision number of the local working repository.
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Overrides ToolTask..::.StandardOutputLoggingImportance.)
Switched | True if working copy is switched.
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)
UseLastCommittedRevision | Specifies whether to use the last committed revision number as opposed to the last updated revision number.

See Also

SvnVersion Class
MSBuild.Community.Tasks.Subversion Namespace


SvnVersion Constructor

[image]

.NET Framework Class Library
SvnVersion Constructor
SvnVersion Class See Also Send Feedback

Initializes a new instance of the SvnVersion class.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SvnVersion()
Visual C++
public:
SvnVersion()

See Also

SvnVersion Class
MSBuild.Community.Tasks.Subversion Namespace


SvnVersion Methods

[image] [image]

.NET Framework Class Library
SvnVersion Methods
SvnVersion Class See Also Send Feedback

The SvnVersion type exposes the following members.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | Runs the exectuable file with the specified task parameters. (Overrides ToolTask..::.Execute()()().)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | Logs the events from text output. (Overrides ToolTask..::.LogEventsFromTextOutput(String, MessageImportance).)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Overrides ToolTask..::.LogToolCommand(String).)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

See Also

SvnVersion Class
MSBuild.Community.Tasks.Subversion Namespace


Execute Method

[image]

.NET Framework Class Library
SvnVersion..::.Execute Method
SvnVersion Class See Also Send Feedback

Runs the exectuable file with the specified task parameters.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

true if the task runs successfully; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

SvnVersion Class
MSBuild.Community.Tasks.Subversion Namespace


GenerateCommandLineCommands Method

[image]

.NET Framework Class Library
SvnVersion..::.GenerateCommandLineCommands Method
SvnVersion Class See Also Send Feedback

Returns a string value containing the command line arguments to pass directly to the executable file.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateCommandLineCommands As String
C#
protected override string GenerateCommandLineCommands()
Visual C++
protected:
virtual String^ GenerateCommandLineCommands() override

Return Value

A string value containing the command line arguments to pass directly to the executable file.

See Also

SvnVersion Class
MSBuild.Community.Tasks.Subversion Namespace


GenerateFullPathToTool Method

[image]

.NET Framework Class Library
SvnVersion..::.GenerateFullPathToTool Method
SvnVersion Class See Also Send Feedback

Returns the fully qualified path to the executable file.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateFullPathToTool As String
C#
protected override string GenerateFullPathToTool()
Visual C++
protected:
virtual String^ GenerateFullPathToTool() override

Return Value

The fully qualified path to the executable file.

See Also

SvnVersion Class
MSBuild.Community.Tasks.Subversion Namespace


LogEventsFromTextOutput Method

[image]

.NET Framework Class Library
SvnVersion..::.LogEventsFromTextOutput Method
SvnVersion Class See Also Send Feedback

Logs the events from text output.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub LogEventsFromTextOutput ( _
    singleLine As String, _
    messageImportance As MessageImportance _
)
C#
protected override void LogEventsFromTextOutput(
    string singleLine,
    MessageImportance messageImportance
)
Visual C++
protected:
virtual void LogEventsFromTextOutput(
    String^ singleLine,
    MessageImportance messageImportance
) override

Parameters

singleLine
Type: System..::.String
The single line.
messageImportance
Type: Microsoft.Build.Framework..::.MessageImportance
The message importance.

See Also

SvnVersion Class
MSBuild.Community.Tasks.Subversion Namespace


LogToolCommand Method

[image]

.NET Framework Class Library
SvnVersion..::.LogToolCommand Method
SvnVersion Class See Also Send Feedback

Logs the starting point of the run to all registered loggers.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub LogToolCommand ( _
    message As String _
)
C#
protected override void LogToolCommand(
    string message
)
Visual C++
protected:
virtual void LogToolCommand(
    String^ message
) override

Parameters

message
Type: System..::.String
A descriptive message to provide loggers, usually the command line and switches.

See Also

SvnVersion Class
MSBuild.Community.Tasks.Subversion Namespace


SvnVersion Properties

[image] [image]

.NET Framework Class Library
SvnVersion Properties
SvnVersion Class See Also Send Feedback

The SvnVersion type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
Exported | True if invoked on a directory that is not a working copy, svnversion assumes it is an exported working copy and prints "exported".
HelpKeywordPrefix | (Inherited from Task.)
HighRevision | High revision number of the local working repository revision range.
HostObject | (Inherited from Task.)
LocalPath | Path to local working copy.
Log | (Inherited from Task.)
LowRevision | Low revision number of the local working repository revision range.
Modifications | True if working copy contains modifications.
ResponseFileEncoding | (Inherited from ToolTask.)
Revision | Revision number of the local working repository.
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Overrides ToolTask..::.StandardOutputLoggingImportance.)
Switched | True if working copy is switched.
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)
UseLastCommittedRevision | Specifies whether to use the last committed revision number as opposed to the last updated revision number.

See Also

SvnVersion Class
MSBuild.Community.Tasks.Subversion Namespace


Exported Property

[image]

.NET Framework Class Library
SvnVersion..::.Exported Property
SvnVersion Class See Also Send Feedback

True if invoked on a directory that is not a working copy, svnversion assumes it is an exported working copy and prints "exported".

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public Property Exported As Boolean
C#
[OutputAttribute]
public bool Exported { get; set; }
Visual C++
[OutputAttribute]
public:
property bool Exported {
    bool get ();
    void set (bool value);
}

See Also

SvnVersion Class
MSBuild.Community.Tasks.Subversion Namespace


HighRevision Property

[image]

.NET Framework Class Library
SvnVersion..::.HighRevision Property
SvnVersion Class See Also Send Feedback

High revision number of the local working repository revision range.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public Property HighRevision As Integer
C#
[OutputAttribute]
public int HighRevision { get; set; }
Visual C++
[OutputAttribute]
public:
property int HighRevision {
    int get ();
    void set (int value);
}

See Also

SvnVersion Class
MSBuild.Community.Tasks.Subversion Namespace


LocalPath Property

[image]

.NET Framework Class Library
SvnVersion..::.LocalPath Property
SvnVersion Class See Also Send Feedback

Path to local working copy.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property LocalPath As String
C#
[RequiredAttribute]
public string LocalPath { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ LocalPath {
    String^ get ();
    void set (String^ value);
}

See Also

SvnVersion Class
MSBuild.Community.Tasks.Subversion Namespace


LowRevision Property

[image]

.NET Framework Class Library
SvnVersion..::.LowRevision Property
SvnVersion Class See Also Send Feedback

Low revision number of the local working repository revision range.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public Property LowRevision As Integer
C#
[OutputAttribute]
public int LowRevision { get; set; }
Visual C++
[OutputAttribute]
public:
property int LowRevision {
    int get ();
    void set (int value);
}

See Also

SvnVersion Class
MSBuild.Community.Tasks.Subversion Namespace


Modifications Property

[image]

.NET Framework Class Library
SvnVersion..::.Modifications Property
SvnVersion Class See Also Send Feedback

True if working copy contains modifications.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public Property Modifications As Boolean
C#
[OutputAttribute]
public bool Modifications { get; set; }
Visual C++
[OutputAttribute]
public:
property bool Modifications {
    bool get ();
    void set (bool value);
}

See Also

SvnVersion Class
MSBuild.Community.Tasks.Subversion Namespace


Revision Property

[image]

.NET Framework Class Library
SvnVersion..::.Revision Property
SvnVersion Class See Also Send Feedback

Revision number of the local working repository.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public Property Revision As Integer
C#
[OutputAttribute]
public int Revision { get; set; }
Visual C++
[OutputAttribute]
public:
property int Revision {
    int get ();
    void set (int value);
}

See Also

SvnVersion Class
MSBuild.Community.Tasks.Subversion Namespace


StandardOutputLoggingImportance Property

[image]

.NET Framework Class Library
SvnVersion..::.StandardOutputLoggingImportance Property
SvnVersion Class See Also Send Feedback

Gets the MessageImportance with which to log errors.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property StandardOutputLoggingImportance As MessageImportance
C#
protected override MessageImportance StandardOutputLoggingImportance { get; }
Visual C++
protected:
virtual property MessageImportance StandardOutputLoggingImportance {
    MessageImportance get () override;
}

Field Value

Return Value

The MessageImportance with which to log errors.

See Also

SvnVersion Class
MSBuild.Community.Tasks.Subversion Namespace


Switched Property

[image]

.NET Framework Class Library
SvnVersion..::.Switched Property
SvnVersion Class See Also Send Feedback

True if working copy is switched.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public Property Switched As Boolean
C#
[OutputAttribute]
public bool Switched { get; set; }
Visual C++
[OutputAttribute]
public:
property bool Switched {
    bool get ();
    void set (bool value);
}

See Also

SvnVersion Class
MSBuild.Community.Tasks.Subversion Namespace


ToolName Property

[image]

.NET Framework Class Library
SvnVersion..::.ToolName Property
SvnVersion Class See Also Send Feedback

Gets the name of the executable file to run.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ToolName As String
C#
protected override string ToolName { get; }
Visual C++
protected:
virtual property String^ ToolName {
    String^ get () override;
}

Field Value

Return Value

The name of the executable file to run.

See Also

SvnVersion Class
MSBuild.Community.Tasks.Subversion Namespace


UseLastCommittedRevision Property

[image]

.NET Framework Class Library
SvnVersion..::.UseLastCommittedRevision Property
SvnVersion Class See Also Send Feedback

Specifies whether to use the last committed revision number as opposed to the last updated revision number.

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property UseLastCommittedRevision As Boolean
C#
public bool UseLastCommittedRevision { get; set; }
Visual C++
public:
property bool UseLastCommittedRevision {
    bool get ();
    void set (bool value);
}

See Also

SvnVersion Class
MSBuild.Community.Tasks.Subversion Namespace


WorkingCopy Class

[image]

.NET Framework Class Library
WorkingCopy Class
Members See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class WorkingCopy
C#
public class WorkingCopy
Visual C++
public ref class WorkingCopy

Remarks

Inheritance Hierarchy

System..::.Object
MSBuild.Community.Tasks.Subversion..::.WorkingCopy

See Also

WorkingCopy Members
MSBuild.Community.Tasks.Subversion Namespace


WorkingCopy Members

[image] [image]

.NET Framework Class Library
WorkingCopy Members
WorkingCopy Class Constructors Methods Properties See Also Send Feedback

The WorkingCopy type exposes the following members.

Constructors

Name | Description
WorkingCopy |

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
Checksum |
Depth |
Schedule |
TextUpdated |
TextUpdatedSpecified |

See Also

WorkingCopy Class
MSBuild.Community.Tasks.Subversion Namespace


WorkingCopy Constructor

[image]

.NET Framework Class Library
WorkingCopy Constructor
WorkingCopy Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public WorkingCopy()
Visual C++
public:
WorkingCopy()

See Also

WorkingCopy Class
MSBuild.Community.Tasks.Subversion Namespace


WorkingCopy Methods

[image] [image]

.NET Framework Class Library
WorkingCopy Methods
WorkingCopy Class See Also Send Feedback

The WorkingCopy type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

WorkingCopy Class
MSBuild.Community.Tasks.Subversion Namespace


WorkingCopy Properties

[image] [image]

.NET Framework Class Library
WorkingCopy Properties
WorkingCopy Class See Also Send Feedback

The WorkingCopy type exposes the following members.

Properties

Name | Description
Checksum |
Depth |
Schedule |
TextUpdated |
TextUpdatedSpecified |

See Also

WorkingCopy Class
MSBuild.Community.Tasks.Subversion Namespace


Checksum Property

[image]

.NET Framework Class Library
WorkingCopy..::.Checksum Property
WorkingCopy Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Checksum As String
C#
public string Checksum { get; set; }
Visual C++
public:
property String^ Checksum {
    String^ get ();
    void set (String^ value);
}

Remarks

See Also

WorkingCopy Class
MSBuild.Community.Tasks.Subversion Namespace


Depth Property

[image]

.NET Framework Class Library
WorkingCopy..::.Depth Property
WorkingCopy Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Depth As String
C#
public string Depth { get; set; }
Visual C++
public:
property String^ Depth {
    String^ get ();
    void set (String^ value);
}

Remarks

See Also

WorkingCopy Class
MSBuild.Community.Tasks.Subversion Namespace


Schedule Property

[image]

.NET Framework Class Library
WorkingCopy..::.Schedule Property
WorkingCopy Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Schedule As String
C#
public string Schedule { get; set; }
Visual C++
public:
property String^ Schedule {
    String^ get ();
    void set (String^ value);
}

Remarks

See Also

WorkingCopy Class
MSBuild.Community.Tasks.Subversion Namespace


TextUpdated Property

[image]

.NET Framework Class Library
WorkingCopy..::.TextUpdated Property
WorkingCopy Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property TextUpdated As DateTime
C#
public DateTime TextUpdated { get; set; }
Visual C++
public:
property DateTime TextUpdated {
    DateTime get ();
    void set (DateTime value);
}

Remarks

See Also

WorkingCopy Class
MSBuild.Community.Tasks.Subversion Namespace


TextUpdatedSpecified Property

[image]

.NET Framework Class Library
WorkingCopy..::.TextUpdatedSpecified Property
WorkingCopy Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Subversion
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property TextUpdatedSpecified As Boolean
C#
public bool TextUpdatedSpecified { get; set; }
Visual C++
public:
property bool TextUpdatedSpecified {
    bool get ();
    void set (bool value);
}

Remarks

See Also

WorkingCopy Class
MSBuild.Community.Tasks.Subversion Namespace


MSBuild.Community.Tasks.SymbolServer Namespace

[image]

.NET Framework Class Library
MSBuild.Community.Tasks.SymbolServer Namespace
Send Feedback

Classes

Class | Description
SymStore | Task that wraps the Symbol Server SymStore.exe application.

Enumerations

Enumeration | Description
SymStoreCommands | Commands for the SymStore tasks.


SymStore Class

[image]

.NET Framework Class Library
SymStore Class
Members See Also Send Feedback

Task that wraps the Symbol Server SymStore.exe application.

Namespace: MSBuild.Community.Tasks.SymbolServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class SymStore _
    Inherits ToolTask
C#
public class SymStore : ToolTask
Visual C++
public ref class SymStore : public ToolTask

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
Microsoft.Build.Utilities..::.ToolTask
MSBuild.Community.Tasks.SymbolServer..::.SymStore

See Also

SymStore Members
MSBuild.Community.Tasks.SymbolServer Namespace


SymStore Members

[image] [image]

.NET Framework Class Library
SymStore Members
SymStore Class Constructors Methods Properties See Also Send Feedback

The SymStore type exposes the following members.

Constructors

Name | Description
SymStore | Initializes a new instance of the SymStore class.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from ToolTask.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | (Inherited from ToolTask.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Overrides ToolTask..::.LogToolCommand(String).)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

Properties

Name | Description
Append | Gets or sets a value indicating SymStore will append new indexing information to an existing index file.
BuildEngine | (Inherited from Task.)
Command | Gets or sets the command.
Comment | Gets or sets the comment for the transaction.
Compress | Gets or sets a value indicating SymStore will create a compressed version of each file copied to the symbol store instead of using an uncompressed copy of the file.
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
Files | Gets or sets the network path of files or directories to add.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
ID | Gets or sets the transaction ID string.
Local | Gets or sets a value indicating whether the file will be in a local directory rather than a network path.
Log | (Inherited from Task.)
LogFile | Gets or sets a log file to be used for command output. If this is not included, transaction information and other output is sent to stdout.
Message | Gets or sets the message to be added to each file.
NoReference | Gets or sets a value indicating whether to omit the creation of reference pointer files for the files and pointers being stored.
Pointer | Gets or sets a value indicating whether SymStore will store a pointer to the file, rather than the file itself.
Product | Gets or sets the name of the product.
ReadIndex | Gets or sets the index file. Causes SymStore to read the data from a file created with WriteIndexFile.
Recursive | Gets or sets a value indicating whether SymStore will add files or directories recursively.
Relative | Gets or sets a value indicating whether the paths in the file pointers will be relative.
ResponseFileEncoding | (Inherited from ToolTask.)
Share | Gets or sets the server and share where the symbol files were originally stored.
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Overrides ToolTask..::.StandardOutputLoggingImportance.)
Store | Gets or sets the root directory for the symbol store.
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)
Verbose | Gets or sets a value indicating whether SymStore will display verbose output.
Version | Gets or sets the version of the product.
WriteIndex | Gets or sets the index file. Causes SymStore not to store the actual symbol files. Instead, SymStore records information in the IndexFile that will enable SymStore to access the symbol files at a later time.

See Also

SymStore Class
MSBuild.Community.Tasks.SymbolServer Namespace


SymStore Constructor

[image]

.NET Framework Class Library
SymStore Constructor
SymStore Class See Also Send Feedback

Initializes a new instance of the SymStore class.

Namespace: MSBuild.Community.Tasks.SymbolServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SymStore()
Visual C++
public:
SymStore()

See Also

SymStore Class
MSBuild.Community.Tasks.SymbolServer Namespace


SymStore Methods

[image] [image]

.NET Framework Class Library
SymStore Methods
SymStore Class See Also Send Feedback

The SymStore type exposes the following members.

Methods

Name | Description
CallHostObjectToExecute | (Inherited from ToolTask.)
DeleteTempFile | (Inherited from ToolTask.)
Equals | (Inherited from Object.)
Execute | (Inherited from ToolTask.)
ExecuteTool | (Inherited from ToolTask.)
Finalize | (Inherited from Object.)
GenerateCommandLineCommands | Returns a string value containing the command line arguments to pass directly to the executable file. (Overrides ToolTask..::.GenerateCommandLineCommands()()().)
GenerateFullPathToTool | Returns the fully qualified path to the executable file. (Overrides ToolTask..::.GenerateFullPathToTool()()().)
GenerateResponseFileCommands | (Inherited from ToolTask.)
GetHashCode | (Inherited from Object.)
GetResponseFileSwitch | (Inherited from ToolTask.)
GetType | (Inherited from Object.)
GetWorkingDirectory | (Inherited from ToolTask.)
HandleTaskExecutionErrors | (Inherited from ToolTask.)
InitializeHostObject | (Inherited from ToolTask.)
LogEventsFromTextOutput | (Inherited from ToolTask.)
LogPathToTool | (Inherited from ToolTask.)
LogToolCommand | Logs the starting point of the run to all registered loggers. (Overrides ToolTask..::.LogToolCommand(String).)
MemberwiseClone | (Inherited from Object.)
SkipTaskExecution | (Inherited from ToolTask.)
ToString | (Inherited from Object.)
ValidateParameters | (Inherited from ToolTask.)

See Also

SymStore Class
MSBuild.Community.Tasks.SymbolServer Namespace


GenerateCommandLineCommands Method

[image]

.NET Framework Class Library
SymStore..::.GenerateCommandLineCommands Method
SymStore Class See Also Send Feedback

Returns a string value containing the command line arguments to pass directly to the executable file.

Namespace: MSBuild.Community.Tasks.SymbolServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateCommandLineCommands As String
C#
protected override string GenerateCommandLineCommands()
Visual C++
protected:
virtual String^ GenerateCommandLineCommands() override

Return Value

A string value containing the command line arguments to pass directly to the executable file.

See Also

SymStore Class
MSBuild.Community.Tasks.SymbolServer Namespace


GenerateFullPathToTool Method

[image]

.NET Framework Class Library
SymStore..::.GenerateFullPathToTool Method
SymStore Class See Also Send Feedback

Returns the fully qualified path to the executable file.

Namespace: MSBuild.Community.Tasks.SymbolServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Function GenerateFullPathToTool As String
C#
protected override string GenerateFullPathToTool()
Visual C++
protected:
virtual String^ GenerateFullPathToTool() override

Return Value

The fully qualified path to the executable file.

See Also

SymStore Class
MSBuild.Community.Tasks.SymbolServer Namespace


LogToolCommand Method

[image]

.NET Framework Class Library
SymStore..::.LogToolCommand Method
SymStore Class See Also Send Feedback

Logs the starting point of the run to all registered loggers.

Namespace: MSBuild.Community.Tasks.SymbolServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub LogToolCommand ( _
    message As String _
)
C#
protected override void LogToolCommand(
    string message
)
Visual C++
protected:
virtual void LogToolCommand(
    String^ message
) override

Parameters

message
Type: System..::.String
A descriptive message to provide loggers, usually the command line and switches.

See Also

SymStore Class
MSBuild.Community.Tasks.SymbolServer Namespace


SymStore Properties

[image] [image]

.NET Framework Class Library
SymStore Properties
SymStore Class See Also Send Feedback

The SymStore type exposes the following members.

Properties

Name | Description
Append | Gets or sets a value indicating SymStore will append new indexing information to an existing index file.
BuildEngine | (Inherited from Task.)
Command | Gets or sets the command.
Comment | Gets or sets the comment for the transaction.
Compress | Gets or sets a value indicating SymStore will create a compressed version of each file copied to the symbol store instead of using an uncompressed copy of the file.
EnvironmentOverride | (Inherited from ToolTask.)
ExitCode | (Inherited from ToolTask.)
Files | Gets or sets the network path of files or directories to add.
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
ID | Gets or sets the transaction ID string.
Local | Gets or sets a value indicating whether the file will be in a local directory rather than a network path.
Log | (Inherited from Task.)
LogFile | Gets or sets a log file to be used for command output. If this is not included, transaction information and other output is sent to stdout.
Message | Gets or sets the message to be added to each file.
NoReference | Gets or sets a value indicating whether to omit the creation of reference pointer files for the files and pointers being stored.
Pointer | Gets or sets a value indicating whether SymStore will store a pointer to the file, rather than the file itself.
Product | Gets or sets the name of the product.
ReadIndex | Gets or sets the index file. Causes SymStore to read the data from a file created with WriteIndexFile.
Recursive | Gets or sets a value indicating whether SymStore will add files or directories recursively.
Relative | Gets or sets a value indicating whether the paths in the file pointers will be relative.
ResponseFileEncoding | (Inherited from ToolTask.)
Share | Gets or sets the server and share where the symbol files were originally stored.
StandardErrorEncoding | (Inherited from ToolTask.)
StandardErrorLoggingImportance | (Inherited from ToolTask.)
StandardOutputEncoding | (Inherited from ToolTask.)
StandardOutputLoggingImportance | Gets the MessageImportance with which to log errors. (Overrides ToolTask..::.StandardOutputLoggingImportance.)
Store | Gets or sets the root directory for the symbol store.
TaskResources | (Inherited from Task.)
Timeout | (Inherited from ToolTask.)
ToolName | Gets the name of the executable file to run. (Overrides ToolTask..::.ToolName.)
ToolPath | (Inherited from ToolTask.)
Verbose | Gets or sets a value indicating whether SymStore will display verbose output.
Version | Gets or sets the version of the product.
WriteIndex | Gets or sets the index file. Causes SymStore not to store the actual symbol files. Instead, SymStore records information in the IndexFile that will enable SymStore to access the symbol files at a later time.

See Also

SymStore Class
MSBuild.Community.Tasks.SymbolServer Namespace


Append Property

[image]

.NET Framework Class Library
SymStore..::.Append Property
SymStore Class See Also Send Feedback

Gets or sets a value indicating SymStore will append new indexing information to an existing index file.

Namespace: MSBuild.Community.Tasks.SymbolServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Append As Boolean
C#
public bool Append { get; set; }
Visual C++
public:
property bool Append {
    bool get ();
    void set (bool value);
}

Field Value

true if append; otherwise, false.

See Also

SymStore Class
MSBuild.Community.Tasks.SymbolServer Namespace


Command Property

[image]

.NET Framework Class Library
SymStore..::.Command Property
SymStore Class See Also Send Feedback

Gets or sets the command.

Namespace: MSBuild.Community.Tasks.SymbolServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Command As String
C#
public string Command { get; set; }
Visual C++
public:
property String^ Command {
    String^ get ();
    void set (String^ value);
}

Field Value

The command.

See Also

SymStore Class
MSBuild.Community.Tasks.SymbolServer Namespace


Comment Property

[image]

.NET Framework Class Library
SymStore..::.Comment Property
SymStore Class See Also Send Feedback

Gets or sets the comment for the transaction.

Namespace: MSBuild.Community.Tasks.SymbolServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Comment As String
C#
public string Comment { get; set; }
Visual C++
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}

Field Value

The comment for the transaction.

See Also

SymStore Class
MSBuild.Community.Tasks.SymbolServer Namespace


Compress Property

[image]

.NET Framework Class Library
SymStore..::.Compress Property
SymStore Class See Also Send Feedback

Gets or sets a value indicating SymStore will create a compressed version of each file copied to the symbol store instead of using an uncompressed copy of the file.

Namespace: MSBuild.Community.Tasks.SymbolServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Compress As Boolean
C#
public bool Compress { get; set; }
Visual C++
public:
property bool Compress {
    bool get ();
    void set (bool value);
}

Field Value

true if compress; otherwise, false.

See Also

SymStore Class
MSBuild.Community.Tasks.SymbolServer Namespace


Files Property

[image]

.NET Framework Class Library
SymStore..::.Files Property
SymStore Class See Also Send Feedback

Gets or sets the network path of files or directories to add.

Namespace: MSBuild.Community.Tasks.SymbolServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Files As String
C#
public string Files { get; set; }
Visual C++
public:
property String^ Files {
    String^ get ();
    void set (String^ value);
}

Field Value

The network path of files or directories to add.

See Also

SymStore Class
MSBuild.Community.Tasks.SymbolServer Namespace


ID Property

[image]

.NET Framework Class Library
SymStore..::.ID Property
SymStore Class See Also Send Feedback

Gets or sets the transaction ID string.

Namespace: MSBuild.Community.Tasks.SymbolServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ID As String
C#
public string ID { get; set; }
Visual C++
public:
property String^ ID {
    String^ get ();
    void set (String^ value);
}

Field Value

The transaction ID string.

See Also

SymStore Class
MSBuild.Community.Tasks.SymbolServer Namespace


Local Property

[image]

.NET Framework Class Library
SymStore..::.Local Property
SymStore Class See Also Send Feedback

Gets or sets a value indicating whether the file will be in a local directory rather than a network path.

Namespace: MSBuild.Community.Tasks.SymbolServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Local As Boolean
C#
public bool Local { get; set; }
Visual C++
public:
property bool Local {
    bool get ();
    void set (bool value);
}

Field Value

true if local; otherwise, false.

See Also

SymStore Class
MSBuild.Community.Tasks.SymbolServer Namespace


LogFile Property

[image]

.NET Framework Class Library
SymStore..::.LogFile Property
SymStore Class See Also Send Feedback

Gets or sets a log file to be used for command output. If this is not included, transaction information and other output is sent to stdout.

Namespace: MSBuild.Community.Tasks.SymbolServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property LogFile As String
C#
public string LogFile { get; set; }
Visual C++
public:
property String^ LogFile {
    String^ get ();
    void set (String^ value);
}

Field Value

The log file to be used for command output.

See Also

SymStore Class
MSBuild.Community.Tasks.SymbolServer Namespace


Message Property

[image]

.NET Framework Class Library
SymStore..::.Message Property
SymStore Class See Also Send Feedback

Gets or sets the message to be added to each file.

Namespace: MSBuild.Community.Tasks.SymbolServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Message As String
C#
public string Message { get; set; }
Visual C++
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}

Field Value

The message to be added to each file.

See Also

SymStore Class
MSBuild.Community.Tasks.SymbolServer Namespace


NoReference Property

[image]

.NET Framework Class Library
SymStore..::.NoReference Property
SymStore Class See Also Send Feedback

Gets or sets a value indicating whether to omit the creation of reference pointer files for the files and pointers being stored.

Namespace: MSBuild.Community.Tasks.SymbolServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property NoReference As Boolean
C#
public bool NoReference { get; set; }
Visual C++
public:
property bool NoReference {
    bool get ();
    void set (bool value);
}

Field Value

true to omit the creation of reference pointer; otherwise, false.

See Also

SymStore Class
MSBuild.Community.Tasks.SymbolServer Namespace


Pointer Property

[image]

.NET Framework Class Library
SymStore..::.Pointer Property
SymStore Class See Also Send Feedback

Gets or sets a value indicating whether SymStore will store a pointer to the file, rather than the file itself.

Namespace: MSBuild.Community.Tasks.SymbolServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Pointer As Boolean
C#
public bool Pointer { get; set; }
Visual C++
public:
property bool Pointer {
    bool get ();
    void set (bool value);
}

Field Value

true if pointer; otherwise, false.

See Also

SymStore Class
MSBuild.Community.Tasks.SymbolServer Namespace


Product Property

[image]

.NET Framework Class Library
SymStore..::.Product Property
SymStore Class See Also Send Feedback

Gets or sets the name of the product.

Namespace: MSBuild.Community.Tasks.SymbolServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Product As String
C#
public string Product { get; set; }
Visual C++
public:
property String^ Product {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the product.

See Also

SymStore Class
MSBuild.Community.Tasks.SymbolServer Namespace


ReadIndex Property

[image]

.NET Framework Class Library
SymStore..::.ReadIndex Property
SymStore Class See Also Send Feedback

Gets or sets the index file. Causes SymStore to read the data from a file created with WriteIndexFile.

Namespace: MSBuild.Community.Tasks.SymbolServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ReadIndex As String
C#
public string ReadIndex { get; set; }
Visual C++
public:
property String^ ReadIndex {
    String^ get ();
    void set (String^ value);
}

Field Value

The read index file.

See Also

SymStore Class
MSBuild.Community.Tasks.SymbolServer Namespace


Recursive Property

[image]

.NET Framework Class Library
SymStore..::.Recursive Property
SymStore Class See Also Send Feedback

Gets or sets a value indicating whether SymStore will add files or directories recursively.

Namespace: MSBuild.Community.Tasks.SymbolServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Recursive As Boolean
C#
public bool Recursive { get; set; }
Visual C++
public:
property bool Recursive {
    bool get ();
    void set (bool value);
}

Field Value

true if recursive; otherwise, false.

See Also

SymStore Class
MSBuild.Community.Tasks.SymbolServer Namespace


Relative Property

[image]

.NET Framework Class Library
SymStore..::.Relative Property
SymStore Class See Also Send Feedback

Gets or sets a value indicating whether the paths in the file pointers will be relative.

Namespace: MSBuild.Community.Tasks.SymbolServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Relative As Boolean
C#
public bool Relative { get; set; }
Visual C++
public:
property bool Relative {
    bool get ();
    void set (bool value);
}

Field Value

true if relative; otherwise, false.

See Also

SymStore Class
MSBuild.Community.Tasks.SymbolServer Namespace


Share Property

[image]

.NET Framework Class Library
SymStore..::.Share Property
SymStore Class See Also Send Feedback

Gets or sets the server and share where the symbol files were originally stored.

Namespace: MSBuild.Community.Tasks.SymbolServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Share As String
C#
public string Share { get; set; }
Visual C++
public:
property String^ Share {
    String^ get ();
    void set (String^ value);
}

Field Value

The server and share where the symbol files were originally stored.

See Also

SymStore Class
MSBuild.Community.Tasks.SymbolServer Namespace


StandardOutputLoggingImportance Property

[image]

.NET Framework Class Library
SymStore..::.StandardOutputLoggingImportance Property
SymStore Class See Also Send Feedback

Gets the MessageImportance with which to log errors.

Namespace: MSBuild.Community.Tasks.SymbolServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property StandardOutputLoggingImportance As MessageImportance
C#
protected override MessageImportance StandardOutputLoggingImportance { get; }
Visual C++
protected:
virtual property MessageImportance StandardOutputLoggingImportance {
    MessageImportance get () override;
}

Field Value

Return Value

The MessageImportance with which to log errors.

See Also

SymStore Class
MSBuild.Community.Tasks.SymbolServer Namespace


Store Property

[image]

.NET Framework Class Library
SymStore..::.Store Property
SymStore Class See Also Send Feedback

Gets or sets the root directory for the symbol store.

Namespace: MSBuild.Community.Tasks.SymbolServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Store As String
C#
public string Store { get; set; }
Visual C++
public:
property String^ Store {
    String^ get ();
    void set (String^ value);
}

Field Value

The root directory for the symbol store.

See Also

SymStore Class
MSBuild.Community.Tasks.SymbolServer Namespace


ToolName Property

[image]

.NET Framework Class Library
SymStore..::.ToolName Property
SymStore Class See Also Send Feedback

Gets the name of the executable file to run.

Namespace: MSBuild.Community.Tasks.SymbolServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ToolName As String
C#
protected override string ToolName { get; }
Visual C++
protected:
virtual property String^ ToolName {
    String^ get () override;
}

Field Value

Return Value

The name of the executable file to run.

See Also

SymStore Class
MSBuild.Community.Tasks.SymbolServer Namespace


Verbose Property

[image]

.NET Framework Class Library
SymStore..::.Verbose Property
SymStore Class See Also Send Feedback

Gets or sets a value indicating whether SymStore will display verbose output.

Namespace: MSBuild.Community.Tasks.SymbolServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Verbose As Boolean
C#
public bool Verbose { get; set; }
Visual C++
public:
property bool Verbose {
    bool get ();
    void set (bool value);
}

Field Value

true if verbose; otherwise, false.

See Also

SymStore Class
MSBuild.Community.Tasks.SymbolServer Namespace


Version Property

[image]

.NET Framework Class Library
SymStore..::.Version Property
SymStore Class See Also Send Feedback

Gets or sets the version of the product.

Namespace: MSBuild.Community.Tasks.SymbolServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Version As String
C#
public string Version { get; set; }
Visual C++
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}

Field Value

The version of the product.

See Also

SymStore Class
MSBuild.Community.Tasks.SymbolServer Namespace


WriteIndex Property

[image]

.NET Framework Class Library
SymStore..::.WriteIndex Property
SymStore Class See Also Send Feedback

Gets or sets the index file. Causes SymStore not to store the actual symbol files. Instead, SymStore records information in the IndexFile that will enable SymStore to access the symbol files at a later time.

Namespace: MSBuild.Community.Tasks.SymbolServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property WriteIndex As String
C#
public string WriteIndex { get; set; }
Visual C++
public:
property String^ WriteIndex {
    String^ get ();
    void set (String^ value);
}

Field Value

The write index file.

See Also

SymStore Class
MSBuild.Community.Tasks.SymbolServer Namespace


SymStoreCommands Enumeration

[image]

.NET Framework Class Library
SymStoreCommands Enumeration
See Also Send Feedback

Commands for the SymStore tasks.

Namespace: MSBuild.Community.Tasks.SymbolServer
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration SymStoreCommands
C#
public enum SymStoreCommands
Visual C++
public enum class SymStoreCommands

Members

Member name | Description
add | Add to the symbol server store.
query | Query the symbol server store.
delete | Delete from the symbol serer store.

See Also

MSBuild.Community.Tasks.SymbolServer Namespace


MSBuild.Community.Tasks.Tfs Namespace

[image]

.NET Framework Class Library
MSBuild.Community.Tasks.Tfs Namespace
Send Feedback

Classes

Class | Description
TeamFoundationServerException | Exceptions returned by the Team Foundation Server
TfsVersion | Determines the changeset in a local Team Foundation Server workspace

Interfaces

Interface | Description
IServer | Describes the behavior of a Team Foundation Server


IServer Interface

[image]

.NET Framework Class Library
IServer Interface
Members See Also Send Feedback

Describes the behavior of a Team Foundation Server

Namespace: MSBuild.Community.Tasks.Tfs
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Interface IServer
C#
public interface IServer
Visual C++
public interface class IServer

See Also

IServer Members
MSBuild.Community.Tasks.Tfs Namespace


IServer Members

[image] [image]

.NET Framework Class Library
IServer Members
IServer Interface Methods See Also Send Feedback

The IServer type exposes the following members.

Methods

Name | Description
GetLatestChangesetId | Retrieves the latest changeset ID associated with a path

See Also

IServer Interface
MSBuild.Community.Tasks.Tfs Namespace


IServer Methods

[image] [image]

.NET Framework Class Library
IServer Methods
IServer Interface See Also Send Feedback

The IServer type exposes the following members.

Methods

Name | Description
GetLatestChangesetId | Retrieves the latest changeset ID associated with a path

See Also

IServer Interface
MSBuild.Community.Tasks.Tfs Namespace


GetLatestChangesetId Method

[image]

.NET Framework Class Library
IServer..::.GetLatestChangesetId Method
IServer Interface See Also Send Feedback

Retrieves the latest changeset ID associated with a path

Namespace: MSBuild.Community.Tasks.Tfs
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Function GetLatestChangesetId ( _
    localPath As String, _
    credentials As ICredentials _
) As Integer
C#
int GetLatestChangesetId(
    string localPath,
    ICredentials credentials
)
Visual C++
int GetLatestChangesetId(
    String^ localPath,
    ICredentials^ credentials
)

Parameters

localPath
Type: System..::.String
A path on the local filesystem
credentials
Type: System.Net..::.ICredentials
Credentials used to authenticate against the serer

Return Value

See Also

IServer Interface
MSBuild.Community.Tasks.Tfs Namespace


TeamFoundationServerException Class

[image]

.NET Framework Class Library
TeamFoundationServerException Class
Members See Also Send Feedback

Exceptions returned by the Team Foundation Server

Namespace: MSBuild.Community.Tasks.Tfs
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class TeamFoundationServerException _
    Inherits Exception
C#
public class TeamFoundationServerException : Exception
Visual C++
public ref class TeamFoundationServerException : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
MSBuild.Community.Tasks.Tfs..::.TeamFoundationServerException

See Also

TeamFoundationServerException Members
MSBuild.Community.Tasks.Tfs Namespace


TeamFoundationServerException Members

[image] [image]

.NET Framework Class Library
TeamFoundationServerException Members
TeamFoundationServerException Class Constructors Methods Properties See Also Send Feedback

The TeamFoundationServerException type exposes the following members.

Constructors

Name | Description
TeamFoundationServerException | Overloaded.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetBaseException | (Inherited from Exception.)
GetHashCode | (Inherited from Object.)
GetObjectData | (Inherited from Exception.)
GetType | (Inherited from Exception.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Exception.)

Properties

Name | Description
Data | (Inherited from Exception.)
HelpLink | (Inherited from Exception.)
HResult | (Inherited from Exception.)
InnerException | (Inherited from Exception.)
Message | (Inherited from Exception.)
Source | (Inherited from Exception.)
StackTrace | (Inherited from Exception.)
TargetSite | (Inherited from Exception.)

See Also

TeamFoundationServerException Class
MSBuild.Community.Tasks.Tfs Namespace


TeamFoundationServerException Constructor

[image] [image]

.NET Framework Class Library
TeamFoundationServerException Constructor
TeamFoundationServerException Class See Also Send Feedback

Overload List

Name | Description
TeamFoundationServerException()()() | Creates a new instance of the exception
TeamFoundationServerException(String) | Creates a new instance of the exception

See Also

TeamFoundationServerException Class
TeamFoundationServerException Members
MSBuild.Community.Tasks.Tfs Namespace


TeamFoundationServerException Constructor

[image]

.NET Framework Class Library
TeamFoundationServerException Constructor
TeamFoundationServerException Class See Also Send Feedback

Creates a new instance of the exception

Namespace: MSBuild.Community.Tasks.Tfs
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public TeamFoundationServerException()
Visual C++
public:
TeamFoundationServerException()

See Also

TeamFoundationServerException Class
TeamFoundationServerException Overload
MSBuild.Community.Tasks.Tfs Namespace


TeamFoundationServerException Constructor (String)

[image]

.NET Framework Class Library
TeamFoundationServerException Constructor (String)
TeamFoundationServerException Class See Also Send Feedback

Creates a new instance of the exception

Namespace: MSBuild.Community.Tasks.Tfs
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public TeamFoundationServerException(
    string message
)
Visual C++
public:
TeamFoundationServerException(
    String^ message
)

Parameters

message
Type: System..::.String
A description of the exception

See Also

TeamFoundationServerException Class
TeamFoundationServerException Overload
MSBuild.Community.Tasks.Tfs Namespace


TeamFoundationServerException Methods

[image] [image]

.NET Framework Class Library
TeamFoundationServerException Methods
TeamFoundationServerException Class See Also Send Feedback

The TeamFoundationServerException type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetBaseException | (Inherited from Exception.)
GetHashCode | (Inherited from Object.)
GetObjectData | (Inherited from Exception.)
GetType | (Inherited from Exception.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Exception.)

See Also

TeamFoundationServerException Class
MSBuild.Community.Tasks.Tfs Namespace


TeamFoundationServerException Properties

[image] [image]

.NET Framework Class Library
TeamFoundationServerException Properties
TeamFoundationServerException Class See Also Send Feedback

The TeamFoundationServerException type exposes the following members.

Properties

Name | Description
Data | (Inherited from Exception.)
HelpLink | (Inherited from Exception.)
HResult | (Inherited from Exception.)
InnerException | (Inherited from Exception.)
Message | (Inherited from Exception.)
Source | (Inherited from Exception.)
StackTrace | (Inherited from Exception.)
TargetSite | (Inherited from Exception.)

See Also

TeamFoundationServerException Class
MSBuild.Community.Tasks.Tfs Namespace


TfsVersion Class

[image]

.NET Framework Class Library
TfsVersion Class
Members See Also Send Feedback

Determines the changeset in a local Team Foundation Server workspace

Namespace: MSBuild.Community.Tasks.Tfs
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class TfsVersion _
    Inherits Task
C#
public class TfsVersion : Task
Visual C++
public ref class TfsVersion : public Task

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.Tfs..::.TfsVersion

See Also

TfsVersion Members
MSBuild.Community.Tasks.Tfs Namespace


TfsVersion Members

[image] [image]

.NET Framework Class Library
TfsVersion Members
TfsVersion Class Constructors Methods Properties See Also Send Feedback

The TfsVersion type exposes the following members.

Constructors

Name | Description
TfsVersion |

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | Runs the exectuable file with the specified task parameters. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Changeset | The latest changeset ID in the local path
Domain | The domain of the user to authenticate on the server
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
LocalPath | Path to local working copy.
Log | (Inherited from Task.)
Password | The password for the user to authenticate on the server
TaskResources | (Inherited from Task.)
TfsLibraryLocation | The location of the Team Foundation Server client assemblies. Leave empty when the client is installed in the Global Assembly Cache.
Username | The user to authenticate on the server

See Also

TfsVersion Class
MSBuild.Community.Tasks.Tfs Namespace


TfsVersion Constructor

[image]

.NET Framework Class Library
TfsVersion Constructor
TfsVersion Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Tfs
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public TfsVersion()
Visual C++
public:
TfsVersion()

See Also

TfsVersion Class
MSBuild.Community.Tasks.Tfs Namespace


TfsVersion Methods

[image] [image]

.NET Framework Class Library
TfsVersion Methods
TfsVersion Class See Also Send Feedback

The TfsVersion type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | Runs the exectuable file with the specified task parameters. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

TfsVersion Class
MSBuild.Community.Tasks.Tfs Namespace


Execute Method

[image]

.NET Framework Class Library
TfsVersion..::.Execute Method
TfsVersion Class See Also Send Feedback

Runs the exectuable file with the specified task parameters.

Namespace: MSBuild.Community.Tasks.Tfs
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

true if the task runs successfully; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

TfsVersion Class
MSBuild.Community.Tasks.Tfs Namespace


TfsVersion Properties

[image] [image]

.NET Framework Class Library
TfsVersion Properties
TfsVersion Class See Also Send Feedback

The TfsVersion type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
Changeset | The latest changeset ID in the local path
Domain | The domain of the user to authenticate on the server
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
LocalPath | Path to local working copy.
Log | (Inherited from Task.)
Password | The password for the user to authenticate on the server
TaskResources | (Inherited from Task.)
TfsLibraryLocation | The location of the Team Foundation Server client assemblies. Leave empty when the client is installed in the Global Assembly Cache.
Username | The user to authenticate on the server

See Also

TfsVersion Class
MSBuild.Community.Tasks.Tfs Namespace


Changeset Property

[image]

.NET Framework Class Library
TfsVersion..::.Changeset Property
TfsVersion Class See Also Send Feedback

The latest changeset ID in the local path

Namespace: MSBuild.Community.Tasks.Tfs
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property Changeset As Integer
C#
[OutputAttribute]
public int Changeset { get; }
Visual C++
[OutputAttribute]
public:
property int Changeset {
    int get ();
}

See Also

TfsVersion Class
MSBuild.Community.Tasks.Tfs Namespace


Domain Property

[image]

.NET Framework Class Library
TfsVersion..::.Domain Property
TfsVersion Class See Also Send Feedback

The domain of the user to authenticate on the server

Namespace: MSBuild.Community.Tasks.Tfs
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Domain As String
C#
public string Domain { get; set; }
Visual C++
public:
property String^ Domain {
    String^ get ();
    void set (String^ value);
}

Remarks

Leave empty to use the credentials of the current user.

See Also

TfsVersion Class
MSBuild.Community.Tasks.Tfs Namespace


LocalPath Property

[image]

.NET Framework Class Library
TfsVersion..::.LocalPath Property
TfsVersion Class See Also Send Feedback

Path to local working copy.

Namespace: MSBuild.Community.Tasks.Tfs
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property LocalPath As String
C#
[RequiredAttribute]
public string LocalPath { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ LocalPath {
    String^ get ();
    void set (String^ value);
}

See Also

TfsVersion Class
MSBuild.Community.Tasks.Tfs Namespace


Password Property

[image]

.NET Framework Class Library
TfsVersion..::.Password Property
TfsVersion Class See Also Send Feedback

The password for the user to authenticate on the server

Namespace: MSBuild.Community.Tasks.Tfs
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password { get; set; }
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

Remarks

Leave empty to use the credentials of the current user.

See Also

TfsVersion Class
MSBuild.Community.Tasks.Tfs Namespace


TfsLibraryLocation Property

[image]

.NET Framework Class Library
TfsVersion..::.TfsLibraryLocation Property
TfsVersion Class See Also Send Feedback

The location of the Team Foundation Server client assemblies. Leave empty when the client is installed in the Global Assembly Cache.

Namespace: MSBuild.Community.Tasks.Tfs
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property TfsLibraryLocation As String
C#
public string TfsLibraryLocation { get; set; }
Visual C++
public:
property String^ TfsLibraryLocation {
    String^ get ();
    void set (String^ value);
}

See Also

TfsVersion Class
MSBuild.Community.Tasks.Tfs Namespace


Username Property

[image]

.NET Framework Class Library
TfsVersion..::.Username Property
TfsVersion Class See Also Send Feedback

The user to authenticate on the server

Namespace: MSBuild.Community.Tasks.Tfs
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Username As String
C#
public string Username { get; set; }
Visual C++
public:
property String^ Username {
    String^ get ();
    void set (String^ value);
}

Remarks

Leave empty to use the credentials of the current user.

See Also

TfsVersion Class
MSBuild.Community.Tasks.Tfs Namespace


MSBuild.Community.Tasks.Xml Namespace

[image]

.NET Framework Class Library
MSBuild.Community.Tasks.Xml Namespace
Send Feedback

Classes

Class | Description
XmlMassUpdate | Performs multiple updates on an XML file
XmlNodeTaskItem | Represents a single XmlNode selected using an XML task.
XmlQuery | Reads a value or values from lines of XML
XmlTaskHelper | Provides methods used by all of the XML tasks


XmlMassUpdate Class

[image]

.NET Framework Class Library
XmlMassUpdate Class
Members Example See Also Send Feedback

Performs multiple updates on an XML file

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlMassUpdate _
    Inherits Task
C#
public class XmlMassUpdate : Task
Visual C++
public ref class XmlMassUpdate : public Task

Remarks

XmlMassUpdate allows to to specify multiple changes to make to an XML file (the ContentFile. By default, the changes are applied to the ContentFile, but you can create a new file by providing the MergedFile attribute. The change instructions are specified using XML in the SubstitutionsFile. If the SubstitutionsFile does not mirror the structure of the ContentFile exactly, you can specify the ContentRoot and SubstitutionsRoot XPath expressions which determine how the files should be mapped to each other.

Any element within the SubstitutionsRoot will find the corresponding element in the ContentRoot. If it does not exist, it will be created with all of its attributes. If it does exist, the attributes will be added or updated as specified.

Any attribute declared within the UpdateControlNamespace will not be copied to the modified file. Valid attributes are key and action. The key attribute allows you to define an attribute to use as the identifying attribute when you only want to update a single element, and multiple elements with the same name exist. You can also use the action="remove" attribute to specify that an element should be deleted instead of updated.

Examples

These examples will demonstrate how to make multiple updates to a XML file named web.config. It looks like:

Copy Code
          <?xml version="1.0" encoding="utf-8" ?>
<configuration>
    <appSettings>
        <add key="ItemsPerPage" value="10" />
        <add key="EnableCaching" value="true" />
        <add key="DefaultServer" value="TIGRIS" />
    </appSettings>
    <system.web>
        <compilation defaultLanguage="c#" debug="true" />
        <customErrors mode="Off" />
        <trace enabled="true" requestLimit="10" pageOutput="true" />
        <globalization requestEncoding="utf-8" responseEncoding="utf-8" />
    </system.web>
</configuration>

Examples

You can update the file using instructions from an external file (specified as the SubstitutionsFile):
Copy Code
        <XmlMassUpdate ContentFile="web.config" SubstitutionsFile="changes.xml" ContentRoot="/configuration/system.web" SubstitutionsRoot="/system.web" />
The SubstitutionsFile is named changes.xml and contains:
Copy Code
        <system.web>
        <compilation debug="false" />
        <customErrors mode="RemoteOnly" defaultRedirect="Error.htm">
          <error statusCode="401" redirect="AccessDenied.aspx" />
        </customErrors>
        <trace enabled="false" />
      </system.web>

Examples

You can also provide the update instructions within the MSBuild project file itself. It takes advantage of the MSBuild ProjectExtensions element which allows you to add XML to a project file that will be ignored by the MSBuild engine. This example also demonstrates how to use NamespaceDefinitions:
Copy Code
        <ProjectExtensions>
  <system.web>
    <compilation debug="false" />
    <trace enabled="false" />
  </system.web>
</ProjectExtensions>
<Target Name="SubstituteFromProj">
  <XmlMassUpdate ContentFile="web.config" ContentRoot="/configuration/system.web"
    NamespaceDefinitions="msb=http://schemas.microsoft.com/developer/msbuild/2003"
    SubstitutionsFile="$(MSBuildProjectFullPath)"
    SubstitutionsRoot="/msb:Project/msb:ProjectExtensions/msb:system.web" />
</Target>

Examples

The following example demonstrates how to deal with "keyed" elements. When you need to update an element, and multiple elements exist with the same name, it must be be differentied by one of its attributes. You designate the differentiating attribute using the "key" attribute declared in the UpdateControlNamespace. If an element matching the keyed attribute is not found, a new element will be created (DefaultSort in the example). This example also demonstrates creating a new file with the merged changes instead of modifying the original file.
Copy Code
         <XmlMassUpdate ContentFile="web.config" SubstitutionsFile="changes.xml" MergedFile="web.config.keyed.xml"  />
Using a changes.xml file with the following contents:
Copy Code
        <configuration xmlns:xmu="urn:msbuildcommunitytasks-xmlmassupdate">
  <appSettings>
        <add xmu:key="key" key="EnableCaching" value="false" />
        <add xmu:key="key" key="DefaultSort" value="LastName" />
  </appSettings>
</configuration>

Examples

Use a changes.xml file with the following contents to demonstrate how to remove an element from the updated file:
Copy Code
        <configuration xmlns:xmu="urn:msbuildcommunitytasks-xmlmassupdate">
  <appSettings>
        <add xmu:key="key" key="ItemsPerPage" xmu:action="remove" />
        <trace xmu:action="remove" />
  </appSettings>
</configuration>

Examples

You can also specify the changes to apply from within the target document. By making use of the SubstitutionsRoot property, you can store multiple sets of changes to apply based on runtime conditions. Consider the following source web.config file:
Copy Code
        <?xml version="1.0" encoding="utf-8" ?>
<configuration>
    <system.web>
        <compilation defaultLanguage="c#" debug="true" />
        <customErrors mode="Off" />
        <trace enabled="true" requestLimit="10" pageOutput="true" />
        <globalization requestEncoding="utf-8" responseEncoding="utf-8" />
    </system.web>
    <substitutions>
      <test>
        <system.web>
          <compilation debug="false" />
          <trace enabled="true" />
        </system.web>
      </test>
      <prod>
        <system.web>
          <compilation debug="false" />
          <trace enabled="false" />
        </system.web>
      </prod>
    </substitutions>
</configuration>
You could use the following task definition, which relies on a property "TargetEnvironment" to determine which set of changes to apply:
Copy Code
         <XmlMassUpdate ContentFile="web.config" ContentRoot="/configuration" SubstitutionsRoot="/configuration/substitutions/$(TargetEnvironment)" />
You will need to provide a value of "test" or "prod" to the TargetEnvironment property. The property can be defined in a PropertyGroup section of the MSBuild file, or passed as a command-line parameter.
Copy Code
         msbuild build.proj /p:TargetEnvironment=prod

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.Xml..::.XmlMassUpdate

See Also

XmlMassUpdate Members
MSBuild.Community.Tasks.Xml Namespace


XmlMassUpdate Members

[image] [image]

.NET Framework Class Library
XmlMassUpdate Members
XmlMassUpdate Class Constructors Methods Properties See Also Send Feedback

The XmlMassUpdate type exposes the following members.

Constructors

Name | Description
XmlMassUpdate |

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
LoadContentDocument | Returns ContentFile as an XmlDocument.
LoadSubstitutionsDocument | Returns SubstitutionsFile as an XmlDocument.
MemberwiseClone | (Inherited from Object.)
SaveMergedDocument | Creates MergedFile from the specified XmlDocument
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
ContentFile | The original file whose content is to be updated
ContentPathUsedByTask | The full path of the file containing content updated by the task
ContentRoot | The XPath expression identifying root node that substitions are relative to
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
MergedFile | The file created after performing the updates
MergedPathUsedByTask | The full path of the file containing the results of the task
NamespaceDefinitions | A collection of prefix=namespace definitions used to query the XML documents
SubstitutionsFile | The file containing the list of updates to perform
SubstitutionsPathUsedByTask | The full path of the file containing substitutions used by the task
SubstitutionsRoot | The XPath expression used to locate the list of substitutions to perform
TaskResources | (Inherited from Task.)
UpdateControlNamespace | The namespace used for XmlMassUpdate pre-defined attributes

See Also

XmlMassUpdate Class
MSBuild.Community.Tasks.Xml Namespace


XmlMassUpdate Constructor

[image]

.NET Framework Class Library
XmlMassUpdate Constructor
XmlMassUpdate Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public XmlMassUpdate()
Visual C++
public:
XmlMassUpdate()

See Also

XmlMassUpdate Class
MSBuild.Community.Tasks.Xml Namespace


XmlMassUpdate Methods

[image] [image]

.NET Framework Class Library
XmlMassUpdate Methods
XmlMassUpdate Class See Also Send Feedback

The XmlMassUpdate type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
LoadContentDocument | Returns ContentFile as an XmlDocument.
LoadSubstitutionsDocument | Returns SubstitutionsFile as an XmlDocument.
MemberwiseClone | (Inherited from Object.)
SaveMergedDocument | Creates MergedFile from the specified XmlDocument
ToString | (Inherited from Object.)

See Also

XmlMassUpdate Class
MSBuild.Community.Tasks.Xml Namespace


Execute Method

[image]

.NET Framework Class Library
XmlMassUpdate..::.Execute Method
XmlMassUpdate Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

True if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

XmlMassUpdate Class
MSBuild.Community.Tasks.Xml Namespace


LoadContentDocument Method

[image]

.NET Framework Class Library
XmlMassUpdate..::.LoadContentDocument Method
XmlMassUpdate Class See Also Send Feedback

Returns ContentFile as an XmlDocument.

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function LoadContentDocument As XmlDocument
C#
protected virtual XmlDocument LoadContentDocument()
Visual C++
protected:
virtual XmlDocument^ LoadContentDocument()

Return Value

Remarks

This method is not intended for use by consumers. It is exposed for testing purposes.

See Also

XmlMassUpdate Class
MSBuild.Community.Tasks.Xml Namespace


LoadSubstitutionsDocument Method

[image]

.NET Framework Class Library
XmlMassUpdate..::.LoadSubstitutionsDocument Method
XmlMassUpdate Class See Also Send Feedback

Returns SubstitutionsFile as an XmlDocument.

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function LoadSubstitutionsDocument As XmlDocument
C#
protected virtual XmlDocument LoadSubstitutionsDocument()
Visual C++
protected:
virtual XmlDocument^ LoadSubstitutionsDocument()

Return Value

Remarks

This method is not intended for use by consumers. It is exposed for testing purposes.

See Also

XmlMassUpdate Class
MSBuild.Community.Tasks.Xml Namespace


SaveMergedDocument Method

[image]

.NET Framework Class Library
XmlMassUpdate..::.SaveMergedDocument Method
XmlMassUpdate Class See Also Send Feedback

Creates MergedFile from the specified XmlDocument

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function SaveMergedDocument ( _
    mergedDocument As XmlDocument _
) As Boolean
C#
protected virtual bool SaveMergedDocument(
    XmlDocument mergedDocument
)
Visual C++
protected:
virtual bool SaveMergedDocument(
    XmlDocument^ mergedDocument
)

Parameters

mergedDocument
Type: System.Xml..::.XmlDocument
The XML to save to a file

Return Value

Remarks

This method is not intended for use by consumers. It is exposed for testing purposes.

See Also

XmlMassUpdate Class
MSBuild.Community.Tasks.Xml Namespace


XmlMassUpdate Properties

[image] [image]

.NET Framework Class Library
XmlMassUpdate Properties
XmlMassUpdate Class See Also Send Feedback

The XmlMassUpdate type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
ContentFile | The original file whose content is to be updated
ContentPathUsedByTask | The full path of the file containing content updated by the task
ContentRoot | The XPath expression identifying root node that substitions are relative to
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Log | (Inherited from Task.)
MergedFile | The file created after performing the updates
MergedPathUsedByTask | The full path of the file containing the results of the task
NamespaceDefinitions | A collection of prefix=namespace definitions used to query the XML documents
SubstitutionsFile | The file containing the list of updates to perform
SubstitutionsPathUsedByTask | The full path of the file containing substitutions used by the task
SubstitutionsRoot | The XPath expression used to locate the list of substitutions to perform
TaskResources | (Inherited from Task.)
UpdateControlNamespace | The namespace used for XmlMassUpdate pre-defined attributes

See Also

XmlMassUpdate Class
MSBuild.Community.Tasks.Xml Namespace


ContentFile Property

[image]

.NET Framework Class Library
XmlMassUpdate..::.ContentFile Property
XmlMassUpdate Class See Also Send Feedback

The original file whose content is to be updated

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property ContentFile As ITaskItem
C#
[RequiredAttribute]
public ITaskItem ContentFile { get; set; }
Visual C++
[RequiredAttribute]
public:
property ITaskItem^ ContentFile {
    ITaskItem^ get ();
    void set (ITaskItem^ value);
}

Remarks

This task is currently under construction and not necessarily feature complete.

See Also

XmlMassUpdate Class
MSBuild.Community.Tasks.Xml Namespace


ContentPathUsedByTask Property

[image]

.NET Framework Class Library
XmlMassUpdate..::.ContentPathUsedByTask Property
XmlMassUpdate Class See Also Send Feedback

The full path of the file containing content updated by the task

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property ContentPathUsedByTask As String
C#
[OutputAttribute]
public string ContentPathUsedByTask { get; }
Visual C++
[OutputAttribute]
public:
property String^ ContentPathUsedByTask {
    String^ get ();
}

See Also

XmlMassUpdate Class
MSBuild.Community.Tasks.Xml Namespace


ContentRoot Property

[image]

.NET Framework Class Library
XmlMassUpdate..::.ContentRoot Property
XmlMassUpdate Class See Also Send Feedback

The XPath expression identifying root node that substitions are relative to

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ContentRoot As String
C#
public string ContentRoot { get; set; }
Visual C++
public:
property String^ ContentRoot {
    String^ get ();
    void set (String^ value);
}

Remarks

When not specified, the default is the document root: /

See Also

XmlMassUpdate Class
MSBuild.Community.Tasks.Xml Namespace


MergedFile Property

[image]

.NET Framework Class Library
XmlMassUpdate..::.MergedFile Property
XmlMassUpdate Class See Also Send Feedback

The file created after performing the updates

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property MergedFile As ITaskItem
C#
public ITaskItem MergedFile { get; set; }
Visual C++
public:
property ITaskItem^ MergedFile {
    ITaskItem^ get ();
    void set (ITaskItem^ value);
}

See Also

XmlMassUpdate Class
MSBuild.Community.Tasks.Xml Namespace


MergedPathUsedByTask Property

[image]

.NET Framework Class Library
XmlMassUpdate..::.MergedPathUsedByTask Property
XmlMassUpdate Class See Also Send Feedback

The full path of the file containing the results of the task

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property MergedPathUsedByTask As String
C#
[OutputAttribute]
public string MergedPathUsedByTask { get; }
Visual C++
[OutputAttribute]
public:
property String^ MergedPathUsedByTask {
    String^ get ();
}

See Also

XmlMassUpdate Class
MSBuild.Community.Tasks.Xml Namespace


NamespaceDefinitions Property

[image]

.NET Framework Class Library
XmlMassUpdate..::.NamespaceDefinitions Property
XmlMassUpdate Class Example See Also Send Feedback

A collection of prefix=namespace definitions used to query the XML documents

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property NamespaceDefinitions As ITaskItem()
C#
public ITaskItem[] NamespaceDefinitions { get; set; }
Visual C++
public:
property array<ITaskItem^>^ NamespaceDefinitions {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

Examples

Defining multiple namespaces:
Copy Code

<XmlMassUpdate ContentFile="web.config"
  SubstitutionsRoot="/configuration/substitutions"
     NamespaceDefinitions = "soap=http://www.w3.org/2001/12/soap-envelope;x=http://www.w3.org/1999/XSL/Transform">
/>

See Also

XmlMassUpdate Class
MSBuild.Community.Tasks.Xml Namespace


SubstitutionsFile Property

[image]

.NET Framework Class Library
XmlMassUpdate..::.SubstitutionsFile Property
XmlMassUpdate Class See Also Send Feedback

The file containing the list of updates to perform

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property SubstitutionsFile As ITaskItem
C#
public ITaskItem SubstitutionsFile { get; set; }
Visual C++
public:
property ITaskItem^ SubstitutionsFile {
    ITaskItem^ get ();
    void set (ITaskItem^ value);
}

See Also

XmlMassUpdate Class
MSBuild.Community.Tasks.Xml Namespace


SubstitutionsPathUsedByTask Property

[image]

.NET Framework Class Library
XmlMassUpdate..::.SubstitutionsPathUsedByTask Property
XmlMassUpdate Class See Also Send Feedback

The full path of the file containing substitutions used by the task

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property SubstitutionsPathUsedByTask As String
C#
[OutputAttribute]
public string SubstitutionsPathUsedByTask { get; }
Visual C++
[OutputAttribute]
public:
property String^ SubstitutionsPathUsedByTask {
    String^ get ();
}

See Also

XmlMassUpdate Class
MSBuild.Community.Tasks.Xml Namespace


SubstitutionsRoot Property

[image]

.NET Framework Class Library
XmlMassUpdate..::.SubstitutionsRoot Property
XmlMassUpdate Class See Also Send Feedback

The XPath expression used to locate the list of substitutions to perform

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property SubstitutionsRoot As String
C#
public string SubstitutionsRoot { get; set; }
Visual C++
public:
property String^ SubstitutionsRoot {
    String^ get ();
    void set (String^ value);
}

Remarks

When not specified, the default is the document root: /

When there is a set of elements with the same name, and you want to update a single element which can be identified by one of its attributes, you need to include an attribute named 'key' in the namespace urn:msbuildcommunitytasks-xmlmassupdate. The value of the attribute is the name of the attribute that should be used as the unique identifier.

See Also

XmlMassUpdate Class
MSBuild.Community.Tasks.Xml Namespace


UpdateControlNamespace Property

[image]

.NET Framework Class Library
XmlMassUpdate..::.UpdateControlNamespace Property
XmlMassUpdate Class See Also Send Feedback

The namespace used for XmlMassUpdate pre-defined attributes

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UpdateControlNamespace As String
C#
public string UpdateControlNamespace { get; }
Visual C++
public:
property String^ UpdateControlNamespace {
    String^ get ();
}

Remarks

Evaluates to: urn:msbuildcommunitytasks-xmlmassupdate

Attributes decorated with this namespace are used to control how a substitutions element or attribute is handled during the update. For example, the key attribute is used to identify the attribute on an element that uniquely identifies the element in a set.

See Also

XmlMassUpdate Class
MSBuild.Community.Tasks.Xml Namespace


XmlNodeTaskItem Class

[image]

.NET Framework Class Library
XmlNodeTaskItem Class
Members See Also Send Feedback

Represents a single XmlNode selected using an XML task.

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlNodeTaskItem _
    Implements ITaskItem
C#
public class XmlNodeTaskItem : ITaskItem
Visual C++
public ref class XmlNodeTaskItem : ITaskItem

Inheritance Hierarchy

System..::.Object
MSBuild.Community.Tasks.Xml..::.XmlNodeTaskItem

See Also

XmlNodeTaskItem Members
MSBuild.Community.Tasks.Xml Namespace


XmlNodeTaskItem Members

[image] [image]

.NET Framework Class Library
XmlNodeTaskItem Members
XmlNodeTaskItem Class Constructors Methods Properties See Also Send Feedback

The XmlNodeTaskItem type exposes the following members.

Constructors

Name | Description
XmlNodeTaskItem | Initializes a new instance of an XmlNodeTaskItem

Methods

Name | Description
CloneCustomMetadata |
CopyMetadataTo |
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetMetadata |
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
RemoveMetadata |
SetMetadata |
ToString | Returns a string representation of the XmlNodeTaskItem. (Overrides Object..::.ToString()()().)

Operators

Name | Description
Explicit | Returns the ItemSpec when the XmlNodeTaskItem is explicitly cast as a String

Properties

Name | Description
ItemSpec |
MetadataCount |
MetadataNames |

See Also

XmlNodeTaskItem Class
MSBuild.Community.Tasks.Xml Namespace


XmlNodeTaskItem Constructor

[image]

.NET Framework Class Library
XmlNodeTaskItem Constructor
XmlNodeTaskItem Class See Also Send Feedback

Initializes a new instance of an XmlNodeTaskItem

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    xpathNavigator As XPathNavigator, _
    reservedMetaDataPrefix As String _
)
C#
public XmlNodeTaskItem(
    XPathNavigator xpathNavigator,
    string reservedMetaDataPrefix
)
Visual C++
public:
XmlNodeTaskItem(
    XPathNavigator^ xpathNavigator,
    String^ reservedMetaDataPrefix
)

Parameters

xpathNavigator
Type: System.Xml.XPath..::.XPathNavigator
The selected XmlNode
reservedMetaDataPrefix
Type: System..::.String
The prefix to attach to the reserved metadata properties.

See Also

XmlNodeTaskItem Class
MSBuild.Community.Tasks.Xml Namespace


XmlNodeTaskItem Methods

[image] [image]

.NET Framework Class Library
XmlNodeTaskItem Methods
XmlNodeTaskItem Class See Also Send Feedback

The XmlNodeTaskItem type exposes the following members.

Methods

Name | Description
CloneCustomMetadata |
CopyMetadataTo |
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetMetadata |
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
RemoveMetadata |
SetMetadata |
ToString | Returns a string representation of the XmlNodeTaskItem. (Overrides Object..::.ToString()()().)

Operators

Name | Description
Explicit | Returns the ItemSpec when the XmlNodeTaskItem is explicitly cast as a String

See Also

XmlNodeTaskItem Class
MSBuild.Community.Tasks.Xml Namespace


CloneCustomMetadata Method

[image]

.NET Framework Class Library
XmlNodeTaskItem..::.CloneCustomMetadata Method
XmlNodeTaskItem Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Function CloneCustomMetadata As IDictionary
C#
public IDictionary CloneCustomMetadata()
Visual C++
public:
virtual IDictionary^ CloneCustomMetadata() sealed

Return Value

Implements

ITaskItem..::.CloneCustomMetadata()()()

See Also

XmlNodeTaskItem Class
MSBuild.Community.Tasks.Xml Namespace


CopyMetadataTo Method

[image]

.NET Framework Class Library
XmlNodeTaskItem..::.CopyMetadataTo Method
XmlNodeTaskItem Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub CopyMetadataTo ( _
    destinationItem As ITaskItem _
)
C#
public void CopyMetadataTo(
    ITaskItem destinationItem
)
Visual C++
public:
virtual void CopyMetadataTo(
    ITaskItem^ destinationItem
) sealed

Parameters

destinationItem
Type: Microsoft.Build.Framework..::.ITaskItem

Implements

ITaskItem..::.CopyMetadataTo(ITaskItem)

See Also

XmlNodeTaskItem Class
MSBuild.Community.Tasks.Xml Namespace


Explicit Operator

[image]

.NET Framework Class Library
XmlNodeTaskItem..::.Explicit Operator
XmlNodeTaskItem Class See Also Send Feedback

Returns the ItemSpec when the XmlNodeTaskItem is explicitly cast as a String

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    taskItemToCast As XmlNodeTaskItem _
) As String
C#
public static explicit operator string (
    XmlNodeTaskItem taskItemToCast
)
Visual C++
static explicit operator String^ (
    XmlNodeTaskItem^ taskItemToCast
)

Parameters

taskItemToCast
Type: MSBuild.Community.Tasks.Xml..::.XmlNodeTaskItem
The XmlNodeTaskItem

Return Value

See Also

XmlNodeTaskItem Class
MSBuild.Community.Tasks.Xml Namespace


GetMetadata Method

[image]

.NET Framework Class Library
XmlNodeTaskItem..::.GetMetadata Method
XmlNodeTaskItem Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Function GetMetadata ( _
    metadataName As String _
) As String
C#
public string GetMetadata(
    string metadataName
)
Visual C++
public:
virtual String^ GetMetadata(
    String^ metadataName
) sealed

Parameters

metadataName
Type: System..::.String

Return Value

Implements

ITaskItem..::.GetMetadata(String)

See Also

XmlNodeTaskItem Class
MSBuild.Community.Tasks.Xml Namespace


RemoveMetadata Method

[image]

.NET Framework Class Library
XmlNodeTaskItem..::.RemoveMetadata Method
XmlNodeTaskItem Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub RemoveMetadata ( _
    metadataName As String _
)
C#
public void RemoveMetadata(
    string metadataName
)
Visual C++
public:
virtual void RemoveMetadata(
    String^ metadataName
) sealed

Parameters

metadataName
Type: System..::.String

Implements

ITaskItem..::.RemoveMetadata(String)

See Also

XmlNodeTaskItem Class
MSBuild.Community.Tasks.Xml Namespace


SetMetadata Method

[image]

.NET Framework Class Library
XmlNodeTaskItem..::.SetMetadata Method
XmlNodeTaskItem Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetMetadata ( _
    metadataName As String, _
    metadataValue As String _
)
C#
public void SetMetadata(
    string metadataName,
    string metadataValue
)
Visual C++
public:
virtual void SetMetadata(
    String^ metadataName,
    String^ metadataValue
) sealed

Parameters

metadataName
Type: System..::.String
metadataValue
Type: System..::.String

Implements

ITaskItem..::.SetMetadata(String, String)

See Also

XmlNodeTaskItem Class
MSBuild.Community.Tasks.Xml Namespace


ToString Method

[image]

.NET Framework Class Library
XmlNodeTaskItem..::.ToString Method
XmlNodeTaskItem Class See Also Send Feedback

Returns a string representation of the XmlNodeTaskItem.

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override

Return Value

See Also

XmlNodeTaskItem Class
MSBuild.Community.Tasks.Xml Namespace


XmlNodeTaskItem Properties

[image] [image]

.NET Framework Class Library
XmlNodeTaskItem Properties
XmlNodeTaskItem Class See Also Send Feedback

The XmlNodeTaskItem type exposes the following members.

Properties

Name | Description
ItemSpec |
MetadataCount |
MetadataNames |

See Also

XmlNodeTaskItem Class
MSBuild.Community.Tasks.Xml Namespace


ItemSpec Property

[image]

.NET Framework Class Library
XmlNodeTaskItem..::.ItemSpec Property
XmlNodeTaskItem Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ItemSpec As String
C#
public string ItemSpec { get; set; }
Visual C++
public:
virtual property String^ ItemSpec {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ITaskItem..::.ItemSpec

See Also

XmlNodeTaskItem Class
MSBuild.Community.Tasks.Xml Namespace


MetadataCount Property

[image]

.NET Framework Class Library
XmlNodeTaskItem..::.MetadataCount Property
XmlNodeTaskItem Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MetadataCount As Integer
C#
public int MetadataCount { get; }
Visual C++
public:
virtual property int MetadataCount {
    int get () sealed;
}

Implements

ITaskItem..::.MetadataCount

See Also

XmlNodeTaskItem Class
MSBuild.Community.Tasks.Xml Namespace


MetadataNames Property

[image]

.NET Framework Class Library
XmlNodeTaskItem..::.MetadataNames Property
XmlNodeTaskItem Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MetadataNames As ICollection
C#
public ICollection MetadataNames { get; }
Visual C++
public:
virtual property ICollection^ MetadataNames {
    ICollection^ get () sealed;
}

Implements

ITaskItem..::.MetadataNames

See Also

XmlNodeTaskItem Class
MSBuild.Community.Tasks.Xml Namespace


XmlQuery Class

[image]

.NET Framework Class Library
XmlQuery Class
Members Example See Also Send Feedback

Reads a value or values from lines of XML

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlQuery _
    Inherits Task
C#
public class XmlQuery : Task
Visual C++
public ref class XmlQuery : public Task

Remarks

Use the Lines property (possibly populated from the the ReadLinesFromFile task) if you want to perform multiple queries against some XML in memory. Use the XmlFileName property to query a large XML file.

An XPath expression can return multiple nodes in the Values collection. The number of nodes returned is availabe in the ValuesCount output TaskParameter.

When the XPath expression resolves to an element node, all of the attributes of the element are added as metadata to the returned ITaskItem. In addition, some reserved metadata properties are available on all element nodes. They are all prefixed with the ReservedMetaDataPrefix, which is a single underscore (_) by default.

Reserved Property
_value | The value of the node (non-xml text between the opening and closing tags).
_innerXml | The markup representing the children of this node.
_outerXml | The markup representing this node and all its child nodes.

Examples

Read an attribute value by selecting it with an XPath expression:
Copy Code

<ReadLinesFromFile File="web.config">
    <Output TaskParameter="Lines" ItemName="FileContents" />
</ReadLinesFromFile>

<XmlQuery Lines="@(FileContents)"
    XPath = "/configuration/system.web/compilation/@defaultLanguage">
    <Output TaskParameter="Values" PropertyName="CompilationLanguage" />
</XmlQuery>

<Message Text="The default language is $(CompilationLanguage)." />

Examples

Read attribute values (from an XML file) using item metadata on a selected element node:
Copy Code

<XmlQuery XmlFileName="$(MSBuildProjectDirectory)\web.config"
    XPath = "/configuration/system.web/compilation">
    <Output TaskParameter="Values" ItemName="CompilationElement" />
</XmlQuery>

<Message Text="The default language is: $(CompilationElement.defaultLanguage)." />
<Message Text="Debug is enabled: $(CompilationElement.debug)." />

Examples

Read an element value (requires use of the reserved metadata property "_value"):
Copy Code

<ReadLinesFromFile File="web.config">
    <Output TaskParameter="Lines" ItemName="FileContents" />
</ReadLinesFromFile>

<XmlQuery Lines="@(FileContents)"
    XPath = "/configuration/singleValue/LastName">
    <Output TaskParameter="Values" PropertyName="LastNameElement" />
</XmlQuery>

<Message Text="The last name is %(LastNameElement._value)" />

Inheritance Hierarchy

System..::.Object
Microsoft.Build.Utilities..::.Task
MSBuild.Community.Tasks.Xml..::.XmlQuery

See Also

XmlQuery Members
MSBuild.Community.Tasks.Xml Namespace


XmlQuery Members

[image] [image]

.NET Framework Class Library
XmlQuery Members
XmlQuery Class Constructors Methods Properties See Also Send Feedback

The XmlQuery type exposes the following members.

Constructors

Name | Description
XmlQuery |

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Lines | The lines of a valid XML document
Log | (Inherited from Task.)
NamespaceDefinitions | A collection of prefix=namespace definitions used to query the XML document
ReservedMetaDataPrefix | The string that is prepended to all reserved metadata properties.
TaskResources | (Inherited from Task.)
Values | The values selected by XPath
ValuesCount | The number of values returned in Values
XmlFileName | Gets or sets the name of an XML file to query
XPath | The query used to identify the values in the XML document

See Also

XmlQuery Class
MSBuild.Community.Tasks.Xml Namespace


XmlQuery Constructor

[image]

.NET Framework Class Library
XmlQuery Constructor
XmlQuery Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public XmlQuery()
Visual C++
public:
XmlQuery()

See Also

XmlQuery Class
MSBuild.Community.Tasks.Xml Namespace


XmlQuery Methods

[image] [image]

.NET Framework Class Library
XmlQuery Methods
XmlQuery Class See Also Send Feedback

The XmlQuery type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Execute | When overridden in a derived class, executes the task. (Overrides Task..::.Execute()()().)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

XmlQuery Class
MSBuild.Community.Tasks.Xml Namespace


Execute Method

[image]

.NET Framework Class Library
XmlQuery..::.Execute Method
XmlQuery Class See Also Send Feedback

When overridden in a derived class, executes the task.

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Execute As Boolean
C#
public override bool Execute()
Visual C++
public:
virtual bool Execute() override

Return Value

True if the task successfully executed; otherwise, false.

Implements

ITask..::.Execute()()()

See Also

XmlQuery Class
MSBuild.Community.Tasks.Xml Namespace


XmlQuery Properties

[image] [image]

.NET Framework Class Library
XmlQuery Properties
XmlQuery Class See Also Send Feedback

The XmlQuery type exposes the following members.

Properties

Name | Description
BuildEngine | (Inherited from Task.)
HelpKeywordPrefix | (Inherited from Task.)
HostObject | (Inherited from Task.)
Lines | The lines of a valid XML document
Log | (Inherited from Task.)
NamespaceDefinitions | A collection of prefix=namespace definitions used to query the XML document
ReservedMetaDataPrefix | The string that is prepended to all reserved metadata properties.
TaskResources | (Inherited from Task.)
Values | The values selected by XPath
ValuesCount | The number of values returned in Values
XmlFileName | Gets or sets the name of an XML file to query
XPath | The query used to identify the values in the XML document

See Also

XmlQuery Class
MSBuild.Community.Tasks.Xml Namespace


Lines Property

[image]

.NET Framework Class Library
XmlQuery..::.Lines Property
XmlQuery Class See Also Send Feedback

The lines of a valid XML document

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property Lines As ITaskItem()
C#
public ITaskItem[] Lines { get; set; }
Visual C++
public:
property array<ITaskItem^>^ Lines {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

See Also

XmlQuery Class
MSBuild.Community.Tasks.Xml Namespace


NamespaceDefinitions Property

[image]

.NET Framework Class Library
XmlQuery..::.NamespaceDefinitions Property
XmlQuery Class Example See Also Send Feedback

A collection of prefix=namespace definitions used to query the XML document

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property NamespaceDefinitions As ITaskItem()
C#
public ITaskItem[] NamespaceDefinitions { get; set; }
Visual C++
public:
property array<ITaskItem^>^ NamespaceDefinitions {
    array<ITaskItem^>^ get ();
    void set (array<ITaskItem^>^ value);
}

Examples

Defining multiple namespaces:
Copy Code

<XmlMassUpdate ContentFile="web.config"
  SubstitutionsRoot="/configuration/substitutions"
     NamespaceDefinitions = "soap=http://www.w3.org/2001/12/soap-envelope;x=http://www.w3.org/1999/XSL/Transform">
/>

See Also

XmlQuery Class
MSBuild.Community.Tasks.Xml Namespace


ReservedMetaDataPrefix Property

[image]

.NET Framework Class Library
XmlQuery..::.ReservedMetaDataPrefix Property
XmlQuery Class See Also Send Feedback

The string that is prepended to all reserved metadata properties.

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property ReservedMetaDataPrefix As String
C#
public string ReservedMetaDataPrefix { get; set; }
Visual C++
public:
property String^ ReservedMetaDataPrefix {
    String^ get ();
    void set (String^ value);
}

Remarks

The default value is a single underscore: '_'

All attributes of an element node are added as metadata to the returned ITaskItem, so this property can be used to avoid clashes with the reserved properties. For example, if you selected the following node:

Copy Code
 <SomeNode _name="x" _value="y" />
the _value attribute would clash with the value reserved property, when using the default prefix. If you set the ReservedMetaDataPrefix to another value (two underscores '__') there would be no clash. You would be able to select the attribute using %(item._value) and the value of the node using %(item.__value).

See Also

XmlQuery Class
MSBuild.Community.Tasks.Xml Namespace


Values Property

[image]

.NET Framework Class Library
XmlQuery..::.Values Property
XmlQuery Class See Also Send Feedback

The values selected by XPath

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property Values As ITaskItem()
C#
[OutputAttribute]
public ITaskItem[] Values { get; }
Visual C++
[OutputAttribute]
public:
property array<ITaskItem^>^ Values {
    array<ITaskItem^>^ get ();
}

See Also

XmlQuery Class
MSBuild.Community.Tasks.Xml Namespace


ValuesCount Property

[image]

.NET Framework Class Library
XmlQuery..::.ValuesCount Property
XmlQuery Class See Also Send Feedback

The number of values returned in Values

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<OutputAttribute> _
Public ReadOnly Property ValuesCount As Integer
C#
[OutputAttribute]
public int ValuesCount { get; }
Visual C++
[OutputAttribute]
public:
property int ValuesCount {
    int get ();
}

See Also

XmlQuery Class
MSBuild.Community.Tasks.Xml Namespace


XmlFileName Property

[image]

.NET Framework Class Library
XmlQuery..::.XmlFileName Property
XmlQuery Class See Also Send Feedback

Gets or sets the name of an XML file to query

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Property XmlFileName As String
C#
public string XmlFileName { get; set; }
Visual C++
public:
property String^ XmlFileName {
    String^ get ();
    void set (String^ value);
}

Field Value

The full path of the XML file.

See Also

XmlQuery Class
MSBuild.Community.Tasks.Xml Namespace


XPath Property

[image]

.NET Framework Class Library
XmlQuery..::.XPath Property
XmlQuery Class See Also Send Feedback

The query used to identify the values in the XML document

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
<RequiredAttribute> _
Public Property XPath As String
C#
[RequiredAttribute]
public string XPath { get; set; }
Visual C++
[RequiredAttribute]
public:
property String^ XPath {
    String^ get ();
    void set (String^ value);
}

See Also

XmlQuery Class
MSBuild.Community.Tasks.Xml Namespace


XmlTaskHelper Class

[image]

.NET Framework Class Library
XmlTaskHelper Class
Members See Also Send Feedback

Provides methods used by all of the XML tasks

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlTaskHelper
C#
public class XmlTaskHelper
Visual C++
public ref class XmlTaskHelper

Inheritance Hierarchy

System..::.Object
MSBuild.Community.Tasks.Xml..::.XmlTaskHelper

See Also

XmlTaskHelper Members
MSBuild.Community.Tasks.Xml Namespace


XmlTaskHelper Members

[image] [image]

.NET Framework Class Library
XmlTaskHelper Members
XmlTaskHelper Class Constructors Methods See Also Send Feedback

The XmlTaskHelper type exposes the following members.

Constructors

Name | Description
XmlTaskHelper |

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
JoinItems | Concatenates the string value of a list of ITaskItems into a single string
LoadNamespaceDefinitionItems | Uses the prefix=namespace definitions in definitions to populate namespaceManager
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

XmlTaskHelper Class
MSBuild.Community.Tasks.Xml Namespace


XmlTaskHelper Constructor

[image]

.NET Framework Class Library
XmlTaskHelper Constructor
XmlTaskHelper Class See Also Send Feedback

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public XmlTaskHelper()
Visual C++
public:
XmlTaskHelper()

See Also

XmlTaskHelper Class
MSBuild.Community.Tasks.Xml Namespace


XmlTaskHelper Methods

[image] [image]

.NET Framework Class Library
XmlTaskHelper Methods
XmlTaskHelper Class See Also Send Feedback

The XmlTaskHelper type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
JoinItems | Concatenates the string value of a list of ITaskItems into a single string
LoadNamespaceDefinitionItems | Uses the prefix=namespace definitions in definitions to populate namespaceManager
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

XmlTaskHelper Class
MSBuild.Community.Tasks.Xml Namespace


JoinItems Method

[image]

.NET Framework Class Library
XmlTaskHelper..::.JoinItems Method
XmlTaskHelper Class See Also Send Feedback

Concatenates the string value of a list of ITaskItems into a single string

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function JoinItems ( _
    items As ITaskItem() _
) As String
C#
public static string JoinItems(
    ITaskItem[] items
)
Visual C++
public:
static String^ JoinItems(
    array<ITaskItem^>^ items
)

Parameters

items
Type: array< Microsoft.Build.Framework..::.ITaskItem >[]()[]
The items to concatenate

Return Value

A single string containing the values from all of the items

See Also

XmlTaskHelper Class
MSBuild.Community.Tasks.Xml Namespace


LoadNamespaceDefinitionItems Method

[image]

.NET Framework Class Library
XmlTaskHelper..::.LoadNamespaceDefinitionItems Method
XmlTaskHelper Class See Also Send Feedback

Uses the prefix=namespace definitions in definitions to populate namespaceManager

Namespace: MSBuild.Community.Tasks.Xml
Assembly: MSBuild.Community.Tasks (in MSBuild.Community.Tasks.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LoadNamespaceDefinitionItems ( _
    namespaceManager As XmlNamespaceManager, _
    definitions As ITaskItem() _
)
C#
public static void LoadNamespaceDefinitionItems(
    XmlNamespaceManager namespaceManager,
    ITaskItem[] definitions
)
Visual C++
public:
static void LoadNamespaceDefinitionItems(
    XmlNamespaceManager^ namespaceManager,
    array<ITaskItem^>^ definitions
)

Parameters

namespaceManager
Type: System.Xml..::.XmlNamespaceManager
The XmlNamespaceManager to populate.
definitions
Type: array< Microsoft.Build.Framework..::.ITaskItem >[]()[]
The prefix=namespace definitions.

See Also

XmlTaskHelper Class
MSBuild.Community.Tasks.Xml Namespace